Subject: RE: [Sigtran] RE: M3UA IG: section 3.15 reworked

From: "Javier Pastor-Balbas (ECE)" <[email-masked]>
Date: Wed, 18 Jun 2003 16:09:52 +0200

Brian, 

Using n=1 it will work as you desire...

Cheers // Javier.

> -----Original Message-----
> From: Brian F. G. Bidulock [mailto:[email-masked]]
> Sent: miércoles, 18 de junio de 2003 12:38
> To: Javier Pastor-Balbas (ECE)
> Cc: [email-masked]'; Ken Morneault (E-mail); Antonio Cañete (ECE)
> Subject: Re: [Sigtran] RE: M3UA IG: section 3.15 reworked
> 
> 
> Javier,
> 
> Please see comments below...
> 
> Javier Pastor-Balbas (ECE) wrote:                             
>                       (Tue, 17 Jun 2003 16:51:16)
> > --------- 
> > New text: (Section 4.3.2) 
> > ---------
> > 
> > AS-DOWN: The Application Server is unavailable.  This state 
> implies that the
> > number of ASPs being in ASP-INACTIVE or ASP-ACTIVE is less than "n".
> > Initially the AS will be in this state. An Application 
> Server is in the
> > AS-DOWN state when it is removed from a configuration.
> > 
> > AS-INACTIVE: The Application Server is available but no 
> application traffic
> > is active. This implies that there are at least n ASPs in either
> > ASP-INACTIVE or ASP-ACTIVE but the total number of ASPs in 
> ASP-ACTIVE state
> > has not reach n.  The recovery timer T(r) is not running or 
> has expired. 
> > 
> > AS-ACTIVE: The Application Server is available and 
> application traffic is
> > active. The AS moves to this state after being in 
> AS-INACTIVE and getting n
> > ASPs in ASP-ACTIVE state or, after reaching AS-ACTIVE and 
> keeping one or
> > more ASPs in ASP-ACTIVE state. 
> 
> I strongly disagree with the above.  The SG can move to the 
> AS-ACTIVE state
> with one ASP in the ASP-ACTIVE state: it need not wait until 
> 'n'.  You are
> still interpreting 'n' as some sort of absolute minimum 
> number of ASPs,
> when it was agreed that 'n' is the number of ASPs required to 
> handle the
> maximum engineered load.  As such, there is no reason why the 
> SG cannot
> place the AS AS-ACTIVE when one ASP is in the ASP-ACTIVE 
> state for the AS.
> 
> The Old text is correct.  The above is incorrect.
> 
> > 
> > AS-PENDING: The last active ASP has transitioned from ASP-ACTIVE to
> > ASP-INACTIVE or ASP-DOWN.  A recovery timer T(r) SHOULD be 
> started and all
> > incoming signalling messages SHOULD be queued by the SGP. 
> If an ASP becomes
> > ASP-ACTIVE before T(r) expires, the AS is moved to the 
> AS-ACTIVE state and
> > all the queued messages will be sent to the ASP. 
> > 
> > If T(r) expires before an ASP becomes ASP-ACTIVE, the SGP 
> MAY stops queuing
> > messages and discards all previously queued messages. The 
> AS will move to
> > the AS-INACTIVE state if at least the number of ASPs in 
> ASP-INACTIVE sum n,
> > otherwise it will move to AS-DOWN state. 
> > 
> > Figure 5 shows an example AS state machine for the case where the 
> > AS/ASP data is preconfigured and an n+k redundancy model. 
> > 
> > 
> >              Figure 5: AS State Transition Diagram
> > 
> >                    
> >      +----------+          IA2AC              +-------------+
> >      |    AS-   |---------------------------->|     AS-     |
> >      | INACTIVE |                             |   ACTIVE    |
> >      |          |<-----------                 |             |
> >      +----------+            \                +-------------+
> >         ^   |                 \                    ^   |
> >         |   | IA2DN            \ PN2IA             |   | AC2PN
> >         |   |                   \                  |   | 
> >   DN2IA |   |                    \          PN2AC  |   | 
> >         |   v                     \                |   v
> >      +----------+                  \          +-------------+
> >      |          |                   ----------|             |
> >      | AS-DOWN  |                             | AS-PENDING  |
> >      |          |                  PN2DN      |  (queueing) |
> >      |          |<----------------------------|             |
> >      +----------+                             +-------------+
> > 
> > 
> > 
> > DN2IA: One ASP moves to ASP-INACTIVE causing that n ASPs 
> are in either
> > ASP-ACTIVE or ASP-INACTIVE states.
> > 
> > IA2DN: One ASP moves to ASP-DOWN causing that the number of 
> ASPs in either
> > ASP-ACTIVE or ASP-INACTIVE drops below n.
> 
> Wrong, as per above.  If one ASP is in the ASP-ACTIVE state 
> for the AS,
> the AS is AS-ACTIVE.
> 
> > 
> > IA2AC: one ASP moves to ASP-ACTIVE, causing number of ASPs 
> in the ASP-ACTIVE
> > state to be n.
> 
> Wrong, as per above.  If one ASP moves to the ASP-ACTIVE 
> state for the AS,
> the AS is AS-ACTIVE.
> 
> > 
> > AC2PN: the last ASP in ASP-ACTIVE state moves to 
> ASP-INACTIVE or ASP-DOWN
> > states, causing the number of ASPs in ASP-ACTIVE drop below 1.
> > 
> > PN2AC: One ASP moves to ASP-ACTIVE.
> > 
> > PN2IA: T(r) Expiry, n or more ASPs are in ASP-INACTIVE.
> > 
> > PN2DN: T(r) Expiry, the number of ASPs in ASP-INACTIVE 
> state is less than n.
> > 
> > As "n" ASPs are needed to handle the maximum engineered 
> load of the AS, an
> > AS becomes AS-ACTIVE right after n ASPs reach the 
> ASP-ACTIVE state during
> > the start-up phase.
> 
> The above is incorrect per concensus.  For the start-up 
> decision, the SG
> can choose to either wait for 'n' or start traffic on the 
> first active ASP.
> What it MUST do not send NTFY(AS-ACTIVE) until it considers 
> the AS in the
> AS-ACTIVE state.
> 
> > Once the traffic is flowing, an AS keeps the AS-ACTIVE
> > state till the last ASP turns to another state different to 
> ASP-ACTIVE,
> > avoiding unnecessary traffic disturbances as long as there are ASPs
> > available, in the assumption that the AS will not always be 
> exposed to the
> > maximum load. 
> 
> It won't necessarily be exposed to maximum load on startup either.
> 
> Text below covers things internal to the SG only, and is unnecessary:
> 
> > 
> > There are other cases where the AS/ASP configuration data is created
> > dynamically. In those cases there would be differences in 
> the state machine,
> > especially at creation of the AS. For example, where the AS/ASP
> > configuration data is not created until Registration of the 
> first ASP, the
> > AS-INACTIVE state is entered directly upon the nth 
> successful REG REQ from
> > an ASP belonging to that AS.  Another example is where the AS/ASP
> > configuration data is not created until the nth ASP 
> successfully enters the
> > ASP-ACTIVE state.  In this latter case the AS-ACTIVE state 
> is entered
> > directly.
> 
> Stick with the old text.
> 
> --brian
> 
> -- 
> Brian F. G. Bidulock
> [email-masked]
> http://www.openss7.org/
> 

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 18 Jun 2003 12:13:36 -0600

Javier,

Don't be absurd.  n<>1 is the case we speak of.

--brian

Javier Pastor-Balbas (ECE) wrote:                                                   (Wed, 18 Jun 2003 16:09:52)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/