Subject: Re: [Sigtran] M3UA : Multiple SGPs in SG

From: [email-masked]
Date: Fri, 6 Jun 2003 09:56:14 +0530

Hi Tolga,
                    I am of the openion that scope of n+k redundancy should
depend on how one views and implements an SG. In figure given below if an
implementation wants to reroute some AS traffic to its adjacent SGP on its
way to AS it should be allowed.BTW as you have also agreed that ASP1 and
ASP2 also qualifies as two ASP's of AS if SGP1 and SGP2 has active
associations with ASP1 and ASP2 respectively.SGP may not want to block the
traffic for AS if association between SGP1 and ASP2 is not active for AS
assuming n = 2, k = 0(for n+k redundancy). I am not able to understand what
interopability issue will be involved in it.No doubt limiting scope of n+k
redundancy to SGP is clear and simple but some implementations may want to
use inter SGP routing to route there traffic to AS. So it ultimately
depends on how you want your SG implementation to behave.

                      SG
                  +--------------+            AS
                  |              |        +---------+--+
                  |              |        |            |
                  | +--------+   |        |+--------+  |
                  | |        |   |        ||        |  |
                  | |  SGP1  *---+--------++ ASP1   |  |
                  | +--------+\  |        |+--------+  |
                  |    |         \        |            |
  inter SGP  -----+----+         |        |            |
  routing         |    |         |   \    |            |
                  | +--------+   |     \  |+--------+  |
                  | |        |   |       \||        |  |
                  | | SGP2   +---+------ -*+  ASP2  |  |
                  | +--------+   |        |+--------+  |
                  |              |        |            |
                  +--------------+        +------------+

Regards
Kamesh
Hughes Software Systems

Tolga Asveren <[email-masked]>@ietf.org on 06/05/2003 07:40:28 PM

Sent by:    [email-masked]

To:    [email-masked]
cc:

Subject:    Re: [Sigtran] M3UA : Multiple SGPs in SG

Hi Kamesh,

IMO, it is a fair assumption for most of the cases
that processing power for SG-side hosts is higher than
of a single ASP (of course, still a configuration
issue)

For loadsharing on SG-side, for incoming traffic from
SS7 there is already loadsharing among links, and
links are residing on different hosts. So, I would
think incoming traffic will be more or less evenly
distributed among different hosts (and probably you
will first try the local SGP on that host to route the
traffic to ASPs, but still implementation dependent).

   Tolga
--- [email-masked] wrote:
>
>
>
>
> Hi Tolga,
>                      I want to clarify one more
> point that in n+k
> redundancy mode we are saying that n ASP's should be
> active in SGP for the
> AS to handle AS traffic, but can you tell me are we
> assuming that SGP
> handling entire traffic of AS is an high processing
> machine with
> processing power of 3 ASP's.I think it is slightly
> unfair on SGP. We can
> also distribute traffic for AS among SGP's of SG
> which has active
> associations with three ASP's and allow
> implementations to load share
> traffic of AS not only among ASP's (of AS) but
> within SGP's of SG too.
>
> Regards
> Kamesh
>
>
>
>
> Tolga Asveren <[email-masked]>@ietf.org on
> 06/05/2003 05:53:51 PM
>
> Sent by:    [email-masked]
>
>
> To:    [email-masked]
> cc:
>
> Subject:    Re: [Sigtran] M3UA : Multiple SGPs in SG
>
>
> Hi Kamesh,
>
>
>              associations
>     | | | |    | | | |      | | | |
>    +---------+------------+-----------+
>    |   SGP1  |   SGP2     |   SGP3    |
>    ************************************
>    *              MTP3                *
>    *         |            |           *
>    * host1   |   host2    |  host3    *
>    ************************************
>      |   |       |     |       |    |
>      |   |       |     |       |    |
>                 Links
>
>
> Basically adjacent SS7 node is just aware that there
> is a MTP3 peer and some links to communicate with
> it,
> and will probably loadshare traffic based on SLS
> betwen those links. Once the messages are inside the
> SG-box, it is up to you, what to do with them (and I
> would think although a lot of things inside SG are
> implementation dependent, there is no direct mapping
> between links and SGPs)
>
> BTW, like you have said, it really migt be possible
> to
> loadshare traffic between two ASPs, which are ACTIVE
> for separate SGPs -and this also IMO would qualify
> as
> 2 ACTIVE ASPs because this is not two associations
> to
> the same ASP-, but I still think this might bring
> interoperability problems. To decide, when to start
> traffic, IMO ASP and SGP should work in harmony. So,
> IMO it is a good choice to leave the peers as SGP
> and
> ASP for ASPTM procedures.
>
> I also checked a sentence related with this topic
> -in
> ASP Active Procedures- in RFC, there it stands that
> "ASPs should coordinate the number of ACTIVE ASPs
> for
> the AS", I think this may be clarified as "the
> number
> of ACTIVE ASPs for the AS for a specific SGP".
>
>    Tolga
>
>
> --- [email-masked] wrote:
> >
> >
> >
> >
> > Tolga,
> >    Can you clearly show with figure how an SS7
> node
> > adjacent to SG would
> > route traffic for AS in this scenario, clearly
> > showing signalling links
> > used by adjacent SS7 node and mapping of these
> links
> > to SGP's of SG.
> >
> > Regards
> > Kamesh
> >
> >
> >
> >
> >
> > Tolga Asveren <[email-masked]>@ietf.org
> on
> > 06/05/2003 04:34:06 PM
> >
> > Sent by:    [email-masked]
> >
> >
> > To:    [email-masked]
> > cc:
> >
> > Subject:    Re: [Sigtran] M3UA : Multiple SGPs in
> SG
> >
> >
> > Kamesh,
> >
> > Some comments below, just my 2 cents.
> >
> >   Tolga
> > --- [email-masked] wrote:
> > >
> > >
> > >
> > >
> > > Umesh some comments
> > >
> > > It all depends on how SG is implemented.If SS7
> > node
> > > adjacent to SG is
> > > routing traffic to SGP without making any
> > > assumptions of inter SGP routing
> > > then routing of traffic to AS ultimately depends
> > on
> > > the number of active
> > > associations capable of handling traffic for AS
> > > corresponding to SGP.In
> > > this case scope of n+k redundancy is valid
> > > corresponding to SGP i.e number
> > > of active associations of ASP's (of AS) with
> > single
> > > SGP(of SG), which
> > > should be n to handle traffic for AS. For this
> > > scenario your ORD options
> > [TOLGA]A SG is seen from SS7 point of view as a
> > single
> > entity. A node in SS7 domain is not aware of the
> > concept of SGs and SGPs. BTW, important is the
> > number
> > of ACTIVE ASPs to handle the traffic, not the
> number
> > of associations to an ACTIVE ASP. So, I wouldn't
> > think
> > that it will increase the performance of an ASP,
> if
> > you have 3 -instead of 1- association to the same
> > ASP.
> > > are valid for both the points.Now if SS7 node
> > > adjacent to SG is routing
> > > traffic to SGP without caring whether the
> traffic
> > > for AS is ultimately
> > > routed through active associations of ASP's (of
> > AS)
> > > with SGP1 or SGP2 or
> > > SGP3 which may involve inter SGP routing then
> > scope
> > > of n+k redundancy is
> > > valid corresponding to SG i.e number of active
> > > associations of ASP's (of
> > > AS) with any SGP in the SG.For this scenario
> first
> > > options of your two
> > > points are appropriate. Ultimately it all
> depends
> > on
> > > how you view and
> > > implement SG.
> > [TOLGA]IMO it is clear that for n+k situation,
> both
> > ASP and SGP should behave the same, otherwise it
> > might
> > bring interoperability problems that SG tries to
> > activate traffic based on the SGwide number of
> > ACTIVE
> > ASPs, and ASP kepps the counter per SGP. ASPTM is
> > sent
>
=== message truncated ===

__________________________________
Do you Yahoo!?
Yahoo! Calendar - Free online calendar with sync to Outlook(TM).
http://calendar.yahoo.com
_______________________________________________
Sigtran mailing list
[email-masked]
 https://www1.ietf.org/mailman/listinfo/sigtran

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: Tolga Asveren <[email-masked]>
Date: Fri, 6 Jun 2003 04:05:03 -0700 (PDT)

Hi Kamesh,

If we have to types of SGs (one, which activates
traffic based on number of ACTIVE ASPs per SGP and the
other per SG), ASPs can't decide -at least based on
the current RFC- when to start/accept traffic. What
ASPs are supposed to do is coordinating number of
ACTIVE ASPs among the cluster, but if they don't know,
whether the SG is deciding based on per SGP counter or
not, there will be interoperability problems (for
example SG uses a global ACTIVE ASP counter and starts
traffic but ASPs are counting per SGP, they probably
will drop arriving DATA). 

    Tolga
--- [email-masked] wrote:
>                   |              |       
> +---------+--+
>                   |              |        |         
>   |
>                   | |        |   |        ||       
> |  |
>                   |    |         \        |         
>   |
>   routing         |    |         |   \    |         
>   |
>                   | |        |   |       \||       
> |  |
>                   |              |        |         
>   |
> 06/05/2003 07:40:28 PM

__________________________________
Do you Yahoo!?
The New Yahoo! Search - Faster. Easier. Bingo.
http://search.yahoo.com
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 6 Jun 2003 13:49:12 -0600

Tolga,

SGs cannot "start" traffic.  They are not the stimulus.
The remote signalling points must start traffic in
response to a user part test and it will take a significant
amount of time before any traffic flows.

But we've discussed this before....

What I can't understand is why the IG hasn't been
corrected yet.

--brian

Tolga Asveren wrote:                                                                 (Fri, 06 Jun 2003 04:05:03)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: Tolga Asveren <[email-masked]>
Date: Fri, 6 Jun 2003 13:04:52 -0700 (PDT)

Brian,

I think it was clear what I mean with "starting",
allowing traffic for a specific AS to ASP direction
from SGP. 
BTW, related with this topic -I assume you refer to
the following sentence at the bottom of page 33 in IG:
"An SGP or IPSP, upon reception of an ASP Active
message for the first ASP in a Loadshare AS, SHOULD
NOT direct traffic to a newly active ASP until it
determines that there are sufficient resources to
handle the expected load (e.g., until there are "n"
ASPs in state ASP-ACTIVE in the AS)."
To my understanding, there was no consensus to change
"SHOULD NOT" to "MAY".
(And if there is such a consensus in the future, I
would think we should also allow for the n=1 case to
route DATA from SGPs to INACTIVE ASPs)

   Tolga 
--- "Brian F. G. Bidulock" <[email-masked]>
wrote:
> Tolga Asveren wrote:                                
>                                 (Fri, 06 Jun 2003
> 04:05:03)
> > >                     I am of the openion that
> > > of n+k redundancy should
> > > implementation wants to reroute some AS traffic
> to
> > > its adjacent SGP on its
> > > way to AS it should be allowed.BTW as you have
> also
> > > agreed that ASP1 and
> > > ASP2 also qualifies as two ASP's of AS if SGP1
> and
> > > SGP2 has active
> > > associations with ASP1 and ASP2 respectively.SGP
> may
> > > not want to block the
> > > traffic for AS if association between SGP1 and
> ASP2
> > > is not active for AS
> > > assuming n = 2, k = 0(for n+k redundancy). I am
> not
> > > able to understand what
> > > interopability issue will be involved in it.No
> doubt
> > > limiting scope of n+k
> > > use inter SGP routing to route there traffic to
> AS.
> > > So it ultimately
> > > depends on how you want your SG implementation
> to
> > > behave.
> > > 
> > > 
> > >                       SG
> > >                   +--------------+            AS
> > >                   |              |       
> > > +---------+--+
> > >                   |              |        |     
>    
> > >   |
> > >                   | +--------+   |       
> > > |+--------+  |
> > >                   | |        |   |        ||    
>   
> > > |  |
> > >                   | |  SGP1  *---+--------++
> ASP1  
> > > |  |
> > >                   | +--------+\  |       
> > > |+--------+  |
> > >                   |    |         \        |     
>    
> > >   |
> > >   inter SGP  -----+----+         |        |     
>    
> > >   |
> > >   routing         |    |         |   \    |     
>    
> > >   |
> > >                   | +--------+   |     \ 
> > > |+--------+  |
> > >                   | |        |   |       \||    
>   
> > > |  |
> > >                   | | SGP2   +---+------ -*+ 
> ASP2 
> > > |  |
> > >                   | +--------+   |       
> > > |+--------+  |
> > >                   |              |        |     
>    
> > >   |
> > >                   +--------------+       
> > > +------------+
> > > 
> > > Regards
> > > Kamesh
> > > Hughes Software Systems
> > > 
> > > 
> > > 
> > > 
> > > that processing power for SG-side hosts is
> higher
> > > than
> > > will first try the local SGP on that host to
> route
> > > the
> > > > redundancy mode we are saying that n ASP's
> should
> > > be
> > > > active in SGP for the
> > > > AS to handle AS traffic, but can you tell me
> are
> > > we
> > > > assuming that SGP

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 6 Jun 2003 14:27:11 -0600

Tolga,

There was concensus to interpret n as maximum
engineered load and to remove the section from
the IG.

--brian

Tolga Asveren wrote:                                                                 (Fri, 06 Jun 2003 13:04:52)