Subject: [Sigtran] AS Override question

From: "Nitin Tomar" <[email-masked]>
Date: Thu, 26 Jun 2003 11:01:39 -0700

Hi All,
One basic question related to AS state in Override mode.
Scenario is:
An SG is served by two SGPs (SGP-1 and SGP-2) and AS is served by two ASPs
(ASP-1 and ASP-2),
let's say ASP-1 is initially active for AS and it has sent ASP-ACTIVE
message only towards
SGP-1, and now the SGP-2 receives this ASP-ACTIVE from ASP-2 for the same
AS.

What shall be the behavior at SG in response to ASP-ACTIVE from ASP-2,
I can see three possibilities:
a) SG (SGP-2) shall reject ASP-ACTIVE from ASP-2 as ASP-1 is already active
towards SGP1,
    if yes then what shall be the errorcode used in rejection message?

b) SG shall mark the ASP-2 as active for AS and mark the ASP-1 as INACTIVE
(and send the NTFY
    message (ALT-ASP-ACTIVE) to ASP-1 but in this case SG will not know from
which SGP
    it shall send the NTFY message?).

c) SG shall accept the ASP-2's request as well but in this case for a single
AS in OVERRIDE mode there
    will be two ASPs which are ACTIVE (each from different SGPs).

It will be interesting to know that what other M3UA implementers think about
handling above scenario.

Thanks
Nitin

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 26 Jun 2003 12:07:55 -0600

Nitin,

ASPTM/SM message and ASP state in the AS are per-SGP.

--brian

Nitin Tomar wrote:                                                                   (Thu, 26 Jun 2003 11:01:39)
>    An  SG is served by two SGPs (SGP-1 and SGP-2) and AS is served by two
>    ASPs (ASP-1 and ASP-2),
> 
>    SGP-1,  and  now the SGP-2 receives this ASP-ACTIVE from ASP-2 for the
>    same AS.
> 
> 
> 
>    a)  SG  (SGP-2) shall reject ASP-ACTIVE from ASP-2 as ASP-1 is already
>    active towards SGP1,
> 
>    b)  SG  shall  mark  the  ASP-2 as active for AS and mark the ASP-1 as
>    INACTIVE (and send the NTFY
> 
>         message  (ALT-ASP-ACTIVE)  to  ASP-1 but in this case SG will not
>    know from which SGP
> 
>    c)  SG shall accept the ASP-2's request as well but in this case for a
>    single AS in OVERRIDE mode there
> 
>    It  will  be  interesting  to  know  that what other M3UA implementers
>    think about handling above scenario.
> 
> 
> 
>    Thanks
> 
>    Nitin

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Samuel Dur D. Jeyaseelan" <[email-masked]>
Date: Fri, 27 Jun 2003 02:11:16 -0500 (CDT)

Nitin,

 This is just for your information.

 Basically state of an AS is determined with respect to an SGP.

  Alcatel USA, Inc.                  Internet: <userid>@ssd.usa.alcatel.com
  1000 Coit Road, Plano, Texas 75075
  ******* The opinions expressed are not those of Alcatel USA, Inc. *******

>     if yes then what shall be the errorcode used in rejection message?
How does SGP-2 know that AS is already ACTIVE for SGP1?
You mean to say SGP2 interacts with SGP1 as soon as it receives ASP ACTIV
message.If this is your answer then the AS state is determined with
respect to (SGP1+SGP2), this case SGP2 should send a NTFY message to ASP1
or SGP2 can instruct SGP1 to send a NTFY message to ASP1 to go down.

>     it shall send the NTFY message?).
refer above ans.
>     will be two ASPs which are ACTIVE (each from different SGPs).
refer above ans.

> It will be interesting to know that what other M3UA implementers think about
Note: REG message is being sent by ASP before ASP ACTIVE message.
If AS state is determined with respect to (SGP1+SGP2), see the following
case
 1.ASP1 sends RK1 to SGP1
 2. SGP1 interacts with SGP2 and returns a unique RC1
 .
 .
 .

 1.ASP2 sends RK1 to SGP2
 2.SGP2 interacts with SGP1 and finds RK1 is already existing in SGP1 so
   SGP2 will send a REG RESP with error code to ASP2.

 3.By seening REG RESP with error code ASP2 should not be sending ASP
 ACTIV message to SGP2.

 like this, so many cases can be dealt.

---

From: Tolga Asveren <[email-masked]>
Date: Fri, 27 Jun 2003 12:00:08 -0700 (PDT)

Samuel,

IMO, that you interprete SG as peer -instead of SGP-
for ASPTM procedures is not inline with RFC.

    Tolga
--- "Samuel Dur D. Jeyaseelan"
>  like this, so many cases can be dealt.

__________________________________
Do you Yahoo!?
SBC Yahoo! DSL - Now only $29.95 per month!
http://sbc.yahoo.com