Subject: RE: [Sigtran] RE: M3UA IG: section 3.15 reworked

From: "Javier Pastor-Balbas (ECE)" <[email-masked]>
Date: Wed, 18 Jun 2003 11:55:39 +0200

Hi Tolga, 

I think I understand your concern. If we want that both ASPs and SGPs have the same AS state view, one option is to configure T(r) in both machines with the same value. But even then there is a network delay that you may not control. In that case the ASPs will realize of their new state with the help of NTFY message.

Another different point is the transition PN2AC. It follows the philosophy of having the AS-ACTIVE state even when only one ASP is in ASP-ACTIVE state. It's a result of adapting the model to the max-engineered-load "n" view.

Cheers // Javier.

> -----Original Message-----
> From: Tolga Asveren [mailto:[email-masked]]
> Sent: martes, 17 de junio de 2003 21:27
> To: [email-masked]
> Subject: Re: [Sigtran] RE: M3UA IG: section 3.15 reworked
> 
> 
> Hi Javier,
> 
> IMO the changes in general are nice, I have one
> question/comment though:
> For PN2AC transition, unless ASPs have knowledge of
> T(r), they can't decide whether the first ACTIVE ASP
> will make AS to switch to ACTIVE or not -because they
> can't know whether AS has already switched to INACTIVE
> after T(r) expiry or not- (AS state machine is
> described from SG point of view but I believe we
> should make it possible that ASPs and SGPs can have
> the same AS state view) -in fact I am not sure,
> whether to favor PN2AC transition by allowing it to
> happen with only one ACTIVE ASP is the best solution
> or not-.
> Furthermore, if the proposed PN2AC is going to be kept
> I would think PN2IA should be somethink like "T(r)
> expiry, no ACTIVE ASPs"
> 
>     Tolga
> --- "Javier Pastor-Balbas (ECE)"
> <[email-masked]> wrote:
> > This is the last version. There were still some
> > unfinished sentences and inconsistences in the first
> > text I sent. Now, they are fixed.
> > 
> > Cheers // Javier.
> > 
> > 
> > --------- 
> > Old text: (Section 4.3.2) 
> > ---------
> > 
> > AS-DOWN: The Application Server is unavailable. 
> > This state implies 
> > that all related ASPs are in the ASP-DOWN state for
> > this AS. Initially the AS will be in this state. An
> > Application Server is in the AS-DOWN state when it
> > is removed from a configuration.
> > 
> > AS-INACTIVE: The Application Server is available but
> > no application 
> > traffic is active (i.e., one or more related ASPs
> > are in the ASP-
> > INACTIVE state, but none in the ASP-ACTIVE state). 
> > The recovery 
> > timer T(r) is not running or has expired. 
> > 
> > AS-ACTIVE: The Application Server is available and
> > application traffic is active.  This state implies
> > that at least one ASP is in the ASP-ACTIVE state.
> > 
> > AS-PENDING: An active ASP has transitioned to
> > ASP-INACTIVE or ASP-DOWN  and it was the last
> > remaining active ASP in the AS.  A recovery timer
> > T(r) SHOULD be started and all incoming signalling
> > messages SHOULD be queued by the SGP. If an ASP
> > becomes ASP-ACTIVE before T(r) expires, the AS is
> > moved to the AS-ACTIVE state and all the queued
> > messages will be sent to the ASP. 
> > 
> > If T(r) expires before an ASP becomes ASP-ACTIVE,
> > and the SGP has no 
> > alternative, the SGP may stops queuing messages and
> > discards all 
> > previously queued messages. The AS will move to the
> > AS-INACTIVE state 
> > if at least one ASP is in ASP-INACTIVE state,
> > otherwise it will move 
> > to AS-DOWN state. 
> > 
> > Figure 5 shows an example AS state machine for the
> > case where the 
> > AS/ASP data is preconfigured.  For other cases where
> > the AS/ASP 
> > configuration data is created dynamically, there
> > would be differences 
> > in the state machine, especially at creation of the
> > AS.  
> > 
> >                  Figure 5: AS State Transition
> > Diagram
> > 
> >      +----------+   one ASP trans to ACTIVE  
> > +-------------+
> >      |    AS-   |---------------------------->|    
> > AS-     |      
> >      | INACTIVE |                             |  
> > ACTIVE    |
> >      |          |<---                         |     
> >        |
> >      +----------+    \                       
> > +-------------+
> >         ^   |         \ Tr Expiry,                ^ 
> >   |
> >         |   |          \ at least one             | 
> >   |
> >         |   |           \ ASP in ASP-INACTIVE     | 
> >   |
> >         |   |            \                        | 
> >   |
> >         |   |             \                       | 
> >   |
> >         |   |              \                      | 
> >   |
> > one ASP |   | all ASP       \            one ASP  | 
> >   | Last ACTIVE
> > trans   |   | trans to       \           trans to | 
> >   | ASP trans to
> > to      |   | ASP-DOWN        -------\   ASP-     | 
> >   | ASP-INACTIVE
> > ASP-    |   |                         \  ACTIVE   | 
> >   | or ASP-DOWN
> > INACTIVE|   |                          \          | 
> >   |  (start Tr)
> >         |   |                           \         | 
> >   |
> >         |   |                            \        | 
> >   |
> >         |   v                             \       | 
> >   v         
> >      +----------+                          \ 
> > +-------------+
> >      |          |                           --|     
> >        |      
> >      | AS-DOWN  |                             |
> > AS-PENDING  |
> >      |          |                             | 
> > (queueing) |
> >      |          |<----------------------------|     
> >        |
> >      +----------+    Tr Expiry and no ASP    
> > +-------------+
> >                      in ASP-INACTIVE state)   
> > 
> >  Tr = Recovery Timer
> > 
> > 
> > 
> > For example, where the AS/ASP configuration data is
> > not created until 
> > Registration of the first ASP, the AS-INACTIVE state
> > is entered 
> > directly upon the first successful REG REQ from an
> > ASP.  Another 
> > example is where the AS/ASP configuration data is
> > not created until the first ASP successfully enters
> > the ASP-ACTIVE state.  In this case the AS-ACTIVE
> > state is entered directly.
> > 
> > 
> > --------- 
> > New text: (Section 4.3.2) 
> > ---------
> > 
> > AS-DOWN: The Application Server is unavailable. 
> > This state implies that the number of ASPs being in
> > ASP-INACTIVE or ASP-ACTIVE is less than "n".
> > Initially the AS will be in this state. An
> > Application Server is in the AS-DOWN state when it
> > is removed from a configuration.
> > 
> > AS-INACTIVE: The Application Server is available but
> > no application traffic is active. This implies that
> > there are at least n ASPs in either ASP-INACTIVE or
> > ASP-ACTIVE but the total number of ASPs in
> > ASP-ACTIVE state has not reach n.  The recovery
> > timer T(r) is not running or has expired. 
> > 
> > AS-ACTIVE: The Application Server is available and
> > application traffic is active. The AS moves to this
> > state after being in AS-INACTIVE and getting n ASPs
> > in ASP-ACTIVE state or, after reaching AS-ACTIVE and
> > keeping one or more ASPs in ASP-ACTIVE state. 
> > 
> > AS-PENDING: The last active ASP has transitioned
> > from ASP-ACTIVE to ASP-INACTIVE or ASP-DOWN.  A
> > recovery timer T(r) SHOULD be started and all
> > incoming signalling messages SHOULD be queued by the
> > SGP. If an ASP becomes ASP-ACTIVE before T(r)
> > expires, the AS is moved to the AS-ACTIVE state and
> > all the queued messages will be sent to the ASP. 
> > 
> > If T(r) expires before an ASP becomes ASP-ACTIVE,
> > the SGP MAY stops queuing messages and discards all 
> > previously queued messages. The AS will move to the
> > AS-INACTIVE state 
> > if at least the number of ASPs in ASP-INACTIVE sum
> > n, otherwise it will move to AS-DOWN state. 
> > 
> > Figure 5 shows an example AS state machine for the
> > case where the 
> > AS/ASP data is preconfigured and an n+k redundancy
> > model. 
> > 
> > 
> >              Figure 5: AS State Transition Diagram
> > 
> >                    
> >      +----------+          IA2AC             
> > +-------------+
> >      |    AS-   |---------------------------->|    
> > AS-     |
> >      | INACTIVE |                             |  
> > ACTIVE    |
> >      |          |<-----------                 |     
> >        |
> >      +----------+            \               
> > +-------------+
> >         ^   |                 \                    ^
> >   |
> >         |   | IA2DN            \ PN2IA             |
> >   | AC2PN
> >         |   |                   \                  |
> >   | 
> >   DN2IA |   |                    \          PN2AC  |
> >   | 
> >         |   v                     \                |
> >   v
> >      +----------+                  \         
> > +-------------+
> >      |          |                   ----------|     
> >        |
> > 
> === message truncated ===
> 
> 
> __________________________________
> Do you Yahoo!?
> The New Yahoo! Search - Faster. Easier. Bingo.
> http://search.yahoo.com
> 
> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/sigtran
> 

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: Tolga Asveren <[email-masked]>
Date: Wed, 18 Jun 2003 04:22:00 -0700 (PDT)

Hi Javier,
--- "Javier Pastor-Balbas (ECE)"
<[email-masked]> wrote:
> 
> Hi Tolga, 
> 
> I think I understand your concern. If we want that
> both ASPs and SGPs have the same AS state view, one
> option is to configure T(r) in both machines with
> the same value. But even then there is a network
> delay that you may not control. In that case the
> ASPs will realize of their new state with the help
> of NTFY message.
[TOLGA]Maybe a few sentences about use of NTFY for
such cases can be added(?). Till now -and according to
RFC- it had only advisory meaning, now it is a bit
more than this.
> 
> Another different point is the transition PN2AC. It
> follows the philosophy of having the AS-ACTIVE state
> even when only one ASP is in ASP-ACTIVE state. It's
> a result of adapting the model to the
> max-engineered-load "n" view.
> 
> Cheers // Javier.
>