Subject: [Sigtran] Network Byte Order

From: Pablo Salinas <[email-masked]>
Date: Tue, 10 Jun 2003 09:29:03 -0500 (CDT)

Hi there,
              I have a silly question. The RFC 3331 indicates that M2UA packets should be sent in Network Byte Order (Big Endian Order). So, this means that for the common message header
 
 0                          1                         2                             3
 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
|           Tag (0x1)                  |           Length=8                   |
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
|                 Interface Identifier (integer)                                |
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
 
M2UA should send first the Tag from left to rigth, then the length parameter and finally the Interface Identifier (from left to right), rigth?
 
Please, can someone help me out?
 
                               greetings,
                                             Pablo Salinas

---------------------------------
Do You Yahoo!?
Todo lo que quieres saber de Estados Unidos, América Latina y el resto del Mundo.
Visíta Yahoo! Noticias.

---

From: [email-masked]
Date: Tue, 10 Jun 2003 20:03:33 +0530

Hi,
you are right.
M2UA will send first TAG than length and so on..........

regds
Satyendra

Pablo Salinas <[email-masked]>@ietf.org on 06/10/2003 07:59:03 PM

Sent by:    [email-masked]

To:    [email-masked]
cc:

Subject:    [Sigtran] Network Byte Order

Hi there,
              I have a silly question. The RFC 3331 indicates that M2UA
packets should be sent in Network Byte Order (Big Endian Order). So, this
means that for the common message header

 0                          1
2                             3
 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
|           Tag (0x1)                  |
Length=8                   |
+-+-+-+-+-+-+-+-+-+-+-+-+-! +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
|                 Interface Identifier
(integer)                                |
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

M2UA should send first the Tag from left to rigth, then the length
parameter and finally the Interface Identifier (from left to right), rigth?

                               greetings,
                                             Pablo Salinas

Do You Yahoo!?
[IMAGE]Todo lo que quieres saber de Estados Unidos, América Latina y el
resto del Mundo.
Visíta Yahoo! Noticias.

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran