Subject: RE: [Sigtran] Re: M3UA Notify message

From: "Javier Pastor-Balbas (ECE)" <[email-masked]>
Date: Tue, 24 Jun 2003 17:53:40 +0200

Hi Brian,

The text you show below together with section 1.4.4.1 does not say that you may send NTFY before "n" ASPs are ACTIVE per section 1.4.4.1. Then you can conclude that you MAY wait till n+m ASPs till you send the NTFY. M

>   An SGP or IPSP, upon reception of an ASP Active
>   message for the first ASP in a Loadshare AS, MAY
>   choose not to direct traffic to a newly active ASP
>   until it determines that there are sufficient
>   resources to handle the expected load (e.g., until
>   there are "n" ASPs in state ASP-ACTIVE in the AS).
>   In this case, the SGP or IPSP SHOULD withhold the
>   Notify (AS-ACTIVE) until there are sufficient
>   resources.

It seems that your statements are not aligned with section 1.4.4.1, 3rd paragraph... This section clearly says that n ASPs are needed. 

But also section 4.3.2 does not say a word about withholding the NTFY(AS-ACTIVE) as it is explained in other sections. What means that the text needs some fixings...

I would recommend to fixed the text to clearly specify the behavior we want.

Cheers // Javier.

> -----Original Message-----
> From: Brian F. G. Bidulock [mailto:[email-masked]]
> Sent: sábado, 21 de junio de 2003 0:14
> To: Tolga Asveren
> Cc: [email-masked]
> Subject: Re: [Sigtran] Re: M3UA Notify message
> 
> 
> Tolga,
> 
> Tolga Asveren wrote:                                          
>                        (Fri, 20 Jun 2003 13:50:08)
> > Brian,
> > 
> > 1- NTFY has only advisory meaning, there is no
> > "SHOULD" action, which is to be taken after NTFY, so
> > your argument that ASPs can rely on NTFY is not valid
> 
> The RFC does not say that.  It says:
> 
>   An SGP or IPSP, upon reception of an ASP Active
>   message for the first ASP in a Loadshare AS, MAY
>   choose not to direct traffic to a newly active ASP
>   until it determines that there are sufficient
>   resources to handle the expected load (e.g., until
>   there are "n" ASPs in state ASP-ACTIVE in the AS).
>   In this case, the SGP or IPSP SHOULD withhold the
>   Notify (AS-ACTIVE) until there are sufficient
>   resources.
> 
> And the ASP can rely on it.  The Notify is advisory.
> The ASP can ignore it if it likes.  It does not
> compel the ASP to do anything.  The ASP can ignore
> the notification of AS state change at its own peril.
> 
> The argument that an ASP can rely on this notify is
> ensured by the SHOULD in the passage above.
> 
> > -you know it was proposed to make ASPs decide for the
> > AS state change by NTFY but it was not accepted,
> 
> That was an observation in an old thread, not a
> rejection.
> 
> The ASP is welcome to use whatever information it
> has at its disposal, INCLUDING Notify, which it can
> rely upon because of the requirement (MUST) for the
> SGP to send it.
> 
> > because it was considered as a too radical change-.
> 
> What change?  It is already there in the RFC in
> section 4.3.4.3.  This is also true for M2UA and
> SUA.
> 
> > Nowhere it is stated in RFC nor in IG, that ASPs
> > decide to accept/receive application traffic based on
> > NTFY.
> 
> There is no requirement for them to do so.  There
> is, however, a requirement placed on ASPs in thes
> same section (4.3.4.3) that reads;
> 
>   For the n+k redundancy case, ASPs which are in the
>   AS SHOULD coordinate amoung themselves the number
>   of active ASPs in the AS, and should start sending
>   traffic only after 'n' ASPs are active.
> 
> It does not require the ASP to use Notify, but it
> does not keep the ASP from using whatever means it
> has at its disposal for coordinating that 'n' ASPs
> become active.
> > 
> > 2- RFC tells that ASPs SHOULD arrange number of ACTIVE
> > ASPs among themselves, but allows SG to start routing
> > traffic even with less than n ACTIVE ASP.
> 
> As it should.
> 
> > Just look to
> > the definition of INACTIVE AS in RFC, an AS whith no
> > application traffic flowing to/from it. So, they might
> > have inconsistent views of AS state.
> 
> No, because the ASP will coordinate that 'n' are
> active.
> 
> > 
> > 3- If n is to be seen as the mother day's value, IMO
> > it really has nothing to do with M3UA, because it
> > won't change AS state at all (or maybe you can give an
> > example about its relation to M3UA)
> 
> I think you misread the first quote from 4.3.4.3.
> The ASP has little idea what load it will be offered
> when it activates.  This is why it should coordinate
> that 'n' are active.  It might be Mother's Day, it
> might not.  The SG, on the other hand, has a better
> idea of what load will be offered and will activate
> when the number of ASPs is sufficient to handle the
> load.  That is not necessariliy 'n'.  'n' is just an
> example in the quote: "(e.g., until thare are "n"
> ASPs in state ASP-ACTIVE in the AS)".  The SG
> normally activates the AS with the first active ASP
> (as indicated and completely consistent with the
> state diagram and descriptions in the RFC), but it
> MAY wait until 'n' are active.  In any case it sends
> Notify to indicate that th AS is active as it MUST
> (see the MUSTs in section 4.3.4.5).
> 
> It is not a question that the SGP MUST send Notify.
> It MAY wait until sufficient ASPs are active to
> handle the load (and not necessarily "n", but it may
> be "n") and it SHOULD withhold the Notify until
> sufficient ASPs are active to handle the load.
> 
> This provide the SG designer with the freedom to
> meet dynamic load and redundancy needs at the same
> time as ensuring interoperability through the Notify
> and ASP-Active procedures.
> 
> You seem to want to restrict this further, taking
> the necessary flexibility away from the SG designer
> with no resulting benefit.  I cannot agree with the
> proposal.  The RFC is both sufficient and necessary
> in this regard.
> 
> Strike 3.15.
> 
> --brian
> 
> -- 
> Brian F. G. Bidulock
> [email-masked]
> http://www.openss7.org/
> 
> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/sigtran
> 

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: Tolga Asveren <[email-masked]>
Date: Tue, 24 Jun 2003 09:13:39 -0700 (PDT)

Hi Javier,

My opinion is, when AS state change happens should be
clearly defined and M3UA documents are not the place
to discuss traffic engineering issues other than that.
So, IMO, the text you proposed is fine -maybe just
renaming max engineered load, or clearly explaining
what is meant with that-. 

      Tolga
--- "Javier Pastor-Balbas (ECE)"
<[email-masked]> wrote:
> Hi Brian,
> 
> The text you show below together with section
> 1.4.4.1 does not say that you may send NTFY before
> "n" ASPs are ACTIVE per section 1.4.4.1. Then you
> can conclude that you MAY wait till n+m ASPs till
> you send the NTFY. M
> 
> It seems that your statements are not aligned with
> section 1.4.4.1, 3rd paragraph... This section
> clearly says that n ASPs are needed. 
> 
> But also section 4.3.2 does not say a word about
> withholding the NTFY(AS-ACTIVE) as it is explained
> in other sections. What means that the text needs
> some fixings...
> 

__________________________________
Do you Yahoo!?
SBC Yahoo! DSL - Now only $29.95 per month!
http://sbc.yahoo.com

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 24 Jun 2003 11:25:41 -0600

Javier,

Javier Pastor-Balbas (ECE) wrote:                                                   (Tue, 24 Jun 2003 17:53:40)
> Hi Brian,
> 
> The text you show below together with section 1.4.4.1 does not say that you
> may send NTFY before "n" ASPs are ACTIVE per section 1.4.4.1. Then you can
> conclude that you MAY wait till n+m ASPs till you send the NTFY. M

Read: (Section 4.3.4.5:)

  A Notify message reflecting a change in the AS state MUST be
  sent to all ASPs in the AS, except thos in the ASP-DOWN state,
  with apporpriate Status Information and any ASP Identifier of
  the failed ASP.  ...  The Notify message must be sent whether
  the AS state change was a result of an ASP failure or
  reception of an ASP State management (ASPSM) / ASP Traffic
  Management (ASPTM) message.  In the second case, the Notify
  message MUST be sent after any related acknowledgement message
  (e.g., ASP Up Ack, ASP Down Ack, ASP Active Ack, or ASP
  Inactive Ack).

Read: (Section 4.3.2:)

  AS-ACTIVE: The Application Server is available and application
  traffic is active.  This state implies that at least one ASP
  is in the ASP-ACTIVE state.

Read: (Section 4.3.4.3:)

  An SGP or IPSP, upon reception of an ASP Active message for
  the first ASP in a Loadshare AS, MAY choose not to direct
  traffic to a newly active ASP until it determines that there
  are sufficient resources to handle the expected load (e.g.,
  until there are "n" ASPs in state ASP-ACTIVE in the AS).  In
  this case, the SGP or IPSP SHOULD withhold the Notify
  (AS-ACTIVE) until there are sufficient resources.
  
The first passage says that I must send Notify(AS Actve), the
second passages says that I can send it when the first ASP is
Active for the AS, the third passage says that I may withhold it
until sufficient resources are active (regardless of 'n').

> It seems that your statements are not aligned with section 1.4.4.1, 3rd
> paragraph... This section clearly says that n ASPs are needed. 

1.4.4.1 says nothing about when to send messages.

> 
> But also section 4.3.2 does not say a word about withholding the
> NTFY(AS-ACTIVE) as it is explained in other sections. What means that the
> text needs some fixings...

No.  It is stated in section 4.3.4.3, the ASP Active procedures.
There are a lot of things stated in the 4.3.4.3 procedures that
are not stated in section 4.3.2, because 4.3.2 is an OVERVIEW.

> I would recommend to fixed the text to clearly specify the

IMO nothing needs changing.  But, if you have another text
proposal, please don't hesitate to suggest it.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 24 Jun 2003 11:27:12 -0600

Tolga,

You have no response to my last message of June 20th?

--brian

Tolga Asveren wrote:                                                                 (Tue, 24 Jun 2003 09:13:39)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/