Subject: Re: [Sigtran] M3UA : Multiple SGPs in SG

From: [email-masked]
Date: Thu, 5 Jun 2003 17:14:28 +0530

Tolga,
   Can you clearly show with figure how an SS7 node adjacent to SG would
route traffic for AS in this scenario, clearly showing signalling links
used by adjacent SS7 node and mapping of these links to SGP's of SG.

Regards
Kamesh

Tolga Asveren <[email-masked]>@ietf.org on 06/05/2003 04:34:06 PM

Sent by:    [email-masked]

To:    [email-masked]
cc:

Subject:    Re: [Sigtran] M3UA : Multiple SGPs in SG

Kamesh,

Some comments below, just my 2 cents.

  Tolga
--- [email-masked] wrote:
>
>
>
>
> Umesh some comments
>
> It all depends on how SG is implemented.If SS7 node
> adjacent to SG is
> routing traffic to SGP without making any
> assumptions of inter SGP routing
> then routing of traffic to AS ultimately depends on
> the number of active
> associations capable of handling traffic for AS
> corresponding to SGP.In
> this case scope of n+k redundancy is valid
> corresponding to SGP i.e number
> of active associations of ASP's (of AS) with single
> SGP(of SG), which
> should be n to handle traffic for AS. For this
> scenario your ORD options
[TOLGA]A SG is seen from SS7 point of view as a single
entity. A node in SS7 domain is not aware of the
concept of SGs and SGPs. BTW, important is the number
of ACTIVE ASPs to handle the traffic, not the number
of associations to an ACTIVE ASP. So, I wouldn't think
that it will increase the performance of an ASP, if
you have 3 -instead of 1- association to the same ASP.
> are valid for both the points.Now if SS7 node
> adjacent to SG is routing
> traffic to SGP without caring whether the traffic
> for AS is ultimately
> routed through active associations of ASP's (of AS)
> with SGP1 or SGP2 or
> SGP3 which may involve inter SGP routing then scope
> of n+k redundancy is
> valid corresponding to SG i.e number of active
> associations of ASP's (of
> AS) with any SGP in the SG.For this scenario first
> options of your two
> points are appropriate. Ultimately it all depends on
> how you view and
> implement SG.
[TOLGA]IMO it is clear that for n+k situation, both
ASP and SGP should behave the same, otherwise it might
bring interoperability problems that SG tries to
activate traffic based on the SGwide number of ACTIVE
ASPs, and ASP kepps the counter per SGP. ASPTM is sent
from ASP/SGP to ASP/SGP. Those messages are never
intended to be sent per SG. So, IMO it is clear that
decisions should be made always from SGP point of
view, not SG.
>
> Regards
> Kamesh
> Hughes Software Systems
>
>
>
>
> "Umesh Vats" <[email-masked]>@ietf.org on 06/04/2003
> 09:48:07 PM
>
> Please respond to <[email-masked]>
>
> Sent by:    [email-masked]
>
>
> To:    <[email-masked]>
> cc:
>
> Subject:    [Sigtran] M3UA : Multiple SGPs in SG
>
>
> I have some queries for the case, where an SG
> comprises of three SGPs
> and connected with 4 ASPs.
>
> Each ASP is connected with each SGP.
> So the list of associtions is :
>
>  SGP1 : ASP1 (Assoc1), ASP2 (Assoc2), ASP3 (Assoc3),
> ASP4 (Assoc4)
>  SGP2 : ASP1 (Assoc5), ASP2 (Assoc6), ASP3 (Assoc7),
> ASP4 (Assoc8)
>  SGP3 : ASP1 (Assoc9), ASP2 (Assoc10), ASP3
> (Assoc11), ASP4 (Assoc12)
>
> 1. AS in n+k redundancy mode : Suppose we configure
> n as 3.
>                    Now suppose ASP1 goes ACTIVE for
> all three SGPs.
>                    Does this mean that :
>
>                    n=3 limit is reached and AS
> should be made active.(e.g.
>                    this may mean that ASP is capable
> handling traffic
>                    otherwise it would have gone
> ACTIVE only via one SGP)
>                                      OR
>                    n=1 limit is reached. At least
> two more ASPs need to
>                    go ACTIVE via any of the SGPs in
> SG before AS can go
>                    ACTIVE on SG.
>
>
> 2. AS in override mode : Suppose an application
> server is being served by
> all
>                    4 ASPs in override mode. Does
> this mean that,
>
>                    at any given time, each SGP will
> have at the most one
>                    ASP
>                    ACTIVE for an AS
>                                       OR
>                    at any given time, an SG
> (combining all SGPs) will have
> at
>                    the most one ASP ACTIVE for an AS
>
>
> Umesh Vats
>
> _______________________________________________
> Sigtran mailing list
> [email-masked]
>  https://www1.ietf.org/mailman/listinfo/sigtran
>
>
> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/sigtran

__________________________________
Do you Yahoo!?
Yahoo! Calendar - Free online calendar with sync to Outlook(TM).
http://calendar.yahoo.com
_______________________________________________
Sigtran mailing list
[email-masked]
 https://www1.ietf.org/mailman/listinfo/sigtran

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: Tolga Asveren <[email-masked]>
Date: Thu, 5 Jun 2003 05:23:51 -0700 (PDT)

Hi Kamesh,

             associations
    | | | |    | | | |      | | | |
   +---------+------------+-----------+
   |   SGP1  |   SGP2     |   SGP3    |
   ************************************
   *              MTP3                *
   *         |            |           *
   * host1   |   host2    |  host3    *
   ************************************
     |   |       |     |       |    |
     |   |       |     |       |    |
                Links

Basically adjacent SS7 node is just aware that there
is a MTP3 peer and some links to communicate with it,
and will probably loadshare traffic based on SLS
betwen those links. Once the messages are inside the
SG-box, it is up to you, what to do with them (and I
would think although a lot of things inside SG are
implementation dependent, there is no direct mapping
between links and SGPs)

BTW, like you have said, it really migt be possible to
loadshare traffic between two ASPs, which are ACTIVE
for separate SGPs -and this also IMO would qualify as
2 ACTIVE ASPs because this is not two associations to
the same ASP-, but I still think this might bring
interoperability problems. To decide, when to start
traffic, IMO ASP and SGP should work in harmony. So,
IMO it is a good choice to leave the peers as SGP and
ASP for ASPTM procedures.

I also checked a sentence related with this topic -in
ASP Active Procedures- in RFC, there it stands that
"ASPs should coordinate the number of ACTIVE ASPs for
the AS", I think this may be clarified as "the number
of ACTIVE ASPs for the AS for a specific SGP".

   Tolga

> > "Umesh Vats" <[email-masked]>@ietf.org on
=== message truncated ===