Subject: [Sigtran] RE: M3UA IG: section 3.15 reworked

From: "Javier Pastor-Balbas (ECE)" <[email-masked]>
Date: Tue, 17 Jun 2003 16:51:16 +0200

This is the last version. There were still some unfinished sentences and inconsistences in the first text I sent. Now, they are fixed.

Cheers // Javier.

--------- 
Old text: (Section 4.3.2) 
---------

AS-DOWN: The Application Server is unavailable.  This state implies 
that all related ASPs are in the ASP-DOWN state for this AS. Initially the AS will be in this state. An Application Server is in the AS-DOWN state when it is removed from a configuration.

AS-INACTIVE: The Application Server is available but no application 
traffic is active (i.e., one or more related ASPs are in the ASP-
INACTIVE state, but none in the ASP-ACTIVE state).  The recovery 
timer T(r) is not running or has expired. 

AS-ACTIVE: The Application Server is available and application traffic is active.  This state implies that at least one ASP is in the ASP-ACTIVE state.

AS-PENDING: An active ASP has transitioned to ASP-INACTIVE or ASP-DOWN  and it was the last remaining active ASP in the AS.  A recovery timer T(r) SHOULD be started and all incoming signalling messages SHOULD be queued by the SGP. If an ASP becomes ASP-ACTIVE before T(r) expires, the AS is moved to the AS-ACTIVE state and all the queued messages will be sent to the ASP. 

If T(r) expires before an ASP becomes ASP-ACTIVE, and the SGP has no 
alternative, the SGP may stops queuing messages and discards all 
previously queued messages. The AS will move to the AS-INACTIVE state 
if at least one ASP is in ASP-INACTIVE state, otherwise it will move 
to AS-DOWN state. 

Figure 5 shows an example AS state machine for the case where the 
AS/ASP data is preconfigured.  For other cases where the AS/ASP 
configuration data is created dynamically, there would be differences 
in the state machine, especially at creation of the AS.  

                 Figure 5: AS State Transition Diagram

     +----------+   one ASP trans to ACTIVE   +-------------+
     |    AS-   |---------------------------->|     AS-     |      
     | INACTIVE |                             |   ACTIVE    |
     |          |<---                         |             |
     +----------+    \                        +-------------+
        ^   |         \ Tr Expiry,                ^    |
        |   |          \ at least one             |    |
        |   |           \ ASP in ASP-INACTIVE     |    |
        |   |            \                        |    |
        |   |             \                       |    |
        |   |              \                      |    |
one ASP |   | all ASP       \            one ASP  |    | Last ACTIVE
trans   |   | trans to       \           trans to |    | ASP trans to
to      |   | ASP-DOWN        -------\   ASP-     |    | ASP-INACTIVE
ASP-    |   |                         \  ACTIVE   |    | or ASP-DOWN
INACTIVE|   |                          \          |    |  (start Tr)
        |   |                           \         |    |
        |   |                            \        |    |
        |   v                             \       |    v         
     +----------+                          \  +-------------+
     |          |                           --|             |      
     | AS-DOWN  |                             | AS-PENDING  |
     |          |                             |  (queueing) |
     |          |<----------------------------|             |
     +----------+    Tr Expiry and no ASP     +-------------+
                     in ASP-INACTIVE state)   

 Tr = Recovery Timer

For example, where the AS/ASP configuration data is not created until 
Registration of the first ASP, the AS-INACTIVE state is entered 
directly upon the first successful REG REQ from an ASP.  Another 
example is where the AS/ASP configuration data is not created until the first ASP successfully enters the ASP-ACTIVE state.  In this case the AS-ACTIVE state is entered directly.

--------- 
New text: (Section 4.3.2) 
---------

AS-DOWN: The Application Server is unavailable.  This state implies that the number of ASPs being in ASP-INACTIVE or ASP-ACTIVE is less than "n". Initially the AS will be in this state. An Application Server is in the AS-DOWN state when it is removed from a configuration.

AS-INACTIVE: The Application Server is available but no application traffic is active. This implies that there are at least n ASPs in either ASP-INACTIVE or ASP-ACTIVE but the total number of ASPs in ASP-ACTIVE state has not reach n.  The recovery timer T(r) is not running or has expired. 

AS-ACTIVE: The Application Server is available and application traffic is active. The AS moves to this state after being in AS-INACTIVE and getting n ASPs in ASP-ACTIVE state or, after reaching AS-ACTIVE and keeping one or more ASPs in ASP-ACTIVE state. 

AS-PENDING: The last active ASP has transitioned from ASP-ACTIVE to ASP-INACTIVE or ASP-DOWN.  A recovery timer T(r) SHOULD be started and all incoming signalling messages SHOULD be queued by the SGP. If an ASP becomes ASP-ACTIVE before T(r) expires, the AS is moved to the AS-ACTIVE state and all the queued messages will be sent to the ASP. 

If T(r) expires before an ASP becomes ASP-ACTIVE, the SGP MAY stops queuing messages and discards all 
previously queued messages. The AS will move to the AS-INACTIVE state 
if at least the number of ASPs in ASP-INACTIVE sum n, otherwise it will move to AS-DOWN state. 

Figure 5 shows an example AS state machine for the case where the 
AS/ASP data is preconfigured and an n+k redundancy model. 

             Figure 5: AS State Transition Diagram

     +----------+          IA2AC              +-------------+
     |    AS-   |---------------------------->|     AS-     |
     | INACTIVE |                             |   ACTIVE    |
     |          |<-----------                 |             |
     +----------+            \                +-------------+
        ^   |                 \                    ^   |
        |   | IA2DN            \ PN2IA             |   | AC2PN
        |   |                   \                  |   | 
  DN2IA |   |                    \          PN2AC  |   | 
        |   v                     \                |   v
     +----------+                  \          +-------------+
     |          |                   ----------|             |
     | AS-DOWN  |                             | AS-PENDING  |
     |          |                  PN2DN      |  (queueing) |
     |          |<----------------------------|             |
     +----------+                             +-------------+

DN2IA: One ASP moves to ASP-INACTIVE causing that n ASPs are in either ASP-ACTIVE or ASP-INACTIVE states.

IA2DN: One ASP moves to ASP-DOWN causing that the number of ASPs in either ASP-ACTIVE or ASP-INACTIVE drops below n.

IA2AC: one ASP moves to ASP-ACTIVE, causing number of ASPs in the ASP-ACTIVE state to be n.

AC2PN: the last ASP in ASP-ACTIVE state moves to ASP-INACTIVE or ASP-DOWN states, causing the number of ASPs in ASP-ACTIVE drop below 1.

PN2AC: One ASP moves to ASP-ACTIVE.

PN2IA: T(r) Expiry, n or more ASPs are in ASP-INACTIVE.

PN2DN: T(r) Expiry, the number of ASPs in ASP-INACTIVE state is less than n.

As "n" ASPs are needed to handle the maximum engineered load of the AS, an AS becomes AS-ACTIVE right after n ASPs reach the ASP-ACTIVE state during the start-up phase. Once the traffic is flowing, an AS keeps the AS-ACTIVE state till the last ASP turns to another state different to ASP-ACTIVE, avoiding unnecessary traffic disturbances as long as there are ASPs available, in the assumption that the AS will not always be exposed to the maximum load. 

There are other cases where the AS/ASP configuration data is created dynamically. In those cases there would be differences in the state machine, especially at creation of the AS. For example, where the AS/ASP configuration data is not created until Registration of the first ASP, the AS-INACTIVE state is entered directly upon the nth successful REG REQ from an ASP belonging to that AS.  Another example is where the AS/ASP configuration data is not created until the nth ASP successfully enters the ASP-ACTIVE state.  In this latter case the AS-ACTIVE state is entered directly.

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 17 Jun 2003 13:07:32 -0600

Javier,

I believe the concensus from the last long discussions was to
remove section 3.15.

--brian

Javier Pastor-Balbas (ECE) wrote:                                                   (Tue, 17 Jun 2003 16:51:16)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: Tolga Asveren <[email-masked]>
Date: Tue, 17 Jun 2003 12:27:15 -0700 (PDT)

Hi Javier,

IMO the changes in general are nice, I have one
question/comment though:
For PN2AC transition, unless ASPs have knowledge of
T(r), they can't decide whether the first ACTIVE ASP
will make AS to switch to ACTIVE or not -because they
can't know whether AS has already switched to INACTIVE
after T(r) expiry or not- (AS state machine is
described from SG point of view but I believe we
should make it possible that ASPs and SGPs can have
the same AS state view) -in fact I am not sure,
whether to favor PN2AC transition by allowing it to
happen with only one ACTIVE ASP is the best solution
or not-.
Furthermore, if the proposed PN2AC is going to be kept
I would think PN2IA should be somethink like "T(r)
expiry, no ACTIVE ASPs"

    Tolga
--- "Javier Pastor-Balbas (ECE)"
<[email-masked]> wrote:
> This is the last version. There were still some
> unfinished sentences and inconsistences in the first
> text I sent. Now, they are fixed.
> 
> Cheers // Javier.
> 
> 
> --------- 
> that all related ASPs are in the ASP-DOWN state for
> this AS. Initially the AS will be in this state. An
> Application Server is in the AS-DOWN state when it
> is removed from a configuration.
> 
> AS-ACTIVE: The Application Server is available and
> application traffic is active.  This state implies
> that at least one ASP is in the ASP-ACTIVE state.
> 
> AS-PENDING: An active ASP has transitioned to
> ASP-INACTIVE or ASP-DOWN  and it was the last
> remaining active ASP in the AS.  A recovery timer
> T(r) SHOULD be started and all incoming signalling
> messages SHOULD be queued by the SGP. If an ASP
> becomes ASP-ACTIVE before T(r) expires, the AS is
> moved to the AS-ACTIVE state and all the queued
> messages will be sent to the ASP. 
> 
>      | INACTIVE |                             |  
> ACTIVE    |
>      |          |<---                         |     
>        |
>         ^   |         \ Tr Expiry,                ^ 
>   |
>         |   |          \ at least one             | 
>   |
>         |   |            \                        | 
>   |
>         |   |             \                       | 
>   |
>         |   |              \                      | 
>   |
>         |   |                           \         | 
>   |
>         |   |                            \        | 
>   |
>         |   v                             \       | 
>   v         
>      |          |                           --|     
>        |      
>      |          |                             | 
> (queueing) |
> example is where the AS/ASP configuration data is
> not created until the first ASP successfully enters
> the ASP-ACTIVE state.  In this case the AS-ACTIVE
> state is entered directly.
> 
> 
> --------- 
> AS-DOWN: The Application Server is unavailable. 
> This state implies that the number of ASPs being in
> ASP-INACTIVE or ASP-ACTIVE is less than "n".
> Initially the AS will be in this state. An
> Application Server is in the AS-DOWN state when it
> is removed from a configuration.
> 
> AS-INACTIVE: The Application Server is available but
> no application traffic is active. This implies that
> there are at least n ASPs in either ASP-INACTIVE or
> ASP-ACTIVE but the total number of ASPs in
> ASP-ACTIVE state has not reach n.  The recovery
> AS-ACTIVE: The Application Server is available and
> application traffic is active. The AS moves to this
> state after being in AS-INACTIVE and getting n ASPs
> in ASP-ACTIVE state or, after reaching AS-ACTIVE and
> keeping one or more ASPs in ASP-ACTIVE state. 
> 
> AS-PENDING: The last active ASP has transitioned
> from ASP-ACTIVE to ASP-INACTIVE or ASP-DOWN.  A
> recovery timer T(r) SHOULD be started and all
> incoming signalling messages SHOULD be queued by the
> SGP. If an ASP becomes ASP-ACTIVE before T(r)
> expires, the AS is moved to the AS-ACTIVE state and
> all the queued messages will be sent to the ASP. 
> 
> If T(r) expires before an ASP becomes ASP-ACTIVE,
> the SGP MAY stops queuing messages and discards all 
> if at least the number of ASPs in ASP-INACTIVE sum
> n, otherwise it will move to AS-DOWN state. 
> 
>      | INACTIVE |                             |  
> ACTIVE    |
>      |          |<-----------                 |     
>        |
>         ^   |                 \                    ^
>   |
>         |   |                   \                  |
>   | 
>   DN2IA |   |                    \          PN2AC  |
>   | 
>         |   v                     \                |
>   v
>      |          |                   ----------|     
>        |
=== message truncated ===

__________________________________
Do you Yahoo!?
The New Yahoo! Search - Faster. Easier. Bingo.
http://search.yahoo.com

---

From: "Samuel Dur D. Jeyaseelan" <[email-masked]>
Date: Tue, 17 Jun 2003 23:43:50 -0500 (CDT)

Pastor,

 I too believe that concensus was made to delete section 3.15 from IG 
 as RFC is sufficient to explain n+k case.

--Samuel

  Alcatel USA, Inc.                  Internet: <userid>@ssd.usa.alcatel.com
  1000 Coit Road, Plano, Texas 75075
  ******* The opinions expressed are not those of Alcatel USA, Inc. *******

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 18 Jun 2003 04:38:17 -0600

Javier,

Please see comments below...

> AS-DOWN: The Application Server is unavailable.  This state implies that the
> number of ASPs being in ASP-INACTIVE or ASP-ACTIVE is less than "n".
> Initially the AS will be in this state. An Application Server is in the
> AS-DOWN state when it is removed from a configuration.
> 
> AS-INACTIVE: The Application Server is available but no application traffic
> is active. This implies that there are at least n ASPs in either
> ASP-INACTIVE or ASP-ACTIVE but the total number of ASPs in ASP-ACTIVE state
> has not reach n.  The recovery timer T(r) is not running or has expired. 
> 
> AS-ACTIVE: The Application Server is available and application traffic is
> active. The AS moves to this state after being in AS-INACTIVE and getting n
> ASPs in ASP-ACTIVE state or, after reaching AS-ACTIVE and keeping one or
> more ASPs in ASP-ACTIVE state. 

I strongly disagree with the above.  The SG can move to the AS-ACTIVE state
with one ASP in the ASP-ACTIVE state: it need not wait until 'n'.  You are
still interpreting 'n' as some sort of absolute minimum number of ASPs,
when it was agreed that 'n' is the number of ASPs required to handle the
maximum engineered load.  As such, there is no reason why the SG cannot
place the AS AS-ACTIVE when one ASP is in the ASP-ACTIVE state for the AS.

The Old text is correct.  The above is incorrect.

> 
> AS-PENDING: The last active ASP has transitioned from ASP-ACTIVE to
> ASP-INACTIVE or ASP-DOWN.  A recovery timer T(r) SHOULD be started and all
> incoming signalling messages SHOULD be queued by the SGP. If an ASP becomes
> ASP-ACTIVE before T(r) expires, the AS is moved to the AS-ACTIVE state and
> If T(r) expires before an ASP becomes ASP-ACTIVE, the SGP MAY stops queuing
> messages and discards all previously queued messages. The AS will move to
> the AS-INACTIVE state if at least the number of ASPs in ASP-INACTIVE sum n,
> otherwise it will move to AS-DOWN state. 
> 
> IA2DN: One ASP moves to ASP-DOWN causing that the number of ASPs in either
> ASP-ACTIVE or ASP-INACTIVE drops below n.

Wrong, as per above.  If one ASP is in the ASP-ACTIVE state for the AS,
the AS is AS-ACTIVE.

> IA2AC: one ASP moves to ASP-ACTIVE, causing number of ASPs in the ASP-ACTIVE

Wrong, as per above.  If one ASP moves to the ASP-ACTIVE state for the AS,
the AS is AS-ACTIVE.

> 
> AC2PN: the last ASP in ASP-ACTIVE state moves to ASP-INACTIVE or ASP-DOWN
> states, causing the number of ASPs in ASP-ACTIVE drop below 1.
> 
> As "n" ASPs are needed to handle the maximum engineered load of the AS, an
> AS becomes AS-ACTIVE right after n ASPs reach the ASP-ACTIVE state during
> the start-up phase.

The above is incorrect per concensus.  For the start-up decision, the SG
can choose to either wait for 'n' or start traffic on the first active ASP.
What it MUST do not send NTFY(AS-ACTIVE) until it considers the AS in the
AS-ACTIVE state.

> Once the traffic is flowing, an AS keeps the AS-ACTIVE
> state till the last ASP turns to another state different to ASP-ACTIVE,
> avoiding unnecessary traffic disturbances as long as there are ASPs
> available, in the assumption that the AS will not always be exposed to the
> maximum load. 

It won't necessarily be exposed to maximum load on startup either.

Text below covers things internal to the SG only, and is unnecessary:

> 
> There are other cases where the AS/ASP configuration data is created
> dynamically. In those cases there would be differences in the state machine,
> especially at creation of the AS. For example, where the AS/ASP
> configuration data is not created until Registration of the first ASP, the
> AS-INACTIVE state is entered directly upon the nth successful REG REQ from
> an ASP belonging to that AS.  Another example is where the AS/ASP
> configuration data is not created until the nth ASP successfully enters the
> ASP-ACTIVE state.  In this latter case the AS-ACTIVE state is entered
> directly.

Stick with the old text.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/