Subject: RE: [Sigtran] M3UA : IPSP DE behaviour

From: [email-masked]
Date: Fri, 1 Aug 2003 13:46:20 +0530

Vivek,

In your example also IPSP C will send data for AS1 to IPSP A only.I dont
see any reason for IPSP C to send data to IPSP B because ASPAC message is
not sent to IPSP B. I dont see any possibility of single direction traffic
flow in your example also.

Kamesh Kaul
www.hssworld.com
Hughes Software Systems

"Vivek Toky" <[email-masked]> on 08/01/2003 01:23:11 PM

To:    Kamesh Kaul/HSS@HSS, [email-masked]
cc:

Subject:    RE: [Sigtran] M3UA : IPSP DE behaviour

Kamesh,

  Single direction traffic will still be possible. If you look at my
example carefully you will notice that in case of 3 IPSPs, it will be
possible. It may be for a short duration of time. In my example local
AS is already Active as it sent ASP Active message to one of the peer
IPSPs ( also got the ACK back )

please go through the example again .. waiting for comments ?

Vivek
>
>
>
>
> Hi Some comments below
>
>  When IPSP B receives ASPAC message from IPSP A for AS1 it marks
remote
> IPSP A active for remote AS1 and sends ASPAC ack back for AS1 to
IPSP A.Now
> with these message exchanges it means that IPSP A is ready to receive
> traffic for AS1.At this point of time IPSP B has not expressed its
> willingness to send data for any AS.IPSP B  cannot  send any
application
> data because its local applications are not active yet.So single
direction
> traffic flow will never occur.Now when IPSP B sends ASPAC message
for AS2
> to IPSP A and gets back ASPAC ack for AS2 it will give resume
indication to
> user now.AS1 and AS2 are basically same type of MTP3 users, and user
to
> user communication will only start if both users are ready and
active.
>
>
>     +-----------+              +-----------+
>     |           |              |           |
>     | IPSP A    |              | IPSP B    |
>     |           +--------------+           |
>     |           |              |           |
>     +-----------+              +-----------+
>
>         AS1                        AS2
>
> Kamesh Kaul
> www.hssworld.com
> Hughes Software Systems
>
>
>
>
>
> "VIvek Toky" <[email-masked]>@ietf.org on 07/31/2003 11:19:39 PM
>
> Sent by:    [email-masked]
>
>
> To:    "Tolga Asveren" <[email-masked]>, <[email-masked]>
> cc:
>
> Subject:    RE: [Sigtran] M3UA : IPSP DE behaviour
>
>
> Tolga,
>
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On
Behalf Of
> Tolga Asveren
> Sent: Thursday, July 31, 2003 10:19 AM
> To: [email-masked]
> Subject: RE: [Sigtran] M3UA : IPSP DE behaviour
>
>
> Vivek,
> --- Vivek Toky <[email-masked]> wrote:
> > Please see my comments inline
> >
> > > See my opigion online
> > >
> > > > -----Original Message-----
> > > > From: Vivek Toky [mailto:[email-masked]]
> > > > Sent: Thursday, July 31, 2003 2:42 PM
> > > > To: Tolga Asveren; [email-masked]
> > > > Subject: RE: [Sigtran] M3UA : IPSP DE behaviour
> > > >
> > > >
> > > > Hi Tolga,
> > > >   "Above case" means
> > > > "when AS1 has activated itself by sending
> > > >  ASP Active from both the IPSPs (A & B) but
> > > >  AS2 has sent ASP Active just to IPSP_A."
> > > >
> > > > In my opinion IPSP_C should loadshare the
> > traffic
> > > > as it has received ASP active from both the
> > IPSPs
> > > > so AS1 is accessible through both of these.
> > > > However, it is the responsibility of AS1 to
> > route
> > > > all the traffic towards AS2 through IPSP_A.
> > >
> > > If IPSP_B receive some traffic from IPSP_C BUT no
> > AS is ACTIVE for
> > it on
> > > IPSP_C can it route this traffic???
> > > CAN a SG send to a ss7 network a message receive
> > from an INACTIVE
> > ASP !
> > > I don't think so!
> > > IPSP DE must be considered as two ASP/SG head to
> > tail.
> > >
> > [Vivek]
> > AS is ACTIVE on IPSP_B (remember it sent ASP Active
> > message)
> [TOLGA]State of an AS is in the context of an ASP/SGP
> pair. That ASP (IPSP_B) sends ACTIVE does not mean
> that AS is ACTIVE for the SGP, unless SGP sends
> ASPAC-ACK (IPSP_C in your example)
>
> You are right, state of AS is in context of ASP, this was
> what I wanted to say. I am assuming that SGP did send
> ACTIVE ack back and ASP( for that AS) is active through
> the SGP from which it got the ACK back. Is it fine now...
>
>
> > As far as the SGP - ASP example see the following..
> >
> > 1. It is the AS which is Active or Inactive not ASP
> > 2. ASPTM ptocedures are between SGPs and ASPs not SG
> > and ASPs
> >
> > The local AS on the ASP may be active through some
> > other
> > SGP (say SGPy)to which an ACTIVE message has been
> > sent.
> > So SGP (say SGPx) should route the traffic to SS7
> > coming from an
> > ASP which is inactive for an AS, because that AS is
> > Active through some other SGP and SS7 destination
> > may still
> > be able to send the traffic towards that AS through
> > some
> > other SGP
> >
> > In M3UA outgoing and Incoming Traffic flows are
> > independent,
> > so why restrict the traffic ?
> >
> > > >
> > > > In either case I think it is worth mentioning in
> >
> > > > Implementor's guide whether Unidirectional
> > traffic
> > > > is possible between associations(in case of
> > > > IPSP DE) or not.It will avoid any further
> > > > confusion or possible interoperatibility issues.
> > > >
> > > > thanks,
> > > >
> > > > -Vivek.
> > > >
> > > > > Vivek,
> > > > > --- Vivek Toky <[email-masked]> wrote:
> > > > > > Hi All,
> > > > > >  What should be done in the following case:
> > > > > >
> > > > > >
> > > > > >       |IPSP_A                             |
> > > > > >   AS1 |      ---------------------- IPSP_C|
> > AS2
> > > > > >       |IPSP_B                             |
> > > > > >
> > > > > > IPSP_A and IPSP_B are in loadshare mode.
> > > > > >
> > > > > >   when AS1 has activated itself by sending
> > > > > > ASP Active from both the IPSPs (A & B) but
> > > > > > AS2 has sent ASP Active just to IPSP_A.
> > > > > >
> > > > > > What should IPSP_C do on receiving traffic
> > for AS1?
> > > > > >
> > > > > > a) Loadshare the traffic towards IPSP_A and
> > IPSP_B
> > > > > >
> > > > > > or
> > > > > >
> > > > > > b) It should send all the traffic to IPSP_A
> > and
> > > > > >    wait untill it sends ASP Active IPSP_B as
> > well.
> > > > > >    In the above case IPSP_B cannot send the
> > traffic
> > > > > >    towards IPSP_C but IPSP_C can.
> > > > > [TOLGA]It should send all traffic to IPSPS_A.
> > Which
> > > > > case do you refer as "the above case", a) or
> > b) ?
> > > > > >
> > > > > > thanks,
> > > > > > Vivek.
> > > > > >
> > > > >
> > > > >
> > > > > __________________________________
> > > > > Do you Yahoo!?
> > > > > Yahoo! SiteBuilder - Free, easy-to-use web
> > site design software
> > > > > http://sitebuilder.yahoo.com
> > > > >
> > > > >
> > _______________________________________________
> > > > > Sigtran mailing list
> > > > > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/sigtran
> > > > >
> > > > >
> > > >
> > > > --
> > > > Continuous Computing
> > > > http://www.ccpu.com
> > > >
> > > > _______________________________________________
> > > > Sigtran mailing list
> > > > [email-masked]
> > > > https://www1.ietf.org/mailman/listinfo/sigtran
> > > >
> > >
> > >
> >
> > --
> > Continuous Computing
> > http://www.ccpu.com
>
>
> __________________________________
> Do you Yahoo!?
> Yahoo! SiteBuilder - Free, easy-to-use web site design software
> http://sitebuilder.yahoo.com
>
> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/sigtran
>
>
> _______________________________________________
> Sigtran mailing list
> [email-masked]
>  https://www1.ietf.org/mailman/listinfo/sigtran
>
>
>
> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/sigtran
>
>

--
Continuous Computing
 http://www.ccpu.com

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Vivek Toky" <[email-masked]>
Date: Fri, 1 Aug 2003 11:41:39 -0700

Hi Kamesh,
  Although ASPAC message has not been sent to IPSP B, but the local AS is
still active and is sending and receiving traffic through IPSP A. Now on the
other side IPSP A and IPSP B are part of the same AS ( AS1 ). So following
points should be noted.

1. Bi-directional traffic between AS1 and AS2 is possible
2. IPSP B has already sent ASPAC and received ASPAC Ack, so it is ready to
receive traffic.

 So why don't we loadshare the traffic among IPSP A and IPSP B as the
traffic is anyway going to get to the same destination i.e. AS1

In the reverse direction AS1 can choose IPSP A to send traffic towards AS2,
as only IPSP A has received ASPAC from IPSP C (for AS2)

comments?

-Vivek.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
[email-masked]
Sent: Friday, August 01, 2003 1:16 AM
To: Vivek Toky
Cc: [email-masked]
Subject: RE: [Sigtran] M3UA : IPSP DE behaviour

Vivek,

Kamesh Kaul
www.hssworld.com
Hughes Software Systems

Kamesh,

Vivek
remote
IPSP A.Now
application
direction
for AS2
indication to
to
active.
Behalf Of

--
Continuous Computing
 http://www.ccpu.com

---

From: Tolga Asveren <[email-masked]>
Date: Fri, 1 Aug 2003 11:50:40 -0700 (PDT)

Vivek,

Last time I misunderstood your example, yes IMO you
are right, traffic should be loadshared between IPSP
A/B, because both of them have sent ASPAC and received
ASPAC-ACK from IPSP-C, showing that both of them are
ready to receive traffic for AS1 from IPSP-C.

   Tolga
--- Vivek Toky <[email-masked]> wrote:
> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of
> [email-masked]

__________________________________
Do you Yahoo!?
The New Yahoo! Search - Faster. Easier. Bingo.
http://search.yahoo.com

---

From: kamesh kaul <[email-masked]>
Date: Sat, 2 Aug 2003 20:23:46 -0700 (PDT)

Hi Vivek,
    I argee with you that if we intermix IPSP SE and
DE models we can start loadsharing traffic for AS2
among IPSP B and IPSP A even though IPSP B has not
received ASPAC message from IPSP c.It would result in
intermixing of two IPSP models.For some messages IPSP
C has to behave in DE manner and for other SE
behaviour is required.Lets take your example. On
receiving ASPAC messages from IPSP A and IPSP B for
AS1 IPSP C updates only remote IPSP'S states for AS1
behaving in DE manner.when IPSP c sends ASPAC for AS2
to IPSP A and receives ACK back then also IPSP C
changes its state to active for local AS2 behaving in
DE manner.Now as you said Bi-directional data is
flowing from IPSP C and IPSP A where as single
direction traffic is possible from IPSP C to IPSP B
(for AS2).Now assume IPSP A sends ASPIA message for
AS1 to IPSP C in this case IPSP c on receiving ASPIA
message has to update state of remote IPSP A in AS1
and also state of local IPSP C in local AS2 behaving
in SE manner.If IPSP C does not bother about local
state updation on receiving ASPIA from IPSP A, IPSP C
will continue to send data messages for AS2 to IPSP B
without receiving anything from other side. This will
result in single direction traffic from IPSP C to AS1
without the knowledge of IPSP C.If we associate AS
state with local and peer IPSP's (in your example
AS2's state with IPSP c and each peer IPSPA and IPSPB,
AS2's state with IPSP C and each peer IPSP's) single
direction traffic flow is not possible. Please comment

Regards
Kamesh        
> > > > CAN a SG send to a ss7 network a message
=== message truncated ===

__________________________________
Do you Yahoo!?
Yahoo! Calendar - Free online calendar with sync to Outlook(TM).
http://calendar.yahoo.com

---

From: "Vivek Toky" <[email-masked]>
Date: Mon, 4 Aug 2003 21:17:43 -0700

Kamesh,
  Please see comments inline
-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
kamesh kaul
Sent: Saturday, August 02, 2003 8:24 PM
To: Vivek Toky
Cc: [email-masked]
Subject: RE: [Sigtran] M3UA : IPSP DE behaviour

Hi Vivek,
in SE manner.

[Vivek]
 You have a good point but I did not understand why would we need to change
the state of IPSP C in this case ( when IPSP A sends ASPIA to IPSP C). When
IPSP A sends ASPIA message for AS1 to IPSP C then only IPSP A's state will
change in local AS1 and the corresponding remote AS1 on the other side. You
are right that AS1 will not be able to receive traffic through IPSP A , but
that doesnot restrict AS1 to send traffic from IPSP A. Note: AS1 is still UP
and ready to process data and so is AS2. If AS1 wants to go down and not
process data at all then it should sent Inactive through both the IPSPs (
IPSP A and IPSP B). Now the question arises that what should IPSP A do if it
receives data from AS1 which has inactivated itself from both  the IPSPs and
is now totally unable to receive DATA ? ... following points should be noted
1. If AS1 doesn't want to receive data, why we care if the data sent by AS1
went through all the way to AS2.
2. Now we know that AS2 won't be able to send data to AS1 atall so it can
take recovery and De-activate itself through IPSP A (to which it sent ASP
Active and got Active Ack.)

does it make sense ? please comment..

If IPSP C does not bother about local

Regards
Kamesh