Subject: [Sigtran] question about m3UA

From: "Ling-Chih Kao" <[email-masked]>
Date: Mon, 4 Aug 2003 14:10:01 +0800

Should ASP3 in the Section 5.1.4 of <draft-ietf-sigtran-m3ua-implementors-guide-04.txt> receive NOTIFY(AS-INACTIVE)?

Thanls

Ling-Chih Kao

---

From: "J.Javier Pastor (EE/EEM)" <[email-masked]>
Date: Thu, 21 Aug 2003 09:26:22 +0200

Hi Samuel, 

Yes, this seems to be in line with the conclusions about n+k redundancy...

Thanks // Javier.

> -----Original Message-----
> From: Samuel Dur D. Jeyaseelan [mailto:[email-masked]]
> Sent: miércoles, 20 de agosto de 2003 21:39
> To: Ling-Chih Kao
> Cc: sigtran
> Subject: Re: [Sigtran] question about m3UA
> 
> 
> 
> Pastor,
> 
> IG section 5.1.4 and 5.2.3 are co-related, but section 5.2.3 
> diagram is
> wrong because ASP2 is alive so SGP will send a 
> NTFY(insuf-resources-at-AS)
> to INACTIVE-ASPes.
> 
> Section 5.2.3 diagram should look like this
> 
>         SGP                 ASP1                ASP2          
>       ASP3
>           |                   |                   |           
>         |
>           |<----ASP Inact.----|                   |           
>         |
>           |---ASP Inact Ack-->|                   |           
>         |
>           |                   |                   |           
>         |
>           |NOTIFY(Ins. ASPs)->|                   |           
>         |
>           |                   |                   |           
>         |
>           |                   |                   |           
>         |
>           |---------------------------------------NOTIFY(Ins. 
> ASPs)-->|
>           |                   |                   |           
>         |
>           |                   |                   |           
>         |
>           |<----------------------------------------ASP Act 
> (Ldshr)---|
>           |------------------------------------------ASP Act 
> (Ack)--->|
>           |                   |                   |           
>         |
>           |-NTFY(AS-ACTIVE)-->|                   |           
>         |
>           |-------------------NOTIFY(AS-ACTIVE)-->|           
>         |
>           
> |---------------------------------------NOTIFY(AS-ACTIVE)-->|
>           |                   |                   |           
>         |
>           |                   |                   |           
>         |
> 
> 
> Did you remeber this, we discussed few months back that in 
> n+k reduntancy
> case SGP should not stop the traffic until 'n' becomes zero.
> 
> --Samuel
> 
> On Wed, 20 Aug 2003, Ling-Chih Kao wrote:
> 
> >  Samuel
> > 
> > The example in sec. 5.1.4 and 5.2.3 is for "2+1" sparing 
> loadsharing case.
> > The original active ASP is ASP1 and ASP2. Later, ASP1 
> withdraws  and ASP3
> > overrides it. ASP2 is still active; therefore, not all ASPs 
> go into ASP
> > inactive. Am I wrong?
> > 
> > In  the example of sec. 5.1.4  for "2+1" sparing 
> loadsharing case, the
> > decision of  ASPs taking care traffic is still by a craft means via
> > configured database. (In this example, ASP1 and ASP2 take 
> care traffic
> > first.)
> > Or, depend on which ASP send ASP active to SGP first?
> > 
> > Thanks
> > 
> > Ling-Chih Kao
> > 
> > 
> > ----- Original Message -----
> > From: "Samuel Dur D. Jeyaseelan" <[email-masked]>
> > To: "Ling-Chih Kao" <[email-masked]>
> > Cc: "sigtran" <[email-masked]>
> > Sent: Tuesday, August 19, 2003 7:58 PM
> > Subject: Re: [Sigtran] question about m3UA
> > 
> > 
> > >
> > > Ling-Chih Kao,
> > >
> > > comments in-line.
> > >
> > > On Tue, 19 Aug 2003, Ling-Chih Kao wrote:
> > >
> > > > Hi, Samuel
> > > >
> > > > You mentioned that NTFY("AS-Pending") - sending this to all
> > INACTIVE-ASPs is
> > > > mandatory because any of the INACTIVE-ASP will become ACT.
> > > > However, from the definition of M3UA Implementor's 
> Guide, it said that
> > > > "AS-PENDING: The last active ASP has transitioned from 
> ASP-ACTIVE to
> > > >    ASP-INACTIVE or ASP-DOWN.  A recovery timer T(r) 
> SHOULD be started
> > > >    and all incoming signalling messages SHOULD be 
> queued by the SGP. If
> > > >    an ASP becomes ASP-ACTIVE before T(r) expires, the 
> AS is moved to the
> > > >    AS-ACTIVE state and all the queued messages will be 
> sent to the ASP".
> > > >
> > > > ASP3 overrides ASP1 when ASP1 want to withdraw (example 
> in sec. 5.2.3
> > (2+1
> > > > redundancy model)).The AS still has an active ASP 
> (ASP2). Why did SGP
> > send
> > > > NTFY("AS-Pending") to all ASPs? Are this wrong?
> > >
> > > NTFY(AS-Pending) is sent only when the final ACTIVE ASP goes down.
> > > How do you say ASP2 is ACTIVE?
> > >
> > > >
> > > > As mentioned in sec. 5.2.1 of  RFC 3332, how did SGP 
> instruct which ASP
> > > > should send ASP Active to SGP  when SGP M3UA layer 
> detects the loss of
> > the
> > > > peer M3UA?
> > > My understanding is , it is not the SGP which instructs 
> which ASP to
> > > come-up, but it is the craft person's local database 
> configuration at
> > > Application Server side.
> > >
> > > If SGP detects loss of peer M3UA layer (may be ASP1 does 
> not respond with
> > > heartbeat-ack)SGP will send a NTFY message to ASP2 so 
> that ASP2 will
> > > become ACTIVE.
> > >
> > > >
> > > > As mentioned in sec. 5.2.2 of RFC 3332, What is the 
> reason for ASP2 to
> > > > override ASP1 ? How did ASP2 know to send ASP Active to 
> SGP? When the
> > model
> > > > is 2+2 redundancy model, there are two backup ASPs, 
> which ASP will
> > override
> > > > original ASP?
> > >
> > > What is the reason for ASP2 to override ASP1 ?
> > > See, everything is controlled by a craft means via 
> configured database.
> > > Say for example, traffic is smooth between SGP1 and ASP1 
> but after some
> > > time craft wants to do some kind of databse modification 
> at ASP1 so he
> > > make ASP2 to send the ASP-ACTIVE, Is this ok?
> > >
> > > All qtns are answered above with respect to local 
> database configuration
> > > at Application Server.
> > >
> > > > Ling-Chih Kao
> > > >
> > > > ----- Original Message -----
> > > > From: "Samuel Dur D. Jeyaseelan" <[email-masked]>
> > > > To: "Ling-Chih Kao" <[email-masked]>
> > > > Cc: <[email-masked]>; "sigtran" <[email-masked]>
> > > > Sent: Wednesday, August 13, 2003 5:18 PM
> > > > Subject: Re: [Sigtran] question about m3UA
> > > >
> > > >
> > > > >
> > > > > Ling-Chih Kao,
> > > > >
> > > > > On Wed, 13 Aug 2003, Ling-Chih Kao wrote:
> > > > >
> > > > > > Hi, Samuel
> > > > > >
> > > > > > 1.
> > > > > > ASP3  in Sec. 5.1.4 did not send ASP Act. to SGP; 
> however,  it
> > received
> > > > > > NOTIFY (AS-ACTIVE).
> > > > > >
> > > > > > This NOTIFY is also optional whether ASP3 send ASP 
> Act. to SGP or
> > not.
> > > > > > That's right ?
> > > > > >
> > > > > As per RFC it is mandatory.Basically NTFY has been 
> used not only to
> > > > > reflect the AS state but also used like 'insufficent 
> # of ASPs' to all
> > > > > INACTIVE ASPs.
> > > > > NTFY(AS-ACTIVE) - sending this to all INACTIVE-ASPs 
> is mandatory as
> > per
> > > > >                   RFC, But i dont see any purpose here.
> > > > >
> > > > > NTFY("Insuff # of ASPs) - sending this to all INACTIVE-ASPs is
> > mandatory
> > > > >                           because any of the 
> INACTIVE-ASP will become
> > ACT.
> > > > >
> > > > > NTFY("AS-Pending") - sending this to all 
> INACTIVE-ASPs is mandatory
> > > > >                      because any of the INACTIVE-ASP 
> will become ACT.
> > > > >
> > > > > > Should ASP3 send  ASP Act. to SGP?
> > > > > >
> > > > > In our example(n+k case), if n=2 then 2 ASPs(say ASP1 
> and ASP2) will
> > send
> > > > > ASP-ACT messages.But you can have a test case where 
> you will be
> > sending
> > > > > ASP-ACT from ASP3, this case SGP will honour that ASP-ACT.But
> > basically
> > > > > 'k' ASP is used for backup purpose so unless ASP1 or 
> ASP2 goes down
> > ASP3
> > > > > will not be sending ASP3-ACT.
> > > > >
> > > > > > 2.
> > > > > > Should ASP3 send  ASP UP to SGP?
> > > > > >
> > > > > Yes, because you make the backup ASP ready to a 
> certain level so that
> > > > > when any one of the ASCTIVE-ASP goes down, backup ASP 
> will take
> > minimum
> > > > > time to take up the load.
> > > > >
> > > > > > If ASP3 did not sent ASP UP to SGP, reception of 
> NOTIFY(AS-INACTIVE)
> > is
> > > > also
> > > > > > optional. Or, ASP3 will not receive  
> NOTIFY(AS-INACTIVE) because
> > ASP3
> > > > does
> > > > > > not sent ASP UP to SGP.
> > > > > This already Brian has answered.NTFY will not be 
> processed in DOWN
> > state.
> > > > >
> > > > > --Samuel
> > > > > >
> > > > > >
> > > > > > Ling-Chih Kao
> > > > > >
> > > > > > ----- Original Message -----
> > > > > > From: "Samuel Dur D. Jeyaseelan" 
> <[email-masked]>
> > > > > > To: "Brian F. G. Bidulock" <[email-masked]>
> > > > > > Cc: "Ling-Chih Kao" <[email-masked]>; "sigtran"
> > <[email-masked]>
> > > > > > Sent: Wednesday, August 13, 2003 12:27 PM
> > > > > > Subject: Re: [Sigtran] question about m3UA
> > > > > >
> > > > > >
> > > > > >
> > > > > > Brian,
> > > > > >  If it is mandatory to send NTFY(AS-STATE) to all 
> ASPes(other than
> > > > down),
> > > > > >  Why dont we send SS7 node availability status(like
> > DUNA,DAVA,DRST...)
> > > > > >  to all INACTIVE-ASPes?(because anyway when 
> INACTIVE-ASP moves to
> > ACTIVE
> > > > > >  ASP, it should know the status of SS7 nodes but 
> finally it was
> > decided
> > > > > >  that newly active ASP will send an DAUD and gets 
> the SS7 node(s)
> > status
> > > >
> > > > > >  or SGP may send SS7 node(s) status to the newly 
> active ASP.)
> > > > > >  This i suggested long back(i think you remeber) 
> but you strongly
> > > > opposed
> > > > > >  it. Now you are partially true with my old arguments.
> > > > > >
> > > > > > --Samuel
> > > > > >
> > > > > >   Alcatel USA, Inc.                  Internet:
> > > > <userid>@ssd.usa.alcatel.com
> > > > > >   1000 Coit Road, Plano, Texas 75075
> > > > > >   ******* The opinions expressed are not those of 
> Alcatel USA, Inc.
> > > > *******
> > > > > >
> > > > > > On Tue, 12 Aug 2003, Brian F. G. Bidulock wrote:
> > > > > >
> > > > > > > Ling-Chih,
> > > > > > >
> > > > > > > Mandatory.  All ASP-INACTIVE ASPs for an AS 
> receive notifications
> > > > > > > of state change.  ASP3 is ASP-INACTIVE in this 
> case and must
> > receive
> > > > > > > the notification.
> > > > > > >
> > > > > > > The contentious case is when an ASP (ASP3) 
> becomes ASP-INACTIVE
> > from
> > > > > > > ASP-DOWN.  I believe that the SGP should notify 
> the newly inactive
> > > > > > > ASP of the current state of the AS (which it did 
> not receive
> > before).
> > > > > > > Samuel thinks that they should somehow guess the 
> state of the AS.
> > > > > > >
> > > > > > > --brian
> > > > > > >
> > > > > > > Ling-Chih Kao wrote:
> > > > > > (Wed, 13 Aug 2003 08:55:25)
> > > > > > > > Hi, Brian and Samuel
> > > > > > > >
> > > > > > > > The answer for both of you is different.
> > > > > > > > See again in Sec. 5.1.4, the ASP3 is for 
> backup. ASP3 did not
> > sent
> > > > ASP
> > > > > > Act.
> > > > > > > > to SGP. Why did it receive NOTIFY(AS-ACTIVE) ? 
> This is optional
> > or
> > > > > > > > mandatory?
> > > > > > > >
> > > > > > > > Thanks
> > > > > > > >
> > > > > > > > Ling-Chih Kao
> > > > > > > >
> > > > > > > >
> > > > > > > >
> > > > > > > > ----- Original Message -----
> > > > > > > > From: "Samuel Dur D. Jeyaseelan" 
> <[email-masked]>
> > > > > > > > To: "Brian F. G. Bidulock" <[email-masked]>
> > > > > > > > Cc: "Ling-Chih Kao" <[email-masked]>; "sigtran"
> > > > <[email-masked]>
> > > > > > > > Sent: Friday, August 08, 2003 6:08 PM
> > > > > > > > Subject: Re: [Sigtran] question about m3UA
> > > > > > > >
> > > > > > > >
> > > > > > > >
> > > > > > > > Brian,
> > > > > > > >  Huh, it is not an implementation dependent, rfc says
> > > > > > > >  ASPs which are in that AS should coordinate 
> among themselves
> > the
> > > > number
> > > > > > > >  of active ASPs in the AS.So it is clear to SGP 
> that first
> > arrived
> > > > > > > >  'n' ASPs will receive NTFY(AS-INACT) message.
> > > > > > > >
> > > > > > > >  If you want to send NTFY(AS-INACT) to all 
> ASPes(other than DOWN
> > > > state)
> > > > > > > >  you are not restricted but it is not mandatory 
> to send, thats
> > what
> > > > i
> > > > > > > >  am saying from the beginning.
> > > > > > > >
> > > > > > > >  Keep IG as it is.
> > > > > > > > --Samuel
> > > > > > > >
> > > > > > > >   Alcatel USA, Inc.                  Internet:
> > > > > > <userid>@ssd.usa.alcatel.com
> > > > > > > >   1000 Coit Road, Plano, Texas 75075
> > > > > > > >   ******* The opinions expressed are not those 
> of Alcatel USA,
> > Inc.
> > > > > > *******
> > > > > > > >
> > > > > > > > On Fri, 8 Aug 2003, Brian F. G. Bidulock wrote:
> > > > > > > >
> > > > > > > > > Samuel,
> > > > > > > > >
> > > > > > > > > Maybe clear to the ASPs depending on 
> implementation, but not
> > > > > > > > > clear to the SGP.  If the NTFY(AS-INACTIVE) 
> is not going to be
> > > > > > > > > used by any of the ASPs, why send it in the 
> first place?
> > > > > > > > > If it serves a purpose, it should be sent to 
> all of them to
> > avoid
> > > > > > > > > the race condition.
> > > > > > > > >
> > > > > > > > > --brian
> > > > > > > > >
> > > > > > > > > Samuel Dur D. Jeyaseelan wrote:
> > > > > > > > (Fri, 08 Aug 2003 04:36:50)
> > > > > > > > > >
> > > > > > > > > > Brian,
> > > > > > > > > >  We all know that in n+k redundancy case 
> that ASPes will
> > > > coordinate
> > > > > > > > > >  among themselves the number of active ASPs 
> in the AS, here
> > it
> > > > is
> > > > > > > > > >  clear that who is going to go to ACTIVE 
> state then where is
> > the
> > > > > > > > > >  question of race condition?
> > > > > > > > > >
> > > > > > > > > > --Samuel
> > > > > > > > > >
> > > > > > > > > >   Alcatel USA, Inc.                  Internet:
> > > > > > > > <userid>@ssd.usa.alcatel.com
> > > > > > > > > >   1000 Coit Road, Plano, Texas 75075
> > > > > > > > > >   ******* The opinions expressed are not 
> those of Alcatel
> > USA,
> > > > Inc.
> > > > > > > > *******
> > > > > > > > > >
> > > > > > > > > > On Fri, 8 Aug 2003, Brian F. G. Bidulock wrote:
> > > > > > > > > >
> > > > > > > > > > > Samuel,
> > > > > > > > > > >
> > > > > > > > > > > What if ASP1 and ASP3 receive it but ASP2 
> did not, just
> > > > because
> > > > > > > > > > > ASP3's ASPUP arrived before ASP2's.  That 
> is a race
> > condition.
> > > > > > > > > > > This is why it is wise (and "SHOULD" is 
> appropriate) to
> > avoid
> > > > > > > > > > > the race condition by sending 
> NTFY(AS-INACTIVVE) to all of
> > the
> > > > > > > > > > > ASPs when they come up.  It should not be 
> optional.  It is
> > > > > > necessary
> > > > > > > > > > > to proper interworking that this race be broken.
> > > > > > > > > > >
> > > > > > > > > > > --brian
> > > > > > > > > > >
> > > > > > > > > > > Samuel Dur D. Jeyaseelan wrote:
> > > > > > > > (Fri, 08 Aug 2003 04:17:31)
> > > > > > > > > > > >
> > > > > > > > > > > > Brian,
> > > > > > > > > > > >  Ok,say ASP1,ASP2 and ASP3 send ASP-UP message
> > respectively,
> > > > but
> > > > > > > > ASP1 and
> > > > > > > > > > > >  ASP2 received NTFY(AS-INACT) but ASP3 did not.
> > > > > > > > > > > >  Now ASP1 sends ASP-ACT message then 
> ASP3 sends ASP-ACT
> > > > message,
> > > > > > > > > > > >  here it is mandatory to send 
> NTFY(AS-ACT) to both
> > > > ASPes(ASP1
> > > > > > and
> > > > > > > > ASP3).
> > > > > > > > > > > >
> > > > > > > > > > > >  This is the reason i said it is an 
> optional of sending
> > > > > > > > NTFY(AS-INACT)
> > > > > > > > > > > >  to 'n+1'th ASP.
> > > > > > > > > > > >
> > > > > > > > > > > > --Samuel
> > > > > > > > > > > >
> > > > > > > > > > > >   Alcatel USA, Inc.                  Internet:
> > > > > > > > <userid>@ssd.usa.alcatel.com
> > > > > > > > > > > >   1000 Coit Road, Plano, Texas 75075
> > > > > > > > > > > >   ******* The opinions expressed are 
> not those of
> > Alcatel
> > > > USA,
> > > > > > Inc.
> > > > > > > > *******
> > > > > > > > > > > >
> > > > > > > > > > > > On Fri, 8 Aug 2003, Brian F. G. Bidulock wrote:
> > > > > > > > > > > >
> > > > > > > > > > > > > Samuel,
> > > > > > > > > > > > >
> > > > > > > > > > > > > Yes, I have a problem, because it is 
> a race condition.
> > > > > > > > > > > > >
> > > > > > > > > > > > > --brian
> > > > > > > > > > > > >
> > > > > > > > > > > > > Samuel Dur D. Jeyaseelan wrote:
> > > > > > > > (Fri, 08 Aug 2003 04:04:50)
> > > > > > > > > > > > > >
> > > > > > > > > > > > > > Brian,
> > > > > > > > > > > > > >
> > > > > > > > > > > > > >   I meant first 2 ASPes will receive NTFY
> > > > messages.Sending
> > > > > > NTFY
> > > > > > > > to
> > > > > > > > > > > > > >   3rd ASP is an optional.Do you 
> have any problem
> > here?
> > > > > > > > > > > > > >
> > > > > > > > > > > > > > --Samuel
> > > > > > > > > > > > > >
> > > > > > > > > > > > > >   Alcatel USA, Inc.                 
>  Internet:
> > > > > > > > <userid>@ssd.usa.alcatel.com
> > > > > > > > > > > > > >   1000 Coit Road, Plano, Texas 75075
> > > > > > > > > > > > > >   ******* The opinions expressed 
> are not those of
> > > > Alcatel
> > > > > > USA,
> > > > > > > > Inc. *******
> > > > > > > > > > > > > >
> > > > > > > > > > > > > > On Fri, 8 Aug 2003, Brian F. G. 
> Bidulock wrote:
> > > > > > > > > > > > > >
> > > > > > > > > > > > > > > Samuel,
> > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > None of the ASPs are handling 
> traffic at that
> > point.
> > > > Who
> > > > > > is
> > > > > > > > to say
> > > > > > > > > > > > > > > that ASP1 and ASP2 are the 'n' 
> and ASP3 is the
> > 'k'.
> > > > > > Perhaps
> > > > > > > > ASP2
> > > > > > > > > > > > > > > and ASP3 are the 'n' and ASP1 is 
> the 'k'.  The SGP
> > > > surely
> > > > > > > > doesn't know.
> > > > > > > > > > > > > > > Sending NTFY(AS-INACTIVE) to all 
> of them is the
> > wisest
> > > > > > choice.
> > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > --brian
> > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > Samuel Dur D. Jeyaseelan wrote:
> > > > > > > > (Fri, 08 Aug 2003 03:47:30)
> > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > Ling-Chih Kao and Brian,
> > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > In n+k reduntancy case,when n=2 
> that means ASP1
> > and
> > > > ASP2
> > > > > > are
> > > > > > > > going to
> > > > > > > > > > > > > > > > handle the traffic.So sending 
> NTFY to these
> > ASPes is
> > > > > > > > mandatory.
> > > > > > > > > > > > > > > > Sending NTFY to ASP3 is an 
> optional because it
> > is
> > > > not
> > > > > > going
> > > > > > > > to handle
> > > > > > > > > > > > > > > > the traffic.When ASP1 or ASP2 
> goes down then
> > ASP3
> > > > will
> > > > > > come
> > > > > > > > up to take
> > > > > > > > > > > > > > > > over the traffic this case SGP 
> will send a NTFY
> > > > message
> > > > > > with
> > > > > > > > AS state,
> > > > > > > > > > > > > > > > here it is mandatory to send 
> NTFY to ASP3.
> > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > --Samuel
> > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > >   Alcatel USA, Inc.             
>      Internet:
> > > > > > > > <userid>@ssd.usa.alcatel.com
> > > > > > > > > > > > > > > >   1000 Coit Road, Plano, Texas 75075
> > > > > > > > > > > > > > > >   ******* The opinions 
> expressed are not those
> > of
> > > > > > Alcatel
> > > > > > > > USA, Inc. *******
> > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > On Fri, 8 Aug 2003, Ling-Chih Kao wrote:
> > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > > Dear Samuel Dur D. Jeyaseelan
> > > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > > From the new definition of 
> AS-INACTIVE in sec
> > > > 4.3.2 of
> > > > > > > > > > > > > > > > >
> > > > draft-ietf-sigtran-m3ua-implementors-guide-04.txt>,
> > > > > > the AS
> > > > > > > > becomes
> > > > > > > > > > > > > > > > > AS-INACTIVE when there are at 
> least n ASPs in
> > > > either
> > > > > > > > ASP-INACTIVE or
> > > > > > > > > > > > > > > > > AS-ACTIVE.
> > > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > > Therefore, in sec. 5.1.4, AS becomes
> > AS-INACTIVE
> > > > when
> > > > > > SGP
> > > > > > > > receives two ASP
> > > > > > > > > > > > > > > > > UP (from ASP1 and ASP2).  
> However, when the
> > SGP
> > > > > > receives
> > > > > > > > ASP UP from ASP3,
> > > > > > > > > > > > > > > > > SGP does not  send NOTIFY 
> (AS-INACTIVE) to
> > ASP3. I
> > > > > > want to
> > > > > > > > know whether it
> > > > > > > > > > > > > > > > > is optional or not?
> > > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > > Thanks.
> > > > > > > > > > > > > > > > > Ling-Chih Kao
> > > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > > ----- Original Message -----
> > > > > > > > > > > > > > > > > From: "Samuel Dur D. Jeyaseelan"
> > > > > > > > <[email-masked]>
> > > > > > > > > > > > > > > > > To: "Ling-Chih Kao" 
> <[email-masked]>
> > > > > > > > > > > > > > > > > Cc: "sigtran" <[email-masked]>
> > > > > > > > > > > > > > > > > Sent: Friday, August 08, 2003 3:41 PM
> > > > > > > > > > > > > > > > > Subject: Re: [Sigtran] 
> question about m3UA
> > > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > > Ling-Chih Kao,
> > > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > > NTFY(AS-INACT) is sent to all 
> all available
> > peer
> > > > > > ASPes.
> > > > > > > > > > > > > > > > > Note: Available peer means an 
> ASP which
> > received
> > > > > > > > ASP-UP-ACK
> > > > > > > > > > > > > > > > > in response to ASP-UP 
> messages.(as per RFC
> > section
> > > > > > > > 4.3.4.1).
> > > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > > If you active the AS as soon 
> as a single ASP
> > goes
> > > > to
> > > > > > > > ASP-INACT
> > > > > > > > > > > > > > > > > state then it is obvious that 
> whoever sends
> > ASP-UP
> > > > > > message
> > > > > > > > to
> > > > > > > > > > > > > > > > > SGP, immediately SGP will send a
> > NTFY(AS-INACT) to
> > > > the
> > > > > > > > concern
> > > > > > > > > > > > > > > > > ASP followd by ASP-UP-ACK.
> > > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > > --Samuel
> > > > > > > > > > > > > > > > >   Alcatel USA, Inc.           
>        Internet:
> > > > > > > > <userid>@ssd.usa.alcatel.com
> > > > > > > > > > > > > > > > >   1000 Coit Road, Plano, Texas 75075
> > > > > > > > > > > > > > > > >   ******* The opinions 
> expressed are not those
> > of
> > > > > > Alcatel
> > > > > > > > USA, Inc. *******
> > > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > > On Fri, 8 Aug 2003, Ling-Chih 
> Kao wrote:
> > > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > > > Hi all,
> > > > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > > > After SGP receives the ASP 
> UP from ASP1, SGP
> > > > should
> > > > > > > > immediately send
> > > > > > > > > > > > > > > > > > NOTIFY(AS-INACTIVE)   to 
> all ASP in the same
> > AS.
> > > > Is
> > > > > > this
> > > > > > > > right?
> > > > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > > > Thanks
> > > > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > > > Ling-Chih Kao
> > > > > > > > > > > > > > > > > > ----- Original Message -----
> > > > > > > > > > > > > > > > > > From: "Samuel Dur D. Jeyaseelan"
> > > > > > > > <[email-masked]>
> > > > > > > > > > > > > > > > > > To: "Brian F. G. Bidulock"
> > > > <[email-masked]>
> > > > > > > > > > > > > > > > > > Cc: <[email-masked]>; 
> "Ling-Chih Kao"
> > > > > > > > <[email-masked]>;
> > > > > > > > > > > > > > > > > "sigtran"
> > > > > > > > > > > > > > > > > > <[email-masked]>
> > > > > > > > > > > > > > > > > > Sent: Tuesday, August 05, 
> 2003 1:22 PM
> > > > > > > > > > > > > > > > > > Subject: Re: [Sigtran] 
> question about m3UA
> > > > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > > > Brian,
> > > > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > > > On Mon, 4 Aug 2003, Brian 
> F. G. Bidulock
> > wrote:
> > > > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > > > > kakaul,
> > > > > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > > > > But I think that we 
> agreed that it would
> > be
> > > > wise
> > > > > > to
> > > > > > > > tell newly inactive
> > > > > > > > > > > > > > > > >
> > > > > > > >   ------------------
> > > > > > > > > > > > > > > > > > > ASPs that state of the 
> AS.  Also, in the
> > > > diagram,
> > > > > > the
> > > > > > > > state of the AS
> > > > > > > > > > > > > > > > > >   -------------------------
> > > > > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > > > > What does ASP3 do with 
> NOTIFY(AS-INACTIVE)?
> > > > > > > > > > > > > > > > > > Whenever AS state-change 
> happens at SGP, a
> > NTFY
> > > > will
> > > > > > be
> > > > > > > > sent to all ASPes
> > > > > > > > > > > > > > > > > > (other than DOWN-ASPes) 
> pertaining to the
> > same
> > > > RC
> > > > > >
> > > > >
> > > >
> > > >
> > >
> > >
> > > _______________________________________________
> > > Sigtran mailing list
> > > [email-masked]
> > > https://www1.ietf.org/mailman/listinfo/sigtran
> > 
> > 
> 
> 
> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/sigtran
> 

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran