Subject: Re: [Sigtran] SUA - RC in CLDT

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 8 Aug 2003 00:30:38 -0600

Anzile,,

Anzile, Christophe wrote:                                                          (Thu, 07 Aug 2003 11:24:09)
> Brian (& Valerie),
> 
> Please do not make RC mandatory in ASPAC, or you'll have strong side effects on the draft..
> This is not consistent at all with what's written in the draft page 92, ie
>  [ it is not necessary for the ASP to 
>    include all Routing Contexts of interest in a single ASP Active 
>    message, thus requesting to become active in all Routing Contexts at 
>    the same time.  Multiple ASP Active messages MAY be used to activate 
>    within the Application Servers independently, or in sets.  In the 
>    case where an ASP Active message does not contain a Routing Context 
>    parameter, the receiver must know, via configuration data, which 
>    Application Server(s) the ASP is a member. ]
> 
> -> This is clear that if no RC is present in the ASPAC, it should be considered as a wildcard
> for all AS statically configured in the SG.. 

No, that is not what it means.  If RC is not included, only a single AS can
exist for the SCTP association.

> In return, SG should send back all RCs activated in the ASPAC-ACK msg.

No.  If there is no RC in ASPAC there may be no RC in ASPAC Ack.

> 
> -> This is why RC is therefore mandatory in CLDT/CLDR.

Don't think so...

--brian

> 
> 
> Christophe.
> 
> 
> -----Original Message-----
> From: Brian F. G. Bidulock [mailto:[email-masked]]
> Sent: Thursday, August 07, 2003 9:18 AM
> To: Valerie Gastaud
> Cc: Sigtran
> Subject: Re: [Sigtran] SUA - RC in CLDT
> 
> 
> Valerie,
> 
> SUA had RC mandatory in all messages.  This was just a cut and paste error
> from "common UA procedures".  The SUA draft should be corrected to make RC
> mandatory in ASPAC.  Although it may make some sense to M2UA and even M3UA
> to have RC optional in ASPAC, it makes little sense in SUA.  This is why
> RC is mandatory in all messages in SUA.
> 
> --brian
> 
> Valerie Gastaud wrote:                                                             (Wed, 06 Aug 2003 15:33:59)
> > 
> > Why is RC mandatory in the SUA data messages (CLDT/CLDR + class2 messages)?
> > This is not consistent with M3UA and this is not consistent with the SUA
> > ASPAC message in which the RC is optional.
> > In case of static provisioning of RK, if an SGP receives an ASPAC w/o RC, it
> > won't be able to insert the RC in the CLDT.
> > 
> > Valerie
> > 
> > 
> > 
> > _______________________________________________
> > Sigtran mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/sigtran
> 
> -- 
> Brian F. G. Bidulock
> [email-masked]
> http://www.openss7.org/
> 
> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/sigtran

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Samuel Dur D. Jeyaseelan" <[email-masked]>
Date: Fri, 8 Aug 2003 01:58:42 -0500 (CDT)

Everybody,

RC is a mandatory field when an ASP serves more than one AS.
A single ASP ACTIVE message without RC can not be used to active 
multiple ASes across a common SCTP association.RFC does not explicitely
say that RC is mandatory when an ASP serves
multiple ASes across a common association.But it is implied.

RFC has given a flexibility that RC is an optional field when it serves
a single AS.

Say an example, an ASP1 serves multiple ASes and has been connected to 
SGP1.If RC is an optional parameter to activate all ASes, the potential
problem is, while sending DATA messages to ASP1, 

1) How does ASP1 relate the DATA message with an appropriate AS?

2) Suppose AS2 goes down, How does AS2 indicate this to SGP1?(remeber 
   RC has not been communicated between SGP1 and AS2)

3) Suppose SGP1 wants to put AS1 in DOWN state for some kind of
   configuration purpose, How does SGP1 communicate this with AS1 without 
   RC?

RFC implicitely says that RC is a mandatory field when an ASP serves
more than one ASes.

--Samuel

  Alcatel USA, Inc.                  Internet:
<userid>@ssd.usa.alcatel.com
  1000 Coit Road, Plano, Texas 75075
  ******* The opinions expressed are not those of Alcatel USA, Inc. *******

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 8 Aug 2003 01:06:50 -0600

Samuel,

The M3UA IG section 3.5 changes "optional" to "conditional" everywhere
for RC to indicate this explicitly.

--brian

Samuel Dur D. Jeyaseelan wrote:                                                     (Fri, 08 Aug 2003 01:58:42)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Valerie Gastaud" <[email-masked]>
Date: Fri, 8 Aug 2003 10:19:25 +0200

All,

It is clear for M3UA: RC is conditional in the ASPAC/ack and data and the
rule is:
- an ASP serves only one AS across a common association => it is possible
not to configure/exchange RC, neither in ASPAC/ack nor in data.
- an ASP serves multiple ASes across one association => RCs must be used.

If we use the same rule for SUA, then the RC in the SUA data must be
modified from Mandatory to Conditional. If we keep RC mandatory in the SUA
data, then even if one ASP serves a single AS, we are forced to exchange a
RC.

Brian, if RC is mandatory in all SUA messages as you suggest, does this mean
that you consider that one SUA ASP will never serve a single AS?

Valerie

-----Original Message-----
From: Brian F. G. Bidulock [mailto:[email-masked]]
Sent: vendredi 8 aout 2003 09:07
To: Samuel Dur D. Jeyaseelan
Cc: Anzile, Christophe; Valerie Gastaud; Sigtran
Subject: Re: [Sigtran] SUA - RC in CLDT

Samuel,

--brian

Samuel Dur D. Jeyaseelan wrote:
(Fri, 08 Aug 2003 01:58:42)

--
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 8 Aug 2003 02:49:46 -0600

Valerie,

Valerie Gastaud wrote:                                                             (Fri, 08 Aug 2003 10:19:25)
> that you consider that one SUA ASP will never serve a single AS?

No, just if an ASP serves a single AS then it would configure a
single RC value and include it where mandatory.

The ASP that can only serve a single AS has little use or value for SUA.
(And questionable use or value for M3UA.)

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Anzile, Christophe" <[email-masked]>
Date: Thu, 7 Aug 2003 11:24:09 +0200

Brian (& Valerie),

Christophe.

-----Original Message-----
From: Brian F. G. Bidulock [mailto:[email-masked]]
Sent: Thursday, August 07, 2003 9:18 AM
To: Valerie Gastaud
Cc: Sigtran
Subject: Re: [Sigtran] SUA - RC in CLDT

Valerie,

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/