Subject: Re: [Sigtran] question about m3UA

From: [email-masked]
Date: Fri, 8 Aug 2003 13:54:54 +0530

Brian,
   Do you mean to say that whenever new ASP is sending ASPUP or ASPAC(for
an AS) which does not result in AS state change at SGP.SGP  responds  with
ACK and NOTIFY(AS).
Right ?
What should ASP do with that NOTIFY.

Regards
Kamesh Kaul
www.hssworld.com
Hughes Software Systems

"Brian F. G. Bidulock" <[email-masked]>@ietf.org on 08/08/2003
01:43:16 PM

Please respond to [email-masked]

Sent by:    [email-masked]

To:    Ling-Chih Kao <[email-masked]>
cc:    sigtran <[email-masked]>

Subject:    Re: [Sigtran] question about m3UA

Ling-Chih,

We agreed it was a good idea to send it, even though there is no
text in the RFC that explicitly requires it.

It might be a good idea to add "SHOULD" text to the IG and correct
the diagram 5.1.4.

--brian

Ling-Chih Kao wrote:
(Fri, 08 Aug 2003 16:05:53)
> Dear Samuel Dur D. Jeyaseelan
>
>
> >From the new definition of AS-INACTIVE in sec 4.3.2 of
> draft-ietf-sigtran-m3ua-implementors-guide-04.txt>, the AS becomes
> AS-INACTIVE when there are at least n ASPs in either ASP-INACTIVE or
> AS-ACTIVE.
>
> Therefore, in sec. 5.1.4, AS becomes AS-INACTIVE when SGP receives two
ASP
> UP (from ASP1 and ASP2).  However, when the SGP receives  ASP UP from
ASP3,
> SGP does not  send NOTIFY (AS-INACTIVE) to ASP3. I want to know whether
it
> is optional or not?
>
> Thanks.
> Ling-Chih Kao
>
> ----- Original Message -----
> From: "Samuel Dur D. Jeyaseelan" <[email-masked]>
> To: "Ling-Chih Kao" <[email-masked]>
> Cc: "sigtran" <[email-masked]>
> Sent: Friday, August 08, 2003 3:41 PM
> Subject: Re: [Sigtran] question about m3UA
>
>
>
> Ling-Chih Kao,
>
> NTFY(AS-INACT) is sent to all all available peer ASPes.
> Note: Available peer means an ASP which received ASP-UP-ACK
> in response to ASP-UP messages.(as per RFC section 4.3.4.1).
>
> If you active the AS as soon as a single ASP goes to ASP-INACT
> state then it is obvious that whoever sends ASP-UP message to
> SGP, immediately SGP will send a NTFY(AS-INACT) to the concern
> ASP followd by ASP-UP-ACK.
>
>
> --Samuel
>   Alcatel USA, Inc.                  Internet:
<userid>@ssd.usa.alcatel.com
>   1000 Coit Road, Plano, Texas 75075
>   ******* The opinions expressed are not those of Alcatel USA, Inc.
*******
>
> On Fri, 8 Aug 2003, Ling-Chih Kao wrote:
>
> > Hi all,
> >
> > After SGP receives the ASP UP from ASP1, SGP should immediately send
> > NOTIFY(AS-INACTIVE)   to all ASP in the same AS. Is this right?
> >
> > Thanks
> >
> > Ling-Chih Kao
> > ----- Original Message -----
> > From: "Samuel Dur D. Jeyaseelan" <[email-masked]>
> > To: "Brian F. G. Bidulock" <[email-masked]>
> > Cc: <[email-masked]>; "Ling-Chih Kao" <[email-masked]>;
> "sigtran"
> > <[email-masked]>
> > Sent: Tuesday, August 05, 2003 1:22 PM
> > Subject: Re: [Sigtran] question about m3UA
> >
> >
> >
> > Brian,
> >
> > On Mon, 4 Aug 2003, Brian F. G. Bidulock wrote:
> >
> > > kakaul,
> > >
> > > But I think that we agreed that it would be wise to tell newly
inactive
------------------
> > > ASPs that state of the AS.  Also, in the diagram, the state of the AS
> >   -------------------------
> >
> > What does ASP3 do with NOTIFY(AS-INACTIVE)?
> > Whenever AS state-change happens at SGP, a NTFY will be sent to all
ASPes
> > (other than DOWN-ASPes) pertaining to the same RC.
> > This is what i remember that everybody agreed.
> >
> > --Samuel
> > > does not change with the second ASP (ASP2) sending ASPUP.  The AS
> changes
> > > state to AS-INACTIVE with ASP1 coming up.  Therefore, the diagram
should
> > > show a NOTIFY(AS-INACTIVE) being sent to each ASP immediately after
the
> > > ASPUP Ack is sent to the ASP in question.
> > >
> > > The diagram is quite wrong.  Also it is wrong considering the changes
to
> > > be made to the next issue of the IG.
> > >
> > > --brian
> > >
> > > [email-masked] wrote:
> > (Tue, 05 Aug 2003 09:31:47)
> > > >
> > > >
> > > >
> > > >
> > > > On receiving ASPUP message from ASP3 state of AS does not change,
so
> > > > NOTIFY(AS-INACTIVE) is not send to ASP3.
> > > >
> > > > Kamesh
> > > >
> > > >
> > > >
> > > >
> > > > "Ling-Chih Kao" <[email-masked]>@ietf.org on 08/04/2003
11:40:01
> > AM
> > > >
> > > > Sent by:    [email-masked]
> > > >
> > > >
> > > > To:    "sigtran" <[email-masked]>
> > > > cc:
> > > >
> > > > Subject:    [Sigtran] question about m3UA
> > > >
> > > >
> > > >
> > > >
> > > > Should ASP3 in the Section 5.1.4 of
> > > > <draft-ietf-sigtran-m3ua-implementors-guide-04.txt> receive
> > > > NOTIFY(AS-INACTIVE)?
> > > >
> > > > Thanls
> > > >
> > > > Ling-Chih Kao
> > > >
> > > >
> > > >
> > > > _______________________________________________
> > > > Sigtran mailing list
> > > > [email-masked]
> > > > https://www1.ietf.org/mailman/listinfo/sigtran
> > >
> > > --
> > > Brian F. G. Bidulock
> > > [email-masked]
> > > http://www.openss7.org/
> > >
> > > _______________________________________________
> > > Sigtran mailing list
> > > [email-masked]
> > > https://www1.ietf.org/mailman/listinfo/sigtran
> > >
> > >
> >
> >
> > _______________________________________________
> > Sigtran mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/sigtran
> >
> >
> > _______________________________________________
> > Sigtran mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/sigtran
> >
> >
>
>
> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/sigtran

--
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

_______________________________________________
Sigtran mailing list
[email-masked]
 https://www1.ietf.org/mailman/listinfo/sigtran

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 8 Aug 2003 02:57:01 -0600

kakaul,

[email-masked] wrote:                                                           (Fri, 08 Aug 2003 13:54:54)
> an AS) which does not result in AS state change at SGP.SGP  responds  with

Only when the new ASP sends ASPUP.  Becase before that point, the ASP has
not received any notifications.  Notifications are only sent to ASPs in
the ASP-INACTIVE state for the AS and not in the ASP-DOWN state.

> What should ASP do with that NOTIFY.

Take it under advisement in the same manner as the other ASPs receiving
NTFY(AS-INACTIVE).  As with the other ASPs, this ASP may choose based on
this and any other information that it has at its disposal about the
intentions of other ASPs, to send ASPAC (or not) for the AS.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/