Subject: RE: [Sigtran] M3UA : IPSP DE behaviour

From: [email-masked]
Date: Thu, 7 Aug 2003 15:42:25 +0530

Hi Vivek,
   Please go through the section attached from RFC 3332
   4.3.4.4.1 IPSP Considerations (ASP Inactive)

   An IPSP may be considered in the ASP-INACTIVE state by a remote IPSP
   after an ASP Inactive or ASP Inactive Ack message has been received
   from it.

   Alternatively, an interchange of ASP Inactive messages from each end
   can be performed. This option follows the ASP state transition
   diagram and gives the additional advantage of selecting a particular
   AS to be deactivated from each end. It is especially useful when an
   IPSP is serving more than one AS. It would need four messages for
   completion.

   IMO IPSP A in your example after sending ASPIA message for AS1 would
   not be able to send or receive traffic from or for AS1.

Regards
Kamesh Kaul
www.hssworld.com
Hughes Software Systems

"Vivek Toky" <[email-masked]>@ietf.org on 08/07/2003 10:00:09 AM

Sent by:    [email-masked]

To:    Kamesh Kaul/HSS@HSS
cc:    <[email-masked]>

Subject:    RE: [Sigtran] M3UA : IPSP DE behaviour

Kamesh,

  See my comments Inline..

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Wednesday, August 06, 2003 8:47 PM
To: [email-masked]
Cc: [email-masked]
Subject: [Spam] RE: [Sigtran] M3UA : IPSP DE behaviour

Vivek
      Please see comments in line

"Vivek Toky" <[email-masked]>@ietf.org on 08/05/2003 09:47:43 AM

Sent by:    [email-masked]

To:    "kamesh kaul" <[email-masked]>
cc:    <[email-masked]>

Subject:    RE: [Sigtran] M3UA : IPSP DE behaviour

Kamesh,
  Please see comments inline
-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
kamesh kaul
Sent: Saturday, August 02, 2003 8:24 PM
To: Vivek Toky
Cc: [email-masked]
Subject: RE: [Sigtran] M3UA : IPSP DE behaviour

Hi Vivek,
    I argee with you that if we intermix IPSP SE and
DE models we can start loadsharing traffic for AS2
among IPSP B and IPSP A even though IPSP B has not
received ASPAC message from IPSP c.It would result in
intermixing of two IPSP models.For some messages IPSP
C has to behave in DE manner and for other SE
behaviour is required.Lets take your example. On
receiving ASPAC messages from IPSP A and IPSP B for
AS1 IPSP C updates only remote IPSP'S states for AS1
behaving in DE manner.when IPSP c sends ASPAC for AS2
to IPSP A and receives ACK back then also IPSP C
changes its state to active for local AS2 behaving in
DE manner.Now as you said Bi-directional data is
flowing from IPSP C and IPSP A where as single
direction traffic is possible from IPSP C to IPSP B
(for AS2).Now assume IPSP A sends ASPIA message for
AS1 to IPSP C in this case IPSP c on receiving ASPIA
message has to update state of remote IPSP A in AS1
and also state of local IPSP C in local AS2 behaving
in SE manner.

[Vivek]
 You have a good point but I did not understand why would we need to change
the state of IPSP C in this case ( when IPSP A sends ASPIA to IPSP C). When
IPSP A sends ASPIA message for AS1 to IPSP C then only IPSP A's state will
change in local AS1 and the corresponding remote AS1 on the other side. You
are right that AS1 will not be able to receive traffic through IPSP A , but
that doesnot restrict AS1 to send traffic from IPSP A.
[Kamesh]
IPSP A is inactive (it has send ASPIA) for AS1 so how can it send data for
AS1.
****Vivek*****
That is what I am trying to say, IPSP A is inactive to receive data. It can
still send data because remote destination is still active to receive data
through  IPSP A
If sending an Active message means it will be able to send and receive data
then an Active Ack from other would have been suffcient to tell IPSP A that
it can start sending data as well. But it did not happen.. IPSP C sent an
explicit Active message to indicate that its ready to receive data so IPSP
C is the one who will indicate that now it is not going to receive data.
IPSP A does not need to stop sending data to IPSP C just because it send
ASPIA message.
**************

Note: AS1 is still UP
and ready to process data and so is AS2. If AS1 wants to go down and not
process data at all then it should sent Inactive through both the IPSPs (
IPSP A and IPSP B).
[Kamesh]
 IPSP B cant’t send data for AS1 to IPSP C because IPSP C has not send
ASPAC message to it.So it means that AS1’s data cant reach IPSP C because
IPSP A is inactive for AS1 and IPSP B has not received ASPAC message from
IPSP C.
Now the question arises that what should IPSP A do if it
receives data from AS1 which has inactivated itself from both  the IPSPs
and
is now totally unable to receive DATA ? ... following points should be
noted
1. If AS1 doesn't want to receive data, why we care if the data sent by AS1
went through all the way to AS2.
2. Now we know that AS2 won't be able to send data to AS1 atall so it can
take recovery and De-activate itself through IPSP A (to which it sent ASP
Active and got Active Ack.)

does it make sense ? please comment..

[Kamesh]
 We have to check the state of local IPSP before selecting remote
application server for data

If IPSP C does not bother about local
state updation on receiving ASPIA from IPSP A, IPSP C
will continue to send data messages for AS2 to IPSP B
without receiving anything from other side. This will
result in single direction traffic from IPSP C to AS1
without the knowledge of IPSP C.If we associate AS
state with local and peer IPSP's (in your example
AS2's state with IPSP c and each peer IPSPA and IPSPB,
AS2's state with IPSP C and each peer IPSP's) single
direction traffic flow is not possible. Please comment

Regards
Kamesh
--- Vivek Toky <[email-masked]> wrote:
> Hi Kamesh,
>   Although ASPAC message has not been sent to IPSP
> B, but the local AS is
> still active and is sending and receiving traffic
> through IPSP A. Now on the
> other side IPSP A and IPSP B are part of the same AS
> ( AS1 ). So following
> points should be noted.
>
> 1. Bi-directional traffic between AS1 and AS2 is
> possible
> 2. IPSP B has already sent ASPAC and received ASPAC
> Ack, so it is ready to
> receive traffic.
>
>  So why don't we loadshare the traffic among IPSP A
> and IPSP B as the
> traffic is anyway going to get to the same
> destination i.e. AS1
>
> In the reverse direction AS1 can choose IPSP A to
> send traffic towards AS2,
> as only IPSP A has received ASPAC from IPSP C (for
> AS2)
>
> comments?
>
> -Vivek.
>
> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of
> [email-masked]
> Sent: Friday, August 01, 2003 1:16 AM
> To: Vivek Toky
> Cc: [email-masked]
> Subject: RE: [Sigtran] M3UA : IPSP DE behaviour
>
>
>
>
>
>
> Vivek,
>
> In your example also IPSP C will send data for AS1
> to IPSP A only.I dont
> see any reason for IPSP C to send data to IPSP B
> because ASPAC message is
> not sent to IPSP B. I dont see any possibility of
> single direction traffic
> flow in your example also.
>
> Kamesh Kaul
> www.hssworld.com
> Hughes Software Systems
>
>
>
>
> "Vivek Toky" <[email-masked]> on 08/01/2003
> 01:23:11 PM
>
> To:    Kamesh Kaul/HSS@HSS, [email-masked]
> cc:
>
> Subject:    RE: [Sigtran] M3UA : IPSP DE behaviour
>
>
> Kamesh,
>
>   Single direction traffic will still be possible.
> If you look at my
> example carefully you will notice that in case of 3
> IPSPs, it will be
> possible. It may be for a short duration of time. In
> my example local
> AS is already Active as it sent ASP Active message
> to one of the peer
> IPSPs ( also got the ACK back )
>
> please go through the example again .. waiting for
> comments ?
>
> Vivek
> >
> >
> >
> >
> > Hi Some comments below
> >
> >  When IPSP B receives ASPAC message from IPSP A
> for AS1 it marks
> remote
> > IPSP A active for remote AS1 and sends ASPAC ack
> back for AS1 to
> IPSP A.Now
> > with these message exchanges it means that IPSP A
> is ready to receive
> > traffic for AS1.At this point of time IPSP B has
> not expressed its
> > willingness to send data for any AS.IPSP B  cannot
>  send any
> application
> > data because its local applications are not active
> yet.So single
> direction
> > traffic flow will never occur.Now when IPSP B
> sends ASPAC message
> for AS2
> > to IPSP A and gets back ASPAC ack for AS2 it will
> give resume
> indication to
> > user now.AS1 and AS2 are basically same type of
> MTP3 users, and user
> to
> > user communication will only start if both users
> are ready and
> active.
> >
> >
> >     +-----------+              +-----------+
> >     |           |              |           |
> >     | IPSP A    |              | IPSP B    |
> >     |           +--------------+           |
> >     |           |              |           |
> >     +-----------+              +-----------+
> >
> >         AS1                        AS2
> >
> > Kamesh Kaul
> > www.hssworld.com
> > Hughes Software Systems
> >
> >
> >
> >
> >
> > "VIvek Toky" <[email-masked]>@ietf.org on
> 07/31/2003 11:19:39 PM
> >
> > Sent by:    [email-masked]
> >
> >
> > To:    "Tolga Asveren" <[email-masked]>,
> <[email-masked]>
> > cc:
> >
> > Subject:    RE: [Sigtran] M3UA : IPSP DE behaviour
> >
> >
> > Tolga,
> >
> > -----Original Message-----
> > From: [email-masked]
> [mailto:[email-masked]]On
> Behalf Of
> > Tolga Asveren
> > Sent: Thursday, July 31, 2003 10:19 AM
> > To: [email-masked]
> > Subject: RE: [Sigtran] M3UA : IPSP DE behaviour
> >
> >
> > Vivek,
> > --- Vivek Toky <[email-masked]> wrote:
> > > Please see my comments inline
> > >
> > > > See my opigion online
> > > >
> > > > > -----Original Message-----
> > > > > From: Vivek Toky [mailto:[email-masked]]
> > > > > Sent: Thursday, July 31, 2003 2:42 PM
> > > > > To: Tolga Asveren; [email-masked]
> > > > > Subject: RE: [Sigtran] M3UA : IPSP DE
> behaviour
> > > > >
> > > > >
> > > > > Hi Tolga,
> > > > >   "Above case" means
> > > > > "when AS1 has activated itself by sending
> > > > >  ASP Active from both the IPSPs (A & B) but
> > > > >  AS2 has sent ASP Active just to IPSP_A."
> > > > >
> > > > > In my opinion IPSP_C should loadshare the
> > > traffic
> > > > > as it has received ASP active from both the
> > > IPSPs
> > > > > so AS1 is accessible through both of these.
> > > > > However, it is the responsibility of AS1 to
> > > route
> > > > > all the traffic towards AS2 through IPSP_A.
> > > >
> > > > If IPSP_B receive some traffic from IPSP_C BUT
> no
> > > AS is ACTIVE for
> > > it on
> > > > IPSP_C can it route this traffic???
> > > > CAN a SG send to a ss7 network a message
> receive
> > > from an INACTIVE
> > > ASP !
>
=== message truncated ===

__________________________________
Do you Yahoo!?
Yahoo! Calendar - Free online calendar with sync to Outlook(TM).
http://calendar.yahoo.com

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

_______________________________________________
Sigtran mailing list
[email-masked]
 https://www1.ietf.org/mailman/listinfo/sigtran

"DISCLAIMER: This message is proprietary to Hughes Software Systems Limited
(HSS) and is intended solely for the use of the individual to whom it is
addressed. It may contain  privileged or confidential information and
should not be circulated or used for any purpose other than for what it is
intended. If you have received this message in error, please notify the
originator immediately. If you are not the intended recipient, you are
notified that you are strictly prohibited from using, copying, altering, or
disclosing the contents of this message. HSS accepts no responsibility for
loss or damage arising from the use of the information transmitted by this
email including damage from virus."

_______________________________________________
Sigtran mailing list
[email-masked]
 https://www1.ietf.org/mailman/listinfo/sigtran
J(-���j)b�	b�Ԣ��ڞ'�~����i����
bz���j)fj��b��?�(-��

---

From: "Vivek Toky" <[email-masked]>
Date: Thu, 7 Aug 2003 23:22:14 -0700

Hi Kamesh,
   The text specified in the section can be interpreted in several ways. Please see inline response

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
[email-masked]
Sent: Thursday, August 07, 2003 3:12 AM
To: Vivek Toky
Cc: [email-masked]
Subject: [Spam] RE: [Sigtran] M3UA : IPSP DE behaviour

Hi Vivek,

   Alternatively, an interchange of ASP Inactive messages from each end
   can be performed. This option follows the ASP state transition
   diagram and gives the additional advantage of selecting a particular
   AS to be deactivated from each end ([Vivek:] does it mean, if you inactivate AS in one direction that does not de-activate AS from other end).
   It is especially useful when an IPSP is serving more than one AS. 
   It would need four messages for completion ([Vivek:] does it mean that single direction inactivation will not complete the inactivation procedure ).

[Vivek:] I would say that RFC as well as IG do not explain IPSP DE correctly.
There should be more explicit statements present to avoid any interoperability problems. The example which I gave clearly explains that there is no need to stop traffic in both directions if Inactivation occurred just from one direction. I would again suggest the authors of M3UA to clarify IPSP DE Activation and De-Activation procedure in next version of IG.

Regards
Kamesh Kaul
www.hssworld.com
Hughes Software Systems

To:    Kamesh Kaul/HSS@HSS
cc:    <[email-masked]>

Kamesh,

  See my comments Inline..

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Wednesday, August 06, 2003 8:47 PM
To: [email-masked]
Cc: [email-masked]
Subject: [Spam] RE: [Sigtran] M3UA : IPSP DE behaviour

Vivek

Kamesh,
-----Original Message-----

Hi Vivek,

[Vivek]

Note: AS1 is still UP

[Kamesh]

Regards
Kamesh

J(-j)b	b枲Ԣ '~ i 
bz  j)fj b?(-