Subject: FW: [Sigtran] M3UA : IPSP DE behaviour

From: "BAND,RICHARD (HP-France,ex1)" <[email-masked]>
Date: Wed, 30 Jul 2003 14:37:48 +0200

Resending...
Hi Kamesh, Umesh,

I agree that the protocol allows traffic from IPSP B to A without having
traffic from IPSP A to B.

However, I do think that there is a problem with the notifications for the
AS on each side:
In this situation, how should the IPSPs A and B indicate the availability of
the remote AS to the local AS?
Should IPSP A indicate that AS 2 is available, even though it knows AS 2
cannot reply?
Should IPSP B indicate that AS 1 in unavailable, as AS 2 cannot send any
messages to AS 1? 
If so, what should IPSP B do when AS 1 sends traffic? Discard the messages,
or transfer the data to AS 2, which will then receive traffic from an
unavailable destination?

In my opinion, both IPSPs should indicate that the remote AS is unavailable.
I would say that the DE IPSP exchange mode allows each side to indicate its
readiness to receive traffic, but traffic should not be started unless both
sides are active.
It seems to me that this is the only to avoid the problems described above.

Please let me know your opinion on this point.

Regards,

Richard Band

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Wednesday, July 30, 2003 06:17
To: [email-masked]
Cc: [email-masked]
Subject: Re: [Sigtran] M3UA : IPSP DE behaviour

Umesh

  IPSP B can send DATA messages for AS1 to IPSP A only if on receiving
ASPAC message from IPSP A , IPSP B sends ASPAC ack for AS1 to IPSP A.Not
activating AS2 means IPSP B will not be able to receive any message for
AS2.So in a way only data for AS1 will flow from IPSP B to IPSP A.

Regards
Kamesh Kaul
www.hssworld.com
Hughes Software Systems

"Umesh Vats" <[email-masked]>@ietf.org on 07/30/2003 07:44:36 AM

Please respond to <[email-masked]>

Sent by:    [email-masked]

To:    <[email-masked]>
cc:

Subject:    [Sigtran] M3UA : IPSP DE behaviour

Suppose we have two Double Ended IPSPs A and B. AS1 is application server
on IPSP-A and AS2 is application server on IPSP-B

     AS1 A----------B AS2

Now, IPSP-A sends ASPAC for for AS1 to B. IPSP-B doesn't activate AS2.
After this, can IPSP-B send DATA messages for AS1 to IPSP-A in any scenario
?

Thanks
Umesh Vats
Sr Software Engg.
extn : 8986

_______________________________________________
Sigtran mailing list
[email-masked]
 https://www1.ietf.org/mailman/listinfo/sigtran

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: Tolga Asveren <[email-masked]>
Date: Mon, 11 Aug 2003 14:24:51 -0700 (PDT)

Richard,

M3UA does not dictate, which MTP3/MTP3 User part
primitive should be sent to an application when -this
is dependent on architecture and implementation-. So,
IMO from M3UA protocol point of view, there is no way
to introduce the intelligence you are describing below
with DE-IPSP mode, but this might be done in NIF. And
also, an application does not get indication about
remote AS availability but primitives like in plain
MTP3 about remote PC status.
In fact, it seems to me that such a harmonization of
remote/local AS states might make DE mode quite
similar to SE mode from application point of view,
where the intelligence is shifted from M3UA to NIF
-and this may beg the question why DE mode is
introduced-.

     Tolga
--- "BAND,RICHARD (HP-France,ex1)"
> After this, can IPSP-B send DATA messages for AS1 to

__________________________________
Do you Yahoo!?
Yahoo! SiteBuilder - Free, easy-to-use web site design software
http://sitebuilder.yahoo.com