Subject: [Sigtran] Sigtran Plugtest - DAY 1

From: Ken Morneault <[email-masked]>
Date: Tue, 02 Sep 2003 04:02:05 -0400

Below are the issues and comments raised after the first day
of testing at the Plugtest.

M3UA
---------

1)  A general comment regarding a preference of returned error
value for the following condition per the RFC.

           ASP                                  SG
          --------                              ------------
     ASP Active (no RC) --------->
                                  <---------   Error ("no AS configured")

     ASP Active (RC1)    ---------->
                                  <---------   Error ("invalid RC")

There was a stated preference to allow the SG to return
Error ("no AS configured") in response to ASP Active (RC1).

2)  For IPSP Double-Ended mode, there is still some confusion
about where ASP Down should be exchanged by both ends or
if one end is sufficient.  The latest M3UA IG states that ASPSM
messages MUST be sent from both sides.  There is a request to
add a message flow diagram to emphasize this statement for
the ASP Down case.

Also, do both sides have to send ASP Active before data can be
sent?  In other words, should the logic for sending data be (a)
or (b) below.

   (a)  send ASP Active, receive ASP Active Ack, receive ASP Active

   (b)  send ASP Active, receive ASP Active Ack

3)  The latest M3UA IG missed an issue that had been discussed
on the Sigtran email list.  Given the following scenario:

           ASP                                  SG
          --------                              ------------
       REG REQ  (RK1) --------->
                                <---------     REG RSP (success, rc=2)

     ASP goes down, then comes back up

       REG REQ  (RK1) --------->
                                <---------     REG RSP (error - routing key already reg, rc=2)

It is important that the M3UA IG note that the REG RSP (error-routing key
already registered) MUST contain the Routing Context to ensure both sides
are in-sync.

4)  A question as to whether or not NA could be removed from the Data
message.  However, a quick poll showed that several implementations do
send NA in the Data message if NA is provisioned.

5)  A question as to whether or not there is any value in having the
SG reflect the Traffic Mode in ASP Active Ack.

6)  Given a SG sends DRST (APC1) / SCON (APC1) to an ASP then later sends a
DAVA (APC1).  Does the SG need to resend SCON (APC1) if the congestion
state has not changed?  

M2PA
----------

1)  Why was alignment without proving added to draft 9? 

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Tolga Asveren" <[email-masked]>
Date: Tue, 2 Sep 2003 11:13:34 -0400

>    (b)  send ASP Active, receive ASP Active Ack
[TOLGA] IMO, it definitly is (b). IPSP-DE M3UA has no knowledge of
corraleting RKs to each other. This is something, which needs to be done
somewhere else (NIF etc...). IPSP-SE does this corraletion on RK level -by
embedding corraletion info inside the RK-, and keeps the logic within M3UA.
For (a), I would ask, ASP Active for which RK should be received, there is
no corraletion present.
> SG reflect the Traffic Mode in ASP Active Ack.
[TOLGA] I think there is a value -ASP can verify that SG can support the
desired traffic mode-, but probably the real question is, whether this can
be left as configuration issue or not. I even remember a proposal long time
ago to use Traffic Mode in ASPAC-ACK to inform ASP about the traffic mode of
SG itself.
> DAVA (APC1).  Does the SG need to resend SCON (APC1) if the congestion
[TOLGA]IMO, no.

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 2 Sep 2003 09:43:02 -0600

Tolga,

Tolga Asveren wrote:                                                                 (Tue, 02 Sep 2003 11:13:34)
> > DAVA (APC1).  Does the SG need to resend SCON (APC1) if the congestion

I agree.  DAVA does not indicate cessation or alteration in congestion in any way.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 2 Sep 2003 17:06:16 -0600

Ken,

One question below...

Ken Morneault wrote:                                                                   (Tue, 02 Sep 2003 04:02:05)
> value for the following condition per the RFC.

Why is the ASP not sending ASPUP when it come up?

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: Tom George <[email-masked]>
Date: Wed, 03 Sep 2003 10:51:33 -0500

Here is the statement in 4.1.3  Link Alignment:

"The proving period MAY be omitted if this is allowed by the applicable
MTP2 standard (e. g., [Q.2210])."

This was added in case someone wants an M2PA that works like Q.2210.

tomG.

On 09/02/03 Ken Morneault wrote:
   [...]
> M2PA
   [...]

-- 
* Tom George       PB7-24001 (near B-21)      [email-masked]  *
* 972-519-3168   Intranet:  http://www.ssd.usa.alcatel.com/~tgeorge/  *
*   I actively disclaim speaking for Alcatel.  I do not purport to    *
*   advertise or represent its position, operations, or activities.   *

---

From: Ken Morneault <[email-masked]>
Date: Wed, 03 Sep 2003 13:33:03 -0400

Brian,

The ASP does send ASP Up.  It's just not shown in the message
flow.

Ken

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 3 Sep 2003 12:20:34 -0600

Ken,

Ken Morneault wrote:                                                                   (Wed, 03 Sep 2003 13:33:03)
> The ASP does send ASP Up.  It's just not shown in the message

Then the SG, upon receipt of the ASPUP, should consider the ASP
in the ASP-DOWN state and deactivate all AS and deregister all RKs
for the ASP before responding with ASPUP Ack.  The second REG REQ
will receive (success, rc=2) and (rk already registered) is never
necessary.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/