Subject: RE: [Sigtran] Sigtran Plugtest - DAY 2-5: M3UA NTFY

From: "J.Javier Pastor (KI/EEM)" <[email-masked]>
Date: Fri, 5 Sep 2003 17:36:08 +0200

Brian, 

Pls see below...

> -----Original Message-----
> From: Brian F. G. Bidulock [mailto:[email-masked]]
> Sent: viernes, 05 de septiembre de 2003 16:39
> To: J.Javier Pastor (KI/EEM)
> Cc: Ken Morneault; [email-masked]
> Subject: Re: [Sigtran] Sigtran Plugtest - DAY 2-5: M3UA NTFY
> 
> 
> J.Javier,
> 
> J.Javier Pastor (KI/EEM) wrote:                               
>                     (Fri, 05 Sep 2003 16:34:28)
> > Brian, 
> > 
> > See my comments below...
> > 
> > > -----Original Message-----
> > > From: Brian F. G. Bidulock [mailto:[email-masked]]
> > > Sent: viernes, 05 de septiembre de 2003 16:10
> > > To: J.Javier Pastor (KI/EEM)
> > > Cc: Ken Morneault; [email-masked]
> > > Subject: Re: [Sigtran] Sigtran Plugtest - DAY 2-5
> > > 
> > > 
> > > J.Javier,
> > > 
> > > J.Javier Pastor (KI/EEM) wrote:                               
> > >                     (Fri, 05 Sep 2003 15:11:24)
> > > 
> > 
> >  [snip]
> > 
> > > > > > 
> > > > > > 4)  It has been agreed that the AS state be sent in a 
> > > > > Notify message 
> > > > > > when an ASP transfers to ASP-INACTIVE (assuming the SG 
> > > knows which
> > > > > > AS(es) the ASP is configured for).  However, the Status 
> > > > > Type "AS State
> > > > > > Change" seems inappropriate.  Suggest a new Status Type.
> > > > > 
> > > > > Excellent suggestion.  How about "State Indication" ?  What 
> > > > > about failed ASPs?
> > > > > Does an SG inform newly INACTIVE ASPs in an AS about ASP 
> > > > > failures that occured
> > > > > before it became inactive (and which are still failed)?
> > > > > 
> > > > 
> > > > It was agreed to send the NTFY("Insufficient ASPs"), and 
> > > the Status Type
> > > > therefore should be "Other". Nothing new is needed to 
> be defined.
> > > 
> > > No, also for sending the current state of the AS to ASPs 
> > > newly entering the
> > > ASP-INACTIVE state from ASP-DOWN.  So when ASP-x comes 
> online and goes
> > > ASP-INACTIVE from ASP-DOWN I would send "AS State Change - AS 
> > > Active" when the
> > > state has not changed?  (It always was active, I'm just 
> > > informing the newly
> > > ASP-INACTIVE ASP).
> > > 
> > > Or would it be better to send "AS State Indication - AS Active?".
> > >                                   ^^^^^^^^^^^^^^^^
> > > Distinguishing this initial boot-up notification from a 
> state change
> > > notification has value.
> > > 
> > 
> > Ok, referring to that case, my opinion is that the only 
> fact that bother the
> > new ASP getting ASP-INACTIVE state from ASP-DOWN state, is 
> the current state
> > of the AS. That information is already provided with the current
> > posibilities. What would be the difference if we include the
> > "State-Indication"? Would the ASP react in a different way?
> 
> As there is no required behavior in response to NTFY, one 
> cannot say that the
> ASP would necessarily act in one way or the other.  One thing is sure:
> saying "State-Indication" provides more INFORMATION upon 
> which the ASP can
> make an informed decision, because the ASP can distinguish 
> the case of being
> notified about a pre-exisiting event and being notified about 
> an impending
> event.  Case in point might be "State Indication - AS 
> Pending".  If this had
> just occured, the ASP might want to jump in.  If it has 
> persisted for some
> time, the ASPs action might be more conservative.
> 

My opinion is that whenever an ASP receives the notification of AS_Pending, it should try to reach the ASP_ACTIVE state ASAP. I don't understand the option of keep waiting if has persisted for some time...

Apart from this, I still don't see any difference between the "indication" and the "state change". The ASP will receive the NTFY upon reaching the ASP-INACTIVE state and it will consider it as the indication of the current state of the AS. It would be the internal communication between the ASPs, if implemented, that indicates which ASP should activate. 

Upon reaching the ASP-INACTIVE state an ASP coming from the ASP-DOWN will receive the same NTFY(s) as the ASPs in ASP-INACTIVE received the last time they were notified. e.g. NTFY(AS-ACTIVE)+NTFY(Insuf Resources), or NTFY(AS-ACTIVE) or NTFY(AS-PENDING)...

Cheers // Javier. 

> --brian
> > Cheers // Javier.
> -- 
> Brian F. G. Bidulock
> [email-masked]
> http://www.openss7.org/

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 5 Sep 2003 09:46:13 -0600

J.Javier,

J.Javier Pastor (KI/EEM) wrote:                                                   (Fri, 05 Sep 2003 17:36:08)
>
> My opinion is that whenever an ASP receives the notification of AS_Pending,
> it should try to reach the ASP_ACTIVE state ASAP. I don't understand the
> option of keep waiting if has persisted for some time...
> 
> Apart from this, I still don't see any difference between the "indication"
> and the "state change". The ASP will receive the NTFY upon reaching the
> ASP-INACTIVE state and it will consider it as the indication of the current
> state of the AS.

Precisely.  It cannot distinguish between the two unless there is a different
status.

> It would be the internal communication between the ASPs, if implemented,
> that indicates which ASP should activate. 

Upon reboot, it may take time for the ASP to fully sycnrhonize with peer ASPs.

> 
> Upon reaching the ASP-INACTIVE state an ASP coming from the ASP-DOWN will
> receive the same NTFY(s) as the ASPs in ASP-INACTIVE received the last time
> they were notified. e.g. NTFY(AS-ACTIVE)+NTFY(Insuf Resources), or
> NTFY(AS-ACTIVE) or NTFY(AS-PENDING)...

But not as timely...

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/