Subject: [Sigtran] M2UA additional IIDs supported

From: "Therese Keenan" <[email-masked]>
Date: Wed, 10 Sep 2003 13:39:12 -0500

Hi Everyone -

This is an M2UA implementation question. Here is the configuration:

SGP <----> ASP1

1. ASP1:Sends ASP UP to SGP
2. SGP: Sends ASP UP Ack to ASP1
3. ASP1: Sends ASP Active with the optional list of IIDs encoded
4. SGP: 
     a. Updates the State of ASP1 - ready to receive MAUP messaging
     b. Updates the IIDs supported by this ASP (based on list provided
within ASP Active)
     c. Sends ASP Active ACK 
     d. Sends notify (ASP active)

4. An additional IID is then manually configured on ASP1 and on SGP. ASP1
wants to support this IID. 

How does ASP1 inform SGP that it wants to support the new manually
provisioned IID? Does ASP1 send another ASP Active message including all of
the IIDs it wants to support or do we need a separate message?

Thanks for your input,

Therese

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 10 Sep 2003 13:19:44 -0600

Therese,

Therese Keenan wrote:                                                              (Wed, 10 Sep 2003 13:39:12)
>    4.  An  additional IID is then manually configured on ASP1 and on SGP.
>    ASP1 wants to support this IID.
> 
>    provisioned  IID?  Does ASP1 send another ASP Active message including
>    all of the IIDs it wants to support or do we need a separate message?

Don't send ASP Active and don't send a separate message.  Once it is
configured, Just establish the link from the ASP and start using it.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Barry Nagelberg" <[email-masked]>
Date: Wed, 10 Sep 2003 15:36:30 -0400

Brian,

Your suggestion will not work if the newly-configured IID is in an AS that
is different from the AS's of any of the already-active IIDs. In this case,
the ASP must send an ASP active message for the newly-configured IID.

Barry Nagelberg

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Brian F. G. Bidulock
> Sent: Wednesday, September 10, 2003 3:20 PM
> To: Therese Keenan
> Cc: [email-masked]
> Subject: Re: [Sigtran] M2UA additional IIDs supported
>
>
> Therese,
>
> Therese Keenan wrote:

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 10 Sep 2003 15:09:37 -0600

Barry,

Yes, I believe the question was for adding an IID to an already active AS.

--brian

Barry Nagelberg wrote:                                                               (Wed, 10 Sep 2003 15:36:30)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/