Subject: RE: [Sigtran] Sigtran Plugtest - DAY 2-5: M3UA IPSP

From: "J.Javier Pastor (KI/EEM)" <[email-masked]>
Date: Fri, 5 Sep 2003 17:42:16 +0200

Hi Brian, 

Pls, see below...

> -----Original Message-----
> From: Brian F. G. Bidulock [mailto:[email-masked]]
> Sent: viernes, 05 de septiembre de 2003 16:10
> To: J.Javier Pastor (KI/EEM)
> Cc: Ken Morneault; [email-masked]
> Subject: Re: [Sigtran] Sigtran Plugtest - DAY 2-5
> 
> 
> J.Javier,
> 
> J.Javier Pastor (KI/EEM) wrote:                               
>                     (Fri, 05 Sep 2003 15:11:24)
> 

[snip]

> > 
> > > > 
> > > > 8)  In IPSP SE, should the ASP receiving ASP Up/Active Ack
> > > > also send Notify messages?  General though is that it should.
> > > 
> > > No, the IPSP sending ASP Up/Active Ack sends Notify.
> > 
> > 
> > I agree with the general thought. Once the communication is 
> established they
> > should work in a peer-to-peer basis. Then both could send NTFY.-
> 
> Both sending notify would be both acting like SG.  Which is SG-SG
> communication.  Which is something different that SE and DE.  SE is
> inherently ASP-SG communication.  Only one side behaves like an SG.
> Only one side sends notify.
> 
> Don't try to make SE, DE again... ;)
> 

After doublechecking, I would recommend not to send the NTFY because those IPSP are the one who are acting as a client. Sending NTFY from the SG was due to SG is the server and they can not react upon a state change. So they have to inform the client part of the current status.

In this case the IPSP receiving ASP receiving ASP Up/Active Ack acts as a client. They don't need to inform the others, they can themselves take the action of sending ASPAC or ASPIA.

Anyway if people participating in the Plugtest see any other reason, please comment.

Cheers // Javier.

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Tolga Asveren" <[email-masked]>
Date: Fri, 5 Sep 2003 12:04:02 -0400

Hi Javier/Brian,
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> J.Javier Pastor (KI/EEM)
> Sent: Friday, September 05, 2003 11:42 AM
> To: [email-masked]'
> Subject: RE: [Sigtran] Sigtran Plugtest - DAY 2-5: M3UA IPSP
>
>
> Hi Brian,
>
> Pls, see below...
>
> After doublechecking, I would recommend not to send the NTFY
> because those IPSP are the one who are acting as a client.
> Sending NTFY from the SG was due to SG is the server and they can
> not react upon a state change. So they have to inform the client
> part of the current status.
>
> In this case the IPSP receiving ASP receiving ASP Up/Active Ack
> acts as a client. They don't need to inform the others, they can
> themselves take the action of sending ASPAC or ASPIA.
[TOLGA]I respectfully disagree that IPSP-SE is a client/server model
(IPSP-DE is). ASPAC/ASPAC-ACK has different semantic for IPSP-SE than for
regular ASP/SGP case. It has meaning for both directions, and means "My AS
wants to communicate with your AS -where those AS are defined by the RK-,
rather than "My AS wants to get a service from you". IMO, none of the IPSP
is acting as a client(or as a server) in IPSP-SE, it is really kind of
peer-to-peer. So, I still would think sending NTFY in both directions might
be usefull, to inform other IPSPs serving the same AS, about the state of
AS.