Subject: RE: [Sigtran] Sigtran Plugtest - DAY 2-5

From: "J.Javier Pastor (KI/EEM)" <[email-masked]>
Date: Fri, 5 Sep 2003 15:11:24 +0200

Hi all, 

Please see my comments below...

> -----Original Message-----
> From: Brian F. G. Bidulock [mailto:[email-masked]]
> Sent: viernes, 05 de septiembre de 2003 13:02
> To: Ken Morneault
> Cc: [email-masked]
> Subject: Re: [Sigtran] Sigtran Plugtest - DAY 2-5
> 
> 
> Ken,
> 
> Ken Morneault wrote:                                          
>                          (Fri, 05 Sep 2003 05:54:14)
> > 
> > 
> [snip]
> > 
> > M3UA
> > ---------
> > 
> > 1)  Need to draw a picture - will send out later.
> > 
> > 2)  Question - is the AS state maintained per SGP or SG.  Vivek
> > has several subquestions regarding this - I'll ask him to submit
> > them as follow up.
> 
> Per SGP.  This was agreed long time ago.
> 

Right.

> > 
> > 3)  How to handle NIF Unavailable was removed from IGv05.  There is
> > a suggestion that we specify how to handle this situation in the IG.
> 
> We agreed to remove it.
> 

Yes, we finally agreed to remove it and stated that people could look at the different threads where it was discussed to find possible solutions.

Another option we have, if people think it is interesting, is to include it as an IMPLEMENTATION NOTE.

> > 
> > 4)  It has been agreed that the AS state be sent in a 
> Notify message 
> > when an ASP transfers to ASP-INACTIVE (assuming the SG knows which
> > AS(es) the ASP is configured for).  However, the Status 
> Type "AS State
> > Change" seems inappropriate.  Suggest a new Status Type.
> 
> Excellent suggestion.  How about "State Indication" ?  What 
> about failed ASPs?
> Does an SG inform newly INACTIVE ASPs in an AS about ASP 
> failures that occured
> before it became inactive (and which are still failed)?
> 

It was agreed to send the NTFY("Insufficient ASPs"), and the Status Type therefore should be "Other". Nothing new is needed to be defined.

> > 
> > 5)  Why does Network Appearance have to be the first parameter
> > in the Data message.
> 
> Because when used it determines the context of all the others.
> 
> > 
> > 6)  Clarify text as to when Notify (ASP Failure) must be sent.  Is
> > is upon failure (SCTP assoc fails) or any transition to 
> ASP-DOWN state.
> 
> Only on failure.  If an ASP sends and ASP Down message, it is 
> not considered
> failed.  It is considered withdrawn.  Remember that ASP 
> Failure was intended
> to allow ASP1 to distinguish between these two situations:
> 
> 
>      ________                      ________ 
>     |        |                    |        |
>     |        |           Failure  |        |
>     |  ASP1  |-------X   X--------|  ASP2  |
>     |        |                    |        |
>     |________|                    |________|
>         |                              |    
>         |                              |    
>         |___________        ___________|    
>                     |      |                
>                     |      |                
>                     |______|                
>                    |        |               
>                    |        |               
>                    |  SGP1  |               
>                    |        |               
>                    |________|               
>                                             
> 
>      ________                      X_X_X_X_ 
>     |        |                    X        X
>     |        |                    X        X
>     |  ASP1  |-------X   X--------X  ASP2  X
>     |        |                    X        X
>     |________|            Failure X_X_X_X_XX
>         |                              |    
>         | <----ASP Failure             |    
>         |___________        ___X    X__|    
>                     |      |                
>                     |      |                
>                     |______|                
>                    |        |               
>                    |        |               
>                    |  SGP1  |               
>                    |        |               
>                    |________|               
>                                             
> 
> If SGP1 sends ASP Failure when ASP2 sends ASP Down in the top 
> diagram, it will
> defeat the purpose of distingushing the two scenarios.  ASP 
> Failure is only
> sent when (from the SGP's view) the ASP has failed.  
> Informing ASP1 of this
> permits it to determine whether ASP2 has failed utterly or 
> whether it has just
> lost communication to it.

Agreed.

> 
> > 7)  Should an Error (Invalid Version) be sent for any message with
> > invalid version.  Currently, the text indicates it is only sent for
> > an invalid version in ASP Up message.  Should add text to Section
> > 3.8.1.
> 
> That's right.  Only for ASP Up.  ASPs are not expected to 
> really need to
> spontaneously change versions in the middle of transmissions.
> 

Agreed.

> > 
> > 8)  In IPSP SE, should the ASP receiving ASP Up/Active Ack
> > also send Notify messages?  General though is that it should.
> 
> No, the IPSP sending ASP Up/Active Ack sends Notify.

I agree with the general thought. Once the communication is established they should work in a peer-to-peer basis. Then both could send NTFY.-

Cheers // Javier.
> 
> --brian
> 
> -- 
> Brian F. G. Bidulock
> [email-masked]
> http://www.openss7.org/
> 
> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/sigtran
> 

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 5 Sep 2003 08:09:57 -0600

J.Javier,

J.Javier Pastor (KI/EEM) wrote:                                                   (Fri, 05 Sep 2003 15:11:24)

[snip]
> 
> Yes, we finally agreed to remove it and stated that people could look at the
> different threads where it was discussed to find possible solutions.
> 

Sure.

> It was agreed to send the NTFY("Insufficient ASPs"), and the Status Type
> therefore should be "Other". Nothing new is needed to be defined.

No, also for sending the current state of the AS to ASPs newly entering the
ASP-INACTIVE state from ASP-DOWN.  So when ASP-x comes online and goes
ASP-INACTIVE from ASP-DOWN I would send "AS State Change - AS Active" when the
state has not changed?  (It always was active, I'm just informing the newly
ASP-INACTIVE ASP).

Or would it be better to send "AS State Indication - AS Active?".
                                  ^^^^^^^^^^^^^^^^
Distinguishing this initial boot-up notification from a state change
notification has value.

[snip]
> I agree with the general thought. Once the communication is established they
> should work in a peer-to-peer basis. Then both could send NTFY.-

Both sending notify would be both acting like SG.  Which is SG-SG
communication.  Which is something different that SE and DE.  SE is
inherently ASP-SG communication.  Only one side behaves like an SG.
Only one side sends notify.

Don't try to make SE, DE again... ;)

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/