Subject: RE: [Sigtran] M3UA IG05 :Response to ASPIA

From: "J.Javier Pastor (TS/EEM)" <[email-masked]>
Date: Tue, 23 Sep 2003 15:43:01 +0200

Brian, 

Could you please refer where that decission was agreed? I didn't find it...

Thanks // Javier.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: martes, 23 de septiembre de 2003 12:34
> To: [email-masked]
> Cc: [email-masked]
> Subject: Re: [Sigtran] M3UA IG05 :Response to ASPIA
> 
> 
> 
> 
> 
> 
> Brian,
>              It is not there in current IG.
> 
> 
> 
> 
> "Brian F. G. Bidulock" <[email-masked]> on 09/23/2003 
> 03:56:25 PM
> 
> Please respond to [email-masked]
> 
> To:    Kamesh Kaul/HSS@HSS
> cc:    [email-masked]
> 
> Subject:    Re: [Sigtran] M3UA IG05 :Response to ASPIA
> 
> 
> kakaul,
> 
> We already agreed to drop the 's' (plural) from Application Server's'
> in these passages.
> 
> --brian
> 
> [email-masked] wrote:
> (Tue, 23 Sep 2003 15:33:15)
> >
> >
> >
> >
> > Hi,
> >          Referring to section 4.3.4.3 ASP Active Procedures
> >
> >    "In the case where an ASP Active message does not 
> contain a Routing
> > Context
> >    parameter, the receiver must know, via configuration data, which
> >        Application Server(s) the ASP is a member."
> >
> >      Referring to section 4.3.4.4 ASP Inactive Procedures
> >
> >         "In the case where an ASP Inactive message does not
> >    contain a Routing Context parameter, the receiver must know, via
> >    configuration data, which Application Servers the ASP is 
> a member and
> >        move the ASP to the ASP-INACTIVE state in all Application
> Servers."
> >
> > These lines imply that if ASPAC/IA messages is received without RC
> receiver
> > should activate/inactivate all the application servers 
> served by ASP.
> > If that is not implied then some clearification should be 
> added in IG to
> > make RC conditional in ASPAC and ASPIA messages aswell to avoid any
> further
> > confusions. Current IG does not address this problem
> >
> > Kamesh Kaul
> > www.hssworld.com
> > Hughes Software Systems
> 
> --
> Brian F. G. Bidulock
> [email-masked]
>  http://www.openss7.org/
> 
> 
> 
> 
> 
> 
> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/sigtran
> 

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 23 Sep 2003 11:41:28 -0600

J.Javier,

A few moons ago now.  Perhaps Tolga can recall the name of the thread...

The point was that the RFC permits an SG implementation to decide what
"configured" means and refuse any ASPAC/ASPIA without an RC value with "No
Configured AS for ASP".  The wildcard behavior is not guaranteed by the RFC.
The ASP must include RC in DATA and SNMM if there is more than a single AS and
must therefore know the values if there is more than one AS and an SG
implementation is fully within its rights to refuse any ASPAC/ASPIA where
there is more than one AS.

Note that the error message say "No Configured AS for ASP", not "No Configured
AS(s) for ASP".

The situation was meant to accomodate the case where the ASP thought that it
was not necessary to include RC in any message, but there is not a single AS
configured for the ASP.

If the wildcard behavior is necessary, it needs to be stated under which
conditions the SG should not (or must not) respond with "No Configured AS for
ASP".  But that is rather pointless for M3UA, as the ASPs need to know the RC
values in any case.  For SUA, the matter is a little different.  SUA can have
many thousands of RC values representing GTT entries.  Wildcarding in this
fashion is a short-hand for long SUA messages.  M2UA gets around this by
activating IIDs rather than AS, and providing its own shorthand and rules for
specifying ranges of IIDs that make up a single AS.

Somehow I don't think that we can get away without making some statement
in the IG.

Perhaps the advocates of the "wildcard" behavior can propose text.

--brian

J.Javier Pastor (TS/EEM) wrote:                                                   (Tue, 23 Sep 2003 15:43:01)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/