Subject: RE: [Sigtran] Sigtran Plugtest - DAY 2-5: M3UA NTFY

From: "J.Javier Pastor (KI/EEM)" <[email-masked]>
Date: Fri, 5 Sep 2003 16:34:28 +0200

Brian, 

See my comments below...

> -----Original Message-----
> From: Brian F. G. Bidulock [mailto:[email-masked]]
> Sent: viernes, 05 de septiembre de 2003 16:10
> To: J.Javier Pastor (KI/EEM)
> Cc: Ken Morneault; [email-masked]
> Subject: Re: [Sigtran] Sigtran Plugtest - DAY 2-5
> 
> 
> J.Javier,
> 
> J.Javier Pastor (KI/EEM) wrote:                               
>                     (Fri, 05 Sep 2003 15:11:24)
> 

 [snip]

> > > > 
> > > > 4)  It has been agreed that the AS state be sent in a 
> > > Notify message 
> > > > when an ASP transfers to ASP-INACTIVE (assuming the SG 
> knows which
> > > > AS(es) the ASP is configured for).  However, the Status 
> > > Type "AS State
> > > > Change" seems inappropriate.  Suggest a new Status Type.
> > > 
> > > Excellent suggestion.  How about "State Indication" ?  What 
> > > about failed ASPs?
> > > Does an SG inform newly INACTIVE ASPs in an AS about ASP 
> > > failures that occured
> > > before it became inactive (and which are still failed)?
> > > 
> > 
> > It was agreed to send the NTFY("Insufficient ASPs"), and 
> the Status Type
> > therefore should be "Other". Nothing new is needed to be defined.
> 
> No, also for sending the current state of the AS to ASPs 
> newly entering the
> ASP-INACTIVE state from ASP-DOWN.  So when ASP-x comes online and goes
> ASP-INACTIVE from ASP-DOWN I would send "AS State Change - AS 
> Active" when the
> state has not changed?  (It always was active, I'm just 
> informing the newly
> ASP-INACTIVE ASP).
> 
> Or would it be better to send "AS State Indication - AS Active?".
>                                   ^^^^^^^^^^^^^^^^
> Distinguishing this initial boot-up notification from a state change
> notification has value.
> 

Ok, referring to that case, my opinion is that the only fact that bother the new ASP getting ASP-INACTIVE state from ASP-DOWN state, is the current state of the AS. That information is already provided with the current posibilities. What would be the difference if we include the "State-Indication"? Would the ASP react in a different way?

Cheers // Javier.

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 5 Sep 2003 08:39:09 -0600

J.Javier,

J.Javier Pastor (KI/EEM) wrote:                                                   (Fri, 05 Sep 2003 16:34:28)
> Ok, referring to that case, my opinion is that the only fact that bother the
> new ASP getting ASP-INACTIVE state from ASP-DOWN state, is the current state
> of the AS. That information is already provided with the current
> posibilities. What would be the difference if we include the
> "State-Indication"? Would the ASP react in a different way?

As there is no required behavior in response to NTFY, one cannot say that the
ASP would necessarily act in one way or the other.  One thing is sure:
saying "State-Indication" provides more INFORMATION upon which the ASP can
make an informed decision, because the ASP can distinguish the case of being
notified about a pre-exisiting event and being notified about an impending
event.  Case in point might be "State Indication - AS Pending".  If this had
just occured, the ASP might want to jump in.  If it has persisted for some
time, the ASPs action might be more conservative.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/