Subject: RE: [Sigtran] M3UA-IG05-Notify to ASPs moving from Down->Inactive

From: [email-masked]
Date: Thu, 11 Sep 2003 14:32:58 +0530

Hi Tolga

Hi Anjali,
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> [email-masked]
> Sent: Wednesday, September 10, 2003 8:48 AM
> To: [email-masked]
> Subject: [Sigtran] M3UA-IG05-Notify to ASPs moving from Down->Inactive
>
>
>
>
>
>
> Hi all
>
>  This is regarding  sending Notify specifying the AS-state
>   to the ASPs transitioning to Inactive  from Down.
>
>   In order to clearly demarcate the above scenario from the
>   normal one where AS-state change is notified to the ASPs
>   through Notify message
>   IMO ,  Notify message should contain another
>   status type such as AS-State-update and corresponding to
>   this status information as the as state.
>
>  This issue was raised during plugtest discussions and later
>  on list but nothing finalized.
[TOLGA] IMO, a new status type is not necessary. One might argue, that a
new
status type might give ASP some extra information, but IMO this information
is already implicitly present at ASP, i.e. ASP itself knows that it has
just
switched from DOWN to INACTIVE and that the NTFY it is going to receive is
for state update rather than a newly occuring event.

[ANJALI] The reason for this is as I  had mentioned above also distinction
between  the two scenarios of as-state change and as-state update, where an
ASP would know explicitly that NTFY is being sent to indicate state update
.
Apart from this .IMO this would also avoid the case when  two different
implementations are interoperating with the ASP implementation not
expecting
Notify with status type AS_STATE_CHANGE after moving from Down->Inactive
and SGP implementation sending the same, which would create problem.
The above wont occur in case a new status type is sent in Notify
which an ASP can just ignore.

_______________________________________________
Sigtran mailing list
[email-masked]
 https://www1.ietf.org/mailman/listinfo/sigtran

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Tolga Asveren" <[email-masked]>
Date: Thu, 11 Sep 2003 10:09:42 -0400

Hi Anjali,
> Sent: Thursday, September 11, 2003 5:03 AM
> To: Tolga Asveren
> Cc: [email-masked]
> Subject: RE: [Sigtran] M3UA-IG05-Notify to ASPs moving from
> Down->Inactive
>
>
>
>
>
>
> Hi Tolga
>
>
>
>
> Hi Anjali,
[TOLGA]IMO, because ASP itself is aware that it has restarted, there is no
need to indicate this with a special status type. I furthermore would think,
this information is not very usefull.
> which an ASP can just ignore.
[TOLGA]Why? If ASP wants to do so, it can always ignore the NTFY. I don't
see a problem here. And as I mentioned above, I doubt that ASPs behavior
will/should be different for NTFY received as state update or as state
change.