Subject: [Sigtran] (M2PA) LSPO and LSPR sent on stream 1 and LSPR used to re-synch resolves PO issue?

From: [email-masked]
Date: Thu, 25 Sep 2003 07:54:50 -0400

Hello All,

I also agree LSPO and LSPR should be sent on stream 1, and that LSPR
should be used to re-synch sequence numbers.

Does this resolve all of M2PA's outstanding processor outage issues?

Regards,

Jeff

                      David Lehmann                                                                                               
                      <lehmann@ulticom         To:      [email-masked]                                                      
                      .com>                    cc:      [email-masked], Andrew Booth <[email-masked]>, Tom George             
                      Sent by:                 <[email-masked]>, [email-masked]                                         
                      sigtran-admin@ie         Subject: Re: [Sigtran] Misc M2PA questions                                         
                      tf.org                                                                                                      

                      09/19/03 11:21                                                                                              
                      AM                                                                                                          

Brian F. G. Bidulock wrote:
> I still think
> that LS PO and LS PR (or maybe just LS PR) should be sent on stream '1'
to
> avoid problems in the wild.

I agree that both LSPO and LSPR should be on the data stream.
Was there any resolution on this matter?

--

David Lehmann                          Ulticom, Inc.
AOL/Yahoo IM: davidULCM                1020 Briggs Road
1-856-787-2729                         Mt. Laurel, NJ 08054   USA

_______________________________________________
Sigtran mailing list
[email-masked]
 https://www1.ietf.org/mailman/listinfo/sigtran

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: Andrew Booth <[email-masked]>
Date: Thu, 25 Sep 2003 15:18:20 -0400

Hi Jeff,

I think there is still the question of whether the side experiencing LPO 
is supposed to resynchronize sequence numbers after a flush and if so, how.

Andrew

-- 
Andrew Booth, Software Developer
Signaling Systems Group, Performance Technologies
613-237-4344

Visit www.pt.com/mailing.html to subscribe to our Packets & Signals eLetter.

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 25 Sep 2003 13:40:17 -0600

Andrew,

Andrew Booth wrote:                                                                 (Thu, 25 Sep 2003 15:18:20)
> is supposed to resynchronize sequence numbers after a flush and if so, how.

Yes.  I propose sending LS Ready response to LSPR to accomplish this.
If LSPR is sent on stream 1, this LS Ready should be sent on stream 1 as
well, as follows:

all on stream 1:

        LSPR
   --------------->
     DATA (ACK)
  <---------------
  <---------------
  <---------------
         LSR
  <---------------
  resync

     DATA ACK
   --------------->
         LSR
   --------------->
            resync

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: Tom George <[email-masked]>
Date: Fri, 26 Sep 2003 09:56:12 -0500

This looks OK to me and everyone else seems to like it. I will go ahead 
and put it into the draft.

tomG.

-- 
* Tom George       PB7-24001 (near B-21)      [email-masked]  *
* 972-519-3168   Intranet:  http://www.ssd.usa.alcatel.com/~tgeorge/  *
*   I actively disclaim speaking for Alcatel.  I do not purport to    *
*   advertise or represent its position, operations, or activities.   *