Subject: RE: [Sigtran] M2UA additional IIDs supported

From: "Therese Keenan" <[email-masked]>
Date: Thu, 11 Sep 2003 08:56:59 -0500

Brian -

What is the intended reason for having an optional IID list parameter within
the ASPAC?

To clarify what you commented on in the e-mail below: The IIDs are manually
provisioned on both the SGP and the ASP.  The ASP has knowledge of what IIDs
it supports and what SGPs it connects to for each IID. I do not want to
provision any ASP address information on the SGP. This information can be
determined from the provisioning on the ASP. 

Thanks,
Therese

-----Original Message-----
From: Brian F. G. Bidulock [mailto:[email-masked]] 
Sent: Wednesday, September 10, 2003 4:15 PM
To: Keenan, Therese [RICH2:TX73:EXCH]
Cc: [email-masked]
Subject: Re: [Sigtran] M2UA additional IIDs supported

Therese,

I don't understand, in (4) below you say that the IIDs are then "manually
configured on ASP1 and on SGP."  Now you are saying you don't want to
configure the IIDs at the SGP?  How will it ever know to which physical
interface an IID corresponds?

--brian

Therese Keenan wrote:
(Wed, 10 Sep 2003 14:30:27)
> 
>    Hi Brian -
> 
>    Thanks for getting back to me. What we are trying to do is use the ASP
>    active  message  with  the IIDs encoded. The reason is that we did not
>    want  to  provision  all of the ASP connections on each of our SGPs --
>    lots of provisioning and lots of room for error.
> 
>    I  think  if  there  is the ability to include the IIDs within the ASP
>    active message, there should be some sort of method to update the list
>    of  supported  IIDs.Otherwise, this would mean that any implementation
>    that  sends  the list of supported IIDs within the ASPAC message would
>    never be able to update the IIDs. What do you think?
> 
>    Thanks for your input,
> 
>    Therese
> 
>    -----Original Message-----
>    From: Brian F. G. Bidulock [[1]mailto:[email-masked]]
>    Sent: Wednesday, September 10, 2003 2:20 PM
>    To: Keenan, Therese [RICH2:TX73:EXCH]
>    Cc: [email-masked]
>    Subject: Re: [Sigtran] M2UA additional IIDs supported
> 
>    Therese,
> 
>    Therese Keenan
>    wrote:
>    (Wed, 10 Sep 2003 13:39:12)
>    >
>    >    Hi Everyone -
>    >
>    >      This   is   an   M2UA  implementation  question.  Here  is  the
>    configuration:
>    >
>    >                               SGP <----> ASP1
>    >
>    >    1. ASP1:Sends ASP UP to SGP
>    >    2. SGP: Sends ASP UP Ack to ASP1
>    >    3. ASP1: Sends ASP Active with the optional list of IIDs encoded
>    >    4. SGP:
>    >          a.  Updates  the  State  of  ASP1  -  ready to receive MAUP
>    messaging
>    >          b.  Updates  the  IIDs supported by this ASP (based on list
>    provided
>    >    within ASP Active)
>    >         c. Sends ASP Active ACK
>    >         d. Sends notify (ASP active)
>    >
>    >    4.  An  additional IID is then manually configured on ASP1 and on
>    SGP.
>    >    ASP1 wants to support this IID.
>    >
>    >     How   does   ASP1   inform  SGP that it wants to support the new
>    manually
>    >     provisioned   IID?   Does  ASP1  send another ASP Active message
>    including
>    >    all of the IIDs it wants to support or do we need a separate
>    > message?
> 
>    Don't  send  ASP Active and don't send a separate message.  Once it is
>    configured, Just establish the link from the ASP and start using 
> it.
> 
>    --brian
> 
>    >
>    >    Thanks for your input,
>    >    Therese
> 
>    --
>    Brian F. G. Bidulock
>    [email-masked]
>    [2]http://www.openss7.org/
> 
> References
> 
>    1. mailto:[email-masked]
>    2. http://www.openss7.org/

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 11 Sep 2003 11:05:34 -0600

Therese,

Therese Keenan wrote:                                                              (Thu, 11 Sep 2003 08:56:59)
> 
>    Brian -
> 
>    What  is the intended reason for having an optional IID list parameter
>    within the ASPAC?

The intention of the option IID list parameter was to allow an ASP to
activate a fully or partially specified set of links on a single AS.

If you add an IID to the group at the SGP, there is no need to reactivate
the AS.

--brian

> 
>    To  clarify  what  you  commented on in the e-mail below: The IIDs are
>    manually  provisioned  on  both  the  SGP  and  the  ASP.  The ASP has
>    knowledge  of  what  IIDs it supports and what SGPs it connects to for
>    each  IID.  I  do not want to provision any ASP address information on
>    the  SGP.  This information can be determined from the provisioning on
>    the ASP.
> 
>    Thanks,
>    Therese
> 
>    I  don't  understand,  in  (4)  below  you  say that the IIDs are then
>    "manually  configured  on  ASP1  and  on SGP."  Now you are saying you
>    don't want to configure the IIDs at the SGP?  How will it ever know to
>    which physical interface an IID corresponds?
> 
>    --brian
> 
>    Therese Keenan
>    wrote:
>    >    From: Brian F. G. Bidulock [[1][2]mailto:[email-masked]]
>    >    [2][3]http://www.openss7.org/
>    >
>    > References
>    >
>    >    1. [4]mailto:[email-masked]
>    >    2. [5]http://www.openss7.org/
> 
>    --
>    Brian F. G. Bidulock
>    [email-masked]
>    [6]http://www.openss7.org/
> 
> References
> 
>    2. mailto:[email-masked]
>    3. http://www.openss7.org/
>    4. mailto:[email-masked]
>    5. http://www.openss7.org/
>    6. http://www.openss7.org/

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran