Subject: RE: [Sigtran] M3UA IG v05 - Parameter problems in Sending NTFY af ter sending ASP-INACTIVE-ACK

From: "J.Javier Pastor (TS/EEM)" <[email-masked]>
Date: Tue, 23 Sep 2003 16:36:47 +0200

Hi Barry, 

I also agree with Tolga. I think we can make it with the current "AS-StateChange" since having and additional code does not provide any valuable extra information. This was also mentioned in the thread "Sigtran Plugtest - DAY 2-5: M3UA NTFY".

Could we survive with the current name ("change") or do you think we really need to change it to "notification"?

Cheers // Javier.

> -----Original Message-----
> From: Tolga Asveren [mailto:[email-masked]]
> Sent: viernes, 12 de septiembre de 2003 16:21
> To: [email-masked]
> Subject: RE: [Sigtran] M3UA IG v05 - Parameter problems in 
> Sending NTFY
> after sending ASP-INACTIVE-ACK
> 
> 
> > -----Original Message-----
> > From: [email-masked] 
> [mailto:[email-masked]]On Behalf Of
> > Barry Nagelberg
> > Sent: Friday, September 12, 2003 10:13 AM
> > To: SIGTRAN Mailing List
> > Subject: [Sigtran] M3UA IG v05 - Parameter problems in Sending NTFY
> > after sending ASP-INACTIVE-ACK
> >
> >
> > There are also parameter problems in Section 3.22 of M3UA 
> IG v05 (Sending
> > NTFY after sending ASP-INACTIVE-ACK):
> >
> > The purpose of this change is to notify the ASP about the 
> state of an AS,
> > following reception of ASPUP at the SGP. The unstated scenario
> > here is that
> > the AS state has not changed - otherwise a Notify message 
> would have been
> > sent automatically.
> >
> > But because the AS state has not changed, there is a problem in
> > choosing the
> > correct State Type and State Information parameters for the
> > Notify message.
> > For Status Type, we can't use "AS-StateChange", because the 
> state has not
> > changed. Thus we must use "Other".
> >
> > But within "Other", there are no suitable State Information
> > values. None of
> > the current values - "Insufficient ASP resources active in 
> AS", "Alternate
> > ASP Active", or "ASP Failure" are suitable.
> >
> > We will need a new Status Type value such as "AS State 
> Notification".
> [TOLGA]Or we change status type "AS-StateChange" to 
> "AS-StateChange/Update"
> or "AS-StateNotification" -afterall informing about an AS 
> state change is
> also a notification-
> 
> 
> 
> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/sigtran
> 

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Barry Nagelberg" <[email-masked]>
Date: Tue, 23 Sep 2003 10:46:18 -0400

Javier,

Yes, I think that the current "AS-StateChange" is OK. The ASP which receives
this NTFY message will just have to do an extra check to see if the AS state
has really changed or not.

Barry Nagelberg

> From: J.Javier Pastor (TS/EEM) [mailto:[email-masked]]
> Sent: Tuesday, September 23, 2003 10:37 AM
> To: [email-masked]; 'Barry Nagelberg'
> Cc: 'Tolga Asveren'
> Subject: RE: [Sigtran] M3UA IG v05 - Parameter problems in Sending NTFY
> I also agree with Tolga. I think we can make it with the current
> "AS-StateChange" since having and additional code does not
> provide any valuable extra information. This was also mentioned
> in the thread "Sigtran Plugtest - DAY 2-5: M3UA NTFY".
>
> Could we survive with the current name ("change") or do you think
> we really need to change it to "notification"?
>
> Cheers // Javier.
>