Subject: Re: [Sigtran] M3UA IG05 :Response to ASPIA

From: [email-masked]
Date: Wed, 24 Sep 2003 09:27:48 +0530

Hi,  Sorry for typo in New text it is ASP-ACTIVE instead of ASP-INACTIVE
   In my understanding Section 4.3.4.3 in RFC needs minor change:

   Old Text:
  In the   case where an ASP Active message does not contain a Routing
Context parameter, the receiver must know, via configuration data, which
Application Server(s) the ASP is a member.

New Text:
  In the case where an ASP Active message does not contain a Routing
Context parameter, the receiver must know, via configuration data, which
Application Server(s) the ASP is a member and move the ASP to the
ASP-ACTIVE state in all Application  Servers.

 Also error code No Configured AS for ASP should mean that receiver of
ASPAC/ASPIA messages has no configured AS for the ASP/IPSP  sending
ASPAC/ASPIA messages.In this case IG 05 section 3.9.2 should be changed to
give correct meaning of the error code.

Kamesh Kaul
www.hssworld.com
Hughes Software Systems

"Brian F. G. Bidulock" <[email-masked]> on 09/23/2003 11:11:28 PM

Please respond to [email-masked]

To:    "J.Javier Pastor (TS/EEM)" <[email-masked]>
cc:    [email-masked], Kamesh Kaul/HSS@HSS

Subject:    Re: [Sigtran] M3UA IG05 :Response to ASPIA

J.Javier,

A few moons ago now.  Perhaps Tolga can recall the name of the thread...

The point was that the RFC permits an SG implementation to decide what
"configured" means and refuse any ASPAC/ASPIA without an RC value with "No
Configured AS for ASP".  The wildcard behavior is not guaranteed by the
RFC.
The ASP must include RC in DATA and SNMM if there is more than a single AS
and
must therefore know the values if there is more than one AS and an SG
implementation is fully within its rights to refuse any ASPAC/ASPIA where
there is more than one AS.

Note that the error message say "No Configured AS for ASP", not "No
Configured
AS(s) for ASP".

The situation was meant to accomodate the case where the ASP thought that
it
was not necessary to include RC in any message, but there is not a single
AS
configured for the ASP.

If the wildcard behavior is necessary, it needs to be stated under which
conditions the SG should not (or must not) respond with "No Configured AS
for
ASP".  But that is rather pointless for M3UA, as the ASPs need to know the
RC
values in any case.  For SUA, the matter is a little different.  SUA can
have
many thousands of RC values representing GTT entries.  Wildcarding in this
fashion is a short-hand for long SUA messages.  M2UA gets around this by
activating IIDs rather than AS, and providing its own shorthand and rules
for
specifying ranges of IIDs that make up a single AS.

Somehow I don't think that we can get away without making some statement
in the IG.

Perhaps the advocates of the "wildcard" behavior can propose text.

--brian

J.Javier Pastor (TS/EEM) wrote:
(Tue, 23 Sep 2003 15:43:01)
> Brian,
>
> Could you please refer where that decission was agreed? I didn't find
it...
>
> Thanks // Javier.
>
> > -----Original Message-----
> > From: [email-masked] [mailto:[email-masked]]
> > Sent: martes, 23 de septiembre de 2003 12:34
> > To: [email-masked]
> > Cc: [email-masked]
> > Subject: Re: [Sigtran] M3UA IG05 :Response to ASPIA
> >
> >
> >
> >
> >
> >
> > Brian,
> >              It is not there in current IG.
> >
> >
> >
> >
> > "Brian F. G. Bidulock" <[email-masked]> on 09/23/2003
> > 03:56:25 PM
> >
> > Please respond to [email-masked]
> >
> > To:    Kamesh Kaul/HSS@HSS
> > cc:    [email-masked]
> >
> > Subject:    Re: [Sigtran] M3UA IG05 :Response to ASPIA
> >
> >
> > kakaul,
> >
> > We already agreed to drop the 's' (plural) from Application Server's'
> > in these passages.
> >
> > --brian
> >
> > [email-masked] wrote:
> > (Tue, 23 Sep 2003 15:33:15)
> > >
> > >
> > >
> > >
> > > Hi,
> > >          Referring to section 4.3.4.3 ASP Active Procedures
> > >
> > >    "In the case where an ASP Active message does not
> > contain a Routing
> > > Context
> > >    parameter, the receiver must know, via configuration data, which
> > >        Application Server(s) the ASP is a member."
> > >
> > >      Referring to section 4.3.4.4 ASP Inactive Procedures
> > >
> > >         "In the case where an ASP Inactive message does not
> > >    contain a Routing Context parameter, the receiver must know, via
> > >    configuration data, which Application Servers the ASP is
> > a member and
> > >        move the ASP to the ASP-INACTIVE state in all Application
> > Servers."
> > >
> > > These lines imply that if ASPAC/IA messages is received without RC
> > receiver
> > > should activate/inactivate all the application servers
> > served by ASP.
> > > If that is not implied then some clearification should be
> > added in IG to
> > > make RC conditional in ASPAC and ASPIA messages aswell to avoid any
> > further
> > > confusions. Current IG does not address this problem
> > >
> > > Kamesh Kaul
> > > www.hssworld.com
> > > Hughes Software Systems
> >
> > --
> > Brian F. G. Bidulock
> > [email-masked]
> >  http://www.openss7.org/
> >
> >
> >
> >
> >
> >
> > _______________________________________________
> > Sigtran mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/sigtran
> >

--
Brian F. G. Bidulock
[email-masked]
 http://www.openss7.org/

"DISCLAIMER: This message is proprietary to Hughes Software Systems Limited
(HSS) and is intended solely for the use of the individual to whom it is
addressed. It may contain  privileged or confidential information and
should not be circulated or used for any purpose other than for what it is
intended. If you have received this message in error, please notify the
originator immediately. If you are not the intended recipient, you are
notified that you are strictly prohibited from using, copying, altering, or
disclosing the contents of this message. HSS accepts no responsibility for
loss or damage arising from the use of the information transmitted by this
email including damage from virus."

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 23 Sep 2003 23:00:30 -0600

kakaul,

I don't see how this guarantees the wildcard behavior.  As configuration
data is a local (and optional) thing, the SG is still at liberty to send the
error code whenever RC is missing.

--brian

[email-masked] wrote:                                                           (Wed, 24 Sep 2003 09:27:48)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/