Subject: Re: [Sigtran] Sigtran Plugtest - DAY 2-5: DAUD Question

From: [email-masked]
Date: Wed, 10 Sep 2003 17:41:05 +0530

Hi all,

       Correct SS7 point code was d.e.f

       Figure below shows two AS's AS1 with
       routing key DPC only, AS2 with routing
       key (DPC + OPC). One of the questions
       that was raised in recent plugtestwas
       that if AS1 sends DAUD message for point
       code a.b.c what should be the response of
       SG to the received DAUD from AS. Some of the
       participants said DUNA.
       Please give your comments on the same.

                                             DPC x.y.z

                                           +------------+
                                           |            |
                                       -----            |
                                      |    |   AS 1     |
                                      |    |            |
    PC d.e.f      +-----------+       |    +------------+
   +------+       |           |       |
   |      |       |           |       |
   |      --------|  SG       --------
   |      |       |           --------     +------------+
   +------+       |           |       |    |            |
                  +-----------+       |    |            |
                                       -----   AS 2     |
                                           |            |
                                           +------------+
                                             DPC a.b.c
                                                +
                                             OPC d.e.f

Regards
Kamesh Kaul
www.hssworld.com
Hughes Software Systems

"DISCLAIMER: This message is proprietary to Hughes Software Systems Limited
(HSS) and is intended solely for the use of the individual to whom it is
addressed. It may contain  privileged or confidential information and
should not be circulated or used for any purpose other than for what it is
intended. If you have received this message in error, please notify the
originator immediately. If you are not the intended recipient, you are
notified that you are strictly prohibited from using, copying, altering, or
disclosing the contents of this message. HSS accepts no responsibility for
loss or damage arising from the use of the information transmitted by this
email including damage from virus."

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Tolga Asveren" <[email-masked]>
Date: Wed, 10 Sep 2003 10:02:57 -0400

>        Please give your comments on the same.
[TOLGA]
a)If DUNA is has to be sent, this probably would mean that SG is keeping
destination status per OPC/DPC pair rather than just per DPC. I wouldn't
think that it is a good idea to force to have such a logic on each SG.

b)If DUNA not sent, then what will happen with messages, sent from AS1 with
DPC=a.b.c? Sending DUNA (or even maybe sending DUPU with AffectedPC=a.b.c).
Probably sending DUNA in such a case should work -AS1 will receive it and
might send DAUD after a while, which will be answered with DAVA, but the
first DATA afterwards with DPC=a.b.c will cause again a new DUNA.

   1-1-1
 +------+
 | SEP1 +-------+                        AS1:DPC=3-3-3
 +------+       |                            OPC=1-1-1
              +-+----+      +------+     +------+
              | STP1 +------+ SG1  +-----+ ASP1 |
  2-2-2       +-+----+      +------+     +------+
 +------+       |
 | SEP2 +-------+
 +------+

SG1 is seen as a regular STP from SS7 point of view. Now (considering that
AS1 is ACTIVE), what will be status of the route for Pc=3-3-3 via SG1 on
STP1, allowed or not? (Just as a -really ugly-
workaround, one can think, that it is allowed and messages with
OPC=2-2-2/DPC=3-3-3 will be replies with UPU for the corrsponding user part
at SG -but then SEP2 will keep trying etc...) Especially when I think on
that example, it seems to me that DPC/IPC RKs are not very easy to handle
because there is no such contruct on MTP3.

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 10 Sep 2003 11:40:35 -0600

kakaul,

The SG is permitted to transfer traffic between AS.  Because the
SG hosts both both codes x.y.z and a.b.c, the response would normally
be DAVA.

--brian

[email-masked] wrote:                                                           (Wed, 10 Sep 2003 17:41:05)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/