Subject: RE: [Sigtran] M3UA : 2 or 4 messages for ASP-UP in IPSP DE ?

From: "J.Javier Pastor (ML/EEM)" <[email-masked]>
Date: Wed, 20 Jul 2005 12:50:53 +0200

Brian, 

If you say that having one ASPUP exchange is not feasible (due to big problems) for DE, it should also apply to SE. Otherwise single ASPUPexchange in DE should be seen as a technical improvement since you don't use more messages than needed. 

cheers // Javier.

-----Original Message-----
From: Brian F. G. Bidulock [mailto:[email-masked]]
Sent: miércoles, 20 de julio de 2005 12:06
To: J.Javier Pastor (ML/EEM)
Cc: 'Cavalier, Laurent'; [email-masked]
Subject: Re: [Sigtran] M3UA : 2 or 4 messages for ASP-UP in IPSP DE ?

J.Javier,

Not at all. SE only requires a single exchange of messages.  DE requires
a double exchanges of messages.  It is what the S and D mean.  If you
try to skip an exchange in the DE model, it breaks.

--brian

J.Javier Pastor (ML/EEM) wrote:                                                   (Wed, 20 Jul 2005 12:24:26)
> Brian, 
> 
> Why do you have these big problems with DE and not with SE. Does it
> mean that SE is not operable for you?
> 
> Chees // Javier.

-----Original Message-----
From: Brian F. G. Bidulock [mailto:[email-masked]]
Sent: miércoles, 20 de julio de 2005 12:06
To: J.Javier Pastor (ML/EEM)
Cc: 'Cavalier, Laurent'; [email-masked]
Subject: Re: [Sigtran] M3UA : 2 or 4 messages for ASP-UP in IPSP DE ?

J.Javier,

I disagree.  Once the association is formed, both DE-IPSP must send ASP
Up.  In the example, IPSP-B must be given the opportunity to respond to
the ASP Up with ERR("Invalid Version") or ERR("Unsupported Message
Type"), or ERR("Refused - Management Blocking") or ERR("Unexpected
Message").

When IPSP-B sends ASP Up it signals its ability to send ASP
Active/Inactive messages activating or deactivating it's AS.  It does
not indicate that it is able to receive ASP Active/Inactive messages nor
that it is able to activate remote AS.  This is only indicated by
sending ASP Up Ack.  Skipping the second exchange would remove IPSP-B's
ability to indicate its inability to support the receipt of these
messages at this time, either by sending ERR("Refused - Management
Blocking") or by delaying sending ASP Up Ack.  IPSP-B certainly does not
need to be prepared to receive ASPTM messages until it has explicitly
sent ASP Up Ack to the peer.

Please align the example to the text.  It was never our intention to try
to make DE model operate like SE model.

--brian

J.Javier Pastor (ML/EEM) wrote:                                                   (Wed, 20 Jul 2005 10:44:07)
> Yes, you are right that the current text is saying so. This may have
> been a matter of cut&paste due to normalization of the text I
> presume... Anyway, I still think, as it was stating in previous , that
> it is not needed to send the four messages. Unless anyone objects, I
> think we could easily add a line in order to align the text and the
> example again. Otherwise, we may just remove the optionality in the
> examples...
> 
> Cheers // Javier.
> 
> -----Original Message-----
> From: Cavalier, Laurent [mailto:[email-masked]]
> Sent: miércoles, 20 de julio de 2005 10:06
> To: J.Javier Pastor (ML/EEM); [email-masked]
> Cc: [email-masked]
> Subject: RE: [Sigtran] M3UA : 2 or 4 messages for ASP-UP in IPSP DE ?
> 
> 
> Hi Javier,
> 
> It seems that you have not the same opinion than Brian and it enforce my
> confusion.
> 
> If we consider that the optimization is possible, 
> then the second exchange of ASP-UP is optional:
> 
>                  IPSP-A                           IPSP-B
>                    |                                |
>                    |<-------------ASP Up------------|
>                    |-----------ASP Up Ack---------->|
>                    |                                |
>                    |-------------ASP Up------------>| (Optional)
>                    |<----------ASP Up Ack-----------| (Optional)
>                    |                                |
> 
> With the previously described assumption, why in the last M3UA RFC
> 3332Bis-04, 
> in paragraph "4.3.4.1.2 IPSP Considerations (ASP Up)", we have:
> 
> "  Alternatively, when using IPSP DE model, an interchange of ASP Up
>    messages from each end MUST be performed. Four messages are needed
>    for completion.  "
> 
> It seems that this sentence explain that the second exchange of ASP-UP
> is always mandatory?
> 
> Thanks
> 
> Laurent

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 20 Jul 2005 05:35:17 -0600

J.Javier,

J.Javier Pastor (ML/EEM) wrote:                        (Wed, 20 Jul 2005 12:50:53)
> Brian, 
> 
> If you say that having one ASPUP exchange is not feasible (due to big
> problems) for DE, it should also apply to SE.

That's an absurd statement.

> Otherwise single ASPUPexchange in DE should be seen as a technical
> improvement since you don't use more messages than needed. 

SE (which is all single exchange) *is* an improvement over DE.  If one
want to have single exchanges of messages, just use the SE model instead
of the inefficient DE model that cannot cope with single exchanges of
messages.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/