Subject: RE: [Sigtran] M3UA : 2 or 4 messages for ASP-UP in IPSP DE ?

From: "Cavalier, Laurent" <[email-masked]>
Date: Mon, 18 Jul 2005 14:15:28 +0200

Thanks Brian for your answer but my question was about ASP-UP in Double
Exchange.

Does only one single exchange of ASP Up/ASP Up-ack message can be
considered as enough? 
Cf. below:

                IPSP-A                           IPSP-B
                  |                                |
                  |<-------------ASP Up------------|
                  |-----------ASP Up Ack---------->|
                  |                                |
                  |<------- ASP Active(RCb)--------|
                  |-----ASP Active Ack (RCb)------>|
                  |                                |
                  |------- ASP Active(RCa)-------->|
                  |<-----ASP Active Ack (RCa)------|

Or do we need 2 exchanges of ASP Up/ASP Up-ack ? 
(4 ASPSM messages exchanged) Cf. below:

                IPSP-A                           IPSP-B
                  |                                |
                  |<-------------ASP Up------------|
                  |-----------ASP Up Ack---------->|
                  |                                |
                  |-------------ASP Up------------>|
                  |<----------ASP Up Ack-----------|
                  |                                |
                  |<------- ASP Active(RCb)--------|
                  |-----ASP Active Ack (RCb)------>|
                  |                                |
                  |------- ASP Active(RCa)-------->|
                  |<-----ASP Active Ack (RCa)------|

Thanks

Laurent

> -----Original Message-----
> From: Brian F. G. Bidulock [mailto:[email-masked]] 
> Sent: Thursday, July 14, 2005 10:51 AM
> To: Cavalier, Laurent
> Cc: [email-masked]
> Subject: Re: [Sigtran] M3UA : 2 or 4 messages for ASP-UP in IPSP DE ?

> Laurent,

> The text is correct, the example is not, really.

> In that ASP Active and Ack, I think the "(optional)" refers to the
Routing Context (which is optional, err, well, > > conditional, in ASP
Active/Ack).

> --brian

> Cavalier, Laurent wrote:                      (Wed, 13 Jul 2005
15:59:05)
> > Hello All,
> > 
> > I have one question about RFC 3332 :
> > 
> > in the last M3UA RFC 3332Bis-04, in paragraph 4.3.4.1.2, it's said 
> > that in IPSP double exchanged mode, four messages are needed for 
> > completion of the ASP Up procedure, later in dataflow example
section, 
> > the second couple of ASP Up - Up-ack is mentioned as optional.
> > 
> > Can you please clarify which of these two procedures is correct?
> > 
> > Extract of RFC 3332 :
> > 4.3.4.1.2 IPSP Considerations (ASP Up)
> > ...
> > ...
> >    Alternatively, when using IPSP DE model, an interchange of ASP Up
> > messages from each end MUST be performed. 
> >    Four messages are needed for completion.
> > ...
> > ...
> > 
> > 5.6.2 Double exchange:
> > 
> >                IPSP-A                           IPSP-B
> >                  |                                |
> >                  |<-------------ASP Up------------|
> >                  |-----------ASP Up Ack---------->|
> >                  |                                |
> >                  |-------------ASP Up------------>|  (optional)
> >                  |<----------ASP Up Ack-----------|  (optional)
> >                  |                                |
> >                  |<------- ASP Active(RCb)--------|  RC: Routing
Context
> >                  |-----ASP Active Ack (RCb)------>|      (optional)
> >                  |                                |
> >                  |------- ASP Active(RCa)-------->|  RC: Routing
Context
> >                  |<-----ASP Active Ack (RCa)------|      (optional)
> >                  |                                |
> >                  |<=========  DATA (RCa) =========|
> >                  |==========  DATA (RCb) ========>|
> >                  |                                |
> > ...
> > ...
> > 
> > Thanks
> > 
> > Laurent
> > 
> > _______________________________________________
> > Sigtran mailing list
> > [email-masked] https://www1.ietf.org/mailman/listinfo/sigtran

> -- 
> Brian F. G. Bidulock
> [email-masked]
> http://www.openss7.org/

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 18 Jul 2005 06:58:21 -0600

Larent,

The text is correct, you need double exchange of ASP UP/Ack.

We just forgot to update the example somewhere along the way.
I understand that the 'bis' draft is at IESG last call: perhaps
the editors can correct the example in the final 48 hours.

--brian

Cavalier, Laurent wrote:                                                         (Mon, 18 Jul 2005 14:15:28)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/