Subject: [Sigtran] M3UA : 2 or 4 messages for ASP-UP in IPSP DE ?

From: "Cavalier, Laurent" <[email-masked]>
Date: Wed, 13 Jul 2005 15:59:05 +0200

Hello All,

I have one question about RFC 3332 :

in the last M3UA RFC 3332Bis-04, in paragraph 4.3.4.1.2, it's said that
in IPSP double exchanged mode, four messages are needed for completion
of the ASP Up procedure, later in dataflow example section, the second
couple of ASP Up - Up-ack is mentioned as optional.

Can you please clarify which of these two procedures is correct?

Extract of RFC 3332 : 
4.3.4.1.2 IPSP Considerations (ASP Up)
...
...
   Alternatively, when using IPSP DE model, an interchange of ASP Up
messages from each end MUST be performed. 
   Four messages are needed for completion.
...
...

5.6.2 Double exchange:

               IPSP-A                           IPSP-B
                 |                                |
                 |<-------------ASP Up------------|
                 |-----------ASP Up Ack---------->|
                 |                                |
                 |-------------ASP Up------------>|  (optional)
                 |<----------ASP Up Ack-----------|  (optional)
                 |                                |
                 |<------- ASP Active(RCb)--------|  RC: Routing Context
                 |-----ASP Active Ack (RCb)------>|      (optional)
                 |                                |
                 |------- ASP Active(RCa)-------->|  RC: Routing Context
                 |<-----ASP Active Ack (RCa)------|      (optional)
                 |                                |
                 |<=========  DATA (RCa) =========|
                 |==========  DATA (RCb) ========>|
                 |                                |
...
...

Thanks

Laurent

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 14 Jul 2005 02:50:55 -0600

Laurent,

The text is correct, the example is not, really.

In that ASP Active and Ack, I think the "(optional)" refers to
the Routing Context (which is optional, err, well, conditional,
in ASP Active/Ack).

--brian

Cavalier, Laurent wrote:                      (Wed, 13 Jul 2005 15:59:05)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/