Subject: RE: [Sigtran] M3UA : 2 or 4 messages for ASP-UP in IPSP DE ?

From: "Cavalier, Laurent" <[email-masked]>
Date: Wed, 20 Jul 2005 12:03:19 +0200

Javier,

I am of the opinion that is NOT needed to send the FOUR messages,
and it would be a good choice to align the text and the example.

Laurent

-----Original Message-----
From: J.Javier Pastor (ML/EEM) [mailto:[email-masked]] 
Sent: Wednesday, July 20, 2005 10:44 AM
To: Cavalier, Laurent; [email-masked]
Cc: [email-masked]
Subject: RE: [Sigtran] M3UA : 2 or 4 messages for ASP-UP in IPSP DE ?

Yes, you are right that the current text is saying so. This may have been a matter of cut&paste due to normalization of the text I presume... Anyway, I still think, as it was stating in previous , that it is not needed to send the four messages. Unless anyone objects, I think we could easily add a line in order to align the text and the example again. Otherwise, we may just remove the optionality in the examples...

Cheers // Javier.

-----Original Message-----
From: Cavalier, Laurent [mailto:[email-masked]]
Sent: miércoles, 20 de julio de 2005 10:06
To: J.Javier Pastor (ML/EEM); [email-masked]
Cc: [email-masked]
Subject: RE: [Sigtran] M3UA : 2 or 4 messages for ASP-UP in IPSP DE ?

Hi Javier,

It seems that you have not the same opinion than Brian and it enforce my confusion.

If we consider that the optimization is possible, 
then the second exchange of ASP-UP is optional:

                 IPSP-A                           IPSP-B
                   |                                |
                   |<-------------ASP Up------------|
                   |-----------ASP Up Ack---------->|
                   |                                |
                   |-------------ASP Up------------>| (Optional)
                   |<----------ASP Up Ack-----------| (Optional)
                   |                                |

With the previously described assumption, why in the last M3UA RFC 3332Bis-04, 
in paragraph "4.3.4.1.2 IPSP Considerations (ASP Up)", we have:

"  Alternatively, when using IPSP DE model, an interchange of ASP Up
   messages from each end MUST be performed. Four messages are needed
   for completion.  "

It seems that this sentence explain that the second exchange of ASP-UP is always mandatory?

Thanks

Laurent

-----Original Message-----
From: J.Javier Pastor (ML/EEM) [mailto:[email-masked]] 
Sent: Wednesday, July 20, 2005 8:31 AM
To: [email-masked]'; Cavalier, Laurent
Cc: [email-masked]
Subject: RE: [Sigtran] M3UA : 2 or 4 messages for ASP-UP in IPSP DE ?

Hi guys, 

The example is also correct. It is just showing a possible optimisation. At the end ASP-UP is simply used to tell the other peer that you are existing. Whenever you are able to answer you are advertising this existence as well. Therefore the second exchange, although not wrong, could be easily avoided. 

If it gets some confusion, we should add this to our possible editorial improvements list...

Cheers // Javier.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: lunes, 18 de julio de 2005 14:58
To: Cavalier, Laurent
Cc: [email-masked]
Subject: Re: [Sigtran] M3UA : 2 or 4 messages for ASP-UP in IPSP DE ?

Larent,

The text is correct, you need double exchange of ASP UP/Ack.

We just forgot to update the example somewhere along the way.
I understand that the 'bis' draft is at IESG last call: perhaps the editors can correct the example in the final 48 hours.

--brian

Cavalier, Laurent wrote:
(Mon, 18 Jul 2005 14:15:28)
> Thanks Brian for your answer but my question was about ASP-UP in
> Double Exchange.
> 
> Does only one single exchange of ASP Up/ASP Up-ack message can be
> considered as enough? Cf. below:
> 
>                 IPSP-A                           IPSP-B
>                   |                                |
>                   |<-------------ASP Up------------|
>                   |-----------ASP Up Ack---------->|
>                   |                                |
>                   |<------- ASP Active(RCb)--------|
>                   |-----ASP Active Ack (RCb)------>|
>                   |                                |
>                   |------- ASP Active(RCa)-------->|
>                   |<-----ASP Active Ack (RCa)------|
> 
> Or do we need 2 exchanges of ASP Up/ASP Up-ack ?
> (4 ASPSM messages exchanged) Cf. below:
> 
>                 IPSP-A                           IPSP-B
>                   |                                |
>                   |<-------------ASP Up------------|
>                   |-----------ASP Up Ack---------->|
>                   |                                |
>                   |-------------ASP Up------------>|
>                   |<----------ASP Up Ack-----------|
>                   |                                |
>                   |<------- ASP Active(RCb)--------|
>                   |-----ASP Active Ack (RCb)------>|
>                   |                                |
>                   |------- ASP Active(RCa)-------->|
>                   |<-----ASP Active Ack (RCa)------|
> 
> Thanks
> 
> Laurent
> 
> > -----Original Message-----
> > From: Brian F. G. Bidulock [mailto:[email-masked]]
> > Sent: Thursday, July 14, 2005 10:51 AM
> > To: Cavalier, Laurent
> > Cc: [email-masked]
> > Subject: Re: [Sigtran] M3UA : 2 or 4 messages for ASP-UP in IPSP DE
?
> 
> 
> > Laurent,
> 
> > The text is correct, the example is not, really.
> 
> > In that ASP Active and Ack, I think the "(optional)" refers to the
> Routing Context (which is optional, err, well, > > conditional, in ASP

> Active/Ack).
> 
> > --brian
> 
> > Cavalier, Laurent wrote:                      (Wed, 13 Jul 2005
> 15:59:05)
> > > Hello All,
> > > 
> > > I have one question about RFC 3332 :
> > > 
> > > in the last M3UA RFC 3332Bis-04, in paragraph 4.3.4.1.2, it's said 
> > > that in IPSP double exchanged mode, four messages are needed for 
> > > completion of the ASP Up procedure, later in dataflow example
> section,
> > > the second couple of ASP Up - Up-ack is mentioned as optional.
> > > 
> > > Can you please clarify which of these two procedures is correct?
> > > 
> > > Extract of RFC 3332 :
> > > 4.3.4.1.2 IPSP Considerations (ASP Up)
> > > ...
> > > ...
> > >    Alternatively, when using IPSP DE model, an interchange of ASP
> > > Up messages from each end MUST be performed.
> > >    Four messages are needed for completion.
> > > ...
> > > ...
> > > 
> > > 5.6.2 Double exchange:
> > > 
> > >                IPSP-A                           IPSP-B
> > >                  |                                |
> > >                  |<-------------ASP Up------------|
> > >                  |-----------ASP Up Ack---------->|
> > >                  |                                |
> > >                  |-------------ASP Up------------>|  (optional)
> > >                  |<----------ASP Up Ack-----------|  (optional)
> > >                  |                                |
> > >                  |<------- ASP Active(RCb)--------|  RC: Routing
> Context
> > >                  |-----ASP Active Ack (RCb)------>|
(optional)
> > >                  |                                |
> > >                  |------- ASP Active(RCa)-------->|  RC: Routing
> Context
> > >                  |<-----ASP Active Ack (RCa)------|
(optional)
> > >                  |                                |
> > >                  |<=========  DATA (RCa) =========|
> > >                  |==========  DATA (RCb) ========>|
> > >                  |                                |
> > > ...
> > > ...
> > > 
> > > Thanks
> > > 
> > > Laurent
> > > 
> > > _______________________________________________
> > > Sigtran mailing list
> > > [email-masked] https://www1.ietf.org/mailman/listinfo/sigtran
> 
> > --
> > Brian F. G. Bidulock
> > [email-masked]
> > http://www.openss7.org/

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 20 Jul 2005 04:08:26 -0600

Laurent,

Take a look at my other note.

--brian

Cavalier, Laurent wrote:                                                         (Wed, 20 Jul 2005 12:03:19)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/