Subject: RE: [Sigtran] SCTP Payload Protocol ID for IUA & DUA

From: "Michael Mentz" <[email-masked]>
Date: Fri, 29 Jul 2005 01:21:36 +0100

Thanks Michael,

That is the way I thought, IUA PPID for everything apart from DUA messages which use DUA PPID.

As to any benefit of using the PPID, I guess it born out of a need to decide whether a message is to be routed to IUA or to DUA because the server is running separate association for each but on one SCTP port 9900.  This configuration doesn't seem right to me.

Can we clean it up and recommend that in cases where you backhaul DPNSS/DASS2 and Q931 in the same SCTP association, this is done the same IUA association using the IUA PPID for everything apart from the DUA messages defined in the DUA spec (DPTM + MGMT DUA Status)? 

DUA after all is simply some extensions to IUA, rather than a 'new' UAL and so there shouldn't be a need to run separate IUA and DUA associations as they are the same thing, especially to the same SCTP instance.

Cheers,
Mike

-----Original Message-----
From: Michael Tuexen [mailto:[email-masked]] 
Sent: 28 July 2005 17:25
To: Mentz, Michael [MOP:MA05:EXCH]
Cc: [email-masked]
Subject: Re: [Sigtran] SCTP Payload Protocol ID for IUA & DUA

Dear all,
could someone explain why you can not use an IUA PPID if you are using IUA and and DUA PPID when using DUA. If you want to, you can send both on one association.

What is the benefit from sending DUA messages with an IUA PPID? (At least ethereal will consider the DATA chunk carrying IUA)

Best regards
Michael

On Jul 28, 2005, at 16:26 Uhr, Michael Mentz wrote:

> Afternoon all,
>
> Just looking for clarification on a paragraph of the DUA specification
> :-
>
> "
>  4.0 Use of SCTP Payload Protocol ID
> As an option, IUA value for SCTP Payload Protocol ID MAY also be used 
> for DUA, for instance, if one wanted to backhaul ISDN and DPNSS over 
> the same SCTP association.  However, use of separate SCTP Payload 
> Protocol IDs (10 for DUA and 1 for IUA) is recommended as the primary 
> option even in scenarios where ISDN and DPNSS are backhauled over the 
> same SCTP association.
>
> SCTP Payload Protocol ID of "10" SHOULD be used for DUA if only DPNSS 
> is backhauled over a SCTP association - i.e., in scenarios where 
> simultaneous backhauling of ISDN and DPNSS over the same association 
> is NOT required
>
> The SCTP Payload Protocol Identifier is included in each SCTP Data 
> chunk, to indicate which protocol the SCTP is carrying. This Payload 
> Protocol Identifier is not directly used by SCTP but MAY be used by 
> certain network entities to identify the type of information being 
> carried in a Data chunk. The User Adaptation peer MAY use the Payload 
> Protocol Identifier as a way of determining whether the message is for 
> IUA or DUA.
>  "
>
> My understanding relates to a scenario where backhauling IUA and DUA 
> over the same SCTP association is required.
>
> Would I be right in thinking that the SCTP association can contain one 
> IUA association backhauling the QPTM and DPTM messages to different 
> Interface ID's? - This appears to be a valid configuration?
>
> Or is the implication that the SCTP association will actually contain 
> two separate IUA and DUA associations either running on different 
> ports, or the same port with routing done on PPID.
>
> Is there a preferred option? I see no reason why QPTM and DPTM cannot 
> be backhauled over the same IUA RFC3057 association...
>
> My thinking is that if there were separate IUA and DUA associations, 
> then the same Payload Protocol ID's would apply to all message classes 
> (ASP,QPTM),
>
> but if you are running DPTM and QPTM in the same IUA association, then 
> which would you use for message classes such as ASPSM, ASPTM, do we 
> just choose one and use it throughout?
>
> Is it's use negated due to the fact that we do not need to select 
> IUA/DUA in the first place.
>
> Many Thanks if anyone can help clarify...
>
> Mike Mentz
>
>
>
> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/sigtran

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 28 Jul 2005 21:08:27 -0600

Michael,

What is so expensive about opening a separate SCTP association?

PPID has not been used to date for multiplexing UAs over a single
association, it has more been used, as Prof. Tuexen notes, for
identifying payload on the wire for monitoring.

--brian

Michael Mentz wrote:                         (Fri, 29 Jul 2005 01:21:36)
> As to any benefit of using the PPID, I guess it born out of a need to
> decide whether a message is to be routed to IUA or to DUA because the
> server is running separate association for each but on one SCTP port
> 9900.  This configuration doesn't seem right to me.
> 
> Can we clean it up and recommend that in cases where you backhaul
> DPNSS/DASS2 and Q931 in the same SCTP association, this is done the
> same IUA association using the IUA PPID for everything apart from the
> DUA messages defined in the DUA spec (DPTM + MGMT DUA Status)? 
> 
> DUA after all is simply some extensions to IUA, rather than a 'new'
> UAL and so there shouldn't be a need to run separate IUA and DUA
> associations as they are the same thing, especially to the same SCTP
> instance.
> 
> Cheers,
> Mike
> 

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/