Subject: RE: [Sigtran] M3UA : 2 or 4 messages for ASP-UP in IPSP DE ?

From: "J.Javier Pastor (ML/EEM)" <[email-masked]>
Date: Fri, 22 Jul 2005 13:05:50 +0200

I think it is not time to change anything (technically speaking) in the draft except what IESG may find out. Therefore, my suggestion is to keep everything as agreed. The agreement was not to have always 4 messages as initially mandated, but allowing the implementation with only two... (as demonstrates the text that Laurent shows in 4.3, 4.3.1, 5.6)

It's not the proper time to change the agreements unless we want to make a completely improved new version for M3UA...

Cheers // Javier.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: jueves, 21 de julio de 2005 14:50
To: [email-masked]
Subject: RE: [Sigtran] M3UA : 2 or 4 messages for ASP-UP in IPSP DE ?

I agree with Brian and Tolga.
Let's keep the IPSP DE model as agreed before, i.e. requiring a double exchange of ASPSM and ASPTM messages.
This ensures interoperability and keeps it simple.

Valerie

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On
Behalf Of Brian F. G. Bidulock
Sent: mercredi 20 juillet 2005 22:51
To: Cavalier, Laurent
Cc: [email-masked]
Subject: Re: [Sigtran] M3UA : 2 or 4 messages for ASP-UP in IPSP DE ?

Laurent,

Cavalier, Laurent wrote:                                                         (Wed, 20 Jul 2005 18:41:31)
> Hi guys,
> 
> IMO both alternative are conceptuality possible and technically feasible.
> The most important is to standardize and remove contradiction from RFC.
> 
> If 4 messages are used for ASPUP procedure, the model is simpler
> because it's like if IPSPs are made of 1 SGP plus 1 ASP. In addition,
> it cause the bidirectional activation between two IPSP (ASPTM) to be
> unconnected and independent. 
> 
> On the other hand, Double Exchange contains the word "double" but it
> could mean that only exchanged ASPTM message need be doubled. ASPTM
> are specific to AS but ASPSM concern the whole IPSP and 2 messages
> could be enough to express M3UA layer availability. An IPSP which send
> an ASP UP has certainly an available M3UA layer, and certainly the
> IPSP which respond with an ASPUP ACK has also its local M3UA layer
> available. 

Not necessarily, in the ASPF/SGPF model, sending ASP Up only indicates
that the ASPF is available.  Sending ASP Ack indicates that the SGPF
is available.

I agree with Tolga, enforcement of 4 messages is the only way to ensure
interoperability (needs to be a MUST) and sending 2 less messages would
not be any savings, anyway.

> 
> IMO the actual draft of RFC is more oriented to a choice with only 2
> messages exchanged; it's why I thought, that at this stage, it was
> easier to target the 2 messages model (because there is few references
> to the 4 messages model in rfc). In addition, using the 2 messages
> model is more permissive and allows interoperating with all
> implementations (designed for 4 or 2 messages).

Except for the example, references to 2 messages are for the SE model.

Changing to 2 messages would require pulling the document back from IESG
or starting a bis-bis draft at this point so that we can fully comment
on the resulting text.  Also, all other ASP Up related procedures (M3UA
Version, Management Blocking, etc.) would need to be reviewed and text
added to describe how they could possibly work for DE.  With 4 messages,
these exchanges are clearly the same as the equivalent ASP/SGP procedures.
With only 2 they cannot be.  This is why I say that when you try to skip
messages in DE it breaks.

--brian

> 
> Laurent
> 
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of Tolga Asveren
> Sent: Wednesday, July 20, 2005 2:08 PM
> To: [email-masked]
> Subject: RE: [Sigtran] M3UA : 2 or 4 messages for ASP-UP in IPSP DE ?
> 
> 
> I am aware that what I am going to tell relies a bit on
> "implementation issues", but:
> 
> 1- With DE model, we always had a coupled ASP/SGP state machine in
> mind. Allowing a single ASPUP/ASPUP-ACK exchange would break that
> assumption.
> 
> 2- I don't think skipping a single ASPUP/ASPUP-ACK exchange is a very
> significant optimization and won't matter much.
> 
> Overall, IMHO for the sake of keeping things clean and simple,
> enforcing douple exchnage ASPUP/ASPUP-ACK seems a better alternative.
> 
>    Tolga
> 

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 22 Jul 2005 06:07:22 -0600

J.Javier,

I don't recall that it was ever agreed to allow 2.  I believe is just
something you added to the document between -01 and -02.  Can you point
to a thread of discussion where a concensus was reached on the
"complication" of allowing 2?  Why were you so willing to change the
document to 2, yet so unwilling to correct it to 4?

If you wish, we can always direct these comments on the technical merit
of the document directly to IESG.  Is that what you would prefer?

--brian

J.Javier Pastor (ML/EEM) wrote:              (Fri, 22 Jul 2005 13:05:50)
> I think it is not time to change anything (technically speaking) in
> the draft except what IESG may find out. Therefore, my suggestion is
> to keep everything as agreed. The agreement was not to have always 4
> messages as initially mandated, but allowing the implementation with
> only two... (as demonstrates the text that Laurent shows in 4.3,
> 4.3.1, 5.6)
> 
> It's not the proper time to change the agreements unless we want to
> make a completely improved new version for M3UA...
> 
> Cheers // Javier.
> 

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Tolga Asveren" <[email-masked]>
Date: Fri, 22 Jul 2005 07:56:37 -0400

Javier,

To my understanding, the agreement was as stated by Brian, myself and
Valerie -but this could be just my interpretation-.

   Tolga

> Behalf Of J.Javier Pastor (ML/EEM)
> Sent: Friday, July 22, 2005 7:06 AM
> To: 'Valerie Gastaud'; [email-masked]
> I think it is not time to change anything (technically speaking)
> in the draft except what IESG may find out. Therefore, my
> suggestion is to keep everything as agreed. The agreement was not
> to have always 4 messages as initially mandated, but allowing the
> implementation with only two... (as demonstrates the text that
> Laurent shows in 4.3, 4.3.1, 5.6)
>
> It's not the proper time to change the agreements unless we want
> to make a completely improved new version for M3UA...
>
> Cheers // Javier.
>
> Let's keep the IPSP DE model as agreed before, i.e. requiring a
> double exchange of ASPSM and ASPTM messages.
> > From: [email-masked]
> [mailto:[email-masked]] On Behalf Of Tolga Asveren