Subject: RE: [Sigtran] M3UA : 2 or 4 messages for ASP-UP in IPSP DE ?

From: "Cavalier, Laurent" <[email-masked]>
Date: Wed, 20 Jul 2005 18:41:31 +0200

Hi guys,

IMO both alternative are conceptuality possible and technically feasible.
The most important is to standardize and remove contradiction from RFC.

If 4 messages are used for ASPUP procedure, the model is simpler because it's like if IPSPs are made of 1 SGP plus 1 ASP. In addition, it cause the bidirectional activation between two IPSP (ASPTM) to be unconnected and independent. 

On the other hand, Double Exchange contains the word "double" but it could mean that only exchanged ASPTM message need be doubled. ASPTM are specific to AS but ASPSM concern the whole IPSP and 2 messages could be enough to express M3UA layer availability. An IPSP which send an ASP UP has certainly an available M3UA layer, and certainly the IPSP which respond with an ASPUP ACK has also its local M3UA layer available. 

IMO the actual draft of RFC is more oriented to a choice with only 2 messages exchanged; it's why I thought, that at this stage, it was easier to target the 2 messages model (because there is few references to the 4 messages model in rfc). In addition, using the 2 messages model is more permissive and allows interoperating with all implementations (designed for 4 or 2 messages).

Laurent

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Tolga Asveren
Sent: Wednesday, July 20, 2005 2:08 PM
To: [email-masked]
Subject: RE: [Sigtran] M3UA : 2 or 4 messages for ASP-UP in IPSP DE ?

I am aware that what I am going to tell relies a bit on "implementation issues", but:

1- With DE model, we always had a coupled ASP/SGP state machine in mind. Allowing a single ASPUP/ASPUP-ACK exchange would break that assumption.

2- I don't think skipping a single ASPUP/ASPUP-ACK exchange is a very significant optimization and won't matter much.

Overall, IMHO for the sake of keeping things clean and simple, enforcing douple exchnage ASPUP/ASPUP-ACK seems a better alternative.

   Tolga

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On
> Behalf Of Brian F. G. Bidulock
> Sent: Wednesday, July 20, 2005 6:06 AM
> To: J.Javier Pastor (ML/EEM)
> Cc: [email-masked]; 'Cavalier, Laurent'
> Subject: Re: [Sigtran] M3UA : 2 or 4 messages for ASP-UP in IPSP DE ?
>
>
> J.Javier,
>
> I disagree.  Once the association is formed, both DE-IPSP must send 
> ASP Up.  In the example, IPSP-B must be given the opportunity to 
> respond to the ASP Up with ERR("Invalid Version") or ERR("Unsupported 
> Message Type"), or ERR("Refused - Management Blocking") or 
> ERR("Unexpected Message").
>
> When IPSP-B sends ASP Up it signals its ability to send ASP 
> Active/Inactive messages activating or deactivating it's AS.  It does 
> not indicate that it is able to receive ASP Active/Inactive messages 
> nor that it is able to activate remote AS.  This is only indicated by 
> sending ASP Up Ack.  Skipping the second exchange would remove 
> IPSP-B's ability to indicate its inability to support the receipt of 
> these messages at this time, either by sending ERR("Refused - 
> Management
> Blocking") or by delaying sending ASP Up Ack.  IPSP-B certainly does not
> need to be prepared to receive ASPTM messages until it has explicitly
> sent ASP Up Ack to the peer.
>
> Please align the example to the text.  It was never our intention to 
> try to make DE model operate like SE model.
>
> --brian
>
> J.Javier Pastor (ML/EEM) wrote:
>                 (Wed, 20 Jul 2005 10:44:07)
> > Yes, you are right that the current text is saying so. This may have 
> > been a matter of cut&paste due to normalization of the text I 
> > presume... Anyway, I still think, as it was stating in previous , 
> > that it is not needed to send the four messages. Unless anyone 
> > objects, I think we could easily add a line in order to align the 
> > text and the example again. Otherwise, we may just remove the 
> > optionality in the examples...
> >
> > Cheers // Javier.
> >
> > -----Original Message-----
> > From: Cavalier, Laurent [mailto:[email-masked]]
> > Sent: miércoles, 20 de julio de 2005 10:06
> > To: J.Javier Pastor (ML/EEM); [email-masked]
> > Cc: [email-masked]
> > Subject: RE: [Sigtran] M3UA : 2 or 4 messages for ASP-UP in IPSP DE 
> > ?
> >
> >
> > Hi Javier,
> >
> > It seems that you have not the same opinion than Brian and it 
> > enforce my confusion.
> >
> > If we consider that the optimization is possible,
> > then the second exchange of ASP-UP is optional:
> >
> >                  IPSP-A                           IPSP-B
> >                    |                                |
> >                    |<-------------ASP Up------------|
> >                    |-----------ASP Up Ack---------->|
> >                    |                                |
> >                    |-------------ASP Up------------>| (Optional)
> >                    |<----------ASP Up Ack-----------| (Optional)
> >                    |                                |
> >
> > With the previously described assumption, why in the last M3UA RFC 
> > 3332Bis-04, in paragraph "4.3.4.1.2 IPSP Considerations (ASP Up)", 
> > we have:
> >
> > "  Alternatively, when using IPSP DE model, an interchange of ASP Up
> >    messages from each end MUST be performed. Four messages are needed
> >    for completion.  "
> >
> > It seems that this sentence explain that the second exchange of 
> > ASP-UP is always mandatory?
> >
> > Thanks
> >
> > Laurent
>
> --
> Brian F. G. Bidulock
> [email-masked]
> http://www.openss7.org/
>
> _______________________________________________
> Sigtran mailing list
> [email-masked] https://www1.ietf.org/mailman/listinfo/sigtran

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 20 Jul 2005 14:50:47 -0600

Laurent,

Cavalier, Laurent wrote:                                                         (Wed, 20 Jul 2005 18:41:31)
> If 4 messages are used for ASPUP procedure, the model is simpler
> because it's like if IPSPs are made of 1 SGP plus 1 ASP. In addition,
> it cause the bidirectional activation between two IPSP (ASPTM) to be
> unconnected and independent. 
> 
> On the other hand, Double Exchange contains the word "double" but it
> could mean that only exchanged ASPTM message need be doubled. ASPTM
> are specific to AS but ASPSM concern the whole IPSP and 2 messages
> could be enough to express M3UA layer availability. An IPSP which send
> an ASP UP has certainly an available M3UA layer, and certainly the
> IPSP which respond with an ASPUP ACK has also its local M3UA layer
> available. 

Not necessarily, in the ASPF/SGPF model, sending ASP Up only indicates
that the ASPF is available.  Sending ASP Ack indicates that the SGPF
is available.

I agree with Tolga, enforcement of 4 messages is the only way to ensure
interoperability (needs to be a MUST) and sending 2 less messages would
not be any savings, anyway.

> 
> IMO the actual draft of RFC is more oriented to a choice with only 2
> messages exchanged; it's why I thought, that at this stage, it was
> easier to target the 2 messages model (because there is few references
> to the 4 messages model in rfc). In addition, using the 2 messages
> model is more permissive and allows interoperating with all
> implementations (designed for 4 or 2 messages).

Except for the example, references to 2 messages are for the SE model.

Changing to 2 messages would require pulling the document back from IESG
or starting a bis-bis draft at this point so that we can fully comment
on the resulting text.  Also, all other ASP Up related procedures (M3UA
Version, Management Blocking, etc.) would need to be reviewed and text
added to describe how they could possibly work for DE.  With 4 messages,
these exchanges are clearly the same as the equivalent ASP/SGP procedures.
With only 2 they cannot be.  This is why I say that when you try to skip
messages in DE it breaks.

--brian

> 1- With DE model, we always had a coupled ASP/SGP state machine in
> mind. Allowing a single ASPUP/ASPUP-ACK exchange would break that
> assumption.
> 
> 2- I don't think skipping a single ASPUP/ASPUP-ACK exchange is a very
> significant optimization and won't matter much.
> 
> Overall, IMHO for the sake of keeping things clean and simple,
> enforcing douple exchnage ASPUP/ASPUP-ACK seems a better alternative.
> 
>    Tolga
> 

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Valerie Gastaud" <[email-masked]>
Date: Thu, 21 Jul 2005 14:50:12 +0200

I agree with Brian and Tolga.
Let's keep the IPSP DE model as agreed before, i.e. requiring a double exchange of ASPSM and ASPTM messages.
This ensures interoperability and keeps it simple.

Valerie

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On
Behalf Of Brian F. G. Bidulock
Sent: mercredi 20 juillet 2005 22:51
To: Cavalier, Laurent
Cc: [email-masked]
Subject: Re: [Sigtran] M3UA : 2 or 4 messages for ASP-UP in IPSP DE ?

Laurent,

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/