Subject: [Sigtran] M2PA- Priority of transmitting and receiving messages

From: Devayya <[email-masked]>
Date: Wed, 13 Jul 2005 17:52:57 +0530

Hi All,

  As per section 4.1.8 of draft-ietf-sigtran-m2pa-13.txt,

       "higher priority should be given to the Link Status stream 
messages than the
        User Data stream messages while transmitting and receiving the 
messages."

 1)  M2PA sends messages using ordered delivery of SCTP option, Does 
this serves the above purpose?
 2)  Does the SCTP send the messages by deciding the priority?
 3)  Is it necessary to decide the priority in M2PA itself ?

Please clarify.....

Thanks,
devayya

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: Tom George <[email-masked]>
Date: Wed, 13 Jul 2005 15:04:19 -0500

SCTP ordered delivery is only within streams. SCTP has no way of knowing 
which stream is of higher priority. So M2PA should do it.

tomG.

Devayya wrote:
> 1)  M2PA sends messages using ordered delivery of SCTP option, Does this 
> serves the above purpose?

-- 
Tom George in Plano, TX

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 14 Jul 2005 02:58:31 -0600

Devayya,

When M2PA goes to send messages (to SCTP), if it has both data messages
and link status messages, it sends the link status messages first.

--brian

Devayya wrote:                              (Wed, 13 Jul 2005 17:52:57)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/