Subject: [Sigtran] M2PA retrasmission buffer

From: Dario <[email-masked]>
Date: Tue, 17 Apr 2007 15:01:24 -0700 (PDT)

Hi,

I am having some problems to understand why M2PA should maintain
retransmission buffers - since SCTP is performing retransmissions. Can you
help me to clarify this?
thanks.
Kind regards, Dario
-- 
View this message in context: http://www.nabble.com/M2PA-retrasmission-buffer-tf3597831.html#a10048667
Sent from the IETF - Sigtran mailing list archive at Nabble.com.

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 17 Apr 2007 16:45:59 -0600

Dario,

For retransmission (by MTP3) on another link.

--brian

Dario wrote:                                                         (Tue, 17 Apr 2007 15:01:24)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: Dario <[email-masked]>
Date: Tue, 17 Apr 2007 23:43:43 -0700 (PDT)

Hi Brian,
so it means that both SCTP and M2PA should buffer sent but not acknowledged
messages?
On the other hand, Data Retrieval and Retransmission is not supported in
M3UA.
Best regards, Dario

Brian F. G. Bidulock wrote:
>> View this message in context:
>> http://www.nabble.com/M2PA-retrasmission-buffer-tf3597831.html#a10048667

-- 
View this message in context: http://www.nabble.com/M2PA-retrasmission-buffer-tf3597831.html#a10053138
Sent from the IETF - Sigtran mailing list archive at Nabble.com.

---

From: "Barry Nagelberg" <[email-masked]>
Date: Wed, 18 Apr 2007 12:35:51 +0400

Dario,

1. The M2PA and SCTP retransmission buffers are used for totally different
purposes:

a. The SCTP retransmission buffer is used to retransmit a packet if it gets
lost at the TCP/IP layer.
b. The M2PA retransmission buffer is used to retransmit a msg during link
switchover at the MTP2/MTP3 layers.

2. M3UA has no need for a retransmission buffer because it sits between the
MTP3 and MTP3-user layers.

Barry Nagelberg

-----Original Message-----
From: Dario [mailto:[email-masked]]
Sent: Wednesday, April 18, 2007 10:44 AM
To: [email-masked]
Subject: Re: [Sigtran] M2PA retrasmission buffer

Hi Brian,

--
View this message in context:
http://www.nabble.com/M2PA-retrasmission-buffer-tf3597831.html#a10053138
Sent from the IETF - Sigtran mailing list archive at Nabble.com.

---

From: Dario <[email-masked]>
Date: Wed, 18 Apr 2007 02:00:03 -0700 (PDT)

Hi Barry,

does it mean that
MTP3/M2PA/SCTP stack  does Data Retrieval + Changeover for unsent and not
acknowledged messages,
while M3UA/SCTP stack does not perform Data Retrieval + Changeover of not
acknowledged messages?

Thanks!
Kind regards, Dario

Barry Nagelberg wrote:
>> Dario wrote:                                                        
>> (Tue,
>> 17 Apr 2007 15:01:24)

-- 
View this message in context: http://www.nabble.com/M2PA-retrasmission-buffer-tf3597831.html#a10054816
Sent from the IETF - Sigtran mailing list archive at Nabble.com.

---

From: "Barry Nagelberg" <[email-masked]>
Date: Wed, 18 Apr 2007 14:10:02 +0400

Dario,

Sorry, my previous email below was incorrect.

Both the M2PA and SCTP retransmission buffers are used to retransmit a msg
during link switchover at the SCTP-user layer. The SCTP retransmission
buffer has an additional purpose to retransmit a packet if it gets lost at
the TCP/IP layer.

Barry Nagelberg

-----Original Message-----
From: Barry Nagelberg [mailto:[email-masked]]
Sent: Wednesday, April 18, 2007 12:36 PM
To: [email-masked]
Subject: RE: [Sigtran] M2PA retrasmission buffer

Dario,

Barry Nagelberg

-----Original Message-----
From: Dario [mailto:[email-masked]]
Sent: Wednesday, April 18, 2007 10:44 AM
To: [email-masked]
Subject: Re: [Sigtran] M2PA retrasmission buffer

Hi Brian,

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 18 Apr 2007 11:17:07 -0600

Dario,

Dario wrote:                                                                         (Tue, 17 Apr 2007 23:43:43)
> so it means that both SCTP and M2PA should buffer sent but not acknowledged

M2PA buffers messagse sent and even acknowledged by the peer SCTP, but not yet
acknowledged by the peer M2PA.

> On the other hand, Data Retrieval and Retransmission is not supported in

Well, really it is.  See draft-bidulock-sigtran-corid-05.txt for an example of
how to use existing mechanisms to effect the same procedures as changeover,
changeback and forced and controlled rerouting.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Asveren, Tolga" <[email-masked]>
Date: Wed, 18 Apr 2007 13:31:10 -0400

Dario,

The reason for M2PA retransmission buffers is to support MTP3
changeover/changeback procedures. M2PA did not have buffers till
draft-04 (or something around this number). Then buffers have been
introduced.

I agree that this creates some double standard:
a) For M3UA, we assume that SCTP multihoming will provide network/NIF
redundancy
b) For M2PA, we assume even if the M2PA link (or better said the
corresponding SCTP association) has failed, the remote host still could
be there and reachable (otherwise what is the point of
changeover/changeback).

I am in the camp which says M3UA does it right. SCTP multihoming +
proper IP network engineering is the way to address this issue. If you
loose your SCTP association to a remote host, this means it is down
(within a reasonable probabilistic range of course). There are others
which think different. And we argue about this regularly (I would say it
is usually every 3 months or so :-) )

The nice (or funny, depending on how you evaluate it :-) )thing about
the M3UA and M2PA standards is that they do opposite things. This
provides flexibility (or confusion) when people want to pick the
protocol to use.

    Thanks,
    Tolga
> From: Brian F. G. Bidulock [mailto:[email-masked]]
> Sent: Wednesday, April 18, 2007 1:17 PM
> To: Dario
> Cc: [email-masked]
> (Tue, 17 Apr 2007 23:43:43)
> >
> > Hi Brian,
> M2PA buffers messagse sent and even acknowledged by the peer SCTP, but
not
> yet