Subject: [Sigtran] OS in SCTP

From: "Ambika Tripathy" <[email-masked]>
Date: Thu, 26 Apr 2007 14:47:58 +0530

Hi,

I have one doubt in IBS and OBS

ASP                 SG
------------------------
OBS = 5             OBS = 2
IBS = 5             IBS = 2

Then what should be the OBS and IBS value in INIT and INIT-ACK chunks?

If I am not wrong below is the result.

INIT
OBS = 5
IBS  = 5

INIT-ACK
OBS = 2
IBS = 2

and the ASP end after receiving the INIT-ACK what should be updated OBS and
IBS.

-- 
Br,
Ambika Prasad Tripathy
Nethawk Networks
Cell: +91-94375 47730
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: Ashwani Kathuria <[email-masked]>
Date: Thu, 26 Apr 2007 15:49:56 +0530

Hello Ambika

The In-bound stream and Out-bound streams parameters of INIT and INIT ACK 
chunk tells the peer that how many maximum IBS and OBS the sender can 
support. Based on this received stream information from peer and it's own 
configuration the stack decides the final stream configuration.
The number of final Inbound stream = MIN(Own IBS, Peer's OBS)
The number of final Outbound stream = MIN(Own OBS, Peer's IBS)

In your example

ASP                                     SG
 
--------------INIT[IBS=5, OBS=5]----------------->

<---------INIT ACK [IBS=2, OBS=2]-------------

After receiving INI-ACK at ASP:
Inbound stream = MIN(5,2) = 2
Outbound stream = MIN(5,2) = 2

Ashwani Kathuria

A R I C E N T
 
The Presidency Tower ?A, 351/2, Sector 14
M.G. Road Gurgaon 122001, Haryana, India.
 
Main     +91 124.417.6333
Extn.    5218
Fax      +91 124..4176225
Mobile   +91 991.142.4546
www.aricent.com

"Ambika Tripathy" <[email-masked]> 
04/26/2007 02:47 PM

To
sigtran <[email-masked]>, bidulock <[email-masked]>
cc

Subject
[Sigtran] OS in SCTP

Hi,

ASP                 SG
------------------------
OBS = 5             OBS = 2
IBS = 5             IBS = 2 

 
INIT
OBS = 5
IBS  = 5
 
INIT-ACK
OBS = 2
IBS = 2
 
and the ASP end after receiving the INIT-ACK what should be updated OBS 
and IBS.

-- 
Br,
Ambika Prasad Tripathy
Nethawk Networks
Cell: +91-94375 47730 _______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

***********************  Aricent- Confidential   ***********************

***********************  Aricent- Confidential   ***********************
"DISCLAIMER: This message is proprietary to Aricent  and is intended solely for the use of 
the individual to whom it is addressed. It may contain privileged or confidential information and should not be 
circulated or used for any purpose other than for what it is intended. If you have received this message in error, 
please notify the originator immediately. If you are not the intended recipient, you are notified that you are strictly
prohibited from using, copying, altering, or disclosing the contents of this message. Aricent accepts no responsibility for 
loss or damage arising from the use of the information transmitted by this email including damage from virus."
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Ashish Soregaonkar" <[email-masked]>
Date: Thu, 26 Apr 2007 15:52:20 +0530

5.1.1 Handle Stream Parameters

   In the INIT and INIT ACK chunks, the sender of the chunk shall
   indicate the number of outbound streams (OS) it wishes to have in the
   association, as well as the maximum inbound streams (MIS) it will
   accept from the other endpoint.

   After receiving the stream configuration information from the other
   side, each endpoint shall perform the following check:  If the peer's
   MIS is less than the endpoint's OS, meaning that the peer is
   incapable of supporting all the outbound streams the endpoint wants
   to configure, the endpoint MUST either use MIS outbound streams, or
   abort the association and report to its upper layer the resources
   shortage at its peer.

   After the association is initialized, the valid outbound stream
   identifier range for either endpoint shall be 0 to min(local OS,
   remote MIS)-1.