Subject: [Sigtran] M2UA: remote ASP state

From: "flash view" <[email-masked]>
Date: Thu, 12 Apr 2007 17:09:58 +0300

Hello,

RFC 3331, 4.3.4.1 ASP Up Procedures says
=========
If an ASP Up message is received and *internally* *the remote ASP is in
the ASP-ACTIVE state*, an ASP Up Ack message is returned, as well as
an Error message ("Unexpected Message), and* the remote ASP state is
changed to ASP-INACTIVE in all relevant Application Servers*.
=========

As I understand, remote *ASP state is defined on a per-AS*.
But in RFC 3331 there is "*internally* the remote ASP is in the ASP-ACTIVE
state".

Could somebody clarify what does mean "*internally *the remote ASP is in X
state"?

Thanks,
Andriy Melnyk.
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 12 Apr 2007 08:33:46 -0600

flash,

"Internally" here just means that the SG has the ASP marked ASP-ACTIVE
for some AS.  That is, the ASP is not in the ASP-DOWN state.  See the
state diagram in the RFC.

--brian

flash view wrote:                               (Thu, 12 Apr 2007 17:09:58)
> 
>    Hello,
>    RFC 3331, [1]4.3.4.1 ASP Up Procedures says
>    =========
>    If an ASP Up message is received and internally the remote ASP is in
>    the ASP-ACTIVE state , an ASP Up Ack message is returned, as well as
>    an Error message ("Unexpected Message), and the remote ASP state is
>    changed to ASP-INACTIVE in all relevant Application Servers.
>    =========
>    As I understand, remote ASP state is defined on a per-AS.
>    But in RFC 3331 there   is  "internally  the  remote  ASP  is  in  the
>    ASP-ACTIVE state".
>    Could  somebody  clarify what does mean " internally the remote ASP is
>    in X state"?
>    Thanks,
>    Andriy Melnyk.
> 
> References
> 
>    1. http://4.3.4.1/

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/