Subject: [Sigtran] Re: Some scenarios related to M3UA ASPAC-ASPIA Procedures section

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 14 Aug 2007 04:56:03 -0600

sigtran_maillist,

Your mailer wrapped your diagrams horribly.

--brian

[email-masked] wrote:                       (Tue, 14 Aug 2007 15:26:58)
> 
>    Hi All,
>    What would be the possible handling in following scenarios.
>    1)
>    ASP  Side
>                               SG  Side
>    AS1 with Traffic Mode Loadshare
>                             AS1 with Traffic Mode Loadshare
>    AS2 with Traffic Mode Loadshare
>                             AS2 with Traffic Mode Overide
>                               -------------------------- ASPAC  ( without
>    RC, without Traffic Mode )------------->
>    2)
>    ASP  Side
>                               SG  Side
>    AS1 with Traffic Mode Loadshare
>                             AS1 with Traffic Mode Loadshare
>    AS2 with Traffic Mode Loadshare
>                             AS2 with Traffic Mode Overide
>                               -------------------------- ASPAC  ( without
>    RC, with Traffic Mode as Loadshare) ------------->
>    3)
>    ASP  Side
>                               SG  Side
>    AS1 with Traffic Mode Loadshare (RC1)
>                                   AS1 with Traffic Mode Loadshare (RC1)
>    AS2 with Traffic Mode Loadshare (RC2)
>                                   AS2 with Traffic Mode Overide (RC2)
>                               -------------------------- ASPAC  (with RC1
>    and RC2, without Traffic Mode ) ------------->
>    4)
>    ASP  Side
>                               SG  Side
>    AS1 with Traffic Mode Loadshare (RC1)
>                                   AS1 with Traffic Mode Loadshare (RC1)
>    AS2 with Traffic Mode Loadshare (RC2)
>                                   AS2 with Traffic Mode Overide (RC2)
>                               -------------------------- ASPAC  (with RC1
>    and RC2, with Traffic Mode Loadshare ) ------------->
>    Regards
>    Ankur Arora
>    ***********************  Aricent-Private   ***********************
> 
> "DISCLAIMER: This message is proprietary to Aricent  and is intended solely for
>  the use of 
> the individual to whom it is addressed. It may contain privileged or confidenti
> al information and should not be 
> circulated or used for any purpose other than for what it is intended. If you h
> ave received this message in error, 
> please notify the originator immediately. If you are not the intended recipient
> , you are notified that you are strictly
> prohibited from using, copying, altering, or disclosing the contents of this me
> ssage. Aricent accepts no responsibility for 
> loss or damage arising from the use of the information transmitted by this emai
> l including damage from virus."

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 14 Aug 2007 05:52:02 -0600

sigtran_maillist,

All scenarios are  a misconfiguration.  Errors are expected to result.
Only in the case where traffic mode is specified in the ASPAC will the
SG detect your misconfiguration and will report "Unsupported Traffic Mode".

Whether Both RC are specified in the ASPAC or not makes no difference.
Each AS is independent of the other.

--brian

[email-masked] wrote:                       (Tue, 14 Aug 2007 16:40:25)

> 1) 
> 
> ASP  Side						SG  Side
> 
> AS1 with Traffic Mode Loadshare			AS1 with Traffic Mode Loadshare
> AS2 with Traffic Mode Loadshare			AS2 with Traffic Mode Overide
> 
>      -------------------------- ASPAC  ( without RC, without Traffic Mode )------------->
> 
> 
> 2) 
> 
> ASP  Side						SG  Side
> 
> AS1 with Traffic Mode Loadshare			AS1 with Traffic Mode Loadshare
> AS2 with Traffic Mode Loadshare			AS2 with Traffic Mode Overide
> 
> 
>      -------------------------- ASPAC  ( without RC, with Traffic Mode as Loadshare) ------------->
> 
> 3) 
> 
> ASP  Side						SG  Side
> 
> AS1 with Traffic Mode Loadshare (RC1)			AS1 with Traffic Mode Loadshare (RC1)
> AS2 with Traffic Mode Loadshare (RC2)			AS2 with Traffic Mode Overide (RC2)
> 
>   -------------------------- ASPAC  (with RC1 and RC2, without Traffic Mode ) ------------->
> 
> 4) 
> 
> ASP  Side						SG  Side
> 
> AS1 with Traffic Mode Loadshare (RC1)			AS1 with Traffic Mode Loadshare (RC1)
> AS2 with Traffic Mode Loadshare (RC2)			AS2 with Traffic Mode Overide (RC2)
> 
>   -------------------------- ASPAC  (with RC1 and RC2, with Traffic Mode Loadshare ) ------------->

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: ankur arora <[email-masked]>
Date: Wed, 15 Aug 2007 23:32:02 -0700 (PDT)

Hi Brian,
   
  As mentioned by you, only in the cases where traffic mode is specified in the ASPAC message, SG detect your misconfiguration. So we have to make this parameter as mendatory. It will solve the problem in scenarios 1 and 3.
   
  Also we have to make RC as conditional parameter in ASPTM Messages, like SSNM messages. 
   
  Please comment on this.
   
  Regards
  Ankur Arora

"Brian F. G. Bidulock" <[email-masked]> wrote:
  sigtran_maillist,

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

       
---------------------------------
Fussy? Opinionated? Impossible to please? Perfect.  Join Yahoo!'s user panel and lay it on us.

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 16 Aug 2007 12:15:14 -0600

ankur,

Traffic mode cannot be a mandatory paramter, because the specs support
more traffic modes (by a priori arrangement) than are specified by the
paramter.  That is, you would need an "Other" traffic mode codepoint.

Putting an RC value in the message or not has nothing to do with it.

Configure your SGs and ASPs correctly and you will not have any problem.

No change required.

--brian

ankur arora wrote:                                (Wed, 15 Aug 2007 23:32:02)
> 
>    Hi Brian,
> 
> 
> 
>    As mentioned by you, only in the cases where traffic mode is specified
>    in  the  ASPAC message, SG detect your misconfiguration. So we have to
>    make  this  parameter  as  mendatory.  It  will  solve  the problem in
>    scenarios 1 and 3.
> 
> 
> 

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/