Subject: [Sigtran] Strange LK-SCTP behavior in a multi-homing M3UA setup

From: mosbah abdelkader <[email-masked]>
Date: Mon, 21 Feb 2011 17:29:33 +0100

Hi,

I have the following setup:
          - 1 M3UA ASP: with 2 IP addresses.
          - 2 M3UA SGP: each one with 4 IP addresses.

After launch, the ASP setups 4 associations: 2 with each SGP. Each
association is multihomed with 2 IP addresses in both sides.

The ASP sends traffic to the 2 SGP in a loadsharing configuration.

Normally, after associating the ASP should align with the 2 SGP with the
following procedure:

               SGP                             ASP1

                |                               |
                |<-------------ASP Up-----------|
                |-----------ASP Up Ack--------->|
                |                               |
                |<------- ASP Active(RCn)-------|  RC: Routing Context

                |-----ASP Active Ack (RCn)----->|      (optional)
                |                               |
                |-----NTFY(AS-ACTIVE)(RCn)----->|
                |                               |

The problem is that LK-SCTP is sending SHUTDOWN without ANY REASON sometimes
from ASP, sometimes from SGP1 and sometimes from SGP2. This behaviour
disturbs the whole execution process.

I have attached a wireshark capture for the ASP side.

I am using OpenSUSE 11.1 and lksctp-tools-1.0.9-1.28.

Can you please provide some help or hint to help me resolve this issue.

Thank you in advance.

--
Best Regards

Abdelkader Mosbah.

---

From: Michael Tüxen <[email-masked]>
Date: Mon, 21 Feb 2011 19:37:05 +0100

On Feb 21, 2011, at 5:29 PM, mosbah abdelkader wrote:

> After launch, the ASP setups 4 associations: 2 with each SGP. Each association is multihomed with 2 IP addresses in both sides.
> 
> 
> Normally, after associating the ASP should align with the 2 SGP with the following procedure:
> 
>                SGP                             ASP1
> 
> 
>                 |                               |
> 
> The problem is that LK-SCTP is sending SHUTDOWN without ANY REASON sometimes from ASP, sometimes from SGP1 and sometimes from SGP2. This behaviour disturbs the whole execution process.
> 
> 
I guess you are using one to many style sockets (since LKSCTP would not bundle
DATA chunks with a COOKIE chunk on one to one style sockets) and the timer
to automatically close an association is configured to 4 seconds.

It also looks like the M3UA layer does not follow the state diagram in Figure 3
of RFC 4666. Frame 63 contains a COOKIE bundled with a ASPAC, which should not
be the case...

Best regards
Michael
> 
> 
> Thank you in advance.
> 
> --
> Best Regards
> 
> Abdelkader Mosbah.
> 
> <test-m3ua_21-02-2011_15-30.pcap>_______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sigtran

---

From: mosbah abdelkader <[email-masked]>
Date: Tue, 22 Feb 2011 11:27:09 +0100

Hi Michael,

Thank you for help.

I am sorry if the message arrives multiple times because the mailing list
does not accept the message size due to the attachements. Now I have
compressed them.

>> to automatically close an association is configured to 4 seconds.

<< Yes, you are right. I have corrected the SCTP_AUTOCLOSE timer and now I
don't get the SHUTDOWN message.

>> of RFC 4666. Frame 63 contains a COOKIE bundled with a ASPAC, which
should not

<< I am using M3UA RFC 3332. I have attached the new capture whitout
SHUTDOWN and another test done in the loopback containing a working ASP-SGP
association and communication. Please can you give comments on both cases.

Thank you.

--
Best Regards

Abdelkader Mosbah