Subject: [Sigtran] Invalid Stream Identifier err for DATA message

From: santosh nayak <[email-masked]>
Date: Sat, 26 Feb 2011 06:56:29 +0530

Hi,

As per RFC 4666  "Invalid Stream Identifier" error is sent if a message is
received on an unexpected SCTP stream (e.g., a Management message was
received on a stream other than "0"). So the err message only received in
response for Management message

But we are receiving the above error message. When we send a DATA message
(i.e. SSA) with not the proper stream id.

Is the behavior correct. if yes please explain.

Attaching the pcap for reference

Thanks,
Santosh

---

From: Michael Tüxen <[email-masked]>
Date: Sat, 26 Feb 2011 10:24:49 +0100

On Feb 26, 2011, at 2:26 AM, santosh nayak wrote:

> Hi,
> 
> As per RFC 4666  "Invalid Stream Identifier" error is sent if a message is received on an unexpected SCTP stream (e.g., a Management message was received on a stream other than "0"). So the err message only received in response for Management message  
> 
> But we are receiving the above error message. When we send a DATA message (i.e. SSA) with not the proper stream id.
> 
RFC 4666, Section 1.4.7 states: The DATA message MUST NOT be sent on stream 0.

The DATA message (frame 10) was send on stream 0, therefore the ERR.

Best regards
Michael
> <err1.pcap>_______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sigtran