Subject: [Sigtran] Concern on the M3UA SSNM request, DUPU.

From: prabath weerasinghe <[email-masked]>
Date: Thu, 21 Jul 2016 14:07:30 +0530

Hi All,

I was referring the rfc4666 <https://tools.ietf.org/html/rfc4666> for M3UA
and have few concerns regarding the DUPU SSNM message.
The specification says that a DUPU indicates the unavailability of a
certain user part.

If I may quote;
" The DUPU message is used by an SGP to inform concerned ASPs that a

 remote peer MTP3-User Part (e.g., ISUP or SCCP) at an SS7 node is
 unavailable"

I have two questions.
1.  How these concerned ASPs are identified.
     Is it upon receiving a MTP-Transfer for a particular user part (say
SCCP) or can it      be sent periodically for a given ASP ?

2. I couldn't find any SSNM message that indicates a User Part's
 Availability. Am I wrong here to expect such a message and if so how come
a concerned ASP know if a     certain User Part is available at a given
point code.

It would be an immense help if anyone could clarify the aforementioned
concerns.

Thanks and Regards,

-- 
Prabath Weerasinghe

_________________________________________________________________________________
Confidentiality and Disclaimer

This email and any attachments are intended only for the person or entity
to whom it is addressed. Its contents may be privileged, confidential or
otherwise protected from disclosure. If you are not the intended recipient,
please do not read, disclose, distribute or copy this email or use the
information therein or act or omit to act in reliance thereof. Please also
inform the sender of erroneous receipt and delete the material from your
system.

---

From: David Laight <[email-masked]>
Date: Thu, 21 Jul 2016 08:41:33 +0000

Read the MTP3 spec and look at when UPU is sent.

From: Sigtran [mailto:[email-masked]] On Behalf Of prabath weerasinghe
Sent: 21 July 2016 09:38
To: [email-masked]
Subject: [Sigtran] Concern on the M3UA SSNM request, DUPU.

Hi All,

I was referring the rfc4666<https://tools.ietf.org/html/rfc4666> for M3UA and have few concerns regarding the DUPU SSNM message.
The specification says that a DUPU indicates the unavailability of a certain user part.

If I may quote;

 unavailable"

I have two questions.
1.  How these concerned ASPs are identified.
     Is it upon receiving a MTP-Transfer for a particular user part (say SCCP) or can it      be sent periodically for a given ASP ?

2. I couldn't find any SSNM message that indicates a User Part's  Availability. Am I wrong here to expect such a message and if so how come a concerned ASP know if a     certain User Part is available at a given point code.

It would be an immense help if anyone could clarify the aforementioned concerns.

Thanks and Regards,

--
Prabath Weerasinghe

This email and any attachments are intended only for the person or entity to whom it is addressed. Its contents may be privileged, confidential or otherwise protected from disclosure. If you are not the intended recipient, please do not read, disclose, distribute or copy this email or use the information therein or act or omit to act in reliance thereof. Please also inform the sender of erroneous receipt and delete the material from your system.

---

From: prabath weerasinghe <[email-masked]>
Date: Thu, 21 Jul 2016 18:00:58 +0530

Hi David,

Thanks for the quick reply. I checked the MTP3 spec and got all cleared up.

Thanks and Regards,

On Thu, Jul 21, 2016 at 2:11 PM, David Laight <[email-masked]>
wrote:

> *From:* Sigtran [mailto:[email-masked]] *On Behalf Of *prabath
> weerasinghe
> *Sent:* 21 July 2016 09:38
> *To:* [email-masked]
> *Subject:* [Sigtran] Concern on the M3UA SSNM request, DUPU.
>
>
>
> Hi All,
>
>
>
> I was referring the rfc4666 <https://tools.ietf.org/html/rfc4666> for
> M3UA and have few concerns regarding the DUPU SSNM message.
>
> Registered Address Lakeside, Bramley Road, Mount Farm, Milton Keynes, MK1
> 1PT, UK
> Registration No: 1397386 (Wales)
>
> P *Please consider the environment and don't print this e-mail unless you
> really need to*
>

-- 
Prabath Weerasinghe
Department of Electrical Engineering
University of Moratuwa
Blog-*psawtech*talks.blogspot.com <http://psawtechtalks.blogspot.com/>