Subject: [Sigtran] M3UA error "No Configured AS for ASP”

From: Suchetha P <[email-masked]>
Date: Fri, 30 Sep 2016 17:34:33 +0000 (UTC)

Hi,

IuPS interface(Packet switching/data interface) between the nodes  Signalling Gateway and SGSN is down after the Trillium SIGTRAN Stack Upgrade.
This is because of the M3UA error "No o Configured AS for ASP”.

1)    The asExhangeMode is set to “singleExchange” at Signalling Gateway while at SGSN side asExhangeMode is set to “doubleExchange”.
2)    Both the nodes are sending ASPUP & ASPUPACK. SG(Signalling Gateway) then sends ASPAC and SGSN responds with ASPAC Ack. SGSN sends ASPAC but SG doesn’t respond with ASPAC Ack and instead it sends error message “ No Configured AS for ASP”.

We need to investigate why SG is not responding with ASPAC Ack message and instead sending Error message towards  SGSN. 
Can this be a configuration issue ?Or a bug ?The same configuration was working before the Trillium upgrade.
Is it proper to have one node in single exchange mode while the other as double exchange ?
Is the error being thrown for no routing context in the ASP AC message ?

Best Regards,
Suchetha

---

From: David Laight <[email-masked]>
Date: Mon, 3 Oct 2016 09:15:14 +0000

From: Suchetha P
> Sent: 30 September 2016 18:35
> Hi,
> 
> IuPS interface(Packet switching/data interface) between the nodes  Signalling Gateway and SGSN is down
> after the Trillium SIGTRAN Stack Upgrade.
> This is because of the M3UA error "No o Configured AS for ASP.
> 
> 1)    The asExhangeMode is set to singleExchange at Signalling Gateway while at SGSN side
> asExhangeMode is set to doubleExchange.
> 2)    Both the nodes are sending ASPUP & ASPUPACK. SG(Signalling Gateway) then sends ASPAC and SGSN
> responds with ASPAC Ack. SGSN sends ASPAC but SG doesnt respond with ASPAC Ack and instead it sends
> error message  No Configured AS for ASP.
> 

You need to ask your software supplier.

	David