Subject: [Simple] Re: draft-rosenberg-simple-components-00.txt (threading)

From: "Petri K. Koskelainen" <[email-masked]>
Date: Thu, 28 Feb 2002 12:24:18 -0500 (EST)

Hi,

The draft proposes that In-Reply-To header should
be used for message threading in paging mode,
and the draft also states that in message session 
mode threading is already provided.

I don't fully agree here. It works for two-party messaging
but not well in group messaging scenarios.

Problem 1: Message session supports only one discussion thread 
per session.
This does not well reflect real-life scenarios. 
For example, there may be a group chat session with 20 people. 
It is very likely that they have different
conversation topics going-on at the same time although they 
are in the same group. It is also likely that smaller sub-threads
emerge and it would be nice if these can be somehow shown
in the user interface similarly to current network news UIs.
For example, if there are several questions asked in the group
and users respond with "yes!" or "no" in the message body it is 
quite difficult to know to which question they were intended.
User Interface could show them nicely if there were header support 
for it.

Problem 2: Group messaging server creates new Call-IDs for each call-leg.
In-Reply-To has also problems in group IM paging mode
since the server creates new Call-IDs for each 
participant. One call-id is valid only between one user and the server.
The server has to remember all previous Call-IDs so
it can change Call-IDs in In-Reply-To accordingly when somebody 
is responding to group message. 
It must have the history and know that a message it sent to Bob 
a day ago with Call-ID=X is in fact the same message than 
message sent to Alice with Call-ID=Y. This becames quite complicated.

Problem 3: Lack of global and common ID for each group message.
Now it is difficult to reference a specific group instant message
afterwards so that everybody understands it. Only the server
has the knowledge (if it keeps the history). The recipients
don't know that group IM sent to me with Call-ID=X is the same than
group IM sent to Alice with Call-ID=Y. In some cases it would
be useful to have the information available in the message.

These problems can be solved if new header (Message-ID)
is defined and References header is used (like in NNTP messages).

BR,
--
Petri
_______________________________________________
simple mailing list
[email-masked]
http://mailman.dynamicsoft.com/mailman/listinfo/simple

---

From: "Dean Willis" <[email-masked]>
Date: Thu, 28 Feb 2002 12:12:35 -0600

> is defined and References header is used (like in NNTP messages).

I'm reminded of the tumbler approach that Ted Nelson developed in the Xanadu
framework for providing infinitely subscopable addressing.

Essentially, a subscope of any address could could be declared by suffixing
a "." and a subscope identifier to the existing address. Although tumblers
used numeric addressing ostensibly derived from byte counts within static
documents, a similar mechanism was later used for describing heirarchy in
usenet groups, such as "rec.humor.funny.standards.messaging".

--
Dean