Subject: RE: [Simple] Comments on xcap-list-usage

From: [email-masked]
Date: Tue, 27 Jan 2004 14:37:48 +0200

I would like to follow up on this issue since I faced the same problem while updating the XCAP usage for CPCP.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> ext Jonathan Rosenberg
> Sent: 13.November.2003 11:14
> To: Khartabil Hisham (NMP-MSW/Helsinki)
> Cc: [email-masked]
> Subject: Re: [Simple] Comments on xcap-list-usage
> 
> [email-masked] wrote:
> > 
> > - If the "uri" attribute is absent in a document, but the
> > "subscribeable" flag is set to true. the XCAP server must allocate
> > a URI. But what if the URI is present but conflicts with an already
> > existing URI? How does the server react? Does it reject the request
> > or does it just rewrite the URI?
> 
> Great question.
> 
> I think it should return an error. The reason is that the document 
> would be in violation of one of the non-schema data constraints.
> 
> The real question is, how does the client know that it should retry 
> with a different URI?
> 
> I see no obvious answer. There are a few possibilities:
> 
>    * disallow clients from setting the URI
>    * invent a new error resposne code
>    * add a body to the 409 that describes the condition
> 

I think the easiest and fastest thing to do is disallow the client from setting the URI. Any other opinions?

Regards,
Hisham

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 28 Jan 2004 17:29:21 -0500

Certainly that tactic is simpler. However, it makes it hard to have 
"vanity URIs" for specific lists, for example - 
[email-masked]. Do we think that this function is needed?

-Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.                600 Lanidex Plaza
Chief Technology Officer                    Parsippany, NJ 07054-2711
dynamicsoft
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

---

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 28 Jan 2004 17:29:21 -0500

-Jonathan R.