Subject: RE: [Simple] Subscribing to different PResentities

From: "Kamal Gupta" <[email-masked]>
Date: Thu, 22 Jan 2004 18:44:57 -0800

Thanks Orit.
But my question was not Subscribing to a list where List consists of number of Presentities and one can Subscribe to all the Presentities in one shot by subscribing to list.
I had the scenario where User needs to Subscribe to a List (consisting of number or Users/Presentities) and also need to Subscribe to another List/Group consisting of different set of users/Presentities.

In that case I agree to earlier answers and it is required to have separate dialogs for each subscription.

Thanks.
KG

-----Original Message-----
From: Orit Levin [mailto:[email-masked]]
Sent: Thursday, January 22, 2004 6:08 PM
To: Kamal Gupta; [email-masked]
Subject: RE: [Simple] Subscribing to different PResentities

I am surprised by the previous answers.

Although the whole scenario hasn't been standardized yet, but the
required pieces to achieve this functionality are well identified.

You can SUBSCRIBE to a URI which points to a list of presentities of
your interest and get their statuses within a SINGLE DIALOG as per
http://www.ietf.org/internet-drafts/draft-ietf-simple-event-list-04.txt.

You can either preconfigure the list on your presence server or use
something along the lines of
http://www.ietf.org/internet-drafts/draft-levin-simple-adhoc-list-01.txt
to build it dynamically using the SUBSCRIBE dialog.

Orit.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Kamal Gupta
Sent: Tuesday, January 20, 2004 5:45 PM
To: [email-masked]
Subject: [Simple] Subscribing to different PResentities

Hi,

I was wondering if it is allowed to Subscribe to 2 different
Presentities in the same dialog for the same event. I understand this
leads to putting a different "To" url in the request. And as the dialog
includes : the from-tag, to-tag, call-id, Is it OK to put a different
"To" url in 2 Subscribe messages within a dialog ??

Thanks.
KG

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: "Ashir Ahmed" <[email-masked]>
Date: Fri, 23 Jan 2004 18:15:55 +0900

A list can contain multiple lists. Can't it?
Ashir
----- Original Message ----- 
From: "Kamal Gupta" <[email-masked]>
To: "Orit Levin" <[email-masked]>; <[email-masked]>
Sent: Friday, January 23, 2004 11:44 AM
Subject: RE: [Simple] Subscribing to different PResentities

Thanks Orit.
But my question was not Subscribing to a list where List consists of number
of Presentities and one can Subscribe to all the Presentities in one shot by
subscribing to list.
I had the scenario where User needs to Subscribe to a List (consisting of
number or Users/Presentities) and also need to Subscribe to another
List/Group consisting of different set of users/Presentities.

In that case I agree to earlier answers and it is required to have separate
dialogs for each subscription.

Thanks.
KG

-----Original Message-----
From: Orit Levin [mailto:[email-masked]]
Sent: Thursday, January 22, 2004 6:08 PM
To: Kamal Gupta; [email-masked]
Subject: RE: [Simple] Subscribing to different PResentities

Orit.

-----Original Message-----

Hi,

Thanks.
KG

---

From: "Ashir Ahmed" <[email-masked]>
Date: Fri, 23 Jan 2004 18:15:55 +0900

----- Original Message ----- 
From: "Kamal Gupta" <[email-masked]>
To: "Orit Levin" <[email-masked]>; <[email-masked]>
Sent: Friday, January 23, 2004 11:44 AM
Subject: RE: [Simple] Subscribing to different PResentities

Thanks Orit.

Thanks.
KG

-----Original Message-----
From: Orit Levin [mailto:[email-masked]]
Sent: Thursday, January 22, 2004 6:08 PM
To: Kamal Gupta; [email-masked]
Subject: RE: [Simple] Subscribing to different PResentities

Orit.

-----Original Message-----

Hi,

Thanks.
KG