Subject: [Simple] Sender identification in MSRP

From: Heil Franca Marcelo <[email-masked]>
Date: Fri, 23 Jan 2004 16:20:27 +0100

Hello,

Considering a multiparty session-based messaging using a tightly-coupled conferencing model, where a central conference server maintains MSRP sessions (setup via SIP) with each participant and forwards the data received in one MSRP session from a participant to other participants:

Is there a way for a participant on the conference to find out who was the original sender of the data it receives in the MSRP session with the conference server? (e. g. as it is posssible via the CNAME/SSRC/CSRC fields in RTCP/RTP for media channels using RTP transport)
Is this a topic to be handled in the MSRP draft? Would a new header in the MSRP SEND command be necessary for that? 

Marcelo

---

From: [email-masked]
Date: Fri, 23 Jan 2004 17:37:44 +0200

Hi Marcelo,
 
The current thinking is that To/From headers in "message/cpim" are used for conveying this information. The conference focus would insist all participants use message/cpim as the top level MIME wrapper. Message/cpim format is mandatory to support in the current MSRP draft.
 
Cheers,
Aki

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of ext Heil Franca Marcelo
Sent: 23 January, 2004 17:20
To: [email-masked]'
Subject: [Simple] Sender identification in MSRP

Hello, 

Marcelo

---

From: [email-masked]
Date: Fri, 23 Jan 2004 17:37:44 +0200

Hi Marcelo,

Cheers,
Aki

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of ext Heil Franca Marcelo
Sent: 23 January, 2004 17:20
To: [email-masked]'
Subject: [Simple] Sender identification in MSRP

Hello, 

Marcelo