Subject: [Simple] Subscribing to different PResentities

From: "Kamal Gupta" <[email-masked]>
Date: Tue, 20 Jan 2004 17:45:28 -0800

Hi,

I was wondering if it is allowed to Subscribe to 2 different Presentities in the same dialog for the same event. I understand this leads to putting a different "To" url in the request. And as the dialog includes : the from-tag, to-tag, call-id, Is it OK to put a different "To" url in 2 Subscribe messages within a dialog ??

Thanks.
KG

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 21 Jan 2004 04:16:43 -0500

I dont think it makes sense to do this. There is no way to know 
whether or not the second presentity exists at the end of the first 
dialog.

-Jonathan R.

Kamal Gupta wrote:

> Hi,
> 
> I was wondering if it is allowed to Subscribe to 2 different
> Presentities in the same dialog for the same event. I understand
> this leads to putting a different "To" url in the request. And as
> the dialog includes : the from-tag, to-tag, call-id, Is it OK to
> put a different "To" url in 2 Subscribe messages within a dialog ??
> 
> 
> Thanks. KG
> 
> 
> 
> 
> _______________________________________________ Simple mailing list
>  [email-masked] https://www1.ietf.org/mailman/listinfo/simple
> 

-- 
Jonathan D. Rosenberg, Ph.D.                600 Lanidex Plaza
Chief Technology Officer                    Parsippany, NJ 07054-2711
dynamicsoft
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

---

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 21 Jan 2004 04:16:43 -0500

-Jonathan R.

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 21 Jan 2004 10:59:30 -0500

> I was wondering if it is allowed to Subscribe to 2 different Presentities in the same dialog for the same event. I understand this leads to putting a different "To" url in the request. And as the d…

No. Its not a matter of "allowed" - it is impossible by definition.

The subscription target is initially defined by the request URI. This 
becomes the dialog target. Effectively, the target of the dialog defines 
the presentity you are subscribed to. Any other subscription thru the 
same dialog will be associated with the same presentity.

	Paul

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 21 Jan 2004 10:59:30 -0500

Paul