Subject: [Simple] MSRP: Lack of version in the protocol

From: "Murty Dasari" <[email-masked]>
Date: Wed, 23 Jun 2004 12:56:48 -0700

Hi,

I've a question about MSRP protocol (based on
draft-ietf-simple-message-sessions-06.txt)  

Currently MSRP messages do not contain any version information. Wouldn't it
be helpful to have major and minor version numbers similar to HTTP?

Is there some other way to support multiple protocol revisions and future
MSRP methods? 

Appreciate any comments.

thanks, 

- Murty

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Ben Campbell <[email-masked]>
Date: Mon, 28 Jun 2004 16:02:28 -0500

This was discussed in the working group some time back. The consensus 
was that there was no use for a version indicator, since MSRP would 
never negotiate versions.

Since MSRP is _always_ negotiated with an external signaling protocol, 
any version negotiation belongs there. Any version updates to MSRP must 
describe how to indicate the new version in the sdp exchange.

Murty Dasari wrote:

> Hi,
> 
>  
> 
> I’ve a question about MSRP protocol (based on 
> Currently MSRP messages do not contain any version information. Wouldn’t 
> it be helpful to have major and minor version numbers similar to HTTP?
> 
> Is there some other way to support multiple protocol revisions and 
> future MSRP methods?
> 
>  
> 
> Appreciate any comments.
> 
>  
> 
> thanks,
> 
> - Murty
> 
> 
> ------------------------------------------------------------------------
>