Subject: [Simple] MSRP: updated offer on transaction timeout or non-2xx/415 respons e

From: "Christer Holmberg (JO/LMF)" <[email-masked]>
Date: Mon, 7 Jun 2004 19:03:40 +0200

Hi,

I have a question about the case if a non-2xx/415 response is received, or a timeout occurs, for a MSRP message.

Chapter 6.5.3 says:

"8.  If any other response code is received, or if the transaction
times out, the endpoint SHOULD assume the session has failed,
either tear down the session, or attempt to re-establish the
session by sending an updated SDP offer proposing a new
connection.  If a new connection is established, the endpoint MAY
choose to resend the content on the new connection."

My question is: what information in the updated the MSRP media description (m= line) should be changed, to indicate that the connection should be re-established, ie that the the m= line is not unchanged, and only send eg as part of a refresh? The SDP session level o= parameter is not enough, because the SDP may contain multiple media descriptions (m= line), and one needs to find out which has been updated? Since the c= line IP address, and m= line port, has no meaning in MSRP I guess something in the path attribute would have to be updated, or? If one doesn't want to change the IP address/port (may not be possible eg due to firewalls), does a new resource value indicate that the TCP connection should be re-established?

Also, does the node really need to send an updated SDP in the first place, if the IP parameters don't change? Why not just trying to re-establish the TCP connection?

Regards,

Christer Holmberg
Ericsson Finland

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Paul Kyzivat <[email-masked]>
Date: Mon, 07 Jun 2004 14:00:22 -0400

> My question is: what information in the updated the MSRP media description (m= line) should be changed, to indicate that the connection should be re-established, ie that the the m= line is not unch…

Assuming you don't have reason to change something else, it would be 
sufficient to simply change the 'resource' portion of the msrp url.

> Also, does the node really need to send an updated SDP in the first place, if the IP parameters don't change? Why not just trying to re-establish the TCP connection?

1) because permitting this would require that a tcp listener always be 
active just in case this should happen. This could be a burden for some 
nodes.

2) because an attempt to establish a connection when one is already 
active is interpretted as an attack.

	Paul