Subject: RE: [Simple] MSRP: delivery reports and transaction responses

From: [email-masked]
Date: Fri, 18 Jun 2004 10:50:29 +0300

And here is the table to report success:

report-success  | Send Response? | Send report on success?
----------------+----------------+------------------------
true            | MUST NOT       | MUST
false           | MUST NOT       | MUST NOT

/Hisham

> -----Original Message-----
> From: ext Adam Roach [mailto:[email-masked]]
> Sent: 18.June.2004 01:13
> To: Mike Hammer
> Cc: Ben Campbell; [email-masked]; Khartabil Hisham
> (Nokia-TP-MSW/Helsinki); [email-masked]; [email-masked]
> Subject: Re: [Simple] MSRP: delivery reports and transaction responses
> 
> 
> Mike Hammer wrote:
> > Would it not be possible to use just two binary flags and 
> just make the 
> > behavior of the receiving node a "Should not send DSN, MUST 
> not send 
> > response" with the sending node having a "MAY discard 
> received DSN" or 
> > is this a limited BW case for the sender?  I would think 
> that a relay 
> > for BW-limited sender could also discard before a BW-limited link.
> 
> The problem is that people envision doing things like sending
> administrative messages (e.g. "The IM system will be down from
> 5:00 to 7:00 pm for maintenance") to thousands or even hundreds
> of thousands of users, and they don't want negative responses
> for the ones that fail.
> 
> > report-success=true     send response?, send Pos-DSN report
> > report-success=false    send response?, no Pos-DSN report
> > report-failures=true    send response,  send Neg-DSN report
> > report-failures=false   no response,    no report
> > report-failures=partial no response,    may send report
> > applies to all devices.
> > 
> > I'm still missing some details (? above).
> 
> The "Report Success" flag never, ever, ever has an impact
> on whether transaction responses are sent. In fact, relays
> never need to even consider the value of the "Report Success"
> flag. It is processed by endpoints only.
> 
> report-failures | Send Response? | Send report on failure?
> ----------------+----------------+------------------------
> true            | MUST           | MUST
> false           | MUST NOT       | MUST NOT
> partial         | MUST NOT       | MAY
> 
> /a
> 

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Ben Campbell <[email-masked]>
Date: Fri, 18 Jun 2004 09:25:06 -0500

This is somewhat incorrect. The "Send Response" column is entirely 
depending on the report-failure flag and is orthagonal to the 
report-success flag.