Subject: RE: [Simple] Re: MSRP: Max message size indication

From: "Christer Holmberg (JO/LMF)" <[email-masked]>
Date: Mon, 28 Jun 2004 08:28:17 +0200

Hi,

So, do we have some kind of conclusion on this?

Some people have asked for use-cases, and scenarios where this can be useful, and I think a number of those have now been presented.

Regards,

Christer Holmberg
Ericsson Finland

> -----Original Message-----
> From: Paul Kyzivat [mailto:[email-masked]]
> Sent: 15. kesäkuuta 2004 2:04
> To: [email-masked]
> Cc: Adam Roach; [email-masked]'; 
> [email-masked]; Christer
> Holmberg (JO/LMF); [email-masked]; Ben Campbell
> Subject: Re: [Simple] Re: MSRP: Max message size indication
> 
> 
> 
> 
> Alex Audu wrote:
> > I think there is great value in  end-point being able to signal the 
> > maximum size of data it is
> > willing /able to accept at a time. This information could 
> be used by the 
> > sender to, for example
> > send a less memory intensive version of say an image, 
> instead of a full 
> > blown memory hungry
> > version.  This will allow the information to be communicated with a 
> > decreased risk of truncation
> > at first try. That makes for a more efficient communication (than 
> > without this feature).
> 
> This is the most compelling argument for this feature that I 
> have seen.
> 
> 	Paul
> 

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Ben Campbell <[email-masked]>
Date: Mon, 28 Jun 2004 14:56:58 -0500

I believe the conclusion is to allow signaling max size you wish to 
receive, but not to signal the max you intend to send.

---

From: Cullen Jennings <[email-masked]>
Date: Tue, 29 Jun 2004 21:14:50 -0700

Trying to be more specific. The SDP parameter is a max size the person
receiving the SDP should send. It is the max size of the message not the
chunk. The receiver SHOULD NOT send messages larger than this. It is the
size of the content not the size of the message.

Cullen,

And if it is set to 1 it means you are in character by character T.140 mode
:-) The previos line is a joke I'm not suggesting that

On 6/28/04 12:56 PM, "Ben Campbell" <[email-masked]> wrote:

>> Some people have asked for use-cases, and scenarios where this can be useful,
>> and I think a number of those have now been presented.
>> 
>> Regards,
>> 
>> Christer Holmberg
>> Ericsson Finland
>> 
>> 
>>

---

From: Ben Campbell <[email-masked]>
Date: Wed, 30 Jun 2004 08:37:48 -0500

> size of the content not the size of the message.

Agreed.

> :-) The previos line is a joke I'm not suggesting that

I don't want to solve that problem just yet. _But_, do you really 
consider a real time text usage of MSRP by sending one character per 
chunk to be acceptable? Talk about a bandwidth explosion. I think we 
will need something more complicated for that to work.

---

From: Alex Audu <[email-masked]>
Date: Wed, 30 Jun 2004 11:55:44 -0500

Hi Cullen,

Yeap,..this will do.

Thanks,
Alex.