Subject: RE: [Simple] XCAP Issue 5 Interim Summary: selecting multiple ele ments

From: Biot Olivier <[email-masked]>
Date: Fri, 11 Jun 2004 15:06:00 +0200

Wouldn't it be simpler to use HTTP POST for multiple insertions as
idempotence cannot be guaranteed? Additionally, atomic operations could be
implemented by using HTTP POST and some "envelope" media type instead of the
purely Etag-based approach as described today.

The HTTP OPTIONS mechanism can be used to query the capabilities of an XCAP
server for a given URI/URN. The Allow header in the response will tell the
XCAP client which HTTP operations are allowed, and the Accept header can
enumerate the accepted media types (e.g., the "envelope").

Doing so will allow the definition of an interoperable XCAP extension, and
this way we can avoid the multiple insertions idempotence dilemma in the
baseline XCAP spec.

Any comments?

Regards,

Olivier

|-----Original Message-----
|From: Joel M. Halpern
|
|
|I think leaving out multiple inserts, and telling people how 
|to cope with 
|the absence is MUCH better than the complications we are going 
|to get by 
|trying to include multiple inserts.
|
|Thank you,
|Joel
|
|At 02:33 AM 6/10/2004 -0400, Jonathan Rosenberg wrote:
|>[problem statement with non idempotent multiple insert]
|>
|>[Proposals for enforcing idempotentence]
|>....
|>[Suggestion that we leave out multiple inserts.]
|>I suggested that I could include some guidelines on schema 
|design to avoid 
|>the need for mutliple insertions. There seemed to be support for this 
|>position. The guidelines I will include are basically this:
|>
|>[Guidelines for avoiding the need for multiple inserts.]
|>
|>Any objections?
|>
|>Thanks,
|>Jonathan R.

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 29 Jun 2004 17:01:14 -0400

> purely Etag-based approach as described today.

There are other, much bigger problems here. Most notably, POST is a sure 
sign that you are really defining a new protocol (and indeed, in this 
case, a database protocol), and that HTTP is probably not the right match.

-Jonathan R.
-- 
Jonathan D. Rosenberg, Ph.D.                600 Lanidex Plaza
Chief Technology Officer                    Parsippany, NJ 07054-2711
dynamicsoft
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com