Subject: RE: [Simple] Re: MSRP: Max message size indication

From: "Christer Holmberg (JO/LMF)" <[email-masked]>
Date: Thu, 10 Jun 2004 07:17:01 +0200

Hi,

>This draft is called "Advanced Instant Messaging Requirements 
>for the Session Initiation Protocol". Note the word 
>"Advanced". It means additional, not base requirements.
> 
>We are not at a stage yet where solutions for advanced 
>requirements can be discussed. The draft is not even a WG 
>item. There are, however, some exceptions: In some cases, it 
>was found necessary to incorporate some of the advanced 
>features to make the protocol usable (eg: DSNs).  Max message 
>size is not one of those.

During this discussion I think someone indicated that there it could be usable to indicate the max-size in a MSRP 4xx response. Now, to my understanding that is also only an "advanced" requirement - at least I couldn't find it in RFC2779 (please correct me if I'm wrong).

Also, a generic question about the IETF procedures. Is it stated somewhere, or has the WG done a check, that we support all appropriate requirements (and which those are) in RFC2779, or is it something someone has to find out for him/herself? Just for my information...

Regards,

Christer Holmberg
Ericsson Finland

> 
> Regards,
> Hisham
> 
> > -----Original Message-----
> > From: ext Gonzalo Camarillo [mailto:[email-masked]]
> > Sent: 08.June.2004 22:14
> > To: Ben Campbell
> > Cc: Niemi Aki (Nokia-M/Espoo); Khartabil Hisham 
> > (Nokia-TP-MSW/Helsinki);
> > Chris Boulton; [email-masked]; Christer Holmberg (JO/LMF); Jonathan
> > Rosemberg
> > Subject: Re: [Simple] Re: MSRP: Max message size indication
> > 
> > 
> > Ben,
> > 
> > let me try to understand the discussion here. We have a 
> requirements 
> > document (written by Jonathan) that says the following:
> > 
> > http://www.ietf.org/internet-drafts/draft-rosenberg-simple-mes
> > saging-requirements-01.txt
> > 
> >     "REQ-CONTENT-1: A UA MUST be able to indicate the 
> maximum message
> >        size it is willing to receive."
> > 
> > According to the requirements, the protocol MUST support 
> it... do you 
> > want to go through the requirements phase again at this point?
> > 
> > Gonzalo
> > 
> > 
> > 
> > Ben Campbell wrote:
> > 
> > > So far, I have had 4 people (counting myself) respond 
> > no/no, 2 respond 
> > > yes/yes, and one equivocation that I interpret as yes/no.
> > > 
> > > This is a pretty small fraction of the work group. If only 
> > seven people 
> > > care enough to even comment, I'm not sure we have a mandate 
> > for this.
> > > 
> > > So, if there is anyone out there who cares but has not said 
> > so, please 
> > > do so soon.
> > > 
> > > Aki Niemi wrote:
> > > 
> > >> I'll have to vote for no/no. I don't think it solves the 
> > real problem,
> > >> which is not having the sender/recipient ability to 
> abort transfer
> > >> mid-message.
> > >>
> > >> Cheers,
> > >> Aki
> > >>
> > >> On Mon, 2004-06-07 at 18:30, ext Ben Campbell wrote:
> > >>
> > >>> I'd like to try and get some closure on this:
> > >>>
> > >>> Please answer yes or no to the following:
> > >>>
> > >>> 1) Should we add the optional signaling of the maximum 
> > content size 
> > >>> you are willing to _receive_ into the SDP exchange.
> > >>>
> > >>> 2) Should we add the optional signaling of the maximum 
> > content size 
> > >>> you are planning to _send_ into the SDP exchange.
> > >>>
> > >>> 3) If either 1 or 2 is yes, do we send one value for the 
> > session, or 
> > >>> one value per each type for which we have indicated support.
> > >>>
> > >>> My personal opinions:
> > >>>
> > >>> No and No. In all honesty, I think this could be a useful 
> > feature, 
> > >>> but I don't think MSRP has to have it to function. I am 
> > voting no, 
> > >>> not because I disagree with the feature, but because I 
> > don't want to 
> > >>> add additional work to completing MSRP unless it is absolutely 
> > >>> necessary. But if consensus says we need it, I do not 
> > object on any 
> > >>> technical basis.
> > >>
> > 
> > 
> 
> _______________________________________________
> Simple mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/simple
> 

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Gonzalo Camarillo <[email-masked]>
Date: Thu, 10 Jun 2004 11:06:33 +0300

Folks,

we are using more time in discussing this small issue than what it would 
take to resolve it. People are asking for an *optional* SDP attribute 
that allows a UA to say "Hey, FYI: I cannot receive messages over 40 KB".

Writing the specification of such an SDP attribute would take, 
literally, less than 10 minutes, because you do not need any type of 
negotiation or any type of special offer/answer behavior. It is only an 
attribute that is sent to the receiver of the SDP "For His Information". 
If the receiver does not understand it, nothing bad happens.

Some people have claimed that the addition of such attribute could delay 
the standardization of the protocol (I have not heard any technical 
reason against this parameter)... given that it is only an *optional* 
informational attribute that can be defined in a couple of paragraphs, 
its inclusion would not delay the protocol at all.

So, if nobody has a better reason for excluding this attribute that 
claiming that it would delay things, I propose that we add its 
definition to MSRP and move on to issues that do have a real impact in 
the MSRP protocol machinery.

Gonzalo