Subject: Re: [Simple] Re: MSRP: Max message size indication

From: Gonzalo Camarillo <[email-masked]>
Date: Wed, 09 Jun 2004 10:39:18 +0300

Hisham,

so, what is the purpose of the *advanced* requirements? Are they going
to be used to develop a new protocol different from MSRP, are they going
to be used to develop extensions to MSRP, or are they going to be just
ignored?

In any case, if these are not the requirements that apply to MSRP, where
are the requirements that do apply?

Gonzalo

[email-masked] wrote:

> This draft is called "Advanced Instant Messaging Requirements for the Session Initiation Protocol". Note the word "Advanced". It means additional, not base requirements.
> 
> We are not at a stage yet where solutions for advanced requirements can be discussed. The draft is not even a WG item. There are, however, some exceptions: In some cases, it was found necessary to incorporate some of the advanced features to make the protocol usable (eg: DSNs).  Max message size is not one of those.
> 
> Regards,
> Hisham
> 
> 
>>-----Original Message-----
>>From: ext Gonzalo Camarillo [mailto:[email-masked]]
>>Sent: 08.June.2004 22:14
>>To: Ben Campbell
>>Cc: Niemi Aki (Nokia-M/Espoo); Khartabil Hisham 
>>(Nokia-TP-MSW/Helsinki);
>>Chris Boulton; [email-masked]; Christer Holmberg (JO/LMF); Jonathan
>>Rosemberg
>>Subject: Re: [Simple] Re: MSRP: Max message size indication
>>
>>
>>Ben,
>>
>>let me try to understand the discussion here. We have a requirements 
>>document (written by Jonathan) that says the following:
>>
>>http://www.ietf.org/internet-drafts/draft-rosenberg-simple-mes
>>saging-requirements-01.txt
>>
>>    "REQ-CONTENT-1: A UA MUST be able to indicate the maximum message
>>       size it is willing to receive."
>>
>>According to the requirements, the protocol MUST support it... do you 
>>want to go through the requirements phase again at this point?
>>
>>Gonzalo
>>
>>
>>
>>Ben Campbell wrote:
>>
>>
>>>So far, I have had 4 people (counting myself) respond 
>>
>>no/no, 2 respond 
>>
>>>yes/yes, and one equivocation that I interpret as yes/no.
>>>
>>>This is a pretty small fraction of the work group. If only 
>>
>>seven people 
>>
>>>care enough to even comment, I'm not sure we have a mandate 
>>
>>for this.
>>
>>>So, if there is anyone out there who cares but has not said 
>>
>>so, please 
>>
>>>do so soon.
>>>
>>>Aki Niemi wrote:
>>>
>>>
>>>>I'll have to vote for no/no. I don't think it solves the 
>>
>>real problem,
>>
>>>>which is not having the sender/recipient ability to abort transfer
>>>>mid-message.
>>>>
>>>>Cheers,
>>>>Aki
>>>>
>>>>On Mon, 2004-06-07 at 18:30, ext Ben Campbell wrote:
>>>>
>>>>
>>>>>I'd like to try and get some closure on this:
>>>>>
>>>>>Please answer yes or no to the following:
>>>>>
>>>>>1) Should we add the optional signaling of the maximum 
>>
>>content size 
>>
>>>>>you are willing to _receive_ into the SDP exchange.
>>>>>
>>>>>2) Should we add the optional signaling of the maximum 
>>
>>content size 
>>
>>>>>you are planning to _send_ into the SDP exchange.
>>>>>
>>>>>3) If either 1 or 2 is yes, do we send one value for the 
>>
>>session, or 
>>
>>>>>one value per each type for which we have indicated support.
>>>>>
>>>>>My personal opinions:
>>>>>
>>>>>No and No. In all honesty, I think this could be a useful 
>>
>>feature, 
>>
>>>>>but I don't think MSRP has to have it to function. I am 
>>
>>voting no, 
>>
>>>>>not because I disagree with the feature, but because I 
>>
>>don't want to 
>>
>>>>>add additional work to completing MSRP unless it is absolutely 
>>>>>necessary. But if consensus says we need it, I do not 
>>
>>object on any 
>>
>>>>>technical basis.
>>>>
> 

-- 
Gonzalo Camarillo         Phone :  +358  9 299 33 71
Oy L M Ericsson Ab        Mobile:  +358 40 702 35 35
Telecom R&D               Fax   :  +358  9 299 30 52
FIN-02420 Jorvas          Email :  [email-masked]
Finland                   http://www.hut.fi/~gonzalo

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: [email-masked]
Date: Wed, 9 Jun 2004 09:47:31 +0300

Regards,
Hisham