Subject: RE: [Simple] MSRP Boundary header

From: "Vijay Kishen Hampapur Parthasarathy" <[email-masked]>
Date: Wed, 30 Jun 2004 11:33:27 -0700

Can you comment on the initial question on why not allow both methods
for message framing.  

Vijay

-----Original Message-----
From: Ben Campbell [mailto:[email-masked]] 
Sent: Wednesday, June 30, 2004 6:20 AM
To: Paul Kyzivat
Cc: Ted Hardie; [email-masked]; Vijay Kishen Hampapur
Parthasarathy; [email-masked]
Subject: Re: [Simple] MSRP Boundary header

Paul Kyzivat wrote:

> 
> 
> Ted Hardie wrote:
> 
>> At 7:48 PM -0700 6/29/04, Sean Olson wrote:
>>
>>> Why not allow both methods?
>>> It seems clear that there are probably two common use cases:
>>>
>>> 1) Simple, brief messages as in today's IM conversations
>>> 2) Larger, more complex, richer messages as forseen in 3G and other 
>>> environments
>>
>>
>>
>> Sorry to ask such a potentially silly question, but aren't the 
>> messages in case one to be handled by SIP/SIMPLE, rather than MSRP?
> 
> 
> No. Maybe if you have a one-shot message it should be. But if you are 
> having a conversation composed of simple brief messages then I believe

> the expectation is that you would be using MSRP.
> 

Or at one composed of a series of short, interactive messages. (Which is
probably what Paul meant to say.

> At least that is my expectation. One subject that has yet to be dealt 
> with is the relationship (and possibly migration) between page mode 
> and session mode. The fact that you ask the question you did is an 
> indication that this isn't a solved problem.
> 

This is true. We have had discussions indicating that we need to say
something about when to use each, and how to transition between them.

I personally think that sort of thing belong in the SIMPLE architecture
draft effort, which we have not been putting much effort into of late.

>     Paul

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Ben Campbell <[email-masked]>
Date: Wed, 30 Jun 2004 13:35:07 -0500

Because having two ways to do the same thing adds complexity to both the 
implementation and the specification.