Subject: [Simple] Xcap authorization rules - Multiple URIs in Identity

From: Schmidt Christian <[email-masked]>
Date: Mon, 7 Jun 2004 15:51:52 +0200

Hi Jonathan,

a short question, concerning the actual Version of your draft:
Presence Authorization Rules: draft-ietf-simple-presence-rules-00

Is it possible to use more then one uri in the Identity Element (3.1.1)?

Example:
<cr:conditions>
   <cr:identity>
       <cr:uri>[email-masked]</cr:uri>
       <cr:uri>[email-masked]</cr:uri>
   </cr:identity>
</cr:conditions>

This could be very helpful, to increase efficiency (subscription or change of rules). 
There would be no need for an external reference and the related problems.

Is it possible to extend section 3.1.1 of your draft, to make clear,
that multiple uri's are allowed?

Best Regards,

+++++++++++++++++++++++++++++++++++++
+ Christian Schmidt, Siemens AG     +
+ Phone            +49 89 636-75192 +
+ Fax              +49 89 636-75165 +
+ Mobile           +49 178 7700363  +
+ [email-masked]     +
+ [email-masked]      +
+++++++++++++++++++++++++++++++++++++ 

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 08 Jun 2004 11:42:42 -0400

Right now, the common policy schema only allows one URI per identity. 
However, I see no specific reason for this constraint, and believe it 
should allow multiple URIs. The condition matches as long as *any* of 
the URi that are listed match. Without this there is needless 
duplication of rules.

Since this is a common policy issue, I'm cc-ing geopriv. Hannes - are 
you ok with this change?

Also, note that the common policy doc needs to say that, when the 
<conditions> element has multiple conditions (such as <identity>), the 
rule matches only if ALL conditions match (i.e., its an AND at that level).

Thanks,
Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.                600 Lanidex Plaza
Chief Technology Officer                    Parsippany, NJ 07054-2711
dynamicsoft
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

---

From: "Hannes Tschofenig" <[email-masked]>
Date: Tue, 8 Jun 2004 18:23:38 +0200

hi jonathan, 
> However, I see no specific reason for this constraint, and 
> believe it should allow multiple URIs. The condition matches 
> as long as *any* of the URi that are listed match. Without 
> this there is needless duplication of rules.

i agree with you. 

> 
> Since this is a common policy issue, I'm cc-ing geopriv. 
> Hannes - are you ok with this change?

fine with me. 
> 
> Also, note that the common policy doc needs to say that, when 
> the <conditions> element has multiple conditions (such as 
> <identity>), the rule matches only if ALL conditions match 
> (i.e., its an AND at that level).
> 
that's correct. 

ciao
hannes