Subject: [Simple] How to get SIP phone presence info

From: Jing Qian <[email-masked]>
Date: Thu, 24 Jun 2004 09:35:01 -0500

Hi,

I am working on the Presence Server to get the presence
status of a specific user's SIP phone - on the call , not on
the call - a user based SIP phone status. Currently, there
is no SIP server or SIP PBX standard available. Would
anybody give me an idea how can the presence status of
a SIP phone be published to a Presence Server by a SIP
server/PBX or other service?

Any idea will be appreciated. Thanks in advance.

Jing

[email-masked] wrote:

> There are scenarios where a subscriber has created a filter in a subscription but wishes to replace that filter with another. There were 2 options presented at the interim with me proposing to adopt the 2nd as the solution.
>
> Option 1: remove and add a filter in the same subscription
>
> <?xml version="1.0" encoding="UTF-8"?>
>       <filter-set xmlns="urn:ietf:params:xml:ns:simple-filter"
>                          xmlns:pidf="urn:ietf:params:xml:ns:pidf">
>             <filter id="8439" remove="True"/>
>             <filter id="8440" uri="sip:[email-masked]">
>                <what>
>              <include>//pidf:tuple/pidf:status/pidf:basic</include>
>                 </what>
>             </filter>
> </filter-set>
>
> Option 2: Allow a filter to be replaced re-using the same filter id
>
> <?xml version="1.0" encoding="UTF-8"?>
>       <filter-set xmlns="urn:ietf:params:xml:ns:simple-filter"
>                          xmlns:pidf="urn:ietf:params:xml:ns:pidf">
> <filter id="8439" uri="sip:[email-masked]">
>                <what>
>              <include>//pidf:tuple/pidf:status/pidf:basic</include>
>                 </what>
>             </filter>
> </filter-set>
>
> No one objected to option 2. If there aren't any objections on the mailing list, I will add some clarification text on this issue.
>
> Regards,
> Hisham
>
> _______________________________________________
> Simple mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/simple

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Jonathan Rosenberg <[email-masked]>
Date: Mon, 28 Jun 2004 17:31:55 -0400

There are a few possibilities:

1. There is an RPID extension for indicating whether or not a user is on 
the phone or not. The IP PBX can send a PUBLISH message for the AOR of 
the user, including a presence document indicating this information.

2. I had submitted, quite some time back, a proposal for adding phone 
status information to pidf:

http://www.jdrosen.net/papers/draft-rp-simple-pidf-phone-00.txt

There was pushback to all of this in pidf, and these days, I am inclined 
to agree. I think that phone status is really a separate event package. 
I have in mind to submit an update to this document defining a separate 
event package, but there is nothing right now.

3. The dialog event package and reg event package, when put together, 
tell you a lot about the status of a SIP phone.

-Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.                600 Lanidex Plaza
Chief Technology Officer                    Parsippany, NJ 07054-2711
dynamicsoft
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

---

From: Henning Schulzrinne <[email-masked]>
Date: Mon, 28 Jun 2004 21:14:09 -0400

> the user, including a presence document indicating this information.

Slight amplification: this is one of the standard RPID activity tokens 
("on-the-phone"), not an RPID extension.