Subject: RE: [Simple] XCAP Issue 8: Etag Scope

From: [email-masked]
Date: Wed, 30 Jun 2004 11:25:06 +0300

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]]On Behalf
> Of ext Jonathan Rosenberg
> Sent: 29.June.2004 23:16
> To: Khartabil Hisham (Nokia-TP-MSW/Helsinki)
> Cc: [email-masked]; [email-masked]
> Subject: Re: [Simple] XCAP Issue 8: Etag Scope
> 
> 
> 
> 
> [email-masked] wrote:
> 
> > 
> >> -----Original Message----- From: [email-masked] 
> >> [mailto:[email-masked]]On Behalf Of ext Jonathan Rosenberg
> >>  Sent: 28.June.2004 14:30 To: Drage, Keith (Keith) Cc: Simple WG 
> >> Subject: Re: [Simple] XCAP Issue 8: Etag Scope
> >> 
> >> 
> >> 
> >> 
> >> Drage, Keith (Keith) wrote:
> >> 
> >> 
> >>> It certainly would be useful to see use cases if people
> >> 
> >> think we need
> >> 
> >>> more complicated solutions.
> >> 
> >> I'd also like to understand the use cases for this. Hisham, can you
> >>  provide some more?
> > 
> > 
> > There is a requirement where key participants, for example, get the
> > privilege to modify the Dial-out list, the security parameters in a
> > conference, or add a media stream to the conference.
> 
> Sure. The question, however, is whether, in these cases, its 
> necessary 
> to condition these operations on the current values?

I was answering the question on whether there are cases that require multiple users to modify the same piece of XML document.

I think you are right that those cases don't need conditioning.

/Hisham

> So, for 
> the cases 
> you mention:
> 
> 1. modify dial-out list: I would imagine in most cases 
> someone wants to 
> add or remove a user from these lists. Removal doesn't require 
> conditioning the DELETE. Adding doesnt require it either; if 
> you want to 
> make sure that the user isnt already there, you can do 
> If-Not-Match: *.
> 
> 2. modify security parameters: Here, I would imagine that the most 
> common case is merely to *set* them, without regards to 
> verifying that 
> someone else hasn't tried to set them since you last checked. 
> Would it 
> make a difference if they had? Why not just PUT the whole <SC>?
> 
> 3. adding a media stream: I'm not exactly sure how this works, so I 
> can't say if it can be done without a conditional operation.
> 
> 
> I'll also note that if you want to condition it, you still 
> can; its just 
> that if someone else has changed one of these other things, 
> you may need 
> to refetch the piece you care about.
> 
> 
> In my mind, the proposed text I sent out was *really* 
> complicated, and 
> was meant to make it clear that there is, IMHO, quite a lot 
> of cost to 
> this complex scope definitions.
> 
> -Jonathan R.
> -- 
> Jonathan D. Rosenberg, Ph.D.                600 Lanidex Plaza
> Chief Technology Officer                    Parsippany, NJ 07054-2711
> dynamicsoft
> [email-masked]                     FAX:   (973) 952-5050
> http://www.jdrosen.net                      PHONE: (973) 952-5000
> http://www.dynamicsoft.com
> 
> _______________________________________________
> Simple mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/simple
> 

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 30 Jun 2004 05:13:26 -0400

[email-masked] wrote:

>>> There is a requirement where key participants, for example, get
>>> the privilege to modify the Dial-out list, the security
>>> parameters in a conference, or add a media stream to the
>>> conference.
>> 
>> necessary to condition these operations on the current values?
> 
> 
> I was answering the question on whether there are cases that require
> multiple users to modify the same piece of XML document.
> 

Does that mean that you are ok with document level scopes?

-Jonathan R.