Subject: RE: [Simple] XCAP List Issue 1: External Reference Scope

From: [email-masked]
Date: Mon, 14 Jun 2004 10:52:13 +0300

2 is OK, but you still need some text defining the behaviour when the referenced list cannot be accessed (has been removed, etc).

Regards,
Hisham

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]]On Behalf
> Of ext Jonathan Rosenberg
> Sent: 11.June.2004 14:14
> To: Simple WG
> Subject: [Simple] XCAP List Issue 1: External Reference Scope
> 
> 
> This issue was raised some time ago, by Hisham I think, and 
> has yet to 
> be resolved. I had slides on this (and the other list issues) 
> prepared 
> for the interim, but we didnt get to it.
> 
> The resource list schema includes an <entry-ref> element 
> which contains 
> a reference to another entry. The purpose of this is to avoid 
> entering 
> duplicate data about a user when that user appears on multiple buddy 
> lists. The content of this element is a reference to an 
> <entry> element. 
> The question is, what is the scope of this reference? Is it:
> 
> 1. an HTTP URI representing an XCAP resource that is an 
> <entry> element 
> on this server or another server, in this domain or another domain 
> (i.e., 
> http://server.example.com/xcap-root/resource-lists/users/jdrosen/doc1/
> ~~/resource-lists/list/entry
> 
> 
> 2. a path from the XCAP root services URI, pointing to an <entry> 
> element on this server (i.e., "/resource-lists/users/jdrosen/doc1/
> ~~/resource-lists/list/entry"
> 
> 3. a path from the current document, pointing to an <entry> 
> element in 
> the same document (i.e., "/resource-lists/list/entry"
> 
> 
> I think doing (1) introduces all kinds of hairy issues around 
> authorization (you'd need to define policies about who can look at 
> specific entries in your lists) and referential integrity.  I think 3 
> gives insufficient flexibility. I'd like to be able to have a company 
> list of users, and define by buddy list as a series of references to 
> that central list. As such, I'd propose 2.
> 
> Comments?
> 
> Thanks,
> Jonathan R.
> -- 
> Jonathan D. Rosenberg, Ph.D.                600 Lanidex Plaza
> Chief Technology Officer                    Parsippany, NJ 07054-2711
> dynamicsoft
> [email-masked]                     FAX:   (973) 952-5050
> http://www.jdrosen.net                      PHONE: (973) 952-5000
> http://www.dynamicsoft.com
> 
> 
> _______________________________________________
> Simple mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/simple
> 

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Jonathan Rosenberg <[email-masked]>
Date: Thu, 17 Jun 2004 06:23:11 -0400

Right, good point. In all cases you have a problem with referential 
integrity. Options 1 and 3 have other problems too though.

I think that, if the reference list cannot be accessed, the behavior 
depends on the application using the document. To be clear, it is NOT my 
assumption that the xcap server would resolve this reference when 
returning the content of the document. In other words, if I fetch, using 
XCAP, a list, and that list includes an entry reference, the server 
would return the list with the reference. It would not replace that 
reference with the actual entry being referred to. This is not a 
database join operation.

If the application is a buddy list server (aka resource list server, 
RLS), it would just ignore that entry and not attempt a subscription to it.

-Jonathan R.