Subject: RE: [Simple] Comment to data model and RPID regarding <device> element

From: [email-masked]
Date: Sun, 13 Mar 2005 18:49:03 +0200

Hi,

I agree with Henning that mobile vs. fixed, screen size and keyboard are the most distinctive elements of a device. I suppose it might be possible to distinguish between the device types based on these.

LAPTOP
- MOBILE
- "LARGE" SCREEN
- "QWERTY" KEYBOARD

CELLPHONE/PDA
- MOBILE
- "SMALL" SCREEN
- "NUMERIC" KEYBOARD

BLACKPHONE
- FIXED
- NO SCREEN
- "NUMERIC" KEYPAD

DESKTOP
- FIXED
- "LARGE" SCREEN
- "QWERTY" KEYBOARD

I'm not sure if you can express the differences between all the other devices proposed by Aki (and Dave :-), but I suppose this would cover most of the devices where e.g. SIP UAs wil be found. Also, I'm not sure how useful the difference of knowing between for instance cell phone and PDA or desktop PC and Playstation 2 would be for the watcher.

Markus

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]]On Behalf
> Of ext Henning Schulzrinne
> Sent: 11 March, 2005 17:46
> To: Niemi Aki (Nokia-NRC/Helsinki)
> Cc: ext David R Oran; [email-masked]
> Subject: Re: [Simple] Comment to data model and RPID 
> regarding <device>
> element
> 
> 
> I agree that CPU MHz counts (and memory) are meaningless - 
> and getting 
> increasingly so. Even Intel and AMD have stopped advertising GHz. In 
> about a year or two, almost all CPUs will be between 1 and 4 
> GHz, where 
> architecture, such as multiple cores, matters far more than GHz.
> 
> In first approximation, screen sizes reflect the type of applications 
> that the system designer had in mind, and presumably put a 
> corresponding 
> CPU in the box.
> 
> Thus, suggestion: only encode user-interface capabilities.
> 
> Aki Niemi wrote:
> > Another point. I'm pretty sure at least most mobile phone 
> manufacturers 
> > will be reluctant to advertice the phone's CPU speed. And 
> which CPU is 
> > that anyway? Also, s PS2 might advertize some 200MHz and 
> 32MB of memory, 
> > and that still doesn't mean that the device is a PC from 
> the eighties.
> > 
> > Having said that though, if the consensus is against enumeration of 
> > labels for devices, then at least we should add the characteristic 
> > markup to RPID.
> > 
> > Cheers,
> > Aki
> > 
> > ext Henning Schulzrinne wrote:
> > 
> >> I'm with Dave. If CPU, screen and memory are not 
> sufficient, we should 
> >> define the other characteristics that matter. 'mobile' has been 
> >> proposed. From a user perspective what matters is
> >> - size of display (including 'none')
> >> - ease of text entry (12-digit vs. Treo-style vs. real keyboard)
> >>
> >> I don't know why I would need to make a distinction between a Treo 
> >> PDA+cellphone, one of those micro clamshell laptops or a 
> Sony PSP - or 
> >> how any such distinction remains meaningful over time.
> >>
> >> Aki Niemi wrote:
> >>
> >>>
> >>> ext David R Oran wrote:
> >>>
> >>>>> I could cite real-world systems, where such a feature 
> is already 
> >>>>> present. A buddy shows a little mobile-phone icon, if 
> they're using 
> >>>>> the IM client on a mobile. Also, the data model already 
> talks about 
> >>>>> the users' need of being able to address devices, like 
> "call me on 
> >>>>> my mobile phone". The heuristics for deriving that info out of 
> >>>>> things like CPU speed are not robust at all.
> >>>>>
> >>>> But this example is covered by other characteristics, 
> notably, the 
> >>>> "mobile" property. I agree that it's useful for the 
> presence system 
> >>>> to know the difference between a home phone, a mobile 
> phone, or an 
> >>>> office phone. What's not useful is to try to encode 
> those things in 
> >>>> a "device type".
> >>>>
> >>>> Riddle me this one - do I PUBLISH from my Treo as a 
> "mobile phone" 
> >>>> or a "PDA", or do we have a device type which is 
> "combined PDA and 
> >>>> mobile phone", and go over the edge to combinatorial explosion.
> >>>
> >>>
> >>>
> >>>
> >>> This would be entirely up to the UA; it could indicate a 
> device type 
> >>> of "PDA" and include the "mobile" prescaps in its service 
> >>> description. You would still use e.g. prescaps to indicate the 
> >>> capabilities, and the device type would merely mirror 
> whatever was on 
> >>> the sales package of the device.
> >>>
> >>> The point is that if you don't have a handle enumeration 
> on the type 
> >>> of the device, then a big part of the benefit in being able to 
> >>> represent devices goes away and <device> becomes merely 
> an abstract 
> >>> container for a set of services.
> >>>
> >>> My use case is one where I want to be able to render some 
> eye-candy 
> >>> to the user depending on what type of device(s) the presentity is 
> >>> using. The RPID/CIPID has the watcher-given icon that *could* be 
> >>> used, but then the watcher no longer has a say in what 
> gets displayed.
> >>>
> >>> What the data model currently has is IMHO merely 
> hand-waiving, as the 
> >>> characteristics (CPU, memory, screen) are not constant 
> over time, and 
> >>> if you gear your implementation towards today's devices, 
> then next 
> >>> year it would seem all of your buddies are using a PC 
> instead of a Treo.
> >>>
> >>> Cheers,
> >>> Aki
> >>
> >>
> >>
> 
> _______________________________________________
> Simple mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/simple
> 

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Henning Schulzrinne <[email-masked]>
Date: Sun, 13 Mar 2005 13:04:08 -0500

[email-masked] wrote:
> Hi,
> 
> I agree with Henning that mobile vs. fixed, screen size and keyboard
> are the most distinctive elements of a device. I suppose it might be
> possible to distinguish between the device types based on these.
> 
> LAPTOP - MOBILE - "LARGE" SCREEN - "QWERTY" KEYBOARD
> 
> CELLPHONE/PDA - MOBILE - "SMALL" SCREEN - "NUMERIC" KEYBOARD
> 
> BLACKPHONE - FIXED - NO SCREEN - "NUMERIC" KEYPAD
> 
> DESKTOP - FIXED - "LARGE" SCREEN - "QWERTY" KEYBOARD
> 
> I'm not sure if you can express the differences between all the other
> devices proposed by Aki (and Dave :-), but I suppose this would cover
> most of the devices where e.g. SIP UAs wil be found. Also, I'm not
> sure how useful the difference of knowing between for instance cell
> phone and PDA or desktop PC and Playstation 2 would be for the
> watcher.

That's pretty much what I had in mind. I'd much rather label the 
properties, so that we don't have to worry about various permutations in 
the future. Just as an example, some of the SIP phones are

    FIXED
    SMALL B/W SCREEN
    NUMERIC KEYPAD

and may, in the future, be

    FIXED
    MID-SIZED COLOR SCREEN
    SMALL QWERTY KEYPAD

Labeling both as 'black phone' is not very helpful, but they are not 
really PDAs or laptops, either.

I'd suggest the following rough division:

    Screen: small (< 400,000 pixels), mid-sized (< 700,000), large
      or just convey the pixel count in Kpixels, as well as whether the 
screen is monochrome (< 256 shades of gray); grayscale or color.

    Keyboard: numeric, hunt-and-peck (Treo/Blackberry-like), regular

    Mobility: mobile, portable (e.g., iMac or Xbox), fixed

Obviously, there are better names for these things. If the watcher 
recognizes standard combinations of these to show a laptop icon or a PDA 
icon, that's a UI decision.

Henning