Subject: AW: [Simple] When does RLS reduce Presence traffic?

From: "Beck01, Wolfgang" <[email-masked]>
Date: Wed, 13 Sep 2006 09:50:33 +0200

Jonathan wrote:
> Reginfo is not an alternative to presence. Its an input to presence.

You misunderstood me. The message flow would be like this:
1. watcher subscribes to the contact's reginfo
2. watcher gets notified that the contact went online
3. watcher sends now a presence subscribe to the contact >>directly<<
4. contact notifies watcher about it's presence state

Clients can download and maintain policy documents using an XCAP server.
But we dont need to connect this XCAP server to a presence server, which
seems to be a problem for implementers. We've heard anything
from 'Give us ten minutes to make the XCAP changes effective for current
subscriptions' to 'Oh, the changes on the XCAP server will only be effective for
new subscriptions'.

This solution produces a lot of messages. This is a problem for mobile clients.
For some reason, presence subscribes are not allowed to be forked, so the watcher
can't merge notify's from different devices of a contact.

As long as one doesn't use record-route, the proxy will only see the reginfo registers. 
Even with Record-Route, all those presence subscribes and notify's don't need special
treatment or state maintenance.

Wolfgang

--
T-Systems Enterprise Services GmbH
Technologiezentrum
Next Generation IP Services and Systems
+49 6151 9372863
Am Kavalleriesand 3
64295 Darmstadt

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 13 Sep 2006 11:39:31 -0400

Wolfgang,

What you suggest assumes that a user has no meaningful presence status 
when not registered. This may be valid for some, but I don't think it is 
a reasonable assumption in general.

	Paul