Subject: RE: [Simple] When does RLS reduce Presence traffic?

From: "Beck01, Wolfgang" <[email-masked]>
Date: Wed, 6 Sep 2006 16:52:55 +0200

David wrote:
> [..]
> I see optimizing Presence traffic as an interesting challenge, given the existence of a number of different and 
> complementary options, which might perform different depending on the use case on how they are combined together 
> (e.g.: performance of the RLS vs. setting up large subscription timers)...

To add one more alternative:
You could even remove the whole presence server and use the reginfo event package to see
when your contacts come online. The reginfo state changes only when the UA comes on- or
offline.

The presence subscribe/notify messages could be exchanged directly between the
UAs. Watcher authorization would be trivial and wouldn't have much latency. State merging
would run on the UA instead of an already overworked presence server. However, this comes
at the price of some bandwidth and might not be the best solution for mobile devices. But
for an ISP, it could be attractive.

Wolfgang

--
T-Systems
Next Generation IP Services and Systems
+49 6151 937 2863
Am Kavalleriesand 3
64295 Darmstadt
Germany 

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Avshalom Houri <[email-masked]>
Date: Thu, 7 Sep 2006 14:12:41 +0300

The following doc may be relevant

http://www.ietf.org/internet-drafts/draft-rang-simple-problem-statement-00.txt

Thanks
--Avshalom

"Beck01, Wolfgang" <[email-masked]> 
06/09/2006 17:52

To
[email-masked]
cc

Subject
RE: [Simple] When does RLS reduce Presence traffic?

David wrote:
> complementary options, which might perform different depending on the 
use case on how they are combined together 

To add one more alternative:
You could even remove the whole presence server and use the reginfo event 
package to see
when your contacts come online. The reginfo state changes only when the UA 
comes on- or
offline.

The presence subscribe/notify messages could be exchanged directly between 
the
UAs. Watcher authorization would be trivial and wouldn't have much 
latency. State merging
would run on the UA instead of an already overworked presence server. 
However, this comes
at the price of some bandwidth and might not be the best solution for 
mobile devices. But
for an ISP, it could be attractive.

Wolfgang

---

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 12 Sep 2006 17:24:05 -0400

Reginfo is not an alternative to presence. Its an input to presence. 
However, the authorization tools we've developed (common policy and 
presence policy documents) are meant to be applied to presence 
documents. They don't apply to other event packages.

-Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.                   600 Lanidex Plaza
Cisco Fellow                                   Parsippany, NJ 07054-2711
Cisco Systems
[email-masked]                              FAX:   (973) 952-5050
http://www.jdrosen.net                         PHONE: (973) 952-5000
http://www.cisco.com