Subject: [Simple] Partial Publication of elements with more than one instance possible

From: Pankaj Munjal <[email-masked]>
Date: Thu, 12 Mar 2009 11:45:04 +0530

Hello all,

According to the Presence RFCs, there can be a few elements like
<note>, <cipid>-<display_name> that can have multiple entries.
However, they don't have ids associated with them to identify the instances.

If my client is using partial publish to change values of one of such
instances, then which instance shall be updated on the Server?
(Assuming that my initial PUBLISH had more than one instance for such
field)

Is this scenario documented in some RFC/draft?

Kindly suggest!

Regards,
Pankaj

---

From: "Smyth, Colm (Colm)" <[email-masked]>
Date: Thu, 12 Mar 2009 11:58:44 -0000

Hi Panjaj,

Each instance of <note> and <display-name> is distinguished by a locale
(xml:lang).

All the best,
Colm Smyth
Lead/Architect - Avaya Communication Manager <NG> Presence Server |
Unified Communications
AVAYA | [email-masked] | +353 1 656 7843 (x37843)

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Pankaj Munjal
Sent: 12 March 2009 06:15
To: simple
Subject: [Simple] Partial Publication of elements with more than
oneinstance possible

Hello all,

According to the Presence RFCs, there can be a few elements like <note>,
<cipid>-<display_name> that can have multiple entries.
However, they don't have ids associated with them to identify the
instances.

Kindly suggest!

Regards,
Pankaj
_______________________________________________
Simple mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/simple

---

From: "Deka Sanjeeb Kumar-KHBJ46" <[email-masked]>
Date: Tue, 31 Mar 2009 18:43:29 +0800

Hi All,

Can anyone help me out for the following:

Party A has "Call Waiting" enabled. 
Party A is in conversation with Emergency(E911) Server.
Party B makes a call to Party A during the conversation.

I just wanted to know whether Party A should get a Call Waiting tone or
it sends a 486 Busy response to Party B.

Moreover, is there any document available which explains about the
priority of a feature during Feature Interaction?

Regards,
Sanjeeb

---

From: "Vijay K. Gurbani" <[email-masked]>
Date: Tue, 31 Mar 2009 16:14:29 -0500

> priority of a feature during Feature Interaction?

Sanjeeb: Feature Interaction (FI) was a tough enough nut
to crack back in the days of centralized PSTN.  With the
decomposed and distributed architecture of Internet telephony,
it is more challenging as each endpoint thinks it knows the
absolute version of the truth.

There isn't any one document that talks about FI in Internet
telephony.  I would start with the following pointers and
see where you end up:

1) Pamela Zave's research on FI at ATT (see
  http://www.research.att.com/~pamela/fi.html) -- this has a link
  to a lot of papers.
2) "Feature Interaction in Internet Telephony", Jonathan Lennox
  and Henning Schulzrinne. From Proceedings of the Sixth International
  Workshop on Feature Interactions in Telecommunications and Software
  Systems, May 2000. <http://www1.cs.columbia.edu/~lennox/featint.pdf>

Ciao.

- vijay
-- 
Vijay K. Gurbani, Bell Laboratories, Alcatel-Lucent
1960 Lucent Lane, Rm. 9C-533, Naperville, Illinois 60566 (USA)
Email: vkg@{alcatel-lucent.com,bell-labs.com,acm.org}
Web:   http://ect.bell-labs.com/who/vkg/