Subject: Re: [Simple] Liaison Statement from the Open Mobile Alliance

From: Ben Campbell <[email-masked]>
Date: Wed, 18 Nov 2009 15:59:23 -0600

<chair>
We've had a small amount of on-list discussion. From the emails so far I gather that there are no objections to correcting the schema as published by IANA to match those from RFC 4826. However, there have been some objections to adding the SchemaLocation parameters as requested in the liaison statement.

Everyone--please take a look at the liaison statement and offer your opinions. Even "me too" comments would be helpful at this point. It's been almost two months since OMA sent the liaison statement, and we need to respond to it ASAP.

Thanks!

Ben.

</chair>

On Oct 2, 2009, at 1:12 PM, Ben Campbell wrote:

> (as SIMPLE co-chair)
> 
> OMA sent a liaison statement to the SIMPLE working group. The statement's overview reads as follows:
> 
> "This Liaison Statement reports XML validation problems in the XML schemas that were introduced in RFC 4826 and asks for correction."
> 
> Please read the LS, and send your opinions to the SIMPLE list. A PDF  is available at https://datatracker.ietf.org/documents/LIAISON/file707.pdf
> 
> Thanks!
> 
> Ben.
> _______________________________________________
> Simple mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/simple

---

From: Hisham Khartabil <[email-masked]>
Date: Thu, 19 Nov 2009 12:14:37 +1100

<as individual>

No issues in correcting the IANA pages, but we can't make modifications or
extensions to a schema published in an RFC unless the extension is
documented and published.

Thanks,
Hisham

2009/11/19 Ben Campbell <[email-masked]>

> <chair>
> We've had a small amount of on-list discussion. From the emails so far I
> gather that there are no objections to correcting the schema as published by
> IANA to match those from RFC 4826. However, there have been some objections
> to adding the SchemaLocation parameters as requested in the liaison
> statement.
>
> Everyone--please take a look at the liaison statement and offer your
> opinions. Even "me too" comments would be helpful at this point. It's been
> almost two months since OMA sent the liaison statement, and we need to
> respond to it ASAP.
>
> Thanks!
>
> Ben.
>
> </chair>
>
>
> > "This Liaison Statement reports XML validation problems in the XML
> schemas that were introduced in RFC 4826 and asks for correction."
> >
> > Please read the LS, and send your opinions to the SIMPLE list. A PDF  is
> available at https://datatracker.ietf.org/documents/LIAISON/file707.pdf
> >
> > Thanks!
> >
> > Ben.

---

From: Ben Campbell <[email-masked]>
Date: Wed, 18 Nov 2009 19:31:20 -0600

<individual>

And the thing they are asking for would generally _not_ make sense to put in an RFC, unless we are willing to ensure the URL to the schema lives forever.

On Nov 18, 2009, at 7:14 PM, Hisham Khartabil wrote:

> <as individual>
> 
> No issues in correcting the IANA pages, but we can't make modifications or extensions to a schema published in an RFC unless the extension is documented and published.
> 
> Thanks,
> Hisham
>

---

From: Ben Campbell <[email-masked]>
Date: Fri, 20 Nov 2009 15:06:20 -0600

Digging a little deeper, I have a question about the schemaLocation request in the liaison statement:

The statement proposes adding a schemaLocation attribute to the <import> element that imports the resource-list schema into the RLS-Services  schema. But on inspection, there is no <import> element whatsoever in the rls-services schema. However, the <schema> element does contain a namespace declaration that references resource-list. Was the liaison statement intended to request we add schemaLocation to the namespace declaration?

Or am I missing something?

---

From: "Rauschenbach, Uwe (NSN - DE/Munich)" <[email-masked]>
Date: Wed, 25 Nov 2009 18:31:58 +0100

Hi Ben,
 
thanks for moving this forward. As the author of the LS, let me provide
some clarification.
 
The LS states:
 
Validation problems in urn:ietf:params:xml:ns:rls-services Schema as
available from [3]

This XML schema imports the resource-lists schema, however does not
provide a schema location for it. Due to this, the rls-services schema
does not validate because the validator can not fetch the referenced
schema. It is therefore suggested to add a schemaLocation attribute to
the <import> declaration of the rls-services XML schema instance in the
IANA repository.
[3] http://www.iana.org/assignments/xml-registry/schema/rls-services.xsd
<http://www.iana.org/assignments/xml-registry/schema/rls-services.xsd> 

I have cross-checked and indeed neither the schema in IANA repository
nor the one in the RFC contains an <import> statement. So, the text in
the LS is not 100% correct but its spirit is that OMA requests to make
sure that validators that use this schema will be informed about the
additional schema needed for validation and its location. Note that a
similar <import> declaration (including a schemaLocation attribute) is
contained in the XML schema for resource-lists (it imports the standard
XML namespace).  

Based on the schema for rls-services in RFC4826, the LS should have
stated:

The rls-services XML schema references the resource-lists schema
namespace, however neither imports the schema nor provides a schema
location for it. Due to this, the rls-services schema does not validate
because the validator can not fetch the referenced schema. It is
therefore suggested to add the missing <import> declaration (including a
schemaLocation attribute) to the rls-services XML schema instance in the
IANA repository.

Sorry about the confusion caused, and good catch.

Kind regards,
Uwe 

________________________________

	From: [email-masked] [mailto:[email-masked]]
On Behalf Of ext Ben Campbell
	Sent: Friday, November 20, 2009 10:06 PM
	To: [email-masked]; Simple WG; Dean Willis
	Subject: Re: [Simple] Liaison Statement from the Open Mobile
Alliance

	Digging a little deeper, I have a question about the
schemaLocation request in the liaison statement: 

	The statement proposes adding a schemaLocation attribute to the
<import> element that imports the resource-list schema into the
RLS-Services  schema. But on inspection, there is no <import> element
whatsoever in the rls-services schema. However, the <schema> element
does contain a namespace declaration that references resource-list. Was
the liaison statement intended to request we add schemaLocation to the
namespace declaration?

		<individual>

		And the thing they are asking for would generally _not_
make sense to put in an RFC, unless we are willing to ensure the URL to
the schema lives forever.

			<as individual>
			
			No issues in correcting the IANA pages, but we
can't make modifications or extensions to a schema published in an RFC
unless the extension is documented and published.
			
			Thanks,
			Hisham

				<chair>
				We've had a small amount of on-list
discussion. From the emails so far I gather that there are no objections
to correcting the schema as published by IANA to match those from RFC
4826. However, there have been some objections to adding the
SchemaLocation parameters as requested in the liaison statement.
				
				Everyone--please take a look at the
liaison statement and offer your opinions. Even "me too" comments would
be helpful at this point. It's been almost two months since OMA sent the
liaison statement, and we need to respond to it ASAP.
				
				Thanks!
				
				Ben.
				
				</chair>

				On Oct 2, 2009, at 1:12 PM, Ben Campbell
wrote:
				
				> (as SIMPLE co-chair)
				>
				> OMA sent a liaison statement to the
SIMPLE working group. The statement's overview reads as follows:
				>
				> "This Liaison Statement reports XML
validation problems in the XML schemas that were introduced in RFC 4826
and asks for correction."
				>
				> Please read the LS, and send your
opinions to the SIMPLE list. A PDF  is available at
https://datatracker.ietf.org/documents/LIAISON/file707.pdf

---

From: "Thomson, Martin" <[email-masked]>
Date: Thu, 26 Nov 2009 08:14:45 +0800

Uwe,

Can I suggest that you submit errata on 4826?  That is the usual method we use to resolve actual errors.

To date, the policy has been to NOT use schemaLocation in RFCs.  We’ve had a lot of discussion on the merits (and disadvantages) of putting schemaLocation attributes in files.  Our discussions concentrated on that aspect.  If there is a case for doing so, then IANA need to be the ones that accept the responsibility for maintaining schema URLs, since RFCs will not.

--Martin

From: [email-masked] [mailto:[email-masked]] On Behalf Of Rauschenbach, Uwe (NSN - DE/Munich)
Sent: Thursday, 26 November 2009 4:32 AM
To: ext Ben Campbell; [email-masked]; Simple WG; Dean Willis
Subject: Re: [Simple] Liaison Statement from the Open Mobile Alliance

Hi Ben,

thanks for moving this forward. As the author of the LS, let me provide some clarification.

The LS states:

Validation problems in urn:ietf:params:xml:ns:rls-services Schema as available from [3]

This XML schema imports the resource-lists schema, however does not provide a schema location for it. Due to this, the rls-services schema does not validate because the validator can not fetch the referenced schema. It is therefore suggested to add a schemaLocation attribute to the <import> declaration of the rls-services XML schema instance in the IANA repository.
[3] http://www.iana.org/assignments/xml-registry/schema/rls-services.xsd

I have cross-checked and indeed neither the schema in IANA repository nor the one in the RFC contains an <import> statement. So, the text in the LS is not 100% correct but its spirit is that OMA requests to make sure that validators that use this schema will be informed about the additional schema needed for validation and its location. Note that a similar <import> declaration (including a schemaLocation attribute) is contained in the XML schema for resource-lists (it imports the standard XML namespace).

Based on the schema for rls-services in RFC4826, the LS should have stated:
The rls-services XML schema references the resource-lists schema namespace, however neither imports the schema nor provides a schema location for it. Due to this, the rls-services schema does not validate because the validator can not fetch the referenced schema. It is therefore suggested to add the missing <import> declaration (including a schemaLocation attribute) to the rls-services XML schema instance in the IANA repository.

Kind regards,
Uwe

________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of ext Ben Campbell
Sent: Friday, November 20, 2009 10:06 PM
To: [email-masked]; Simple WG; Dean Willis
Subject: Re: [Simple] Liaison Statement from the Open Mobile Alliance
Digging a little deeper, I have a question about the schemaLocation request in the liaison statement:

<individual>

<as individual>

Thanks,
Hisham
2009/11/19 Ben Campbell <[email-masked]<mailto:[email-masked]>>
<chair>
We've had a small amount of on-list discussion. From the emails so far I gather that there are no objections to correcting the schema as published by IANA to match those from RFC 4826. However, there have been some objections to adding the SchemaLocation parameters as requested in the liaison statement.

Thanks!

Ben.

</chair>

On Oct 2, 2009, at 1:12 PM, Ben Campbell wrote:

> [email-masked]<mailto:[email-masked]>

_______________________________________________
Simple mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/simple

_______________________________________________
Simple mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/simple

---

From: Ben Campbell <[email-masked]>
Date: Wed, 25 Nov 2009 20:35:08 -0600

Unless I misunderstand, the statement is not asking for an update to the RFC--it's asking for an update to the IANA published version. It's an IETF policy question whether that would actually require an RFC update or errata.

On Nov 25, 2009, at 6:14 PM, Thomson, Martin wrote:

> > Please read the LS, and send your opinions to the SIMPLE list. A PDF  is available athttps://datatracker.ietf.org/documents/LIAISON/file707.pdf
> >
> > Thanks!
> >
> > Ben.

---

From: "Thomson, Martin" <[email-masked]>
Date: Thu, 26 Nov 2009 11:14:50 +0800

I think that an errata needs to be raised to resolve the import issue; I’m happy to raise this myself.

It would be possible to put schemaLocation in RFCs, but that’s an IETF policy issue that we’d have to discuss with the XML experts and probably with IANA, since they would have to maintain the documents that the links refer to.  To date, the policy has been to avoid this, but that doesn’t mean that the policy can’t be changed.

--Martin

From: Ben Campbell [mailto:[email-masked]]
Sent: Thursday, 26 November 2009 1:35 PM
To: Thomson, Martin
Cc: Rauschenbach, Uwe (NSN - DE/Munich); [email-masked]; Simple WG; Dean Willis
Subject: Re: [Simple] Liaison Statement from the Open Mobile Alliance

Uwe,

--Martin

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Rauschenbach, Uwe (NSN - DE/Munich)
Sent: Thursday, 26 November 2009 4:32 AM
To: ext Ben Campbell; [email-masked]<mailto:[email-masked]>; Simple WG; Dean Willis
Subject: Re: [Simple] Liaison Statement from the Open Mobile Alliance

Hi Ben,

The LS states:

Kind regards,
Uwe

________________________________
From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of ext Ben Campbell
Sent: Friday, November 20, 2009 10:06 PM
To: [email-masked]<mailto:[email-masked]>; Simple WG; Dean Willis
Subject: Re: [Simple] Liaison Statement from the Open Mobile Alliance
Digging a little deeper, I have a question about the schemaLocation request in the liaison statement:

<individual>

<as individual>

Thanks,
Hisham

Thanks!

Ben.

</chair>