Subject: Re: [Simple] Liaison Statement from the Open Mobile Alliance

From: Brian McColgan <[email-masked]>
Date: Fri, 20 Nov 2009 16:37:25 -0500

Ben Campbel wrote:

> And the thing they are asking for would generally _not_ make sense to put in an RFC,...

<as individual>

What about simply adding the schemaLocation as an 'informative comment'?  At least folks (i.e. implementors making use of these XML Schema's) would be able to locate a 'presumably correct' soft-copy of the XSD corresponding to the RFC.  

Or perhaps the RFC template could be ammended to include the IANA schema location? 

>...unless we are willing to ensure the URL to the schema lives forever.

Ben, do you know something (regarding IANA) that we don't?  8^)
 		 	   		  
_________________________________________________________________
Ready. Set. Get a great deal on Windows 7. See fantastic deals on Windows 7 now
http://go.microsoft.com/?linkid=9691818

---

From: Ben Campbell <[email-masked]>
Date: Fri, 20 Nov 2009 16:08:01 -0600

> What about simply adding the schemaLocation as an 'informative comment'?  At least folks (i.e. implementors making use of these XML Schema's) would be able to locate a 'presumably correct' soft-cop…

If I understand the liaison statement correctly, they need schemaLocation in a formally correct location, so that automated validation tools can find and include the referenced schema. That is, this is for automata, not people. So I'm not sure adding it as just a comment helps. (Note that I am _not_ sure I understand the liaison statement correctly on this point--please see my other email on the subject.)

> Ben, do you know something (regarding IANA) that we don't?  8^)

 I am not aware of some impending doom, if that's what you mean. :-) It's probably really up to IANA whether this sort of thing makes sense. I can see they might want the ability to reorganize such things from time to time, but they may consider that no different than other IANA registered information that gets written into RFC-stone. 

> Get a great deal on Windows 7 and see how it works the way you want. See the Windows 7 offers now._______________________________________________
> Simple mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/simple