Subject: Re: [Simple] Suggested next actions with draft-ietf-simple-interdomain-scaling-analysis

From: "Bernard Aboba" <[email-masked]>
Date: Tue, 8 Dec 2009 10:44:34 -0800

I agree with all of Peter's points below. 

However, this begs the question of what the next steps are on 

draft-ietf-simple-interdomain-scaling-analysis. 

IMHO, both draft-ietf-simple-interdomain-scaling-analysis and

draft-saintandre-xmpp-presence-analysis would benefit from the context that

Peter's suggested "more general analysis" would provide.  

Not only would that context make both documents more understandable, but

it would also help answer the questions posed in item #5.   "Better numbers"
by

themselves can't accomplish that. 

Peter Saint-Andre wrote:

> Avshalom and I just had a chat about this I-D. He might post in more 

> detail, but my main conclusions are as follows:

> 1. Analyzing the network impact of presence technologies is the 

> responsible thing for the IETF to do.

> 2. The analyses in draft-ietf-simple-interdomain-scaling-analysis and 

> draft-saintandre-xmpp-presence-analysis are not intended to force work 

> on optimizations, instead they are intended to frame a broader 

> discussion about the network impact of presence technologies.

> 3. It's unproductive to set up a competition in this regard between 

> SIP and XMPP.

> 4. It would be more productive to move up a level of abstraction by 

> discussing presence technologies at a higher level (not specific to 

> SIP or XMPP).

> 5. A more general treatment might help protocol designers, application 

> developers, and service operators think more clearly about protocol 

> optimizations, implementation improvements, and deployment sizing.

> However, detailed discussion of those issues belongs somewhere else, 

> not in the general analysis document.

> If people on this list think it would be helpful, Avshalom and I are 

> open to working together on a more general analysis.

> Peter

---

From: Peter Saint-Andre <[email-masked]>
Date: Tue, 08 Dec 2009 11:47:55 -0700

If we work on a more general analysis, perhaps there might not be next
steps on draft-ietf-simple-interdomain-scaling-analysis. I think it's
too early to say.

On 12/8/09 11:44 AM, Bernard Aboba wrote:
> I agree with all of Peter’s points below.
> 
>  
> 
> Peter’s suggested “more general analysis” would provide. 
> 
>  
> 
> it would also help answer the questions posed in item #5.   “Better
> numbers” by
> 
> themselves can’t accomplish that.
> 
>  
> 
>  
> 
>  
> 
> Peter Saint-Andre wrote:
>

---

From: Avshalom Houri <[email-masked]>
Date: Tue, 8 Dec 2009 22:43:52 +0200

In other words, does the SIMPLE WG is interested in revising the the
interdomain-scaling draft to satisfy the last minute comments at the IESG
according to the work plan that I have sent to the list few weeks ago,
or they would rather prefer that Peter and me will work on a new a 
document
that will merge both the SIMPLE and the XMPP scaling analysis documents
in a more general way as described in Peter's note below?

--Avshalom

[email-masked] wrote on 08/12/2009 08:47:55 PM:

> From:
> 
> Peter Saint-Andre <[email-masked]>
> 
> To:
> 
> Bernard Aboba <[email-masked]>
> 
> Cc:
> 
> [email-masked]
> 
> Date:
> 
> 08/12/2009 08:48 PM
> 
> Subject:
> 
> Re: [Simple] Suggested next actions with draft-ietf-simple-
> interdomain-scaling-analysis
> 
> Sent by:
> 
> [email-masked]
> 
> > I agree with all of Peter?s points below.
> > 
> > 
> > 
> > Peter?s suggested ?more general analysis? would provide. 
> > 
> > 
> > 
> > it would also help answer the questions posed in item #5.   ?Better
> > numbers? by
> > 
> > themselves can?t accomplish that.
> > 
> > 
> > 
> > 
> > 
> > 
> > 
> > Peter Saint-Andre wrote:
> > 
> [attachment "smime.p7s" deleted by Avshalom Houri/Haifa/IBM] 
> _______________________________________________
> Simple mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/simple

---

From: Ben Campbell <[email-masked]>
Date: Thu, 10 Dec 2009 16:33:39 -0600

Hi Avshalom and Peter,

Can you offer some examples of the sort of analyses you have in mind?

On Dec 8, 2009, at 2:43 PM, Avshalom Houri wrote:

> or they would rather prefer that Peter and me will work on a new a document

---

From: Hisham Khartabil <[email-masked]>
Date: Sat, 12 Dec 2009 00:49:06 +1100

Avshalom,

I don't think you will be able to easily satisfy the DISCUSS issues without
substantial changes to the draft, which will most likely be thrown back to
the WG by the IESG.

(with my individual hat on)
I don't think we want to do what Peter is suggesting in the SIMPLE WG. If we
are to go down that path, then I suggest removing that milestone from the
charter and do the work elsewhere.

Thanks,
Hisham

2009/12/9 Avshalom Houri <[email-masked]>

---

From: Avshalom Houri <[email-masked]>
Date: Wed, 16 Dec 2009 12:35:23 +0200

Hisham,

The plan that I have sent earlier was agreed also by Cullen but anyway I 
think that the revised document will have to go back to the WG.
I hope that this time we will not get last second surprises (just before 
it was to be approved) as an RFC from the IESG.
Note that the document has passed several WGLC, IETF last call, dedicated 
review and was about to be approved by the IESG when the comments were 
made.

Regarding your comment about doing a more general document in the SIMPLE, 
why do you think that that is not something that SIMPLE should not do?
Is that because you think that this type of documents is not something 
that the IETF should do in general?

--Avshalom

From:
Hisham Khartabil <[email-masked]>
To:
Avshalom Houri/Haifa/IBM@IBMIL
Cc:
[email-masked], Peter Saint-Andre <[email-masked]>
Date:
11/12/2009 03:49 PM
Subject:
Re: [Simple] Suggested next actions with 
draft-ietf-simple-interdomain-scaling-analysis

Avshalom,

I don't think you will be able to easily satisfy the DISCUSS issues 
without substantial changes to the draft, which will most likely be thrown 
back to the WG by the IESG.

(with my individual hat on)
I don't think we want to do what Peter is suggesting in the SIMPLE WG. If 
we are to go down that path, then I suggest removing that milestone from 
the charter and do the work elsewhere.

Thanks,
Hisham

--Avshalom

---

From: Avshalom Houri <[email-masked]>
Date: Wed, 16 Dec 2009 12:40:20 +0200

Ben,

I am not sure if there is an example of a similar document at the IETF.
The idea is as described by Peter in points 3 and 4 below is to discuss 
presence scalability in
general and try to delay as much as possible (maybe appendixes) 
discussions on specific protocols.

Anyway, I am not sure if there is enough support for more general document 
in the SIMPLE group
and not sure about if there is still interest in the original document in 
the SIMPLE WG as the amount of
responses is scanty and we do not get any numbers from real deployments. 
Are not there any deployments
of SIMPLE?

I am very frustrated regarding getting these type of comments from the 
IESG on the last second before it was to
be approved as an RFC. However, I want to finish this document only more 
as honor to the amount of work that
people have invested in this document.

So I should assume that there is not enough support for general document 
in the SIMPLE group and I should porceed
with the original plan as was agreed also by Cullen?

Thanks
--Avshalom

From:
Ben Campbell <[email-masked]>
To:
11/12/2009 12:35 AM

Hi Avshalom and Peter,

--Avshalom

---

From: Peter Saint-Andre <[email-masked]>
Date: Wed, 16 Dec 2009 08:53:53 -0700

When Avshalom and I spoke recently, we discussed the idea of a "more
general" treatment of the topic of presence scalability, but did not get
into specifics of what that would mean. Here is my take...

Each of the current drafts discusses a particular technology (SIMPLE or
XMPP). However, at a higher level of abstraction I think that *any*
presence technology is going to have a non-trivial network impact,
simply because of the multiplicative nature of presence (when I come
online or change my presence or go offline, that information will be
multicasted to tens or hundreds or in my case thousands of people).

Therefore, rather than talking about SIMPLE or XMPP or any other
particular presence technology, I think it would be appropriate to
discuss at a higher level how presence behaves on the network. That
means abstracting from SIMPLE and XMPP. It means making some assumptions
about presence in general, but I think there are enough commonalities
between the presence technologies we know best to make this fairly
straightforward. It means talking about ranges with regard to the size
of presence notifications, but both of the analyses already talk about
ranges with regard to the number of buddies and other factors, so that
is not a big change. It means dropping the competition between SIMPLE
and XMPP about who's better, but that was never very productive in the
first place and we've removed the comparative stuff from the I-Ds in
question long ago. And so on.

Whether this work belongs in the SIMPLE WG or can be pursued as an
independent submission is a matter for the chairs to decide, but I'm
still convinced that it is appropriate for the IETF to analyse the
network impact of presence technologies. No, presence doesn't have the
impact of voice or video, but its impact is non-trivial and deserves to
be documented so that operators can take the impact into account when
deciding to deploy SIMPLE, XMPP, or any other technology.

Peter

On 12/16/09 3:40 AM, Avshalom Houri wrote:
> Anyway, I am not sure if there is enough support for more general
> document in the SIMPLE group
> and not sure about if there is still interest in the original document
> in the SIMPLE WG as the amount of
> From: 	Ben Campbell <[email-masked]>
> To: 	Avshalom Houri/Haifa/IBM@IBMIL
> Cc: 	[email-masked], Peter Saint-Andre <[email-masked]>
> Date: 	11/12/2009 12:35 AM
> Subject: 	Re: [Simple] Suggested next        actions        with      
> ------------------------------------------------------------------------
> 
> 
> 
> Hi Avshalom and Peter,
> 
> _
> [email-masked] <mailto:[email-masked]> wrote on
> 08/12/2009 08:47:55 PM:
> 
>> From:
>>
>> Peter Saint-Andre <[email-masked] <mailto:[email-masked]>>
>>
>> To:
>>
>> Bernard Aboba <[email-masked]
> <mailto:[email-masked]>>
>>
>> Cc:
>>
>> [email-masked] <mailto:[email-masked]>
>>
>> Date:
>>
>> 08/12/2009 08:48 PM
>>
>> Subject:
>>
>> [email-masked] <mailto:[email-masked]>
>>