Subject: [sip-clf] Open issues for the SIP CLF representation draft

From: Gonzalo Salgueiro <[email-masked]>
Date: Thu, 10 Feb 2011 01:52:42 -0500

Folks -

In preparation for the -00 draft of the WG implementation draft, I need to close on a few unresolved issues that we agreed during the Virtual Interim Meeting to take to the list for further discussion. Please provide timely feedback so we minimize the number of open issues to discuss in Prague.

1. Shall we use a TAB or a SPACE (or any LWS) as field delimiters?

Considerations and points raised:

- TABs don’t survive Telnet or web pages very well, especially when copy/pasting.
- spaces can appear inside fields (as can most other delimiters we choose)
- how do TAB and SPACE delimiters interact with shell tools (rep, cut, awk)

2. Do we need to update the syntax of the optionally logged fields from the current well known (though possibly more cryptic) TLV representation?

<mandatory fields>	01,07,foo.bar	02,0b,hello world      

to something more easily readable (like tag="value")?

<mandatory fields> 1="foo.bar" 2="hello world”

Considerations and points raised:

- some concern about adding quotes around values (since some fields will contain quotes)
- this issue exists for almost any delimiter
- essentially a matter of "taste"

Warm Regards,

--Gonzalo

---

From: Peter Musgrave <[email-masked]>
Date: Sun, 13 Feb 2011 08:07:40 -0500

Hi, 

1. I guess I favour tabs (since I expect a lot of spaces in fields) despite their drawbacks in e.g. Telnet. 

2. I would avoid the equals and quotes since this introduces two elements which could be in the data whereas the TLV introduces only one (comma)

Peter Musgrave
(as individual)

On 2011-02-10, at 1:52 AM, Gonzalo Salgueiro wrote:

> _______________________________________________
> sip-clf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sip-clf

---

From: Gonzalo Salgueiro <[email-masked]>
Date: Sun, 27 Feb 2011 16:03:02 -0500

Thanks Peter. Does anyone else care to weigh in with some opinions on this prior to the -00 deadline?

Regards,

Gonzalo