Subject: [sip-clf] Protocol Action: 'Format for the Session Initiation Protocol (SIP) Common Log Format (CLF)' to Proposed Standard (draft-ietf-sipclf-format-11.txt)

From: The IESG <[email-masked]>
Date: Wed, 09 Jan 2013 12:48:44 -0800

The IESG has approved the following document:
- 'Format for the Session Initiation Protocol (SIP) Common Log Format
   (CLF)'
  (draft-ietf-sipclf-format-11.txt) as Proposed Standard

This document is the product of the SIP Common Log Format Working Group.

The IESG contact persons are Robert Sparks and Gonzalo Camarillo.

A URL of this Internet Draft is:
http://datatracker.ietf.org/doc/draft-ietf-sipclf-format/

Technical Summary:

The Session Initiation Protocol does not have a common log format, and as a result, 
each server supports a distinct log format that makes it unnecessarily complex 
to produce tools to do trend analysis and security detection. This document describes 
a text based format based on the data model defined in the companion document 
draft-ietf-sipclf-problem-statement. This format uses an indexed text approach to 
facilitate rapid searching of the log contents while retaining the advantages of a 
generic text search and filtering tools.

Working Group Summary:

The discussion of indexed-ascii specifically did not result in any contentious issues 
in the WG discussion. More generally the choice of indexed ascii was more difficult 
for the WG and took place during the development of draft-ietf-sipclf-problem-statement.

Document Quality:

There were sample implementations of the indexed ascii format written by 
Peter Musgrave and placed on the sipclf Wiki page 
(<http://trac.tools.ietf.org/wg/sipclf/trac/wiki>). 
Vijay Gurbani reports that three other implementations are known.

Personnel:

Peter Musgrave is the document shepherd. Robert Sparks is the responsible AD.

---

From: Peter Musgrave <[email-masked]>
Date: Thu, 10 Jan 2013 04:31:26 -0500

Woohoo! (There is an announce for the problem statement as well)

Big thanks to Vijay Gurbani, Gonzola Salguiro and our AD Robert Sparks for getting these across the finish line!

Peter Musgrave

Begin forwarded message:

> From: The IESG <[email-masked]>
> Subject: [sip-clf] Protocol Action: 'Format for the Session Initiation Protocol (SIP)	Common Log Format (CLF)' to Proposed Standard	(draft-ietf-sipclf-format-11.txt)
> Date: 9 January, 2013 3:48:44 PM EST
> To: IETF-Announce <[email-masked]>
> Cc: sipclf chair <[email-masked]>, sipclf mailing list <[email-masked]>, RFC Editor <[email-masked]>
> 
> _______________________________________________
> sip-clf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sip-clf

---

From: "Vijay K. Gurbani" <[email-masked]>
Date: Thu, 10 Jan 2013 08:35:02 -0600

On 01/10/2013 03:31 AM, Peter Musgrave wrote:
> Big thanks to Vijay Gurbani, Gonzola Salguiro and our AD Robert Sparks
> for getting these across the finish line!

Thanks, Peter.  I will also like to thank Adam, Theo, Dale, Paul, 
Henning, Spencer and many others in the WG that provided valuable
feedback on these drafts as they progressed.

Thank you as well for the prototype implementations and other
associated chair duties to move these drafts along.

Ciao,

- vijay
-- 
Vijay K. Gurbani, Bell Laboratories, Alcatel-Lucent
1960 Lucent Lane, Rm. 9C-533, Naperville, Illinois 60563 (USA)
Email: vkg@{bell-labs.com,acm.org} / [email-masked]
Web:   http://ect.bell-labs.com/who/vkg/

---

From: Gonzalo Salgueiro <[email-masked]>
Date: Thu, 10 Jan 2013 11:00:27 -0500

>> Woohoo! (There is an announce for the problem statement as well)

Hurray indeed!  
> Thanks, Peter.  I will also like to thank Adam, Theo, Dale, Paul, Henning, Spencer and many others in the WG that provided valuable

Absolutely. Big thanks to Adam for his original indexed ascii manuscript, The guidance from Chris Lonvick and the feedback from Hadriel, Joe, Paul, etc. was invaluable. Thanks to all.

> associated chair duties to move these drafts along.

It isn't lost on me/us how much work Peter and Robert (as chair and AD) put into getting these progressed to publication.  Sincere thanks.

Cheers,

Gonzalo

---

From: Eric Burger <[email-masked]>
Date: Thu, 10 Jan 2013 14:26:07 -0500

Are we done yet? :-)

Great work, everyone!