Subject: [sip-overload] soc-overload-control-08 released

From: "Vijay K. Gurbani" <[email-masked]>
Date: Mon, 12 Mar 2012 12:32:01 -0500

Folks: I have updated soc-overload-control to version -08 [1].

I realize that WGLC does not end until Mar-15 for this draft, but
I wanted to update the archives to include the discussion on the
algorithm we had last week on the mailing list [2] and one minor
editorial text agreed to in [3].

Please take a look at the "Note" at the end of the algorithm in
version -08; there are a couple of magic numbers buried there that
I will like to expose to a wider audience to make sure that the
defaults chosen there are reasonable.

[1] http://tools.ietf.org/html/draft-ietf-soc-overload-control-08
[2] 
http://www.ietf.org/mail-archive/web/sip-overload/current/threads.html#00734
[3] http://www.ietf.org/mail-archive/web/sip-overload/current/msg00757.html

Thanks,

- vijay
-- 
Vijay K. Gurbani, Bell Laboratories, Alcatel-Lucent
1960 Lucent Lane, Rm. 9C-533, Naperville, Illinois 60563 (USA)
Email: vkg@{bell-labs.com,acm.org} / [email-masked]
Web:   http://ect.bell-labs.com/who/vkg/

---

From: "Ravindran, Parthasarathi" <[email-masked]>
Date: Thu, 15 Mar 2012 18:05:22 +0000

Hi Vijay,

1) Sec 9.1.2 Event package mechanism proposes a new event package but it does not provides the exact package for convey the overload information. Please let me whether the intention is to use "oc" parameters in Via of NOTIFY message or implementers has to choose their own event package. IMO, it is better to define some package in the standard rather than just providing the design and implementers choose the proprietary packages.

Some Editorial comments & query

2) Sec 5.4 para 2: whether overload control applies for IP or IP & port. please let me know significance of port in this context

3) Sec 5.6: "SIP server SHOULD strip the" instead "proxy SHOULD strip the"

4) Sec 5.6: Any specific reason for having "SHOULD" instead of "MUST". I'm interested in knowing whether any implementation is interested in forwarding this information to multiple hop using configuration mechanism.

5) Sec 5.7 "2nd line note" shall be added in I-D.noel-soc-overload-rate-control

6) Sec 5.10.1: It may be better to provide the recommendation for "REGISTER" message vs other message like INVITE as well. IMO, REGISTER has to be given higher priority over INVITE message in SIP servers.

Thanks
Partha

>-----Original Message-----
>From: [email-masked] [mailto:sip-overload-
>[email-masked]] On Behalf Of Vijay K. Gurbani
>Sent: Monday, March 12, 2012 11:02 PM
>To: [email-masked]
>Subject: [sip-overload] soc-overload-control-08 released
>
>I realize that WGLC does not end until Mar-15 for this draft, but I
>wanted to update the archives to include the discussion on the algorithm
>we had last week on the mailing list [2] and one minor editorial text
>agreed to in [3].
>
>Please take a look at the "Note" at the end of the algorithm in version
>-08; there are a couple of magic numbers buried there that I will like
>to expose to a wider audience to make sure that the defaults chosen
>there are reasonable.
>
>_______________________________________________
>sip-overload mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/sip-overload