Subject: SIP & RTSP interworking?

From: Linden deCarmo <[email-masked]>
Date: Tue, 14 Mar 2000 08:26:55 -0500

What would be the proper (or suggested) procedure to tie a SIP session to an
RTSP session?

What I'd like to do is setup a session with SIP (via an INVITE), then
control streaming aspects via RTSP (i.e. play, pause, stop etc.).  However,
its not clear to me how I tie the RTSP session id to the previously
established SIP session.

Thanks.

Linden deCarmo
Netspeak Corporation
902 Clint Moore Road
Suite 104
Boca Raton, FL 33487

---

From: Dean Willis <[email-masked]>
Date: Wed, 15 Mar 2000 13:10:25 -0600

Here's what I would suggest:

Build a SIP UAS that understands the RTSP end and contains stream management
logic. This UAS either reinvites to establish the link to RTSP streams, or
copies the RTP from each stream back into the media path for the remote UA.

I know of some people(s) who are already using each approach to build a
voice mail system that can use a standard RTSP server as a media store.
Makes unified messaging with URL passing MUCH easier.

--
dean

> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Linden
> deCarmo
> Sent: Tuesday, March 14, 2000 7:27 AM
> To: [email-masked]'
> Subject: SIP & RTSP interworking?
>
>