Subject: RE: Stateful/Stateless proxies

From: "Glenn Morrow" <[email-masked]>
Date: Fri, 3 Mar 2000 09:42:00 -0600

Do you mean call or transactionally stateful?

> -----Original Message-----
> From:	Jonathan Rosenberg [SMTP:[email-masked]]
> Sent:	Friday, March 03, 2000 1:08 AM
> To:	yinshaohua
> Cc:	Igor Slepchin; [email-masked]
> Subject:	Re: Stateful/Stateless proxies
> 
> 
> 
> yinshaohua wrote:
> > 
> > Hi:
> >     Now that " A single physical proxy may act as stateless in some
> > situations and as stateful in others" , what role do we comply with when
> > making a proxy stateful or stateless after receiving a INVITE request?
> 
> Whichever you want, depening on what it is you wish to accomplish. Its
> based on administrator policy, the service being invoked, or whatever.
> The only rules are:
> 
> 1. if you send TCP, you have to be stateful
> 2. if you send multicast, you have to be stateful
> 3. if you fork, you have to be stateful
> 
> -Jonathan R.
> -- 
> Jonathan D. Rosenberg                       200 Executive Drive
> Chief Scientist                             Suite 120 
> dynamicsoft                                 West Orange, NJ 07052
> [email-masked]                     FAX:   (732) 741-4778
> http://www.cs.columbia.edu/~jdrosen         PHONE: (732) 741-7244
> http://www.dynamicsoft.com
>

---

From: Jonathan Rosenberg <[email-masked]>
Date: Fri, 03 Mar 2000 12:34:13 -0500

Yes. When the SIP spec says "stateful", thats "transaction stateful".

-Jonathan R.

> Glenn Morrow wrote: