Subject: Teardown sequence for SIP-to-ISDN call

From: [email-masked]
Date: Thu, 30 Mar 2000 15:00:49 -0600

In "SIP Telephony Call Flow Examples," the teardown sequence for a
SIP-to-ISDN call (pp. 83-84) is shown as 

       |     BYE F24    |                |
       |--------------->|                |
       |     200 F25    |                |
       |<---------------| DISConnect F27 |
       |                |--------------->|
       |                |   RELease F28  |
       |                |<---------------|
       |                | RELease COM F29|
       |                |--------------->|
       |                |                |

I was wondering why this was selected instead of 

       |     BYE        |                |
       |--------------->|                |
       |                | DISConnect     |
       |                |--------------->|
       |                |   RELease      |
       |                |<---------------|
       |     200        |                |
       |<---------------|                |
       |                | RELease COM    |
       |                |--------------->|

Thanks,

Cliff Harris

---

From: Alan Johnston <[email-masked]>
Date: Thu, 30 Mar 2000 15:46:31 -0600

Cliff,

An older version of the document had the explanation for this - I should add it
back in.

The reason for this flow is that you do not want the teardown of resources on
one network dependent on the teardown of resources on the other network.  Once
the BYE is received by the Gateway, the call is over so all resources should be
freed up as soon as possible.  If the teardown failed for some reason on the
ISDN side (due to a network problem, for example) you would not want the IP
resources including the RTP port left hanging.

Resources in Section 5 are freed up in the same way, with the RLC not dependent
on the receipt of a 200 OK in 5.1.1 on page 119, for example.

Alan Johnston
MCI WorldCom