Subject: Stateful/Stateless proxies

From: "yinshaohua" <[email-masked]>
Date: Fri, 3 Mar 2000 11:11:10 +0800

Hi:
    Now that " A single physical proxy may act as stateless in some
situations and as stateful in others" , what role do we comply with when
making a proxy stateful or stateless after receiving a INVITE request?
    If having a role , there can process a request clearly for Proxy.
    Am I correct ?
    Regards!

Shaohua Yin

2000/3/3
-----Original Message-----
???: Igor Slepchin <[email-masked]>
???: Shail Bhatnagar <[email-masked]>
??: [email-masked] <[email-masked]>
??: 2000?3?2? 13:31
??: Re: Stateful/Stateless proxies

>As was noted several times on this list, stateful or stateless are
>logical entities, not physical proxy servers. A single physical proxy
>may act as stateless in some situations and as stateful in others.
>
>To answer your question, the proxy has several options in the case you
>describe: it can act stateful, it can choose the location with the
>highest q value, a random location, etc. Note that a proxy cannot fork,
>do sequential search on contacts or return a redirect response if it
>wants to remain stateless.
>
>---
>Igor Slepchin
>
>
>Shail Bhatnagar wrote:
>>
>> As per the FAQ on Henning's page - a stateless proxy cannot fork. However
it
>> will still try to find out the next hop based on some location service .
So,
>> what should the stateless proxy do if the location service returns more
than
>> one contact point  -
>>     * Send request  to only one
>>     * Send to all
>>
>> Thanks,
>> Shail
>

---

From: Jonathan Rosenberg <[email-masked]>
Date: Fri, 03 Mar 2000 02:08:21 -0500

> making a proxy stateful or stateless after receiving a INVITE request?

Whichever you want, depening on what it is you wish to accomplish. Its
based on administrator policy, the service being invoked, or whatever.
The only rules are:

1. if you send TCP, you have to be stateful
2. if you send multicast, you have to be stateful
3. if you fork, you have to be stateful

-Jonathan R.
-- 
Jonathan D. Rosenberg                       200 Executive Drive
Chief Scientist                             Suite 120 
dynamicsoft                                 West Orange, NJ 07052
[email-masked]                     FAX:   (732) 741-4778
http://www.cs.columbia.edu/~jdrosen         PHONE: (732) 741-7244
http://www.dynamicsoft.com