Subject: Re: Information request! (Billing Package?)

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 01 Mar 2000 00:23:56 -0500

"Rosen, Brian" wrote:
> 
> Interesting, I assumed everything EXCEPT a gateway throws CDRs.
> Assuming a decomposed gateway, the GW feeds statistics to a Call Agent
> (which would be a SIP UA among other things) that throws CDRs.
> 
> The billing system collates all the CDRs.
> 
> The spec required is, of course, the format of the CDR and the way they
> are transported.  You could claim that a "transaction log" is a form of
> CDR I suppose.

My impression has been that the formats of these logs and data generated
by gateways, servers, and so on, are generally vendor/device specific.
Several companies make a living by allowing collection tools to read
this data, based on templates provided to the systems, and generate
standard CDRs. This has obviated the need for standard formats for these
intermediary data records.

> 
> I'd certainly agree that SIP itself doesn't have any "billing package".
> A UA and a server might, but that is independent of the protocol.  Billing
> might very well impact some things in SIP.

Actually, I think its the other way around. SIP impacts billing.
Remember, one bills for services, not for protocols. "Billing for SIP"
is itself actually meaningless. What you are billing for are gateway
services, transport services, features, etc.. So, SIP impacts billing in
the sense that it enables new services (such as those which combine web,
email, etc. with voice), for which new models of what is billed for need
to be thought out.

-Jonathan R.

-- 
Jonathan D. Rosenberg                       200 Executive Drive
Chief Scientist                             Suite 120 
dynamicsoft                                 West Orange, NJ 07052
[email-masked]                     FAX:   (732) 741-4778
http://www.cs.columbia.edu/~jdrosen         PHONE: (732) 741-7244
http://www.dynamicsoft.com

---

From: Nathan Nelson <[email-masked]>
Date: Wed, 01 Mar 2000 08:51:03 -0600

The point that was being ask is not specific to SIP, but more general to a
decomposed architectures.

The current formats that are used to bill PSTN traffic are based on AMA BAF or
a carrier/vendor defined CDR.  Inet believes there is a need to build a
standard format for a Transaction over IP record that allows for elements and
parameters to be recorded.

Some of the key components of this record could be:

    A Tracking field to tie multiple records from multiple platforms together
    Time Stamps
    Usage Stamps
    Originating Information (PSTN Number, IP address, email address.....)
    Terminating Information (PSTN Number, IP address, email address....)
    Terminating Port/ Media Gateway
    Originating Port/Media Gateway
    Amount of bandwidth used
    Types of Applications used
    Premiums associated with Applications
    Application Information (Application server IP addresses)
    Intermediate network usage

One of the basic issues with a decomposed architecture from an accounting
aspect is that multiple devices are involved in call set, routing, application
usage, signaling, and finally termination.  It would be nice to see IETF
support a group that looks at accountability and billing, or at least provide
a basic model to build such records.

Thx,
Nate Nelson
Inet

"Rosen, Brian" wrote:

> Brian
> > -----Original Message-----
> > From: Dean Willis [mailto:[email-masked]]
> > Sent: Tuesday, February 29, 2000 2:41 PM
> > To: Mart Nurmet; [email-masked]
> > Subject: RE: Information request! (Billing Package?)
> >
> >
> > What would a billing package look like? I've never really
> > understood the
> > concept, and it might be useful to talk about it some more.
> >
> > Here's how some implementors are doing it:
> >
> > 1) Gateways throw CDRs using RADIUS or something similar.
> > This feeds into
> > rating, reporting, and billing systems,
> >
> > 2) SIP servers record transaction logs. These may feed into rating and
> > billing systems, and probably feed into reporting systems.
> >
> > 3) QoS PEP and PDPs log resource usages. These feed upstream as well.
> >
> > 4) Other systems, like profile managers, report usage.
> >
> > 5) Rating, reporting, and billing systems sift thru the vast
> > amounts of
> > information coming at them and make useful things happen.
> >
> > All of these things use other protocols and systems -- they aren't SIP
> > specific. They do rely on SIP functions like authentication
> > -- that is, the
> > goal of achieving billing functions has driven some
> > requirements into the
> > design of SIP. However, other than driving some requirements
> > to SIP, such
> > efforts are generally considered to be outside the scope of
> > the SIP WG.
> >
> > Are you perhaps proposing to add functionality to SIP to
> > simplify or enhance
> > reporting capabilities or to simplify the task of driving
> > downstream billing
> > systems?
> >
> > --
> > Dena
> > > -----Original Message-----
> > > From: [email-masked]
> > > [mailto:[email-masked]]On Behalf Of
> > Mart Nurmet
> > > Sent: Monday, February 28, 2000 2:24 PM
> > > To: [email-masked]
> > > Subject: Information request! (Billing Package?)
> > >
> > >
> > > I am looking for information if there has been any work
> > done to generate a
> > > billing package for SIP.  From my look at the available
> > > information there does
> > > not seem to be any.  Is that the case or am I missing something?
> > >
> > > Thank you,
> > > -Mart
> > >
> > >
> >
> >

---

From: Dean Willis <[email-masked]>
Date: Wed, 01 Mar 2000 12:52:09 -0600

My sponsors would certainly be interested in a complete and standard CDR
format that would be supported by multiple vendors.

Is that a SIP WG item?

As I understand it this sort of accounting work is in the domain of the AAA
(Authentication, Authorization, Accounting) working group. As we're
currently using RADIUS to throw most of our CDRs, and RADIUS is in AAA,
that's where I've been sending CDR issues.

--
Dean

> [mailto:[email-masked]]On Behalf Of Nathan
> Nelson
> Sent: Wednesday, March 01, 2000 8:51 AM
> To: Rosen, Brian
> Cc: [email-masked]
> Subject: Re: Information request! (Billing Package?)
>
>

---

From: Kevin Summers <[email-masked]>
Date: Fri, 03 Mar 2000 09:10:19 -0600

This would appear to be something more in the AAA WG realm, not a SIP WG
item.

Kevin Summers
Global Network Evolution
MCI Worldcom

> [mailto:[email-masked]]On Behalf Of Dean Willis
> Sent: Wednesday, March 01, 2000 12:52 PM
> To: Nathan Nelson; Rosen, Brian