Subject: RE: I-D ACTION:draft-polk-sip-mlpp-mapping-00.txt

From: "Rosen, Brian" <[email-masked]>
Date: Thu, 16 Mar 2000 11:16:30 -0500

Perhaps I'm mistaken, but I believe the PSTN actually does
implement MLPP, but it is only used by the government in
emergency situations.

I do agree that Emergency calls have to be differentiated 
from Premptable calls.  

On your final thread, it should certainly be possible to define
an extension to SIP that is not useful in the PSTN; extensions
that are useful only within an enterprise for example should
be acceptable, or in the home, as well as something like MLPP 
which is useful within a government communications system.

Brian

> -----Original Message-----
> From: Ken Carlberg [mailto:[email-masked]]
> Sent: Thursday, March 16, 2000 11:01 AM
> To: James M. Polk
> Cc: [email-masked]
> Subject: Re: I-D ACTION:draft-polk-sip-mlpp-mapping-00.txt 
> 
> 
> 
> > Like so many others -- I'm letting you know of a new Draft 
> > (draft-polk-sip-mlpp-mapping-00.txt) that addresses 'Multi-Level 
> > Precedence and Preemption' in SIP environments. 
> Specifically it provides 
> > the background of existing Voice Networks that have 
> specific requirements 
> > for differentiating Classes of Voice traffic, not just 
> Voice from all other 
> > types of traffic. This I-D also recommends the ability to 
> mandate the 
> > Header-Field 'Priority:' during session set-up within a 
> domain (analagous 
> > to how the existing MLPP  networks function today), but 
> with the obvious 
> > advantages of IP (vs. TDM). I know that should get some 
> attention by itself.
> 
> Nice piece of work, however I have some concerns.  First, 
> some background 
> info.
> 
> Within the U.S., MLPP (ANSI-T1.619A) is only available on 
> some military 
> systems like Autovon.  It is _illegal_ to use it (i believe 
> by mandate of 
> FCC) in the U.S. PSTN because it involves *preemption* of 
> calls.  I don't 
> believe there is another country that allows its PSTN to 
> preempt existing 
> calls, though I would appreciate being corrected on this.  So 
> I have some
> concern about mandating SIP receivers to recognize MLPP if it can only
> be used within closed-loop/non-public systems.  
> 
> On the other hand, the SS7 system of Sprint, MCI, and AT&T support 
> ANSI-T1.631-1993 -- High Probability of Completion (HPC), in which 
> emergency calls are marked accordingly and are queued to improve the
> *probability* that their call will be completed.  I.e., no preemption
> is generated by the emergency call.  
> 
> Part of the reason I bring this up is that if one is going to 
> specify a 
> more definitive description of priority for SIP, as well as 
> the action to 
> be taken, then I would prefer a document that included both 
> preemptive and 
> non-preemptive values.  I agree there is a need/marketplace 
> for SIP-MLPP, 
> but I'd prefer to see a more encompasing document.
> 
> I'm curious as to the position on this subject of the SIP 
> chairs.  Does
> the group advance a document that is not (and cannot be) supported by 
> the PSTN?
> 
> cheers,
> 
> -ken
> 
> 
> 
>

---

From: Ken Carlberg <[email-masked]>
Date: Thu, 16 Mar 2000 11:23:05 -0500

> implement MLPP, but it is only used by the government in

Unless the FCC changed things recently, MLPP in the US PSTN is a definite 
no-no.

> which is useful within a government communications system.

Agreed with respect to something that may or may not be "useful".  But the
kicker that I'm curious about is whether the proposed specification is 
illegal (not allowed) when applied to the general public.

cheers,

-ken

---

From: Bob Bell <[email-masked]>
Date: Thu, 16 Mar 2000 09:36:29 -0700

Ken -

One thing to consider is that in a non-PSTN network, such as the SIP 
network, the FCC rulings for the PSTN have no "legal" force. When the FCC 
made its ruling on MLPP in the PSTN, they were trying to prevent the 
commandeering of relatively scarce resources by a few "fat cats". In the IP 
world, it is possible to still retain communications with a lower QoS even 
though the higher QoS connection has been preempted. Anyway, that is just a 
thought.

Bob Bell

>illegal (not allowed) when applied to the general public.

Bob Bell
Cisco Systems Inc.
801-294-3034(v)
801-294-3023(f)

---

From: Jonathan Rosenberg <[email-masked]>
Date: Sun, 19 Mar 2000 11:08:27 -0500

> illegal (not allowed) when applied to the general public.

Here at IETF, we make protocols that run on the Internet, not the PSTN.
As there are no regulations regarding this kind of thing on the
Internet, it is not an issue for us. 

-Jonathan R.

-- 
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (732) 741-4778
http://www.cs.columbia.edu/~jdrosen         PHONE: (732) 741-7244
http://www.dynamicsoft.com