Subject: typo or error in the call flow examples draft.

From: Sunitha Kumar <[email-masked]>
Date: Tue, 28 Mar 2000 19:13:36 -0800

Hi:

I noticed  the user=phone is outside <> in
draft-ietf-sip-call-flows-00.txt
Just thought I could bring it to the author's notice.

4.1.1 p.77

   F1 INVITE A -> Proxy 1

   INVITE sip:[email-masked];user=phone  SIP/2.0
   Via: SIP/2.0/UDP here.com:5060
   From: BigGuy <sip:[email-masked]>;user=phone
   To: LittleGuy <sip:[email-masked]>;user=phone
   :
   :
   F2 (100 Trying) Proxy 1 -> User A

   SIP/2.0 100 Trying
   Via: SIP/2.0/UDP here.com:5060
   From: BigGuy <sip:[email-masked]>;user=phone
   To: LittleGuy <sip:[email-masked]>;user=phone
   :
   :
   F3 INVITE Proxy 1 -> NGW 1

   INVITE sip:[email-masked];user=phone SIP/2.0
   Via: SIP/2.0/UDP ss1.wcom.com:5060
   Via: SIP/2.0/UDP here.com:5060
   Record-Route: <sip:[email-masked]>
   From: BigGuy <sip:[email-masked]>;user=phone
   To: LittleGuy <sip:[email-masked]>;user=phone
   :
   :
   F4 (100 Trying) NGW 1 -> Proxy 1

   SIP/2.0 100 Trying
   Via: SIP/2.0/UDP ss1.wcom.com:5060
   From: BigGuy <sip:[email-masked]>;user=phone
   To: LittleGuy <sip:[email-masked]>;user=phone
   :
   :
   F7 183 Session Progress NGW 1 -> Proxy 1

   SIP/2.0 183 Session Progress
   Via: SIP/2.0/UDP ss1.wcom.com:5060
   Via: SIP/2.0/UDP here.com:5060
   From: BigGuy <sip:[email-masked]>;user=phone
   To: LittleGuy <sip:[email-masked]>;user=phone
   :
   :
   F8 183 Session Progress Proxy 1 -> User A

   SIP/2.0 183 Session Progress
   Via: SIP/2.0/UDP here.com:5060
   From: BigGuy <sip:[email-masked]>;user=phone
   To: LittleGuy <sip:[email-masked]>;user=phone

And there are several more.
The same thing happens in 4.1.2, 4.1.3, etc.

Thanks
sunitha

---

From: Alan Johnston <[email-masked]>
Date: Thu, 30 Mar 2000 08:19:29 -0600

Sunitha,

You are correct - this is a typo.  The user=phone parameter is part of the URL
and belongs inside the <>.

Thanks for pointing it out - it will be corrected.

Alan Johnston
MCI WorldCom