Subject: RE: SIP & RTSP interworking?

From: Linden deCarmo <[email-masked]>
Date: Wed, 15 Mar 2000 14:57:25 -0500

Dean,

This is an interesting suggestion, but the scenario I'm operating under is
this:

UAC<->UAC (in this case the UAC really is an RTSP server), both must
understand SIP and RTSP.  I need a way to tie the sessions between two
distinct protocols.  Is a viable alternative to embed the RTSP SETUP message
as a SIP body for the INVITE?  This would clearly associate the sessions,
but I hate to have a proprietary solution that wouldn't work with other
products that understood SIP & RTSP.

Linden deCarmo
Netspeak Corporation
902 Clint Moore Road
Suite 104
Boca Raton, FL 33487

> -----Original Message-----
> From:	Dean Willis [SMTP:[email-masked]]
> Sent:	Wednesday, March 15, 2000 2:10 PM
> To:	Linden deCarmo; [email-masked]
> Subject:	RE: SIP & RTSP interworking?
> 
> 
> Here's what I would suggest:
> 
> Build a SIP UAS that understands the RTSP end and contains stream
> management
> logic. This UAS either reinvites to establish the link to RTSP streams, or
> copies the RTP from each stream back into the media path for the remote
> UA.
> 
> I know of some people(s) who are already using each approach to build a
> voice mail system that can use a standard RTSP server as a media store.
> Makes unified messaging with URL passing MUCH easier.
> 
> --
> dean
> 
> > -----Original Message-----
> > From: [email-masked]
> > [mailto:[email-masked]]On Behalf Of Linden
> > deCarmo
> > Sent: Tuesday, March 14, 2000 7:27 AM
> > To: [email-masked]'
> > Subject: SIP & RTSP interworking?
> >
> >
> > What would be the proper (or suggested) procedure to tie a SIP
> > session to an
> > RTSP session?
> >
> > What I'd like to do is setup a session with SIP (via an INVITE), then
> > control streaming aspects via RTSP (i.e. play, pause, stop etc.).
> >  However,
> > its not clear to me how I tie the RTSP session id to the previously
> > established SIP session.
> >
> > Thanks.
> >
> > Linden deCarmo
> > Netspeak Corporation
> > 902 Clint Moore Road
> > Suite 104
> > Boca Raton, FL 33487
> >
> >

---

From: Kundan Singh <[email-masked]>
Date: Wed, 15 Mar 2000 15:09:50 -0500 (EST)

--
Kundan Singh     http://www.cs.columbia.edu/~kns10

> products that understood SIP & RTSP.

In that case, the UA may return the RTSP Contact: URI in (say) 3xx
response.

 UA1          UA2
     INVITE
 -------------->

   3xx Moved
   Contact:rtsp://server/resource
 <-------------

   SETUP rtsp://server/resource
 -------------->
 . . .

Since UA here understand both SIP and RTSP it should not be
a problem.

If the SIP call is already established, and UA2 wants to
switch to RTSP,  then (IMO) it may use blind call transfer
(BYE,Also:rtsp://...) to ask UA1 to connect to RTSP
server of UA2. Comments ??