Subject: Simultaneous transactions

From: "Joshua Moloney" <[email-masked]>
Date: Wed, 1 Mar 2000 11:40:54 -0000

Hi all,

Is it legal to start a second transaction before the first is complete?

Example:

A INVITEs B to a session
B responds with a 100 TRYING
A sends an INFO to B (i.e. before the 200 & ACK messages have been sent
regarding the original INVITE)

I'd like to think that this scenario is not allowed. It would confuse the
CSeq mechanism.

Thanks,

Josh Moloney
Nortel Networks

---

From: [email-masked]
Date: Wed, 1 Mar 2000 17:44:58 +0530

I think it depends on what the next transaction is. For invite, it must
not.

 RFC2453bis states :
" A UAC MUST NOT issue another INVITE request for the same call leg before
the previous transaction
has completed. A UAS that receives an INVITE before it sent the final
response to an INVITE with a lower
CSeq number MUST return a 400 (Bad Request) response and MUST include a
Retry-After header field
with a randomly chosen value of between 0 and 10 seconds. A UA that
receives an INVITE while it has an
INVITE transaction pending, returns a 500 (Internal Server Error) and also
includes a Retry-After header
field."

Thats that for INVITE only.

However, it makes sense  in cases like CANCEL when you send a CANCEL for an
 INVITE
that has not recvd a final response yet.

As far as INFO is concerned, well Im not sure how useful it would be, but I
 guess someone might find a need to send some message
encapsulated in an INFO to the recipient, since it is just an INFOrmational
 message.

Regds
Arjun

--
Arjun Roychowdhury @ Hughes Software Systems

"Joshua Moloney" <[email-masked]> on 03/01/2000 05:10:54 PM

To:   "[email-masked]'"
      <[email-masked]>
cc:

Subject:  Simultaneous transactions

Hi all,

Example:

A INVITEs B to a session

Thanks,

Josh Moloney
Nortel Networks

---

From: [email-masked]
Date: Wed, 1 Mar 2000 17:44:58 +0530

RFC2453bis states :

Regds
Arjun

Hi all,

Example:

A INVITEs B to a session

Thanks,

Josh Moloney
Nortel Networks