Subject: SIP INFO method

From: Sunitha Kumar <[email-masked]>
Date: Mon, 06 Mar 2000 18:27:39 -0800

Hi:

Is some one aware of the current status of this draft?

Also, a question on the current draft:
It is said that the INFO msg follows the protocol rules of the BYe msg.
so, does this imply that  a InFo msg should be sent from the caller
after the 200 OK is received, and from the callee after the ACKis
received?

Thanks much!

--
Sunitha Kumar
Software Engineer
Vovida Networks
(408) 957 - 6374

---

From: Jonathan Rosenberg <[email-masked]>
Date: Mon, 06 Mar 2000 21:24:51 -0500

> Is some one aware of the current status of this draft?

This draft is under consideration by IESG for proposed standard.

> It is said that the INFO msg follows the protocol rules of the BYe
> msg. so, does this imply that  a InFo msg should be sent from the
> caller after the 200 OK is received, and from the callee after the
> ACKis received?

Huh? Of course not. By follow the rules, it means retransmission rules,
tag handling, route processing, etc.
This is stated quite explicitly in the document:

>  2.4 Behavior of SIP User Agents
> 
>       Unless stated otherwise, the protocol rules for the INFO request
>       governing the usage of tags, Route and Record-Route,
>       retransmission and reliability, CSeq incrementing and message
>       formatting follow those in [1] as defined for the BYE request.

-Jonathan R.

-- 
Jonathan D. Rosenberg                       200 Executive Drive
Chief Scientist                             Suite 120 
dynamicsoft                                 West Orange, NJ 07052
[email-masked]                     FAX:   (732) 741-4778
http://www.cs.columbia.edu/~jdrosen         PHONE: (732) 741-7244
http://www.dynamicsoft.com

---

From: "Bor Prihavec" <[email-masked]>
Date: Tue, 7 Mar 2000 11:43:14 +0100

Hi everyone,

I am l looking for SIP based products (Telephony gateways, SIP Servers, SIP User Agents, ...). available on market now or in a short time which would allow me to build a VoIP based Call Center.
So far I am aware of DynamicSoft, Vovida networks, Mediatrix and Object Software. 

I also need an ANSI C implementation of SIP stack / SIP User Agent to use it on our DSP platform.

Any hint is most welcome.
Thanks in advance!

Bor Prihavec

-----------------------
Ultra d.o.o.
Brnciceva 31
1000 Ljubljana
Slovenia, Europe
tel: + 386 61 161 5800
fax: + 386 61 161 5805
[email-masked]