Subject: uploading services from the user's home network to a sip server of the visited network within a 3G.IP environement

From: "Liess, Laura" <[email-masked]>
Date: Wed, 15 Mar 2000 10:12:18 +0100

Hi,

after doing a very good job by deciding to take SIP for call control for multimedia services within 3G.IP networks, the 3G.IP operators have a lot of open items concerning the architecture, one of them being which network controls the services for a roaming user: the home network, the visited network or shared control. The concrete question: how can I upload at the begin or during the call the roamimg user's services available in the home network into the SIP proxy of the visited network? As far as I know, the CPL and REGISTER helps me to upload services only from the UA to the proxy.    

Is anyone else working on similar issues? I know of the Telcordia mobility efforts, but the 3G.IP requirements and architecture seem to be somehow different. The 3G.IP operators would like to reuse their just implemented GPRS and the GPRS mobility.

Thanks a lot
Laura

---

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 15 Mar 2000 11:18:11 -0500

"Liess, Laura" wrote:
> 
> Hi,
> 
> after doing a very good job by deciding to take SIP for call control for multimedia services within 3G.IP >networks, the 3G.IP operators have a lot of open items concerning the architecture, one of them being which >network controls the services for a roaming user: the home network, the visited network or shared control. >The concrete question: how can I upload at the begin or during the call the roamimg user's services >available in the home network into the SIP proxy of the visited network? As far as I know, the CPL and >REGISTER helps me to upload services only from the UA to the proxy.

I'm not an expert in wireless, so I'm not certain of the scope of the
services we are talking about. Mid call services, for example, are not
currently within the scope of CPL. However, there is nothing which
prevents the CPL-upload-in-register mechanism from being used by a
server to upload scripts to another server. Registrations, in general,
can be used for third party controls. The From field identifies the
party initiating the registration. 

-Jonathan R.

-- 
Jonathan D. Rosenberg                       200 Executive Drive
Chief Scientist                             Suite 120 
dynamicsoft                                 West Orange, NJ 07052
[email-masked]                     FAX:   (732) 741-4778
http://www.cs.columbia.edu/~jdrosen         PHONE: (732) 741-7244
http://www.dynamicsoft.com