Subject: RE: Cross-domain QoS setup

From: "Mark Gibson" <[email-masked]>
Date: Thu, 2 Mar 2000 16:41:21 -0000

Please excuse my ignorance but I cannot find a reference to the PRACK Method
listed below in any SIP drafts. Although I have an understanding of its
functionality from the example below, I'd like to be sure what it does. Can
someone point me towards the relevant document.

Cheers

Mark

	-----Original Message-----
	From:	Adam B. Roach [SMTP:[email-masked]]
	Sent:	Tuesday, February 22, 2000 4:11 PM
	To:	[email-masked]; [email-masked];
[email-masked]
	Cc:	[email-masked]
	Subject:	Cross-domain QoS setup

	<snip>

	3) The PRACK confirming the 18x will echo back the finally
	   agreed-on preconditions. This will serve as a "go ahead"
	   message to the called party to begin its actual resource
	   reservation.
	<snip>
	--------------------
	UAS->UAC

	SIP/2.0 183 Preconditions
	To: Adam Roach <[email-masked]>
	From: John Q. Public <[email-masked]>
	CSeq: 1 INVITE
	Session: QoS
	Content-Type: application/sdp

	v=0
	m=audio 48327 RTP/AVP 0
	a=qos:mandatory sendrecv
	m=video 10275 RTP/AVP 31
	a=qos:optional sendrecv
	--------------------
	UAC->UAS

	PRACK sip:[email-masked] SIP/2.0
	To: Adam Roach <[email-masked]>
	From: John Q. Public <[email-masked]>
	CSeq: 2 PRACK
	Session: QoS
	Content-Type: application/sdp

	v=0
	m=audio 48327 RTP/AVP 0
	a=qos:mandatory sendrecv
	m=video 10275 RTP/AVP 31
	a=qos:optional sendrecv
	--------------------

---

From: Michelle Kitchings <[email-masked]>
Date: Thu, 02 Mar 2000 11:25:46 -0600

Mark,

See

http://www.ietf.org/internet-drafts/draft-ietf-sip-100rel-00.txt

The link is on Hennings's page (http://www.cs.columbia.edu/~hgs/sip), under
Drafts -> Extensions -> Reliability of Provisional Responses.

-- 
Michelle Kitchings | Ph:  +1 972 583 7101 | 1010 E. Arapaho, MS L-04
Ericsson, Inc.     | Fax: +1 972 669 0154 | Richardson, TX 75081 USA

> Mark Gibson wrote:
...