Subject: Why must a stateless proxy insert a Via header for itself.

From: "Anoop Tripathi" <[email-masked]>
Date: Fri, 17 Mar 2000 11:31:39 -0600

Currently, the RFC states that every server in the path of a request must add
itself as a Via header.

As a stateless proxy, if this restriction is removed then I can process more
calls with faster call setup times.

So , can we make inserting itself as a Via optional for a stateless proxy.

Thanks,

Anoop

---

From: Shail Bhatnagar <[email-masked]>
Date: Fri, 17 Mar 2000 12:48:17 -0500

> So , can we make inserting itself as a Via optional for a stateless proxy.

Then how do you do loop detection ??

-- 
Best regards,
Shail

---

From: David Daiker <[email-masked]>
Date: Fri, 17 Mar 2000 14:21:08 -0500 (EST)

Anoop,

Just call your proxy a firewall, and then you don't have to.
Though, be advised that the next downstream UAS will add a 'received'
parameter to the topmost 'via' so you will see all subsequent responses
to this request.

regards,
david