Subject: [SIP] I-D ACTION:draft-ietf-sip-call-flows-03.txt

From: [email-masked]
Date: Mon, 05 Mar 2001 06:46:09 -0500

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Session Initiation Protocol Working Group of the IETF.

	Title		: SIP Telephony Call Flow Examples
	Author(s)	: A. Johnston, S. Donovan, R. Sparks, 
                          C. Cunningham, D. Willis, J. Rosenberg,
                          K. Summers, H. Schulzrinne
	Filename	: draft-ietf-sip-call-flows-03.txt
	Pages		: 219
	Date		: 02-Mar-01
	
This informational document gives examples of SIP (Session Initiation
Protocol) call flows for IP telephony.  Elements in these call flows
include SIP User Agents and Clients, SIP Proxy and Redirect Servers,
and Gateways to the PSTN (Public Switch Telephone Network).

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-sip-call-flows-03.txt

Internet-Drafts are also available by anonymous FTP. Login with the username
"anonymous" and a password of your e-mail address. After logging in,
type "cd internet-drafts" and then
	"get draft-ietf-sip-call-flows-03.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html 
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
	[email-masked].
In the body type:
	"FILE /internet-drafts/draft-ietf-sip-call-flows-03.txt".
	
NOTE:	The mail server at ietf.org can return the document in
	MIME-encoded form by using the "mpack" utility.  To use this
	feature, insert the command "ENCODING mime" before the "FILE"
	command.  To decode the response(s), you will need "munpack" or
	a MIME-compliant mail reader.  Different MIME-compliant mail readers
	exhibit different behavior, especially when dealing with
	"multipart" MIME messages (i.e. documents which have been split
	up into multiple messages), so check your local documentation on
	how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: Alan Johnston <[email-masked]>
Date: Mon, 05 Mar 2001 10:22:28 -0600

All,

Here are the changes between this and the last version of the document:

 - The word "Telephony" has been removed from the document title (despite what this
announcement says!)

 - Selected messages have been successfully validated against a SIP parser for accuracy.
Thanks to Kundan Singh for doing this.

 - Added word "informational" to Abstract, and added additional wording about this document
being informational and not normative.

 - Added re-INVITE call flow (T.38 Fax) in 3.1.7. Thanks to Jean-Francois Mule for this
flow.

 - Removed SDP from all 183 Session Progress messages since it is not needed based on
recent working group consensus.  Corrected figures to show early media path as one way.

 - Removed PRACK from example 4.1.2 since there is no longer any need for the 183 to be
transported reliably since it no longer contains SDP.

 - Corrected Call-ID in 3.1.1.

 - Corrected domain in WWW-Authenticate and Proxy-Authenticate headers to be a SIP URL.

I did include the SIP Test Messages in the document as they seem to be stable.  I can still
remove them and put into a separate draft as was discussed in San Diego.

 - Section 7.4 SIP Date corrected to Sat, 01 Dec 2040 16:00:00 GMT

 - Section 7.7 Retransmission strategy for unknown method message should be based on BYE
not INVITE

 - Section 7.10 multiple message element of this test removed as this behavior is no longer
allowed, higher SIP version number part moved into 7.41

 - Section 7.18 recommended response changed

 - Added Test Messages 7.21 through 7.41

One annoying nit - the top of each page still shows a November 2000 date instead of March
2001.

As always, thanks to everyone who has sent contributions or changes to the document.

Thanks,
Alan Johnston
WorldCom
sip:[email-masked]

[email-masked] wrote:

>   ------------------------------------------------------------------------
>
>    draft-ietf-sip-call-flows-03.txtName: draft-ietf-sip-call-flows-03.txt
>                                    Type: Plain Text (text/plain)

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementor's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to 
[email-masked] with "subscribe" in the body.