Subject: RE: [SIP] Using sip or tel scheme in URIs with SIP-T

From: "Yu, James" <[email-masked]>
Date: Thu, 22 Mar 2001 10:01:38 -0600

Jon brought up a good point.  Is there a reason why tel URL is not allowed
in the Contact header?  The tel URL can be converted to a sip URL if sip URL
is the only allowed URL.  But the question is why the tel URL is not allowed
in the Contact header?

If the Request-URI allows many types of URLs, it seems logical that the
Contact header should allow those URLs.

James

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Wednesday, March 21, 2001 9:21 PM
> To: [email-masked]; [email-masked]
> Subject: RE: [SIP] Using sip or tel scheme in URIs with SIP-T
> 
> 
> RFC2543bis (section 2.2) lists some headers (notably 
> Contacts) in which only
> the SIP URI can be used. The protocol permits other schemes 
> (like the tel
> URL) to be used elsewhere. So presumably it is legal for a UA 
> to use schemes
> in the URIs within responses other than those schemes which have been
> received in a request (with the Contact caveat, etc). I 
> cannot speak to the
> existence of UAs which do not 'support' the tel URL (frankly, 
> I'm not sure
> what failures a UA might experience as a result of receiving 
> an unfamiliar
> URI scheme), but I think generally you can assume that the 
> sorts of entities
> to which you would be likely to send a tel URL in a SIP 
> message probably
> support the tel scheme. Also note that it is unlikely that 
> any entity that
> understands SIP URIs will have substantial trouble parsing tel URLs
> considering that (to plagarize a recent mail on this subject)
> 
> "... the user portion of a sip URI can be a
> telephone-subscriber. The BNF for telephone-subscriber is 
> defined by the tel
> URL, and is anything that can be after the tel: in the tel URL."
> 
> And yes, the ';user=phone' for the tel URL example in the 
> "Mapping" draft is
> a typo. That was meant to be a SIP URI example in which the 
> presence of the
> 'user=phone' would differentiate the user portion of the URI from a
> non-telephony username (like old Compuserve email addresses 
> or something).
> 
> Jon Peterson
> Level(3) Communications
> 
> -----Original Message-----
> From: Doug Hurtig [mailto:[email-masked]]
> Sent: Wednesday, March 21, 2001 6:15 PM
> To: [email-masked]
> Subject: [SIP] Using sip or tel scheme in URIs with SIP-T
> 
> 
> Hi,
> 
>  The  "SIP  Call Flows Examples" document uses the "sip" 
> scheme for URIs.
>   The "Mapping of ISUP Parameters to SIP headers in SIP-T" draft
>   shows that either the sip or tel scheme is valid.
> 
>   This is no problem to handling on the incoming side. 
> However, can I assume
> that
>    if I send either tel or sip in the URI that the receiving end will
> understand
> this?
> 
>   What if  I receive a message which uses one scheme to 
> identify the URI, is
> it
> allowed
>    that my response contain URIs with the other scheme?
> 
>    It seems that if the "tel" scheme is used it is implied 
> that the value is
>    a telephone number and there is no need to ever include 
> the "user=phone"
> parameter.  Have
>    I missed something here?
> 
> --
> Regards,
> Doug Hurtig
> 
> Tekelec
> 2425 N. Central Expressway
> Richardson, Texas 75080
> 
> [email-masked]
> 972.301.1203
> 
> 
> 
> _______________________________________________
> This list is for continuing development of the SIP protocol.
> The sip-implementor's list is the place to discuss implementation,
> and to receive advice on understanding existing sip.
> To subscribe to it, send mail to 
> [email-masked] with "subscribe" in the body.
> 
> _______________________________________________
> This list is for continuing development of the SIP protocol.
> The sip-implementor's list is the place to discuss implementation,
> and to receive advice on understanding existing sip.
> To subscribe to it, send mail to 
> [email-masked] with "subscribe" in the body.
> 

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementor's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to 
[email-masked] with "subscribe" in the body.

---

From: "Bob Penfield" <[email-masked]>
Date: Thu, 22 Mar 2001 12:47:37 -0500

see inline comments below

----- Original Message -----
From: "Yu, James" <[email-masked]>
To: <[email-masked]>
Cc: <[email-masked]>
Sent: Thursday, March 22, 2001 11:01 AM
Subject: RE: [SIP] Using sip or tel scheme in URIs with SIP-T

> is the only allowed URL.  But the question is why the tel URL is not
allowed
Because the Contact header is used to send subsequent SIP messages it must
be the SIP URL of the User Agent (or possibly some other SIP server). A tel
URL represents an endpoint that may or may not be on the IP network.

> >    a telephone number and there is no need to ever include

Bob
d:-)

Robert F. Penfield
Chief Software Architect
Acme Packet, Inc.
130 New Boston Street
Woburn, MA 01801
[email-masked]

---

From: "Sean Olson" <[email-masked]>
Date: Thu, 22 Mar 2001 11:15:26 -0600

This is an interesting question. Since Contact:
effectively forms part of a Route: list. Since
it was decided that only sip: URIs are allowed
in a Record-Route:, do we use the same logic for
Contact:? I don't believe so. The rule of thumb
would seem to be that you should only use non-sip
URLs in Contact: in REGISTER requests and 3xx 
responses.

/sean

---

From: "Robert Chen" <[email-masked]>
Date: Thu, 22 Mar 2001 16:41:35 -0800

What should the proxy server do if we never get the BYE message?

If neither UA will end the call with a BYE message, how can the proxy server
know?

Only SIP gateway contact with Radius server is meanful? A proxy server
contact with Radius server is meanless?

Thanks.