Subject: RE: [SIP] REFER feature with 'replaces' header

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 14 Mar 2001 07:48:22 -0500

> -----Original Message-----
> From: Venkatesh Venkataramanan
> [mailto:[email-masked]]
> Sent: Monday, March 12, 2001 1:45 PM
> To: Suheel Hussain; Billy Biggs
> Cc: SIP List
> Subject: RE: [SIP] REFER feature with 'replaces' header
> 
> 
> This question is probably not totally relevant to this chain, but
> nevertheless, I wanted some clarification...
> 
> As I remember it correct, one of the issues with REFER was 
> that the transfer
> will not always be successful.... I remember a thread about 
> this 4/5 months
> back and think it had to do with Contact/Request URL not 
> always identifying
> the end point exactly (like in cases of ACD agents behind firewalls or
> something to that effect. My guess is that the modified REFER 
> *still* does
> not address this issue. Is my understanding correct??

That is correct. THe problem is that SIP end to end routing may not be
deterministic for a given URL. So, if you use the From or To field of the
original call leg, it won't necessarily get you to the right party. If you
use Contact, this also may not work. The contact header might be using an
address behind a firewall or nat, which requires traversal of a proxy that
had record-routed. 

The recommended solution was, I think, to use caller preferences in
combination with the To/From field.

Regarding the original thread, usage of Replaces is still under debate, so I
would warn people against shipping implementations of it at this time. REFER
has nearly 30 minutes of discussion time at IETF 50, and this is one issue
we need to tackle.

-Jonathan R.
---
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementor's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to 
[email-masked] with "subscribe" in the body.

---

From: Dvir Oren <[email-masked]>
Date: Thu, 15 Mar 2001 14:00:58 +0200 (IST)

> has nearly 30 minutes of discussion time at IETF 50, and this is one issue

Is there an alternative solution to Replaces?

-- 
Dvir Oren               <[email-masked]>
Lucid Voice Ltd.   <http://www.lucidvoice.com>
5 Jabotinski St., Ramat-Gan, 52520      Israel
Tel: 972 3 5757488          Fax: 972 3 5757499