Subject: RE: [SIP] Issue with domain names in Via header

From: Igor Slepchin <[email-masked]>
Date: Sat, 17 Mar 2001 15:48:12 -0500

> -----Original Message-----
> From: Gonzalo Camarillo [mailto:[email-masked]]
> 
> The response problem is already solved. 

Do you mean Jonathan's proposal under discussion? Sure; however, that
proposal requires that a cluster of n proxies have n DNS SRV records; it
also requires stateless proxies to perform a DNS query when forwarding
responses even if the upstream hop is alive. Requiring that the received
parameter be always added and trying the IP from received first when
forwarding responses would eliminate both of these problems.

---
Igor Slepchin

<...>
> Gonzalo
> 
> Igor Slepchin wrote:
> > 
> > I think this could be solved fairly easily for response 
> failover case if we
> > require that proxy servers always add the received tag with 
> the source IP.
> > They would then always send the response to that IP first 
> and perform a DNS
> > lookup only if sending to the address in received failed.
> > 
> > This may also be generally useful since stateless proxies 
> would not be
> > required to perform a DNS lookup before sending responses...
> > 
> > ---
> > Igor Slepchin
> > 
> > > -----Original Message-----
> > > From: Neil Deason [mailto:[email-masked]]
> > > Sent: Friday, March 16, 2001 4:09 AM
> > > To: Gonzalo Camarillo
> > > Cc: Henning Schulzrinne; Arnoud van Wijk (ELN); Jonathan 
> Rosenberg;
> > > [email-masked]'
> > > Subject: Re: [SIP] Issue with domain names in Via header
> > >
> > >
> > > This doesn't fix the open issue with SRV randomisation
> > > messing up attempts by stateless proxies to pick the
> > > same server.
> > >
> > > http://lists.bell-labs.com/pipermail/sip/2000q4/003180.html
> > >
> > > Cheers,
> > > Neil.
> > > --
> > > Ubiquity Software Corporation, UK        http://www.ubiquity.net
> > >

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementor's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to 
[email-masked] with "subscribe" in the body.

---

From: Gonzalo Camarillo <[email-masked]>
Date: Sat, 17 Mar 2001 22:47:07 +0200

Igor,

> forwarding responses would eliminate both of these problems.

That's the idea, trying the IP address that appears in the message
first, and then, if it fails, the SRV will provide alternative
solutions.

However, stateless proxies will not catch ICMP messages, so I do not see
the problem with them. They will just not try several addresses. The
improvement only works for stateful proxies.

Gonzalo

-- 
Gonzalo Camarillo                    Phone :   +1 212 939 71 71
Columbia University                  Mobile:  +358 40 702 35 35
472 Computer Science Building        Fax   :  +358  9 299 30 52
1214 Amsterdam Ave., Mail Code 0401  http://www.hut.fi/~gonzalo
New York, NY 10027                   
USA                              [email-masked]