Subject: RE: [SIP] Response if user not registered?

From: "Roy, Radhika R, ALCOO" <[email-masked]>
Date: Fri, 30 Mar 2001 15:01:25 -0500

Folks:

Let us not forget the reality in offering the VoIP services. As Brian has
explained, there has to be charging. That is, there need to be an
association between the caller (person) and the device/location/address.

(No one is disputing the fact that calls can always be made is the IP
addresses are known and routers can route the calls to the destination IP
addresses, and IP addresses can be assigned dynamically.)

Best regards,

Radhika R. Roy
AT&T

-----Original Message-----
From: Brian F. G. Bidulock [mailto:[email-masked]]
Sent: Friday, March 30, 2001 2:40 PM
To: Michael Thomas
Cc: Drage, Keith (Keith); [email-masked]; 'Juha Heinanen';
[email-masked]
Subject: Re: [SIP] Response if user not registered?

Michael,

I don't have an IP address tatooed on my forhead and
my left hand.

Also, some like to charge for calls based on where you
are calling from.  They often like to charge you, not
your terminal.

--Brian

Michael Thomas wrote:                     (Fri, 30 Mar 2001 10:46:32)
> Brian F. G. Bidulock writes:
>  > Michael,
>  > 
>  > Sorry Mike, registration is for personal mobility as
>  > well, not just terminal mobility.
> 
>    And this contradicts what I said... how?
>    It certainly doesn't make a case for linkage
>    of incoming and outgoing calls to some HLR-like
>    entity. Location is only important on the
>    incoming call side. The outgoing side is
>    completely separate. Likewise, data
>    connectivity is completely separate from
>    call/SIP presence. This is the fundamental
>    conflation that Q.931-like schemes get 
>    completely wrong in the IP world.
> 
> 	      Mike

-- 
Brian F. G. Bidulock    ¦ The reasonable man adapts himself to the ¦
[email-masked]    ¦ world; the unreasonable one persists in  ¦
http://www.openss7.org/ ¦ trying  to adapt the  world  to himself. ¦
                        ¦ Therefore  all  progress  depends on the ¦
                        ¦ unreasonable man. -- George Bernard Shaw ¦

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementor's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to 
[email-masked] with "subscribe" in the body.

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementor's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to 
[email-masked] with "subscribe" in the body.

---

From: Michael Thomas <[email-masked]>
Date: Fri, 30 Mar 2001 13:09:56 -0800 (PST)

Being able to charge for services does not equate
to needing to faithfully recreate the current
PSTN. There are fundamental differences between
IP's openness and the walled gardens of the PSTN.
Not taking them into account will either produce
an undeployable service (fraud) or an undeployable
service (subject to mass defection to the first
service provider who breaks ranks with the
cartel).

ISP's in the IP world have exactly one thing they
control: the quality of the bits they put into
their network. All other things they have to
compete for. The sooner we all admit that and move
on, the sooner sustainable business models can be
devised.

For SIP, that means you have no control over who I
use for the outbound proxy. There's no reason to
modify SIP to enforce something that is
unenforcible.

		Mike

---

From: Henry Sinnreich <[email-masked]>
Date: Fri, 30 Mar 2001 15:23:55 -0600

>PSTN.

This strikes a cord. Some sources say that the cost of the usage based phone
bill is almost 50% of the cost of the phone call itself.

Henry

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of Michael Thomas
Sent: Friday, March 30, 2001 3:10 PM
To: Roy, Radhika R, ALCOO
Cc: [email-masked]; Michael Thomas; Drage, Keith (Keith);
[email-masked]; 'Juha Heinanen'; [email-masked]
Subject: RE: [SIP] Response if user not registered?

		Mike

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 30 Mar 2001 16:20:46 -0600

Michael,

Michael Thomas wrote:                 (Fri, 30 Mar 2001 13:09:56)

<skip_motherhood_statements>
> on, the sooner sustainable business models can be
</skip_motherhood_statements>

> modify SIP to enforce something that is

Who said they wanted SIP to control which outbound
proxy you used?  I was just expecting that you register
with the one you want to use before you use it...

---

From: Juha Heinanen <[email-masked]>
Date: Sat, 31 Mar 2001 13:37:21 +0300 (EEST)

> with the one you want to use before you use it...

registrat and outbound proxy are two different entities in the sip
wordls.  1.4.7 states:

  The REGISTER request allows a client to let a proxy or redirect server
  know at which address(es) it can be reached.

if 3gpp wants the register mean something else, they better start their
own working group within 3gpp and stop wasting bandwidth on this list.

-- juha

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Sat, 31 Mar 2001 06:31:17 -0600

Juha,

Juha Heinanen wrote:                        (Sat, 31 Mar 2001 13:37:21)
>   know at which address(es) it can be reached.
<skip_abuse>
> own working group within 3gpp and stop wasting bandwidth on this list.
</skip_abuse>

Why stop an implementation (acting as a combined registrar and
outbound proxy) from requiring registration before permitting
outbound INVITEs?  All that was asked for was an error code for
gosh sakes.

I don't know what you're being so protective about: SIP is so
close to ISUP that (if it weren't for the text coding) one might
as well run it over SS7.

-- 
Brian F. G. Bidulock

---

From: Juha Heinanen <[email-masked]>
Date: Sat, 31 Mar 2001 16:12:13 +0300 (EEST)

Brian F. G. Bidulock writes:

 > outbound INVITEs?

because the semantics of register have nothing to do with outbound
invites.

-- juha

---

From: Michael Thomas <[email-masked]>
Date: Sat, 31 Mar 2001 14:56:02 -0800 (PST)

It seems apparent that you think that you can
enforce some security property by requiring
registration. I do not see what requiring
registration enforces for *either* case, incoming
or outgoing. If I already have network access,
then there's nothing to prevent me from bypassing
the local SIP registrar/proxy in all but a few
pathetically contrived cases which have zero long
term likelihood of survival.

I get the sense that there is an unstated
assumption going on here and that is that SIP is
being used to enable network access and/or QoS.
Is that the case?

		Mike