Subject: [SIP] Comments about draft-ietf-sip-call-flows-03.txt

From: Alexandre Charest <[email-masked]>
Date: Mon, 12 Mar 2001 09:20:48 -0500

The first suggestion I have would be to determine the password used and
compute real responses for authentication through out the document.
The other comments are mainly edition bugs in the various packets. Here is
what I found:
call-flow 3.1.2 and 3.1.3 
F3: CSeq method should be ACK instead of INVITE 
F4: Authorization header should be a Proxy-Authorization header 

call-flow 3.1.3 
F10: CSeq method should be ACK instead of INVITE 
F11:Authorization header should be a Proxy-Authorization header 
F15: the description line should tell that the INVITE is sent by Proxy 2
instead of Proxy 1 and the Record-Route headers are reversed 
F16, F17 and F18: the Record-Route headers are reversed 
F19: Contact contains the UAS address: it should contain BigGuy
<sip:[email-masked]> or should not be present 

call-flow 3.1.4 
F11: CSeq method should contain ACK instead of INVITE 
F12: Authorization header should be a Proxy-Authorization header 

call-flow 3.1.5 
F1: there should not be a space before host part of the request-uri 

call-flow 3.1.6 
F3: CSeq method should be ACK instead of INVITE 
F10: Content-Length is 152 instead of 145 
F12: Request-Uri and Route header are inverted: the ACK should be sent to
request-uri: sip:[email-masked] and contain Route:
<sip:[email-masked]> 

call-flow 4.1.1 
F1: Content-Length is 140, not 147 
F10: Content-Length is 164, not 150 

call-flow 4.1.2 
F1: Content-Length is 140, not 147 
F16: there should not be a new-line in the Route sip-url 

call-flow 4.1.3 
F1: Content-Length is 140, not 147 
F5: CSeq method should be ACK instead of INVITE 
F12: Content-Length is 164, not 150 

call-flow 4.2.1 
F1: Content-Length is 140, not 147 

Alexandre Charest, B. Sc.
Software Designer
Mediatrix Telecom Inc. (www.mediatrix.com)
tél:(819) 829-8749 #275
fax: (819) 829-5100

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementor's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to 
[email-masked] with "subscribe" in the body.

---

From: Alan Johnston <[email-masked]>
Date: Wed, 14 Mar 2001 09:21:31 -0600

Alexandre,

Thanks for your comments - I will make the corrections.  On the ACK of F19 in
3.1.3 the Contact header should not be present and will be removed.

Thanks,
Alan Johnston
WorldCom
sip:[email-masked]