Subject: RE: [SIP] 2543bis clarification of 487

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 21 Mar 2001 02:09:23 -0500

> -----Original Message-----
> From: Daniel G. Petrie [mailto:[email-masked]]
> Sent: Wednesday, March 21, 2001 1:35 AM
> To: [email-masked]
> Subject: [SIP] 2543bis clarification of 487
> 
> 
> I think this is a request for explicit clarification
> of the CANCEL/487 handling.  Were this an
> RFC this would probably be more appropriate
> for the the implementors list.  I have been
> having a disagreement with what the proper
> behavior of 487.  Here's the scenario:
> 
> Caller sends INVITE
> Callee sends 180
> Caller sends CANCEL
> Callee sends 200 for the CANCEL
> Callee sends 487 for the INVITE
> 
> Here is what I believe to be the proper
> behavior and the part of contention:
> 
> The Callee should resend the 200 for the CANCEL
> only if it receives a resend of the CANCEL request.

Yes.

> 
> The callee should resend the 487 until it receives an ACK
> from the caller or timeout etc.

Yes.

> 
> The caller should send an ACK for every 487
> response that it gets. 

Yes.

> The caller should send the
> ACK when it receives the 200 Ok for the CANCEL
> for upward compatability issues as the callee may not
> support the 487.

No.

I don't get it. If the callee supports 487, it will send it, retransmit it
as per rfc2543, and the regular sip reliability will work. If the callee
doesn't support 487, there is nothing to ACK, since no response is going to
be sent.

-Jonathan R.
---
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementor's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to 
[email-masked] with "subscribe" in the body.

---

From: Vijay Gurbani <[email-masked]>
Date: Wed, 21 Mar 2001 11:24:05 -0600

Daniel:

See http://lists.bell-labs.com/pipermail/sip/2000q4/003485.html for more
information about resolving this issue (including maintaining backwards
compatibility).  You may want to follow the thread for more information as
well, but the link above should give you a good idea of its resolution.

-- 
Vijay K. Gurbani  vkg@{lucent.com,research.bell-labs.com,acm.org}
Internet Software and eServices Group 
Lucent Technologies/Bell Labs Innovations 263 Shuman Blvd., Rm 1A-413
Naperville, Illinois 60566     Voice: +1 630 224 0216   Fax: +1 630 713 0184