Subject: RE: [SIP] SIP Registration interval

From: Gordon Ledgard <[email-masked]>
Date: Thu, 15 Mar 2001 10:40:15 -0500

I would agree with Jonathan, but extend the statement a bit.

I would expect that registrars should be free to disallow any
sort of registration based on any sort of algorithm or heuristic
they wished, including unrealistic subscription times. I
don't really think the registration mechanism itself (IE the
SIP transactions rules) ought to be dictating rejection
algorithms within registrars, except to say how to perform
the rejection.

Different registrars will have funamentally differing
capabilities.

Gordon Ledgard
IPeria, Inc.
[email-masked]
(781) 993-3540

-----Original Message-----
From: Jonathan Rosenberg [mailto:[email-masked]]
Sent: Thursday, March 15, 2001 10:27 AM
To: 'Henning Schulzrinne'; [email-masked]
Cc: [email-masked]'
Subject: RE: [SIP] SIP Registration interval

> -----Original Message-----
> From: Henning Schulzrinne [mailto:[email-masked]]
> Sent: Thursday, March 15, 2001 8:31 AM
> To: [email-masked]
> Cc: [email-masked]'
> Subject: Re: [SIP] SIP Registration interval
> 
> 
> 
> 
> Stephen Terrill wrote:
> > 
> > Hi Henning,
> > 
> > Can you clarify the proposal - is it that the client takes 
> the registration time from the refresh rate in a 2xx 
> registration response?  In this case, does this allow the 
> registrar to increase the registration time if the original 
> time requested by the client was considered to low.
> 
> Simple rule:
> 
> - Client takes registration interval from registrar.
> 
> - Unless something really strange is going on, the registrar uses
> whatever registration interval the client wants.

The only issue is how the server can differentiate between small
registration lifetimes which are useful for some services (and should be
allowed), and small registration lifetimes that will be used continuously
(which the server may want to disallow). I would suggest that the two cases
can be differentiated, if needed, by heuristics at the registrar. When a
contact is registered with a lifetime below X, its accepted, and the server
increments a counter for this registration. Everytime that contact is
refreshed in less than X seconds, the counter is bumped. If it exceeds N,
the server can return some larger expiration time in the next refresh. 

This works assuming that short lived registrations for these services are
"one-shots", which seems to be the case so far.

-Jonathan R.

---
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementor's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to 
[email-masked] with "subscribe" in the body.

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementor's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to 
[email-masked] with "subscribe" in the body.

---

From: "Bob Penfield" <[email-masked]>
Date: Thu, 15 Mar 2001 13:57:39 -0500

Jonathan's proposal would retain the registrar's ability to increase the
expiration time. Would it be better to not allow the registrar to lengthen
the expiration time, but have the registrar reject the request when it
figured out that the client was doing periodic refreshing too frequently and
suggest a more acceptable refresh rate?

Bob Penfield
Chief Software Architect
Acme Packet, Inc.
130 New Boston Street
Woburn, MA 01801
[email-masked]

----- Original Message -----
From: "Gordon Ledgard" <[email-masked]>
To: "'Jonathan Rosenberg'" <[email-masked]>; "'Henning
Schulzrinne'" <[email-masked]>;
<[email-masked]>
Cc: <[email-masked]>
Sent: Thursday, March 15, 2001 10:40 AM
Subject: RE: [SIP] SIP Registration interval