Subject: RE: [SIP] SIP Registration interval

From: Baniel Uri-CUB001 <[email-masked]>
Date: Thu, 8 Mar 2001 05:33:11 -0600

>Limiting the max. no. of contacts is a good idea as well. 
>"400 Too Many Contacts" feels about right. 

Sounds like 412 may just do it.. Henning? (Jonathan?Eve?Mark?)

[Uri Baniel] 
 -----Original Message-----
From: Sean Olson (EUS) [mailto:[email-masked]]
Sent: Wednesday, March 07, 2001 4:54 PM
To: 'Baniel Uri-CUB001'; 'Henning G. Schulzrinne'
Cc: [email-masked]'
Subject: RE: [SIP] SIP Registration interval

> BTW, speaking about limits, I have not seen a limitation for number of 
> contacts in the spec.(for the registration request only! I am not sure 
> regarding redirection ) 
> If the main reason for limiting the time interval (ceiling 
> limitation) is 
> for making sure the registrar table is not growing too big, 
> then wouldn't it 
> make sense to define max number of contacts allowed? 

The main reason for limiting the time interval is to limit the 
rate of incoming REGISTER requests, not to limit the registrar 
table size. 

Limiting the max. no. of contacts is a good idea as well. 
"400 Too Many Contacts" feels about right. 

> Also if the registrar provides the contact information to a 
> proxy server, do 
> we want the proxy server to search for ever? 

The proxy has the same discretionary control that the registrar 
has.  The difference between this case and the need to 
specify a lower bound on the expiration time is that the proxy 
has direct control. Granted, specifying a minimum expiration time 
requires a cooperative UA, but that applies to almost all of SIP. 

/sean

---

From: Henning Schulzrinne <[email-masked]>
Date: Thu, 08 Mar 2001 09:23:49 -0500

> Baniel Uri-CUB001 wrote:
> Sounds like 412 may just do it.. 

No, 412 is definitely the wrong one; this has nothing to do with
preconditions. (SIP doesn't define 412, but any status codes that are
used in HTTP are not redefined with another meaning.)

Generally speaking, this is a server problem, so it should take the 500
blame. The client has done nothing wrong. Except in extreme cases
(hundreds of Contact headers), I would guess that any
industrial-strength server won't have to worry about limiting this,
unless this is used by lots of clients in a concerted denial-of-service
attack. Certainly, anything like eight is far too restrictive.

The more error conditions and restrictions you impose, the more tech
support headaches you incur. My guess is that in most cases, a few
microcents of disk space is the far better trade-off. (Even with a 1000
bytes of Contact, we're talking a storage cost of 0.0005 cents here. You
have to have a lot of long Contact headers before you've made up for one
tech support call.)

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementor's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to 
[email-masked] with "subscribe" in the body.