Subject: RE: [SIP] Informing UA after network initated deregistration?

From: William Marshall <[email-masked]>
Date: Fri, 9 Mar 2001 12:39:28 -0500 (EST)

Henning, Mike, Bob, all,

I think rather than debating the various situations in which
a network operator may delete a registration (and prevent further
service to that subscriber), the more appropriate question for
this group is how to inform the UA that it has happened.

The main issue is still:  If the UA is displaying some status indication 
that the registration/service is active, how to keep the display correct?

Summary so far:

Choice #1:  don't.  UA will find out with next registration request.
Choice #2:  through a non-SIP mechanism, e.g. SMS or email notification,
		(if not real-time, then combines with #1)
Choice #3:  Subscribe/Notify (is it appropriate for this? no comments yet)
Choice #4:  anything else???

Bill Marshall
[email-masked]

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementor's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to 
[email-masked] with "subscribe" in the body.

---

From: Michael Thomas <[email-masked]>
Date: Fri, 9 Mar 2001 11:55:08 -0800 (PST)

If what you're after is essentially the equivalent
of message waiting indicator, SUBSCRIBE/NOTIFY at
a _service level_ seems like the right thing. That
completely divorces this from the registrar,
though if the service wanted to coordinate with
the registrar to clear any registrations, that
would be their own business.

	       Mike