Subject: RE: [SIP] Fwd: SIP transfer call flows

From: "Mo Zonoun" <[email-masked]>
Date: Sat, 31 Mar 2001 07:02:26 -0500

Can some tell me, how to make sure that a new INVITE in Call Transfer gets
to the correct UA-C when there are multiple candidates, including the case
when UA-C is a gateway to another network.
Thanks,
Mo Zonoun

---

From: "Brett Tate" <[email-masked]>
Date: Sat, 31 Mar 2001 14:42:17 -0500

> Can some tell me, how to make sure that a new 
> INVITE in Call Transfer gets to the correct 
> UA-C when there are multiple candidates, 
> including the case when UA-C is a gateway 
> to another network.

I think that there have been two potential 
solutions suggested thus far.
1) Refer-To with a preloaded Route.  I assume that 
the first hop would need to be globally reachable 
for the best potential of success.
2) Refer with all required headers to allow a 
known call-leg to be hijacked.  I think that 
this one is known to have problems unless the 
potential to update a Contact (and maybe 
Record-Route) for a new Route exists.  I think 
that the other problem was the current 
restriction that SDP "m=" lines have to 
continue to align.

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementor's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to 
[email-masked] with "subscribe" in the body.

---

From: Alan Johnston <[email-masked]>
Date: Sat, 31 Mar 2001 14:14:16 -0600

The attended transfer flow 2.5 from the SIP Service Examples draft shows
the use of Caller Preferences where the REFER contains:

   Refer-To:
<sip:[email-masked]?Accept-Contact=sip:[email-masked];only=true>

which results in the INVITE having

   Accept-Contact=sip:[email-masked];only=true

This can help solve this problem.  The other solution is the Replaces
header (which will be included in the next draft of the SIP Service
Examples) which allows the transferer to specify the Call-ID, To, and From
tags.  If the target is a gateway, presumably, the combination of the
phone number in the URL and the Call-ID should allow the gateway to
uniquely identify the call.

Thanks,
Alan Johnston
WorldCom
sip:[email-masked]