Subject: [SIP] Tokens in VIA header

From: Ragunath Devarasu <[email-masked]>
Date: Thu, 8 Mar 2001 17:46:35 -0800

All,

If a Proxy adds a token (Name=SecretValue) in VIA header when it forwards
the request, 
then, will it see the Token in its response VIA headers.

I had checked the Sip Spec, it Says "UAS or Redirect Server copies the Via
Header fields
into its response".

Can I safely assume that all UAS/Redirect Servers will copy the tokens
(Name=SecretValue) 
into its Reponses in VIA header.

Sorry, if it is a novice question.

Regards,
Ragunath.

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementor's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to 
[email-masked] with "subscribe" in the body.

---

From: "Brett Tate" <[email-masked]>
Date: Thu, 8 Mar 2001 21:12:52 -0500

via-extension was not in rfc2543. 

Thus there are no guarantees unless 
dealing with bis compliant products.

> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Ragunath Devarasu
> Sent: Thursday, March 08, 2001 8:47 PM
> To: [email-masked]
> Subject: [SIP] Tokens in VIA header
> 
> 
> All,
>