Subject: [SIP] Stateful proxy and ACK

From: Nils Henrik Lorentzen <[email-masked]>
Date: Fri, 23 Mar 2001 11:37:34 +0100

Hi,

For what response codes should a statefull proxy originate ACKs ?
AFAI understand a forking proxy originates ACKs for
all non-1xx/2xx responses.
Is this the correct behaviour for a non-forking statefull proxy also ?
I cannot find a clear answer in the sip-draft,
but the above at seems to be correct,
as I guess the ACK from the UAC only needs to be forwarded all the
way in case of a 200, sice it then may contain an SDP.

TIA !

Nils Henrik

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementor's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to 
[email-masked] with "subscribe" in the body.

---

From: "Mayank Sharma" <[email-masked]>
Date: Fri, 23 Mar 2001 17:05:54 +0530

> Is this the correct behaviour for a non-forking statefull proxy also ?

yes

Regards,
Mayank