Subject: RE: [SIP] Reliability of non-INVITE requests

From: Jonathan Rosenberg <[email-masked]>
Date: Sat, 17 Mar 2001 00:17:31 -0500

Gonzalo,

I don't see the inconsistency. With UDP, you retransmit the request. WIth
TCP, you don't Section 10.2.1 and 10.2.2 in bis-02 seem clear on that.

-Jonathan R.

---
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (973) 952-5000
http://www.dynamicsoft.com

> -----Original Message-----
> From: Gonzalo Camarillo [mailto:[email-masked]]
> Sent: Friday, March 16, 2001 3:43 PM
> To: sip
> Subject: [SIP] Reliability of non-INVITE requests
> 
> 
> Hello,
> 
> Section 10.2 of rfc2543bis deals with reliability for non-INVITE
> requests.
> It explains that a SIP client using UDP should continue 
> retransmitting a
> request even after having received a provisional response.
> 
> However, if the SIP client uses TCP does not have to retransmit the
> request at all.
> 
> I believe there is an inconsistency between both behaviors (TCP and
> UDP).
> 
> Could somebody clarify this?
> 
> Thanks,
> 
> Gonzalo
> -- 
> Gonzalo Camarillo                    Phone :   +1 212 939 71 71
> Columbia University                  Mobile:  +358 40 702 35 35
> 472 Computer Science Building        Fax   :  +358  9 299 30 52
> 1214 Amsterdam Ave., Mail Code 0401  http://www.hut.fi/~gonzalo
> New York, NY 10027                   
> USA                              [email-masked]
> 
> 
> _______________________________________________
> This list is for continuing development of the SIP protocol.
> The sip-implementor's list is the place to discuss implementation,
> and to receive advice on understanding existing sip.
> To subscribe to it, send mail to 
> [email-masked] with "subscribe" in the body.
> 

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementor's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to 
[email-masked] with "subscribe" in the body.

---

From: Gonzalo Camarillo <[email-masked]>
Date: Sat, 17 Mar 2001 22:13:24 +0200

Jonathan,

I am a SIP UA. If I use TCP, I send the request and TCP ensures that the
next hop (the proxy) receives the request.

If I use UDP, I retransmit the request until I get a provisional
response. When I get the provisional response, I am sure that the proxy
got my request.

Now, the situation is the same for both transport protocols: I am sure
that the proxy has got my request.

Why do I have to continue retransmissions in UDP?

Gonzalo