Subject: RE: [SIP] Informing UA after network initated deregistration?

From: "Sriram Parameswar" <[email-masked]>
Date: Fri, 16 Mar 2001 16:09:08 -0600

Hi All,

One scenario which was not discussed for network initiated de-registration.
In the cellular world - fraud/lost or stolen mobiles present a problem. 

In the case that your subscriber loses his mobile and reports it, the
operator may choose to de-register the mobile thus disallowing Mobile
Originated and Mobile Terminated calls. I see this as a perfectly legitimate
use of Network initiated de-registration. 

Just to add a little bit more to the discussion - there are contributions in
3GPP that talk of 'NOTIFY'ing the subscriber when such de-registrations
happen.

Regards,

Sriram

__________________________________________
Sriram Parameswar              Phone: 972-685-8540
Wireless IP MultiMedia (WIPMM)   Fax: 972-685-3563
Nortel Networks, Richardson USA  Email: [email-masked]

-----Original Message-----
From: Baniel Uri-CUB001 [mailto:[email-masked]]
Sent: Saturday, March 10, 2001 7:42 AM
To: 'Igor Slepchin'; 'William Marshall'; [email-masked]
Subject: RE: [SIP] Informing UA after network initated deregistration?

Igor

Network initiated deregistration may happen for various reasons. Ironically
I do not see 'registrar crashing' as one of them... (Hot backup etc is just
as you say far beyond SIP and shall not concern us in this regard). It could
be for instance: temporarily suspension of services for a specific
subscriber, because his/her pre paid billing ticket is empty...

I think it is expected by a subscriber to be notified when the system can
not serve him/her. 
He/she may be a bit cranky if he/she was expecting a very important call,
and only after 20 minutes has realized the phone was out of service.. (These
are exactly the things that distinguish between real systems and
kids/hackers toys)
(again just like the cellular analogy). If your system crashed in such a way
that your hot backup did not work, of course you can not do anything about
it.
If I sink in the see, I would probably not have enough time to instruct my
secretary how to pay my last phone bill..

It is true though, that we may want to leave it as an implementation offer
to a SIP operator. Still we need to offer him the way to do it, so as to
keep it standardized.

Uri

-----Original Message-----
From: Igor Slepchin [mailto:[email-masked]]
Sent: Friday, March 09, 2001 5:15 PM
To: 'William Marshall'; [email-masked]
Subject: RE: [SIP] Informing UA after network initated deregistration?

> -----Original Message-----
> From: William Marshall [mailto:[email-masked]]
>
> I think rather than debating the various situations in which
> a network operator may delete a registration (and prevent further
> service to that subscriber), the more appropriate question for
> this group is how to inform the UA that it has happened.

I haven't yet seen a good argument about why it's necessary. If the problem
is taking the registrar down for maintenance, it's well beyond SIP realm -
there are lots of highly available database solution on the market that
allow this.

The example with GUI notification is rather far-fetched in my opinion. The
reachability of a SIP phone is by no means limited by its registrar. What
happens if the access proxy dies? or the router, the ether switch, Internet
backbone goes down etc?

Thank you,
Igor Slepchin

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementor's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to 
[email-masked] with "subscribe" in the body.

---

From: Henning Schulzrinne <[email-masked]>
Date: Fri, 16 Mar 2001 23:12:17 -0800

I mentioned this case before. In all likelihood, you'll just be
notifying the criminal holding the stolen handset that he's been
discovered. Whether that's useful or not I can't say. 

> Sriram Parameswar wrote:
> 
> Hi All,
> 
> One scenario which was not discussed for network initiated
> de-registration. In the cellular world - fraud/lost or stolen mobiles
> present a problem.
> 
> Originated and Mobile Terminated calls. I see this as a perfectly
> legitimate use of Network initiated de-registration.
> 
> Just to add a little bit more to the discussion - there are
> contributions in 3GPP that talk of 'NOTIFY'ing the subscriber when
> such de-registrations happen.
> 
> Regards,
> 
> Sriram
> 
> Network initiated deregistration may happen for various reasons.
> Ironically I do not see 'registrar crashing' as one of them... (Hot
> backup etc is just as you say far beyond SIP and shall not concern us
> in this regard). It could be for instance: temporarily suspension of
> services for a specific subscriber, because his/her pre paid billing
> ticket is empty...
> 
> I think it is expected by a subscriber to be notified when the system
> can not serve him/her.
> He/she may be a bit cranky if he/she was expecting a very important
> call, and only after 20 minutes has realized the phone was out of
> service.. (These are exactly the things that distinguish between real
> systems and kids/hackers toys)
> 
> (again just like the cellular analogy). If your system crashed in such
> a way that your hot backup did not work, of course you can not do
> anything about it.
> 
> If I sink in the see, I would probably not have enough time to
> instruct my secretary how to pay my last phone bill..
> 
> It is true though, that we may want to leave it as an implementation
> offer to a SIP operator. Still we need to offer him the way to do it,
> so as to keep it standardized.
> 
> Uri
>

---

From: "Dean Willis" <[email-masked]>
Date: Tue, 20 Mar 2001 09:38:43 -0600

RE: [SIP] Informing UA after network initated deregistration?
here's the problem -- cancelling the registration neither prevents the phone from sending or receiving calls. It merely prevents any proxy associated with the cancelling registrar from correctly proxying calls to the deregistered identity. So, the thief just tells his buddies to call him by IP address and not by phone number -- so the registration is never even accessed. Or the "thief" loads a DNS A record for the phone into another domain (maybe an A record for "myphone" into domain "phonethief.com"), again bypassing registration.

--
Dean
  ----- Original Message ----- 
  From: Sriram Parameswar 
  To: 'Baniel Uri-CUB001' ; 'Igor Slepchin' ; 'William Marshall' ; [email-masked] 
  Sent: Friday, March 16, 2001 4:09 PM
  Subject: RE: [SIP] Informing UA after network initated deregistration?

  Hi All, 

  One scenario which was not discussed for network initiated de-registration. In the cellular world - fraud/lost or stolen mobiles present a problem. 

  In the case that your subscriber loses his mobile and reports it, the operator may choose to de-register the mobile thus disallowing Mobile Originated and Mobile Terminated calls. I see this as a perfectly legitimate use of Network initiated de-registration. 

  Just to add a little bit more to the discussion - there are contributions in 3GPP that talk of 'NOTIFY'ing the subscriber when such de-registrations happen.

  Regards, 

  Sriram 

  -----Original Message----- 
  From: Baniel Uri-CUB001 [mailto:[email-masked]] 
  Sent: Saturday, March 10, 2001 7:42 AM 
  To: 'Igor Slepchin'; 'William Marshall'; [email-masked] 
  Subject: RE: [SIP] Informing UA after network initated deregistration? 

  Igor 

  Network initiated deregistration may happen for various reasons. Ironically I do not see 'registrar crashing' as one of them... (Hot backup etc is just as you say far beyond SIP and shall not concern us in this regard). It could be for instance: temporarily suspension of services for a specific subscriber, because his/her pre paid billing ticket is empty...

  I think it is expected by a subscriber to be notified when the system can not serve him/her. 
  He/she may be a bit cranky if he/she was expecting a very important call, and only after 20 minutes has realized the phone was out of service.. (These are exactly the things that distinguish between real systems and kids/hackers toys)

  (again just like the cellular analogy). If your system crashed in such a way that your hot backup did not work, of course you can not do anything about it.

  If I sink in the see, I would probably not have enough time to instruct my secretary how to pay my last phone bill.. 

  It is true though, that we may want to leave it as an implementation offer to a SIP operator. Still we need to offer him the way to do it, so as to keep it standardized.

  Uri 

  -----Original Message----- 
  From: Igor Slepchin [mailto:[email-masked]] 
  Sent: Friday, March 09, 2001 5:15 PM 
  To: 'William Marshall'; [email-masked] 
  Subject: RE: [SIP] Informing UA after network initated deregistration? 

  Thank you, 
  Igor Slepchin