Subject: RE: [SIP] Call Transfer Using REFER Method.

From: Jonathan Rosenberg <[email-masked]>
Date: Thu, 1 Mar 2001 02:40:33 -0500

Comments below.

> -----Original Message-----
> From: Ragunath Devarasu [mailto:[email-masked]]
> Sent: Monday, February 26, 2001 5:58 PM
> To: [email-masked]'
> Subject: [SIP] Call Transfer Using REFER Method.
> 
> 
> Hi All,
> 
> 	We are having a hard time trying to figure out how to make the
> Transferee send the Invite to the Transfer Target through the 
> proxy when
> REFER is used to transfer the call. Could you shed some light 
> on how this 
> can be achieved.
> 
> Transferee	    Transferor       Proxy		Transfer Target
> 
> Invite|--------------------------->
>       |<----------------------- 100 Trying
>       |             <---------- Invite
>       |         200 -------------->
>       |<----------------------- 200
> Ack   |--------------------------->
>       |             <---------- Ack
>       |        Invite(c=0)-------->
>       |<----------------------- Invite(c=0)
> 200 Ok|--------------------------->
>       |             <---------- 200 Ok
>       |         Ack -------------->
>       |<----------------------- Ack
>       |            Invite(TT)----->
>       |                         Invite ------------->
>       |                           <--------------- 200
>       |                 <-------- 200
>       |        Ack	-------------->
>       |                           Ack -------------->
>       |        Bye	 -------------> 
>       |                           Bye -------------->
>       |                           <--------------- 200
>       |                 <-------- 200
>       |        Refer  ------------>
>       |<------------------------- Refer
> 200 Ok|--------------------------->
>       |            <------------- 200 OK
> Invite|--------------------------------------------->
>       |<------------------------------------------- 200 Ok
> Ack   |--------------------------------------------->
> Bye   |--------------------------------------------->
>       |<------------------------------------------- 200 Ok
> 
> 	We would like to see the last Invite and Bye go through 
> the proxy
> too
> so that the proxy can control that call. Would a Record-Route 
> in the Refer
> help me achieve this goal ? Or a route header embedded in the 
> referred-to 
> header ? Is the transferor mandated to use the route header 
> thus provided?

First off, I would advise you to think about why you want the proxy to
"control the call". Proxies don't control calls. THey route calls. If you
want a centralized system that controls the calls and can do anything you
want, you aren't talking about a proxy any longer, but rather a B2BUA.

An invite triggered by refer can be forced through a specific proxy by
inclusion of a Route header parameter in the referred to URL. However, the
UA sending the REFER inserts this URL. I suppose the proxy could modify it,
but its not pretty and there may be odd failure scenarios.

-Jonathan R.
---
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementor's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to 
[email-masked] with "subscribe" in the body.

---

From: Ed Ellesson <[email-masked]>
Date: Fri, 2 Mar 2001 17:10:34 -0500

Jonathan, 

My question is related to this recent exchange of notes on the REFER Method:

Should we be changing the terminology in other SIP drafts to refer to SIP
Proxies as B2BUA's, when the required functionality demands that all Invites
must be routed through the SIP Proxy?  

I apologize if I have missed an earlier exchange on the list that clarifies
this.  If so, please feel free to just point me to that exchange.  I'm
coming up to speed on the issues involved in applying QOS and Policy to SIP
managed sessions and the RTP flows that are set up in the context of those
sessions.  I have read through this exchange with interest, because I am
trying to reconcile the position about SIP proxies stated in your note, with
the positions taken in other sip drafts, including the sip working group
draft "SIP Extensions for Media Authorization"

http://www.ietf.org/internet-drafts/draft-ietf-sip-call-auth-01.txt

According to that draft, (see Figure 1), the Invite from the UAC must go to
the Outgoing Proxy in order for Client Authentication and Call Authorization
to occur, and in order for the OP to return an Auth. Token to the UAC which
gives the User Agent the ability to insert Media-Authorization info into an
RSVP Path message.  

If the Invite from the Transferee to the Transfer Target does not have to go
through an Outgoing Proxy, how does the bandwidth allocation authorization
get communicated?   

Does this mean that the OP in this draft is really a "B2BUA"?

I noticed the same problem with the following draft, which is not a working
group draft, but perhaps those authors would like to chime in as well?

http://www.ietf.org/internet-drafts/draft-gross-sipaq-00.txt

Under figure 1, this document states:  

"The SIP proxy acts as a policy enforcement point, PEP, for IP communication
sessions that use SIP."  

How can the SIP proxy act as an enforcement point, if the session setup
messages, such as INVITE do not touch it, in all cases?  
Does this mean that the SIP proxy in this draft should also be called a
"B2BUA?"

Ed Ellesson
LongBoard, Inc.
[email-masked]
919-361-3230

 -----Original Message-----
From: 	Jonathan Rosenberg [mailto:[email-masked]] 
Sent:	Thursday, March 01, 2001 2:41 AM
To:	'Ragunath Devarasu'; [email-masked]'
Subject:	RE: [SIP] Call Transfer Using REFER Method.

Comments below.

-Jonathan R.
---