Subject: [SIP] Forking proxy behavior with multiple 200s

From: Bala Santhanam <[email-masked]>
Date: Thu, 29 Mar 2001 16:54:42 -0800

Hi,

What should a forking proxy do with consecutive 200 OKs coming from two
different addresses? Can the proxy generate an ACK and BYE the rest of the
[200] responses after accepting the first arriving 200 response?

Regards,
Bala

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementor's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to 
[email-masked] with "subscribe" in the body.

---

From: "Brett Tate" <[email-masked]>
Date: Thu, 29 Mar 2001 20:37:19 -0500

> [200] responses after accepting the first arriving 200 response?

No. 

The 2xx part of bis Section 12.4 states that 
INVITE 200's are passed onto the originator.  
Proxies basically can never generate a request 
that would require an increment in CSeq; 
they can only generate ACKs and CANCELs.  
The proxy can send a CANCEL for outstanding 
paths.  The UAC would have the choice 
in deciding how to handle the second 200 for 
INVITE.  

This situation should really only 
happen for race conditions unless the called 
party expects the UAC to conference the two 
locations together.

---

From: "Vijay K. Gurbani" <[email-masked]>
Date: Thu, 29 Mar 2001 23:32:18 -0600

> [200] responses after accepting the first arriving 200 response?

Nope; a proxy MUST send ALL 200 OK (INVITE) upstream.  The idea here
is that the proxy is not the arbiter of multiple responses to a request
(even though it may have forked the request).  The final arbiter is the
UAC, which may ACK and BYE the subsequent responses.
 
- vijay
--
Vijay K. Gurbani  vkg@{lucent.com,research.bell-labs.com,acm.org}
Internet Software/IN Architecture Group 
Lucent Technologies/Bell Labs Innovations 263 Shuman Blvd., Rm 1A-413
Naperville, Illinois 60566     Voice: +1 630 224 0216   Fax: +1 630 713
0184