Subject: RE: [SIP] SIP Registration interval

From: Jonathan Rosenberg <[email-masked]>
Date: Thu, 15 Mar 2001 10:27:15 -0500

> -----Original Message-----
> From: Henning Schulzrinne [mailto:[email-masked]]
> Sent: Thursday, March 15, 2001 8:31 AM
> To: [email-masked]
> Cc: [email-masked]'
> Subject: Re: [SIP] SIP Registration interval
> 
> 
> 
> 
> Stephen Terrill wrote:
> > 
> > Hi Henning,
> > 
> > Can you clarify the proposal - is it that the client takes 
> the registration time from the refresh rate in a 2xx 
> registration response?  In this case, does this allow the 
> registrar to increase the registration time if the original 
> time requested by the client was considered to low.
> 
> Simple rule:
> 
> - Client takes registration interval from registrar.
> 
> - Unless something really strange is going on, the registrar uses
> whatever registration interval the client wants.

The only issue is how the server can differentiate between small
registration lifetimes which are useful for some services (and should be
allowed), and small registration lifetimes that will be used continuously
(which the server may want to disallow). I would suggest that the two cases
can be differentiated, if needed, by heuristics at the registrar. When a
contact is registered with a lifetime below X, its accepted, and the server
increments a counter for this registration. Everytime that contact is
refreshed in less than X seconds, the counter is bumped. If it exceeds N,
the server can return some larger expiration time in the next refresh. 

This works assuming that short lived registrations for these services are
"one-shots", which seems to be the case so far.

-Jonathan R.

---
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementor's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to 
[email-masked] with "subscribe" in the body.

---

From: Stephen Terrill <[email-masked]>
Date: Thu, 15 Mar 2001 18:21:23 +0100

Seems adequate!

..//Steve

---

From: "Brett Tate" <[email-masked]>
Date: Thu, 15 Mar 2001 14:42:25 -0500

> "one-shots", which seems to be the case so far.

The suggested method works for registrations.

Are people opposed to allowing for the same 
rule within the Session Timers draft as a 
means for a stateful proxy or UA to request 
a reduction of session extending re-INVITEs?