Subject: Re: [SIP] I-D ACTION:draft-ietf-sip-call-flows-03.txt

From: Michel de Boer <[email-masked]>
Date: Tue, 06 Mar 2001 14:41:59 +0100

Alan,

I just studied some of the call flows from from the follow I-D:

  http://www.ietf.org/internet-drafts/draft-ietf-sip-call-flows-03.txt

I don't understand the request URI in section 3.1.5 for the successful
SIP to SIP
call through a firewall.

The request URI in INVITE F1 is: sip:UserB@ fwp1.wcom.com
However the INVITE is meant for [email-masked], so I would expect that
that INVITE towards the firewall has sip:[email-masked] as request URI.
How
should the firewall otherwise know that it must send an INVITE to
[email-masked]
as the example shows in message F2?

Is this an error, or do I overlook something.

Regards,
Michel de Boer

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementor's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to 
[email-masked] with "subscribe" in the body.

---

From: Alan Johnston <[email-masked]>
Date: Tue, 06 Mar 2001 07:53:48 -0600

Michel,

You are correct - the Request-URI should be
[email-masked];maddr=fwp1.wcom.com

I will make the change.  Thanks for pointing it out.

Thanks,
Alan Johnston
WorldCom
sip:[email-masked]