Subject: RE: [SIP] Proposal for ogranizing WG efforts

From: "Giuseppe Ricagni" <[email-masked]>
Date: Sun, 11 Mar 2001 09:52:08 -0000

Dean,

any news about SIPPING ? I' ve found no related BOFs in the agenda for
Minneapolis, yet the proposed charter appears to have a number of deadlines
before London.

E.g.: where/when is SIP AAA going to be discussed in Minneapolis ?

Could you please recap on the latest developments ?

Cheers 
Giuseppe

Giuseppe Ricagni
[email-masked]

> -----Original Message-----
> From: Dean Willis [mailto:[email-masked]]
> Sent: Wednesday, February 28, 2001 5:39 PM
> To: IETF SIP (E-mail)
> Subject: [SIP] Proposal for ogranizing WG efforts
> 
> 
> The WG chairs and the ADs were talking this morning about how 
> to make the
> working group more effective.One idea that came up sounds 
> interesting, and
> I'd like to share it with you.
> 
> There are really two sorts of tasks that happen in the WG today:
> 
> 1) Defining the protocol: SIP and extensions to SIP using its 
> extension
> mechanisms.
> 
> 2) Describing the mechanisms and requirements of doing useful 
> things with
> SIP.
> 
> Many of the discussions over the past years have started as
> application-specific extensions that have pointed toward 
> general-purpose
> reusable solutions. For example, Message Waiting Indicator 
> proposals led to
> our understanding of the general usefulness of 
> Subscribe/Notify (Events)
> mechanisms. We sometimes didn't notice the generalizability 
> of a mechanism
> until several iterations into implementation discussions 
> (Refer). We've
> started to learn to differentiate our drafts between protocol 
> specifics and
> usage rationales. Unfortunately, sometimes the "how could we" 
> discussions
> have distracted from the immediate goals of completing the base
> specifications. Even the core protocol draft has drawn criticism for
> intermixing usage and specification, and the authors have 
> proposed a rewrite
> to separate those components.
> 
> So here's the idea: What if we were to split the SIP WG into 
> two pieces?
> Maybe two WGs?
> 
> The first part would handle the actual protocol 
> specifications -- things
> like 2543bis, and would deal with new methods, new headers, 
> new response
> codes, and other things in response to requirements generated 
> by the second
> part. Hard standards-track stuff, tightly controlled charter.
> 
> The second part would deal with using SIP, primarily from a
> rationale-and-requirements perspective. This would include call flows,
> application of SIP mechanisms (like using Events for Message 
> Waiting), and
> with things like RFCs to register new  MIME types and DHCP 
> options and the
> like. I believe Allison suggested calling such a group the 
> "SIPPING" effort.
> Such a group would of course do a lot of discussios and would 
> be likely to
> generate several informational  and BCP track documents as well as
> standards-track documents where appropriate.
> 
> This might let us get a little more clarity in the discussions and
> discipline in the process -- and separate some of the topics 
> on the rather
> busy mailing list.
> 
> So, what do you think?
> 
> --
> Dean Willis
> SIP WG CoChair
> 
> 
> _______________________________________________
> This list is for continuing development of the SIP protocol.
> The sip-implementor's list is the place to discuss implementation,
> and to receive advice on understanding existing sip.
> To subscribe to it, send mail to 
> [email-masked] with "subscribe" in the body.

---

From: "Rosen, Brian" <[email-masked]>
Date: Mon, 12 Mar 2001 11:26:51 -0500

The new charters for SIP and SIPPING will be discussed in the SIP WG
meetings.
No need for a BOF.
 
NOTE WELL
 
      We PROBABLY will have a 3rd session, on Friday morning!!!!
 
Brian

-----Original Message-----
From: Giuseppe Ricagni [mailto:[email-masked]]
Sent: Sunday, March 11, 2001 4:52 AM
To: Dean Willis; IETF SIP (E-mail)
Subject: RE: [SIP] Proposal for ogranizing WG efforts

Dean, 

Cheers 
Giuseppe 

Giuseppe Ricagni 

> From: Dean Willis [ mailto:[email-masked]
<mailto:[email-masked]> ]