Subject: [SIP] Request-URI open issue

From: "Brett Tate" <[email-masked]>
Date: Wed, 21 Mar 2001 20:59:02 -0500

The Open Issues BOF minutes section 
"Request-URI Parameters" mentions that 
nothing gets stripped.  I just wanted to 
explicitly ask if this includes the maddr.

If so, draft-ietf-sip-call-flows-03 
section 3.1.2 needs to be updated so that 
the maddr goes into the Request-URI for 
ACKs and BYEs.

I didn't want to take the BOF minutes text 
too literal, but it led to the following 
questions.

Is adding or removing default parameters
also taboo?

I assume it is still ok to re-order the 
parameters and/or strip out LWS.

Is changing case on case-insensitive fields
also taboo?

-brett

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementor's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to 
[email-masked] with "subscribe" in the body.

---

From: Alan Johnston <[email-masked]>
Date: Wed, 28 Mar 2001 13:23:52 -0600

Brett,

See my question below.

Alan.

> the maddr goes into the Request-URI for

Are you arguing that ACK message F15 should have a Request-URI of
sip:[email-masked];maddr=ss1.wcom.com, and the BYE message F18 should
have a Request-URI of sip:[email-masked];maddr=ss2.wcom.com?

---

From: "Brett Tate" <[email-masked]>
Date: Wed, 28 Mar 2001 15:33:33 -0500

> have a Request-URI of sip:[email-masked];maddr=ss2.wcom.com?

The text from the open issues BOF implies 
that the maddr no longer gets stripped.

I'm not arguing for it; I'm trying to ensure 
that I understand how the open issue about 
stripping off maddr and/or other parameters 
was resolved.  And I want to make sure that
the resolution is reflected in the call flows.

If the maddr is no longer to get removed, 
your above Request-URI text looks correct.
It looks like similar changes would need to 
be made throughout the draft in flows where 
a proxy performs a record-route and the call
is answered.