Subject: RE: [SIP] SIP Registration interval

From: Baniel Uri-CUB001 <[email-masked]>
Date: Thu, 8 Mar 2001 09:41:48 -0600

Yes, it definitely makes sense what you say. perhaps we can just offer it as
a recommendation (as opposed to restriction) for the client to limit number
of contacts to X (when X = ?). And then it is truly a server fault if it can
not handle the contacts, since it was only a recommendation for the client,
and thus the 500 range is indeed the right one..

===========================================
[email-masked], 
Tel: (847) 632 4616; Fax: (847) 632 3963; 
===========================================

> -----Original Message-----
> From: Henning Schulzrinne [mailto:[email-masked]]
> Sent: Thursday, March 08, 2001 8:24 AM
> To: Baniel Uri-CUB001
> Cc: 'Sean Olson (EUS)'; [email-masked]'
> Subject: Re: [SIP] SIP Registration interval
> 
> 
> 
> 
> > Baniel Uri-CUB001 wrote:
> > 
> > >Limiting the max. no. of contacts is a good idea as well.
> > >"400 Too Many Contacts" feels about right.
> > 
> > Sounds like 412 may just do it.. 
> 
> No, 412 is definitely the wrong one; this has nothing to do with
> preconditions. (SIP doesn't define 412, but any status codes that are
> used in HTTP are not redefined with another meaning.)
> 
> Generally speaking, this is a server problem, so it should 
> take the 500
> blame. The client has done nothing wrong. Except in extreme cases
> (hundreds of Contact headers), I would guess that any
> industrial-strength server won't have to worry about limiting this,
> unless this is used by lots of clients in a concerted 
> denial-of-service
> attack. Certainly, anything like eight is far too restrictive.
> 
> The more error conditions and restrictions you impose, the more tech
> support headaches you incur. My guess is that in most cases, a few
> microcents of disk space is the far better trade-off. (Even 
> with a 1000
> bytes of Contact, we're talking a storage cost of 0.0005 
> cents here. You
> have to have a lot of long Contact headers before you've made 
> up for one
> tech support call.)
> 

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementor's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to 
[email-masked] with "subscribe" in the body.

---

From: Henning Schulzrinne <[email-masked]>
Date: Thu, 08 Mar 2001 10:49:40 -0500

> and thus the 500 range is indeed the right one..

Any such recommendations will be taken by server vendors as a license to
restrict things or not to test values above these arbitrary limits. The
spec is long enough as is; the last thing we need is more implementation
details that have no meaning and no reasonable way to decide on these
constants (My definition of "reasonable" is as valid as anybody
else's.). If servers should accept more Contact headers, why recommend
that clients restrict themselves to some arbitrary number that may or
may not be appropriate for a particular application?

In general, IETF specs do not take the role of RFI, purchase
specifications, product manuals or implementation descriptions.

The fewer arbitrary limitations or magic constants specs have, the
better.