Subject: RE: [SIP] Response if user not registered?

From: "Drage, Keith (Keith)" <[email-masked]>
Date: Thu, 29 Mar 2001 13:27:18 +0100

Because in 3GPP at least, the act of registration identifies the proxy that
will support all calls for that user, both incoming and outgoing (i.e.
outbound proxy), and the privileges or service capabilities that user has,
e.g. the act of registration tells the outbound proxy that the user can make
outgoing calls.

Keith

Keith Drage
Lucent Technologies
Tel: +44 1793 776249
Email: [email-masked]

> ----------
> From: 	Juha Heinanen[SMTP:[email-masked]]
> Sent: 	27 March 2001 8:01
> To: 	[email-masked]
> Cc: 	[email-masked]
> Subject: 	[SIP] Response if user not registered?
> 
> [email-masked] writes:
> 
>  > In some environments (3G etc.) user has to be registered before being
> able
>  > to issue outgoing requests.
> 
> why is that so?  why isn't it enough that the caller is able to
> authenticate itself, i.e., prove that it has subscribed to the service?
> registration should only be needed for receiving incoming calls.
> 
> -- juha
> 
> _______________________________________________
> This list is for continuing development of the SIP protocol.
> The sip-implementor's list is the place to discuss implementation,
> and to receive advice on understanding existing sip.
> To subscribe to it, send mail to 
> [email-masked] with "subscribe" in the body.
> 

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementor's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to 
[email-masked] with "subscribe" in the body.

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 29 Mar 2001 12:55:27 -0600

Keith,

That is also true in roaming situations in IS-41 based mobile
systems as well.  Roamers must register before making outbound
calls.

Usually this is to establish what nature of chargeable calls the
subscriber can make consistent with service agreements and
interconnection agreements.

Authentication and authorization as the first two steps of the
outbound call process is a wireline concept.  Registration is
the first step in almost all wireless systems.

--Brian

Drage, Keith (Keith) wrote:                       (Thu, 29 Mar 2001 13:27:18)

-- 
Brian F. G. Bidulock    ¦ The reasonable man adapts himself to the ¦
[email-masked]    ¦ world; the unreasonable one persists in  ¦
http://www.openss7.org/ ¦ trying  to adapt the  world  to himself. ¦
                        ¦ Therefore  all  progress  depends on the ¦
                        ¦ unreasonable man. -- George Bernard Shaw ¦

---

From: Michael Thomas <[email-masked]>
Date: Fri, 30 Mar 2001 06:54:14 -0800 (PST)

I'm sorry, but these are apples and oranges. There
is no split of baseline data connectivity and
calls in current cellular. You can't make an
outgoing call without registering because the
current PSTN is a one trick pony. With IP, this
is not the case. How I gain IP connectivity is
completely orthogonal to who I make an outgoing
call. In fact, it's completely orthogonal to
how I make an incoming call too. 

This seeming desire to make the SIP registrar into
a latter day HLR fundamentally misses the point
about IP networks. There is no such need. In fact,
it's fairly clear to me that there's not even a
need for one of the HLR's most important functions
which is to track the mobile's location. That
information is already laying around in gobs: it's
called IP routing.

Before we cast SIP systems in the likeness of the
PSTN God, we really ought to go back to first
principals. Like, for example, that we're dealing
with a connectionless, routed network where voice
calls are just one of any number of applictions.

       Mike

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 30 Mar 2001 12:34:21 -0600

Michael,

Sorry Mike, registration is for personal mobility as
well, not just terminal mobility.

--Brian

Michael Thomas wrote:                   (Fri, 30 Mar 2001 06:54:14)

---

From: Michael Thomas <[email-masked]>
Date: Fri, 30 Mar 2001 10:46:32 -0800 (PST)

> well, not just terminal mobility.

   And this contradicts what I said... how?
   It certainly doesn't make a case for linkage
   of incoming and outgoing calls to some HLR-like
   entity. Location is only important on the
   incoming call side. The outgoing side is
   completely separate. Likewise, data
   connectivity is completely separate from
   call/SIP presence. This is the fundamental
   conflation that Q.931-like schemes get 
   completely wrong in the IP world.

	      Mike

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 30 Mar 2001 13:40:28 -0600

Michael,

I don't have an IP address tatooed on my forhead and
my left hand.

Also, some like to charge for calls based on where you
are calling from.  They often like to charge you, not
your terminal.

--Brian

Michael Thomas wrote:                     (Fri, 30 Mar 2001 10:46:32)

---

From: Juha Heinanen <[email-masked]>
Date: Sat, 31 Mar 2001 13:29:12 +0300 (EEST)

> are calling from.  They often like to charge you, not

in sip world, it is very easy to charge the person and not the terminal,
since when i make a call, the server will authenticate the invite
message and will do so based on a username and password that have
nothing to do with the terminal.

if 3gpp is going to use sip, they should model their thinking
accordingly and forget the ways things are done in current mobile
networks.  if that is not possible, then they better start calling their
protocol something else.

-- juha

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Sat, 31 Mar 2001 06:32:56 -0600

Juha,

It sounds to me like profitability is something that
you are not used to. ;)

--Brian

Juha Heinanen wrote:                              (Sat, 31 Mar 2001 13:29:12)

-- 
Brian F. G. Bidulock