Subject: [SIP] the port in the record-route

From: "Roland" <[email-masked]>
Date: Sun, 18 Mar 2001 18:54:09 -0800

I got a problem in the Record-Route header when my proxy server proxying a request.    

To make sure the subsequent Request visit the same proxy, my proxy add each request a Record-Route header at 
top of the list.

assume the incoming request's Request-URI is sip:[email-masked]:5080  and my proxy is www.proxy.com:5060 
then what should be the Record-Route header? notice the two ports  is different.

If it is sip:[email-masked]:5060;maddr=www.proxy.com ,  after the request route established, the next request from caller 
looks like:
Request_URI = sip:[email-masked]:5060  and send to www.proxy.com:5060  ,  thus the request-URI 's port is wrong!

If it is sip:[email-masked]:5080;maddr=www.proxy.com ,  after the request route established, 
the next request looks like:
Request_URI = sip:[email-masked]:5080  and send to www.proxy.com:5080  ,  

then the request send to wrong proxy port !!!

there is only one port in the record-route header, so
What 's the exact meaning of the port in the Record-route? represents proxy Server? or UAS?

Thanks,

roland

---

From: "Roland" <[email-masked]>
Date: Mon, 19 Mar 2001 11:43:59 -0800

I got a problem when I append a  Record-Route header for a request in my proxy .    

To make sure the subsequent Request visit the same proxy, my proxy add each request a Record-Route header at 
top of the Record-Route list.

assume a UAC send a request to my proxy, 
its Request-URI is sip:[email-masked]:5080  
and my proxy is www.proxy.com:5060 , ( notice the two port number is different).
then what should be the Record-Route header which is added to request by my proxy? 

If it is <sip:[email-masked]:5060;maddr=www.proxy.com> ,  
after the request route established, the next request from UAC looks like:
Request_URI = sip:[email-masked]:5060  and send to www.proxy.com:5060  ,  
thus the request-URI 's port is wrong!

If it is <sip:[email-masked]:5080;maddr=www.proxy.com> ,  after the request route established, 
the next request looks like:
Request_URI = sip:[email-masked]:5080  and send to www.proxy.com:5080  ,  
then the request send to wrong proxy port !!!

there is only one port in the record-route header, so
What 's the exact meaning of the port in the Record-route? represents the next Server? or the UAS?

Thanks,

Thanks again!!!!!!

roland