Subject: RE: [SIP] Informing UA after network initiated deregistration?

From: Baniel Uri-CUB001 <[email-masked]>
Date: Fri, 30 Mar 2001 12:46:05 -0600

Let's view the network initiated de-registration in 3GPP eyes.
Let's try to think when would the network be interested in de-registering a
subscriber (UE).
For now I can see three different cases:

1)The SIP Registration interval has expired before the UE had a chance to
re-register.
2)SIP sessions are being blocked for a specific UE by an admin (e.g.
subscription change, stolen UE)
3)The admin node needs to force re-registration of either a group of UEs or
a specific UE (could happen for several of reasons.

Now when would it make sense to notify the UE about a de-registration event?

case 1)??? - Most of the chance is that the UE has not re-registered because
he has gone out of the serving area.
That means there is no use to burden the network with sending notification
to someone who is anyway not there.
Still there may be some special cases in which a UE may be interested to
know about such an event. For instance a user who is waiting for a very
important call may get upset to discover too late that his mobile has been
deregistered 20 minutes ago and he even did not know about it.

Thus I say, it would make sense to let a UE have the ability to explicitly
specify his wish in such notifications (that means an additional header in
the REGISTER request). When the deregistration happens, the network would
notify or not notify the UE based on his request in Registration time.

case 2 and 3) here there is a good chance that the UE is still around. Thus
I see no reason why not notifying him about the dereg event. Most of the
chances that he will get the message.

What do you guys think??

Uri

> -----Original Message-----
> From: Bob Penfield [mailto:[email-masked]]
> Sent: Friday, March 30, 2001 7:49 AM
> To: Sriram Parameswar; 'Romeo Zwart'; Baniel Uri-CUB001; 'Stephen
> Terrill'; 'Dean Willis'; 'Igor Slepchin'; 'William Marshall'
> Cc: Chen Bonnie-BCHEN1; Xu Lang-LXU1; sip
> Subject: Re: [SIP] Informing UA after network initiated 
> deregistration?
> 
> 
> 
> 
> ----- Original Message -----
> From: "Romeo Zwart" <[email-masked]>
> To: "Sriram Parameswar" <[email-masked]>; "'Romeo Zwart'"
> <[email-masked]>; "Bob Penfield" 
> <[email-masked]>; "Baniel
> Uri-CUB001" <[email-masked]>; "'Stephen Terrill'"
> <[email-masked]>; "'Dean Willis'" 
> <[email-masked]>;
> "'Igor Slepchin'" <[email-masked]>; "'William Marshall'"
> <[email-masked]>
> Cc: "Chen Bonnie-BCHEN1" <[email-masked]>; "Xu Lang-LXU1"
> <[email-masked]>; "sip" <[email-masked]>
> Sent: Friday, March 30, 2001 4:06 AM
> Subject: RE: [SIP] Informing UA after network initiated 
> deregistration?
> 
> 
> > At 01:51 AM 3/30/2001, Sriram Parameswar wrote:
> >
> > >OK - I'll bite.
> >
> > Great, thanks for the input.
> >
> > >I totally agree with you that implicit subscription is not 
> supported in
> > >the presence specifications.
> >
> > What was not clear to me is whether it's not supported for good, but
> > non-articulated, reasons or just because no one has (yet) 
> considered it
> useful.
> >
> > >That leaves us with two approaches
> > >
> > >1. Use the draft-roach-sip-subscribe-notify-03.txt where a 
> registration
> is
> > >an implicit subscription to the *event* of de-registration. You
> > >automatically get a NOTIFY upon de-registration. This is the 3GPP
> approach.
> 
> Just to be acurate, the subscribe-notify draft does not 
> define implicit
> subscription for REGISTER. I don't think that it is 
> specifically described
> in any I-D. However, it was meantioned during one of the SIP 
> meetings at
> IETF-50 last week as a solution to the de-registration 
> notification problem.
> Implicit subscription is used by the REFER method described in
> draft-ietf-cc-transfer. The REGISTER request will need an 
> Event header to
> indicate the event it is subscribing to.
> 
> Bob
> d:-)
> 
> 
> Robert F. Penfield
> Chief Software Architect
> Acme Packet, Inc.
> 130 New Boston Street
> Woburn, MA 01801
> (781) 933-6166
> [email-masked]
> 
> 

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementor's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to 
[email-masked] with "subscribe" in the body.

---

From: "Dean Willis" <[email-masked]>
Date: Sat, 31 Mar 2001 17:58:45 -0600

I really don't think I understand this whole argument.

When I turn on the SIP phone on my desk, it sends register messages to three
different registrars.

Optionally, each registration could be authenticated with separate
credentials. None of those credentials has anything whatsover to do with
authorizing my phone to talk to the network.

And NONE of those registrations have anything whatsoever to do with whether
that phone can make a call. They influence only INBOUND calls to the
identities associated with the registrations.

Whether or not the phone has registered HAS ABSOLULTELY NO IMPACT on whether
that phone has "access" to the network. In fact, it has to have access to
the network BEFORE it can register. Registration is an application, not an
access control mechanism.

I think we're getting layer 2, 3, and 4 horribly confused.

--
Dean

----- Original Message -----
From: "Baniel Uri-CUB001" <[email-masked]>
To: "'Bob Penfield'" <[email-masked]>; "Sriram Parameswar"
<[email-masked]>; "'Romeo Zwart'" <[email-masked]>; "Baniel
Uri-CUB001" <[email-masked]>; "'Stephen Terrill'"
<[email-masked]>; "'Dean Willis'" <[email-masked]>;
"'Igor Slepchin'" <[email-masked]>; "'William Marshall'"
<[email-masked]>
Cc: "Chen Bonnie-BCHEN1" <[email-masked]>; "Xu Lang-LXU1"
<[email-masked]>; "sip" <[email-masked]>
Sent: Friday, March 30, 2001 12:46 PM
Subject: RE: [SIP] Informing UA after network initiated deregistration?