Subject: RE: [SIP] SIP Registration interval

From: Jonathan Rosenberg <[email-masked]>
Date: Thu, 15 Mar 2001 14:42:33 -0500

> -----Original Message-----
> From: Bob Penfield [mailto:[email-masked]]
> Sent: Thursday, March 15, 2001 1:58 PM
> To: Gordon Ledgard; 'Jonathan Rosenberg'; 'Henning Schulzrinne';
> [email-masked]
> Cc: [email-masked]
> Subject: Re: [SIP] SIP Registration interval
> 
> 
> Jonathan's proposal would retain the registrar's ability to 
> increase the
> expiration time. Would it be better to not allow the 
> registrar to lengthen
> the expiration time, but have the registrar reject the request when it
> figured out that the client was doing periodic refreshing too 
> frequently and
> suggest a more acceptable refresh rate?

No, I don't think so.

The reason is that it is the SERVER which is ultimately storing the
registration and providing a service. Fundamental to the C-S model is that
the server gets to decide what service it offers, and how it will fulfill
the client request. No protocol statements in the world can stop a registrar
from storing a registration for whatever time it sees fit.

So, I believe the specifications should follow reality. The server decides,
since it does anyway, and it tells the client its decision. We add the
caveat, as suggested by Henning, that the server should in general do what
the client asks (which is also standard client-server behavior). It might
not even hurt to include the little heuristic algorithm I described, to help
server implementors think about their policies.

-Jonathan R.

---
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementor's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to 
[email-masked] with "subscribe" in the body.

---

From: "Bob Penfield" <[email-masked]>
Date: Thu, 15 Mar 2001 15:10:26 -0500

I guess your right. In the case of a "one-shot" registration, the client can
just de-register at the time it originally wanted the registration to
expire.

Bob Penfield
Chief Software Architect
Acme Packet, Inc.
130 New Boston Street
Woburn, MA 01801
[email-masked]
----- Original Message -----
From: "Jonathan Rosenberg" <[email-masked]>
To: "'Bob Penfield'" <[email-masked]>; "Gordon Ledgard"
<[email-masked]>; "Jonathan Rosenberg" <[email-masked]>;
"'Henning Schulzrinne'" <[email-masked]>;
<[email-masked]>
Cc: <[email-masked]>
Sent: Thursday, March 15, 2001 2:42 PM
Subject: RE: [SIP] SIP Registration interval