Subject: RE: [SIP] Tag in From Field

From: Alexandre Charest <[email-masked]>
Date: Tue, 20 Mar 2001 10:19:57 -0500

Hi,

Isn't it fixed if the From tags become mandatory?

Anyway, a UA that want to detect that the re-INVITE is for an existing call
just has to include a tag in its From header.

-----Original Message-----
From: Christer Holmberg [mailto:[email-masked]]
Sent: Tuesday, March 20, 2001 10:09 AM
To: Jonathan Rosenberg
Cc: 'Vijay Gurbani'; Divya Nath; [email-masked]
Subject: Re: [SIP] Tag in From Field

Hi,

Jonathan Rosenberg wrote:
> 
> Also, I believe we have agreed that the tag in the From field is now
> mandatory.
> 
> The issue was discussed at IETF 49. Here is a summary of the problem:
> 
> 1. A calls B. No tag in From.
> 2. B answers 200 OK. Tag placed into To.
> 3. A crashes and recovers.
> 4. B sends re-invite to A. There is no tag in To field (since there was
none
> in From field from A) . A thinks this is a new call. A answers 200 OK,
> inserts tag into To field.
> 5. B is very confused, since now there is a tag in the remote address!
> 
> Same problem can manifest itself if a stateless proxy responds to the
> re-invite with a 400, inserting a tag.
> 
> The problem is readily solved by making From tags mandatory.
> 
> Anyone have problems with this?

I don't have any problem with it (actually, I think it could be a good
idea). 

However, it is related to one of my favorite topics: the session-timer.

Chapter 4 says:

"The UAS can detect that the re-INVITE is for an existing call by the
existence of the tag in the To field of the re-INVITE."

Now, if the called UA is the one making the refreshes, won't it insert a
tag in the To field ONLY if one was present in the From field in the
original INVITE? Ie, if no tag was present in the From field, no tag
will be inserted in the refresh To field, and if the UAS (the UA that
sent the initial INVITE) has crashed it will not know that the re-INVITE
is for an existing call. Or, should the called UA copy the fields from
the 200 OK response to the re-INVITE? Or? I don't think the session
timer drafts defines how the re-INVITE exactly will look like if it is
sent by the called UA.

Regards,

Christer Holmberg
Ericsson Finland

> 
> -Jonathan R.
> 
> ---
> Jonathan D. Rosenberg                       72 Eagle Rock Ave.
> Chief Scientist                             First Floor
> dynamicsoft                                 East Hanover, NJ 07936
> [email-masked]                     FAX:   (973) 952-5050
> http://www.cs.columbia.edu/~jdrosen         PHONE: (973) 952-5000
> http://www.dynamicsoft.com
> 
> 
> > -----Original Message-----
> > From: Vijay Gurbani [mailto:[email-masked]]
> > Sent: Wednesday, January 17, 2001 4:03 PM
> > To: Divya Nath
> > Cc: [email-masked]
> > Subject: Re: [SIP] Tag in From Field
> >
> >
> > Divya Nath wrote:
> > >
> > >    As specified in section 6.26 of draft-ietf-sip-rfc2543bis-0.2
> > > " A tag in From field must be present when it is possible
> > that the two
> > >instances of a user sharing a SIP address can make call
> > invitations with
> > > the same Call-Id."
> > > What I am unable to understand is when can the Call-Id be
> > same since as per my understanding the Call-Id is globally
> > unique within a single boot
> > > cycle .
> > > Can anybody please clearify the same .
> >
> > Divya:
> >
> > One way for a single Call-ID to have two instances of a user
> > sharing a SIP
> > address is when a proxy forks an INVITE request.  Each of the forked
> > requests will have the same From (including tags) as that of
> > the original.
> >
> > - vijay
> > --
> > Vijay K. Gurbani  vkg@{lucent.com,research.bell-labs.com,acm.org}
> > Internet Software and eServices Group
> > Lucent Technologies/Bell Labs Innovations 263 Shuman Blvd., Rm 1A-413
> > Naperville, Illinois 60566     Voice: +1 630 224 0216   Fax:
> > +1 630 713 0184
> >
> > _______________________________________________
> > This list is for continuing development of the SIP protocol.
> > The sip-implementer's list is the place to discuss implementation,
> > and to receive advice on understanding existing sip.
> > To subscribe to it, send mail to [email-masked] with
> > "subscribe sip-implementors" in the body.
> >
> 
> _______________________________________________
> This list is for continuing development of the SIP protocol.
> The sip-implementor's list is the place to discuss implementation,
> and to receive advice on understanding existing sip.
> To subscribe to it, send mail to
> [email-masked] with "subscribe" in the body.

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementor's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to 
[email-masked] with "subscribe" in the body.

---

From: Christer Holmberg <[email-masked]>
Date: Tue, 20 Mar 2001 17:53:29 +0200

Hi,

>Isn't it fixed if the From tags become mandatory?

Yes. 

The reason I raised the question was because I am confused how the
re-INVITE is build if the called UA sends the refreshes, since the text
I referred to was written before this mandatory-From-tag proposal came
up...
 
>just has to include a tag in its From header.

True, but then it shall be added to the session-timer draft.

Regards,

Christer Holmberg
Ericsson Finland

---

From: Benny Prijono <[email-masked]>
Date: Tue, 20 Mar 2001 17:01:21 +0000

Uh, sorry, I just woke up from my nice dream at work, about a world
where only UAC is required/allowed to refresh session timer.
Apparently things has changed since session-timer draft-01. Now the
UAS can refresh the timer.

So, I can see this is the root of all of this evil, err.., From tag.
One drawback with this new behaviour is, with UAS refreshes the
session timer, there's no way the UAC can detect whether it's a new
INVITE or a re-INVITE, because both new or re-INVITE may have tag in
the From header (yes, it's From header).

-- 
cheers,
Bennylp