Subject: RE: [SIP] SIP Registration interval

From: Baniel Uri-CUB001 <[email-masked]>
Date: Thu, 8 Mar 2001 09:45:42 -0600

Let's put it this way: If we do impose a lower bound on the registration time interval, do we potentially/possibly heart any current or future feature (which is dependant on the client's ability to register often enough) ?

===========================================
[email-masked], 
Tel: (847) 632 4616; Fax: (847) 632 3963; 
===========================================

> -----Original Message-----
> From: Iliff, Tina [mailto:[email-masked]]
> Sent: Thursday, March 08, 2001 8:30 AM
> To: 'Henning Schulzrinne'; Baniel Uri-CUB001
> Cc: 'Sean Olson (EUS)'; [email-masked]'
> Subject: RE: [SIP] SIP Registration interval
> 
> 
> Ok, now back to the question of imposing a lower bound on the 
> registration
> time interval....What are the thoughts?
> 
> Tina Iliff
> 
> 
> -----Original Message-----
> From: Henning Schulzrinne [mailto:[email-masked]]
> Sent: Thursday, March 08, 2001 8:24 AM
> To: Baniel Uri-CUB001
> Cc: 'Sean Olson (EUS)'; [email-masked]'
> Subject: Re: [SIP] SIP Registration interval
> 
> 
> 
> 
> > Baniel Uri-CUB001 wrote:
> > 
> > >Limiting the max. no. of contacts is a good idea as well.
> > >"400 Too Many Contacts" feels about right.
> > 
> > Sounds like 412 may just do it.. 
> 
> No, 412 is definitely the wrong one; this has nothing to do with
> preconditions. (SIP doesn't define 412, but any status codes that are
> used in HTTP are not redefined with another meaning.)
> 
> Generally speaking, this is a server problem, so it should 
> take the 500
> blame. The client has done nothing wrong. Except in extreme cases
> (hundreds of Contact headers), I would guess that any
> industrial-strength server won't have to worry about limiting this,
> unless this is used by lots of clients in a concerted 
> denial-of-service
> attack. Certainly, anything like eight is far too restrictive.
> 
> The more error conditions and restrictions you impose, the more tech
> support headaches you incur. My guess is that in most cases, a few
> microcents of disk space is the far better trade-off. (Even 
> with a 1000
> bytes of Contact, we're talking a storage cost of 0.0005 
> cents here. You
> have to have a lot of long Contact headers before you've made 
> up for one
> tech support call.)
> 
> _______________________________________________
> This list is for continuing development of the SIP protocol.
> The sip-implementor's list is the place to discuss implementation,
> and to receive advice on understanding existing sip.
> To subscribe to it, send mail to 
> [email-masked] with "subscribe" in the body.
> 

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementor's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to 
[email-masked] with "subscribe" in the body.

---

From: Henning Schulzrinne <[email-masked]>
Date: Thu, 08 Mar 2001 10:55:18 -0500

I suspect many clients already simply take the refresh interval from the
server, rather than doing a min(client,server) operation. Maybe it
wouldn't hurt to put that into the spec, as it doesn't seem to cause any
backwards-compatibility problems. (At worst, clients refresh more
frequently than they have to.) I'm against imposing any arbitrary fixed
lower value, for the same reasons that I outlined with regards to the
number of Contact entries.