Subject: [SIP] Huge SIP parser bug for JAIN1.0!!!

From: "Robert Chen" <[email-masked]>
Date: Tue, 6 Mar 2001 10:04:37 -0800

hi, all,

  I find out JAIN public release 1.0 a huge parser problem.

    public RouteHeaderImpl(NameAddress nameAddress)
   {
       setName(RouteHeader.name);
        setNameAddress(nameAddress);
    }

One routeheader is constructed from one nameaddress. So we will parser the
following as two RouteHeader.

Route: <sip:[email-masked];maddr=ss1.wcom.com>,
    <sip:[email-masked];maddr=fwp1.wcom.com>

in JAIN, the setRouteHeaders(java.util.List routeHeaders) in Request will
set the message as different. After parser, we will get a message like this:

Route: <sip:[email-masked];maddr=ss1.wcom.com>
Route: <sip:[email-masked];maddr=fwp1.wcom.com>

Not as this:
Route: <sip:[email-masked];maddr=ss1.wcom.com>,
    <sip:[email-masked];maddr=fwp1.wcom.com>

What should I do now? Anyone has the same problem? I think this is a huge
bug in JAIN. JAIN treat VIA and ROUTE as the same way. But in a message,
only one "Route:". Help!!!! Help again!!!

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementor's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to 
[email-masked] with "subscribe" in the body.

---

From: Igor Slepchin <[email-masked]>
Date: Wed, 7 Mar 2001 00:41:22 -0500

and 

are completely equivalent. 
	
Note that this sort of questions does not belong to SIP WG list; please post
them to jain sip mailing list.

---
Igor Slepchin

> -----Original Message-----
> From: Robert Chen [mailto:[email-masked]]
> Sent: Tuesday, March 06, 2001 1:05 PM
> To: Henning G. Schulzrinne; Michael O'Doherty; Kevin Wang
> Cc: [email-masked]; SIPMailingList
> Subject: [SIP] Huge SIP parser bug for JAIN1.0!!!
> 
> 
> hi, all,
>