Subject: Re: [Sip] Discussion: draft-hoeneisen-sip-proxy-supported-00.txt]

From: [email-masked]
Date: Fri, 20 Jul 2001 19:29:31 +0300

Hi Dean,

Dean Willis wrote:
>
>Ok, my turn to be obtuse. What's the difference between the goal of this 
>draft and
>
>draft-ietf-sip-serverfeatures-04.txt?

The main difference is, that with the Proxy-Supported mechanism
the intermediate _proxy_servers_ are queried for support of certain
features, whereas the draft-ietf-sip-serverfeatures-04
(Supported header field) describes a mechanism, where the
_User_Agent_ informs about features itself supports.

This proposal (Proxy-Supported) somehow complements the Proxy-Require
mechanism. With Proxy-Supported a request goes through even if one
(or more) of the intermediate proxy servers doesn't support an
indicated extension, whereas Proxy-Require results in an error
response in the proxy server.

Hope this answers your question.

br,
 Bernie

>--
>Dean
 
------------ Original Message --------
Subject: [Sip] I-D ACTION:draft-hoeneisen-sip-proxy-supported-00.txt
Date: Mon, 16 Jul 2001 07:01:31 -0400
From: [email-masked]
Reply-To: [email-masked]
To: IETF-Announce: ;
CC: [email-masked]

--NextPart

A New Internet-Draft is available from the on-line Internet-Drafts 
directories.

        Title           : The SIP Proxy-Supported header field
        Author(s)       : B. Hoeneisen et al.
        Filename        : draft-hoeneisen-sip-proxy-supported-00.txt
        Pages           : 11
        Date            : 13-Jul-01
        
The Session Initiation Protocol (SIP) provides a mechanism that
allows a User Agent Client (UAC) to request that a particular
protocol extension has to be used to process the request. The User
Agent Server (UAS) declines the request if it does not support the
extension. Recently also means have been defined for the User Agent
Server (UAS) to determine which extensions are supported by the User
Agent Client (UAC). Furthermore there are also means for requiring
proxy servers to understand certain features.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-hoeneisen-sip-proxy-supported-00.t
xt

Internet-Drafts are also available by anonymous FTP. Login with the username
"anonymous" and a password of your e-mail address. After logging in,
type "cd internet-drafts" and then
        "get draft-hoeneisen-sip-proxy-supported-00.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
        [email-masked].
In the body type:
        "FILE /internet-drafts/draft-hoeneisen-sip-proxy-supported-00.txt".

_______________________________________________
Sip mailing list  http://www.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: [email-masked]
Date: Fri, 20 Jul 2001 14:37:51 -0500

With Proxy-Require, it is clear what is intended:
you require every proxy on the path to support/use
a given extension. With Proxy-Supported, this is
more difficult. You are querying for the (optional)
support of a feature. What does it mean for 3 out
of 4 proxies to support a given feature? 

The biggest problem I see with this approach is
that it doesn't work for the initial request (e.g
INVITE). Most features that come to mind need to
be invoked on the initial request and possibly
subsequent requests for a call. 

regards,
sean olson

>-----Original Message-----
>From: [email-masked] [mailto:[email-masked]]
>Sent: Friday, July 20, 2001 11:30 AM
>To: [email-masked]
>Cc: [email-masked]
>Subject: Re: [Sip] Discussion:
>draft-hoeneisen-sip-proxy-supported-00.txt] 
>
>
>Hi Dean,
>
>Dean Willis wrote:
>>
xt

Send a message to:
        [email-masked].
In the body type: