Subject: RE: [Sip] New I-D on compression of SIP

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 24 Jul 2001 18:13:05 -0400

> -----Original Message-----
> From: Michael Thomas [mailto:[email-masked]]
> Sent: Saturday, July 21, 2001 12:18 PM
> To: Jonathan Rosenberg
> Cc: [email-masked]'; [email-masked]'
> Subject: [Sip] New I-D on compression of SIP
> 
> 
> 
> Jonathan Rosenberg writes:
>  > Folks,
>  > 
>  > I've just submitted a new I-D on compression of SIP 
> messages, particularly
>  > for wireless links. Until the draft appears in the 
> archives, you can pick up
>  > a copy at:
> 
> Jonathan,
> 
> To follow up on my passing comments, it should be
> noted that IPsec already has compression
> transforms which work in combination with
> encryption/message integrity. I'm not sure if TLS
> has this capability, but I wouldn't be surprised
> (nor do I think it would be hard to add if
> not). Thus, there's at least some amount of wheel
> reinvention going on here.

I believe that the IPSec compression mechanisms apply to each packet
independently. That is, there is no carryover of compression context from
one IP packet to the next. The problem is that a single SIP message only
compresses a little (maybe 2:1), but when you take advantage of previous
messages to build a compression context, it can be much, much bigger. Thats
the idea behind my draft, and also the others in the ROHC group - ROGER,
SCRIBE. So, I don't see them as solving the same problem.

-Jonathan R.
---
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
Sip mailing list  http://www.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Michael Thomas <[email-masked]>
Date: Tue, 24 Jul 2001 19:47:29 -0700 (PDT)

> SCRIBE. So, I don't see them as solving the same problem.

Hmm. I guess I have to wonder whether the marginal
difference is actually worth much over the base
Huffman encoding and whatever you manage to eek
out with the dictionary across packets. It does
come at the expense of quite a bit of extra shared
state. If you're sold on that, maybe it would be
best of all to just standardize a SIP specific
dictionary :-)

Not that this actually has much to do with
original point...

		Mike