Subject: RE: [Sip] another modest proposal: change call-leg ID

From: Jay Batson <[email-masked]>
Date: Wed, 11 Jul 2001 17:27:48 -0400

/me resists saying something like "Rogue endpoints?  Nah -- nobody would 
ever *think* of building something uncontrolled, would they?"  ;-)

Just kidding.
-jb

At 12:32 PM 7/11/01, Zmolek, Andrew (Andrew) wrote:

>Jonathan-
>
>Would your proposal in any way enable a rogue endpoint to alter or take 
>over a session by replicating a valid set of Call-ID and tags?
>
>--Andy Zmolek
>     Technology & Standards Engineer
>       CTO Standards
>         Avaya Inc.
>
>             [email-masked]
>               +1 720 444 4001
>
>-----Original Message-----
>From: Jonathan Rosenberg 
>[<mailto:[email-masked]>mailto:[email-masked]]
>Sent: Wednesday, July 11, 2001 12:30 AM
>To: [email-masked]'
>Subject: [Sip] another modest proposal: change call-leg ID
>
>Folks,
>
>While we're on the subject of modest proposals, here is another that I've
>been toying with:
>
>   Change the definition of call-leg ID. Instead of To, To-tag, From,
>   From-tag, and Call-ID, its *only* the tags and the Call-ID. That is,
>   the ID no longer contains the URLs.
>
>There are quite a few benefits from this:
>
>1. A calls B, and its forwarded to C. C accepts, and later re-INVITEs. The
> From field in this re-INVITE is NOT actually the identity of C, but rather,
>B. This screws up the idempotency of SIP INVITE. The >From field has one
>meaning in INVITE, and another in re-INVITE. This makes defining policies
>based on the From field more complex, since they no longer work properly for
>re-INVITE.
>
>2. call-leg ID lookups in gateways are much faster now, since the tags and
>call-ids are just strings. Matching is now case-sensitive string compares.
>Much easier than URL comparison.
>
>3. Overlap dialing is easier. The reason we've had to send each digit as a
>new call leg, is that we needed to change the To field and the request URI.
>By definition, this meant a new call leg. Now, we can send all of that
>within a single call leg. Much cleaner.
>
>4. The Replaces draft benefits. We've already identified a need for the
>Replaces header to identify the entire call leg thats being replaced. This
>gets big when it carries two URLs, two tags, and a call-id. Now, we can
>throw away the URLs. This shortens the header and makes matching of the
>call-leg IDs easier.
>
>5. It works with existing proxies.
>
>THe main drawback, of course, is that this won't interoperate with rfc2543
>UAs. Thats fixable with Supported; the UAC indicates Supported:
>new-call-leg-id in the INVITE if it understands this. In that case, any
>responses or re-invites that change the URLs include a Require:
>new-call-leg-id.
>
>I fully admit that this may not be worth the pain. However, I'd welcome
>comments from others on whether its useful to consider further.
>
>-Jonathan R.
>
>---
>Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
>Chief Scientist                             First Floor
>dynamicsoft                                 East Hanover, NJ 07936
>[email-masked]                     FAX:   (973) 952-5050
><http://www.jdrosen.net>http://www.jdrosen.net                      PHONE: 
>(973) 952-5000
><http://www.dynamicsoft.com>http://www.dynamicsoft.com
>
>
>_______________________________________________
>Sip mailing 
>list 
><http://www.ietf.org/mailman/listinfo/sip>http://www.ietf.org/mailman/listinfo/sip 
>
>This list is for NEW development of the core SIP Protocol
>Use [email-masked] for questions on current sip
>Use [email-masked] for new developments on the application of sip

-------------
PingMe!
Jay Batson
CEO
Pingtel Corp.
mailto:[email-masked]
781-938-5306 (office)

---

From: [email-masked]
Date: Wed, 11 Jul 2001 16:54:53 -0500

Yeah, yeah -- you never stir the pot just for the sake of it, Jay. :)

To address Andrew's question: it is completely unclear how this would
allow hijacking of a call any more than the previous schemes did.
If a system is set up in a way that is so brittle as to allow the
call to be taken over with just tags, that same system will have an
identical problem under the current scheme, in which it could be hijacked
using tags and URIs.

Or I could be missing something. Outline a hypothetical situation
in which a call could be hijacked under the scheme Jonathan
proposes, but in such a way that is not currently possible.

/a

-----Original Message-----
From: Jay Batson [mailto:[email-masked]]
Sent: Wednesday, July 11, 2001 4:28 PM
To: Zmolek, Andrew (Andrew); Jonathan Rosenberg
Cc: Grothe, Lew E (Lew); [email-masked]
Subject: RE: [Sip] another modest proposal: change call-leg ID

/me resists saying something like "Rogue endpoints?  Nah -- nobody would ever
*think* of building something uncontrolled, would they?"  ;-)

Just kidding.
-jb

Jonathan-

Would your proposal in any way enable a rogue endpoint to alter or take over a
session by replicating a valid set of Call-ID and tags?

--Andy Zmolek

            [email-masked]
              +1 720 444 4001

-----Original Message-----
From: Jonathan Rosenberg [mailto:[email-masked]]
Sent: Wednesday, July 11, 2001 12:30 AM
To: [email-masked]'
Subject: [Sip] another modest proposal: change call-leg ID

Folks,

-Jonathan R.

---
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

Sip mailing list  http://www.ietf.org/mailman/listinfo/sip

Sip mailing list  http://www.ietf.org/mailman/listinfo/sip