Subject: RE: [Sip] ABNF comment/nit on draft-ietf-sip-rfc2543bis-03.txt

From: "Fairlie-Cuninghame, Robert" <[email-masked]>
Date: Tue, 10 Jul 2001 02:45:39 -0700

> Beyond the / vs. |, the major difference is that RFC 2234 is a
> character-oriented grammar, while SIP (and HTTP) use a word-oriented
> grammar. We'd have to add a lot of LWSP everywhere in the grammar,
> basically between every token, as in
> 
> Subject  =  ( "Subject" $|$ "s" ) ":" TEXT-UTF8-TRIM
> 
> becomes
> 
> Subject = ( "Subject" $|$ "s") LWSP ":" LWSP TEXT-UTF8-TRIM
> 
> and more complicated grammars become even messier. I'm not convinced
> that this visual noise aids understanding, but there may be other
> reasons to do this.

Well just to stir the pot a little <grin> ...... isn't LWS only allowed on
the right hand side of the colon and not on the left.

Robert.

> -----Original Message-----
> From: Henning G. Schulzrinne [mailto:[email-masked]]
> Sent: Tuesday, July 10, 2001 1:27 AM
> To: Chip Sharp
> Cc: [email-masked]
> Subject: Re: [Sip] ABNF comment/nit on 
> draft-ietf-sip-rfc2543bis-03.txt
> 
> 
> Chip Sharp wrote:
> > 
> > The following production is in Appendix C:
> >         escaped = "%" hex hex
> > 
> > HEX is capitalized in its production.  While this is legal 
> according to
> > RFC2234, is it possible to use the same case?
> 
> Yes, this should be consistent.
> 
> > 
> > I assume this is academic, but why include Appendix C instead of
> > referencing RFC2234 and listing the exceptions/additions?  
> Why use "|" for
> > alternatives instead of the "/" defined in RFC2234?
> > 
> 
> This is annoying, but since rfc2534bis inherits definitions from RFC
> 2068 (HTTP/1.1), which does not quite use RFC 2234, we can either
> 
> - use RFC 2234 and remove all references in syntax to RFC 2068
> 
> - keep the | notation (and a few other modifications relative to 2234)
> from RFC 2068
> 
> Beyond the / vs. |, the major difference is that RFC 2234 is a
> character-oriented grammar, while SIP (and HTTP) use a word-oriented
> grammar. We'd have to add a lot of LWSP everywhere in the grammar,
> basically between every token, as in
> 
> Subject  =  ( "Subject" $|$ "s" ) ":" TEXT-UTF8-TRIM
> 
> becomes
> 
> Subject = ( "Subject" $|$ "s") LWSP ":" LWSP TEXT-UTF8-TRIM
> 
> and more complicated grammars become even messier. I'm not convinced
> that this visual noise aids understanding, but there may be other
> reasons to do this.
> -- 
> Henning Schulzrinne   http://www.cs.columbia.edu/~hgs
> 
> _______________________________________________
> Sip mailing list  http://www.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip
> 

_______________________________________________
Sip mailing list  http://www.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Henning G. Schulzrinne" <[email-masked]>
Date: Tue, 10 Jul 2001 09:46:25 -0400

> the right hand side of the colon and not on the left.

Anywhere between tokens.

Subject : something

is perfectly legal. See test1.txt of the torture tests, for example.