Subject: RE: Transcoding != B2BUA (was RE: [Sip] Forking: a modest proposa l.)

From: "Rosen, Brian" <[email-masked]>
Date: Wed, 11 Jul 2001 17:47:54 -0400

My .02 on this is that we should aim, as much as possible
for DESTINATION TRANSCODING.  There are other names for this.

Basically, in means that the end device, whatever it may be
should, in as many cases as possible, accept whatever
may be thrown at it, and convert it ONCE to whatever it
needs to.  This allows, for example, a mobile-to-mobile
call to have zero to one transcode stages, and not require
<whatever>-711-<whatever>.

Of course you can never enforce this, and you have to
allow for transcoders in the middle, but it really 
makes the quality go down fast to have two transcoding
stages.  The thing to remember is that intermediate
steps often don't know what the REAL destination coder is,
they tend to only know the coder at the edge of their own
domain. 

Brian

Brian

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Wednesday, July 11, 2001 5:32 PM
> To: 'Henning Schulzrinne'; [email-masked]
> Cc: Paul Kyzivat; Jay Batson; [email-masked]
> Subject: Transcoding != B2BUA (was RE: [Sip] Forking: a modest
> proposal.)
> 
> 
> > -----Original Message-----
> > From: Henning Schulzrinne [mailto:[email-masked]]
> >
> > An additional use of B2BUAs is for media translation, but 
> > this is really
> > only likely for multiparty calls, as quality is much better 
> if you can
> > avoid transcoding.
> 
> Sort of. Wireless-to-landline calls go through a GSM-to-G.711
> transcoder; most wireless-to-wireless calls go GSM-to-G.711-to-GSM.
> (Substitute various other heavily-compressed codecs for "GSM" to
> make the above sentence apply all over the world).
> 
> Since the audio characteristics of most phones is so crappy, and
> since an 8 kHz sampling rate is rather dismal, most people don't
> even notice.
> 
> > (I may be underestimating the effect of the screwy
> > licensing for G.72x and various other low-rate codecs here, 
> which also
> > could lead to more transcoding than is technically called for.)
> 
> Three letters: AMR
> 
> 3GPP is going for AMR as a default codec, with the implication that
> G.711 *will* *not* be used.
> 
> Bakeoffs have shown that many firmware SIP implementations use
> G.711 exclusively.
> 
> In the short term, transcoders will abound.
> 
> This is why (I feel) we need to come up with a good architecture
> to support transcoding which doesn't require a B2BUA. No, I'm not
> proposing a work item (we do protocols, not architectures); I'm
> just thinking out loud.
> 
> /a
> 
> 
> _______________________________________________
> Sip mailing list  http://www.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip
> 

_______________________________________________
Sip mailing list  http://www.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: [email-masked]
Date: Wed, 11 Jul 2001 17:05:15 -0500

On IP, transcoding is best accomplished as you describe.

I think you missed my point, though: I was illustrating
the fact that an absurd amount of transcoding goes on currently,
and that it doesn't really hurt because phones sound crappy to
start with. People put up with transcoding, and cannot usually
tell the difference.

The single codec conversion of which you speak is what I'm referring
to when I say that we need a good, non-B2BUA solution for transcoding.

To summarize what I was trying to say: transcoders will be present.
They should not break the signaling. We need to make this happen.

/a

> From: Rosen, Brian [mailto:[email-masked]]
> Sent: Wednesday, July 11, 2001 4:48 PM
> To: [email-masked]'; 'Henning Schulzrinne';
> [email-masked]
> Subject: RE: Transcoding != B2BUA (was RE: [Sip] Forking: a modest
> proposa l.)
> 
>