Subject: Re: [SIP] SIP Message segmentation problem over TCP

From: "Paul E. Jones" <[email-masked]>
Date: Sun, 1 Jul 2001 21:28:58 -0400

Chandra,

TPKT (RFC 1006) would have been the logical thing to do.  However, as SIP is
an ASCII-based protocol, which requires the parsers to look though long
strings like "Content-Length" for information (then perform expensive
arithmetic in order to actually calculate the length in this case), using
TPKT would look like a "kludge" in the protocol.

While the IETF has a history of engineering more efficient protocols, SIP
was not engineered with processing efficiency in mind.

Paul

----- Original Message -----
From: "Chandra Ravipati" <[email-masked]>
To: <[email-masked]>
Sent: Friday, June 29, 2001 3:01 PM
Subject: [SIP] SIP Message segmentation problem over TCP

>
> Hi,
>
> I want to know how others are dealing with message segmentation for TCP.
>
> Do people use TPKT? or use Content-length: ?
>
> Using "content-length" is very inefficient and very protocol specific.
> Why can't we use TPKT?
>
>
> Thanks in advance for your participation in this discussion.
> Chandra Ravipati.
>
> _______________________________________________
> This list is for continuing development of the SIP protocol.
> The sip-implementor's list is the place to discuss implementation,
> and to receive advice on understanding existing sip.
> To subscribe to it, send mail to
> [email-masked] with "subscribe" in the body.
>

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementor's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to 
[email-masked] with "subscribe" in the body.

---

From: Anders Kristensen <[email-masked]>
Date: Mon, 02 Jul 2001 11:47:31 -0400

SIP is based on HTTP and you can blame HTTP for this particular aspect
of SIP. Using a Content-Length header is perfectly logical, BTW.

Cheers,
Anders

---

From: Henry Sinnreich <[email-masked]>
Date: Mon, 02 Jul 2001 11:00:11 -0500

> was not engineered with processing efficiency in mind.

Cheap shot. The issue of text based vs. ASN.1 has been amply debated and
been shown to not make any significant difference.

Henry

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of Anders Kristensen
Sent: Monday, July 02, 2001 10:48 AM
To: Paul E. Jones
Cc: [email-masked]; [email-masked]
Subject: Re: [SIP] SIP Message segmentation problem over TCP

Cheers,
Anders

---

From: Anders Kristensen <[email-masked]>
Date: Mon, 02 Jul 2001 13:15:29 -0400

You said "TPKT (RFC 1006) would have been the logical thing to do". This
implies SIP is doing something less logical wouldn't you say?

SIP clearly puts cleanliness and simplicity above efficiency. I believe
it's fair to say that this has proven to be a winning strategy for
protocol design.

Anders

"Paul E. Jones" wrote:
> 
> Anders,
> 
> I didn't say it was illogical: it's just inefficient.
> 
> Paul
> 
> From: "Anders Kristensen" <[email-masked]>
> To: "Paul E. Jones" <[email-masked]>
> Cc: <[email-masked]>; <[email-masked]>
> Sent: Monday, July 02, 2001 11:47 AM

---

From: Chandra Ravipati <[email-masked]>
Date: Mon, 02 Jul 2001 12:08:06 -0600

Guys,

I did not want to start a debate over whether SIP is good or bad. 
I wanted to understand why SIP can not use TPKT. TPKT is defined 
at(/immediately over) transport layer. 

IMHO, using TPKT is more efficient than SIP/HTTP solution. 
(Don't anybody get emotional(defensive). I am not criticizing any
protocol)

If there is any possibility of influencing the implementation
standard to use TPKT, let's work on it. 

Let's talk about pros/cons without getting emotional.

Thanks,
Chandra.

---

From: Anders Kristensen <[email-masked]>
Date: Mon, 02 Jul 2001 14:19:41 -0400

I don't see how my response was emotional or defensive. I assure you it
wasn't meant to be.

The point is that SIP is not designed to squeeze every last bit of
efficiency out of the network, and that this is a good thing. Noone is
arguing that TPKT wouldn't save a bit of network traffic but it would be
at the cost of making the protocol more ugly by special casing TCP from
UDP and breaking with how HTTP and MIME generally works. For these
reasons, and probably many more like it, what you're proposing is a
non-starter.

I'll shut up now.

Anders

---

From: Chandra Ravipati <[email-masked]>
Date: Mon, 02 Jul 2001 12:08:06 -0600

Guys,

Thanks,
Chandra.

_______________________________________________
Sip mailing list  http://www.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Anders Kristensen <[email-masked]>
Date: Mon, 02 Jul 2001 14:19:41 -0400

I'll shut up now.

Anders

---

From: "Paul E. Jones" <[email-masked]>
Date: Mon, 2 Jul 2001 14:40:20 -0400

Anders,

Ah, you're right: my words did imply that SIP's method was illogical, didn't
it?  Sorry.

Indeed, SIP's method is logical, just less efficient in terms of detecting
message boundaries.

Paul

----- Original Message -----
From: "Anders Kristensen" <[email-masked]>
To: "Paul E. Jones" <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>
Sent: Monday, July 02, 2001 1:15 PM
Subject: Re: [SIP] SIP Message segmentation problem over TCP

> > > > TPKT (RFC 1006) would have been the logical thing to do.  However,
as
> > SIP is
> > > > While the IETF has a history of engineering more efficient
protocols,
> > SIP