Subject: [Sip] SIP Compression

From: "Aniruddha Kulkarni" <[email-masked]>
Date: Tue, 24 Jul 2001 15:29:51 +0200

RoHC works hop-to-hop, not end-to-end when there are multiple hops between two ends. Does SIP Compression mechanisms also have this constraint? If yes, why? Are those designed to work only on cellular link between mobile terminal and fixed end of cellular link (hop-to-hop) ? Why those mechanisms are not designed for end-to-end compression? (reduce large payloads ,whatever be the link characteristics...)

---Aniruddha

---

From: [email-masked]
Date: Tue, 24 Jul 2001 11:27:18 -0500

SIP is not intended to transport large amounts of information.
That plus the ratio of bandwidth used by signalling vs.
the bandwidth used by the media, means that signalling compression
for SIP is not in general a problem. It only really becomes a
problem on low bandwidth, high latency *links* such as a cellular
link where sometimes every byte counts.

In short, I believe signalling compression is a hop-by-hop
problem and not an end-to-end one. A hop-by-hop solution seems
appropriate in this case. 

It should also be noted that you can always apply gzip compression
to the MIME body of a SIP message to achieve some end-to-end
compression. IMHO, this is not needed.

I believe the compression techniques that have been
described so far (ROGER, SCRIBE, EPIC, etc.) are
fairly generic and would work well on a variety of
link types. Some have been tailored with cellular
in mind. 

Hopefully this addresses your concerns,
Sean Olson
Ericsson Inc.

-----Original Message-----
From: Aniruddha Kulkarni [mailto:[email-masked]]
Sent: Tuesday, July 24, 2001 8:30 AM
To: [email-masked]; [email-masked]
Subject: [Sip] SIP Compression

RoHC works hop-to-hop, not end-to-end when there are multiple hops between two ends. 
Does SIP Compression mechanisms also have this constraint? If yes, why? 
Are those designed to work only on cellular link between mobile terminal and 
fixed end of cellular link (hop-to-hop) ? Why those mechanisms are not designed
 for end-to-end compression? 
(reduce large payloads ,whatever be the link characteristics...)

---Aniruddha 

_______________________________________________
Sip mailing list  http://www.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Aniruddha Kulkarni" <[email-masked]>
Date: Wed, 25 Jul 2001 13:44:41 +0200

If one has high latency link then nothing can be done about it. Compression
is not a solution for that.
If one has low bandwidth link and large data to send then Compression can be
the solution.
SIP messages take up only small portion of the available bandwidth (even on
Cellular links..). Then why use compression for SIP messages? Well..
cellular links have high BER, in this situation it is advisable to have
smaller packets to reduce error probability.. that is why use compression.
.. correct?

Still large number of connections to internet are over telephone modem links
with low bandwidth, comparable with latest cellular links. Isn't it useful
to have end-to-end SIP message compression in that situation?

How much the SIP compression schemes are dependant on RoHC? Could they have
in-built mechanism for configuration negotiation? Should they demand this
facility from lower layers? It seems to me that these schemes work more at
application level and should have configuration negotiation at that level
only. That way they could be easily extened for use on end-to-end rather
than limiting them to hop-to-hop (by depending on RoHC).

---Aniruddha

----- Original Message -----
From: <[email-masked]>
To: "'Aniruddha Kulkarni'" <[email-masked]>;
<[email-masked]>; <[email-masked]>
Sent: Tuesday, July 24, 2001 6:27 PM
Subject: RE: [Sip] SIP Compression

---

From: Suheel Hussain <[email-masked]>
Date: Wed, 25 Jul 2001 08:45:47 -0400

I have nagging issue with SIP compression -- compressing and decompressing on 
each proxy server is going to slow down call processing on large networks. 
IMO, it (compression) is not scalable.

Even end-to-end can be a problem if either (or both) UAS and UAC service a 
number of attached SIP-unaware systems. For instance a SIP-PSTN gateway.

Aniruddha Kulkarni wrote:

> ... correct?
>> RoHC works hop-to-hop, not end-to-end when there are multiple hops between
> 
> two ends.
> 
>> Are those designed to work only on cellular link between mobile terminal
> 
> and
> 
>> fixed end of cellular link (hop-to-hop) ? Why those mechanisms are not
> 
> designed
> 

-- 

Suheel Hussain
[email-masked]
Cisco Work # (919) 392-2312

---

From: "Dean Willis" <[email-masked]>
Date: Wed, 25 Jul 2001 09:41:17 -0500

Actually, it's the serialization latency that seems to cause problems. How
long does it a take a 1KB packet to get through a 4.6kbps link? What are the
impacts of this to a user who's trying to set up a four-way bridge call?

--
Dean