Subject: [Sip] Equivalence of "public addresses"

From: "Jo Hornsby" <[email-masked]>
Date: Fri, 20 Jul 2001 11:07:25 +0100

People,

I'd be interested to know if anybody had any experiences /
thoughts on this.

Currently, I interpret bis-03 as requiring Registrars
(and thus I guess Location Services that use the DB that
a Registrar mutates) to treat a public address of
    [email-masked]
as different to
    [email-masked];transport=tcp

This doesn't seem entirely useful.

However, I could perhaps be more sympathetic if someone
wanted
    [email-masked];magic=x
to be different to
    [email-masked];magic=y
Although the fact that neither of these are technically
different to
    [email-masked]
does seem to suggest that this is a bogus approach.
(Note: I am finding it difficult to come up with a
reasonable parameter name, which is why I chose "magic")

The classic, I think, is:
    [email-masked]
being different to
    [email-masked];user=phone
.  I have to admit that I do (and I expect people to
start shouting at me here) find catering for such
terminal mobility slightly anachronstic, since surely
this is only solving a transitional concern?  Not to
mention the fact that have had experience of parties
expecting these two to be equivalent (i.e., REGISTER
as one, INVITE to the other).

So the crux is that should we only be considering
the user part and host part in these matters?  Personally,
I fluctuate on a day to day basis, so I'd be interested
if anybody could ease my nausea.

Thank you,

 - Jo.
-- 
  Jo Hornsby; IT Professional         --       mailto:[email-masked]
 Ubiquity Software Corporation        --         http://www.ubiquity.net/

_______________________________________________
Sip mailing list  http://www.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Jo Hornsby" <[email-masked]>
Date: Fri, 20 Jul 2001 11:29:29 +0100

[...]
>     [email-masked];transport=tcp

Whoops, I should have said:
    [email-masked]
as different to
    [email-masked]:6000
as transport is not legal in the SIP URL of a To
header.

Yours slightly red-faced,

 - Jo.