Subject: [Sip] Adhoc group messaging

From: "Ashhar Farhan" <[email-masked]>
Date: 2 Jul 2001 07:21:42 -0000

While chatting with a peer, an IM user would typically 
like to add a third participant to the chat. 
This is currently not possible in SIP MESSAGE. 

MESSAGE rfc recommends that a group@host url should be 
used for multi-participant chatting. a group id is not 
available in peer chats that are one to one and have to 
include a third recepient (sort of CC of email UAs).

although group@host is definitely the best thing for
large chat groups, most of chat interactivity takes
place within smaller groups of people who interact with
each other and do often need to chat with about 3-4
participants at a time.

this kind of chatting can be accomplished in principle by
making each of the participants send a copy of MESSAGE to
all the other participants. If the group grows too big,
and the bandwidth gets constrained, then they ought to 
move to a scheduled group chat server. However, for most
of the times it is enough to be able to chat with 3-4
pariticipants at a time.

Do note that these groups are created without any
schedule and grow out of a 1-1 chat.
My recommendation would be that:

1. A sends B a MESSAGE, B sends a reply back with the
same Call-ID. so that we have identified a sequence of MESSAGEs that can be displayed within a particular instance of  User interface (like a window).

2. A wants C to join in the chat. A sends some reques(s) to C. At this point, what needs to be done is that:
2.1 C should get a list of all the participants from A.
2.2 C should get the group messaging ID (probably the
shared Calli-ID) for all these messages so that this 
thread of messages to the other participants can be distinguished from any other threads that maybe
concurrently engaged in by C. Alternatively, instead of 
the Call-ID, even Subject can be used (probably a 
combination of the two is going to be the only unique thing).
2.3 Others have to be informed of additon of C to the 
chat group.
2.4 All the future MESSAGEs and NOTIFYcations are send 
to the updated list of participants by all.

one possible implementation for this is that we base this on SUBSCRIBE/NOTIFY.

Step 1:A participant is added by sending a SUBSCRIBE to the new particpant.
Step 2:The new pariticipant responds back by accepting the SUBSCRIPTION. The participant who has added the new 
participant also sends a NOTIFY to other participants 
who can update their chat lists with the userid of the
new participant.

- [email-masked]

____________________________________________________
Buy Feng Shui Package for Rs. 151/- only, at http://shopping.rediff.com/shopping/fengshui_mailer.htm

_______________________________________________
Sip mailing list  http://www.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: [email-masked]
Date: Mon, 2 Jul 2001 22:37:37 -0600

The SIP extensions for Instant Messaging and Presence are currently
discussed in the SIMPLE working group rather than the SIP WG. You can
subscribe to the SIMPLE WG mailing list (or access the archives) by going
to:

http://mailman.dynamicsoft.com/mailman/listinfo/simple

FYI in light of your proposal below, a forthcoming issue of the document set
on the MESSAGE method defines a new way of setting up an IM session between
two parties that uses the INVITE method with a special SDP indicating that
MESSAGEs are to be exchanged directly between the parties. As it turns out,
this allow the IM extension to take advantage of the conferencing methods
used for VoIP, including building an IM 'conference server' or even probably
using some fully-meshed models if you were so inclined. If you glance
through the archives of the SIMPLE mailing list, you'll find some further
information on this, or you can wait for the new drafts (which should appear
in the relatively short term).

Jon Peterson
Level(3) Communications

-----Original Message-----
From: Ashhar Farhan [mailto:[email-masked]]
Sent: Monday, July 02, 2001 1:22 AM
To: [email-masked]
Subject: [Sip] Adhoc group messaging

1. A sends B a MESSAGE, B sends a reply back with the
same Call-ID. so that we have identified a sequence of MESSAGEs that can be
displayed within a particular instance of  User interface (like a window).

2. A wants C to join in the chat. A sends some reques(s) to C. At this
point, what needs to be done is that:
2.1 C should get a list of all the participants from A.
2.2 C should get the group messaging ID (probably the
shared Calli-ID) for all these messages so that this 
thread of messages to the other participants can be distinguished from any
other threads that maybe
concurrently engaged in by C. Alternatively, instead of 
the Call-ID, even Subject can be used (probably a 
combination of the two is going to be the only unique thing).
2.3 Others have to be informed of additon of C to the 
chat group.
2.4 All the future MESSAGEs and NOTIFYcations are send 
to the updated list of participants by all.

one possible implementation for this is that we base this on
SUBSCRIBE/NOTIFY.

Step 1:A participant is added by sending a SUBSCRIBE to the new particpant.
Step 2:The new pariticipant responds back by accepting the SUBSCRIPTION. The
participant who has added the new 
participant also sends a NOTIFY to other participants 
who can update their chat lists with the userid of the
new participant.

- [email-masked]

____________________________________________________
Buy Feng Shui Package for Rs. 151/- only, at
http://shopping.rediff.com/shopping/fengshui_mailer.htm