Subject: RE: [SIP] Re: Codecs G729 and their various flavors

From: Shawn Pouliotte <[email-masked]>
Date: Thu, 5 Jul 2001 14:02:57 -0700

Hi

-G.729 is CS-ACELP, an 8kbps speech Codec (G.729r8)
-G.729a (G.729 Annex A) is a reduced complexity version of G.729 and is
still an 8k voice Codec
-G.729b (G.729 Annex B) is a spec for Voice Activity Detection (VAD),
Discontinuity Transmission (DTX), and Comfort Noise Generation (CNG). More
simply stated, Annex B is silence suppression for use with G.729 or G.729a
voice codecs and is not a codec in itself. 

G.729 and G.729a operate on a 10 mSec speech frame corresponding to 80
samples at a rate of 8kbps. This yields an 80bit speech fame every 10 mSec.
If silence suppression etc. are used (such as Annex B), the frame length
will vary. In the case of annex B, SID frames are 15 bits rather than 80
bits for a speech frame.

Hope that helps
Shawn

-----Original Message-----
From: Gregory Paterno [mailto:[email-masked]]
Sent: Thursday, July 05, 2001 12:08 PM
To: Henning G. Schulzrinne
Cc: [email-masked]; [email-masked]
Subject: RE: [SIP] Re: Codecs G729 and their various flavors

"G.729 is silence suppression and distinguishable by payload
length."

Where could I find information on the payload length supporting
silence suppression for G.711 and G.729b?

Thanks.

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of Henning G.
Schulzrinne
Sent: Thursday, July 05, 2001 11:36 AM
To: [email-masked]
Cc: [email-masked]; [email-masked];
[email-masked];
[email-masked]; [email-masked]
Subject: [SIP] Re: Codecs G729 and their various flavors

Ameet Kher wrote:
>
> Hi
>
> I am trying to follow up on some previous discussions on this
list
> about whether to use dynamic
> payload types for various flavors of the G729 codec. Presently
the
> IANA list has defined a static payload type
> and encoding name only for the G729r8 codec. Should we be using
> dynamic payloads for G729b, G729ab, G729a ?

All new codecs only use dynamic payload types.

> And use X-* as encoding names ? I am sure we cannot use the
same

Using X-* is a certifiably bad idea. The argument has been made
numerous
times on this list, but let me know if you'd like another
rendition of
it.

> static payload value (18) for all these flavors.

You can use the same payload type (doesn't matter if static or
dynamic)
if the codecs are distinguishable by looking at the payload.
G.729a is
just a reduced-complexity implementation, that has the same bit
pattern,
so there doesn't seem to be a need for a new payload type.

G.729 is silence suppression and distinguishable by payload
length.

I have no idea what G.729ab would be; it is not mentioned at
http://www.itu.int/itudoc/itu-t/rec/g/g700-799/index.html

>
> - Ameet
>
>
>
> --
> ******************************
> AMEET KHER, Software Engineer
> Cisco Systems
> Tel : (919) 392-8431
>
>

--
Henning Schulzrinne   http://www.cs.columbia.edu/~hgs

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementor's list is the place to discuss
implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to
[email-masked] with "subscribe" in the
body.

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementor's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to 
[email-masked] with "subscribe" in the body.

---

From: Manoj Bhatia <[email-masked]>
Date: Fri, 06 Jul 2001 16:54:07 -0400

Hi

The fact is that g.729 /g.729a  pair shall not interoperate with
g.729b/g.729ab.
The static payload '18' defined so far is being used for g.729/g.729a by

SIP folks  .
Some are now interested in using g.729b/g.729ab pair for obvious
advantages in
VAD,DTX etc.

So, my question is that why don't we have a static payload defined for
g.729b/g729ab
pair just like we had '18' for the other pair.

Or is it legal to use '18' for this pair too ?

To avoid interop issues, can we lay down rules to state that when to use
'18' and when
not to use '18' especially if a SIP-UA agent has the ability to support
'all' the four flavors of
g729 and is interested in advertising that in its SDP ?

thanks
-manoj

Shawn Pouliotte wrote:

> -G.729a (G.729 Annex A) is a reduced complexity version of G.729 and
> is still an 8k voice Codec
> Discontinuity Transmission (DTX), and Comfort Noise Generation (CNG).
> More simply stated, Annex B is silence suppression for use with G.729
> or G.729a voice codecs and is not a codec in itself.
>
> samples at a rate of 8kbps. This yields an 80bit speech fame every 10
> mSec. If silence suppression etc. are used (such as Annex B), the
> frame length will vary. In the case of annex B, SID frames are 15 bits
> rather than 80 bits for a speech frame.
>
> Hope that helps
> Shawn
>

--
Manoj Bhatia                           |        |         |
[email-masked]                       |       :|:       :|:
7025 Kit Creek Road, RTP, NC - 27709   |     :|||||:   :|||||:
Ph: 919-392-3873  Fax:919-392-6801     |  C i s c o S y s t e m s