Subject: [SIP] Codecs G729 and their various flavors

From: Ameet Kher <[email-masked]>
Date: Thu, 05 Jul 2001 11:57:33 -0400

Hi

I am trying to follow up on some previous discussions on this list about
whether to use dynamic
payload types for various flavors of the G729 codec. Presently the
IANA list has defined a static payload type
and encoding name only for the G729r8 codec. Should we be using dynamic
payloads for G729b, G729ab, G729a ?
And use X-* as encoding names ? I am sure we cannot use the same static
payload value (18) for all these flavors.

- Ameet

--
******************************
AMEET KHER, Software Engineer
Cisco Systems
Tel : (919) 392-8431

---

From: "Henning G. Schulzrinne" <[email-masked]>
Date: Thu, 05 Jul 2001 12:36:22 -0400

Ameet Kher wrote:
> 
> Hi
> 
> I am trying to follow up on some previous discussions on this list
> about whether to use dynamic
> and encoding name only for the G729r8 codec. Should we be using
> dynamic payloads for G729b, G729ab, G729a ?

All new codecs only use dynamic payload types.

> And use X-* as encoding names ? I am sure we cannot use the same

Using X-* is a certifiably bad idea. The argument has been made numerous
times on this list, but let me know if you'd like another rendition of
it.

> static payload value (18) for all these flavors.

You can use the same payload type (doesn't matter if static or dynamic)
if the codecs are distinguishable by looking at the payload. G.729a is
just a reduced-complexity implementation, that has the same bit pattern,
so there doesn't seem to be a need for a new payload type.

G.729 is silence suppression and distinguishable by payload length.

I have no idea what G.729ab would be; it is not mentioned at
http://www.itu.int/itudoc/itu-t/rec/g/g700-799/index.html

-- 
Henning Schulzrinne   http://www.cs.columbia.edu/~hgs

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementor's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to 
[email-masked] with "subscribe" in the body.

---

From: "Henning G. Schulzrinne" <[email-masked]>
Date: Thu, 05 Jul 2001 12:40:34 -0400

> G.729 is silence suppression and distinguishable by payload length.

Typo: Make that G.729 Annex B.

_______________________________________________
Sip mailing list  http://www.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Gregory Paterno <[email-masked]>
Date: Thu, 05 Jul 2001 14:07:37 -0500

"G.729 is silence suppression and distinguishable by payload
length."

Where could I find information on the payload length supporting
silence suppression for G.711 and G.729b?

Thanks.

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of Henning G.
Schulzrinne
Sent: Thursday, July 05, 2001 11:36 AM
To: [email-masked]
Cc: [email-masked]; [email-masked];
[email-masked];
[email-masked]; [email-masked]
Subject: [SIP] Re: Codecs G729 and their various flavors

> And use X-* as encoding names ? I am sure we cannot use the
same

Using X-* is a certifiably bad idea. The argument has been made
numerous
times on this list, but let me know if you'd like another
rendition of
it.

> static payload value (18) for all these flavors.

You can use the same payload type (doesn't matter if static or
dynamic)
if the codecs are distinguishable by looking at the payload.
G.729a is
just a reduced-complexity implementation, that has the same bit
pattern,
so there doesn't seem to be a need for a new payload type.

G.729 is silence suppression and distinguishable by payload
length.

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementor's list is the place to discuss
implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to
[email-masked] with "subscribe" in the
body.