Subject: [Sip] RE: 489 status code

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 1 Aug 2001 02:36:49 -0400

> -----Original Message-----
> From: Gonzalo Camarillo [mailto:[email-masked]]
> Sent: Tuesday, July 31, 2001 3:39 PM
> To: [email-masked]
> Cc: [email-masked]; Jonathan Rosemberg
> Subject: 489 status code
> 
> 
> Hello,
> 
> A minor comment about 489 status code: In Adam's event draft it means
> "Bad Event", and in Jonathan's early media draft it means "Request
> Updated". Since both are just I-Ds this is not really an issue right
> now, but when they advance to RFCs we will have to resolve this
> conflict.

To quote the great Homer Simpson:

"Doh!"

This problem is why bis-04 requests the creation of an IANA registry for
response codes. However, I don't know if it can be established prior to
publication of bis as an rfc, which is what we really want. I did ask IANA
about that, but got no reply.

Anyway, since Adam was there first, I will change this in the early media
draft to something else.

Thanks,
Jonathan R.
---
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
Sip mailing list  http://www.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Gonzalo Camarillo <[email-masked]>
Date: Wed, 01 Aug 2001 18:23:50 +0300

Hello,

Yes, having an IANA registry for response codec would help have
consistent specs. We will most likely use the "request updated" response
code in the next version of the overlap draft, so we better be
consistent :o)

Regards,

Gonzalo

-- 
Gonzalo Camarillo                    Phone :   +1 212 939 71 71
Columbia University                  Mobile:  +358 40 702 35 35
472 Computer Science Building        Fax   :  +358  9 299 30 52
1214 Amsterdam Ave., Mail Code 0401  http://www.hut.fi/~gonzalo
New York, NY 10027                   
USA                              [email-masked]

---

From: "Henning G. Schulzrinne" <[email-masked]>
Date: Wed, 01 Aug 2001 12:53:20 -0400

> code in the next version of the overlap draft, so we better be

Since IANA seems to have delay and packet loss problems, maybe I can set
up a table of new codes. Anybody who has defined a new status code
outside of bis, please set me a reference.

Thanks.

-- 
Henning Schulzrinne   http://www.cs.columbia.edu/~hgs