Subject: RE: [Sip] bis-04 available!

From: Jonathan Rosenberg <[email-masked]>
Date: Fri, 3 Aug 2001 16:15:11 -0400

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Tuesday, July 24, 2001 4:09 PM
> To: [email-masked]; [email-masked]
> Subject: RE: [Sip] bis-04 available!
> 
> 
> Jonathan,
> 
>  Section 16.3 includes the following updated language in the second
> paragraph (thanks):
> 
> The URL SHOULD NOT contain the
> transport parameter, but can in private networks where it is known
> that elements on both sides of the proxy support the specific
> transport.   
> 
>  However, the following language in paragraph 4 also needs to 
> be modified so
> there is no conflict:
> 
> The proxy MAY modify the Record-Route
> value matching the one it inserted into the request. Like the URL in
> the request, it MUST be a SIP URL and MUST NOT contain a transport
> parameter. 

Thanks for pointing it out. I've fixed it for -05.

> 
> 
>  I'd also like to note that since the Record-Route may be 
> modified, it is
> possible the transport could be modified, thus elements on 
> both sides of the
> proxy may not need to support the specific transport as the 
> first modified
> language indicates.  For example, leave off the transport on the
> Record-Route of an Invite going into the private network so 
> UDP defaults on
> the inside, and include transport=tls in the 200 OK's 
> Record-Route when
> interfacing with another element over an unsecure network.  
> This allows
> subsequent requests to run over the same secure connection an initial
> transaction ran over, without requiring the same transport on 
> the other side
> of the proxy.

Yes, you are correct. I have fixed this for -05 as well.

-Jonathan R.
---
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
Sip mailing list  http://www.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Fri, 3 Aug 2001 16:36:22 -0400

> From: James Undery [mailto:[email-masked]]
> Sent: Thursday, July 26, 2001 7:07 AM
> To: Jonathan Rosenberg
> Cc: [email-masked]'
> Subject: Re: [Sip] bis-04 available!
> 
> 
> Hi
> 
> Well I for one am glad the Authentication-Info is now 
> mentioned in the spec,
> that makes my digest draft actually potentially useful!! It 
> would be nice
> however to have the header mentioned in section 10, even if 
> it's just a short
> entry like Authorization.
> 
> James Undery

Good point. I added it for bis-05.

I was about to add Proxy-Authentication-Info too, and then I realized it
doesn't work. The reason is that multiple proxies might want to insert this
header. The header does not define a realm parameter, so that a UAC
receiving many Proxy-Authentication-Info headers in a 2xx won't know which
one applies to which realm. So, it won't be able to use the nextnonce, for
example, since it doesn't know whcih username/pass to apply to each nonce.

Our options are to:

1. forget about Proxy-Authentication-Info (its only briefly mentioned in
rfc2617, easy to miss....)
2. define our own extension to this header containing a realm parameter.

-Jonathan R.

---

---

From: "Fairlie-Cuninghame, Robert" <[email-masked]>
Date: Fri, 10 Aug 2001 10:43:19 -0700

Also Jonathan,

The maddr header is still listed as mandatory for Record-Route in Table 2.

Regards,

Robert.

> From: Jonathan Rosenberg [mailto:[email-masked]]
> Sent: Friday, August 03, 2001 9:15 PM
> To: [email-masked]'; Jonathan Rosenberg; [email-masked]

Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 22 Aug 2001 15:46:29 -0400

Good catch. Fixed.

Thanks,
Jonathan R.

---

> From: Fairlie-Cuninghame, Robert [mailto:[email-masked]]
> Sent: Friday, August 10, 2001 1:43 PM
> To: 'Jonathan Rosenberg'; [email-masked]