Subject: RE: [Sip] update to nat traversal draft!

From: Jonathan Rosenberg <[email-masked]>
Date: Fri, 3 Aug 2001 15:04:04 -0400

> -----Original Message-----
> From: Gonzalo Camarillo [mailto:[email-masked]]
> Sent: Wednesday, August 01, 2001 11:44 AM
> To: Jonathan Rosenberg
> Cc: [email-masked]'; Fairlie-Cuninghame, Robert; [email-masked]'
> Subject: Re: [Sip] update to nat traversal draft!
> 
> 
> Hello,
> 
> > An interesting solution might be for the caller (and 
> callee) to always offer
> > two alternate media streams (using the FID draft), one of 
> which is with its
> > public address, and another with the private address. If 
> media starts
> > arriving on the private address, it re-invites to disable 
> the stream on the
> > public one. Actually, that is probably the most robust and simplest
> > solution. Not sure FID gives you all the semantics you need 
> for this,
> > though...
> 
> I believe it does. The syntax would look like this:
> 
> a=group:FID 1 2
> m=audio 10000 RTP/AVT 8
> c=IN IP4 123.123.123.123
> a=mid:1
> m=audio 20000 RTP/AVT 8
> c=IN IP4 10.0.0.1
> a=mid:2
> 
> The application would send media to both addresses at the 
> same time (in
> parallel), since both contain codec 8.

I'm confused. My interpretation of the fid spec was that things in the same
group were alternates. So, it would not send to both at the same time. It
would instead choose one, which is not what you want.

-Jonathan R.

---
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
Sip mailing list  http://www.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Gonzalo Camarillo <[email-masked]>
Date: Mon, 06 Aug 2001 18:55:31 +0300

Hello,

Comments inline:

> would instead choose one, which is not what you want.

An application chooses one codec and then sends RTP over all the m lines
that contain that codec.

At the beginning I was assuming that a particular codec would be present
only in one m line. However, you suggested (in an MMUSIC meeting) that
we had to define semantics for this case (when a codec appears in
multiple m lines).

Henning and I finally agreed that this was the "right thing to do".
Version 03 of the draft already defines this behavior, but version 04
(will appear in the archives right after London) provides a more formal
definition (without changing the semantics).

Regards,

Gonzalo

-- 
Gonzalo Camarillo                    Phone :   +1 212 939 71 71
Columbia University                  Mobile:  +358 40 702 35 35
472 Computer Science Building        Fax   :  +358  9 299 30 52
1214 Amsterdam Ave., Mail Code 0401  http://www.hut.fi/~gonzalo
New York, NY 10027                   
USA                              [email-masked]