Subject: [Sip] To and Request URI

From: Timothy SOETENS <[email-masked]>
Date: Thu, 30 Aug 2001 15:21:05 +0200

Hi All,

We are currently working on an implementation of SIP. There is however
an issue we have not been able to resolve. 
Apparently, the routing of SIP messages by a SIP proxy is done entirely
based on the Request URI if no Route header is present. However, I
always had the impression that the To URI indicated the callee, so
routing should be based on the To URI. This raised a couple of
questions:
1. If routing is done based on the Request URI, what is the function of
the To URI? Do intermediate Proxies look at the To URI?
2. If the Proxy determines the Request URI based on the TO URI, why do
we have to include the Request URI in the message?

If it has been discussed before, I am sorry, then please point me to
some relevant documents. Thanks,
-- 
Timothy Soetens
_________________________________________

From the Network Strategy Group @ Alcatel

Tel. +32-3-240.42.11
Fax  +32-3-240.48.88

_______________________________________________
Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Ghai, Rajat (Rajat)" <[email-masked]>
Date: Thu, 30 Aug 2001 17:05:46 -0400

Typically TO & Req URI would be the same when the request originates
(there are cases when this is not true, that's why "typically").
However, at some point, the Req URI will be re-written (mostly towards 
desination) but To will remain unchanged. For example,

TO & Req URI could initiate as  <[email-masked]>

However, once the request reaches "sip.acme.com" proxy, it could
dynamically rewrite the req URI to <[email-masked]>
while TO still points to <[email-masked]>

thanks
Rajat Ghai

> >-----Original Message-----
> >From: Timothy SOETENS [mailto:[email-masked]]
> >Sent: Thursday, August 30, 2001 9:21 AM
> >To: sip mailing list
> >Subject: [Sip] To and Request URI
> >
> >
> >Hi All,
> >