Subject: [Sip] Reduced processing overhead for SIP compression

From: "Price, Richard" <[email-masked]>
Date: Tue, 14 Aug 2001 13:52:40 +0100

Hi,

Now that the ROHC WG is looking at SIP compression between the
mobile and the proxy, I would like to discuss the possibility
of combining a SIP compressor with the SIP stack itself.

A "SIP-aware" compression algorithm such as EPIC performs the
compression by parsing a SIP message, converting text strings
to their Huffman equivalents. If we are performing compression
in the mobile and the SIP proxy then we can miss out the text
phase altogether, writing a SIP stack capable of reading and
outputting Huffman characters directly.

Motivation for combining the SIP compressor with the SIP stack
is that the processing overhead of compression is negligible,
or perhaps even negative (as Huffman characters are shorter
than their text equivalents, so there is less to read/output).

Comments on this suggestion would be appreciated, particularly
to check that it fits with the "protocol shim" for carrying
compressed SIP messages as proposed by Jonathan Rosenberg.

Regards,

Richard P

-------------------------------------------------------------------------
Richard Price
Internet Applications & Mobility
Roke Manor Research Ltd.
Old Salisbury Lane
Romsey, Hants
SO51 0ZN, UK.
Telephone: +44 1794 833681
E-mail: [email-masked]
-------------------------------------------------------------------------

---

From: James Undery <[email-masked]>
Date: Tue, 14 Aug 2001 14:13:13 +0100

> compressed SIP messages as proposed by Jonathan Rosenberg.

My comment would be this is an implementation issue and an obvious (?)
extension, if you make the the shim a "logical shim" for an optimised stack
this would work fine. I'd also note that it doesn't require both ends to make
the same implementation decisions.

James Undery

_______________________________________________
Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Dr. Carsten Bormann" <[email-masked]>
Date: Tue, 14 Aug 2001 15:15:24 +0200

> mobile and the proxy,

Just as a careful wording reminder:
We aren't officially chartered yet to do this.
The WG chairs have seen some "general hallway nods" (can I patent this
term?) from the ADs, but until the charter is written, they can't say "yes".
This shouldn't stop us all from working on this, of course.

> If we are performing compression
> phase altogether

This is an implementation strategy question, not a question about the
interoperability of the standard (or do you think it is a
requirement/nice-to-have on the standard to allow this implementation
strategy?).
The strategy may make sense depending on a lot of factors, including
make-or-buy decisions on the SIP stack.

Gruesse, Carsten

---

From: "Hans Hannu" <[email-masked]>
Date: Tue, 14 Aug 2001 16:37:47 +0200

> outputting Huffman characters directly.

Is this really compression anymore? To be it sounds like making SIP binary.

/Hans H