Subject: RE: [Sip] RE: [rohc] Reduced processing overhead for SIP compress ion

From: "Brian Stucker" <[email-masked]>
Date: Wed, 15 Aug 2001 16:17:28 -0500

Well, except that you've got an installed base of parsers that only
understand the
text encoding for SIP.

Brian

-----Original Message-----
From: Price, Richard [mailto:[email-masked]]
Sent: Tuesday, August 14, 2001 11:00 AM
To: [email-masked]'
Cc: [email-masked]; [email-masked]
Subject: [Sip] RE: [rohc] Reduced processing overhead for SIP
compression

Hi,

Yes, this is still compression because the output of a combined SIP
stack/SIP compressor is identical to the output of a standalone
compressor. Key difference between this and making SIP binary is that
the Huffman binary codes are made up by the compressor and do not
need to be standardized by the SIP WG: thus we avoid all of the
problems synchronizing between the text and binary encodings for SIP.

Regards,

Richard P

-----Original Message-----
From: Hans Hannu [mailto:[email-masked]]
Sent: Tuesday, August 14, 2001 3:38 PM
To: Price, Richard; [email-masked]; [email-masked]
Cc: 'Jonathan Rosenberg'
Subject: RE: [rohc] Reduced processing overhead for SIP compression

> A "SIP-aware" compression algorithm such as EPIC performs the
> compression by parsing a SIP message, converting text strings
> to their Huffman equivalents. If we are performing compression
> in the mobile and the SIP proxy then we can miss out the text
> phase altogether, writing a SIP stack capable of reading and
> outputting Huffman characters directly.

Is this really compression anymore? To be it sounds like making SIP binary.

/Hans H

> 
> Motivation for combining the SIP compressor with the SIP stack
> is that the processing overhead of compression is negligible,
> or perhaps even negative (as Huffman characters are shorter
> than their text equivalents, so there is less to read/output).
> 
> Comments on this suggestion would be appreciated, particularly
> to check that it fits with the "protocol shim" for carrying
> compressed SIP messages as proposed by Jonathan Rosenberg.
> 
> Regards,
> 
> Richard P
> 
> --------------------------------------------------------------
> -----------
> Richard Price
> Internet Applications & Mobility
> Roke Manor Research Ltd.
> Old Salisbury Lane
> Romsey, Hants
> SO51 0ZN, UK.
> Telephone: +44 1794 833681
> E-mail: [email-masked]
> --------------------------------------------------------------
> -----------
>

---

From: "Price, Richard" <[email-masked]>
Date: Thu, 16 Aug 2001 11:26:38 +0100

Hi,

If a combined SIP stack/SIP compressor cannot be used for whatever
reason, then feel free to implement a standalone SIP compressor
instead. The output of the compressor is identical in both cases.

Regards,

Richard P

-----Original Message-----
From: Brian Stucker [mailto:[email-masked]]
Sent: Wednesday, August 15, 2001 10:17 PM
To: Price, Richard; [email-masked]'
Cc: [email-masked]; [email-masked]
Subject: RE: [Sip] RE: [rohc] Reduced processing overhead for SIP compress ion

Well, except that you've got an installed base of parsers that only understand the 
text encoding for SIP. 
Brian 

-----Original Message----- 
From: Price, Richard [mailto:[email-masked]] 
Sent: Tuesday, August 14, 2001 11:00 AM 
To: [email-masked]' 
Cc: [email-masked]; [email-masked] 
Subject: [Sip] RE: [rohc] Reduced processing overhead for SIP 
compression 

Hi,