Subject: [Sip] Some questions on SIP message encryption

From: "Chan Tat (NRC/Boston)" <[email-masked]>
Date: Fri, 24 Aug 2001 10:47:24 -0500

Hi,

I have the following questions regarding encryption of SIP messages and
I hope someone could help.

1. In rfc2543bis03, there are examples for using PGP for end-to-end
encryption. Is there any other encryption scheme defined? One thing
which confused me is that PGP is a collection of many schemes. So, for
instance, if DES is to be used, are we supposed to use DES within PGP?
Is it possible to specify the use of DES without PGP? 

2. In section 18.1.4 of rfc2543bis03 about Hop-by-hop encryption, IPSec
and TLS are mentioned. Does it imply that hop-by-hop encryption will not
be performed in the applicaiton layer (encrypting the whole SIP
message)? 

Thank you very much in advance. Any comments and related discussions are
welcome.

Best Regards,

Tat Chan
Senior Reserach Engineer
Nokia Research Center
NOKIA INC
5 Wayside Road, Burlington, MA 01803
Phone (781) 993-5776, Fax (781) 993-1907
[email-masked]

_______________________________________________
Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Chan Tat (NRC/Boston)" <[email-masked]>
Date: Fri, 24 Aug 2001 14:00:08 -0500

Hi all,

> -----Original Message-----
> From: ext Chan Tat (NRC/Boston) [mailto:[email-masked]]
> Sent: August 24, 2001 11:47 AM
> To: [email-masked]
> Subject: [Sip] Some questions on SIP message encryption
> 
> 
> Hi,
> 

Just to clarify, instead of DES, the example I should have used is CAST,
Triple-DES, or IDEA, which PGP supports.
Are we supposed to use them within PGP? or is it possible to specify
their use without PGP?

Tat Chan
Senior Reserach Engineer
Nokia Research Center
NOKIA INC