Subject: RE: [SIP] Killing hung media streams

From: Jonathan Rosenberg <[email-masked]>
Date: Thu, 30 Aug 2001 23:28:30 -0400

> -----Original Message-----
> From: Brett Tate [mailto:[email-masked]]
> Sent: Wednesday, August 29, 2001 8:39 PM
> To: [email-masked]
> Subject: RE: [SIP] Killing hung media streams
> 
> 
> > >   Why must the UAC send a bye when a 481 is received? I 
> > > thought that the
> > >   481 implies that the call leg is terminated. Section 15.5 
> > > states that
> > >   "A UAC receiving a 481 response for any mid-call request 
> > > (INVITE or otherwise)
> > >   MUST consider the call terminated."
> > 
> > Thats the problem. I think this text is wrong. It should send 
> > a BYE, and
> > then consider the call terminated as a result.
> > 
> > Why? Well, we have a general rule that a non-2xx response to 
> > a re-INVITE
> > does not mean the call is dead. Only BYE terminates a call. 
> > I'd like to keep
> > that rule, since it provides a single, consistent way for 
> everyone to
> > say/know whether the call is up or down.
> > 
> > I feel very strongly about this one. Having multiple ways of 
> > signaling that
> > a call is down is very bad, IMHO.
> 
> I thought that this issue was closed per IETF 49 
> with a 481 meaning that the call-leg is dead; 
> thus no need to send a BYE.
> 
> http://www.softarmor.com/sipwg/meets/ietf49/minutes/minutes-sip-49.htm

Wow... my recollection is exactly the opposite. Possibly thats biased by my
own opinion on the correct solution, but I could have sworn that people
concurred that we were going to stick with the rule that 4xx response to
re-INVITE did not terminate a call.

> 
> I realize that call-stateful proxies might want 
> to avoid snooping for a 481.  However based upon 
> the captured minutes and the hum at the meeting, 
> I assume that many UA's would have to be modified 
> to start sending the BYE for dead call-legs.

Well, someone needs to change. Either UA's change to send BYE, or proxies
and other elements change to support 481 indicated call termination. I
generall prefer pushing intelligence out towards the edge.

Let us definitely resolve this quickly. Please, if you have an opinion,
POST!

-Jonathan R.

---
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Anders Kristensen <[email-masked]>
Date: Fri, 31 Aug 2001 00:08:19 -0400

> Let us definitely resolve this quickly. Please, if you have an opinion,

Seems more regular to insist on having UACs always send BYE. Consider
this a HUM in favor of that approach. Hummmm.

Anders

---

From: Vijay Gurbani <[email-masked]>
Date: Fri, 31 Aug 2001 10:01:29 -0500

[...]
> Wow... my recollection is exactly the opposite. Possibly thats biased by 
> my own opinion on the correct solution, but I could have sworn that people

Jonathan:

I recall having a similar discussion with you on the list in the context of 
the call reconstitution I-D.  The gist of the discussion is that the BYE is
is needed.  Going into the discussion I was unsure why this is so, but have
changed my mind since then.  

The reasons why BYE is preferred are listed in 
http://www1.ietf.org/mail-archive/working-groups/sip/current/msg00559.html

- vijay
-- 
Vijay K. Gurbani  vkg@{lucent.com,research.bell-labs.com,acm.org}
Internet Software and eServices Group 
Lucent Technologies/Bell Labs Innovations, 2000 Lucent Lane, Rm 6G-440
Naperville, Illinois 60566     Voice: +1 630 224 0216   Fax: +1 630 713 0184