Subject: RE: [Sip] I-D ACTION:draft-rosenberg-rohc-sip-udpcomp-00.txt

From: Romeo Zwart <[email-masked]>
Date: Tue, 14 Aug 2001 16:36:31 +0200

Coming back from vacation I see a lot of water has passed under
the bridge on this topic.  One minor question remains, please see
below.

At 11:38 PM 7/30/2001, Jonathan Rosenberg wrote:
> > -----Original Message-----
> > From: Romeo Zwart [mailto:[email-masked]]
> > Sent: Thursday, July 19, 2001 3:27 PM
> > To: [email-masked]
> > Cc: [email-masked]; [email-masked]
> > Subject: Re: [Sip] I-D ACTION:draft-rosenberg-rohc-sip-udpcomp-00.txt
> >
> > Jonathan,
> >
> > In the diagram of section 4.6, the WRITE HIGH REFERENCE token
> > is shown as
> > identical to the WRITE HIGH token. I assume this is a typo.
> > What is the
> > intended token for the WRITE HIGH REFERENCE case?
>
>No, they're not the same. The WRITE HIGH REFERECE appears on the top of page
>9. So, WRITE REFERENCE is:
>
>    +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
>    |1|   index     |1|1|0|   TC    | tokens..
>    +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
>
>and WRITE HIGH REFERENCE is:
>
>    +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
>    |1|   index     |0|1|1| index   |x|x|x|   TC    |  tokens
>    +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

Right, whereas, in section 4.4 WRITE HIGH is also shown as:

4.4 WRITE HIGH
    +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
    |1|   index     |0|1|1| index   |   length      |  entry...
    +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

One of these has to be a typo, right?

Romeo

_______________________________________________
Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 21 Aug 2001 17:01:16 -0400

> Sent: Tuesday, August 14, 2001 10:37 AM
> To: Jonathan Rosenberg
> Subject: RE: [Sip] I-D ACTION:draft-rosenberg-rohc-sip-udpcomp-00.txt
> 
> 
> > > Subject: Re: [Sip] I-D 
> ACTION:draft-rosenberg-rohc-sip-udpcomp-00.txt
> > >
> > > Jonathan,
> > >

Write high and write high reference are not the same. Write high reference
creates a new codebook entry by concatenating existing entries. Write high
simply creates a new one from the enclosed text.

-Jonathan R.

---
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com