Subject: RE: [Sip] VIA Header

From: Wai Wu <[email-masked]>
Date: Wed, 8 Aug 2001 09:29:44 -0400

Hi Christer,
	The Cisco Sip implementation (at least for their IP phones, the ones
I am working on are CISCO IP PHONE 7960/7940s) puts values from all the VIA
headers in a single header, separated with a comma.

Wai Wu

-----Original Message-----
From: Christer Holmberg [mailto:[email-masked]]
Sent: Wednesday, August 08, 2001 5:57 AM
To: Mukesh R Shah
Cc: [email-masked]
Subject: Re: [Sip] VIA Header

Hi Mukesh,

I am not really sure I understand your question, but I'll give it a try.

In SIP you can have multiple VIA headers. The ABNF, however, also allow
you to put all the values of those headers in a single header, separated
with a comma. I don't think I've ever seen it in real-world use, but it
is allowed.

Regards,

Christer Holmberg
Ericsson Finland

Mukesh R Shah wrote:
> 
> Hi All,
> 
> Its a basic doubt .
> Why r we having multiple values in VIA header ?
> What is the significance of having it?
> Also give situation when the proxy will add multiple value to VIA header?
> 
> Thanks in Advance,
> Mukesh
> 
>   ------------------------------------------------------------------------
>                                Name: InterScan_Disclaimer.txt
>    InterScan_Disclaimer.txt    Type: Plain Text (text/plain)
>                            Encoding: 7bit

---

From: "Mukesh R Shah" <[email-masked]>
Date: Wed, 8 Aug 2001 19:34:35 +0530

RE: [Sip] VIA Headerhi,

But i dont think any proxy adds two VIA header value at a time.
Am i right ?
i think putting of all VIA values in single VIA header might be taking place
at the last proxy server or UAS ?

Thanks,
Mukesh
  -----Original Message-----
  From: [email-masked] [mailto:[email-masked]]On Behalf Of Wai Wu
  Sent: Wednesday, August 08, 2001 7:00 PM
  To: [email-masked]
  Subject: RE: [Sip] VIA Header

  Hi Christer,
          The Cisco Sip implementation (at least for their IP phones, the
ones I am working on are CISCO IP PHONE 7960/7940s) puts values from all the
VIA headers in a single header, separated with a comma.

  Wai Wu

  -----Original Message-----
  From: Christer Holmberg [mailto:[email-masked]]
  Sent: Wednesday, August 08, 2001 5:57 AM
  To: Mukesh R Shah
  Cc: [email-masked]
  Subject: Re: [Sip] VIA Header

  Hi Mukesh,

  Regards,

  Christer Holmberg
  Ericsson Finland

---

From: Christer Holmberg <[email-masked]>
Date: Wed, 08 Aug 2001 17:08:48 +0300

Hi Mukesh,

>But i dont think any proxy adds two VIA header value at a time.

Yes.

>i think putting of all VIA values in single VIA header might be taking
>place at the last proxy server or UAS ?

I think it can take place at anywhere.

Regards,

Christer Holmberg
Ericsson Finland

>              The Cisco Sip implementation (at least for their IP
>      phones, the ones I am working on are CISCO IP PHONE
>      7960/7940s) puts values from all the VIA headers in a single
>      header, separated with a comma.
> 
>      Wai Wu
> 
>      From: Christer Holmberg
>      [mailto:[email-masked]]