Subject: RE: [Sip] Re-use of Call-ID in the SIP Replaces header

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 1 Aug 2001 02:14:36 -0400

> -----Original Message-----
> From: Billy Biggs [mailto:[email-masked]]
> Sent: Tuesday, July 31, 2001 10:36 AM
> To: Jonathan Cumming
> Cc: SIP List
> Subject: Re: [Sip] Re-use of Call-ID in the SIP Replaces header
> 
> 
> Jonathan Cumming ([email-masked]):
> 
> > In section 2.2 of draft-biggs-sip-replaces-01, you specify that "A
> > unique call-id may be given to the replacement call.".  This seems
> > unnecessarily weak and could lead to interoperability problems where
> > an application assumes the re-use of the Call-ID.
> > 
> > If a unique Call-ID is required, as specified in RFC 2543, then why
> > give the end-point the option to re-use the existing Call-ID?
> 
>   When we were first discussing methods of performing attended call
> transfer, there was alot of discussion about using the Call-ID to
> perform the replaces operation, that is, the replacement call (or
> joining call) would be identified by having the same Call-ID as an
> existing call.
> 
>   So, the text should really read "in our replaces model, a unique
> call-id may be given to the replacement call, instead of 
> previous models
> which overloaded the meaning of the call-id".  I wasn't trying to
> dictate behavior either way.

"may" is not strong enough. I think the consensus was to continue to have
call-ids be unique, in which case the replacement call MUST use a new
call-id.

-Jonathan R.
---
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
Sip mailing list  http://www.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Billy Biggs <[email-masked]>
Date: Tue, 31 Jul 2001 10:35:41 -0400

So, the text should really read "in our replaces model, a unique
call-id may be given to the replacement call, instead of previous models
which overloaded the meaning of the call-id".  I wasn't trying to
dictate behavior either way.

> I suggest that "A unique call-id MUST be given to the replacement
> call".

  Since this seems to be the modern consensus on the issue, I will
clarify this in the draft.

-- 
Billy Biggs                     [email-masked]
http://www.billybiggs.com/      [email-masked]