Subject: RE: [Sip] Re: SDP hold

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 22 Aug 2001 14:29:30 -0400

So, here is an important question on the inactive attribute. If a stream is
inactive, is RTCP sent? I think it probably should, actually... RTCP helps
to keep state alive in various places, and this session is still alive, just
suspended.

THoughts?

-Jonathan R.

---
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

> -----Original Message-----
> From: Colin Perkins [mailto:[email-masked]]
> Sent: Wednesday, August 15, 2001 5:30 AM
> To: Gonzalo Camarillo
> Cc: Jonathan Rosenberg; [email-masked]; mmusic
> Subject: Re: [Sip] Re: SDP hold 
> 
> >a=inactive
> >    This specifies that the tools should be started in inactive
> >    mode.  This is necessary for interactive conferences 
> where users can
> >put other users on hold. No media is sent over an inactive 
> media stream.
> >It can be either a session or media attribute, and is not 
> dependent on
> >charset.

_______________________________________________
Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 22 Aug 2001 19:54:24 -0400

> to keep state alive in various places, and this session is still alive, just

The introduction of a=inactive in some sense supercedes the old
c=0.0.0.0 for hold. But the potential for saying c=0.0.0.0 remains,
probably must remain for backward compatibility, and is still useful
even with a=inactive. It is appropriate when you simply don't have an
address to offer, as might often come about in an invite-on-hold
situation.

So, obviously if you say both a=inactive and c=0.0.0.0 then RTCP ought
not (can't) be sent.

If a=inactive and c= a valid address, then perhaps it makes sense to
send RTCP, but I am not sure. There will certainly be cases when it
isn't feasible to send it - a call controller that invites on hold in
anticipation of a reinvite may not have a media implementation available
with which to send to the other end.

	Paul Kyzivat
	Cisco Systems

---

From: "David R. Oran" <[email-masked]>
Date: Mon, 27 Aug 2001 17:43:26 -0400

I sure think RTCP should be sent.

Dave.

> From: [email-masked] [mailto:[email-masked]] 
> On Behalf Of Jonathan Rosenberg
> Sent: Wednesday, August 22, 2001 2:30 PM
> To: 'Colin Perkins'; Gonzalo Camarillo
> Subject: RE: [Sip] Re: SDP hold 
> 
> 
> So, here is an important question on the inactive attribute. 
> If a stream is inactive, is RTCP sent? I think it probably 
> should, actually... RTCP helps to keep state alive in various 
> places, and this session is still alive, just suspended.
> 
> THoughts?
> 
> -Jonathan R.
> 
> 
> ---