Subject: [Sip] DHCP option for SIP server

From: Martin Stiemerling <[email-masked]>
Date: Wed, 01 Aug 2001 18:02:57 +0200

Hello,

I'm currently working on DHCPv6 and I'm interested in one option
proposed by Schulzrinne and Nair for DHCP (draft-ietf-sip-dhcp-04.txt).
It is the DHCP Option for SIP Servers and it looks like this:

 Code  Len      DNS name of SIP server
+-----+-----+-----+-----+-----+-----+-----+--
| TBD |  n  | s1  | s2  | s3  | s4  | s5  |  ...
+-----+-----+-----+-----+-----+-----+-----+--

As far as I see, is this option only for IPv4 (due to that code and len
are only 8 bit long and in DHCPv6 these both are 16 bit). Is there any
plan to make an option for DHCPv6?

With best regards
Martin Stiemerling

-- 
***************************************************
Martin Stiemerling 
NEC Europe Ltd.         Network Laboratories Europe
Fon: +49 6221 90511 13  Fax: +49 6221 90511 55

_______________________________________________
Sip mailing list  http://www.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Henning G. Schulzrinne" <[email-masked]>
Date: Wed, 01 Aug 2001 13:24:29 -0400

> It is the DHCP Option for SIP Servers and it looks like this:

Well, we first have to get this sorry topic through the IESG...

>  Code  Len      DNS name of SIP server

No plan, but would be a good idea. Are you volunteering?
-- 
Henning Schulzrinne   http://www.cs.columbia.edu/~hgs

---

From: Martin Stiemerling <[email-masked]>
Date: Thu, 02 Aug 2001 11:29:51 +0200

"Henning G. Schulzrinne" wrote:
[...]
> No plan, but would be a good idea. Are you volunteering?

Yes, I do.