Subject: RE: [Sip] Issue #113, wrt Content Sequencing

From: "Petri K. Koskelainen" <[email-masked]>
Date: Thu, 23 Aug 2001 10:42:03 -0400 (EDT)

Hi,

There are at least some use cases for that.

For example, group messaging where large number
of clients are sending (sessionless) instant MESSAGES 
to the group address in a server which generates new 
MESSAGEs to all group members. 
It makes no sense to wait until previous MESSAGE has been
acknowledged since it takes too long. So, there will be 
overlapping MESSAGEs.

The actual application may be e.g. instant message group,
game or whatever sessionless application.

In some applications (like games) it would be really useful
to have the ordering (sequencing) information of the MESSAGEs.
For more description and reasoning see
http://search.ietf.org/internet-drafts/draft-koskelainen-sip-group-00.txt

This feature would be enabled by a new header (set by the group server
in the example above). 

In a similar application, this feature would be useful also
between two endpoints.

--
Petri

> -----Original Message-----
> From: Eric Burger [mailto:[email-masked]]
> Sent: Tuesday, August 07, 2001 6:14 AM
> To: SIP List
> Subject: [Sip] Issue #113, wrt Content Sequencing
> 
> 
> On the one hand, I would love to find a generic mechanism for 
> ordering and
> detecting loss in overlapped non-INVITE content.  However, we 
> hashed over
> this issue in the SIP-events discussion.  Namely, content 
> sequencing and
> recovery is inherently content-specific.  Thus I would propose Strict
> Sequencing (if needed) in the content, as Jonathan originally 
> proposed.

I think the first question we need to ask is whether we even want to solve
the problem of overlapping non-INVITE. 

One of the bigger motivating factors was the MESSAGE method. However, simple
has converged upon NOT using MESSAGE for message transport in the session
model. As a result, that need has disappeared.

Are there other burning needs? This is one of those things where there may
not be a need now, but it could be a big issue down the road when someone
comes up with a need.

Notifications for rapid presence changes, like second-granularity geo-loc
updates, might be a need.

A more radical view is that if you want second-granular presence updates,
you are better off setting up the notifications as a "media stream" as we
are doing for IM, and use just SUBSCRIBE as is to set it up....

THoughts? Lets resolve this.

-Jonathan R.

_______________________________________________
Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: James Undery <[email-masked]>
Date: Thu, 23 Aug 2001 16:50:34 +0100

> acknowledged since it takes too long. So, there will be

I think you're confusing overlapping, in this example the resolution of
the overlapping messages is a service in the server. i.e. the server
recieves a message from A and sends it to all the recipients, all apart
from B acknowledge, C then sends a message, the server sends it to every
one apart from B, A sends another message, which again goes out to every
one except B, when B acknowledges the first message, he gets sent the
second message etc.

> > http://search.ietf.org/internet-drafts/draft-koskelainen-sip-group-

If I was writting a game, I am not sure reliability and any ordering
other strictly increasing would be an issue!

> In a similar application, this feature would be useful also

I'd vote no, the only cases I can think of where it would be needed, SIP
is inappropriate or it's a service issue.

> are doing for IM, and use just SUBSCRIBE as is to set it up....

I agree. I thought the consensus at Minneapolis was that sub/not wasn't
a suitable mechanism for rapid updates, something like an RTP payload
was more appropriate.

James Undery