Subject: RE: [Sip] Question about SIP bis04

From: "Chen, Xin (Xin)" <[email-masked]>
Date: Thu, 16 Aug 2001 20:06:23 +0100

I think this is not the reason, because the original re-INVITE is sent by
UAC not UAS.

Xin Chen

Lucent Technologies
Tel: +44 1793 883137
Mobile: +44 7799 034668

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: 16 August 2001 19:01
To: [email-masked]
Subject: Re: [Sip] Question about SIP bis04

I think in order to re-negotiate the session. The 2xx message itself or the
ACK could have been lost. Since we can not know what have been lost, the
negotiation should start from the beginning.

Please correct me if I am wrong.

--Avshalom

                    "Chen, Xin

                    (Xin)"               To:     "[email-masked]'"
<[email-masked]>                                   
                    <xchen2@lucen        cc:

                    t.com>               Subject:     [Sip] Question about
SIP bis04                               
                    Sent by:

                    sip-admin@iet

                    f.org

                    16/08/2001

                    16:57

Could someone please explain to me:

           15.4 If a UAS never receives an ACK for a 2xx response to a
re-INVITE, it SHOULD generate a re-INVITE
           itself in order to synchronize the state of the session.

What does this description mean? If UAS needs a ACK, why it has to generate
a re-INVITE?

Thanks and Regards

Xin Chen

Lucent Technologies
Tel: +44 1793 883137
Mobile: +44 7799 034668

_______________________________________________
Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

_______________________________________________
Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

_______________________________________________
Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: [email-masked]
Date: Thu, 16 Aug 2001 22:01:13 +0300

--Avshalom

                    "Chen, Xin                                                                                     
                    (Xin)"               To:     "[email-masked]'" <[email-masked]>                                   
                    <xchen2@lucen        cc:                                                                       
                    t.com>               Subject:     [Sip] Question about SIP bis04                               
                    Sent by:                                                                                       
                    sip-admin@iet                                                                                  
                    f.org                                                                                          

                    16/08/2001                                                                                     
                    16:57                                                                                          

Thanks and Regards

Xin Chen

Lucent Technologies
Tel: +44 1793 883137
Mobile: +44 7799 034668

---

From: "Chen, Xin (Xin)" <[email-masked]>
Date: Thu, 16 Aug 2001 20:11:20 +0100

Thanks, I understand your explaination. But why Bis04 says that this is to
synchronize the state of the session? Maybe some other reason as well.

Xin Chen

Lucent Technologies
Tel: +44 1793 883137
Mobile: +44 7799 034668

-----Original Message-----
From: Bert Culpepper [mailto:[email-masked]]
Sent: 16 August 2001 19:06
To: 'Chen, Xin (Xin)'; [email-masked]
Subject: RE: [Sip] Question about SIP bis04

Well, one use of a re-INVITE is to change the media characteristics of
an existing session.  So if a UAS never gets acknowledgement of its
response (times out waiting for the ACK), it can (SHOULD) assume the
transaction failed and continue with the media that existed prior to the
re-INVITE.  But, the other end has already changed presumably to match
its re-INVITE and it may have even received the 200 from the UAS in
which case it did change its media, leading to a "failed call" situation
(UAC using new media and UAS using old media).  The text you ask about
describes a fall-back procedure for the UAS to "recover" the call.  The
UAC is not aware of the problem with the UAS receiving its ACK.

regards,
Bert

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Chen,
Xin (Xin)
Sent: Thursday, August 16, 2001 9:58 AM
To: [email-masked]'
Subject: [Sip] Question about SIP bis04

What does this description mean? If UAS needs a ACK, why it has to
generate
a re-INVITE?

Thanks and Regards

Xin Chen

Lucent Technologies
Tel: +44 1793 883137
Mobile: +44 7799 034668

---

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 22 Aug 2001 01:12:12 -0400

> Sent: Tuesday, August 21, 2001 10:42 AM
> To: 'Michel de Boer'
> Cc: 'Chen, Xin (Xin)'; [email-masked]
> Hi,
> I agree with you that subsequent signaling transactions are likely to
> fail under network conditions that resulted in the ACK never 
> arriving at
> the UAS.  However, there may be situations in which a re-INVITE in the
> reverse direction may succeed.  There are also other uses of 
> re-INVITE,
> such as session-timer, that the procedure described can add value to.
> Others more experienced with SIP than myself can better provide the
> motivation behind the text asked about.

Failures can happen for all kinds of reasons. Some will be recoverable, some
won't. The idea here is to apply a general recovery mechanism, which
involves sending a re-INVITE to achieve agreement on call state and on the
current SDP in use for the call. If the re-INVITE doesn't generate any
response, a BYE is sent (which may not generate a response either, but at
least lets intermediate proxies and other things know the change in call
state). 

> 
> I suppose the authors feel it is better to attempt (at least once) to
> recover the session instead of dropping it right away.  I myself
> interpret the text asked about as exhibiting this philosophy, 
> with which
> I agree.  I also suspect this is the "best" approach for all uses of
> re-INVITE, and is preferable to defining a procedure for each case.

Yes, that is a good point. Right now, there is no general place to put it..

-Jonathan R.

---
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com