Subject: RE: [SIP] Killing hung media streams

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 22 Aug 2001 17:41:09 -0400

> -----Original Message-----
> From: Doug Hurtig [mailto:[email-masked]]
> Sent: Wednesday, August 22, 2001 5:44 PM
> To: [email-masked]
> Subject: RE: [SIP] Killing hung media streams
> 
> 
> Hi,
> 
>   Why must the UAC send a bye when a 481 is received? I 
> thought that the
>   481 implies that the call leg is terminated. Section 15.5 
> states that
>   "A UAC receiving a 481 response for any mid-call request 
> (INVITE or otherwise)
>   MUST consider the call terminated."

Thats the problem. I think this text is wrong. It should send a BYE, and
then consider the call terminated as a result.

Why? Well, we have a general rule that a non-2xx response to a re-INVITE
does not mean the call is dead. Only BYE terminates a call. I'd like to keep
that rule, since it provides a single, consistent way for everyone to
say/know whether the call is up or down.

I feel very strongly about this one. Having multiple ways of signaling that
a call is down is very bad, IMHO.

-Jonathan R.

---
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Brett Tate" <[email-masked]>
Date: Wed, 29 Aug 2001 20:39:19 -0400

> a call is down is very bad, IMHO.

I thought that this issue was closed per IETF 49 
with a 481 meaning that the call-leg is dead; 
thus no need to send a BYE.

http://www.softarmor.com/sipwg/meets/ietf49/minutes/minutes-sip-49.htm

I realize that call-stateful proxies might want 
to avoid snooping for a 481.  However based upon 
the captured minutes and the hum at the meeting, 
I assume that many UA's would have to be modified 
to start sending the BYE for dead call-legs.

No matter the decision, hopefully we can close 
this issue permanently this time. :)