Subject: RE: [Sip] Open Issue #58: Rejected mid-call SDP in 2xx

From: "Brett Tate" <[email-masked]>
Date: Tue, 2 Oct 2001 17:40:06 -0400

> So, if the UAS receives a re-INVITE w/o SDP, 
> and then also receives an
> ACK w/o SDP, what does it do? For the initial 
> INVITE, it probably releases the call, 
> because it's a protocol error. Does the UAS do the
> same here, or should it assume that the UAC SDP 
> has not changed?

Assuming a 2xx response was sent from UAS, 
it is a protocol error per rfc2543bis-04.  
The resulting action is undefined. 

Once the offer/answer SDP usage is split 
into a separate draft, I assume that the 
resulting action will remain undefined to 
avoid constantly defining how devices 
should handle each and every protocol 
violation.

With that said, I assume most devices 
will release the call.  Others might 
assume the SDP hasn't changed.  Others 
will trigger a reinvite with SDP to 
obtain the protocol violators SDP.

_______________________________________________
Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Christer Holmberg <[email-masked]>
Date: Wed, 03 Oct 2001 08:32:17 +0300

Hi Brett,

>obtain the protocol violators SDP.

I guess using a re-INVITE is also one of the options if the UAS doesn't
accept the SDP in the ACK?

Regards,

Christer Holmberg
Ericsson Finland

---

From: Christer Holmberg <[email-masked]>
Date: Wed, 03 Oct 2001 09:19:17 +0300

Hi,

Another question related to this SDP-in-the-ACK issue.

Again, assume that the UAS receives a re-INVITE w/o SDP. It sends back
200 OK with its original SDP. This far, everything is fine.

Then the UAC MUST send its SDP in the ACK. Again, if the UAS accepts it
everything is fine.

In a previous mail, I asked about what the UAS shall do if it does not
accept the SDP in the ACK. The reason the UAS doesn't accept it may be
because it simply doesn't have resources. 

Then, if we have a scenario (someone mentioned some 3pcc cases) where
the SDP must be sent in the ACK, how does the UAC ADD streams in those
cases?
I assume that the number of m= lines in the ACK must match the number in
the 200 OK from the UAS, so the UAC is not allowed to add more streams
in the ACK SDP.

And, IF the UAC would be allowed to do that, how does the UAS then send
back a SDP with a new SDP, where the new m= line is also matched? Using
re-INVITE???

Regards,

Christer Holmberg
Ericsson Finland

A similar case is if the SDP in the ACK contains NEW m= lines. I would
say that is a protocol error