Subject: RE: [Sip] Call-Info: header

From: "Sean Olson (EUS)" <[email-masked]>
Date: Wed, 17 Oct 2001 09:52:03 -0500

>Hi,
>
>I for one would oppose this for use with REGISTER as it is bad enough
>without using it to upload scripts, a separate method like PUBLISH
>proposed by Steve Donovan is better.

I agree entirely. I am not trying to solve the PUBLISH problem (as
I understand it). I would expect this header really only to be
used in the INVITE and 200 OK. (Possibly the ACK as well, but that
would be a stretch). This is really meant to be used in the context
of distributed application components where you are trying to 
convey a URL for a script that a component needs to perform its job.
Make sense?

>
>As for the matter of sending URLs in other methods I'd prefer a
>different syntax purely to escape the REGISTER heritage.

A different syntax than a URL? Or a different syntax than the Call-Info:
header? 

>James

/sean

>-----Original Message-----
>From: [email-masked] [mailto:[email-masked]]On Behalf Of Sean
>Olson (EUS)
>Sent: 16 October 2001 19:18
>To: [email-masked]'
>Subject: [Sip] Call-Info: header
>
>
>Hi,
>I'm sure this has been discussed before. I don't
>want to re-open a discussion if a conclusion has
>been made. In draft-lennox-sip-reg-payload-01.txt,
>it was proposed to extend the list of disposition-types for
>the Content-Disposition: header to include "script".
>I would like to make a similar proposal to extend
>the list of "purpose" tokens for Call-Info: to include
>script. The Call-Info: header could then contain a
>URL to something like a vxml script which could be
>optionally processed by the receiving party.
>Because the current syntax allows a token for this
>parameter, there isn't technically a need to standardize
>this, but I was wondering if there were strong opinions
>either way about including this in the bis draft?
>Regards,
>Sean Olson
>Ericsson Inc.
>

---

From: "James Undery" <[email-masked]>
Date: Wed, 17 Oct 2001 16:22:22 +0100

Hi,

The problem here is related though, the awkwardness is for the case
when the Request partially succeeded, i.e. The INVITE is fine, but I
didn't like the script. Do you 4xx the request and how do you indicate
the cause in a consistent manner (Warning headers are more aimed at
presentation of errors to a user). If you just ignore failed scripts I
don't think you'll have the effect you desire. Unfortunately I can't
think of a constructive suggestion to implement the functionality
you're after in a way that'd make me happy.

I meant the Call-Info parameter, but on reflection, as it's a
different header I can't see what I was worried about.

James

-----Original Message-----
From: Sean Olson (EUS) [mailto:[email-masked]]
Sent: 17 October 2001 15:52
To: 'James Undery'; [email-masked]
Subject: RE: [Sip] Call-Info: header

>different syntax purely to escape the REGISTER heritage.
A different syntax than a URL? Or a different syntax than the
Call-Info:
header?
/sean
>either way about including this in the bis draft?

_______________________________________________
Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip