Subject: [Sip] Call-Info: header

From: "Sean Olson (EUS)" <[email-masked]>
Date: Tue, 16 Oct 2001 13:17:45 -0500

Hi,

I'm sure this has been discussed before. I don't
want to re-open a discussion if a conclusion has
been made. In draft-lennox-sip-reg-payload-01.txt,
it was proposed to extend the list of disposition-types for
the Content-Disposition: header to include "script".
I would like to make a similar proposal to extend
the list of "purpose" tokens for Call-Info: to include
script. The Call-Info: header could then contain a
URL to something like a vxml script which could be
optionally processed by the receiving party. 

Because the current syntax allows a token for this
parameter, there isn't technically a need to standardize
this, but I was wondering if there were strong opinions
either way about including this in the bis draft?

Regards,
Sean Olson
Ericsson Inc.

---

From: "James Undery" <[email-masked]>
Date: Wed, 17 Oct 2001 09:04:24 +0100

Hi,

I for one would oppose this for use with REGISTER as it is bad enough
without using it to upload scripts, a separate method like PUBLISH
proposed by Steve Donovan is better.

As for the matter of sending URLs in other methods I'd prefer a
different syntax purely to escape the REGISTER heritage.

James

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Sean
Olson (EUS)
Sent: 16 October 2001 19:18
To: [email-masked]'
Subject: [Sip] Call-Info: header

Hi,

_______________________________________________
Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip