Subject: RE: [Sip] SDP in 200 OK for INVITE and preconditions

From: "James Undery" <[email-masked]>
Date: Thu, 11 Oct 2001 13:14:30 +0100

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On
> Behalf Of William
> Marshall
> Sent: 11 October 2001 13:07
> To: [email-masked]
> Subject: Re: [Sip] SDP in 200 OK for INVITE and preconditions
>
>
> There is an issue here with document dependencies, and I really
> don't want manyfolks to have a dependency on bis...

As I said in my last call comment I believe it does, because it
mentions Record Route which never worked (or was even implemented
properly) to my knowledge.

James

> RFC2543 essentially allows SDP anywhere, which led to the
> bis wording.
> But in the end, I believe the following is the resulting set of
> MUSTs and options for SDP with manyfolks+bis:
>
> case 1:		SDP in INVITE
> 		SDP in 183
> 		optional SDP in PRACK
> 		SDP in COMET (if COMET is requested)
> 		SDP in 200
>
> case 2:		SDP in 183
> 		SDP in PRACK
> 		SDP in COMET (if COMET is requested)
> 		SDP in 200
> 		SDP in ACK
>
> The need for the SDP in case#1 in the 200-OK was discussed on the
> last earlier this year, and concluded to keep it.  Though the
> SDP in 200/ACK in case#2 wasn't discussed, the reasoning seems
> the same - uniformity with cases that don't use manyfolks.
>
> I agree that some wording should be added to manyfolks to relate
> the SDP in the 200 to the SDP in 183.  Likewise for case#2, the
> SDP in ACK needs to be related to the SDP in PRACK.
>
> Bill Marshall
> [email-masked]
>
> -----original message-----
> Date: Thu, 11 Oct 2001 11:17:17 +0300
> From: "Miguel A. Garcia" <[email-masked]>
> To: [email-masked]
> Subject: SDP in 200 OK for INVITE and preconditions
>
> Hi:
>
> I would like to get some advice on an issue that has been
> recently pointed out.
>
> The 2543bis says clearly that the 200 OK for an INVITE must
> contain SDP. SDP is present in INVITE and 200 OK or in 200
> OK and ACK, but always in 200 OK.
>
> However, if preconditions are used (manyfolks), the SDP is
> already known by both parties before the 200 OK, usually in
> INVITE and 183. As such, one may think if the SDP is still
> needed in 200 OK for the INVITE when preconditions are used.
>
> I checked out the manyfolks draft, and currently it is
> stated that the 200 OK for the INVITE is a "normal" one. By
> "normal" one I understand that it must contain SDP.
>
> needed, as the signaling may have traversed a few proxies
> that depend on the SDP in the 200 OK for whatever reasons
> (opening holes in a firewall or whatever).
>
> I would like to clarify if the SDP in the 200 OK for an
> INVITE is needed when preconditions are used. And I would
> like to identify scenarios where it might be needed.
>
> n negotiation is sent to the trash can).
>
> /Miguel
>
> _______________________________________________
> Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip

_______________________________________________
Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: William Marshall <[email-masked]>
Date: Thu, 11 Oct 2001 08:06:51 -0400 (EDT)

RFC2543 essentially allows SDP anywhere, which led to the bis wording.
But in the end, I believe the following is the resulting set of
MUSTs and options for SDP with manyfolks+bis:

case 1:		SDP in INVITE
		SDP in 183
		optional SDP in PRACK

case 2:		SDP in 183
		SDP in PRACK

Bill Marshall
[email-masked]

-----original message-----
Date: Thu, 11 Oct 2001 11:17:17 +0300
From: "Miguel A. Garcia" <[email-masked]>
To: [email-masked]
Subject: SDP in 200 OK for INVITE and preconditions

Hi:

I would like to get some advice on an issue that has been recently pointed out.

The 2543bis says clearly that the 200 OK for an INVITE must contain SDP. SDP is present in INVITE and 200 OK or in 200 OK and ACK, but always in 200 OK.

However, if preconditions are used (manyfolks), the SDP is already known by both parties before the 200 OK, usually in INVITE and 183. As such, one may think if the SDP is still needed in 200 OK for the INVITE when preconditions are used.

I checked out the manyfolks draft, and currently it is stated that the 200 OK for the INVITE is a "normal" one. By "normal" one I understand that it must contain SDP.

needed, as the signaling may have traversed a few proxies that depend on the SDP in the 200 OK for whatever reasons (opening holes in a firewall or whatever).

I would like to clarify if the SDP in the 200 OK for an INVITE is needed when preconditions are used. And I would like to identify scenarios where it might be needed.

/Miguel