Subject: [Sip] Another proxy-waiting-for-final-response case

From: Christer Holmberg <[email-masked]>
Date: Wed, 31 Oct 2001 09:16:07 +0200

Hi,

Consider the following scenario:

         |------- UAS 1
         |
UAC --- P1------- UAS 2
         |
         |------- UAS 3

Then:

1. UAC sends an INVITE, which gets forked to UAS 1, 2 and 3.

2. UAS 1 sends an 4xx response, which P1 "collects".

3. UAS 2 and UAS 3 both send 18x provisional responses (including To
header tags), which are forwarded by P1 to the UAC.

4. The UAC wants to terminate the leg with UAS 3, so it sends BYE.

5. UAS 3 sends 200 for the BYE and 487 for the INVITE. Now, P1 forwards
the 200 to the UAC, but it "collects" the 487.

6. UAS 2 sends 200 for the INVITE, and P1 now forwards that to the UAC,
and the call is established.

I guess this all works fine, but the point I want to make is that the
UAC will never receive a 487 for the leg it terminated. Or?

Regards,

Christer Holmberg
Ericsson Finland

_______________________________________________
Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "A Venkatraman" <[email-masked]>
Date: Wed, 31 Oct 2001 10:59:04 -0600

Christer
This case is no different from the following case -
P1 forks to 2 UASes.
P1 forwards 18x from 2 UASes back to the UAC.
UAS1 sends 200, UAS2 sends 500 Internal Error
P1 forwards only 200 response to UAC.
UAC will never see the 500.
How is UAC going to clean up the forked "leg"  for which a final response
was never received?

This is implementation-specific to the UAC.
For example, UAC may run a timer for the duration it will expect responses
on forked legs.

 -----Original Message-----
From: 	[email-masked] [mailto:[email-masked]]  On Behalf Of Christer
Holmberg
Sent:	Wednesday, October 31, 2001 1:16 AM
To:	[email-masked]
Subject:	[Sip] Another proxy-waiting-for-final-response case

Hi,

         |------- UAS 1
         |
UAC --- P1------- UAS 2
         |
         |------- UAS 3

Then:

Regards,

Christer Holmberg
Ericsson Finland