Subject: RE: [Sip] Bis-05 question: CANCEL

From: "Shan Lu" <[email-masked]>
Date: Wed, 31 Oct 2001 09:47:38 -0500

Hi,

> -----Original Message-----
> From: Gonzalo Camarillo [mailto:[email-masked]] 
> Sent: Tuesday, October 30, 2001 7:34 PM
> To: Shan Lu
> Subject: Re: [Sip] Bis-05 question: CANCEL
> 
> 
> Hello,
> 
> Shan Lu wrote:
> 
> > Why can't BYE be sent for an early dialog to terminate the dialog?
> 
> Because nobody ensures you that the UAS will send you provisional
> responses. Therefore, if no early dialog is created, the UAC 
> would have
> to store state "for ever", if the 200 OK for the INVITE takes 
> very long.
> 
> Remember that it is possible to establish a dialog without a previous
> early dialog.
> 

Agreed. Then I don't understand how waiting-for-1xx-then-CANCEL rule
helps you in this scenario. You will never receive 1xx and therefore you
never CANCEL and UAC will have to store state forever or till final
response arrives.

Regards,

Shan Lu
sentitO Networks

_______________________________________________
Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Gonzalo Camarillo <[email-masked]>
Date: Wed, 31 Oct 2001 17:27:12 +0200

Hi,

inline:

> never CANCEL and UAC will have to store state forever or till final

Remember that 100 Trying responses are different than other 2xx
responses. You can perfectly not receive a 1xx response because the UAS
decides not to send them. Or because it simply gets lost. However, the
100 response will always be sent by the next hop (unless the final
response takes less than 200 ms, which is unlikely).

You will be retransmitting your INVITE until you receive the 100 Trying.
If it never arrives, you consider the transaction terminated, as
decribed in bis-05.

Regards,

Gonzalo
-- 
Gonzalo Camarillo                    Phone :   +1 212 939 71 71
Columbia University                  Mobile:  +358 40 702 35 35
472 Computer Science Building        Fax   :  +358  9 299 30 52
1214 Amsterdam Ave., Mail Code 0401  http://www.hut.fi/~gonzalo
New York, NY 10027                   
USA                              [email-masked]

---

From: "Bob Penfield" <[email-masked]>
Date: Wed, 31 Oct 2001 10:02:39 -0500

----- Original Message -----
From: "Shan Lu" <[email-masked]>
To: "'Gonzalo Camarillo'" <[email-masked]>
Cc: "IETF SIP Mailing List" <[email-masked]>
Sent: Wednesday, October 31, 2001 9:47 AM
Subject: RE: [Sip] Bis-05 question: CANCEL

> never CANCEL and UAC will have to store state forever or till final

Most of the time, you will receive a 1xx. Even if you did send the CANCEL
right away, you still have to wait for the final response to the INVITE
before you can forget about it (delete the transaction state). You still
have to be prepared to ACK and BYE if you get a 200 response to the INVITE.
You still have transaction state, so it is easy to send the CANCEL as soon
as you get a 1xx. I think the problems of the CANCEL beating the INVITE far
outway any benefits of sending the CANCEL right away.