Subject: [Sip] 407s from different proxies on a SIP session

From: "Ajay Chitturi" <[email-masked]>
Date: Tue, 16 Oct 2001 15:53:36 -0700

Hi,

In the following scenario with multiple proxies, each of the proxies can challenge the request from the client and the client will probably have to respond to the challenges from different proxies using different Proxy-Authorization headers in the same request. How do the proxies differentiate between the different Proxy-Authorization headers and use the right header that was meant for the proxy. I was wondering if there was a standard way to do this.

C1 ---------> P1 ------------> P2 ---------------> C2

Thanks
Ajay.

_______________________________________________
Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Brett Tate" <[email-masked]>
Date: Tue, 16 Oct 2001 20:51:03 -0400

> In the following scenario with multiple proxies, each of the 
> proxies can challenge the request from the client and the 
> client will probably have to respond to the challenges from 
> different proxies using different Proxy-Authorization headers 
> in the same request. How do the proxies differentiate between 
> the different Proxy-Authorization headers and use the right 
> header that was meant for the proxy. I was wondering if there 
> was a standard way to do this.
> 

The realm can be used if the proxy is 
certain that it is unique to the proxy.
Otherwise, the nonce can be generated/parsed 
in a way that uniquely identifies the 
appropriate proxy.

RFC 2617 defines additional parameters 
that could be used assuming that the 
client isn't limited to RFC 2069.