Subject: Re: [Sip] DEPRECATION WARNING: Open Issue #206: CR and LF alone

From: Jiri Kuthan <[email-masked]>
Date: Sun, 07 Oct 2001 17:57:19 +0200

I very much welcome killing CR-only. My execution profiling experience
tells that trying to understand all these options may account
for up to 20% of CPU time in a stateless proxy (depending mainly
on how many characters must be processed which mainly depends
on how messages are built by their senders).

I have not sighted a non-CR-LF implementation, except
debugging messages I send and create on Un*x (LF-only).
(Which is not bad from server's parsing performance perspective 
  ... I always seek LF and ignore optional CR.)

-Jiri

At 05:34 PM 10/5/2001, Jonathan Rosenberg wrote:
>Folks,
>
>My apologies for sending this to sip and sip-implementors, but maximal
>coverage is needed here.
>
>The spec says that implementations MUST send CRLF to terminate lines, but
>MUST interpret CR or LF by themselves as line terminators, for backwards
>compatibility. We want to trim as much of this stuff as possible from the
>spec. So, I ask: is there anyone out there who sends CR or LF alone as line
>terminators? If so, speak up NOW! Otherwise, we will remove this reuqirement
>from the spec and ONLY CRLF will be discussed.
>
>-Jonathan R.

_______________________________________________
Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 9 Oct 2001 09:49:50 -0400

> -----Original Message-----
> From: Brett Tate [mailto:[email-masked]]
> Sent: Monday, October 08, 2001 11:19 AM
> To: 'Jonathan Rosenberg'; [email-masked]
> Subject: RE: [Sip] DEPRECATION WARNING: Open Issue #206: CR 
> and LF alone
> 
> 
> Does this deprecation also apply to SDP lines?  
> I assume no, but I thought I'd ask.
> 

SDP remains what it is. We are talking about SIP only. In particular, the
following sentence:

Senders MUST terminate lines with a CRLF, but receivers MUST also interpret
CR and LF by themselves
as line terminators.

Basically, it will now say that senders MUST terminate lines with CRLF, and
say nothing on CR and LF by themselves.

One of the reasons this was in there initially was the belief that telnet
didn't send CRLF, and we wanted to be able to telnet to a SIP server.
However, we ran a test on solaris, win2000, and linux, and all three default
telnet clients send crlf.

-Jonathan R.
---
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com