Subject: RE: [Sip] Alert-Info: header

From: "Sean Olson (EUS)" <[email-masked]>
Date: Wed, 17 Oct 2001 09:24:18 -0500

This is a point well taken. I wanted to generalize the
header to allow for a variety of cool new features. If
extending this header is not an option, could we propose
a new header for this purpose? (preferably a general header).
I personally don't understand the problem with using this
header for "ringback" if you are allowing it for "ring tone".

With regards to spam, you must be very careful in both directions.
But then again, you must be very careful about accepting an INVITE
as well which has a larger potential for spam. (not to mention 
MESSAGE)

Sean Olson
Ericsson Inc.

> I think using the header for both purposes is overloading it. 
> The idea is
>good, but a different header should be used.  Good point on 
>the spam!  That
>might wind up killing the intended functionality from getting 
>implemented.
>
>John Hearty
>Level3
>
>-----Original Message-----
>From: Alan Johnston [mailto:[email-masked]]
>Sent: Tuesday, October 16, 2001 4:51 PM
>To: Henning G. Schulzrinne
>Cc: Sean Olson (EUS); [email-masked]'
>Subject: Re: [Sip] Alert-Info: header
>
>
>Henning,
>
>So are you opposed to the use of this header as Sean describes 
>it?    The
>use
>of the header for personalized ringback without resorting to 
>early media is
>a
>good idea.
>
>As for its use in distinctive ringing, we'll just need a note 
>to say that
>the
>use of this header requires the strongest security and trust 
>relationship
>otherwise it will be the cause of the worst kind of SPAM.
>
>Thanks,
>Alan.
>
>"Henning G. Schulzrinne" wrote:
>
>> Alan Johnston wrote:
>> >
>> > Sean,
>> >
>> > I have always assumed that the Alert-Info header being listed as a
>> > Request header was an error - it only makes sense for it 
>to be used as
>> > you describe - in a response (180 Ringing, to be specific, 
>since this is
>> > the only SIP response that tells the UAC to play ringback 
>tone to the
>> > caller).
>> >
>> > This then allows a UAS to deliver a customizable ringback 
>tone without
>> > resorting to early media.
>>
>> This is for *ring* tone, not *ringback* tone.
>>
>> >
>> > The use of Alert-Info in an INVITE never made any sense to 
>me.  There
>> > would be a delay in the UAS from the receipt of the INVITE 
>until it had
>> > fetched the alert sound.  Then, assuming that the UAS 
>played the sound,
>> > how would the user even know that his SIP phone or client 
>was ringing?
>> >
>>
>> The delay would often be minuscule (a second or less), in 
>particular if
>> the Alert-Info is inserted by the local proxy on the receiving side
>> (e.g., to do caller-dependent ring tones).
>>
>> I don't understand the last question. If the URL is sound, the callee
>> would hear it...
>>
>> > Used the other way around, the header does not introduce a 
>delay in the
>> > session setup (a delay of audible ringback while the UAC 
>fetches the
>> > ringback sound does not delay the UAS answering), and the 
>caller just
>> > hears a different sound besides ringing, something 
>perfectly possible
>> > with early media, but handled in a much more efficient way 
>using this
>> > header.
>> >
>> > This is how this header will be described in bis-05, so 
>let me know if I
>> > am totally off base here.
>>
>> Yes, unfortunately.
>>
>> >
>> > Thanks,
>> > Alan Johnston
>> > WorldCom
>> > sip:[email-masked]
>> >
>> > "Sean Olson (EUS)" wrote:
>> >
>> p
>>
>> --
>> Henning Schulzrinne   http://www.cs.columbia.edu/~hgs
>>
>> _______________________________________________
>> Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
>> This list is for NEW development of the core SIP Protocol
>> Use [email-masked] for questions on current sip
>> Use [email-masked] for new developments on the application of sip
>
>
>_______________________________________________
>Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
>This list is for NEW development of the core SIP Protocol
>Use [email-masked] for questions on current sip
>Use [email-masked] for new developments on the application of sip
>

---

From: "Mart Nurmet" <[email-masked]>
Date: Wed, 17 Oct 2001 15:23:06 -0500

RE: [Sip] Alert-Info: headerSean et all:

This does not seem to have that much consensus.  John's point would be better served.    

-Mart
  ----- Original Message ----- 
  From: Sean Olson (EUS) 
  To: [email-masked]' ; [email-masked] ; [email-masked] 
  Cc: [email-masked] 
  Sent: Wednesday, October 17, 2001 9:24 AM
  Subject: RE: [Sip] Alert-Info: header

  Sean Olson 
  Ericsson Inc.