Subject: RE: [Sip] Q: hostname sample in bis-05?

From: Robert Sparks <[email-masked]>
Date: Tue, 30 Oct 2001 18:04:06 -0500

Right now, the BNF wins.
I'll change the example to show escaping in the user field instead.

This brings up an interesting question though - should we move to
allow escaping in hostname? 

If we make that move now, we get extra complexity for little to no gain.

However, as IDN becomes more real, we're going to have to do
something like it (and I think escaping across UTF-8 will give us
everything we'd need).

RjS

> -----Original Message-----
> From: Vladimir Vysotsky [mailto:[email-masked]]
> Sent: Tuesday, October 30, 2001 11:49 AM
> To: [email-masked]
> Subject: [Sip] Q: hostname sample in bis-05?
> 
> 
> It seems to me that one of the URL examples in bis-05 
> (section 21.1.4, line
> 3311), namely,
> 
> sip:alice@%61tlanta.com:5060
> 
> contradicts the syntax for the hostname (line 4501) that does 
> not allow
> escapes in the domainlabel. Which is correct?
> 
> Vladimir.
> 
> 
> _______________________________________________
> Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip
> 

_______________________________________________
Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Henning G. Schulzrinne" <[email-masked]>
Date: Tue, 30 Oct 2001 20:15:33 -0500

> something like it (and I think escaping across UTF-8 will give us

The expired draft
http://www.w3.org/International/2000/03/draft-masinter-url-i18n-05.txt
describes the process in detail, but explicitly excludes host names.
However, I doubt that putting ACE in URIs is the right approach, either.

I doubt that the complexity is high, since you're doing escaping and
unescaping for all the other parts.

-- 
Henning Schulzrinne   http://www.cs.columbia.edu/~hgs