Subject: Re: [Sip] Handling of duplicate requests with differing request paths.

From: Christer Holmberg <[email-masked]>
Date: Fri, 26 Oct 2001 17:41:42 +0300

Hi,

>Yes the branch-ID must be the same for ACK & CANCEL requests as the original
>request (see Section 13.5).

Oki. I missed that. My misstake.

>>I am not sure I understand how it can be an implementation specific
>>issue. If the UAC receives two (or more) identical 200 OK responses,
>>doesn't it always assume it is a re-transmission?
>A UAS would consider it a retransmission if the function that matches
>requests to server transactions (17.2.3) returned a positive match. However,
>because the top-most Via is different, the function will not return a match.
>As no other behavior for non-INVITE method is defined then what will result
>is implementation specific.

I am talking about the response, and the UAC behaviour. However, I
noticed that it doesn't matter how many identical responses (482, for
example) we receive, since we will simply ACK those. 

I think that clarified my issues :)

Thanks!

Christer Holmberg
Ericsson Finland

> 
> Robert.
> 
> > -----Original Message-----
> > From: Christer Holmberg [mailto:[email-masked]]
> > Sent: Friday, October 26, 2001 3:16 PM
> > To: [email-masked]
> > Cc: Fairlie-Cuninghame, Robert; Pekka Pessi
> > Subject: Re: [Sip] Handling of duplicate requests with
> > differing request
> > paths.
> >
> >
> >
> > Hi,
> >
> > Another question related to this:
> >
> > If the UAS receives multiple instances of the INVITE, it may
> > send 200 to
> > the first and then 482 to the others.
> >
> > Now, it also have to receive separate ACKs for all the final
> > responses,
> > so my question is: will the Via branch always be the same in
> > the ACK as
> > it was in the INVITE (or whatever request method), or how does the UAS
> > map the ACK to a specific 482 (or 200)?
> >
> > Regards,
> >
> > Christer Holmberg
> > Ericsson Finland
> >
> >
> >
> >
> > Christer Holmberg wrote:
> > >
> > > Hi,
> > >
> > > >Hi Christer & Pekka,
> > > >
> > > >What would actually happen (eg whether the same or
> > different tag is used in
> > > >responses) would be implementation specific [if a UAS
> > ignored the text that
> > > >Jo Hornsby pointed out]. It would depend on how a negative
> > result to the
> > > >algorithm specified in Section 17.2.3 (Matching Requests To Server
> > > >Transactions) is handled.
> > >
> > > I am not sure I understand how it can be an implementation specific
> > > issue. If the UAC receives two (or more) identical 200 OK responses,
> > > doesn't it always assume it is a re-transmisson?
> > >
> > > >However, that discussion (for INVITE anyway) is irrelevant
> > because Bis-05
> > > >does describe the correct behavior for an INVITE request
> > (ie send 482
> > > >response) but it is not specified for non-INVITE requests.
> > > >
> > > >Also Via hiding was removed from the SIP spec in bis-02 -
> > so that is the
> > > >answer to that question. :)
> > >
> > > I know. I had 3GPP on my mind, but the way it's done there doesn't
> > > affect this.
> > >
> > > Regards,
> > >
> > > Christer Holmberg
> > > Ericsson Finland
> > >
> > > >
> > > > Regards,
> > > >
> > > > Robert.
> > > >
> > > > > -----Original Message-----
> > > > > From: Christer Holmberg
> [mailto:[email-masked]]
> > > > Sent: Friday, October 26, 2001 2:18 PM
> > > > To: Pekka Pessi
> > > > Cc: [email-masked]; Robert; [email-masked]
> > > > Subject: Re: [Sip] Handling of duplicate requests with
> > > > differing request
> > > > p aths.
> > > >
> > > >
> > > >
> > > > Hi
> > > >
> > > > >In message
> > > > <[email-masked]>
> > > > Fairlie-Cuninghame, Robert ><[email-masked]> writes:
> > > > >>Like a 200 OK? [which sets up two subscriptions or two active calls]
> > > > >
> > > > >         Does it? Both have identical to-tags.  How is the original
> > > > >         client going to tell difference?  It does not have
> > > > a benefit of
> > > > >         branch parameter.
> > > >
> > > > I agree with Pekka. There are no via headers in the response when the
> > > > UAC receives it, and if the To-tags are identical the UAC
> > > > will treat the
> > > > response as a retransmission of the final response (the UAS
> > > > will resend
> > > > the final response until it receives the ACK).
> > > >
> > > > Regards,
> > > >
> > > > Christer Holmberg
> > > > Ericsson Finland
> > > >
> >
> > _______________________________________________
> > Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
> > This list is for NEW development of the core SIP Protocol
> > Use [email-masked] for questions on current sip
> > Use [email-masked] for new developments on the application of sip

_______________________________________________
Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Fairlie-Cuninghame, Robert" <[email-masked]>
Date: Fri, 26 Oct 2001 07:36:56 -0700

Hi Christer,

Robert.