Subject: RE: [Sip] What is the mapping of ANI II digits to rpi-np?

From: Romel Khan <[email-masked]>
Date: Tue, 2 Oct 2001 15:39:25 -0400

How about do something like:
From: <sip:13082536367;oli=[email-masked];user=phone>
where oli = originating line information = ani-ii

This encloses the II information within telephone URL consistent with
RFC2806 and makes it independent of SIP. 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Saturday, September 29, 2001 8:05 PM
To: [email-masked]; [email-masked]
Subject: Re: [Sip] What is the mapping of ANI II digits to rpi-np?

To all,

In a message dated 9/28/01 5:11:08 PM Eastern Daylight Time,
[email-masked] 
writes:

<< Hi guys,
 
 I had initially sent out a question on this issue and received no
 responses; so I'm trying again... :^)
 
 I'm trying to understand the appropriate translation of ANI II digits to
 their SIP equivalent.  However, when
 I try to match the currently defined ANI II digits from
 http://www.nanpa.com/number_resource_info/ani_ii_assignments.html
 against the keywords defined in
 Appendix A of draft-ietf-sip-privacy-02.txt, it appears to be a sparse,
 non-invertible mapping.
 
 So, I have a few questions:
 1) Is there a more recent version of this syntax?
 2) Could someone define a less sparse, invertible mapping as a best
 current practice?
 3) Should we instead just define a new tag such as, ";ani-ii=number" ?
 4) Other ideas? >>

<<My comment:
It seems best to use your suggestion 3 - simply define a tag for 
"ani-ii=number" and use the currently defined numbers, not some newly 
invented list of keywords that have unknown meanings. Let's not reinvent the

wheel!

Mike Pierce

_______________________________________________
Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

_______________________________________________
Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Flemming Andreasen <[email-masked]>
Date: Tue, 02 Oct 2001 20:10:26 -0400

> where oli = originating line information = ani-ii

Who adds the ANI II ? How do you know you can trust it ?

-- Flemming

--
Flemming Andreasen
Cisco Systems