Subject: RE: [Sip] Alert-Info: header

From: [email-masked]
Date: Tue, 16 Oct 2001 17:08:20 -0600

I think using the header for both purposes is overloading it.  The idea is
good, but a different header should be used.  Good point on the spam!  That
might wind up killing the intended functionality from getting implemented.

John Hearty
Level3

-----Original Message-----
From: Alan Johnston [mailto:[email-masked]]
Sent: Tuesday, October 16, 2001 4:51 PM
To: Henning G. Schulzrinne
Cc: Sean Olson (EUS); [email-masked]'
Subject: Re: [Sip] Alert-Info: header

Henning,

So are you opposed to the use of this header as Sean describes it?    The
use
of the header for personalized ringback without resorting to early media is
a
good idea.

As for its use in distinctive ringing, we'll just need a note to say that
the
use of this header requires the strongest security and trust relationship
otherwise it will be the cause of the worst kind of SPAM.

Thanks,
Alan.

"Henning G. Schulzrinne" wrote:

> Alan Johnston wrote:
> >
> > Sean,
> >
> > I have always assumed that the Alert-Info header being listed as a
> > Request header was an error - it only makes sense for it to be used as
> > you describe - in a response (180 Ringing, to be specific, since this is
> > the only SIP response that tells the UAC to play ringback tone to the
> > caller).
> >
> > This then allows a UAS to deliver a customizable ringback tone without
> > resorting to early media.
>
> This is for *ring* tone, not *ringback* tone.
>
> >
> > The use of Alert-Info in an INVITE never made any sense to me.  There
> > would be a delay in the UAS from the receipt of the INVITE until it had
> > fetched the alert sound.  Then, assuming that the UAS played the sound,
> > how would the user even know that his SIP phone or client was ringing?
> >
>
> The delay would often be minuscule (a second or less), in particular if
> the Alert-Info is inserted by the local proxy on the receiving side
> (e.g., to do caller-dependent ring tones).
>
> I don't understand the last question. If the URL is sound, the callee
> would hear it...
>
> > Used the other way around, the header does not introduce a delay in the
> > session setup (a delay of audible ringback while the UAC fetches the
> > ringback sound does not delay the UAS answering), and the caller just
> > hears a different sound besides ringing, something perfectly possible
> > with early media, but handled in a much more efficient way using this
> > header.
> >
> > This is how this header will be described in bis-05, so let me know if I
> > am totally off base here.
>
> Yes, unfortunately.
>
> >
> > Thanks,
> > Alan Johnston
> > WorldCom
> > sip:[email-masked]
> >
> > "Sean Olson (EUS)" wrote:
> >
> p
>
> --
> Henning Schulzrinne   http://www.cs.columbia.edu/~hgs
>
> _______________________________________________
> Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip

_______________________________________________
Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

_______________________________________________
Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Henning Schulzrinne <[email-masked]>
Date: Tue, 16 Oct 2001 22:56:08 -0400

It seems to be unambiguous with a single name; one advantage is that it
generally seems to help to define the behavior of headers in both
directions.

See earlier message about spam. In some cases, even if you allow random
URLs, this can actually help. If I hear the local [your least favorite
telephone company here] jingle, I will press the deep-six (603) button
without bothering to lift the receiver. It is somewhat unfortunate that
existing SIP phones don't have this button...

---

From: Kim Liu <[email-masked]>
Date: Wed, 17 Oct 2001 09:00:32 -0400

Henning Schulzrinne wrote:
[Deleted]
> existing SIP phones don't have this button...

SPAM is not the major issue with the header as far as I see it.

  * Harrassment
    The phone 'rings' with "I'm watching you..."
    (Spoofed UDP INVITE that points to movie/TV sound web archive
    in Alert-Info, or free/anonymous web-hosting site.)
  * Mischief
    The phone 'rings' with the sound of a fire alarm and someone
    shouting 'Fire!  Someone pull the fire alarm!'
    (Spoofed UDP INVITE that points to movie/TV sound web archive
    in Alert-Info, or free web-hosting site.)
  * Serious mischief
    The phone 'rings' at a police station or such with 'Look out!
    He's got a gun!'
  * DOS 
    Multiple phones in a building are sent INVITEs with Alert-Info
    pointing to 'wav' file that is 10 gigabytes long, tying up the
    bandwidth until the network admin can track down which unattended
    phones/IP addresses are doing this and kill off the connections.
  * Security issues
    If a helper application (i.e. your favorite web browser or
    media player) is used to deal with the information in the 
    Alert-Info header, then this opens up a potential line of
    attack for things like those script viruses, buffer overflows,
    etc.  All the vulnerabilities that have been experienced to
    date with certain email and browser programs.  (It should be
    noted that in this case, even having a trust relationship
    with the calling party may not be enough if the calling
    party has gotten infected with a virus/trojan that spreads
    itself by calling everyone in the address/phone book with 
    itself in the Alert-Info header.  The call will appear to
    have been from a trusted party.)
    If there is no helper application for dealing with various
    types of media files, then the phone itself will have to
    support them -- .wav, .au, .wma, .mp3, .jpg, .avi, .mov,
    .vbs, etc. etc. whatever.

That's not saying these are untraceable or unstoppable, but
it seems like the header pretty much cannot be used without
a very strong security relationship in place between the two
parties, and even that may fail in the last case.  

(Even if people who attempt such things as the above are
caught, there are always plenty of idiots who try such things
because they do not think they will be caught.  The damage
caused by such things needs to be prevented in the first
place, though.)

Even only allowing for 'local ring tone' URLs, those within
the provider's domain, is probably not strong enough.  If 
some party A in the domain has a 'private' sound file party
A uses with party B, but party C learns what the URL is,
then party C can call party D (if D is on the same provider)
specifying party A's ring tone.  The 'local ring tone'
seems a bit odd for the calling party to use -- the calling
party would have to specify a different URL in the Alert-Info
depending on who was being called to refer to the apropriate
local ring tone for the called party's provider.  At that
point it sounds like it would just make more sense for the
called party to have set up a local profile with distinctive
ringtones based on the calling party, and letting the calling
party send over a ring tone out of band.

If the question boils down to "Should an arbitrary URL be
used as a ring tone without the called party's *explicit*
consent?" (emphasis on explicit), then, well, the Alert-Info
seems pretty useless.  The called party will have to have 
configured what is and is not allowable for which parties,
which would tend to lean towards a local distinctive ring
feature, not a "caller specified ring" parameter.  At best,
perhaps a <ring:personal>, <ring:business>, <ring:important>,
etc. type use of the Alert-Info header, to let a trusted,
known calling party specify a specific named ring configured
by the called party.  (i.e. the user configures his phone
such that <ring:personal>, if called by Bob, translates to
<http://someplace.com/~bob/ringtone.wav> if desired, or when
called by Joe, translates to 
<file://myringtones/joe_persona.wav>)

-- 
Kim Liu  [email-masked]    :  Everyone is a darn fool for at 
Senior Software Engineer    :  least five minutes a day;
Lucent Technologies         :  wisdom consists of not 
Clearwater, FL, 33761       :  exceeding the limit