Subject: [Sip] Session Timer - Timeout on Refresh

From: Wray Ferrell <[email-masked]>
Date: Mon, 22 Oct 2001 13:53:18 -0400

Hi,

 Version 0.8 of the draft states:

 "If no response is received to a refreshing re_INVITE is received
before
 the session expiration, the UA SHOULD send a BYE request to terminate
 the call. It SHOULD send this BYE slightly before session expiration."

 The bis-03 draft of SIP states under Reliability for INVITE Requests:

 "If no response is received after sending seven packet requests,
processing
 continues as if a 481 response was received for that request."

 So does the SIP Session Timer override the section on reliability for
 INVITE requests? More specifically if a UA responsible for
 refreshing does not receive a response to it's re-INVITE what
 should it's behavior be? Disconnect the session as if receiving a 481
 or keep the session alive since the session expiration has not yet
 been reached?

Thanks, Wray

_______________________________________________
Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Wray Ferrell <[email-masked]>
Date: Thu, 25 Oct 2001 15:30:20 -0400

Trying again since I got no responses the first time...

Hi,

Version 0.8 of the draft states:
"If no response is received to a refreshing re_INVITE
is received before the session expiration, the UA
SHOULD send a BYE request to terminate the call.
It SHOULD send this BYE slightly before session
expiration"

The bis-03 draft of SIP states under Reliability
for INVITE Requests:
"If no response is received after sending seven packet
requests, processing continues as if a 481 response was
received for that request."

So does the SIP Session Timer override the section on
reliability for INVITE requests? More specifically if
a UA responsible for refreshing does not receive a
response to its' re-INVITE what should its' behavior
be? Disconnect the session as if receiving a 481 or
keep the session alive since the session expiration
has not yet been reached?

Thanks, Wray

---

From: "Brett Tate" <[email-masked]>
Date: Thu, 25 Oct 2001 19:45:21 -0400

> It SHOULD send this BYE slightly before session

I think it should be "If no 2xx response ...".

> received for that request."

Would a 408 be more appropriate than a 481?
This would allow the UAC to decide the 
importance of the re-invite.
 
> has not yet been reached?

I think that the session should stay alive 
if the re-invite didn't have a new sdp.
Allowing the possibility for multiple 
failures during session refreshing was
one of the reasons why the timer draft
starts trying to refresh at 1/2 
session-expires.

If it was a new sdp in the re-invite, 
releasing the call might be desired to 
avoid potential sdp fallback confusion.