Subject: [Sip] Open Issue #281: Entire URI as a key to location service lookup

From: Jonathan Rosenberg <[email-masked]>
Date: Thu, 6 Dec 2001 17:06:16 -0500

Issue:

There are problems with the bis-05 text which says that a proxy should use
the 
entire URL from the request URI as the key to lookup contacts in the
location 
service DB. The problem is that sometimes the R-URI has transport and maddr 
params, used for routing, and these are not part of the To header in the 
REGISTER, so a 404 is getting sent.

Igor Slepchin has proposed that the choice of key is a matter of local
policy, so long 
as its consistent between registration processing and request routing 
processing. However, I think some guidelines would be helpful to avoid
having 
people shoot themselves in the foot. 

The text used to give no guidance on this, but we changed it to say the
entire 
URL since there had been other problems, or so I recall. Not sure what the 
previous problems were, though.

Another issue with using the whole URL as input to the location DB is that
the key is no longer a simple string; this makes lookups more complex.

Proposal:

Allow key for LS lookups to be a matter of local policy. Describe issues
(like using port and maddr are bad).

-Jonathan R.

---
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Jo Hornsby" <[email-masked]>
Date: Fri, 7 Dec 2001 10:51:31 -0000

> Issue:
>
> There are problems with the bis-05 text which says that a
> proxy should use the entire URL from the request URI as the
> key to lookup contacts in the location service DB. The problem
> is that sometimes the R-URI has transport and maddr params,
> used for routing, and these are not part of the To header in
> the REGISTER, so a 404 is getting sent.
>
> Igor Slepchin has proposed that the choice of key is a matter
> of local policy, so long as its consistent between
> registration processing and request routing
> processing. However, I think some guidelines would be helpful
> to avoid having people shoot themselves in the foot.

Agreed on both points.

> The text used to give no guidance on this, but we changed it
> to say the entire URL since there had been other problems, or
> so I recall. Not sure what the previous problems were, though.

user=phone &;)

> Another issue with using the whole URL as input to the
> location DB is that the key is no longer a simple string; this
> makes lookups more complex.
>
> Proposal:
> Allow key for LS lookups to be a matter of local policy.
> Describe issues (like using port and maddr are bad).

I like.

I might also note that typically, making {maddr, transport
(and now port, I guess, with one of your other current
proposals), etc.} significant in the lookup is going to
be nonsensical if the only way the DB can be mutated is
via REGISTER.  This is because the key is the To, and
all of these things are disallowed there.

 - Jo.