Subject: RE: [Sip] Open Issue #144: Branch ID + isCancel() as transaction ID

From: Jonathan Rosenberg <[email-masked]>
Date: Fri, 7 Dec 2001 22:50:14 -0500

> -----Original Message-----
> From: Brett Tate [mailto:[email-masked]]
> Sent: Friday, December 07, 2001 5:56 PM
> To: [email-masked]
> Subject: RE: [Sip] Open Issue #144: Branch ID + isCancel() as
> transaction ID
> 
> > We are so close to this final step, I believe it is worth 
> > taking. The costs
> > are small, its still optional - just an optimization - and we 
> > have full
> > interop. However, the benefits will be very good when you  
> > have a lot of
> > deployed bis elements.
> > 
> > Proposal:
> > 
> > Allow for branch ID to be the transaction ID, by taking the 
> > steps described
> > above.
> 
> I like the simplification.  However using 
> "branch" would definitely cause backward 
> compatibility issues since it was not
> previously required to be globally unique.
> I guess a poll could be taken.

No, no. Thats the purpose of this cookie. So, if you are bis compliant, you
insert branch that is globally unique, and that branch ALWAYS starts with
BRETTTATE, say:

Via: SIP/2.0/UDP foo.com;branch=BRETTTATEasd9asdsd:asd98

Now, when a proxy or UAS receives a request, it looks at the top Via. If the
branch is there AND it has this cookie, the proxy/uas is sure that the
previous hop supports bis and thus inserted a globally unique branch ID.
KNowing that, it need not look farther for a transaction ID, the remainder
of the Via (plus a bit depending on whether its CANCEL or not) define the
tranasction ID. If the branch ID is missing, or if it doesn't start with
BRETTTATE, its an older client, and thus the regular transaction processing
is done.

-Jonathan R.
---
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Brett Tate" <[email-masked]>
Date: Sun, 9 Dec 2001 16:55:59 -0500

> BRETTTATE, its an older client, and thus the regular 

Thanks for the response.  I didn't notice 
the part about the receiver being able to 
deduce that the branch started with the 
"magic cookie".

The proposal sounds fine.

I guess parsing the branch contents to 
know it is globally unique isn't any harder 
than dealing with an extra parameter to
indicate the same thing.  Hopefully a magic
cookie can be chosen which reduces accidental
insertion of the magic cookie by the currently
released products.