Subject: Re: [Sip] Major Open Issue #113: Overlapping Transactions

From: [email-masked]
Date: Thu, 6 Dec 2001 15:37:05 EST

In a message dated 12/5/01 9:35:32 PM Eastern Standard Time, 
[email-masked] writes:

> Issue:
>  
>  This is a major issue. One of the more major ones remaining.
>  
>  Currently, the spec forbids more than one INVITE at a time, and more than
>  one non-INVITE at a time. This is simple, but there are valid concerns that
>  it will bite us down the road when uses require faster operation. Thus, the
>  issue is whether to relax this two constraints.
>  
<snip>
>  
>  Proposal:
>  
>  Disallow overlapping INVITE (because it could get ugly)
>  Allow overlapping non-INVITE (because we will restrict ourselves too much
>  without it)
>    
>  -Jonathan R.
>  
Is "overlapping INVITEs" what is being proposed in draft-ietf-sip-overlap-01 
as a way to handle overlap signaling? That draft proposes to send another 
INVITE while still waiting for the response to the first. As noted, this 
could lead to problems in correct interpretation of responses received out of 
order.

It seems to make sense to not allow overlapping INVITEs, but would that then 
invalidate the proposal in draft-ietf-sip-overlap-01?

Mike Pierce

_______________________________________________
Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Gonzalo Camarillo <[email-masked]>
Date: Fri, 07 Dec 2001 00:55:56 +0200

Hi,

A clarification: overlap INVITEs do not have anything to do with PSTN
overlapped signalling (i.e., IAM + SAM + SAM ...).

In the mapping draft you are referring to subsequent INVITEs belong to
different dialogs, so we do not have any issue there.

Let's not side-track this thread.

Regards,

Gonzalo

-- 
Gonzalo Camarillo                    Phone :   +1 212 939 71 71
Columbia University                  Mobile:  +358 40 702 35 35
472 Computer Science Building        Fax   :  +358  9 299 30 52
1214 Amsterdam Ave., Mail Code 0401  http://www.hut.fi/~gonzalo
New York, NY 10027                   
USA                              [email-masked]