Subject: [Sip] Open Issue #203: transport related params in To/From

From: Jonathan Rosenberg <[email-masked]>
Date: Thu, 6 Dec 2001 03:42:58 -0500

Issue:

Minor issue. Table 1 indicates that in the From/To fields, a SIP URL cannot
contain an maddr, 
but can contain a port. This seems odd. Either all addressing params should
be 
allowed (port, transport, ttl, maddr) else none of them.

Proposal:

From/To are supposed to be logical addresses, so neither port nor maddr nor
any of the others make much sense there. Proposal is to remove unless anyone
is sending with these parameters.

-Jonathan R.

---
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Jo Hornsby" <[email-masked]>
Date: Thu, 6 Dec 2001 14:13:32 -0000

> Issue:
> 
> Minor issue. Table 1 indicates that in the From/To fields, a 
> SIP URL cannot contain an maddr, but can contain a port.
> This seems odd. Either all addressing params should be 
> From/To are supposed to be logical addresses, so neither port 
> nor maddr nor any of the others make much sense there.
> Proposal is to remove unless anyone is sending with these
> parameters.

Sounds good to me.

If this approach is adopted, am I right in thinking we will
have to be _very_ strict about refusing requests that have
these parameters (else I can see nasty SIP URL comparison
issues ariving)?

 - Jo.

---

From: Robert Sparks <[email-masked]>
Date: Sun, 9 Dec 2001 12:33:56 -0500

> From: Jo Hornsby [mailto:[email-masked]]
> > Issue:
> > 

Why not ignore them if present? I can't think of any comparison
issues taking that approach that don't also exist in deciding to
reject the message based on the contents of the URL.

RjS

---

From: "Jo Hornsby" <[email-masked]>
Date: Mon, 10 Dec 2001 02:27:15 -0000

> reject the message based on the contents of the URL.

I think what I was envisaging was some entity on
the network ignoring these parameters, and then
due to some sort of weird transaction keying
interaction, actually removing them when it
responded or proxied sommat.

[I did think that I'd come up with a slightly
more insiduous case that this, but I'm drawing
blanks on recreating, unfortunately.]

Also, if we take the approach that they should
just be ignored, then what happens if two requests
arrive that are otherwise identical apart from the
port in the To:, say?

But I'm not particularly passionate. &:)

 - Jo.

---

From: Jonathan Rosenberg <[email-masked]>
Date: Thu, 27 Dec 2001 02:14:13 -0500

There was one email on this thread supporting the proposal, and the rest 
of the thread dealt with additional wording that might have to be added 
in support of it.

I will comment on the extra wording bits below, but otherwise, I believe 
there is consensus to accept the proposal. In that case, port and maddr 
are disallowed from the To/From URLs.

More comments below.

> responded or proxied sommat.

In this context, having these parameters be "disallowed" means they MUST 
NOT be inserted, and MUST be ignored by any element that receives them 
there. So, to be honest, if you do put them in the To field, and the 
result is that they get stripped when they come back to you, well, thats 
your problem. Bets are off when you send invalid messages. An 
implementation might be nice enough to handle it anyway for you, but its 
not something the spec would mandate.

> arrive that are otherwise identical apart from the

They are identical.

-Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.            72 Eagle Rock Avenue
Chief Scientist                         First Floor
dynamicsoft                             East Hanover, NJ 07936
[email-masked]                 FAX: (973) 952-5050
http://www.jdrosen.net                  PH:  (973) 952-5000
http://www.dynamicsoft.com