Subject: RE: [Sip] Major Open Issue #113: Overlapping Transactions

From: "Chiou, Mark" <[email-masked]>
Date: Mon, 10 Dec 2001 09:14:23 -0600

Hi,

Why don't we pick 190 for Request Updated response instead of 490.
In convention, 4xx is a final response for failure and expecting ACK to
end the transaction for this case. Using 1xx is much better to carry the
conversation going without requiring an ACK. 
For implementation point of view, UAS and UAC can keep track the CSeq
number changes and link all the activities associated with the same
Call-ID, From, and To together, such that it is easier to implement and
maintain the call leg when change any media using overlapping mechanism
than keeping each INVITE as a separate transaction and requiring an ACK
for each INVITE.

Yes, this is feasible for codec negotiation during call setup or
mid-call codec negotiation when interworking is required. 

Regards,

Mark Chiou

-----Original Message-----
From: Gonzalo Camarillo [mailto:[email-masked]]
Sent: Saturday, December 08, 2001 8:34 PM
To: Bob Penfield
Cc: Jonathan Rosenberg; [email-masked]
Subject: Re: [Sip] Major Open Issue #113: Overlapping Transactions

Hello,

inline:

Bob Penfield wrote:
> 
> ----- Original Message -----
> From: "Gonzalo Camarillo" <[email-masked]>
> >
> > Hi,
> >
> > Jonathan Rosenberg wrote:
> >
> > > Proposal:
> > >
> > > Disallow overlapping INVITE (because it could get ugly)
> >
> > INVITEs are essential for early media as it is specified so far (we
all
> > agree early media is both ugly and needed).
> >
> > Early media only happens within a dialog (in the "early" state).
What
> > about allowing to have exactly one pending INVITE within an early
> > dialog?
> >
> > That is, I send my INVITE and I receive a 1xx response with a To
tag.
> > Now I have my early dialog. I can send another INVITE now to change
> > early media stuff (or for whatever), but I cannot overlap a 3rd
INVITE
> > at the same time. If I want to send a 3rd INVITE I have to wait
until
> > the 2nd has completed. And if I want to send a 4th one, I have to
wait
> > until the 3rd has completed.
> 
> When you say "completed", do you mean get a final response? or get a
> provisional response (like the initial INVITE)?

Sorry. What I meant was that a 490 Request Updated response has been
received for the previous INVITE, so we know for sure that the remote
end is processing only one INVITE at a time.

Regards,

Gonzalo

_______________________________________________
Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

_______________________________________________
Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Gonzalo Camarillo <[email-masked]>
Date: Mon, 10 Dec 2001 19:37:04 +0200

Hi,

> Why don't we pick 190 for Request Updated response instead of 490.

Because we want to keep the core of the network transaction aware. The
core does not need to be aware of the new 490 code in order to function
correctly. If the code was 190, the core would need to be updated.

Regards,

Gonzalo