Subject: RE: [Sip] Immediate NOTIFY to a REFER (or other implied subscript ions)

From: Robert Sparks <[email-masked]>
Date: Thu, 13 Dec 2001 19:15:06 -0500

I don't understand what your question is.

The REFER spec has always _allowed_ multiple
notifies in response to a given REFER.

The quote you grabbed (without context) concerned
what happens when you have more than one REFER
outstanding in a dialog. Completely unreleated.

RjS

> -----Original Message-----
> From: Hisham Khartabil [mailto:[email-masked]]
> 
> I think this relates to multiple NOTIFYs issue. If you say a 
> REFER triggers
> an immediate NOTIFY, you are basically guaranteeing a second 
> NOTIFY, are you
> not?
> 
> A refer quote of what Robert said in an earlier discussion about this:
> 
> "the REFER draft makes no requirement for such multiple 
> NOTIFYs. The "each
> NOTIFY" string corresponds to having multiple REFER 
> statements in a dialog"
> 
> Regards,
> Hisham
> 
> > -----Original Message-----
> > From: [email-masked] [mailto:[email-masked]]On 
> Behalf Of Robert
> > Sparks
> > Sent: Friday, 14 December 2001 1:35 AM
> > To: Robert Sparks; 'JF Rey'; [email-masked]
> > Subject: [Sip] Immediate NOTIFY to a REFER (or other implied
> > subscriptions)
> >
> >
> > In the sip-events discussion in the SIP WG meeting I asked if
> > REFER should hold to events immediate NOTIFY semantic. There
> > was short mixed discussion, but no conclusive consensus.
> >
> > Private conversations since have suggested an implicit
> > SUBSCRIBE gets an implicit immediate NOTIFY.
> >
> > Thoughts?
> >
> > RjS
> >
> > _______________________________________________
> > Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
> > This list is for NEW development of the core SIP Protocol
> > Use [email-masked] for questions on current sip
> > Use [email-masked] for new developments on the application of sip
> 

_______________________________________________
Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Hisham Khartabil" <[email-masked]>
Date: Fri, 14 Dec 2001 02:39:55 +0200

> From: Robert Sparks [mailto:[email-masked]]
> Sent: Friday, 14 December 2001 2:15 AM
> To: 'Hisham Khartabil'; Robert Sparks; 'JF Rey'; [email-masked]
> Subject: RE: [Sip] Immediate NOTIFY to a REFER (or other implied
> subscriptions)
>
>

Actually, that was your reply to the comment that stated: If the INVITE
"triggered" by the REFER gets forked, the UAC may receive multiple 2xx final
responses, in which case multiple NOTIFYs will be sent to the client who
issued the single REFER. But anyway, we are side tracking a little.

I thought multiple notifies to a single REFER was not allowed. My apologies
for the misunderstanding.

Are there any other reasons for the immediate notify besides aligning it
with the events draft? I just think its an unnecessary overhead.

Hisham