Subject: Re: [Sip] Open Issue #178: Deprecate absolute times absolutely: S PEAK UP IFYOU USE THEM IN YOUR PRODUCT!!!!!!!!!!

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 19 Dec 2001 14:06:00 -0500

Let me summarize the results so far.

Scott Orton, Vijay Gurbani, Kiranai Pavoori, Brian Stucker all indicated 
it was fine to deprecate absolute times (option A).

Brett Tate says they have deployments with registrars that return 
absolute times, but it would be OK to proceed with option A anway; I 
assume this means that the registrars would need to be revved as soon as 
any of the handsets became bis compliant (since they wouldn't be able to 
handle the absolute tiems). Note that the opposite is true, you don't 
need to rev the handsets if you upgrade the registrar.

Shail indicated that their registrar uses absolute times. Shail - can we 
get more details here? Would there be issues in existing deployments 
that would be seriously affected by this change? I'd really like to do 
option A, since otherwise you need to carry around the code for absolute 
time processing anyway.

Any others?

-Jonathan R.

Brian Stucker wrote:

> Propsal A is the way to go. Do away with absolute times, they cause problems and they're of no real use because all times are relative to the current clock at the processing node anyhow.
>  
> Brian
> 
> -----Original Message-----
> From: Orton, Scott [NGC:B633:EXCH] 
> Sent: Tuesday, December 11, 2001 3:46 PM
> To: 'Kiranmai Pavoori'; jdrosen; vkg
> Cc: sip
> Subject: RE: [Sip] Open Issue #178: Deprecate absolute times absolutely: S PEAK UP IFYOU USE THEM IN YOUR PRODUCT!!!!!!!!!!
> 
> 
> 
> Proposal A is fine. 
> 
> Scott 
> Nortel Networks 
> 
> -----Original Message----- 
> From: Kiranmai Pavoori [ mailto:[email-masked]] 
> Sent: Tuesday, December 11, 2001 9:48 AM 
> To: jdrosen; vkg 
> Cc: sip 
> Subject: Re: [Sip] Open Issue #178: Deprecate absolute times absolutely: 
> SPEAK UP IFYOU USE THEM IN YOUR PRODUCT!!!!!!!!!! 
> 
> 
> Proposal A resolves lots of synchronization problems seen in my work.. 
> 
> 
> 
> 
>>>>Vijay Gurbani <[email-masked]> 12/10 12:44 PM >>> 
>>>>
> Jonathan Rosenberg wrote: 
> 
>>Issue: 
>>
>>The Expires header and expires param in the Contact header allow for 
>>absolute times expressed in GMT. The problem with using absolute times in 
>>the messages is that they require clock synchronization between the two 
>>elements. 
>>
> [...] 
> 
>>PROPOSAL A: 
>>   * Remove absolute times entirely from the specification 
>>
>>PROPOSAL B: 
>>   * Elements MUST NOT send messages with absolute times in Expires or 
>>;expires, but they MUST be prepared to receive requests with absolute 
>>times in those headers, for backwards compatibility 
>>
>>If we can do A, we should. So, speak up NOW if you use absolute times!!! 
>>
> 
> Proposal A is fine.  Our registrar sends out delta time in responses to 
> Register requests, for instance. 
> 
> Thanks, 
> 
> - vijay 
> 

-- 
Jonathan D. Rosenberg, Ph.D.            72 Eagle Rock Avenue
Chief Scientist                         First Floor
dynamicsoft                             East Hanover, NJ 07936
[email-masked]                 FAX: (973) 952-5050
http://www.jdrosen.net                  PH:  (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Shail Bhatnagar <[email-masked]>
Date: Thu, 20 Dec 2001 14:36:08 -0500

> option A, since otherwise you need to carry around the code for absolute

Jonathan, Our proxy/registrar generates 200 response of the form 

SIP/2.0 200 OK
Contact: <sip:contact1>;expires=gmt stamp
Contact: <sip:contact2>;expires=gmt stamp
This is more of an issue for the clients being used
by existing deployments. If customer X, using our
registrar, changes their client and the client cannot
understand this 200 response, there maybe issues.
This gmt time stamp in 200 responses will probably
not be fixed for next few months in our proxy. 

Charles/Sean you want to add something ??

Thanks,
Shail