Subject: [Sip] question about Dialog ID

From: 陈善学 <[email-masked]>
Date: Thu, 6 Dec 2001 10:47:11 +0800

I have a puzzle about Dialog ID.
Dialog consists of CALL_ID,Local URI and Remote URI.
The dialog ID at each UA involved in the dialog is not the same.(original in bis-05)
                                                 ~~~~~~~~~~~~~~~
But the dialog id is the same in UAC and UAS as follow.
Is it a error????

UAC Dialog ID:
    CALL_ID:
    TO:Remote Adress
    From:Local Adress
UAS Dialog ID:
    CALL_ID:
    TO:Local Adress
    From:Remote Adress

If there are different,I consider that it consists in the tag parameter at TO header.

---

From: Gonzalo Camarillo <[email-masked]>
Date: Fri, 07 Dec 2001 01:18:41 +0200

Hi,

The remote address in the UAC is the To field of the INVITE plus tag
whereas the remote address in the UAS is the From feader field of the
INVITE.

Regards,

Gonzalo

-- 
Gonzalo Camarillo                    Phone :   +1 212 939 71 71
Columbia University                  Mobile:  +358 40 702 35 35
472 Computer Science Building        Fax   :  +358  9 299 30 52
1214 Amsterdam Ave., Mail Code 0401  http://www.hut.fi/~gonzalo
New York, NY 10027                   
USA                              [email-masked]

_______________________________________________
Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip