Subject: [Sip] Missing Call-ID header

From: "Gabriel Velo" <[email-masked]>
Date: Mon, 3 Dec 2001 06:46:10 -0300

Dear All,

I have a question regarding chapter 23.4.1
the paragraph state that....

"The request could not be understood due to malformed syntax. The
Reason-Phrase SHOULD identify the syntax problem in more detail, e.g.,
"Missing Call-ID header". "

Must a UA send a 400 response to a request that have missing mandatory
headers ?
If this is right , how a UA match this response to the corresponding
request?.

Apologies if this has already been discussed.

thanks.
Gabriel Velo.

_______________________________________________
Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Mohamed Elsewe <[email-masked]>
Date: Tue, 4 Dec 2001 14:52:06 -0800 (PST)

the from-tag, should be used to match the 400 Bad
Request to the corresponding caller since the from-tag
or to-tag serve as unique identifiers for each user in
the SIP session.

--- Gabriel Velo <[email-masked]> wrote:
> Sip mailing list 
> http://www1.ietf.org/mailman/listinfo/sip

__________________________________________________
Do You Yahoo!?
Buy the perfect holiday gifts at Yahoo! Shopping.
http://shopping.yahoo.com

---

From: Mohamed Elsewe <[email-masked]>
Date: Tue, 4 Dec 2001 14:51:13 -0800 (PST)