Subject: RE: [Sip] Open Issue #178: Deprecate absolute times absolutely: S PEAK UP IFYOU USE THEM IN YOUR PRODUCT!!!!!!!!!!

From: "Scott Orton" <[email-masked]>
Date: Tue, 11 Dec 2001 15:46:25 -0600

Proposal A is fine. 

Scott
Nortel Networks

-----Original Message-----
From: Kiranmai Pavoori [mailto:[email-masked]]
Sent: Tuesday, December 11, 2001 9:48 AM
To: jdrosen; vkg
Cc: sip
Subject: Re: [Sip] Open Issue #178: Deprecate absolute times absolutely:
SPEAK UP IFYOU USE THEM IN YOUR PRODUCT!!!!!!!!!!

Proposal A resolves lots of synchronization problems seen in my work..

>>> Vijay Gurbani <[email-masked]> 12/10 12:44 PM >>>
Jonathan Rosenberg wrote:
> 
> Issue:
> 
> The Expires header and expires param in the Contact header allow for
> absolute times expressed in GMT. The problem with using absolute times in
> the messages is that they require clock synchronization between the two
> elements.
[...]
> PROPOSAL A:
>   * Remove absolute times entirely from the specification
> 
> PROPOSAL B:
>   * Elements MUST NOT send messages with absolute times in Expires or
> ;expires, but they MUST be prepared to receive requests with absolute 
> times in those headers, for backwards compatibility
> 
> If we can do A, we should. So, speak up NOW if you use absolute times!!!

Proposal A is fine.  Our registrar sends out delta time in responses to
Register requests, for instance.

Thanks,

- vijay
-- 
Vijay K. Gurbani  vkg@{lucent.com,research.bell-labs.com,acm.org} 
Internet Software and eServices Group 
Lucent Technologies/Bell Labs Innovations, 2000 Lucent Lane, Rm 6G-440
Naperville, Illinois 60566     Voice: +1 630 224 0216   Fax: +1 630 713 0184

_______________________________________________
Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip 
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

_______________________________________________
Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Brian Stucker" <[email-masked]>
Date: Wed, 12 Dec 2001 00:18:05 -0600

Propsal A is the way to go. Do away with absolute times, they cause problems
and they're of no real use because all times are relative to the current
clock at the processing node anyhow.
 
Brian

-----Original Message-----
From: Orton, Scott [NGC:B633:EXCH] 
Sent: Tuesday, December 11, 2001 3:46 PM
To: 'Kiranmai Pavoori'; jdrosen; vkg
Cc: sip
Subject: RE: [Sip] Open Issue #178: Deprecate absolute times absolutely: S
PEAK UP IFYOU USE THEM IN YOUR PRODUCT!!!!!!!!!!

Proposal A is fine. 

Scott 
Nortel Networks 

-----Original Message----- 
From: Kiranmai Pavoori [ mailto:[email-masked]
<mailto:[email-masked]> ] 
Sent: Tuesday, December 11, 2001 9:48 AM 
To: jdrosen; vkg 
Cc: sip 
Subject: Re: [Sip] Open Issue #178: Deprecate absolute times absolutely: 
SPEAK UP IFYOU USE THEM IN YOUR PRODUCT!!!!!!!!!! 

[...] 

Thanks, 

- vijay 

<http://www1.ietf.org/mailman/listinfo/sip>  

<http://www1.ietf.org/mailman/listinfo/sip>