Subject: [Sip] Immediate NOTIFY to a REFER (or other implied subscriptions)

From: Robert Sparks <[email-masked]>
Date: Thu, 13 Dec 2001 18:34:56 -0500

In the sip-events discussion in the SIP WG meeting I asked if 
REFER should hold to events immediate NOTIFY semantic. There
was short mixed discussion, but no conclusive consensus.

Private conversations since have suggested an implicit
SUBSCRIBE gets an implicit immediate NOTIFY.

Thoughts?

RjS

_______________________________________________
Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Lawrence Conroy <[email-masked]>
Date: Thu, 13 Dec 2001 16:45:21 -0700

>SUBSCRIBE gets an implicit immediate NOTIFY.
Hi there,
  Not quite sure what you mean by implicit.
Is there a NOTIFY ->passed over the wire<-?
  BR,
   Lawrence
-- 
[email-masked]: +44 1794 833666::<my opinions>:

---

From: "Hisham Khartabil" <[email-masked]>
Date: Fri, 14 Dec 2001 02:02:35 +0200

I think this relates to multiple NOTIFYs issue. If you say a REFER triggers
an immediate NOTIFY, you are basically guaranteeing a second NOTIFY, are you
not?

A refer quote of what Robert said in an earlier discussion about this:

"the REFER draft makes no requirement for such multiple NOTIFYs. The "each
NOTIFY" string corresponds to having multiple REFER statements in a dialog"

Regards,
Hisham

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of Robert
> Sparks
> Sent: Friday, 14 December 2001 1:35 AM
> To: Robert Sparks; 'JF Rey'; [email-masked]
> Subject: [Sip] Immediate NOTIFY to a REFER (or other implied
> subscriptions)
>
>

---

From: Alan Johnston <[email-masked]>
Date: Thu, 13 Dec 2001 20:11:12 -0600

I'm inclined to not mess with REFER (yet again) at this late date unless
there is some very, very strong motivation.

Are there any tangible benefits to doing so?

Thanks,
Alan.