Subject: Re: [Sip] Open Issue #150: too many ways of saying "don't send me media"

From: [email-masked]
Date: Thu, 6 Dec 2001 09:22:39 -0600

We have deployments in multi-vendor environment where all vendors are using
c=0.0.0.0 to say "don't send me media". Is there any particular reason we
want to deprecate this mechanism except for "since there are too many".

Our recommendation would be to continue supporting it. I don't think it
would be any big overhead for any implementation to support this. Our
recommendation is:

c=0.0.0.0          ALLOWED
a=inactive,sendly  PREFERRED
zero port:         disables media stream
bw=0               DONT USE

Thanks,

Anoop Tripathi

CommWorks Corporation
A 3Com Company

Jonathan Rosenberg <[email-masked]>@ietf.org on 12/05/2001
11:41:19 PM

Sent by:  [email-masked]

To:   "'sip @ietf.org'" <[email-masked]>
cc:
Subject:  [Sip] Open Issue #150: too many ways of saying "don't send me
      media"

Issue:

There are a bunch of ways to say "don't send me media":

c=0.0.0.0
a=inactive,sendonly
zero port
bw=0

What do these all mean, and do we need them all?

Discussion: We've agreed on most of this already. The only real issue is to
say that bw=0 is never used. So, the proposal is:

c=0.0.0.0          DEPRECATED
a=inactive,sendly  PREFERRED
zero port:         disables media stream
bw=0               DONT USE

-Jonathan R.
---
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

_______________________________________________
Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Christer Holmberg <[email-masked]>
Date: Fri, 07 Dec 2001 17:27:08 +0200

Hi Anoop,

>want to deprecate this mechanism except for "since there are too many".

The reason I don't like the 0.0.0.0 mechanism is because it is IPv4
specific. I want to have a mechanism I can use for IPv6, ATM,
whatever...

Regards,

Christer Holmberg
Ericsson Finland

---

From: Gonzalo Camarillo <[email-masked]>
Date: Fri, 07 Dec 2001 23:10:35 +0200

Hi,

> want to deprecate this mechanism except for "since there are too many".

Yes, the reason is that even though you do not want to receive media,
you can still send. Therefore, you still have to receive RTCP reports.
If you set your address to 0.0.0.0 the remote party does not have a way
to send you RTCP.

Best regards,

Gonzalo