Subject: Re: [Sip] Open Issue #205: Headers and method param in 3xx/REGISTER Contact

From: William Marshall <[email-masked]>
Date: Sun, 9 Dec 2001 12:46:29 -0500 (EST)

An additional point in favor of the resolution propoesed by Jonathan
is that "method=foobar" effectively disllows a future SIP header 
Method: ..whatever...

I pointed this problem out in my comments to the Refer draft, where
it effectively reserved headers "to-tag" and "from-tag".

Agree with the proposal as stated

Bill Marshall
[email-masked]

> From: Jonathan Rosenberg <[email-masked]>
> To: "[email-masked]'" <[email-masked]>
> Date: Thu, 6 Dec 2001 11:35:29 -0500 
> Subject: [Sip] Open Issue #205: Headers and method param in 3xx/REGISTER Contact
>  header URLs
> 
> Issue:
> 
> Minor issue.
> 
> bis-05 allows the URL method parameter and header parameters to appear in
> 3xx and REGISTER requests/responses. Do we really want this?
> 
> Discussion:
> 
> Headers - yes. It makes sense for me to be able to redirect you to my
> voicemail with a specific Subject header, for example:
> 
> 303 Send Voicemail SIP/2.0
> Contact: sip:[email-masked]?Subject=call%20from%20Bob
> 
> Method parameter - no. That is definitely dangerous. The only complication
> is that we use the caller preferences methods (note the plural) contact
> header for presence, amongst other things. Due to the unfortunate closeness
> of these two parameter names, some people are using the method param
> instead, i.e.:
> 
> REGISTER
> Contact: sip:user@host;method="SUBSCRIBE"
> 
> This is definitely WRONG, since the syntax for method does not actually use
> quoted strings. However, it is out there.
> 
> I would argue, on the other hand, that we should not standardize something
> because people have misimplemented it.
> 
> Proposal:
> 
> Allow headers
> disallow method
> 
> -Jonathan R.
> 
> ---
> Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
> Chief Scientist                             First Floor
> dynamicsoft                                 East Hanover, NJ 07936
> [email-masked]                     FAX:   (973) 952-5050
> http://www.jdrosen.net                      PHONE: (973) 952-5000
> http://www.dynamicsoft.com
>  
> 
> _______________________________________________
> Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip
> 

_______________________________________________
Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 26 Dec 2001 23:42:00 -0500

There was only one comment on this issue, below, from Bill, in support.

I will therefore declare this issue closed and the proposal accepted as 
stated.

-Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.            72 Eagle Rock Avenue
Chief Scientist                         First Floor
dynamicsoft                             East Hanover, NJ 07936
[email-masked]                 FAX: (973) 952-5050
http://www.jdrosen.net                  PH:  (973) 952-5000
http://www.dynamicsoft.com