Subject: Re: [Sip] Immediate NOTIFY to a REFER (or other implied subscriptions)

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 18 Dec 2001 12:23:02 -0500

We could avoid the immediate NOTIFY if its true that the reason we 
needed it in sip-events doesn't apply here.

The reason we needed it in sip-events was because the SUBSCRIBE might 
fork, and we need to hear back from each forked branch in order to 
reject the susbcription, get its state, determine how to refresh it, etc.

Do we expect REFER to fork? If so, then the immediate NOTIFY might be 
important.

Generally, although it seems needless overhead, I'd prefer to have one 
sip-events framework, not two. If REFER is indeed an implicit 
subscription, it should follow the sip-events framework.

We can also instead just remove all this implicit stuff from refer, and 
define the refer event package as a separate, formal package. It would 
then require an explicit SUBSCRIBE, but otherwise work identically.

Just a thought.

-Jonathan R.

Alan Johnston wrote:

> I'm inclined to not mess with REFER (yet again) at this late date unless
> there is some very, very strong motivation.
> 
> Are there any tangible benefits to doing so?
> 
> Thanks,
> Alan.
> 
> Robert Sparks wrote:
> 
> 
>>In the sip-events discussion in the SIP WG meeting I asked if
>>REFER should hold to events immediate NOTIFY semantic. There
>>was short mixed discussion, but no conclusive consensus.
>>
>>Private conversations since have suggested an implicit
>>SUBSCRIBE gets an implicit immediate NOTIFY.
>>
>>Thoughts?
>>
>>RjS
>>
>>_______________________________________________
>>Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
>>This list is for NEW development of the core SIP Protocol
>>Use [email-masked] for questions on current sip
>>Use [email-masked] for new developments on the application of sip
>>
> 
> 
> _______________________________________________
> Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip
> 

-- 
Jonathan Rosenberg, PhD                 72 Eagle Rock Avenue
Chief Scientist                         First Floor
dynamicsoft                             East Hanover, NJ 07936
[email-masked]                 FAX: (973) 952-5050
http://www.jdrosen.net                  PH: (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Alan Johnston <[email-masked]>
Date: Tue, 18 Dec 2001 15:36:29 -0600

Jonathan,

I don't think adding an explicit SUBSCRIBE is a good idea - it adds more
messages for little or no gain.  The predominant use of REFER will be within a
dialog, so forking is not an issue.

Let's just finish REFER and get it off our to-do list.

Thanks,
Alan.