Subject: [Sip] Open Issue #150: too many ways of saying "don't send me media"

From: Jonathan Rosenberg <[email-masked]>
Date: Thu, 6 Dec 2001 00:41:19 -0500

Issue:

There are a bunch of ways to say "don't send me media":

c=0.0.0.0
a=inactive,sendonly
zero port
bw=0

What do these all mean, and do we need them all?

Discussion: We've agreed on most of this already. The only real issue is to
say that bw=0 is never used. So, the proposal is:

c=0.0.0.0          DEPRECATED
a=inactive,sendly  PREFERRED
zero port:         disables media stream
bw=0               DONT USE

-Jonathan R.
---
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Henning G. Schulzrinne" <[email-masked]>
Date: Thu, 06 Dec 2001 10:41:54 -0500

> zero port:         disables media stream

What do you mean by "DON'T USE"? Don't use in SDP or don't use the
media? 
-- 
Henning Schulzrinne   http://www.cs.columbia.edu/~hgs

---

From: Gonzalo Camarillo <[email-masked]>
Date: Fri, 07 Dec 2001 23:11:37 +0200

Hi,

> So, the proposal is:

I believe this is the right thing to do.

Regards,

Gonzalo

---

From: Christer Holmberg <[email-masked]>
Date: Sat, 08 Dec 2001 08:33:19 +0200

Hi,

I would vote for this proposal too.

Regards,

Christer Holmberg
Ericsson Finland

---

From: "Eric Burger" <[email-masked]>
Date: Sat, 8 Dec 2001 21:45:30 -0500

Does it really matter?  Unless the semantics are unclear or you want to use
it for something else, why impose limits on SDP?  People can do whatever
works; we should document the preferred way of doing things and explain why
you shouldn't do others, like the problems with 0.0.0.0.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Jonathan Rosenberg
Sent: Thursday, December 06, 2001 12:41 AM
To: [email-masked]'
Subject: [Sip] Open Issue #150: too many ways of saying "don't send me
media"

Issue:

c=0.0.0.0
a=inactive,sendonly
zero port
bw=0

c=0.0.0.0          DEPRECATED

-Jonathan R.
---

---

From: "Brett Tate" <[email-masked]>
Date: Sun, 9 Dec 2001 18:33:42 -0500

> a=inactive,sendonly  PREFERRED

If "c=0.0.0.0" is truly to be deprecated, an 
alternative should be defined which means to
also suspend RTCP.  Otherwise 3PCC'ers desiring 
to hold a particular party, would need to 
actually "inactive" connect a held party somewhere 
just to ensure RTCP.  Because of the side effects,
I'd hate to be required to zero port the media 
stream.

[I know the benefits of choosing a=inactive 
instead of c=0.0.0.0, no need to sell it to me.]