Subject: [Sip] 200 for INFO

From: "Aaron Lo" <[email-masked]>
Date: Fri, 21 Dec 2001 01:37:59 -0800

Hi all,

In RFC2976 SIP INFO Method sec 2.2 page 3, it reads 

   A 200 OK response MUST be sent by a UAS for an INFO request with
   no message body if the INFO request was successfully received for
   an existing call.  Beyond that, no additional operations are
   required.

Does it mean that the 200 OK should not contain a message body, or does
it mean that a 200 OK should be sent even if the INFO does not contain a
message body? Can someone clarify? Thanks.

Aaron

---

From: "Brett Tate" <[email-masked]>
Date: Fri, 21 Dec 2001 05:04:38 -0500

> Does it mean that the 200 OK should not contain a 
> message body, or does it mean that a 200 OK 
> should be sent even if the INFO does not contain a 

It means that an INFO without a message body 
is valid within an existing dialogue.  A 200 OK 
MUST be sent in response to it.

Such functionality is mainly used to check
the status of the dialogue since a 481 MUST
be sent if the dialogue does not exist.

_______________________________________________
Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip