Subject: RE: [Sip] Open Issue #150: too many ways of saying "don't send me media"

From: [email-masked]
Date: Fri, 7 Dec 2001 10:35:49 -0700

I believe one of the drivers for depreciating c=0.0.0.0 as a method of
putting streams on hold was that the RTCP was no longer sent to the original
address.

John Hearty
Level3

-----Original Message-----
From: Christer Holmberg [mailto:[email-masked]]
Sent: Friday, December 07, 2001 8:27 AM
To: [email-masked]
Cc: Jonathan Rosenberg; [email-masked]'
Subject: Re: [Sip] Open Issue #150: too many ways of saying "don't send
me media"

Hi Anoop,

>We have deployments in multi-vendor environment where all vendors are using
>c=0.0.0.0 to say "don't send me media". Is there any particular reason we
>want to deprecate this mechanism except for "since there are too many".

The reason I don't like the 0.0.0.0 mechanism is because it is IPv4
specific. I want to have a mechanism I can use for IPv6, ATM,
whatever...

Regards,

Christer Holmberg
Ericsson Finland

> 
> Our recommendation would be to continue supporting it. I don't think it
> would be any big overhead for any implementation to support this. Our
> recommendation is:
> 
> c=0.0.0.0          ALLOWED
> a=inactive,sendly  PREFERRED
> zero port:         disables media stream
> bw=0               DONT USE
> 
> Thanks,
> 
> Anoop Tripathi
> 
> CommWorks Corporation
> A 3Com Company
> 
> Jonathan Rosenberg <[email-masked]>@ietf.org on 12/05/2001
> 11:41:19 PM
> 
> Sent by:  [email-masked]
> 
> To:   "'sip @ietf.org'" <[email-masked]>
> cc:
> Subject:  [Sip] Open Issue #150: too many ways of saying "don't send me
>       media"
> 
> Issue:
> 
> There are a bunch of ways to say "don't send me media":
> 
> c=0.0.0.0
> a=inactive,sendonly
> zero port
> bw=0
> 
> What do these all mean, and do we need them all?
> 
> Discussion: We've agreed on most of this already. The only real issue is
to
> say that bw=0 is never used. So, the proposal is:
> 
> c=0.0.0.0          DEPRECATED
> a=inactive,sendly  PREFERRED
> zero port:         disables media stream
> bw=0               DONT USE
> 
> -Jonathan R.
> ---
> Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
> Chief Scientist                             First Floor
> dynamicsoft                                 East Hanover, NJ 07936
> [email-masked]                     FAX:   (973) 952-5050
> http://www.jdrosen.net                      PHONE: (973) 952-5000
> http://www.dynamicsoft.com
> 
> _______________________________________________
> Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip
> 
> _______________________________________________
> Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip

_______________________________________________
Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

_______________________________________________
Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Sat, 8 Dec 2001 00:13:35 -0500

Let me also clarify before this thread goes to far astray.

The deprecation of c=0.0.0.0 to put on hold (which means, no longer send
0.0.0.0, but still need to receive it), has already been agreed to and has
already been updated in bis-05 (well, offer-answer-00 to be precise).
Discussions about whether to use 0.0.0.0 for placing calls on hold are
therefore not relevant to this thread. Please read
draft-rosenberg-mmusic-sdp-offer-answer-00.txt which discusses this issue.

The issue is how to differentiate the uses of the various ways of saying
"don't send me media". As I have said above, c=0.0.0.0 should no longer be
sent, but you need to be prepared to receive it. Setting the port to zero
turns of a stream, terminating any tools and associated resources for that
stream. a=inactive/sendonly is for putting calls on hold, effectively -
temporarily ceasing media (but RTCP will still be sent). All of that has
been agreed to.

The new item here, then, is a=bw:0. The proposal is that you do not send the
bandwidth attribute with a value of zero. Rahter, use one of the other
mechanisms.

-Jonathan R.

---

> From: Gonzalo Camarillo [mailto:[email-masked]]
> Sent: Friday, December 07, 2001 4:11 PM
> Hi,
> [email-masked] wrote:
> > 
> Yes, the reason is that even though you do not want to receive media,
> you can still send. Therefore, you still have to receive RTCP reports.
> If you set your address to 0.0.0.0 the remote party does not 
> have a way
> to send you RTCP.
> 
> Best regards,
> 
> Gonzalo
>

---

From: "Drage, Keith (Keith)" <[email-masked]>
Date: Tue, 11 Dec 2001 19:26:20 -0000

Given that all SDP has now been removed from the bis draft, I am not sure
how this remains a SIP WG open issue.

Surely this issue has now transferred to the MMUSIC documentation.

Keith

Keith Drage
Lucent Technologies
Tel: +44 1793 776249
Email: [email-masked]

> ----------
> From: 	Jonathan Rosenberg[SMTP:[email-masked]]
> Sent: 	06 December 2001 5:41
> To: 	[email-masked]'
> Subject: 	[Sip] Open Issue #150: too many ways of saying "don't send
> me media"
> 
> Issue:
>