Subject: RE: [Sip] Immediate NOTIFY to a REFER (or other implied subscript ions)

From: Robert Sparks <[email-masked]>
Date: Thu, 13 Dec 2001 18:56:29 -0500

> -----Original Message-----
> From: Lawrence Conroy [mailto:[email-masked]]
> 
> At 6:34 pm -0500 13/12/01, Robert Sparks wrote:
> >In the sip-events discussion in the SIP WG meeting I asked if
> >REFER should hold to events immediate NOTIFY semantic. There
> >was short mixed discussion, but no conclusive consensus.
> >
> >Private conversations since have suggested an implicit
> >SUBSCRIBE gets an implicit immediate NOTIFY.
> >
> >Thoughts?
> >
> Hi there,
>   Not quite sure what you mean by implicit.
> Is there a NOTIFY ->passed over the wire<-?

If the immediate NOTIFY is implicit, no message
passes on the wire.

RjS

_______________________________________________
Sip mailing list  http://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Sriram Parameswar" <[email-masked]>
Date: Fri, 14 Dec 2001 09:19:41 -0600

I agree with Alan. To the narrowly defined scope of REFER - receiving an
immediate NOTIFY to our implicit subscription does not add to the user
experience. I would leave the REFER spec as it is. Also I am not sure the
Events draft addresses the implicit subscription very clearly either.

Regards,

Sriram

__________________________________________
Sriram Parameswar              Phone: 972-685-8540
Interactive Multimedia Server (IMS) Fax: 972-685-3563
Nortel Networks, Richardson USA  Email: [email-masked]

-----Original Message-----
From: Alan Johnston [mailto:[email-masked]]
Sent: Thursday, December 13, 2001 8:11 PM
To: Robert Sparks
Cc: 'JF Rey'; [email-masked]
Subject: Re: [Sip] Immediate NOTIFY to a REFER (or other implied
subscriptions)

I'm inclined to not mess with REFER (yet again) at this late date unless
there is some very, very strong motivation.

Are there any tangible benefits to doing so?

Thanks,
Alan.