Subject: RE: [Sip] bis-07 comment: Min-Expires header nit

From: "Drage, Keith (Keith)" <[email-masked]>
Date: Tue, 12 Feb 2002 19:13:20 -0000

Further to the comment below, in the table in the bis-07 draft, I note that
the Min-Expires header is optional a 423 response to REGISTER, and in the
events-02 draft, it is mandatory in 423 response to SUBSCRIBE.

I believe it should be the same in both drafts. I believe the bis draft is
correct and the events draft incorrect, as the status-code in the response
can convey meaning even in the absence of the header. However I am looking
for consistency.

Keith

Keith Drage
Lucent Technologies
Tel: +44 1793 776249
Email: [email-masked]

> ----------
> From: 	Drage, Keith (Keith)[SMTP:[email-masked]]
> Sent: 	12 February 2002 19:02
> To: 	[email-masked]'
> Subject: 	[Sip] bis-07 comment: Min-Expires header nit
> 
> The current text of section 24.23 specifies:
> 
> 		24.23 Min-Expires
> 
> 		The Min-Expires header field conveys the minimum
> registration expiration interval to a registrar. The header field contains
> a
> decimal integer number of seconds. The use of the header field in a 423
> (Registration Too Brief) response is described in Sections 10.2.8, 10.3,
> and
> 25.4.17.
> 
> As this header is only included in a response, then surely the 1st
> sentence
> of the text should say something like
> 
> 
> 	...from a registrar...
> 
> Keith
> Keith Drage
> Lucent Technologies
> Tel: +44 1793 776249
> Email: [email-masked]
> 
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip
> 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 13 Feb 2002 00:48:06 -0500

"Drage, Keith (Keith)" wrote:
> I believe it should be the same in both drafts.

Agreed. However, as far as I can tell, its mandatory in the 423 to
REGISTER according to bis-07. Are you sure you were reading the right
row? 

Thanks,
Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.            72 Eagle Rock Avenue
Chief Scientist                         First Floor
dynamicsoft                             East Hanover, NJ 07936
[email-masked]                 FAX: (973) 952-5050
http://www.jdrosen.net                  PH:  (973) 952-5000
http://www.dynamicsoft.com