Subject: RE: [Sip] calling number blocking at sip/isup gateway

From: "Peterson, Jon" <[email-masked]>
Date: Tue, 5 Feb 2002 20:59:02 -0600

I agree, but I'm not sure why this requires any method in the protocol for
making up telephone numbers. It sounds like a gateway implementation issue.

Jon Peterson
NeuStar, Inc.

> -----Original Message-----
> From: Matt Holdrege [mailto:[email-masked]]
> Sent: Tuesday, February 05, 2002 4:38 PM
> To: Dean Willis; [email-masked]
> Subject: Re: [Sip] calling number blocking at sip/isup gateway
> 
> 
> At 08:57 AM 1/29/2002, Dean Willis wrote:
> >I run a real IP telephone service. Unknown parties may place 
> calls over
> >the Internet to my subscribers. My subscribers's profiles 
> may result in
> >forwarding those calls to a PSTN gateway. PSTN charges 
> originating from
> >this operation are charged back to the subscriber (the called party),
> >not the calling party with whom I have no relationship 
> outside the SIP
> >used to set up the call.
> >
> >It really doesn't matter what the calling party put in their From:
> >field, I still need to complete the call. Now, if they were 
> kind enough
> >to put in a phone number, I can map that into the IAM. But if they
> >didn't, I just can't. Now, there's an interesting question on
> >"authenticating" the phone number that they might have included., but
> >that's a different problem.
> 
> You can get away with that now and even traditional PBX 
> access methods do 
> the same on a case by case basis. But the regulatory trend in 
> some places 
> is that you will be required to supply a number at the 
> interconnect point. 
> Even if you invent a number out of your head, you will be 
> responsible for 
> it. But (again) all we need to do is provide the method in 
> the protocol for 
> inserting a number.
> 
> So what is the problem?
> 
> 
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip
> 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Matt Holdrege <[email-masked]>
Date: Tue, 05 Feb 2002 20:30:49 -0800

My point exactly. I'm wondering why the argument has taken this direction. 
Are we OK now with the protocol allowing the preservation of the caller-ID 
restricted flag?