Subject: RE: [Sip] Proxies adding bodies

From: [email-masked]
Date: Tue, 5 Feb 2002 09:41:54 -0700

Good point.  The firewall control proxies discussed in a thread earlier
today need to be able to modify Content-Length, but table 2 does not allow
this...

John Hearty
Level3

> -----Original Message-----
> From: Miguel A. Garcia [mailto:[email-masked]]
> Sent: Tuesday, February 05, 2002 9:20 AM
> To: [email-masked]
> Subject: [Sip] Proxies adding bodies
> 
> 
> Hi:
> 
> I am thinking of a scenario where a proxy is adding a body to 
> the SIP message,
> just to transport some sort of information that is only of 
> use within the 
> network where the proxy is operating.
> 
> According to the SIP bis-07, I see that table 2 restricts a 
> proxy the ability
> to modify the Content-Type, Content-Length and other 
> suitables parameters that
> are needed to describe a possible new body added by a proxy.
> 
> Why is it forbidden that a proxy modifies the Content-Length 
> and Content-Type
> of a message? Any good reason?
> 
> /Miguel
> -- 
> Miguel-Angel Garcia                     Oy LM Ericsson AB
>                                         Jorvas, Finland
> mailto:[email-masked]     Phone:  +358 9 299 3553
> mailto:[email-masked]        Mobile: +358 40 5140002
> 
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip
> 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Christer Holmberg <[email-masked]>
Date: Tue, 05 Feb 2002 18:48:13 +0200

Hi,

Even if the message body itself isn't changed, a Content-Length header
has to be ADDED if a message received on UDP, to be forwarded by the
proxy on TCP, didn't contain a Content-Length header (optional for UDP,
but mandatory for TCP).

Regards,

Christer Holmberg
Ericsson Finland

---

From: Aki Niemi <[email-masked]>
Date: 05 Feb 2002 20:40:26 +0200

Hi,

A couple of issues with the Digest authentication headers:

1)
Lines 3884 - 3886 in section 20.4.0.1 say that the 'uri' parameter must
be enclosed in quotation marks. However, the BNF for Authorization
doesn't reflect that. Also, the example on lines 3795 - 3803 is missing
quotes.

2)
Section 20.1 guidelines for creating realm strings require globally
unique strings. However, section 24 examples for the authentication
headers (lines 5012, 5234, 5247, 5433) don't quite fulfill those
guidelines.

Cheers,
Aki

(Apologies if these issues were already known. Just making sure. ;)

---

From: Jonathan Rosenberg <[email-masked]>
Date: Fri, 08 Feb 2002 14:10:34 -0500

> doesn't reflect that. Also, the example on lines 3795 - 3803 is missing

Egads, good catch. Thanks. I fixed both.

> headers (lines 5012, 5234, 5247, 5433) don't quite fulfill those

OK, we'll fix.

Thanks,
Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.            72 Eagle Rock Avenue
Chief Scientist                         First Floor
dynamicsoft                             East Hanover, NJ 07936
[email-masked]                 FAX: (973) 952-5050
http://www.jdrosen.net                  PH:  (973) 952-5000
http://www.dynamicsoft.com