Subject: [Sip] re: SMIME in SIP

From: Rohan Mahy <[email-masked]>
Date: Sat, 16 Feb 2002 23:16:56 -0800 (Pacific Standard Time)

Mike,

>1) I have said nothing about TLS in this thread
>
>2) I haven't made a proposal for IPsec because Allison said
>   that it won't go into bis regardless

fine.

>3) Equating me asking that we postpone considering e2e
>   mechanisms with people dying tops any claims of
>   LAMEST I can imagine.

In the message I replied to, you implied that the PSTN model of security
was sufficient for SIP.  You didn't concretely propose anything.  This is
in fact the crux of the problem.

>4) TLS doesn't address UDP. IPsec WG is working on
>   NAT traversal

UDP doesn't work well in the Internet at large anyway.  It's support is
still around for backwards compatibility, and for use in specialized
layer2 domains where RTT is expensive; these domains usually run what
amounts to a private network.  IPsec is probably a good thing in those
networks, and the spec allows for that.

5) In order for SMIME to work in a large scale,
   you need a large scale PKI. Good luck.

I'd rather that it work in a few identifiable scenarios like the ones that
I described.  If you want to propose something concrete for large scale
use please go for it.

In the interim, we have four choices regarding SMIME AFAIK:

Make it a MUST:       probably not very popular ;-)
Leave as a SHOULD:    leave the draft as is
Make it a MAY:        a proposal echoed by many
Postpone Last Call:   extremely unpopular among implementers

Your arguments against SMIME seem to be:
a) slammed in at the last moment
b) not necessarily a high priority to the SIP WG
c) too big to implement on a low-end IP phone/gateway
d) uses PKI
e) requires ASN.1

- c) through e) are not showstoppers for the uses I described.
- while b) is certainly true, getting bis to the IESG certainly DOES
appear to be a high priority and these appear to be linked by the IESG.
If you don't like that linkage, you can/should go yell at them.
- a) is absolutely true, but i haven't heard any concrete objection of the
form "If you send this message under these circumstances the UA breaks".
I'd like to concentrate on this type of analysis.

thanks,
-rohan

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Ofir Arkin <[email-masked]>
Date: Sun, 17 Feb 2002 14:09:10 +0000

Rohan,

> networks, and the spec allows for that.

Umm, DNS? Streaming Media? 

Your own voice sampling transporting protocols such as RTP?

Do not dismiss UDP that fast. It has it's usages :)

-- 
Ofir Arkin
Managing Security Architect
@stake, Limited.
http://www.atstake.com
email: 
[email-masked]
Tel: 
+44 (0) 207 495 7002
Fax: 
+44 (0) 207 495 7062
Mobile: +44 (0) 779 630 8632	

-----------------------------
The information transmitted is intended only for the person or entity to 
which it is addressed and may contain confidential and/or privileged 
material.  Any review, re transmission, dissemination or other use of, 
or taking of any action in reliance upon, this information by persons or 
entities other than the intended recipient is prohibited.  If you 
received this in error, please contact the sender and delete the 
material from any computer.

---

From: Michael Thomas <[email-masked]>
Date: Sun, 17 Feb 2002 12:33:02 -0800 (PST)

Rohan Mahy writes:
 > was sufficient for SIP.  

   I said no such thing. I merely pointed out that
   the PSTN relies on transitive trust and the world
   hasn't ended. I have said nothing about the
   rest of their security model. For many, many
   use scenarios reliance on transitive trust will
   still be adequate and widely deployed. SIP is
   not going to implode in a wave of security
   scandals if e2e crypto is not put into bis.
   
 > You didn't concretely propose anything.  This is

   In fact, I have concretely propose something
   on many, many occasions. I'll repeat it for
   the hundredth time:

   1) Choose a hop by hop mechanism for bis
   2) Leave digest alone
   3) Define requirements and create a new
      standards track draft which deals with
      *all* of the inside crypto needs; not
      just e2e, but also end to middle, and 
      middle to middle

   In fact, the primary (only?) security mechanism
   we've had feedback about from the working group
   is the middle-middle case, specifically for RPI.
   Yet, there's nothing in bis which provides for
   that case. Indeed, there are even regulatory
   questions surrounding unauthenticated RPI.
   What does that say about the priorities chosen?

 > UDP doesn't work well in the Internet at large anyway. 

   Where to begin...  no, never mind.

 > I described.  If you want to propose something concrete for large scale

   No, I won't propose something for the large
   scale because I don't think it is by and large
   *feasible*. Throwing SMIME pixie dust at things
   doesn't change the fact that large scale PKI's
   are a myth, and will remain a myth for a long
   time to come. 

 > Postpone Last Call:   extremely unpopular among implementers

   There is a 5th: put it into a separate draft.

 > If you don't like that linkage, you can/should go yell at them.

   In fact, I have asked and have received no
   response. The only thing I've heard is vague
   allusions to working groups saying they'll
   do something but not delivering. This sounds
   like a management problem to me, and frankly
   it's rather patronizing given that the chairs
   have done a commendable job of taking security
   seriously.

		Mike

---

From: Allison Mankin <[email-masked]>
Date: Sun, 17 Feb 2002 17:11:02 -0500

Mike, 

>                                       SIP is 

Sip bis is not even going to IETF last call if it does not
have a strong end-to-end encryption and integrity capability
envisioned in the specification.

I hope all of the IESG will* be talked into this being a MAY 
this time, and not ask me to insist on a stronger level.  

> >Are you actually claiming that SIP without SMIME 
> >would be "a document with horrible security 
> >problems"? I sure hope not, because if you are I 
> >think you need to get a grip; the current PSTN 
> >does exactly this today, and the world has not 
> >come to an end. 
>  

Yes, we are.

The PSTN is not the Internet.  Users in the Internet world need
the capabilities that S/MIME is specified to provide in the
bis draft.  MIME is intrinsic to SIP; S/MIME is a good match.  

Allison

---

From: Michael Thomas <[email-masked]>
Date: Sun, 17 Feb 2002 14:24:05 -0800 (PST)

> this time, and not ask me to insist on a stronger level.  

   A paper tiger is still a paper tiger.

 > bis draft.  MIME is intrinsic to SIP; S/MIME is a good match.  

   You still have not shown where SMIME is actually
   being deployed widely. Surely not email which is
   arguably as if not more important.

	       Mike