Subject: Re: [Sip] further comments on bis-06

From: William Marshall <[email-masked]>
Date: Fri, 8 Feb 2002 16:01:22 -0500 (EST)

Robert,

I'm happy with your resolution of all those comments.  For the
few cases where you had a question or comment attached ---

> 
>    > line 994:	change"ahhs.aa" to "localhost"
> 
> Do you feel strongly about this one? There's pushback the other way.
> 
We ran into this in an early version of the privacy draft.  The
original recommendation there was to use a junk hostname, like
the use of "ahhs.aa" above.  There was pushback at that time
that the value had to be resolvable by DNS, so was changed in
the later revisions of the privacy draft to "localhost".

No strong opinion either way here.  If there are no
other comments requesting it be changed, leave it as "ahhs.aa"

> 
>    > line 1278:	change SHOULD to "will typically".  Spec is in line 8146.
> 
> 8146 must be a typo - where were you pointing?
> 

Sorry about that.  The spec for this behavior is in section 8.1.4.6

> 
>    > line 2103,2109:	I don't think the spec should specify which element in the
>    > 	reference architecture MUST generate a particular request.  Suggest
>    > 	changing "UAC core" to "UAC".
> 
> The point here is that it is the TU (synonym for core - see TU in the
> definitions) is responsible for the ACK. The transaction layer
> is not going to handle it.
> 
> I don't understand your objection - can you clarify?
> 

Your resolution to the earlier comment, considering them concise statements 
of "MUST follow the steps specified in UAC core" addresses this.

Bill Marshall
[email-masked]

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Fri, 08 Feb 2002 16:15:24 -0500

> the later revisions of the privacy draft to "localhost".

I think that was because there were times when DNS resolution was
actually applied to From - when the INVITE had no Contact. Not that
localhost would have helped, of course. However, since Contact is now
mandatory, and widely used I think in real implementations, we are at
the point where To and From are logical identifiers only, and represent
an identity asserted by the ednpoints. 

-Jonathan R.
-- 
Jonathan D. Rosenberg, Ph.D.            72 Eagle Rock Avenue
Chief Scientist                         First Floor
dynamicsoft                             East Hanover, NJ 07936
[email-masked]                 FAX: (973) 952-5050
http://www.jdrosen.net                  PH:  (973) 952-5000
http://www.dynamicsoft.com

---

From: Henning Schulzrinne <[email-masked]>
Date: Fri, 08 Feb 2002 21:44:53 -0500

> other comments requesting it be changed, leave it as "ahhs.aa"

example.com comes to mind.

---

From: Sean Olson <[email-masked]>
Date: Sat, 9 Feb 2002 08:07:56 -0800 (PST)

> other comments requesting it be changed, leave it as

localhost makes things a bit cleaner as well as bit
more explicit which seems like a good general 
goal.

/sean

=====
Sean Olson <[email-masked]>

__________________________________________________
Do You Yahoo!?
Send FREE Valentine eCards with Yahoo! Greetings!
http://greetings.yahoo.com