Subject: Re: [Sip] Multiple 200 OKs for an INVITE

From: Mark Taylor <[email-masked]>
Date: Thu, 28 Feb 2002 05:23:21 -0800 (PST)

This may be a silly question but multiple INVITES are
sent out which cause telephones to ring. Two of these
telephones are answered by human beings at the same
time and send a 200 OK. One of these telephones is
connected to the voice path but the other experiences
an immediate hang up.

Isn't this extremely rude and will cause major
emabarassment to the caller since his name and
possibly picture have been dispayed on the receiving
device. It could also be considered a form of criminal
harrassment to call and imediately hang up on answer.

It should be noted that for calls to human beings as
oposed to machines that all end points that send a
200K must be conferenced into the connection.
> 
> Subject:  Re: [Sip] Multiple 200 OKs for an INVITE
> 
> 
> 
> 
> Hi Ofir,
> 
> If you receive multiple 200 OK, you would normally
> accept the first. Then
> you would ACK/BYE any other 200OK you may receive.
> 
> Regards,
> 
> Christer Holmberg
> Ericsson Finland
> 
> 
> Ofir Arkin wrote:
> 
> > Section 13.2.2.4 2xx responses (for INVITE):
> >
> > "Multiple 2xx responses may arrive at a UAC for a
> single INVITE
> > request...each response is distinguished by the
> tag parameter in the TO
> > header field and each represents a distinct dialog
> identifier".
> >
> > In this phase there is no tag in the 'To' field
> held in the 'state' if I
> > understand this correctly. Actually the 200OK is
> the first message to
> > carry the value back from a UAS.
> >
> > "If the dialog identifier in the 2xx response
> matches the dialog
> > identifier of an existing dialog, the dialog MUST
> be transitioned to the
> > "confirmed" atate..."
> >
> > Ok, but what will happen if we receive in the same
> time two 200OKs from
> > two different UASs? The state is still not
> "confirmed"...
> >
> > Is this is first arrived first processed therefore
> won situation?
> >
> > Also - after the first 200OK will be processed,
> the state will change to
> > "confirmed" and further 200OKs will not match a
> dialog identifier any
> > more...
> >
> > Thoughts?
> >
> > --
> > Ofir Arkin
> > Managing Security Architect
> > @stake, Limited.
> > http://www.atstake.com
> > email:
> > [email-masked]
> > Tel:
> > +44 (0) 207 495 7002
> > Fax:
> > +44 (0) 207 495 7062
> > Mobile: +44 (0) 779 630 8632
> >
> > -----------------------------
> > The information transmitted is intended only for
> the person or entity to
> > which it is addressed and may contain confidential
> and/or privileged
> > material.  Any review, re transmission,
> dissemination or other use of,
> > or taking of any action in reliance upon, this
> information by persons or
> > entities other than the intended recipient is
> prohibited.  If you
> > received this in error, please contact the sender
> and delete the
> > material from any computer.
> >
> > _______________________________________________
> > Sip mailing list 
> https://www1.ietf.org/mailman/listinfo/sip
> > This list is for NEW development of the core SIP
> Protocol
> > Use [email-masked] for questions
> on current sip
> > Use [email-masked] for new developments on the
> application of sip
> 
> 
> _______________________________________________
> Sip mailing list 
> https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP
> Protocol
> Use [email-masked] for questions
> on current sip
> Use [email-masked] for new developments on the
> application of sip
> 
> 
> 
> 

__________________________________________________
Do You Yahoo!?
Yahoo! Greetings - Send FREE e-cards for every occasion!
http://greetings.yahoo.com

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Bob Penfield" <[email-masked]>
Date: Thu, 28 Feb 2002 12:09:32 -0500

----- Original Message -----
From: "Mark Taylor" <[email-masked]>

> harrassment to call and imediately hang up on answer.

I think it is a rather common occurance that you pick up a phone and say
hello and noone is there because they decided the call was a mistake or got
tired of waiting for it to answer. It happens to me quite often,
particularly if I don't pick up for 3 or 4 rings.

I should also point out that proxies are required to CANCEL the other
branches when one of them answers. Therefore, the other unanswered phones
would likely stop ringing with a second or two.

You might consider it rude, but the reason that more than one phone rang is
because a user wanted all those phones to ring when he/she got called. The
theory being that the user would answer the phone he/she is next to and
there would be noone next to the other devices. However, some polite person
might decide they want to answer the user's unattended phone for them.

> 200K must be conferenced into the connection.

This is not always possible, particularly on a small device with limited
resources.

cheers,
(-:bob