Subject: RE: [Sip] note: change in URI comparison rules coming

From: "James Undery" <[email-masked]>
Date: Fri, 15 Feb 2002 09:24:25 -0000

Good. 

Well while we're at it can I suggest we remove all default values  from
SIP URIs. My reasoning would be, port and transport seemed the least
arbitrary. The user parameter has consistently been abused; the method
parameter defaulting to INVITE doesn't seem so convincing in these
SIMPLEr times; ttl does this really justify a default parameter, if you
insist on using multicast you should do it properly with some thought.

This also results in a far simpler comparison rule, that's easy to grasp
and apply.

James

> -----Original Message-----
> From: Robert Sparks [mailto:[email-masked]]
> Sent: 14 February 2002 22:35
> To: James Undery
> Cc: Jonathan Rosenberg; [email-masked]
> Subject: Re: [Sip] note: change in URI comparison rules coming
> 
> 
> The current proposal is no.
> 
> Those two URLs will resolve to the same host/port/transport, but
> making the URLs equivalent will require separate equality rules
> for when the hostpart is an IPv4 address vs a DNS name.
> 
> RjS
> 
> 
> James Undery wrote:
> 
> > Is sip:10.0.0.1 == sip:10.0.0.1;transport=udp still going to hold?
> > 
> > James
> > 
> > 
> >>-----Original Message-----
> >>From: Robert Sparks [mailto:[email-masked]]
> >>Sent: 14 February 2002 15:32
> >>To: Jonathan Rosenberg
> >>Cc: [email-masked]
> >>Subject: Re: [Sip] note: change in URI comparison rules coming
> >>
> >>
> >>The same argument applies to the transport parameter
> >>sip:user@domain;transport=udp will always resolve to udp,
> >>but
> >>sip:user@domain may resolve to tcp through DNS.
> >>
> >>The next version of bis will reflect
> >>
> >>sip:user@domain:5060 != sip:user@domain != 
> >>sip:user@domain;transport=udp
> >>
> >>
> >>RjS

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Fri, 15 Feb 2002 16:14:07 -0500

James Undery wrote:
> SIP URIs. 

Whoa there partner.

We didn't remove defaults for either port or transport; we merely said
that an explicit value does not equal the default. We still need a
default unless you want to force everyone to include them explicitly in
each request.

My reasoning would be, port and transport seemed the least
> This also results in a far simpler comparison rule, that's easy to grasp

Sorry - are you arguing for removal of defaults, or that the default
should never equal the explicit value? That is:

sip:[email-masked];ttl=1
sip:[email-masked]

would not be equal? I could be convinced to go full court on this
one....

-Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.            72 Eagle Rock Avenue
Chief Scientist                         First Floor
dynamicsoft                             East Hanover, NJ 07936
[email-masked]                 FAX: (973) 952-5050
http://www.jdrosen.net                  PH:  (973) 952-5000
http://www.dynamicsoft.com