Subject: RE: [Sip] replays and SMIME

From: "James Undery" <[email-masked]>
Date: Tue, 19 Feb 2002 16:12:45 -0000

> -----Original Message-----
> From: Eric Rescorla [mailto:[email-masked]]

> "James Undery" <[email-masked]> writes:
> > is all that is needed to work with our framework only 
> leaving how the
> > nonce is included into the SMIME body, which superficially 
> would be to
> > include the relevant headers. Obviously this is off the top 
> of my head
> > and should be taken as the ramblings of an idiot.
> Yes, this is more or less what I had in mind, but your draft is
> a lot more complicated than what we'd need for this purpose,
> I suspect.

Ironically I might argue the reverse ;-), however, back to the point, in
my opinion the complexity of our draft is in the Digest portion, the
framework itself is light.

James

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 20 Feb 2002 10:04:21 -0500

> framework itself is light.

I don't even think you need anything beyond whats in bis, and you can
have the ability to provide challenges. The UAS receives an SMIME signed
request, rejects with a 401, requesting digest, providing a nonce, and a
random realm, like "foobar.invalid". The UAC, based on the procedures in
bis, will have no credentials for this realm, and thus it will use the
anonymous username and password. This would go into an Authorization
header, which the UAC would include as part of the signed message. The
key feature of the anonymous authentication is that it reflects back the
nonce, which is all you want to do here.

-Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.            72 Eagle Rock Avenue
Chief Scientist                         First Floor
dynamicsoft                             East Hanover, NJ 07936
[email-masked]                 FAX: (973) 952-5050
http://www.jdrosen.net                  PH:  (973) 952-5000
http://www.dynamicsoft.com

---

From: Michael Thomas <[email-masked]>
Date: Wed, 20 Feb 2002 10:12:29 -0800 (PST)

> nonce, which is all you want to do here.

   1) This is not in the text or obvious
   2) It's not clear that the nonce can be shipped in the clear
   3) Yuck

	Mike

---

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 20 Feb 2002 16:57:31 -0500

Michael Thomas wrote:
> 
>  This would go into an Authorization

Agreed. Its one of these things that doesn't require additional
specification, but would likely not work unless it is explicitly pointed
out.

>    2) It's not clear that the nonce can be shipped in the clear

Why not? We ship it in the clear for normal digest. Can you point to a
specific problem?

>    3) Yuck

Thats not very useful. Neither is your comment (2). I am looking for
statements of conrete problems, and then proposals of concrete
solutions, not the kinds of statements above which don't help this
working group.

-Jonathan R.

---

From: Michael Thomas <[email-masked]>
Date: Wed, 20 Feb 2002 14:18:47 -0800 (PST)

> solutions, not the kinds of statements above which don't help this

Jonathan,

I have sent out serveral pieces of mail about
*concrete* problems over the last few days, and I
made a proposal of a potential way to fix this
particular issue yesterday. Apparently that was
not enough. And it's still not clear that what
you've proposed is correct. An active attacker in
the middle could capture the nonce and create a
new signature. Is that secure? You are not solving
a proxy authentication problem here. You are
making claims that somebody can use these e2e
security mechanism which pass through proxies and
have a reasonable degree of certainty that they
will not be easily compromised through proxies
where there may well be significant incentive for
bad guys to do very bad things. 

And please don't cop attitude that this is not
without performance impact. "Yuck" is a perfectly
reasonable response to something that increases
the ever escalating message load for a simple call
even more.

However, if what you're really asking for me to do
is shut up because it's too close to deadlines,
fine. I'll unsubscribe until the working group
feels like actually solving security problems
instead of throwing in last minute, not well
thought out or reviewed, feel-good security
mechanisms for the benefit of the AD's, and the
detriment of SIP.

	Mike

---

From: Eric Rescorla <[email-masked]>
Date: 20 Feb 2002 14:43:34 -0800

> Why not? We ship it in the clear for normal digest. Can you point to a
This could use some analysis but I think it's safe.

-Ekr

-- 
[Eric Rescorla                                   [email-masked]]
                http://www.rtfm.com/