Subject: [Sip] Comments on bis-06

From: "Jo Hornsby" <[email-masked]>
Date: Fri, 1 Feb 2002 17:13:59 -0000

Okay, so here are my (incomplete) comments on bis-06;
like all the others, I wanted to get them out now
so that they might actually be useful bearing-in-mind
the Monday Deadline.

As a general comment, every so-often, a paragraph
seems to be inexplicably all bunched up line-wise;
f.ex.: 1942 - 1944, 1982 - 1990, 2060 - 2064.
(Obviously, the only concern here is that it
offends my aesthetic sensibilities.)

( These are all comments based on the PDF: )
 * 619: I find "A call stateful proxy is always
   stateful" just ever-so-slightly confusing.
   Maybe it would be helpful to add a paranthetical
   "transaction", a la "A call stateful proxy is
   always [transaction] stateful"?
 * 656: Just a corner case, but would it be better
   to say something like: "A proxy that receives
   all request from a client, even though it _may
   not be_ the server resolved by the Request-URI"?
 * 676: Should probably say "...the client to
   contact an alternate set of URIs" for true
   correctness.
 * 693: Shouldn't 6xx halt a sequential search,
   too?
 * 711: Random Blank Line.
 * 1040: I'd rather see something like "A UAC MUST
   insert a Max-Forwards header field into each request
   it originates.  The value needs to be large
   enough to ensure that the request can traverse
   a reasonable number of proxies, and in the
   absence of local / network policy, or otherwise,
   SHOULD be 70".  (Just slightly concerned at
   the mandatory nature of such a magically random
   figure.)
 * 1059: Section Link appears to be broken.
 * 1063: I think this conflicts with 1832 (and
   List Discussion, as I recall).
 * 1152: Isn't it possible for other types of
   event; e.g., no DNS records, ICMP?
 * 1177: Is the intention here really just
   "until a server responds"?  I would have thought
   we were looking for a 2xx / 6xx.
 * 1674: Shouldn't this be step 7?
 * 1966: Random Blank Line.
 * 1985: Small Point, but why a 500?  I would have
   thought that this would be treated as a client
   error, and thus 4xx?
 * 2251: Again with the 500 -> 4xx.
 * 2282: s/unbound/unbounded/
 * 2328: Spurious Space Beginning Line.

Finally, I feel compelled to do the atypical
syncophancy bit.  Unfortunately, due to some
poor time management (and new seasons of Buffy
Angel, of course), I never got around to a
proper read of bis-05.  So bis-06 is something
of a revelation.  And it really is such an
improvement.

Well, to be honest, before reading this, I was
secure in my employment before, such that a
Lego Desk seemed pretty inevitable; but now
things are so well explained, I reckon you've
made it such that any old Joe could walk in off
the street and write a Proxy or whathaveyou.
So thanks for that.

Ah well, I guess it's back to TAPI.  Damnit.

 - Jo.

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Robert Sparks <[email-masked]>
Date: Sat, 16 Feb 2002 22:04:10 -0600

Finally got all these incorporated.

For the 500 vs 4xx below - as far as I know, the choice
was arbitrary. Jonathan points out that 500 makes a little
more sense than 4xx since a 5xx class response means
"This request may succeed if you send it again at a later
time". The current text still says 500.

RjS

---

From: "Jo Hornsby" <[email-masked]>
Date: Mon, 18 Feb 2002 18:58:59 -0000

> time". The current text still says 500.

Fair enough.

Actually, from that point-of-view, a 5xx is
certainly more desirable semantically.  And
since there is really little other distinction,
seems most sensible.

Good good.

 - Jo.