Subject: Re: [Sip] privacy draft and calling vs called

From: Flemming Andreasen <[email-masked]>
Date: Sat, 02 Feb 2002 15:56:27 -0500

This is indeed a good question. In previous versions of the privacy draft,
we always assumed that only the initial INVITE would contain the
Remote-Party-ID information. A couple of things have changed since then,
most notably the fact that the proxy is now the one responsible for
inserting the Remote-Party-Id, and proxies don't know whether INVITE's (or
other messages which may now also contain Remote-Party-ID's) are initial, or
come from the originating or terminating party. In other words, it becomes
difficult to do anything but simply put "calling" in requests and "called"
in responses, however it's not clear to me that we always want to do that,
e.g. in case of redirection services. What do people think ?

-- Flemming

Terry L Anderson wrote:

> The privacy draft uses
>     party = calling | called
> as the rpi-pty-type in the Remote-Party-ID header.  The descriptions in
> 5.1 (assumed type if parameter is absent), 6.1 and 6.3 indentify
> "calling" with the sender of the request and "called" with the sender of
> a response.  This seems obvious for an initial INVITE.  But I want to
> confirm the intention for a reINVITE which does NOT come from the party
> that initiated the call.  Should "calling" still be indentified with
> "requesting" even though the party is not the original calling party for
> the call?  That is, should calling and called be reversed (as To and
> >From are) from the original for the established call-leg or should they
> maintain their PSTN-like meaning with calling always referring to the
> party that initiated the call-leg?
>
> In either case, it would be helpful to be more explicit about usage for
> subsequent requests since "calling" and "called" are not SIP terms and
> might be confused with their PSTN usage.
>
> --
>
> ------------------------------------------------------------
> Terry L Anderson              mailto:[email-masked]
> Tel:908.582.7013   Fax:908.582.6729
> Lucent Technologies/INS/Voice Over IP Access Networks
> Rm 2B-121, 600 Mountain Av, Murray Hill, NJ 07974
> http://its.lucent.com/~tla (Lucent internal) http://www.gti.net/tla

--
Flemming Andreasen
Cisco Systems

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Sean Olson <[email-masked]>
Date: Sat, 2 Feb 2002 13:11:19 -0800 (PST)

It just makes sense for the RPID to be 
transaction based; the RPID should reflect
the From: header in requests and the To: header
in responses. Or to look at it from a different
point of view, the caller's proxy should never have
to insert a RPID for the calling party. 

/sean

> Sip mailing list 
> https://www1.ietf.org/mailman/listinfo/sip

=====
Sean Olson <[email-masked]>

__________________________________________________
Do You Yahoo!?
Great stuff seeking new owners in Yahoo! Auctions! 
http://auctions.yahoo.com