Subject: [Sip] security preconditions

From: Rohan Mahy <[email-masked]>
Date: Fri, 22 Feb 2002 14:23:30 -0800 (Pacific Standard Time)

Hi Gonzalo,

I think it is still quite reasonable to signal that such-and-such security
is required before I ring.  I think the "confirm" part if much less
important, because all the security negotiation protocols i know about are
reliable.

thanks,
-rohan

To: sip <[email-masked]>, mmusic <[email-masked]>
Subject: [Sip] Removing security preconditions from manyfolks
From: Gonzalo Camarillo <[email-masked]>
Date: Fri, 22 Feb 2002 21:34:44 +0200
CC: "Fredrik Lindholm (ERA)" <[email-masked]>, Jonathan
Rosemberg <[email-masked]>, [email-masked]
List-Id: Session Initiation Protocol <sip.ietf.org>
Sender: [email-masked]

--------------------------------------------------------------------------------

Hi,

we are thinking of removing security preconditions from manyfolks. Right
now manyfolks handles QoS and security preconditions. However, with
MIKEY, this feature seems useless to establish secure channels.

If somebody thinks that removing security preconditions from manyfolks
is a bad idea, please speak up.

Regards,

Gonzalo

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Jari Arkko" <[email-masked]>
Date: Sat, 23 Feb 2002 08:57:27 +0200

With MIKEY, the information about such-and-such security
is also available in the SDP, and can be acted upon (and in
fact without additional roundtrips).

The only question that I have is whether there'd be any other
security schemes that could apply, and would they need the
preconditions? But I can't think of any practical example,
and I think we should reduce overall SIP complexity unless
we see a specific and real need for a feature.

So, I agree with Gonzalo that the security preconditions
should go away.

Jari