Subject: RE: [Sip] T4

From: [email-masked]
Date: Wed, 27 Feb 2002 14:08:19 +0200

All this is fine, but T4 as you define it (Max RRT between request and response) is too short in my opinion. Perhaps it should be set to a higher value.

The other alternative is for the spec to say that timer K must be reset after every retransmission.

Regards,
Hisham

> -----Original Message-----
> From: ext Jonathan Rosenberg [mailto:[email-masked]]
> Sent: Wednesday, February 27, 2002 10:15 AM
> To: Khartabil Hisham (NMP/Helsinki)
> Cc: [email-masked]
> Subject: Re: [Sip] T4
> 
> 
> 
> 
> [email-masked] wrote:
> > 
> > I included this in my comments in bis-07, but never got an answer.
> > 
> > Why is T4 limited to 5 seconds for timer K in the case of non-INVITE
> > (section 17.1.2.2)?
> 
> Sorry, I thought I had answered this somewhere.
> 
> The idea is that you've sent a bunch of BYE requests, for example, and
> now you've got the final response. You want to hang around to 
> catch any
> retransmits of that final response. How long to wait? The interesting
> thing about responses to BYE, is that they are not perioidcally sent;
> they are sent only in response to a request. So, the delay between
> sending a request, and getting a response, is equal to some value (say
> T4'), which represents the amount of time it takes for the request to
> get to the server, for the server to resend the response, and for the
> response to arrive at the client. Let T4 be the maximum value 
> of T4' you
> might ever see, which I have set at around 5s. This should be 
> more than
> sufficient. So, this means that if you've sent a retransmit of the
> request at time t, you would have received the response by t+T4 with
> very high probability, or you won't get one at all. So, if a UAC sends
> requests at times t1,t2,t3,t4, the responses would have arrived at
> t1+T4, t2+T4, t3+T4, t4+T4. The largest of those is t4+T4. 
> Thus, we need
> to wait at least T4 seconds after the last request. Instead, 
> we wait T4
> after the first response, which is always more time (its simpler that
> way). 
> 
> Hope that helps.
> 
> -Jonathan R.
> 
> 
> -- 
> Jonathan D. Rosenberg, Ph.D.            72 Eagle Rock Avenue
> Chief Scientist                         First Floor
> dynamicsoft                             East Hanover, NJ 07936
> [email-masked]                 FAX: (973) 952-5050
> http://www.jdrosen.net                  PH:  (973) 952-5000
> http://www.dynamicsoft.com
> 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Thu, 28 Feb 2002 10:43:20 -0500

[email-masked] wrote:
> 
> All this is fine, but T4 as you define it (Max RRT between request and
> response) is too short in my opinion. Perhaps it should be set to a
> higher value.

5s? I thought it was maybe too high... what is your reasoning for
thinking it is too low?

> after every retransmission.

That is not needed. It is easier, implementation wise and specification
wise, to do it as specified.

-Jonathan R.