Subject: RE: [Sip] Query: Adopt draft-willis-sip-path-xx as WG doc?

From: [email-masked]
Date: Mon, 25 Feb 2002 18:54:53 +0200

Hi Juha!

Comments inline...

 T: Bernie

> -----Original Message-----
> From: ext [email-masked] [mailto:[email-masked]]
> Sent: 25. February 2002 18:03
> To: Honeisen Bernhard (NET/Helsinki)
> Cc: [email-masked]; [email-masked]; [email-masked]
> Subject: RE: [Sip] Query: Adopt draft-willis-sip-path-xx as WG doc?
> 
> 
> [email-masked] writes:
> 
>  > In certain network configurations (e.g. the IMS of
>  > 3GPP) such behavior makes sense.
>  > The registar (let's call it S-CSCF) is one of the hops,
>  > every INVITE has to pass, because the S-CSCF is at the
>  > same time the element, which has to be visited for the
>  > user's outbound services.
> 
> fine, then simply create an SVR record for the home domain of the UA
> that points to the S-CSCF.

Let's assume, we have 10 million users, which are distributed
more of less equally through many instances of S-CSCFs.
At registration time, some resources are reserved on a particular
instance of S-CSCF, so that the call setup times can be minimized,
and security associations can be set up.
Thus, the call has to be routed to a specific instance of S-CSCF

With your proposal of using the DNS SRV (I guess SVR is a typo)
mechanism, it would work only if it would not matter, which
instance of S-CSCF is handling the served UA of this INVITE.
But in certain architectures it does matter.

Note: The S-CSCF are allocated dynamically and could be based
      on the services, a user has subscribed for.

> if the UA wants to use services of its home
> domain for an invite, then the UA creates a loose source route that
> contains this S-CSCF and sends the invite the outbound proxy 
> that it has learned via dhcp from the visited domain.

How does the user know about the exact instance of the S-CSCF,
which is prepared for handling his calls?

The Path header can also be used in the terminating case
(i.e. registar -> UA)
Let's assume, every UA has a default inbound proxy
(the same as DOP), and let's call this proxy P-CSCF.
When the call arrives at the registrar, it does not only
need to insert the registred Contact (i.e. the UA) address,
but also the P-CSCF address, which has to be passed
before the UA. (The P-CSCF is needed for controlling the
radio resources on the air interface.)

How would the S-CSCF know, which is the correct P-CSCF
of this particular user?
I don't think picking the correct Via entry of the register
request is a robust solution.

Note: Also P-CSCF is allocated dynamically.

>  > If there is a security (e.g. firewall) element between
>  > the UA and the S-CSCF (let's call this security element
>  > I-CSCF), the same mechanism can be used so that the
>  > INVITE can be routed smoothly through, without heavy
>  > processing in the proxies.
>  > These kind of scenarios I believe cannot be solved
>  > using your earlier proposal.
> 
> see above. using the outbound proxy of the visited domain 
> should get the messages through local firewalls.
> 
>  > The LOOSE routing does not fully cover the requirments,
>  > which are addressed by the Path header proposal.
>  > 
>  >  Conclusion:
>  >  Your proposal does not fullfill all requirements,
>  >  which can be solved by the Path header proposal. 
> 
> conclusion:  you still fail to show why path message is needed.

What about now?

> -- juha

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: [email-masked]
Date: Mon, 25 Feb 2002 19:28:39 +0200

> Thus, the call has to be routed to a specific instance of S-CSCF

i don't buy that argument.  you can use dns based load balancing instead
of a nailed down s-cscf.  nailed down anything is a very bad idea from
resiliency point of view.  you can also store your security stuff in a
database to which all s-cscfs have access.

 > But in certain architectures it does matter.

is should not matter. see above.

 > which is prepared for handling his calls?

according to the sip protocol specification, if an ua gets a list of srv
records for a domain, then ALL of them must be able to handle the calls
of that domain.  what you try to do is something that is against the
specification.  please call your stuff something else than sip and move
the discussion to the 3g list.

 > How would the S-CSCF know, which is the correct P-CSCF

this is a matter of implementation.  for example, the s-cscf could find
out the domain of the visited network and route the invite to its proxy.

 > What about now?

no better than before.  if you want to implement the g3 walled garden
and force customers messages to be routed via weird ways in stead of the
normal way, you get into these kind of weird proposals.

-- juha