Subject: RE: [Sip] 'sips' URI scheme (comments on proposal?)

From: "Beck01, Wolfgang" <[email-masked]>
Date: Mon, 18 Feb 2002 16:18:58 +0100

Eric Rescorla write:
> -----Original Message-----
> From: Eric Rescorla [mailto:[email-masked]]
> Michael Thomas <[email-masked]> writes:
> >    I'm well aware of that. I had to code up a BER
> >    parser in the late 80's for SNMP. It's still a
> >    pig.> It takes quite a bit of effort to hand
> >    code ASN.1, and even then you get messes like
> >    MIT's Kerberos code which is not only hand
> >    coded, but bloated on top of it.
> I'm sorry, but I don't see the relevance of this. Anything we
> require will force the embedded guys to change something and
> I'm certainly in favor of making that something as minimal as
> possible, consistent with the requirements of decent security.
> 
> What's presently at issue here is the actual impact of adding
> S/MIME as opposed to some non-S/MIME messaging system with
> similar functionality. Your argument about the piggishness
> of ASN.1 notwithstanding, my experience implementing such
> systems leads me to believe that the footprint of such a system
> will be roughly the same as S/MIME.
> 
When I had a first look at the TLS and S/MIME RfCs, I had similar feelings
as Mike. Both protocols appear as huge tasks, which require a lot of extra
development time. Your [Eric's] code size estimation indicate something
different, but for someone less experienced in security protocols it is
hard to decide what can be left off. It might be helpful to write down
the minimum TLS and S/MIME feature sets with respect to SIP in some
informational draft. I fear that with TLS and S/MIME a lot of implementors
will balk and end up without any encryption. 

--
Wolfgang Beck
T-Systems Nova GmbH 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Mon, 18 Feb 2002 13:42:51 -0500

Can someone explain why this entire conversation isn't completely MOOT?

SMIME is a MAY now. Yes, it doesn't work for every single possible
scenario, but there are unquestionably places where it IS useful. Thus,
this argument about whether its good or bad is just a plain WASTE OF
TIME.

I would appreciate if, instead, people could focus on reading and
reviewing the text, to make sure that when people do use the S/MIME
mechanisms, it is done properly.

-Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.            72 Eagle Rock Avenue
Chief Scientist                         First Floor
dynamicsoft                             East Hanover, NJ 07936
[email-masked]                 FAX: (973) 952-5050
http://www.jdrosen.net                  PH:  (973) 952-5000
http://www.dynamicsoft.com