Subject: RE: [Sip] bis-07.9: proxies are not allowed to modify message bod y

From: Adam Roach <[email-masked]>
Date: Fri, 22 Feb 2002 11:39:46 -0500

> -----Original Message-----
> From: Pete Cordell [mailto:[email-masked]]
> 
> All I was thinking was, if it saw something like:
> 
> m=audio 3456 RTP/AVP 0 7
> a=rtpmap:0 PCMU/8000
> a=rtpmap:7 LPC/44100/2     # Whatever linear CD quality is
> m=video 2232 RTP/AVP 51
> b=6000         # Haven't checked SDP, but looking for 6 Mbits/s
> a=rtpmap:51 H262/90000
> 
> in the messages that zipped past it, then it could change it to:
> 
> m=audio 3456 RTP/AVP 0     # No CD quality
> a=rtpmap:0 PCMU/8000
> m=video 2232 RTP/AVP 51
> b=128         # Limited to 128kbits/s
> a=rtpmap:51 H262/90000

Trying to do this sort of enforcement in the SIP signalling
layer is horribly, horribly misguided. If you need to enforce
this sort of policy, you'll need support at the access level;
there are a whole suite of protocols (RSVP, COPS, etc) designed
for exactly this.

If you try to do this with a SIP proxy, I will personally be
one of the first people on your network to build a client that
interprets "PCMU/8000" as "cd-quality-audio," give it to my
friends, and send whatever media I feel like, regardless of
what your meddlesome proxy thinks it has to say about it.

And I guarantee that I won't be the last.

/a

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Pete Cordell" <[email-masked]>
Date: Fri, 22 Feb 2002 18:04:54 -0000

Sure, if I want to be malicious I can do loads of things and I don't have to
wait until I receive a SIP INVITE to do it.  I can quite easily just fire
out loads of UDP packets and gobble up bandwidth that way.  After all,
saying something is PCMU when it is actually something else is not going to
make the dialog of any use to the remote UA.

I was really thinking more of a facilitating service rather than one that
was enforcing.  For example, it might be perfectly reasonable to use CD
quality on the internal LAN, but not across the enterprise access link.
Therefore a UA would want to declare that it can do CD quality on the off
chance that it might be useful, but be happy if some helpful intermediary
advised that you were probably going to loose most of your packets in you do
it across the access link (not to mention getting your managers upset).
Many, many people would be happy to work within those bounds, and something
that helps them get the right mix at the right time can only be helpful.

Besides, who said there wasn't any stick here.  The considerate proxy could
have a nasty side to it and actually talk to the firewall, a la Midcom, and
tell it to discard packets if this flow goes out of SLA.

So go ahead and build your client that interprets "PCMU/8000" as
"cd-quality-audio".  I'm sure it won't be the worst bastardisation of the
SIP spec.

Pete.

=============================================
Pete Cordell
Tech-Know-Ware
[email-masked]
+44 1473 635863
=============================================

----- Original Message -----
From: Adam Roach <[email-masked]>
To: 'Pete Cordell' <[email-masked]>; Bob Penfield
<[email-masked]>
Cc: <[email-masked]>
Sent: 22 February 2002 16:39
Subject: RE: [Sip] bis-07.9: proxies are not allowed to modify message body