Subject: Re: [Sip] more BNF issues

From: Rohan Mahy <[email-masked]>
Date: Sun, 3 Feb 2002 22:00:51 -0800

two comments inline...

[snip]

>> 
>>         sent-protocol = SIP-Version "/" transport
>> 
>> and delete protocol name and protocol version to be 
consistent with the
>> start-line.
>
>I don't feel strongly here, but am inclined to keep the 
current
>definition, as this is what has been specified in rfc2543, 
although with
>implicit LWS. Why remove it here and not other places?

i likewise don't have strong feelings here.  it just seems 
silly to use an explicit string for SIP-Version and then 
redefine the same string with some whitespace nobody will 
ever use.

i guess i feel like we have gone a bit overboard on the WS.  
i thought one the main benefits of using explicit whitespace 
was so you could get rid of some of it!   ;-)

>> - general comment.  using <'> instead of "'" would be more 
readable IMO
>Sorry; where is it used?

"'" is just used once -- in the definition of token

thx,
-r

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Mon, 04 Feb 2002 01:11:44 -0500

> was so you could get rid of some of it!   ;-)

Well, in all honest, I suspect most everyones parsers will accept lws
everywhere, since its more of a burden to special case it than to just
assume it is always there.

> "'" is just used once -- in the definition of token

Actually, reading rfc2234 carefully, I do not think I can make this
change. <> is used to surround rules that have a name. To me, that means
the rule is defined elswehere in the bnf. There is no defined rule for
', so I dont think I can do this. Then again, maybe I am reading too
much into it.

-Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.            72 Eagle Rock Avenue
Chief Scientist                         First Floor
dynamicsoft                             East Hanover, NJ 07936
[email-masked]                 FAX: (973) 952-5050
http://www.jdrosen.net                  PH:  (973) 952-5000
http://www.dynamicsoft.com

---

From: Jiri Kuthan <[email-masked]>
Date: Mon, 04 Feb 2002 17:33:44 +0100

>assume it is always there.

Well, that depends on what you think that a special case is. In my opinion,
useless whitespacess are a special case since they take additional
code. The more code, the less speed, the more bugs.

I don't feel strongly about what we do now, but when building a new
protocol I will strongly recommend against too much liberalism.

-Jiri