Subject: [Sip] Yet more bis-06 comments/nits

From: [email-masked]
Date: Fri, 1 Feb 2002 17:43:15 -0700

Final comments in case anyone is working the weekend to get these in
bis-07.  This was a crash review so I'm sure I missed plenty, but must say I
am very impressed with how this document is shaking out.  Excellent work by
all.

John Hearty
Level3

> 1. Section 3 in the text version (PDF version OK) is missing 
> a space in "SHALL NOT" (carried over from bis-05).
> 
> 2. The text on figure 1 on page 11 is all messed up in the 
> pdf version.  Looks like a different language.
> 
> 3. Line 389 indicates the example contains a minimum required 
> set, but the newly mandatory Max-Forwards is not included.  
> Max-Forwards also appears to be missing in other examples 
> that otherwise appear to have the other minimum required 
> headers, such as sections 11.1, 11.2, 21.4.1 (see note 

also 17.1.1.3

> below), 21.4.2, and all requests in section 26.  Note, it is 
> debatable whether a Max-Forwards is required in a tunneled 
> Invite as in section 21.4.1, this should get a bit of list 
> discussion.  My take is yes, incase some B2BUA or something 
> takes it out and forwards it un-tunneled.  I see no reason to 
> special-case this.
> 
> 4. Section 4, the example 200 OK has the Via list messed up.  
> Looks like the first Via in the list (line 456) should be the 
> last one (line 458).  The last Via has the wrong branch 
> compared to the Invite example.  The first Via should 
> probably have the biloxi domain in it, not the atlanta 
> domain, and something different than pc33 to avoid reader 
> confusion with the Via added by Alice's PC.
> 
> 5. Line 1040, I can't recall in the list discussion if there 
> was any specific reason to disallow the value from being more 
> or less than the selected value of 70 beyond future proofing 
> this for really big networks.  The current wording locks UACs 
> into always putting 70 in the header.  I can see including 
> the header is a MUST, but wonder if the stated value of 70 
> should be a SHOULD or RECOMMENDED to allow UAs some leeway.
> 
> 6. Line 1151, is timeout the ONLY thing the TU will see?  
> What happens when an ICMP host unreachable is returned?  Does 
> that not get to the TU?  Related to this, should line 1184 
> "or network timeouts" be "or network failures"?
> 
> 7. Line 1172 references non-existent section 22.10.
> 
> 8. Line 1334, sooon should be soon.
> 
> 9. Line 1351, delete last "the" in the line (grammar).
> 
> 10. Line 1353, "amd" should be "and".
> 
> 11. Line 1356 "complete" should be "completely".
> 
> 12. Section 10.1 of the text version has a space before a 
> comma in three places.  PDF version is OK (lines 1493-1495).  
> This was also a problem carried over from bis-05.
> 
> 
> Continued:
> 
> 13. Line 1601, remove period after "using".
> 
> 14. Line 1668, "MUST then converted" should be "MUST then be 
> converted".
> 
> 15. Releated to item 5 above, lines 1718-1722 imply varying 
> values of Max-Forwards can be sent by a UA, in conflict with 
> the language in line 1040.
> 
> 16. Line 1792, remove dash after "method".
> 
> 17. Looks like conversion corruption is taking place after 
> italicized words "route set". Section 12.2.1.1, 12.2.1.2 and 
> 12.2.2 in the text version has some missing text compared to 
> the PDF version lines 1909, 1915, 1923 and 1976.  There is an 
> unneeded space in the text version between "route set" and 
> following comma (corresponding to line 1911, 1937, 1962 and 
> 1977 in PDF).  There is a missing period in the text version 
> after "route set" corresponding to line 1939.
> 
> 18. Line 2059, "construction" should be "constructing" 
> (carried over from bis-05).
> 
> 19. The text version has indented text corresponding to PDF 
> version lines 2267-2268 which is not indented.
> 
> 20. Line 2288, "BYE of CANCEL"  should be "BYE or CANCEL".
> 
> 21. The text version has indented text corresponding to PDF 
> version lines 2290-2292 which is not indented.
> 
> 22. Line 2406 has "request." which is missing in 
> corresponding text version section 16.3.
> 
> 23. Lines 2428-2429 in PDF are indented, corresponding text 
> in text version is not indented.
> 
> 24. Lines 2574-2577 in PDF are indented, corresponding text 
> in text version is not indented.
> 
> 25. Line 2583 is related to items 5 and 15 above.  Also, 
> whatever verbage is arrived at on that issue, should have a 
> MUST to add the Max-Forwards (it's currently lower case).  
> This is because section 16.3 #2 allows missing Max-Forwards, 
> and #3 following it allows loop detection to be optional.  
> With those two items, a proxy MUST add the Max-Forwards 
> header if missing to prevent loops from going undetected.
> 
> 26. Line 2595, "wishes remain" should be "wishes to remain".
> 
> 27. Line 2598 in PDF is indented, corresponding text in text 
> version is not indented.
> 
> 28. Lines 2603-2605 in PDF are indented, corresponding text 
> in text version is not indented.
> 
> 29. Lines 2616-2618 in PDF are indented, corresponding text 
> in text version is not indented.
> 
> 30. Line 2650, "by transaction" should be "by the transaction".
> 
> 31. Line 2671, "address that ordered set" should be "address 
> in that ordered set".
> 
> 32. Line 2679, "MUST set" should be "MUST be set".
> 
> 33. Lines 2729-2732 in PDF are indented, corresponding text 
> in text version is not indented.
> 
> 34. Lines 2749-2754 in PDF are indented, corresponding text 
> in text version is not indented.
> 
> 35. Lines 2802-2807 in PDF are indented, corresponding text 
> in text version is not indented.

36. Line 3132 has space before period.  This also resulted in period
wrapping to next line in text version.

37. Line 3140-3141 "that that" should be "that".

38. Section 17.2.1 Figure 7 title is too low, overwriting the page footer.
Same for figure 8 under section 17.2.3.

39. Section 18.1 and 18.2 in the text version has multiple occurences of
missing text and space before comma corruption problems following instances
of "100rel".

40. Line 3385, "a Unsupported" should be "an Unsupported".

41. Line 3400, "must contain Require header" should be "must contain a
Require header".

42. Line 3545, don't stateful proxies also forward stray responses
statelessly?  If so, the word "stateless" in this line might best be
removed.

43. Line 4588, what about TLS transport (port 5061)?

44. Line 4600 has bad section link.

45. Line 5264-5266 should probabally be reworded a little in light of
100rel.

46. Line 5414, bad section reference.

47. Section 26.2 Via headers (other than top Via) are missing received= parm
where required since changing to FQDNs.

48. Section 26 Via headers in 26.1 F1, F2, and 26.2 F13 & F14 are not
changed to Recommended FQDN.

49. Lines 5734-5735 are extraneous and should be removed.

John Hearty
Level3

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Robert Sparks <[email-masked]>
Date: Mon, 04 Feb 2002 15:58:06 -0600

Thanks for the scrutiny John - this is great help.

We got many of these before -07 was released. I fixed the rest of the
nits today and entered bugs against the bigger issues.

See responses inline -

>>a space in "SHALL NOT" (carried over from bis-05).

This is an artifact of the tool used to build .txt files from the
TeX output (as are many of the other comments below). For some of
these we can fix the tool. For others, we'll have to make manual
fixes after processing. In the interim builds, we're catching what
we need to in order for the text to be legible. More attention to
the layout detail will go into the final build (afaik, the RFC editor
will still push it all through an NROFF step to produce the RFC text
version, so there is a point of diminishing returns with fighting the
margin format type errors during these steps). Keep reporting these
kinds of errors as you see them though.

>>pdf version.  Looks like a different language.

Fixed

>>takes it out and forwards it un-tunneled.  I see no reason to 

I did a global pass through the document and added Max-Forwards
to example requests that were supposed to be complete, including
inside the referenced tunnelled message.

>>confusion with the Via added by Alice's PC.

Fixed

>>should be a SHOULD or RECOMMENDED to allow UAs some leeway.

Changed text to reflect SHOULD and motivate the choice of 70.

>>"or network timeouts" be "or network failures"?

This didn't get fixed for -07 - I've opened a bug against it.

>>7. Line 1172 references non-existent section 22.10.

Fixed

>>8. Line 1334, sooon should be soon.

Fixed

>>9. Line 1351, delete last "the" in the line (grammar).

Fixed

>>10. Line 1353, "amd" should be "and".
Fixed

>>11. Line 1356 "complete" should be "completely".
Fixed

>>This was also a problem carried over from bis-05.

conversion to text (see 1)

>>13. Line 1601, remove period after "using".

Fixed

>>14. Line 1668, "MUST then converted" should be "MUST then be 
Fixed

>>the language in line 1040.

Fixed (See 5)

>>16. Line 1792, remove dash after "method".

Fixed

>>after "route set" corresponding to line 1939.

I think I got all these for -07, let me know if you still see
something broken.

>>(carried over from bis-05).

Fixed

>>version lines 2267-2268 which is not indented.

text conversion (see 1)

>>20. Line 2288, "BYE of CANCEL"  should be "BYE or CANCEL".

Fixed

>>version lines 2290-2292 which is not indented.

21 through 24 are text conversion (see 1)

>>header if missing to prevent loops from going undetected.

Fixed (see 5)

>>26. Line 2595, "wishes remain" should be "wishes to remain".

Fixed

>>27. Line 2598 in PDF is indented, corresponding text in text 

27-29 are text conversion (see 1)

>>30. Line 2650, "by transaction" should be "by the transaction".

Fixed

>>31. Line 2671, "address that ordered set" should be "address 

Fixed

>>32. Line 2679, "MUST set" should be "MUST be set".

Fixed

>>in text version is not indented.

33-35 are text conversion (see 1)

> wrapping to next line in text version.

Fixed

> 37. Line 3140-3141 "that that" should be "that".
Fixed

> Same for figure 8 under section 17.2.3.

Bug entered against this

> missing text and space before comma corruption problems following instances

text formatting (see 1), but I think I may have avoided the bug with a 
minor change to the source - See if this goes away in -08.

> 40. Line 3385, "a Unsupported" should be "an Unsupported".

Fixed

> 41. Line 3400, "must contain Require header" should be "must contain a

Fixed

> statelessly?  If so, the word "stateless" in this line might best be

Yes, transaction stateful proxies would forward strays statelessly. 
However, they don't forward _all_ responses, so striking the word
stateless isn't the right change. We'll clean this up.

> 43. Line 4588, what about TLS transport (port 5061)?

Well, this gets interesting.

Turns out that to align with sip-srv, this whole rule is going to go away.

sip:foo;transport=tls is not equivalent to sip:foo:5061;transport=tls
and more shockingly
sip:foo is not equivalent to sip:foo:5060

This is because sip:foo and sip:foo:5060 will resolve differently 
(potentially to different addresses) under the mechanisms in sip-srv

There is a bug against the URI section to modify this bullet accordingly.

> 44. Line 4600 has bad section link.

Fixed

> 45. Line 5264-5266 should probabally be reworded a little in light of

Done.

> 46. Line 5414, bad section reference.

Fixed

> where required since changing to FQDNs.

bug entered

> changed to Recommended FQDN.

bug entered

> 49. Lines 5734-5735 are extraneous and should be removed.

*Laugh* - you are _too_ kind...
They are gone.