Subject: RE: [Sip] draft-ietf-sip-events-04; Questions

From: "Chiou, Mark" <[email-masked]>
Date: Wed, 27 Feb 2002 14:11:31 -0600

Hi Adam,

I have the following questions regarding to 7.4 new Method:

1. Why the Contact header is mandatory for SUBSCRIBER and NOTIFY? If the Contact is not applicable to these methods, then "-" should be applied to R, 1xx, 2xx, 3xx, and 485.
2. I don't think 3xx is applicable to these two methods, such that contact 3xx should have "-" instead of "o".

Regards,

Mark Chiou

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Adam Roach <[email-masked]>
Date: Thu, 28 Feb 2002 11:32:14 -0500

> -----Original Message-----
> From: Chiou, Mark [mailto:[email-masked]]
> 
> 1. Why the Contact header is mandatory for SUBSCRIBER and 
> NOTIFY? If the Contact is not applicable to these methods, 
> then "-" should be applied to R, 1xx, 2xx, 3xx, and 485.

Contact headers form an important part of the route. This
behavior mirrors that of the bis draft.

> 2. I don't think 3xx is applicable to these two methods, such 
> that contact 3xx should have "-" instead of "o".

3xx responses are applicable to all methods, and there's nothing
that an extension can do about it. Redirect servers will always
redirect unknown methods.

I could also argue that 3xx responses can be quite useful
for SUBSCRIBE, with some fairly compelling examples, but
the above fact makes it a rather moot point.

/a