Subject: [Sip] bis08 - telephone-subscriber in rfc2806 and escaped characters

From: "JF Rey" <[email-masked]>
Date: Mon, 25 Feb 2002 22:31:32 +0800

I know that this topic has already been
discussed.

I found this in the archives :

<QUOTE_ARCHIVES>
From: Jonathan Rosenberg 
To: Rohan Mahy 
CC: [email-masked]
Subject: Re: [Sip] bis-06 BNF issues

[snip]
> 
> 13) telephone-subscriber should match 
definition in RFC2806 which also
> allows several other characters, for example:
> 
>         *  #  A  B  C  D   p  w  (  )

Yes. That one has been fixed. The spec now points to rfc2806 for the
BNF. Not sure thats the right thing either, since that bnf allows for
some stuff that is not allowed in the user part... For now, it
references 2806 and says you need to escape stuff that is not allowed.
</QUOTE_ARCHIVES>

Why must these characters be escaped in the
user part ? What would be the problem if they
were not escaped ?

Jean-Francois.

-- 

_______________________________________________
Sign-up for your own FREE Personalized E-mail at Mail.com
http://www.mail.com/?sr=signup

1 cent a minute calls anywhere in the U.S.!

http://www.getpennytalk.com/cgi-bin/adforward.cgi?p_key=RG9853KJ&url=http://www.getpennytalk.com

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: [email-masked]
Date: Tue, 26 Feb 2002 09:04:22 +0530

Hi,

The escaping is done primarly to avoid  confusions while parsing the url.
For more details please refer rfc2396 (Uniform Resource Identifiers (URI):
Generic Syntax)

regds
mahesh

"JF Rey" <[email-masked]> on 02/25/2002 08:01:32 PM

To:   [email-masked]
cc:    (bcc: Mahesh Govind/HSSBLR)

Subject:  [Sip] bis08 - telephone-subscriber in rfc2806 and escaped
      characters

<QUOTE_ARCHIVES>
From: Jonathan Rosenberg
To: Rohan Mahy
CC: [email-masked]

[snip]

Jean-Francois.

--

http://www.getpennytalk.com/cgi-bin/adforward.cgi?p_key=RG9853KJ&url=http:/
/www.getpennytalk.com