Subject: RE: [Sip] note: change in URI comparison rules coming

From: "James Undery" <[email-masked]>
Date: Mon, 18 Feb 2002 09:24:07 -0000

> -----Original Message-----
> From: Jonathan Rosenberg [mailto:[email-masked]]

> James Undery wrote:
> > 
> > Good.
> > 
> > Well while we're at it can I suggest we remove all default 
> values  from
> > SIP URIs. 
> 
> Whoa there partner.
> 
> We didn't remove defaults for either port or transport; we merely said
> that an explicit value does not equal the default. We still need a
> default unless you want to force everyone to include them 
> explicitly in
> each request.

Sorry, I did mean just the comparison.

> My reasoning would be, port and transport seemed the least
> > arbitrary. The user parameter has consistently been abused; 
> the method
> > parameter defaulting to INVITE doesn't seem so convincing in these
> > SIMPLEr times; ttl does this really justify a default 
> parameter, if you
> > insist on using multicast you should do it properly with 
> some thought.
> > 
> > This also results in a far simpler comparison rule, that's 
> easy to grasp
> > and apply.
> 
> Sorry - are you arguing for removal of defaults, or that the default
> should never equal the explicit value? That is:
> 
> sip:[email-masked];ttl=1
> sip:[email-masked]
> 
> would not be equal? I could be convinced to go full court on this
> one....

Bingo, exactly what I intended to say. With the additional change to
multicast ttl this appears to be making more sense, to me atleast.

James 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Mon, 18 Feb 2002 04:34:36 -0500

James Undery wrote:

> multicast ttl this appears to be making more sense, to me atleast.

OK, I'm game. I'll log it into bugzilla. 

Thanks,
Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.            72 Eagle Rock Avenue
Chief Scientist                         First Floor
dynamicsoft                             East Hanover, NJ 07936
[email-masked]                 FAX: (973) 952-5050
http://www.jdrosen.net                  PH:  (973) 952-5000
http://www.dynamicsoft.com