Subject: [Sip] Report an error on BYE

From: [email-masked]
Date: Mon, 4 Feb 2002 13:52:46 +0200

One thing that I think the BYE message is missing: there's no way to 
signal an error condition that caused the "BYE" - as reason codes are 
available only in responses.
It would be nice if the "Warning" header was allowed, and thus a 
reason-code could be passed along as a hint for the reason this BYE was 
sent.
The new BNF now actually supports it (as there's no distinction between 
"General-Header", "Request-Header" and "Response-Header".
The absence of such reason-code means "normal user disconnect"

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Christer Holmberg <[email-masked]>
Date: Mon, 04 Feb 2002 14:05:41 +0200

Hi,

Please have a look at draft-schulzrinne-sip-reason-00.txt.

Regards,

Christer Holmberg
Ericsson Finland