Subject: [Sip] REFER and Replaces with early dialogs

From: "JF Rey" <[email-masked]>
Date: Thu, 14 Feb 2002 22:20:15 +0800

I'm quite sure that someone already asked about this, but I did not find it in the archives.

I try to understand whether a SIP phone can transfer another one when the target of
the transfer is ringing.

draft-biggs-sip-replaces-01.txt states that
<DRAFT_QUOTE>
The to-tag and from-tag parameters MUST be included in the Replaces header, 
</DRAFT_QUOTE>
and
<DRAFT_QUOTE>
If the Replaces header matches an unestablished call leg, that it,
   the INVITE request for the call has not received or been sent a final
   response, the Replaces header MUST be ignored.
</DRAFT_QUOTE>

I don't understand the last sentence. Why ignore Replaces even if a match was found
thanks to it ?

In bis07, the to-tag is mandatory for 1xx (other than 100) responses. So, Replaces 
could match an early dialog as soon as a 1xx  (other than 100) is sent/received.

Did I overlook something ?

Regards,

Jean-Francois Rey
-- 

_______________________________________________
Sign-up for your own FREE Personalized E-mail at Mail.com
http://www.mail.com/?sr=signup

Win a ski trip!
http://www.nowcode.com/register.asp?affiliate=1net2phone3a

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Alan Johnston <[email-masked]>
Date: Thu, 14 Feb 2002 08:32:22 -0600

Hi Jean-Francois,

The latest version of this draft is:

http://search.ietf.org/internet-drafts/draft-ietf-sip-replaces-00.txt

and now allows Replaces to match an early dialog. The Service Examples
I-D will soon be updated to show some of these flows. 

Thanks,
Alan Johnston
WorldCom
sip:[email-masked]

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of JF Rey
> Sent: Thursday, February 14, 2002 8:20 AM
> To: [email-masked]
> Subject: [Sip] REFER and Replaces with early dialogs
> 
> 
> I try to understand whether a SIP phone can transfer another 
> one when the target of the transfer is ringing.
> 
>    response, the Replaces header MUST be ignored. </DRAFT_QUOTE>
> 
> I don't understand the last sentence. Why ignore Replaces 
> even if a match was found thanks to it ?
> 

Win a ski trip!

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip Use
[email-masked] for new developments on the application of sip