Subject: RE: [Sip] S/MIME in SIP

From: "Steffen Fries" <[email-masked]>
Date: Thu, 28 Feb 2002 08:52:54 +0100

Thast true, TLS is one option, but it relies on the usage of 
TCP. When TLS is used for hop-by-hop security, also the link 
between the UA and the Poxy must be TCP (which is still 
optional in bis08).

Steffen

From:           	"Peterson, Jon" <[email-masked]>
To:             	"[email-masked]'" 
<[email-masked]>,
  	[email-masked]
Subject:        	RE: [Sip] S/MIME in SIP
Date sent:      	Thu, 28 Feb 2002 01:46:50 -0600

> 
> TLS, among other things, can secure SIP on a hop-by-hop basis. This is
> discussed in the Security Considerations of bis08.
> 
> Jon Peterson
> NeuStar, Inc.
> 
> > -----Original Message-----
> > From: Steffen Fries [mailto:[email-masked]]
> > Sent: Wednesday, February 27, 2002 11:34 PM
> > To: [email-masked]
> > Subject: [Sip] S/MIME in SIP
> > 
> > 
> > Hi,
> > 
> > by reading the current SIP draft I've got a question. 
> > The S/MIME option described in the current bis-08 seems to be 
> > only thought for end-to-end usage. 
> > Is there any scenario/option where it would be used for 
> > securing messages hop-by-hop. If yes, how is this realised 
> > technically. 
> > For instance when a UA would send a message with S/MIME 
> > tunneled authentication and integrity to a Proxy, how does the 
> > Proxy determine that he is in charge of checking the integrity 
> > of the message and also to calculate an ICV for the next hop? 
> > This example assumes that all entieties have the appropriate 
> > certificates available.
> > 
> > Regards
> > 	Steffen
> > ___________________________________________________________
> > Steffen Fries,     Siemens AG, CT IC 3	
> > Otto-Hahn-Ring 6,  D-81730 Munich, Germany 
> > Phone:  (+49) 89 / 636-53403, Fax  :  (+49) 89 / 636-48000
> > Email:  [email-masked]
> > ___________________________________________________________
> >     This email was written on 100% recycled bytes!
> > 
> > 
> > 
> > _______________________________________________
> > Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> > This list is for NEW development of the core SIP Protocol
> > Use [email-masked] for questions on current sip
> > Use [email-masked] for new developments on the application of sip
> > 
> 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Peterson, Jon" <[email-masked]>
Date: Thu, 28 Feb 2002 01:46:50 -0600

Jon Peterson
NeuStar, Inc.

---

From: Jari Arkko <[email-masked]>
Date: Thu, 28 Feb 2002 10:23:13 +0200

> discussed in the Security Considerations of bis08.

We seem to have relatively good coverage of hop-by-hop and end-to-end,
but sometimes I miss more functionality for end-to-middle, such as the
ability for me to encrypt something and deliver it to my home / home
operator proxy without evil intervening proxies (e.g. the P-CSCF)
seeing it... I know this can be done with B2BUAs but I'm told it
isn't always so desireable to take the B2BUA approach either (see Dean's
heart surgery analogy in some recent thread about that).

Jari