Subject: Re: [Sip] SIP version related statement in bis-08

From: Gabor Fenyes <[email-masked]>
Date: Wed, 27 Feb 2002 16:27:44 +0100 (MET)

Hello,

> I see following statement in bis-08 pdf version page number 21.
>
> "The SIP-Version string is case- insensitive, but implementations MUST send
>  upper-case."
>
> Why is the statement so?
>
> either we must say :
> "The SIP-Version string is case- insensitive, but implementations SHOULD
> send upper-case."
>
>                                                     ========
> or
> "The SIP-Version string is case- sensitive, but implementations MUST send
> upper-case."
>                                                               =========
>
> The statement in the current form doesnt make sence.
> please correct.

It makes perfect sense for backwards compatibility.  You must be prepared
to receive it case insensitively, but if you conform to the new standard
you MUST send all upper-case.

Regards,

Gabor

-----
Gabor Fenyes                    [email-masked]
Support Engineer                Phone:  +36-1-437-7834
Conformance Center (ETH/RLS)    Fax:    +36-1-437-7767
Ericsson Hungary Ltd.           PO Box 107, 1300 Budapest, Hungary
-----

"Nothing so fortifies a friendship as a belief on the part of one
 friend that he is superior to the other."

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: [email-masked]
Date: Wed, 27 Feb 2002 20:43:29 +0530

Hi all,

Why is the statement so?

either we must say :

                                                    ========
or

regards,
Shetti