Subject: [Sip] RE: [Sip-implementors] draft-ietf-sip-service-examples-03.txt

From: "Yadavalli, Satyamurthy" <[email-masked]>
Date: Thu, 7 Feb 2002 11:43:49 -0500

I keep hearing these terms 3pcc, B2BUA, and other approaches etc., and I
wonder how different vendors of SIP components (UAs, proxy servers etc.,)
will be able to realize  supplementary features (sip-service-examples) each
independantly presuming an  approach for each feature.
The same thing said differently: for a simple feature like call
forwarding....should the UA do it or should the proxy do it. If there exists
no specification how would different vendors interoperate to achieve the
call control features across networks?
-satya

> -----Original Message-----
> From: Alan Johnston [mailto:[email-masked]]
> Sent: Wednesday, January 23, 2002 2:45 PM
> To: 'Aymeric MOIZARD'
> Cc: [email-masked]
> Subject: RE: [Sip-implementors] draft-ietf-sip-service-examples-03.txt
> 
> 
> Hi Aymeric,
> 
> An example of where 3pcc or B2BUA might be a better choice would be if
> some of the UAs invoved in a session to be transferred do not support
> the REFER method. Generally, the advantage of 3pcc or B2BUA 
> is that they
> rely on SIP without requiring extensions or feature support.
> 
> Thanks,
> Alan Johnston
> WorldCom
> sip:[email-masked]
> 
> > -----Original Message-----
> > From: [email-masked] 
> > [mailto:[email-masked]] On Behalf Of 
> > Aymeric MOIZARD
> > Sent: Monday, January 21, 2002 9:36 AM
> > Cc: [email-masked]
> > Subject: [Sip-implementors] draft-ietf-sip-service-examples-03.txt
> > 
> > 
> > 
> > Hi,
> > the draft "draft-ietf-sip-service-examples-03.txt"
> > states in the "1. Overview" section that:
> > 
> > "...Also, these flows do not represent the only way to 
> > implement these services - other approaches such as 3pcc 
> > (Third Party Call Control) or Back-to-Back User Agents 
> > (B2BUA) may be more appropriate in some circumstances."
> > 
> > Does anybody can help and give some highlights about which 
> > "circumstances" can lead to choosing another approach.
> > 
> > Thanks
> > Aymeric
> > _______________________________________________
> > Sip-implementors mailing list
> > [email-masked] 
> > http://lists.cs.columbia.edu/mailman/listinfo/> sip-implementors
> > 
> 
> _______________________________________________
> Sip-implementors mailing list
> [email-masked]
> http://lists.cs.columbia.edu/mailman/listinfo/sip-implementors
> 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Fri, 08 Feb 2002 12:51:16 -0500

> call control features across networks?

The SIP spec doesn't tell an operator what services to role out, where
to put them, and so on. The sip spec, and the rest of the
specifications, ensure that the proper SIP tools exist to make the
service work.

Let us take the case of forwarding. It can be done in a proxy in the
network, or in a UA. If a provider chooses not to do it, all that means
is that their service doesn't offer the feature. You can choose to get a
UA that does it, or not, and that would be a user's choice. If the
provider does implement it, the user can make use of that service, or
disable it, and then have it provided on their UA. In all cases, there
is no interop problems at all. 

-Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.            72 Eagle Rock Avenue
Chief Scientist                         First Floor
dynamicsoft                             East Hanover, NJ 07936
[email-masked]                 FAX: (973) 952-5050
http://www.jdrosen.net                  PH:  (973) 952-5000
http://www.dynamicsoft.com

---

From: Suheel Hussain <[email-masked]>
Date: Fri, 08 Feb 2002 13:03:36 -0500

Satya,

 From point of view, SIP pushes major decisions -- call setup, etc. -- into
UA. For all practical purpose proxy should not take part in 
call-control. It is
upto network designer to designate one or more UAs as call manager to
provide features like call forwarding.

-suheel