Subject: RE: [Sip] Proxies adding bodies

From: [email-masked]
Date: Tue, 5 Feb 2002 10:02:48 -0700

Another good point.  bis editors, please advise what changes to table 2
will be made.  At minimum, "a" needs to be added to the proxy column for
Content-Length, "m" also needs to be added to the proxy column to allow
firewall control proxies to remain compliant.

> -----Original Message-----
> From: Christer Holmberg [mailto:[email-masked]]
> Sent: Tuesday, February 05, 2002 9:48 AM
> To: Hearty, John
> Cc: [email-masked]; [email-masked]
> Subject: Re: [Sip] Proxies adding bodies
> 
> 
> 
> Hi,
> 
> Even if the message body itself isn't changed, a Content-Length header
> has to be ADDED if a message received on UDP, to be forwarded by the
> proxy on TCP, didn't contain a Content-Length header 
> (optional for UDP,
> but mandatory for TCP).
> 
> Regards,
> 
> Christer Holmberg
> Ericsson Finland
> 
> 
> 
> [email-masked] wrote:
> > 
> >  Good point.  The firewall control proxies discussed in a 
> thread earlier
> > today need to be able to modify Content-Length, but table 2 
> does not allow
> > this...
> > 
> > John Hearty
> > Level3
> > 
> > > -----Original Message-----
> > > From: Miguel A. Garcia [mailto:[email-masked]]
> > > Sent: Tuesday, February 05, 2002 9:20 AM
> > > To: [email-masked]
> > > Subject: [Sip] Proxies adding bodies
> > >
> > >
> > > Hi:
> > >
> > > I am thinking of a scenario where a proxy is adding a body to
> > > the SIP message,
> > > just to transport some sort of information that is only of
> > > use within the
> > > network where the proxy is operating.
> > >
> > > According to the SIP bis-07, I see that table 2 restricts a
> > > proxy the ability
> > > to modify the Content-Type, Content-Length and other
> > > suitables parameters that
> > > are needed to describe a possible new body added by a proxy.
> > >
> > > Why is it forbidden that a proxy modifies the Content-Length
> > > and Content-Type
> > > of a message? Any good reason?
> > >
> > > /Miguel
> > > --
> > > Miguel-Angel Garcia                     Oy LM Ericsson AB
> > >                                         Jorvas, Finland
> > > mailto:[email-masked]     Phone:  +358 9 299 3553
> > > mailto:[email-masked]        Mobile: +358 40 5140002
> > >
> > > _______________________________________________
> > > Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> > > This list is for NEW development of the core SIP Protocol
> > > Use [email-masked] for questions on current sip
> > > Use [email-masked] for new developments on the 
> application of sip
> > >
> > 
> > _______________________________________________
> > Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> > This list is for NEW development of the core SIP Protocol
> > Use [email-masked] for questions on current sip
> > Use [email-masked] for new developments on the application of sip
> 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Miguel A. Garcia" <[email-masked]>
Date: Tue, 05 Feb 2002 19:17:38 +0200

Hi:

Based on the discussion, I believe that both the Content-Length and
Content-Type should have "am" in the proxy column in table 2.

/Miguel

---

From: Christer Holmberg <[email-masked]>
Date: Tue, 05 Feb 2002 19:20:57 +0200

Hi,

Whar about Content-Encoding? The proxy could, for example, encode the
message body (for compression/whatever purpose...).

In fact, maybe all these issues affect most (every?) Content-Xxx
header...

Regards,

Christer Holmberg
Ericsson Finland

---

From: Robert Sparks <[email-masked]>
Date: Tue, 05 Feb 2002 12:44:38 -0600

The plan is "amr"

RjS