Subject: [Sip] CSeq question?

From: Brazier Lachlan <[email-masked]>
Date: Thu, 14 Feb 2002 12:58:59 +0100

Hello,

probably awnsered long ago, but I couldn't find it :-(

The reason I ask is, that it wasn't clear to me, if the increasing of the
CSeq value in a dialog is bound to a request class (INVITE, BYE, MYREQUEST,
etc.) or to requests in general.

Do I read the draft correct with:

INVITE .....
CSeq: 1 INVITE

200 Ok
CSeq: 1 INVITE

ACK ----
CSeq: 1 ACK

--Dialog is established--

BYE .....
CSeq: 2 BYE

200 Ok
CSeq: 2 BYE

This means, in the BYE request ( or any other request except of CANCEL +
ACK) a CSeq with value "1 BYE" is not allowed?

But for CANCEL:

INVITE .....
CSeq: 1 INVITE

--Dialog is not established--

CANCEL ....
CSeq: 1 CANCEL

Thanks
Lachlan

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Fri, 15 Feb 2002 16:10:31 -0500

> etc.) or to requests in general.

All requests sent from A to B within a dialog, independent of the
method, have increasing CSeq, by value of 1, with two exceptions:

  1. ACK for an INVITE has the same cseq as the invite
  2. cancel for a request has the same cseq as request

So:

INVITE (cseq: 1) ---->
200 (1)<--------
ACK (1)--------->

INFO (2)--------->
200 OK (2)<-------

BYE (3) --------->
200 OK (3)<------

Can you point me to text in bis that would lead you to believe it was
per method? I think the text is pretty clear:

From 12.2.1.1:

The Call-ID of the request MUST be set to the Call-ID of the dialog.
Requests within a dialog MUST 1872
contain strictly monotonically increasing and contiguous CSeq sequence
numbers (increasing-by-one) in 1873
each direction. Therefore, if the local sequence number is not empty,
the value of the local sequence number 1874
MUST be incremented by one, and this value MUST placed into the Cseq
header. If the local sequence 1875
number is empty, an initial value MUST be chosen using the guidelines of
Section 8.1.1.5. The method field 1876
in the Cseq header MUST match the method of the request. 1877

-Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.            72 Eagle Rock Avenue
Chief Scientist                         First Floor
dynamicsoft                             East Hanover, NJ 07936
[email-masked]                 FAX: (973) 952-5050
http://www.jdrosen.net                  PH:  (973) 952-5000
http://www.dynamicsoft.com