Subject: RE: [Sip] bis-07 comment: Min-Expires header nit

From: "Drage, Keith (Keith)" <[email-masked]>
Date: Wed, 13 Feb 2002 10:30:49 -0000

The new text fixes my problem, in that it gets rid of the "to".

Keith

Keith Drage
Lucent Technologies
Tel: +44 1793 776249
Email: [email-masked]

> ----------
> From: 	Jonathan Rosenberg[SMTP:[email-masked]]
> Sent: 	13 February 2002 5:44
> To: 	Drage, Keith (Keith)
> Cc: 	[email-masked]'
> Subject: 	Re: [Sip] bis-07 comment: Min-Expires header nit
> 
> inline:
> 
> "Drage, Keith (Keith)" wrote:
> > 
> > The current text of section 24.23 specifies:
> > 
> >                 24.23 Min-Expires
> > 
> >                 The Min-Expires header field conveys the minimum
> > registration expiration interval to a registrar. The header field
> > contains a
> > decimal integer number of seconds. The use of the header field in a 423
> > (Registration Too Brief) response is described in Sections 10.2.8, 10.3,
> > and
> > 25.4.17.
> > 
> > As this header is only included in a response, then surely the 1st
> > sentence
> > of the text should say something like
> > 
> >         ...from a registrar...
> 
> This text has already been reworded to allow reuse of this error code
> for sip-events. The above text is too registrar specific. The new text
> reads:
> 
> The \header{Min-Expires} header field conveys the minimum refresh
> interval
> supported for soft-state elements managed by that server. This 
> includes \header{Contact} headers that are stored by a registrar. The
> header
> field contains a decimal
> integer number of seconds from 0 to (2**32)-1.
> 
> -Jonathan R.
> -- 
> Jonathan D. Rosenberg, Ph.D.            72 Eagle Rock Avenue
> Chief Scientist                         First Floor
> dynamicsoft                             East Hanover, NJ 07936
> [email-masked]                 FAX: (973) 952-5050
> http://www.jdrosen.net                  PH:  (973) 952-5000
> http://www.dynamicsoft.com
> 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Aymeric MOIZARD <[email-masked]>
Date: Wed, 13 Feb 2002 14:23:22 +0100

my question concerns the route refresh mechanism.
This is located in bis-07 in 12.2 Requests within a Dialog

For a UAS:
  "Requests within a dialog MAY contain Record-Route and Contact header
   fields.  However, these requests do not cause the dialog's route set
   to be modified, although they may modify the remote target URI."

So requests which are route refresh requests do not update the
Route set!

For a UAC:

   "When a UAC recieves a 2xx response to a route refresh resquest, it
   MUST replace the dialog's remote target URI with the URI from the
   Contact header field in that response, if present."

So requests which are route refresh requests do not update the
Route set!

Back to the Global defintion of route refresh request:
   "A route refresh request sent within a dialog is defined as a request
   that can modify the route set of the dialog."

I do not understand why those method are named "route refresh request"?
In either cases (UAC or UAS), those requests can only modify the
remote target URI. As far as I understand, those requests should
be named "remote target refresh request"!

Did I miss something? Is there any cases where the route set COULD/MUST
be modified?

Thanks
Aymeric

---

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 13 Feb 2002 10:37:10 -0500

Inline.

> So requests which are route refresh requests do not update the

Yup, weird, isn't it?

> So requests which are route refresh requests do not update the

True again.

> be named "remote target refresh request"!

Indeed. We already recognized this, and the name has already been
updated.
The name is an artifact of the way routing was working pre-bis-06.

Thanks,
Jonathan R.