Subject: RE: [Sip] use of TCP in bis07

From: "Sanjoy Sen"<[email-masked]>
Date: Mon, 18 Feb 2002 15:04:32 -0600

> -----Original Message-----
> From: Jonathan Rosenberg [mailto:[email-masked]]
> 
> Sanjoy Sen wrote:
> > 
> > lines 3587-3590: If a request is within 500 bytes of the 
> path MTU, or if
> > it is larger
> >    than 1000 bytes when the path MTU is unknown, it MUST be 
> sent using
> >    TCP. This is to prevent fragmentation of messages over 
> UDP, and to
> >    provide congestion control for larger messages.
> > 
> > Although I agree with the intent, this would force 
> terminals to use TCP
> > in many cases - this may not be suitable for many smaller mobile
> > terminals. This should be relaxed from MUST to SHOULD.
> 
> That is not acceptable based on IESG feedback on this question
> specifically. I think that is a fair position; we really want to make
> sure TCP is used for messages that would otherwise fragment.
>
Why is using UDP for any request message < MTU, and using TCP for
transmitting the response if the response > MTU, not acceptable?

---

From: Juha Heinanen <[email-masked]>
Date: Mon, 18 Feb 2002 23:48:56 +0200

> transmitting the response if the response > MTU, not acceptable? 

i asked this same question long time ago, i.e., why can't sip be
transport independent.  i don't remember the details why it didn't work,
but it didn't. the answer can be found in the archives.

-- juha

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip