Subject: RE: [Sip] Question on Section 16.5 Step 7

From: "George Foti (LMC)" <[email-masked]>
Date: Wed, 20 Feb 2002 09:24:54 -0500

Thanks. One more.
Quoting the same paragraph in step 7: lines 2725-2729.

If the proxy has reformatted the request to send to a  strict-routing
element as described in step 6 above, the proxy MUST apply those procedures
to the Request-URI of the request. Otherwise,  the proxy MUST apply those
precdures to the first value in the Route header fiedl if present, else the
Request-URI.

Why is the else needed. Isn't that already covered in the first line?

Rgds.

George Foti
Ericsson Canada

> -----Original Message-----
> From: Robert Sparks [mailto:[email-masked]]
> Sent: Tuesday, February 19, 2002 3:15 PM
> To: George Foti (LMC)
> Cc: [email-masked]'
> Subject: Re: [Sip] Question on Section 16.5 Section 7
> 
> 
> The Request-URI referred to is the Request-URI in the request 
> at that point
> in processing.
> 
> The step you are looking at gets run on a copy of the message for each
> URI placed in the target set. The URI was taken from the 
> target set and
> placed in the Request-URI of the copy in step 2.
> 
> RjS
> 
> George Foti (LMC) wrote:
> > Hi,
> > 
> > I am quoting second paragrapgh of step 7, pdf version lines 
> 2724-2729:
> > 
> > In the absence of such an overriding mechanism, the proxy 
> applies the
> > procedures listed in [4] as follows to determine where to 
> send the request.
> > If the proxy has reformatted the request to send to a 
> strict-routing element
> > as described in step 6 above, the proxy MUST apply those 
> procedures to the
> > Request-URI of the request. Otherwise, the proxy MUST apply 
> the procedures
> > to the first value in the Route header field, if present, else the
> > Request-URI.
> > My question: 
> > Is the Request-URI refered to in the last line the same as 
> the one placed in
> > the target set in section 16.5 . In general, the relation 
> between that step
> > and what got placed in the target set (section 16.5) is unclear.
> > Regards.
> > George Foti
> > Ericsson Canada
> > 
> > 
> > 
> > _______________________________________________
> > Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> > This list is for NEW development of the core SIP Protocol
> > Use [email-masked] for questions on current sip
> > Use [email-masked] for new developments on the application of sip
> > 
> 
> 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 20 Feb 2002 09:54:03 -0500

> Why is the else needed. Isn't that already covered in the first line?

No. The rule is basically:

if(there are Route headers) {

  if(the request is heading to a strict router) {
    
    do DNS on the r-uri;
  } else {
    
    do DNS on top route;
  }
} else {

  do DNS on r-uri;

}

-Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.            72 Eagle Rock Avenue
Chief Scientist                         First Floor
dynamicsoft                             East Hanover, NJ 07936
[email-masked]                 FAX: (973) 952-5050
http://www.jdrosen.net                  PH:  (973) 952-5000
http://www.dynamicsoft.com