Subject: [Sip] Tables 2&3

From: "George Foti (LMC)" <[email-masked]>
Date: Wed, 20 Feb 2002 10:13:24 -0500

Line 4015 says 
The next six columns relate to the presence of a header field in a method.

According to that description all headers that belong to responses should
have a "-", i.e not applicable  for all methods.
This is not case (Error-info for example, etc..)

If the intent of showing something other than "-" under the  method is to
reflect the header presence in a repsonse for that particular method, then
line 4015 should say so.

Rgds

George Foti
Ericsson Canada

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Alan Johnston <[email-masked]>
Date: Wed, 20 Feb 2002 10:35:59 -0600

Hi George,

Thanks for your comments.

See Line 4005:

"2xx, 4xx, etc.: A numerical value or range indicates response codes
with which the header field can be used;"

Obviously, a response code does not have a method, but are generated in
response to a particular method.

I think it is clear enough that Error-Info is optional in 300-699
responses to INVITE, BYE, etc. with the exception of ACK (since a
response is never sent to an ACK).

Thanks,
Alan Johnston
WorldCom
sip:[email-masked]

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of George Foti (LMC)
> Sent: Wednesday, February 20, 2002 9:13 AM
> To: [email-masked]'
> Subject: [Sip] Tables 2&3
> 
> 
> Line 4015 says 
> According to that description all headers that belong to 
> responses should have a "-", i.e not applicable  for all 
> methods. This is not case (Error-info for example, etc..)
> 
> If the intent of showing something other than "-" under the  
> method is to reflect the header presence in a repsonse for 
> that particular method, then line 4015 should say so.
> 
> Rgds
> 
> George Foti
> Ericsson Canada
> 
> Use [email-masked] for questions on current 
> sip Use [email-masked] for new developments on the 
> application of sip
>