Subject: [Sip] NOTIFY behaviour

From: [email-masked]
Date: Thu, 28 Feb 2002 16:43:35 +0200

Section 4.2.1 states 

"When present, the body of the NOTIFY request MUST be formatted into one of the body formats specified in the "Accept" header of the corresponding SUBSCRIBE request. This body will contain either the state of the subscribed resource or a pointer to such state in the form of a URI."

Is the Accept header mandatory in SUBSCRIBE? INVITE mandates its but say that UAS should be ready to receive Requests without an Accept header. In that case, the spec should state that any extension to the events draft should specify the default content-type just in case the accept header was missing.

Section 4.2.2
I believe this section should talk a little about how a NOTIFY is constructed when a SUBSCRIBE with expires 0 is received. specifically the way the subscription-state header is constructed. After all, its the NOTIFY that terminates the dialog, Not the 200 OK to a SUBSCRIBE with expires 0.

Regards,
Hisham Khartabil

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Bob Penfield" <[email-masked]>
Date: Thu, 28 Feb 2002 12:22:05 -0500

----- Original Message ----- 
From: <[email-masked]>

> Section 4.2.1 states 
> 
> "When present, the body of the NOTIFY request MUST be formatted 
> into one of the body formats specified in the "Accept" header of 
> the corresponding SUBSCRIBE request. This body will contain either 
> the state of the subscribed resource or a pointer to such state in 
> the form of a URI."
> 
> Is the Accept header mandatory in SUBSCRIBE? INVITE mandates its 
> but say that UAS should be ready to receive Requests without an 
> Accept header. In that case, the spec should state that any 
> extension to the events draft should specify the default content-
> type just in case the accept header was missing.

The spec already has this requirement for Event Packages in section 5.4.5:

    Event packages also MUST define which MIME type is to be assumed if
    none are specified in the "Accept" header of the SUBSCRIBE request.

> 
> Section 4.2.2
> I believe this section should talk a little about how a NOTIFY is 
> constructed when a SUBSCRIBE with expires 0 is received. 
> specifically the way the subscription-state header is constructed. 
> After all, its the NOTIFY that terminates the dialog, Not the 200 
> OK to a SUBSCRIBE with expires 0.

Section 4.3.6 has this.

    Note that the NOTIFY messages triggered by SUBSCRIBE messages with
    "Expires" headers of 0 will contain a "Subscription-State" value of 
    "terminated", and a "reason" parameter of "timeout".