Subject: [Sip] 10.3 Processing REGISTER requests

From: Ofir Arkin <[email-masked]>
Date: Tue, 26 Feb 2002 14:54:06 +0000

On step number 6:

"..If not, the registrar checks whether the Call-ID agrees with the 
value stored for each binding. If not, it MUST remove the binding. If it 
does agree, it MUST remove the binding only if the CSeq in the request 
is higher than the value stored for that binding".

?

As I understood this is:
Call-ID in REGISTER = Call-ID stored?
	NO - remove the binding you have (insert new?)
	YES - Check for the CSeq if it is higher...

So if the Call-ID != Call-ID stored the binding is removed?
	
Is this true?
-- 
Ofir Arkin
Managing Security Architect
@stake, Limited.
http://www.atstake.com
email: 
[email-masked]
Tel: 
+44 (0) 207 495 7002
Fax: 
+44 (0) 207 495 7062
Mobile: +44 (0) 779 630 8632	

-----------------------------
The information transmitted is intended only for the person or entity to 
which it is addressed and may contain confidential and/or privileged 
material.  Any review, re transmission, dissemination or other use of, 
or taking of any action in reliance upon, this information by persons or 
entities other than the intended recipient is prohibited.  If you 
received this in error, please contact the sender and delete the 
material from any computer.

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: [email-masked]
Date: Tue, 26 Feb 2002 17:07:09 +0200

> -----Original Message-----
> From: ext Ofir Arkin [mailto:[email-masked]]
> Sent: Tuesday, February 26, 2002 4:54 PM
> To: [email-masked]
> Subject: [Sip] 10.3 Processing REGISTER requests
> 
> 
> On step number 6:
> 

	replace binding

> 	YES - Check for the CSeq if it is higher...

	update binding
> So if the Call-ID != Call-ID stored the binding is removed?

Its really the same result.

Regards,
Hisham