Subject: [Sip] Max-Forward checking at UAS

From: [email-masked]
Date: Fri, 23 Aug 2002 13:55:13 +0300

RFC3261 is silent about the behaviour of UAS when a request is received with no Max-Forwards header or a Max-Forwards header with value 0. The behaviour for a proxy is well defined in section 16, but not in section 8 for a UAS behaviour.

Regards,
Hisham
_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Christer Holmberg <[email-masked]>
Date: Fri, 23 Aug 2002 14:36:54 +0300

Hi,

> RFC3261 is silent about the behaviour of UAS when a request is received with no Max-Forwards header or a Max-Forwards header with value 0. The behaviour for a proxy is well defined in section 16, b…

Since Max-Forwards is a mandatory header, if it's not in the received message I guess the UAS should treat the message the same way it would treat it if any other mandatory header (To, From, Call-Id, CSeq or Via) would be missing.

If there is a Max-Forwards header, and the value is zero, at least chapter 21.4.21 explains what to do. Of course it could also be described in chapter 8.2, but chapter 8.1.1.6 DOES explain what a SERVER shall do (even if the chapter itself
describes UAC behaviour).

Regards,

Christer Holmberg
Ericsson Finland