Subject: [Sip] Refer subscription duration

From: "Reshmi Nair" <[email-masked]>
Date: Wed, 28 Aug 2002 15:57:05 +0530

Hi,

The " draft-ietf-sip-refer-06.txt " says that the duration of the subscription is determined by the expires parameter in the Subscription State header of the first Notify. [Section 3.4].

Does that mean the the first Notify 'MUST' have an expires parameter in the Subscription State header ?? 

If not, what should be the duration of the refer-subscription ? There is no default value suggested.

Regards,
Reshmi

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Ranjit Avasarala" <[email-masked]>
Date: Wed, 28 Aug 2002 17:13:38 +0530

Hi Reshmi

    In case u don't specify the duration of ur subsciption in the Expires
header of SUBSCRIBE, then server sets the value of the subscription to some
default valu which is conveyed in the Expires header of NOTIFY.

Subscription-State header conveys the state of the subscription Viz: "init"
, "active" or "terminated"

Ranjit
----- Original Message -----
From: Reshmi Nair <[email-masked]>
To: <[email-masked]>
Sent: Wednesday, August 28, 2002 3:57 PM
Subject: [Sip] Refer subscription duration

> Hi,
>
> The " draft-ietf-sip-refer-06.txt " says that the duration of the
subscription is determined by the expires parameter in the Subscription
State header of the first Notify. [Section 3.4].