Subject: RE: [Sip] Mandatory header changed in response

From: [email-masked]
Date: Tue, 20 Aug 2002 15:40:58 +0300

The point is that its too late to discard since the transactions layer accepted it and moved to the next state, so no retransmissions. 

Its not an implementation issue when To-header gets changed in a 200 Ok for an REGISTER, for example. Or when CSeq gets changed in 200 OK for INVITE. What does Server Core do?

/Hisham

> -----Original Message-----
> From: ext Christer Holmberg [mailto:[email-masked]]
> Sent: Tuesday, August 20, 2002 1:05 PM
> To: Khartabil Hisham (NMP/Helsinki)
> Cc: [email-masked]
> Subject: Re: [Sip] Mandatory header changed in response
> 
> 
> 
> Hi,
> 
> I would regard is as an implementation issue, ie you choose 
> if you don't care about the changed header values, or if you 
> discard the message etc.
> 
> Regards,
> 
> Christer Holmberg
> Ericsson Finland
> 
> [email-masked] wrote:
> 
> > Now that matching responses to requests is done using 
> branch-id. How should the behaviour be when a mandatory 
> header has been modified in the response?
> >
> > E.g. 1
> >
> > REGISTER ...
> > To: sip:[email-masked]
> > Contact: sip:[email-masked]
> > ...
> >
> > 200 Ok
> > To: sip:[email-masked]
> > Contact: sip:[email-masked]
> > ...
> >
> > Do we accept that a binding has been created?
> >
> > E.g. 2
> >
> > INVITE
> > ...
> > CSeq: 1 INVITE
> >
> > 200 ok
> > ...
> > CSeq: 15 INVITE
> >
> > This affects the local sequence number. Which one to store 
> and use for requests within dialogs?
> >
> > Thanks,
> > Hisham
> >
> > _______________________________________________
> > Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> > This list is for NEW development of the core SIP Protocol
> > Use [email-masked] for questions on current sip
> > Use [email-masked] for new developments on the application of sip
> 
> 
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip
> 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Medhavi Bhatia" <[email-masked]>
Date: Tue, 20 Aug 2002 11:03:22 -0400

The spec mentions that the UAS must match the headers in the response. That
has to be done at the transaction layer of the UAS, before the response is
accepted and delivered to the core.

I guess the transaction layer description should be updated to reflect
that...

----- Original Message -----
From: <[email-masked]>
To: <[email-masked]>
Cc: <[email-masked]>
Sent: Tuesday, August 20, 2002 8:40 AM
Subject: RE: [Sip] Mandatory header changed in response

> The point is that its too late to discard since the transactions layer
accepted it and moved to the next state, so no retransmissions.
>
> Its not an implementation issue when To-header gets changed in a 200 Ok
for an REGISTER, for example. Or when CSeq gets changed in 200 OK for
INVITE. What does Server Core do?

---

From: Jonathan Rosenberg <[email-masked]>
Date: Fri, 23 Aug 2002 06:05:15 -0400

The spec is clear on how responses are constructed, and that includes 
copying the CSeq and To as is, with the possible addition of a To tag. 
These are MUST strength requirements.

Therefore, a UAC receiving a response that has a modified To, CSeq, or 
something else, is talking to a mis-implemented UAS. As I have stated 
many times, the spec does not attempt to prescribe behavior for every 
strange (and generally, uncorrectable) error situation, this one 
included. It is an implementation issue how you deal with it if it 
occurs, but there is no expectation of proper operation in this scenario.

-Jonathan R.

Medhavi Bhatia wrote:
>>Its not an implementation issue when To-header gets changed in a 200
> 
> Ok
>>>From: ext Christer Holmberg
>>
> [mailto:[email-masked]]
> 
>>>>Use [email-masked] for new developments on the application of
>>>
> sip
> 
>>>

-- 
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

---

From: Christer Holmberg <[email-masked]>
Date: Fri, 23 Aug 2002 13:27:39 +0300

Hi,

> These are MUST strength requirements.

Does "as is" also mean that all possible parameters must be in the same
order, and does it also mean we're not allowed to add/remove "<" and ">"
characters around the uri.

In other words: is it required to do a byte copy of the whole header from the
request into the response? Personally I think that would be a bad idea, since
the "url comparision" rules do NOT require that.

Regards,

Christer Holmberg
Ericsson Finland

---

From: Rohan Mahy <[email-masked]>
Date: Fri, 23 Aug 2002 14:12:38 -0700

> characters around the uri.

no, as is means that you leave the headers (except for the addition of 
the To tag) *semantically* equivalent.  note that this means not 
fiddling with the hostpart.  i have seen implementations add :5060 and 
transport parameters and other such nonsense.  based on the comparison 
rules in 3261, host and host:5060 are no longer equivalent.

thanks,
-rohan

> request into the response?

required? no
a good idea? maybe

;-)

> Personally I think that would be a bad idea, since
>>> has to be done at the transaction layer of the UAS, before the 
>>> response
>>> is

---

From: Christer Holmberg <[email-masked]>
Date: Sat, 24 Aug 2002 11:07:00 +0300

Hi,

> the To tag) *semantically* equivalent.

Good. So, then I assume it's also allowed to add/remove the "<" and ">"
characters, because it doesn't change the semantics.

I just wanted to clarify this, because I've been involved in some private
discussions about this, where there were some different opinions about it.  My
understanding is that Gonzalo also discussed it with some of you (the editors,
that is) at that time, and assuming to him (Gonzalo, please correct me if I'm
wrong :) my assumption was correct, so...

Regards,

Christer Holmberg
Ericsson Finland

> note that this means not fiddling with the hostpart.  i have seen
> implementations add :5060 and
> transport parameters and other such nonsense.  based on the comparison rules
> in 3261, host and host:5060 are no longer equivalent.
>
> thanks,
> -rohan
>

---

From: "Himanshoo Kumar Saxena (LongGang)" <[email-masked]>
Date: Mon, 26 Aug 2002 14:56:32 +0800

Hi,

I am looking for some information on implementing Presnce service using SIP... Can anyone help me locate correct RFC/standards.

Best Regards
----------------------------------------------------------
Himanshoo Kumar Saxena
IN service department
Huawei Technologies Company Limited
Long Gang District
Shenzhen - 518000
P.R.China
Ph: +86-755-28788924(Off)