Subject: RE: [Sip] Max-Forward checking at UAS

From: [email-masked]
Date: Fri, 23 Aug 2002 14:56:42 +0300

> -----Original Message-----
> From: ext Christer Holmberg [mailto:[email-masked]]
> Sent: Friday, August 23, 2002 2:37 PM
> To: Khartabil Hisham (NMP/Helsinki)
> Cc: [email-masked]
> Subject: Re: [Sip] Max-Forward checking at UAS
> 
> 
> 
> 
> Hi,
> 
> > RFC3261 is silent about the behaviour of UAS when a request 
> is received with no Max-Forwards header or a Max-Forwards 
> header with value 0. The behaviour for a proxy is well 
> defined in section 16, but not in section 8 for a UAS behaviour.
> 
> Since Max-Forwards is a mandatory header, if it's not in the 
> received message I guess the UAS should treat the message the 
> same way it would treat it if any other mandatory header (To, 
> From, Call-Id, CSeq or Via) would be missing.

I actually disagree here for backwards compatibility. If max-forwards is missing, the UAS assumes the max-forwards test has passed and go on processing the request as normal (that's how a proxy is defined to behave).

/Hisham

> 
> If there is a Max-Forwards header, and the value is zero, at 
> least chapter 21.4.21 explains what to do. Of course it could 
> also be described in chapter 8.2, but chapter 8.1.1.6 DOES 
> explain what a SERVER shall do (even if the chapter itself
> describes UAC behaviour).
> 
> Regards,
> 
> Christer Holmberg
> Ericsson Finland
> 
> 
> 
> 
> 
> >
> >
> > Regards,
> > Hisham
> > _______________________________________________
> > Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> > This list is for NEW development of the core SIP Protocol
> > Use [email-masked] for questions on current sip
> > Use [email-masked] for new developments on the application of sip
> 
> 
_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Christer Holmberg <[email-masked]>
Date: Fri, 23 Aug 2002 15:17:07 +0300

Hi,

> I actually disagree here for backwards compatibility. If max-forwards is missing, the UAS assumes the max-forwards test has passed and go on processing the request as normal (that's how a proxy is…

The UAS could check the Via branch-id, to see if the Max-Forwards header is mandatory for that specific message or not. The UAS will have to check the branch-id it anyway, to find out if it is able to use it as
transaction identifier, or if it will have to do it the "old way" (ie using CSeq, Call-ID, etc)

Regards,

Christer Holmberg
Ericsson Finland