Subject: [Sip] Mandatory header changed in response

From: [email-masked]
Date: Tue, 20 Aug 2002 12:44:47 +0300

Now that matching responses to requests is done using branch-id. How should the behaviour be when a mandatory header has been modified in the response?

E.g. 1

REGISTER ...
To: sip:[email-masked]
Contact: sip:[email-masked]
...

200 Ok
To: sip:[email-masked]
Contact: sip:[email-masked]
...

Do we accept that a binding has been created?

E.g. 2

INVITE
...
CSeq: 1 INVITE

200 ok
...
CSeq: 15 INVITE

This affects the local sequence number. Which one to store and use for requests within dialogs?

Thanks,
Hisham

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Christer Holmberg <[email-masked]>
Date: Tue, 20 Aug 2002 13:04:44 +0300

Hi,

I would regard is as an implementation issue, ie you choose if you don't care about the changed header values, or if you discard the message etc.

Regards,

Christer Holmberg
Ericsson Finland