Subject: [Sip] inbound & outbound

From: feng zhang <[email-masked]>
Date: Thu, 22 Aug 2002 11:7:6 +0800

Hi All,

  Can you give me the detailed difference between:

  1) "inbound proxy" and "outbound proxy"

  2) "inbound services" and "outbound services"

Thanks a lot to give me an answer!

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Dean Willis" <[email-masked]>
Date: Thu, 22 Aug 2002 10:38:48 -0500

These terms are relative to what one accepts as one's point of view in
the system.

Pretend you are a SIP User Agent, perhaps a very simple UA that doesn't
even do DNS lookups.

A call coming to you is "inbound".

It may hit your home proxy first, and receive treatment such as being
proxied to you based on your registered contact. This is an "inbound
service", and your home proxy is acting as an "inbound proxy".

Now you want to make a call. Since you're making the call, it is going
"out", or can be called "outbound". You send this call to a proxy, which
looks up the request URI in DNS and sends the call on towards its
destination. This proxy is providing the "outbound service" of DNS
resolution, and is acting as an "outbound proxy" for this call.

On any call there may be any number of inbound and outbound proxies and
services. Some proxies may even provide both sorts for a single call.

Assume the simple network UA1----P1----P2----UA2

UA1 places a call to UA2.

From UA1's perspective, P1 and P2 are outbound proxies. From UA2's
perspective, they are both inbound proxies.

--
Dean

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of feng zhang
> Sent: Thursday, August 22, 2002 12:00 AM
> To: [email-masked]
> Subject: [Sip] inbound & outbound
> 
> 
> Hi All,
> 
> Use [email-masked] for questions on current 
> sip Use [email-masked] for new developments on the 
> application of sip
> 
>