Subject: [Sip] What should do?

From: feng zhang <[email-masked]>
Date: Mon, 26 Aug 2002 22:54:33 +0800

Hi All,

   Look at the scenarios below:

1)

   User A              Stateful Proxy               User B
     |                       |                         |
     |-----1.INVITE--------->|                         |
     |                       |------2.INVITE---------->|
     |<----3. 100------------|                         |
     |                       |<------4. 100------------|
     |                       |                         |
     |-----5.CANCEL--------->|           <--200 OK-----|

  NOTE that , Stateful Proxy has received "CANCEL", at the same time

User B's "200 OK" is on the line, and Proxy has not received it. For

stateful proxy has received User A's "CANCEL", so it forwords "CANCEL"

request to User B. But once it sends "CANCEL", User B's "200 OK" 

arrives. NOW, what should the proxy do? and what should User B do?

User B has just sent "200 OK", then he/she will receive "CANCEL"

2)

User A              Stateful Proxy               User B
     |                       |                         |
     |-----1.INVITE--------->|                         |
     |                       |------2.INVITE---------->|
     |<----3. 100------------|                         |
     |                       |<------4. 100------------|
     |                       |                         |
     |-----5.CANCEL--------->|<-------------200 OK-----|

Here, AT THE SAME TIME Stateful Proxy receives User A's "CANCEL" AND User B's "200 OK",

what should Proxy do then?

3)

User A              Stateful Proxy               User B
     |                       |                         |
     |-----1.INVITE--------->|                         |
     |                       |------2.INVITE---------->|
     |<----3. 100------------|                         |
     |                       |<------4. 100------------|
     |                       |                         |
     |-----5.CANCEL--->      |<-------------200 OK-----|

Here, User A's "CANCEL" is on the line, while stateful proxy has recieved

User B's 200 OK, proxy should forward this 200 OK, but when it has forwarded

the 200 OK, it receives User A's "CANCEL", then , what should proxy do?

And User A will receive User B's 200 OK after the "CANCEL" request, 

what should User A do ?

Thanks a lot to give me an answer1

Best Regards.

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Prabhas Sinha" <[email-masked]>
Date: Mon, 26 Aug 2002 11:24:27 -0400

comments inline..

>      |                       |------2.INVITE---------->|

Since the proxy is yet to receive the 200 OK response from User B so on
receipt of a CANCEL from User A it would generate a CANCEL request of its
own and send it to User B. Now the User B has already generated a final
response for the original request so it would treat this CANCEL as a no-op.
Thus CANCEL will have no effect.

>      |                       |------2.INVITE---------->|

Most probably CANCEL wont have any effect because a final response to INVITE
has been received by the proxy.

>      |                       |------2.INVITE---------->|

Again, CANCEL would be a no-op here. User A will receive 200 OK and if he
doesnt want to continue with the session then
he has to send a BYE to terminate the session.

Thanks,

Prabhas
Research Assistant
Dept of Computer Engineering
North Carolina State University
Raleigh, NC 27695