Subject: [Sip] 3-way conference

From: feng zhang <[email-masked]>
Date: Thu, 15 Aug 2002 18:17:44 +0800

Hi All,

   I want to fulfill "3-way Conference" in this way :

   User A------------User B
     \                /
      \              /
       \            /
        \          /  <-------------------  RTP channels
         \        /
          \      /
           \    /
           User C

   Notes: 1) User A, User B, User C want to "3-way Conference"
          2) Every user should setup two RTP channels with the other two users,
             for examples, User A should setup a RTP channel with User B , and should
             setup a RTP channel with User C, thus , User A's Voice can be sent to B & C,
             on the other hand, User B & C 's voice can be received separately on two 
             RTP channels, and User A can hear B & C's voice simultaneously. In this way,
             I can fulfill "3-way Conference".

   But I want to know :
       1) look at the scenario below:

         User A              User B               User C
           |     INVITE        |                    |
           |------------------>|                    |
           |                   |                    |
           |              INVITE                    |
           |--------------------------------------->|
           |                                        |
        How User B INVITE User C , AND let User C know this INVITE is for the same 
        session(3-way Conference) ? 

       2) in RFC3261 section "13.3.1 Processing of the INVITE"

          it says:
       
          "The INVITE may contain a session description, in which case the UAS
   is being presented with an offer for that session.  It is possible
   that the user is already a participant in that session, even though
   the INVITE is outside of a dialog.  This can happen when a user is
   invited to the same multicast conference by multiple other
              ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
   participants.  If desired, the UAS MAY use identifiers within the
   session description to detect this duplication.  For example, SDP
   contains a session id and version number in the origin (o) field.  "  
       
       I want to know whether "the same multicast conference by multiple other
   participants" it mentions is the way to fulfill a service like "3-way conference"?

    Thank you!

Best Regard!

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: [email-masked]
Date: Thu, 15 Aug 2002 13:22:49 +0300

Please take a look at 

http://www.ietf.org/internet-drafts/draft-ietf-sip-refer-06.txt

and

http://www.ietf.org/internet-drafts/draft-ietf-sipping-conferencing-models-01.txt

Regards,
Hisham

> -----Original Message-----
> From: ext feng zhang [mailto:[email-masked]]
> Sent: Thursday, August 15, 2002 1:18 PM
> To: [email-masked]
> Subject: [Sip] 3-way conference
> 
> 
> Hi All,
>

---

From: "Zmolek, Andrew (Andy)" <[email-masked]>
Date: Thu, 15 Aug 2002 17:39:27 -0600

Although the conferencing-models draft gives this approach as one example, SIP doesn't yet have a method for explicitly associating dialogs and media for a conference in this style. But ongoing work by the conferencing design team should provide at least a partial solution that would allow the two dialogs to become associated (i.e. conference ID)

In your example below, you ask how User B can be told to invite User C. One approach would be to have User A send the B->C invite via 3rd Party Call Control mechanisms.

Yes, there are multicast scenarios for a 3-way conference as well, but it seems unlikely that many UAs would support this. 

--Andy

> From: feng zhang [mailto:[email-masked]]
> Sent: Thursday, August 15, 2002 4:18 AM
> To: [email-masked]