Subject: [Sip] SIP Server Roaming Problem

From: Anthony Liu <[email-masked]>
Date: Sat, 17 Aug 2002 09:37:24 +0800 (CST)

Hi, folks,

I'm new here. If this problem has been discussed, please let me know.
If not, I'm interested in this problem and would like to compose a
new SIP extension draft or been added to some already existed draft.

Here is a brief introduction:

In mobile IP environments, mobile nodes (MN) move around and contacts
their SIP server in home or foreign network. I'm not sure whether
a MN will contact a SIP server in foreign network or the one in its
home network. Can anyone tell me the answer?

If this MN happens to move into a foreign network that wishes any
MN in it contacting its SIP server instead of the one in home network, 
do we have a mechanism for this? I am not trying to address mobility
problems which are handled by Mobile IP. The truth is I think in this
way, a foreign network can do statistics about SIP sessions in its
subnet or even diffserving SIP session packets from ordinary packets.

Regards,
Anthony Liu

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: [email-masked]
Date: Fri, 16 Aug 2002 14:55:29 +0300

Anthony Liu writes:

 > do we have a mechanism for this? 

if you talk about MN that uses the 3g system, then there is no choice
whatsoever.  the MN is in the walled garden as defined by the guardians
of the garden.

-- juha

---

From: Anthony Liu <[email-masked]>
Date: Mon, 19 Aug 2002 09:28:52 +0800 (CST)

> whatsoever.  the MN is in the walled garden as defined by the guardians
First, thanks for your reply, juha,

MN in 3G system is ineed a situation I am considering.
However, I do not think this is a limited question. For
example, we have some complany providing 802.11 Internet
access here in Taiwan and I think in the future, if SIP
is so popular that every computer and every cellular has
it built in, then this would become a question.

As you said, in 3G systems, there is no choice. But how
can a MN (maybe subscribed to some 802.11 service)
change its presence on Internet (SIP location) to a cellular
network it is roaming to without connection lost? (Since
it will be using a proxy mode SIP server in a 3G system.)

Is there a solution for this?

Anthony

---

From: Henry Sinnreich <[email-masked]>
Date: Sun, 18 Aug 2002 16:55:38 -0500

See the mobility page at www.cs.columbia.edu/sip on the mobile Internet.
There is also a page at Telcordia.

Henry

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Anthony Liu
> Sent: Sunday, August 18, 2002 8:29 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: Re: [Sip] SIP Server Roaming Problem
> 
> 
> > > MN in it contacting its SIP server instead of the one in home 
> > network,  > do we have a mechanism for this?
> > 
> > whatsoever.  the MN is in the walled garden as defined by the 
> > guardians of the garden.
> > 
> > -- juha
> > 
> access here in Taiwan and I think in the future, if SIP is so 
> popular that every computer and every cellular has it built 
> in, then this would become a question.
> 
> network it is roaming to without connection lost? (Since it 
> will be using a proxy mode SIP server in a 3G system.)
> 
> Use [email-masked] for questions on current 
> sip Use [email-masked] for new developments on the 
> application of sip
>