Subject: RE: [Sip] SIP Congestion Safety Draft Revised

From: "James Undery" <[email-masked]>
Date: Wed, 7 Aug 2002 15:59:01 +0100

I'd agree with Ben, as I read Hisham's draft it mainly dealt with "congestion" at entities receiving/storing messages, under certain specific architectures (e.g. 3GPP).

James

> -----Original Message-----
> From: Ben Campbell [mailto:[email-masked]]

> Without making judmements on the technical merits of the 
> khartabil draft 
> (and on an admittedly quick read) it seems to me that it attempts to 
> solve a somewhat different problem than the sip-congestsafe 
> draft. I do 
> not think they need to converge, and they may in fact be 
> complementary.
> 
> Dean Willis wrote:
> > Based on list feedback and AD directions the SIP transport 
> congestion
> > safety draft has been revised and resubmitted under a WG 
> title to the
> > archives and should appear shortly. In the interimn, you may wish to
> > review:
> > 
> > 
> http://www.softarmor.com/sipwg/drafts/draft-ietf-sip-congestsa
> fe-00.txt
> > 
> http://www.softarmor.com/sipwg/drafts/draft-ietf-sip-congestsa
> fe-00.html
> > 
> http://www.softarmor.com/sipwg/drafts/draft-ietf-sip-congestsa
> fe-00.xml
> > 
> > 
> > I'd like to ask you to consider the relation to:
> > 
> > 
http://www.softarmor.com/sipwg/drafts/draft-khartabil-sip-congestionsafe
> -ci-00.txt
> 
> Specifically, these seem to refer to different aspects of congestion
> safety. Is some sort of convergence needed? If so, what and how?
> 
> 
> Thanks,
> 
> --
> Dean Willis
> 
> 
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip
> 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: [email-masked]
Date: Wed, 7 Aug 2002 15:11:56 -0400

Actually after reading both I-Ds I feel they need to have a common 
baseline.

Hisham's I-D deals with both network congestion as well as handling 
capacity of a UA that finally receives the message.
He defines procedures for Proxy-Require, 5xx responses as well as the 
Max-Size header

Dean/Ben's draft also defines similar operations (with some exceptions)

Hisham's examples are 3G specific, but the same principles seem to be used 
in both. Therefore, I feel Hisham's draft should 
use the same terminology as this draft (or vice versa - whatever :-) -> it 
makes more sense to me that 
http://www.softarmor.com/sipwg/drafts/draft-ietf-sip-congestsafe-00.txt 
defines common procedures for congestion control 
and 
http://www.softarmor.com/sipwg/drafts/draft-khartabil-sip-congestionsafe-ci-00.txt 
realizes it specifically for the 3G space.

Hisham: The one thing I feel that can be dropped is the max-size token you 
define in the Contact header in REGISTER. Is it really useful ?
Why not just stick to the UA responding with 5xx if its gets a big message 
instead of now requiring proxies to check this additional field 
before forwarding ? 

Some minor edits in 
http://www.softarmor.com/sipwg/drafts/draft-ietf-sip-congestsafe-00.txt

* Section 2: "protocol has not explicit mechanisms for avoiding..."
s/not/no

* Section 3: point 2: "Note that this is an uncomoon case"
s/uncomoon/uncommon

* Page 5, para after fanout diag: s/\&lt/</g

regds
arjun

--
Arjun Roychowdhury @ Hughes Software Systems
11717 Exploration Lane, Germantown MD 20876
(O): 301-212-7860        (M): 240-997-0066

"James Undery" <[email-masked]>
Sent by: [email-masked]
08/07/2002 10:59 AM

        To:     "Ben Campbell" <[email-masked]>, "Dean Willis" 
<[email-masked]>
        cc:     <[email-masked]>
        Subject:        RE: [Sip] SIP Congestion Safety Draft Revised

I'd agree with Ben, as I read Hisham's draft it mainly dealt with 
"congestion" at entities receiving/storing messages, under certain 
specific architectures (e.g. 3GPP).

James

---

From: [email-masked]
Date: Thu, 8 Aug 2002 10:20:36 +0300

Dean/Ben's I-D says: if a proxy detects that a request is too large and it can't forward it with a congestion safe transport protocol, the proxy rejects the request.

My I-D says: well, you can either reject it (referring to the I-D above), or perform content indirection.

The I-D also introduces the capability where a UA can reject a request (max-size header) or ask the home proxy to do something about it before it even gets to the UA (max-size param). I guess Arjun is talking about the latter part of the previous sentence. We added the max-size parameter to the contact header to save bandwidth (error response followed by another request and response) if the UA knows at registration time that it can't handle message size larger than x.

Regards,
Hisham

> From: ext [email-masked] [mailto:[email-masked]]
> Sent: Wednesday, August 07, 2002 10:12 PM
> To: Ben Campbell; Dean Willis; [email-masked]; [email-masked];
> [email-masked]