Subject: [Sip] "List" Event Template Package: new draft available

From: Adam Roach <[email-masked]>
Date: Fri, 25 Oct 2002 17:12:07 -0500

For those of you not following SIMPLE: a while back, we started work
on a mechanism for conveying presence of several entities with a single
subscription. At the Yokohama meeting (and in ensuing mailing list
discussions), we decided that the mechanism would probably be most useful
if it were generalized to a collection event template package that allows
for aggregation of any event package, not just presence.

The resulting i-d describing a template event package for collections
has now been submitted to the drafts editor. Until a copy appears in
the archives, you can download a copy from:

http://pages.sbcglobal.net/roaches/ietf/draft-roach-sip-list-template-00.txt

HTML version also available:
http://pages.sbcglobal.net/roaches/ietf/draft-roach-sip-list-template-00.htm
l

This work is still rather rough around the edges, but I think it gives a
good starting point for discussion.

/a
_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: [email-masked]
Date: Tue, 29 Oct 2002 09:41:54 +0200

Is this replacing the presencelist package? And are we expecting a collection package (not template) any time soon?

Regards,
Hisham

> -----Original Message-----
> From: ext Adam Roach [mailto:[email-masked]]
> Sent: Saturday, October 26, 2002 1:12 AM
> To: [email-masked]'
> Subject: [Sip] "List" Event Template Package: new draft available
> 
>

---

From: Adam Roach <[email-masked]>
Date: Tue, 29 Oct 2002 14:21:10 -0600

The discussion we had on the topic (on the SIMPLE list)
ended with what I believe was consensus to go the 
"collection template package" route instead of the
"collection package" route. If you don't think the
topic received enough discussion, I guess you can
try to raise the issue again -- but revisiting items
that we have already acheived consensus on is one of
the surest ways to stall ongoing work.

/a

> From: [email-masked] [mailto:[email-masked]]
> Sent: Tuesday, October 29, 2002 1:42
> To: [email-masked]; [email-masked]
> Subject: RE: [Sip] "List" Event Template Package: new draft available
> 
> 
> Is this replacing the presencelist package? And are we 
> expecting a collection package (not template) any time soon?
> 
> Regards,
> Hisham
>

---

From: [email-masked]
Date: Wed, 30 Oct 2002 09:44:03 +0200

I know and I agree. I was just asking if the draft you presented is it (since the event name "collection" was not used). I also wanted to know if it will replace the presencelist package. No stalling, just recap.

I guess the answer to both questions is yes.

Regards,
Hisham

> Sent: Tuesday, October 29, 2002 10:21 PM
> To: Khartabil Hisham (NMP/Helsinki); Adam Roach; [email-masked]

---

From: Adam Roach <[email-masked]>
Date: Wed, 30 Oct 2002 10:33:59 -0600

> I know and I agree. I was just asking if the draft you 
> presented is it (since the event name "collection" was not 
> used). 

More or less, yes. There are still a lot of open issues about the
details (e.g. we will probably be moving the meta-information
from the preamble into a separate body part), but the intention
of this draft is to take us in the direction of the final solution.

I chose "list" over "collection" as a name simply because it's much
shorter.

/a