Subject: RE: [Sip] SIPS question

From: [email-masked]
Date: Thu, 31 Oct 2002 14:21:08 +0200

> -----Original Message-----
> From: ext Christer Holmberg [mailto:[email-masked]]
> Sent: Thursday, October 31, 2002 1:37 PM
> To: Khartabil Hisham (NMP/Helsinki)
> Cc: [email-masked]; [email-masked]
> Subject: Re: [Sip] SIPS question
> 
> 
> 
> 
> [email-masked] wrote:
> 
> > > -----Original Message-----
> > > From: ext Christer Holmberg 
> [mailto:[email-masked]]
> > > Sent: Thursday, October 31, 2002 12:31 PM
> > > To: Khartabil Hisham (NMP/Helsinki)
> > > Cc: [email-masked]; [email-masked]
> > > Subject: Re: [Sip] SIPS question
> > >
> > >
> > >
> > > Hi,
> > >
> > > > I guess UA2 should have registered with P1 using a sips-uri
> > > in the contact-header. P1 doesn't care about the
> > > contact-header sent in the 200 OK. UA2 contact-header is
> > > telling UA1 (not P1) to contact it using TLS.
> > >
> > > No, but the Contact header value will be used in requests
> > > during the session, as part of the route set or Request-URI
> > > (depending on if loose routing is used etc)
> >
> > What I meant to say is that if UA2 had registered with P1 
> using a sips-uri in the contact-header, then when P1 is 
> routing the INVITE, it will put sips-uri in the record-route 
> header since the request uri (retrieved from the registrar) 
> is a sips-uri.
> 
> > Since P1 contacted UA2 using sips, the 200 ok must contain 
> a contact-header with sips-uri.
> 
> Ok. So, in this case UA1 will receive a Record-Route with 
> SIPS-URI. So, the next time UA1 sends a request the SIPS-URI 
> indicates it shall use TLS - which UA1 may not even support.

No, P1 will modify the record-route header in the response and will make it a sip-uri.

> 
> And, since UA1 used SIP-URI in its own Contact header, P1 
> shall use UDP (or TCP) to forward requests received from UA2, 
> so now we would have the separate-transport-in-each-direction 
> problem between UA1 and P1, wouldn't we?

UA1 will have a different route-set that UA2.

/Hisham

> Regards,
> Christer Holmberg
> Ericsson Finland
_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 31 Oct 2002 14:43:00 +0200

Hi,

> UA1 will have a different route-set that UA2.

True.

However, EVEN if UA2 has registered itself with P1 using SIPS-URI, and P1 uses TLS to
contact it, UA1 will still receive a Contact header with SIPS-URI, and according to the
RFC ("if the Request-URI is SIPS-URI, TLS MUST be used") it would have to use TLS for the
other requests, even if it doesn't support TLS, and even if the requests aren't even sent
to UA2 (UA1 send them to P1, which record-routed).

Regards,

Christer Holmberg
Ericsson Finland

---

From: "Arunachalam Venkatraman" <[email-masked]>
Date: Thu, 31 Oct 2002 21:25:46 -0600

Christer
Interesting issue.

How about this for a solution ---
The UAS sends a SIPS URI in its Contact only if one of the following is
true-
1. The top Route in its Route Set is a SIPS URI
2. If no Route set has been established, the Contact in the request is a
SIPS-URI.

In all other cases, it sends a SIP-URI in its Contact.

Will this work?

Venkat

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Christer Holmberg
Sent: Thursday, October 31, 2002 6:43 AM
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: Re: [Sip] SIPS question

Hi,

True.

However, EVEN if UA2 has registered itself with P1 using SIPS-URI, and P1
uses TLS to
contact it, UA1 will still receive a Contact header with SIPS-URI, and
according to the
RFC ("if the Request-URI is SIPS-URI, TLS MUST be used") it would have to
use TLS for the
other requests, even if it doesn't support TLS, and even if the requests
aren't even sent
to UA2 (UA1 send them to P1, which record-routed).

Regards,

Christer Holmberg
Ericsson Finland