Subject: [Sip] Bug in absolute-URI grammar

From: [email-masked]
Date: Wed, 9 Oct 2002 11:44:06 +0300

I sent this a while ago and am resending. I also have a further comment/question:

net-path       =  "//" authority [ abs-path ]
authority      =  srvr / reg-name
srvr           =  [ [ userinfo "@" ] hostport ]
reg-name       =  1*( unreserved / escaped / "$" / ","
                  / ";" / ":" / "@" / "&" / "=" / "+" )

How can a parser distinguish between srvr and reg-name? the @ sign is allowed in both?

Regards,
Hisham

> -----Original Message-----
> From: ext [email-masked] 
> [mailto:[email-masked]]
> Sent: Monday, August 19, 2002 3:27 PM
> To: [email-masked]
> Subject: [Sip] Bug in absolute-URI grammar
> 
> 
> srvr           =  [ [ userinfo "@" ] hostport ]
> 
> should be
> 
> srvr           =  [ [ userinfo ] hostport ]
> 
> Regards,
> Hisham
> 
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip
> 
_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 09 Oct 2002 12:17:14 -0400

[email-masked] wrote:
 > I sent this a while ago and am resending.

Yes, there is a bug in the grammar, which will cause an absoluteURI to 
have two @ signs. Clearly, only one is intended. The production for srvr 
should not have the @ sign. This is logged in bugzilla:

http://www.sipwg.org/sipwg/show_bug.cgi?id=645

 > I also have a further
 > comment/question:
 > reg-name  =  1*( unreserved / escaped / "$" / "," / ";" / ":" / "@" / 
 >              "&" / "=" / "+" )
 >

The @ sign does appear to be allowed in both. This is all copied from 
rfc2396, which doesn't give any guidance on how to distinguish the two. 
The only thing it says is that its scheme specific, so perhaps the 
intention is that whether you use srvr or reg-name depends on the scheme.

-Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com