Subject: [Sip] Conflict in Accept header grammer

From: "lakshmi" <[email-masked]>
Date: Sat, 26 Oct 2002 05:05:44 +0530

All,

Accept Header syntax is like this 
accept-range = media-range *(SEMI accept-param)

media-range = ( "*/*"

   / ( m-type SLASH "*" )

   / ( m-type SLASH m-subtype )

   ) *( SEMI m-parameter )

accept-param = ("q" EQUAL qvalue) / generic-param

generic-param = token [ EQUAL gen-value ]

gen-value = token / host / quoted-string

m-parameter = m-attribute EQUAL m-value

m-attribute = token

m-value = token / quoted-string

Here how to distinguish b/w the m-parameter in media-range and generic-param in accept-param.

Thanks,

lakshmi

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Fri, 25 Oct 2002 07:51:57 -0400

Don't know if this helps, but m-parameters are attributes registered along
with the MIME type definitions, hence in theory can be known in advance once
the media types have been decoded.

-----Original Message-----
From: lakshmi [mailto:[email-masked]] 
Sent: Friday, October 25, 2002 7:36 PM
To: [email-masked]
Cc: Jonathan Rosenberg
Subject: [Sip] Conflict in Accept header grammer

All,

Here how to distinguish b/w the m-parameter in media-range and generic-param
in accept-param.

Thanks,
lakshmi
_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Rob Phillips" <[email-masked]>
Date: Fri, 25 Oct 2002 07:04:14 -0500

Correct - essentially, the parser *can't* generically tell the difference between a generic-param and m-parameter.  The handling of the generic-param or m-paramter is specific to the given media-range information.

- rob

-----Original Message-----
From: lakshmi [mailto:[email-masked]] 
Sent: Friday, October 25, 2002 7:36 PM
To: [email-masked]
Cc: Jonathan Rosenberg
Subject: [Sip] Conflict in Accept header grammer

All,

Thanks,
lakshmi