Subject: RE: [Sip] Backward incompatibity in Via header grammar.

From: "Drage, Keith (Keith)" <[email-masked]>
Date: Mon, 14 Oct 2002 12:36:35 +0100

Backward compatibility or incompatibility is assessed against previously published versions of the RFCs, i.e. RFC 2543 to RFC 3261.
 
Compatibility problems with anyone who implements an internet draft, i.e. work in progress, lie with whoever decided not to wait for the published RFC.
 
However the BNF you quote does appear in RFC 2543. I do not know the reason why it was removed, but I would note that there has been a general cleaning up of comment usage throughout RFC 3261 from RFC 2543, and not in this header alone.
 
Keith

Keith Drage
Lucent Technologies
Tel: +44 1793 776249
Email: [email-masked] 

-----Original Message-----
From: Sachin Shenoy [mailto:[email-masked]]
Sent: 14 October 2002 06:42
To: [email-masked]
Subject: [Sip] Backward incompatibity in Via header grammar.

Hi,

According to bis-02 & bis-05 the grammar of Via is following.

Via = ( "Via" | "v" ) HCOLON

1#( sent-protocol sent-by

*( SEMI via-params ) [ comment ] )

It allows for comment to be present in Via header.

But according to the new RFC, this is the grammar,

Via = ( "Via" / "v" ) HCOLON via-parm *(COMMA via-parm)

Which doesn't allow for comment.

Won't this cause backward incompatablity. (Any old proxy 

which inserts comment in Via can cause serious problems for 

new implementation).

Thanks

Sachin

---

From: Jonathan Rosenberg <[email-masked]>
Date: Mon, 14 Oct 2002 22:49:29 -0400

There is no requirement for strict backwards compatibility. We have 
tried to achieve practical backwards compatibility, which means that the 
features we removed or changed weren't really implemented anyway. To our 
knowledge, no one was putting comments in, and since they were a pain, 
we removed them. Removing things that were never used is part of the 
IETF standards process.

-Jonathan R.

Drage, Keith (Keith) wrote:
> Backward compatibility or incompatibility is assessed against previously 
> published versions of the RFCs, i.e. RFC 2543 to RFC 3261.
>  
> Compatibility problems with anyone who implements an internet draft, 
> i.e. work in progress, lie with whoever decided not to wait for the 
> published RFC.
>  
> However the BNF you quote does appear in RFC 2543. I do not know the 
> reason why it was removed, but I would note that there has been a 
> general cleaning up of comment usage throughout RFC 3261 from RFC 2543, 
> and not in this header alone.
>  
> Keith
>  
> 
> Keith Drage
> Lucent Technologies
> Tel: +44 1793 776249
> Email: [email-masked]
> 
>     *From:* Sachin Shenoy [mailto:[email-masked]]
>     *Sent:* 14 October 2002 06:42
>     *To:* [email-masked]
>     *Subject:* [Sip] Backward incompatibity in Via header grammar.
> 
>     Hi,
> 
>     Via = ( "Via" |/ /"v" ) HCOLON
> 

-- 
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip