Subject: [Sip] Standard mechanism to instruct the phone go off hook

From: "Snyder, Duke" <[email-masked]>
Date: Sat, 26 Oct 2002 18:22:57 -0500

Has any work been done to have a standard mechanism for an application to request that the phone answer it's "alerting" call by going off hook (to speaker mode).   Currently, different hard IP phones have a different ways to "auto-answer", but it complicates SIP development working with proprietary, non-SIP techniques.   The PhoneControl draft (http://www.cs.columbia.edu/~hgs/sip/drafts/draft-dean-phonectl-03.txt) seems to do some phone control, but not the auto-answer request.

Common scenarios for this request:
*	A call center agent typically uses auto-answer for his call center calls.  His SIP app (based off his configuration) could send the call to his phone (with a headset), request that the phone answer the call, and the agent handles the call completely hands-free.
*	A call center supervisor selects a call to monitor.  His SIP app will direct the audio of the call to his phone, but first must call his phone to establish an audio path.  Again, typically the supervisor would like the phone to automatically go off hook rather than forcing him to answer the phone.

Authentication would need to be used since most people would not want their SIP phone in their bedroom to go off hook.

Duke Snyder
Interactive Intelligence, Inc.
www.inin.com

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Rosen, Brian" <[email-masked]>
Date: Wed, 30 Oct 2002 14:08:55 -0500

I don't understand why this is needed given the scenarios you
provide.  In the examples you cite, you ALWAYS use autoanswer,
or, at least, you autoanswer for a particular AOR.  That's
a local decision.  The system shouldn't tell you to do that,
your sip UA should decide to do that, based on calling and
called URIs if necessary.  I'm not aware of scenarios where
it's the remote side, or an intermediary, that decides
whether you should or should not autoanswer.

So, local configuration seems very appropriate, and we don't
standardize that.

You could ask for a URI convention.  Consider the "intercom"
function.  Might be nice to have a URI convention for 
that, with a (local) decision on acceptance based on authentication
and who is calling. 

Brian

> -----Original Message-----
> From: Snyder, Duke [mailto:[email-masked]]
> Sent: Saturday, October 26, 2002 7:23 PM
> To: [email-masked]
> Subject: [Sip] Standard mechanism to instruct the phone go off hook
> 
> 
> Has any work been done to have a standard mechanism for an 
> application to request that the phone answer it's "alerting" 
> call by going off hook (to speaker mode).   Currently, 
> different hard IP phones have a different ways to 
> "auto-answer", but it complicates SIP development working 
> with proprietary, non-SIP techniques.   The PhoneControl 
> draft 
> (http://www.cs.columbia.edu/~hgs/sip/drafts/draft-dean-phonect
> l-03.txt) seems to do some phone control, but not the 
> auto-answer request.
> 
> *	A call center agent typically uses auto-answer for his 
> call center calls.  His SIP app (based off his configuration) 
> could send the call to his phone (with a headset), request 
> that the phone answer the call, and the agent handles the 
> call completely hands-free.
> *	A call center supervisor selects a call to monitor.  
> His SIP app will direct the audio of the call to his phone, 
> but first must call his phone to establish an audio path.  
> Again, typically the supervisor would like the phone to 
> automatically go off hook rather than forcing him to answer the phone.
> 
> Authentication would need to be used since most people would 
> not want their SIP phone in their bedroom to go off hook.
> 
> 
> Duke Snyder

---

From: "Snyder, Duke" <[email-masked]>
Date: Thu, 31 Oct 2002 07:14:19 -0500

Correct, for the scenarios below, we always want the phone to be in "auto answer" mode.  The problem is that there will be other calls, such as calls from the spouse, that are sent to the same phone.   In this case, the application knows that the call center supervisor or call center agent does NOT want the auto answer on his phone to kick in (maybe the agent stepped away from his desk or just doesn't want to talk to that specific caller at the moment) and the application could (or could not) send a hopefully-upcoming-SIP notify to inform the phone to answer the alerting call.  This is a comment complaint at every one of our sites.

-----Original Message-----
From: Rosen, Brian [mailto:[email-masked]]
Sent: Wednesday, October 30, 2002 2:09 PM
To: Snyder, Duke; [email-masked]
Subject: RE: [Sip] Standard mechanism to instruct the phone go off hook

Brian