Subject: [Sip] Question on draft-ietf-sip-asserted-identity-02

From: [email-masked]
Date: Mon, 21 Oct 2002 21:39:47 +0530

Hi,
     I had a question regarding the above draft. Say a
subscriber is not to be provided Privacy per the server
configured policy but still requests for privacy by
inserting a "Privacy: id" header in a call. Should the
server
(a) Reject the request with a final failure response
    (say 403) ORR
(b) Forward the request but ensure that privacy is
    not provided by any downstream proxy either.

     In order to do (b), (assuming that the request is
being forwarded to a host in the trust domain), the server
can strip off the "Privacy: id" header so that a downstream
element does not provide the desired privacy. But as per
the draft, only the proxy that applies the privacy function
can strip off the "Privacy: id" header. Or can an intermediate
that is aware of the policy proceed as per (b).

Regards,
Subhash Nayak
Hughes Software Systems
http://www.hssworld.com

This message is proprietary to Hughes Software Systems Limited (HSS) and is
intended solely for the use of the individual to whom it is addressed.  It
may contain privileged or confidential information and should not be
circulated or used for any purpose other than for what it is intended.  If
you have received this message in error, please notify the originator
immediately.  If you are not the intended recipient, you are notified that
you are strictly prohibited from using, copying, altering, or disclosing
the contents of this message.  HSS accepts no responsibility for loss or
damage arising from the use of the information transmitted by this email
including damage from virus.

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Peterson, Jon" <[email-masked]>
Date: Tue, 22 Oct 2002 23:01:33 -0400

I'm not sure I understand the case you describe below, but I'll take a stab
at a response. 

We make no provision in any of these privacy/identity drafts, as far as I
can recall for cases in which a privacy service has policies that preclude
user requests for privacy. This would be comparable to the telephone network
rejecting your attempt to dial *67. Personally, I am not interested in
standardizing any case in which a privacy service with the relevant
capabilities would purposefully refuse to fulfill a user's request for
privacy. I suppose that if you were to implement this as a non-standard
mechanism, your option (a) would be vastly preferable (and would follow the
spirit of Section 5 of the privacy draft).

Jon Peterson
NeuStar, Inc.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Tuesday, October 22, 2002 1:10 AM
> To: [email-masked]; [email-masked]; [email-masked];
> [email-masked]
> Subject: Question on draft-ietf-sip-asserted-identity-02
> 
> 
> 
> 
> Hi,