Subject: RE: [Sip] SIPS question

From: [email-masked]
Date: Thu, 31 Oct 2002 12:21:54 +0200

I guess UA2 should have registered with P1 using a sips-uri in the contact-header. P1 doesn't care about the contact-header sent in the 200 OK. UA2 contact-header is telling UA1 (not P1) to contact it using TLS.

My suggestion would be that UA2 rejects the call and then re-registers with P1 using a sips-uri in the contact-header. Otherwise we have a complicated scenario where P1 has to examine contact-header in response and change the route-header to sips. UA1 has to do the same and change its own contact header to sips in a re-INVITE. Too much.

Regards,
Hisham

> -----Original Message-----
> From: ext Christer Holmberg [mailto:[email-masked]]
> Sent: Wednesday, October 30, 2002 8:38 PM
> To: Peterson, Jon
> Cc: [email-masked]
> Subject: Re: [Sip] SIPS question
> 
> 
> 
> Hi,
> 
> > I agree that I don't see any immediate use for this, but I 
> also don't see
> > any danger that would mandate forbidding it. Was there 
> anything you had in
> > mind?
> 
> Assuming the UAS does insert a SIPS-URI in the Contact, let's 
> have a look at
> the following scenario:
> 
> UA1 ------------- P1 -------------- UA2
> 
> Now, UA1 sends an INVITE to UA2, via P1:
> 
> - UA1 inserts a SIP-URI in the Request-URI
> 
> - P1 inserts a Record-Route header with a SIP-URI
> 
> - UA2 sends 200 with a Contact header with a SIPS-URI
> 
> 
> Q1:  Now, UA2 indicates that requests from P1 to UA2 shall be 
> sent using TLS,
> due to the SIPS-URI in the Contact. However, requests from 
> UA2 to P1 would be
> sent using let's say UDP, due to the SIP-URI in the Record-Route.
> 
> 
> Q2: Now, if P1 supports loose routing, when UA1 sends another 
> request within
> the session, it will look like:
> 
> Request-URI: SIPS-URI: UA2
> Route:SIP-URI: P1;lr
> 
> Now, according to chapter 26.2.2 in RFC3261, if the 
> Request-URI contains a
> SIPS-URI, TLS shall be used. However, the request is not sent to the
> Request-URI, but to the top Route, which contains a SIP-URI. 
> So, since P1
> record routed with a SIP-URI, and that route is used to route 
> the request, why
> shall UA1 make the transport decission based on the SIPS-URI in the
> Request-URI??? UA1 doesn't even know if P1 supports TLS or 
> not, and UA1 may
> not support TLS, so....
> 
> 
> Regards,
> 
> Christer Holmberg
> Ericsson Finland
> 
> 
> 
> 
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip
> 
_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 31 Oct 2002 12:30:48 +0200

Hi,

> I guess UA2 should have registered with P1 using a sips-uri in the contact-header. P1 doesn't care about the contact-header sent in the 200 OK. UA2 contact-header is telling UA1 (not P1) to contact…

No, but the Contact header value will be used in requests during the session, as part of the route set or Request-URI (depending on if loose routing is used etc)

> My suggestion would be that UA2 rejects the call and then re-registers with P1 using a sips-uri in the contact-header. Otherwise we have a complicated scenario where P1 has to examine contact-heade…

This is the reason I first aksed if UA2 is allowed to return a SIPS-URI in the Contact header in the first place :)

Also, I guess you can get similar scenarios if a proxy inserts a Record-Route header with SIPS-URI, even if it receives something sent with a SIP-URI.

Regards,

Christer Holmberg
Ericsson Finland