Subject: [Sip] NOTIFY bevahior

From: Cristian Negresco <[email-masked]>
Date: Wed, 30 Oct 2002 00:00:29 -0800 (PST)

Hello,

SUBSCRIBE request is answered with 200 response and
the notifier immediately sends NOTIFY request to the
subscriber.

Problem is that NOTIFY could arrive at the subscriber
before 200 OK, case in which I assume the subscriber
will give a non-200 OK to the NOTIFY and the
subscription will be cancelled.

Should the proxy implement a mechanism to assure that
200-ok is the first to arrive to the subscriber? 

Thank you for your help.
Cristian

__________________________________________________
Do you Yahoo!?
HotJobs - Search new jobs daily now
http://hotjobs.yahoo.com/
_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Ben Campbell <[email-masked]>
Date: Wed, 30 Oct 2002 08:50:05 -0600

> subscription will be cancelled.

No, the subscriber accepts the NOTIFY and creates a dialog (if one did 
not already exist.) RFC3265 explitly deals with this scenario.

> 200-ok is the first to arrive to the subscriber? 

No, it is not necessary.

Thanks!

Ben.