Subject: RE: [Sip] moving UDP support out of the core SIP document

From: Kevin McCandless <[email-masked]>
Date: Wed, 23 Oct 2002 13:57:19 -0700

Rohan:

At first I would have to agree with Victor but you are right we need a base
for SIP transport.  I remember a white paper that looked at SCTP, TCP and
UDP as transport protocols for SIP.  If you were a carrier with large
amounts of SIP traffic SCTP would be the better transport protocol.  For
less traffic that would be seen between proxy and UA then TCP could be used.
Is it possible to the draft address the three transport protocols and the
necessary security mechanism to support them.  By recommending only one
protocol don't we several limit the deployment.

Just my thoughts....

Kevin... 

> -----Original Message-----
> From: Rohan Mahy [mailto:[email-masked]]
> Sent: Wednesday, October 23, 2002 2:03 PM
> To: Victor Paulsamy
> Cc: [email-masked]
> Subject: Re: [Sip] moving UDP support out of the core SIP document
> 
> 
> Hi Victor,
> 
> Having no default transport does not encourage interoperability which 
> is a major goal of Internet protocols.
> 
> thanks,
> -rohan
> 
> On Wednesday, October 23, 2002, at 11:23 AM, Victor Paulsamy wrote:
> 
> > If SIP is "truly" independent of underlying transport protocols, 
> > wouldn't it
> > be appropriate to make all transports "optional"?
> >
> > Regards,
> >
> > --victor
> >
> >> -----Original Message-----
> >> From: [email-masked] [mailto:[email-masked]]On 
> Behalf Of Rohan
> >> Mahy
> >> Sent: Wednesday, October 23, 2002 11:02 AM
> >> To: [email-masked]
> >> Subject: [Sip] moving UDP support out of the core SIP document
> >>
> >>
> >> Hello Everyone,
> >>
> >> I wanted to share some thoughts that I had about removing 
> UDP from the
> >> core SIP document when we go to draft standard. We are probably at
> >> least one year away from going to Draft Standard. I hope 
> that during
> >> this time most implementations will support RFC3261, and therefore
> >> support TCP.  In addition, it is quite likely that when moving to 
> >> Draft
> >> Standard that the IESG will REQUIRE TLS support on SIP User Agents.
> >> This would ensure a ubiquitous hop-by-hop channel security 
> mechanism,
> >> but which requires a reliable transport (TCP or SCTP).
> >>
> >> Obviously UDP is still very attractive in wireless 
> networks (due to 
> >> RTT
> >> issues) and in other typically private networks with 
> well-understood
> >> delay and loss characteristics. To make most 
> implementations simpler
> >> however, I am proposing that we make unreliable transports (UDP and
> >> DCCP) of SIP optional in User Agents, and that we put the 
> UDP-specific
> >> mechanism (ex: much of the complication of the transaction 
> layer for
> >> handling retransmissions) in a separate Draft Standard 
> document.  It 
> >> is
> >> very likely that if we did this there would also be a baseline 
> >> security
> >> mechanism for UDP as well (probably some profile of 
> IPsec).  The net
> >> effect is that SIP User Agents could also talk to each 
> other using TCP
> >> or TLS+TCP, and that User Agents with a strong preference for UDP 
> >> would
> >> have a consistent security mechanism.  Proxies would still support 
> >> both
> >> transports, so you could easily communicate between a TCP-only User
> >> Agent, and as User Agent which prefers UDP without 
> requiring the User
> >> Agent to switch over to TCP.
> >>
> >> I welcome your discussion and comments on this idea.
> >>
> >> thanks,
> >> -rohan
> >>
> >> _______________________________________________
> >> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> >> This list is for NEW development of the core SIP Protocol
> >> Use [email-masked] for questions on current sip
> >> Use [email-masked] for new developments on the application of sip
> >>
> >
> 
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip
> 
_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Henry Sinnreich <[email-masked]>
Date: Wed, 23 Oct 2002 16:21:10 -0500

I agree with Rohan to have a default value.

Thanks, Henry

> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Kevin McCandless
> Sent: Wednesday, October 23, 2002 3:57 PM
> To: 'Rohan Mahy'; Victor Paulsamy
> Cc: [email-masked]
> Subject: RE: [Sip] moving UDP support out of the core SIP document
> 
> 
> Rohan:
> 
> At first I would have to agree with Victor but you are right 
> we need a base for SIP transport.  I remember a white paper 
> that looked at SCTP, TCP and UDP as transport protocols for 
> SIP.  If you were a carrier with large amounts of SIP traffic 
> SCTP would be the better transport protocol.  For less 
> traffic that would be seen between proxy and UA then TCP 
> could be used. Is it possible to the draft address the three 
> transport protocols and the necessary security mechanism to 
> support them.  By recommending only one protocol don't we 
> several limit the deployment.
> 
> Just my thoughts....
> 
> Kevin... 
> 
> > >> Draft Standard that the IESG will REQUIRE TLS support on 
> SIP User 
> > >> Agents. This would ensure a ubiquitous hop-by-hop 
> channel security
> > mechanism,
> > >> This list is for NEW development of the core SIP Protocol Use 
> > >> [email-masked] for questions on 
> current sip Use 
> > >> [email-masked] for new developments on the application of sip
> > >>
> > >
> > 
> > Use [email-masked] for questions on 
> current sip Use 
> > [email-masked] for new developments on the application of sip
> > 
> Use [email-masked] for questions on current 
> sip Use [email-masked] for new developments on the 
> application of sip
>