Subject: [Sip] Event header in responses

From: [email-masked]
Date: Mon, 31 Mar 2003 09:29:15 +0300

Hi

Bug 677 (http://www.sipwg.org/sipwg/show_bug.cgi?id=677) says that there is confilicting text in RFC 3265 about Event header in responses. The wording of the bug is not 100% clear, but I assume that responses should not contain an Event header. The reason for my question is that SIP Service Examples-04 and shows no Event in responses, presence-10 call flow example shows it, event-list-01 draft shows it sometimes. What is the correct interpretation?

		Jussi
_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Adam Roach <[email-masked]>
Date: Mon, 31 Mar 2003 10:18:42 -0600

The bug you indicate (#677) is in regards to the question
of how to match responses to their requests, not whether
"Event" is allowed in responses.

The short answer to your question, though, is that "Event"
should not be present in responses. The "Event:" header in
steps 6, 8, 10, and 12 of the example of event-lists-01 is
an oversight. Thanks for finding it.

That said, an implementation that receives an "Event" header
in a response should silently discard it.

/a

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Monday, March 31, 2003 0:29
> To: [email-masked]
> Cc: [email-masked]
> Subject: [Sip] Event header in responses
> 
> 
> Hi
> 
> Bug 677 (http://www.sipwg.org/sipwg/show_bug.cgi?id=677) says 
> that there is confilicting text in RFC 3265 about Event 
> header in responses. The wording of the bug is not 100% 
> clear, but I assume that responses should not contain an 
> Event header. The reason for my question is that SIP Service 
> Examples-04 and shows no Event in responses, presence-10 call 
> flow example shows it, event-list-01 draft shows it 
> sometimes. What is the correct interpretation?
> 
> 		Jussi
>