Subject: [Sip] Cancel with a message body

From: "Everist, Giles" <[email-masked]>
Date: Thu, 20 Mar 2003 13:01:21 -0700

Can a Cancel have a message body, and if so does a stateful proxy have
the same responsibility to maintain that message body in a generated
Cancel request as with other messages?  Also, is the proxy required to
maintain ALL headers, such as a "Reason" header in the original Cancel
request?  Thanks for the help.
 
Giles

---

From: Pekka Pessi <[email-masked]>
Date: Sat, 22 Mar 2003 03:54:07 +0200

Everist, Giles <[email-masked]> writes:
><html xmlns:o="urn:schemas-microsoft-com:office:office" xmlns:w="urn:schemas-microsoft-com:office:word" xmlns="http://www.w3.org/TR/REC-html40">

	Kewl.

>request?  Thanks for the help.

	CANCEL is a hop-by-hop request, so stateful proxies do not
	forward it. No message-body or headers get forwarded.

					Pekka
_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip