Subject: RE: [SIP] Sending 2xx responses to INVITE

From: Bilajbegovic Damir <[email-masked]>
Date: Mon, 5 Apr 2004 12:48:01 +0200

Hi,	
	Not sure but I think 1st Invite and 7 retransmission. Intervals are
increasing by double. 
		Hope I helped.
			Bilaj

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Monday, April 05, 2004 12:34 PM
To: [email-masked]
Subject: [SIP] Sending 2xx responses to INVITE

Dear SIP experts,

I have following questions (maybe already discussed on the list in the past)
regarding the sending of 2xx responses to INVITE.

In what way does TU send retransmissions of 2xx responses to INVITE? What is
the interval between these retransmissions? How many retansmissions can be
sent?

Best regards
Anton

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip Use
[email-masked] for new developments on the application of sip

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Umesh Sharma" <[email-masked]>
Date: Mon, 5 Apr 2004 17:35:52 +0530

Hi

>>the interval between these retransmissions?

To quote from rfc 3261 directly:

"The 2xx response is passed to the transport with an
 interval that starts at T1 seconds and doubles for each
 retransmission until it reaches T2 seconds (T1 and T2 are defined in
 Section 17).  Response retransmissions cease when an ACK request for
 the response is received.  This is independent of whatever transport
 protocols are used to send the response."

>>How many retansmissions can be sent?

"If the server retransmits the 2xx response for 64*T1 seconds without
 receiving an ACK, the dialog is confirmed, but the session SHOULD be
 terminated."

In 17.1.1.1

"Eventually, the server transaction decides
   to send a final response.  For unreliable transports, that response
   is retransmitted periodically, and for reliable transports, it is
   sent once."

I have a question too here, Now this line above seems to contradict this
paragraph in
13.3.1.4.

      "Since 2xx is retransmitted end-to-end, there may be hops between
      UAS and UAC that are UDP.  To ensure reliable delivery across
      these hops, the response is retransmitted periodically even if the
      transport at the UAS is reliable."

Am I reading this incorrectly?

regards
-umesh
-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Bilajbegovic Damir
Sent: Monday, April 05, 2004 4:18 PM
To: ??????????? ????? ??????????; [email-masked]
Subject: RE: [SIP] Sending 2xx responses to INVITE

Hi,

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Monday, April 05, 2004 12:34 PM
To: [email-masked]
Subject: [SIP] Sending 2xx responses to INVITE

Dear SIP experts,

Best regards
Anton