Subject: [SIP] Sending 2xx responses to INVITE

From: "Галактионов Антон Николаевич" <[email-masked]>
Date: Mon, 5 Apr 2004 14:34:15 +0400

Dear SIP experts,

I have following questions (maybe already discussed on the list in the past)
regarding the sending of 2xx responses to INVITE.

In what way does TU send retransmissions of 2xx responses to INVITE?
What is the interval between these retransmissions? How many retansmissions
can be sent?

Best regards
Anton

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Hu Yijun,BISC R&D SA(BJ)" <[email-masked]>
Date: Wed, 7 Apr 2004 08:46:38 +0800

hello, Umesh

The more detailed statement to the sever transaction is described in ch17.2.1:

"   If, while in the "Proceeding" state, the TU passes a 2xx response to
   the server transaction, the server transaction MUST pass this
   response to the transport layer for transmission.  It is not
   retransmitted by the server transaction; retransmissions of 2xx
   responses are handled by the TU.  The server transaction MUST then
   transition to the "Terminated" state.

   While in the "Proceeding" state, if the TU passes a response with
   status code from 300 to 699 to the server transaction, the response
   MUST be passed to the transport layer for transmission, and the state
   machine MUST enter the "Completed" state.  For unreliable transports,
   timer G is set to fire in T1 seconds, and is not set to fire for
   reliable transports."

BR
hu yijun

>-----Original Message-----
>From: Umesh Sharma [mailto:[email-masked]]
>Sent: Tuesday, April 06, 2004 8:40 PM
>To: Hu Yijun,BISC R&D SA(BJ); [email-masked]
>Subject: RE: [SIP] Sending 2xx responses to INVITE
>
>
>hi Hu
>
>I re-read the section 17.1.1.1, it looks to me a general 
>statement which
>does not
>distinguishes between non-2xx final & 2xx response.
>
>-regards
>umesh
>
>-----Original Message-----
>From: Hu Yijun,BISC R&D SA(BJ) [mailto:[email-masked]]
>Sent: Tuesday, April 06, 2004 6:32 AM
>To: 'Umesh Sharma'; Bilajbegovic Damir; ??????????? ????? ??????????;
>[email-masked]
>Subject: RE: [SIP] Sending 2xx responses to INVITE
>
>
>Hello,
>
>Please see my comments below.
>
>regards
>hu yijun
>
>>-----Original Message-----
>>From: Umesh Sharma [mailto:[email-masked]]
>>Sent: Monday, April 05, 2004 8:06 PM
>>To: Bilajbegovic Damir; ??????????? ????? ??????????; [email-masked]
>>Subject: RE: [SIP] Sending 2xx responses to INVITE
>>
>>
>>Hi
>>
>>>>In what way does TU send retransmissions of 2xx responses to
>>INVITE? What
>>is
>>>>the interval between these retransmissions?
>>
>>To quote from rfc 3261 directly:
>>
>>"The 2xx response is passed to the transport with an
>> interval that starts at T1 seconds and doubles for each
>> retransmission until it reaches T2 seconds (T1 and T2 are defined in
>> Section 17).  Response retransmissions cease when an ACK request for
>> the response is received.  This is independent of whatever transport
>> protocols are used to send the response."
>>
>>>>How many retansmissions can be sent?
>>
>>"If the server retransmits the 2xx response for 64*T1 seconds without
>> receiving an ACK, the dialog is confirmed, but the session SHOULD be
>> terminated."
>>
>>In 17.1.1.1
>>
>>"Eventually, the server transaction decides
>>   to send a final response.  For unreliable transports, that response
>>   is retransmitted periodically, and for reliable transports, it is
>>   sent once."
>>
>>I have a question too here, Now this line above seems to
>>contradict this
>>paragraph in
>>13.3.1.4.
>>
>>      "Since 2xx is retransmitted end-to-end, there may be 
>hops between
>>      UAS and UAC that are UDP.  To ensure reliable delivery across
>>      these hops, the response is retransmitted periodically
>>even if the
>>      transport at the UAS is reliable."
>>
>>Am I reading this incorrectly?
>
>The description of ch 17.1.1.1 was foucs on the retransmission of the
>non-2xx final response to INVITE, which were administered by 
>the transaction
>layer. Those responses are delivered hop-by-hop. So that, for 
>a certain hop,
>which uses reliable transport, the non-2xx final response is 
>sent only once.
>
>However, the retransmission of the 2XX to INVITE was 
>administered by the
>transaction user (TU). It MUST comply with the ch13.3.1.4 of 
>rfc3261: "the
>response is retransmitted periodically even if the transport 
>at the UAS is
>reliable".
>
>>
>>regards
>>-umesh
>>-----Original Message-----
>>From: [email-masked] [mailto:[email-masked]]On Behalf Of
>>Bilajbegovic Damir
>>Sent: Monday, April 05, 2004 4:18 PM
>>To: ??????????? ????? ??????????; [email-masked]
>>Subject: RE: [SIP] Sending 2xx responses to INVITE
>>
>>
>>Hi,
>>	Not sure but I think 1st Invite and 7 retransmission.
>>Intervals are
>>increasing by double.
>>		Hope I helped.
>>			Bilaj
>>
>>-----Original Message-----
>>From: [email-masked] [mailto:[email-masked]]
>>Sent: Monday, April 05, 2004 12:34 PM
>>To: [email-masked]
>>Subject: [SIP] Sending 2xx responses to INVITE
>>
>>
>>Dear SIP experts,
>>
>>In what way does TU send retransmissions of 2xx responses to
>>INVITE? What is
>>the interval between these retransmissions? How many
>>retansmissions can be
>>sent?
>>
>>Best regards
>>Anton
>>
>>
>>Use [email-masked] for questions on current sip Use
>>[email-masked] for new developments on the application of sip
>>