Subject: [Sip] Far End Camera Control in SIP

From: Rajeew Kumar Singh <[email-masked]>
Date: Wed, 06 Oct 2004 17:40:37 +0530

Hi,
 Can anybody provide some info on Far End Camera Control in SIP.

Regards
Rajeew

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Ranjit Avasarala <[email-masked]>
Date: Thu, 7 Oct 2004 07:25:43 -0700 (PDT)

Hi rajeev

 SIP is not the protocol of choice for far end camera
control or for video conferencing. More ideal protocol
 would be H.324 and H.324M for 3GPP. 

Ranjit

--- Rajeew Kumar Singh <[email-masked]>
wrote:

> Sip mailing list 
> https://www1.ietf.org/mailman/listinfo/sip

=====
Regards
Ranjit

_______________________________
Do you Yahoo!?
Declare Yourself - Register online to vote today!
http://vote.yahoo.com

---

From: Rajeew Kumar Singh <[email-masked]>
Date: Fri, 08 Oct 2004 11:29:35 +0530

Hi Ranjit,
   Now people have started working on SIP based video conferencing.
What till now I came to know that the
"support for Far End Camera Control by SIP User Agent"
    can be signalled by SDP using the "m" field giving support for H.224
like

m:data  9000 RTP/AVP 100
Media Attribute(a):rtpmap:100 H224

This shows that the User Agent has support for Far End Camera Control.
Now the Far End Camera Control messages can be carried in RTP during the
conferencing.
The User agent should be intelligent enough to know the RTP streams related
to
Far End Camera Control..and accordingly the Camera is controlled.

Let me know if there is any misunderstanding on this part..

Thanks
Rajeew

-----Original Message-----
From: Ranjit Avasarala [mailto:[email-masked]]
Sent: Thursday, October 07, 2004 7:56 PM
To: [email-masked]
Cc: [email-masked]
Subject: Re: [Sip] Far End Camera Control in SIP

Hi rajeev

Ranjit

=====
Regards
Ranjit

---

From: Ranjit Avasarala <[email-masked]>
Date: Fri, 08 Oct 2004 12:08:31 +0530

Hi Rajeev

what u say is ok. I mean u can indicate support for 224 in SDP. But IP 
network is not capable of carrying delay sensitive information.

Ranjit

-- 
Regards
Ranjit

---

From: David R Oran <[email-masked]>
Date: Fri, 8 Oct 2004 09:57:03 -0400

> network is not capable of carrying delay sensitive information.
Ah, I didn't know that! Thanks, that'll save me a lot of work. We can 
shut down SIP, SIPPING, MMUSIC, AVT, and DIFFSERV and move on to other 
things.

dave.

>>> Use [email-masked] for new developments on the
David R. Oran
Cisco Fellow
Cisco Systems
7 Ladyslipper Lane
Acton, MA 01720 USA
Tel: +1 978 264 2048
Email: [email-masked]

---

From: Ranjit Avasarala <[email-masked]>
Date: Mon, 11 Oct 2004 09:53:48 +0530

Hi
      What I meant by "IP network is not capable" is still IP network 
has to evolve and lot of work needs to be done to make it robustto carry 
delay sensitive data ..Thats why SIP, SIPPING, SIMPLE , etc groups are 
there..

Dave, Hope u have got what I meant.

Ranjit

-- 
Regards
Ranjit