Subject: [Sip] Doubts in SIP/SDP

From: "Anil Bollineni" <[email-masked]>
Date: Mon, 6 Dec 2004 13:46:12 -0800

Dear All,

    I need to clear some doubts in SDP and SIP protocol specifics. 

   1. Caller sends INVITE without the option 100Rel, callee responds
183, and 183 message is lost, can caller should receive media from
callee?. Or without 183, callee sends 200 OK, 200 OK is lost and sends
media without, it waiting ACK for 200 OK, should caller should receive
the media from callee?

  2. Assume caller sends INVITE to x.x.x.x:5060, can response to INVITE
can come from y.y.y.y:5060?

Actually these two questions are different, if there is some possibility
or the above requirements violates related RFC's, can you please let me
know. I would greatly respect the responses.

Thanks in advance,

Anil

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Anil Bollineni" <[email-masked]>
Date: Mon, 6 Dec 2004 15:49:40 -0800

Hi Paul,
  Thanks for the response. For example, if in normal INVITE/200/ACK scenarios, as soon as callee answers the phone (there by UAS starts the media), UAS sends 200 OK, and assume it is lost, will UAC should play the media received from callee?
 OR
 When the callee answers the phone, should not UAS send the media until it receives ACK for 200 OK and starts the media. Which one is more good?
I think the first one is valid, and in that sense the callee is responsible for the billing that he speaks.

Thanks
Anil

-----Original Message-----
From: Paul Kyzivat [mailto:[email-masked]] 
Sent: Monday, December 06, 2004 3:11 PM
To: Anil Bollineni
Cc: Fatih "Ey|p" NAR; Syed, Mohammad Rafi; [email-masked]; [email-masked]
Subject: Re: [Sip-implementors] RE: [Sip] Doubts in SIP/SDP

Anil,

At the time you send an offer you should be prepared to receive media on 
the offered port, using *any* of the codecs in the offer. Whether you 
receive the 183 with answer is irrelevant to that. The 183 with answer 
in this case potentially allows you to send early media, and possibly 
narrows down the list of codecs used for media you receive. The loss of 
the 183 prevents you from sending early but has no other important 
effect, since the same SDP will be repeated in the 200.

	Paul

Anil Bollineni wrote:
> Hi,
>    Thanks for the response. Actually I may confuse you. Specifically, if the callee sends the media after 183, and 183 is lost, will the caller should accept the media, because it don't know codec should the media expect or caller should decode whatever is coming, by finding the codecs in the list it offers. Sorry I don't know that it is the basic requirement, but in RFC can I find the statements that tell the media starts after the SDP negotiation is completed.
> My options are
>     INVITE------------->		OR INVITE ------------>
> 	      <--------183 (lost)		      <-------->183(lost)
>      drop<----------------media	    accept<-----------(media)
> 
> 
> Thanks,
> Anil
> 
> -----Original Message-----
> From: Fatih "Ey|p" NAR [mailto:[email-masked]] 
> Sent: Monday, December 06, 2004 2:44 PM
> To: Syed, Mohammad Rafi; Anil Bollineni; [email-masked]; [email-masked]
> Subject: RE: [Sip] Doubts in SIP/SDP
> 
> if u insist on to send sdp within provisional response
> (180/183 etc 4 early media connection purpose ex.) and
> you want to verify the reverse signalling path --> u
> may use prack mechanism...
> 
> --- "Syed, Mohammad Rafi" <[email-masked]> wrote:
> 
> 
>>Hi Anil,
>> 
>>Case 1)
>>In INVITE w/o option 100rel(offer) case the callee
>>is supposed to send answer(SDP) in 200 OK. if 200 OK
>>sent from callee is lost its the callee's
>>responsibility to retrnasmitt 200 OK.(or callee
>>retransmitt 200 OK until he recvs ACK from caller).
>> 
>>thank u,
>>Rafi.
>>
>>	-----Original Message----- 
>>	From: Anil Bollineni
>>[mailto:[email-masked]] 
>>	Sent: Mon 12/6/2004 4:46 PM 
>>	To: [email-masked]; [email-masked] 
>>	Cc: 
>>	Subject: [Sip] Doubts in SIP/SDP
>>	
>>	
>>
>>	Dear All,
>>
>>	   1. Caller sends INVITE without the option
>>100Rel, callee responds 183, and 183 message is
>>lost, can caller should receive media from callee?.
>>Or without 183, callee sends 200 OK, 200 OK is lost
>>and sends media without, it waiting ACK for 200 OK,
>>should caller should receive the media from callee?
>>
>>	  2. Assume caller sends INVITE to x.x.x.x:5060,
>>can response to INVITE can come from y.y.y.y:5060?
>>
>>	  
>>
>>	Actually these two questions are different, if
>>there is some possibility or the above requirements
>>violates related RFCâ€™s, can you please let me
>>Sip mailing list 
>>https://www1.ietf.org/mailman/listinfo/sip
> __________________________________ 
> Do you Yahoo!? 
> Meet the all-new My Yahoo! - Try it today! 
> http://my.yahoo.com 
>  
> 
> 
> Sip-implementors mailing list
> [email-masked]
> http://lists.cs.columbia.edu/mailman/listinfo/sip-implementors
>

---

From: "Francois Audet" <[email-masked]>
Date: Thu, 9 Dec 2004 22:01:10 -0500

Of course with forking, this gets really interesting.

> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Dean Willis
> Sent: Thursday, December 09, 2004 14:31
> To: Anil Bollineni
> Cc: [email-masked]; [email-masked]
> Subject: Re: [Sip] Doubts in SIP/SDP
> 
> 
> 
> BTW, this is a lovely "sip-implementors" list question.
> 
> Answers herein are my opinion, and may not mesh with some 
> particularly 
> strict interpretations. On the other hand, one can refer to 
> the Postel 
> axiom "be liberal with what you accept" (or however he said 
> that . . .)
> 
> More detailed procedures are available in 
> draft-ietf-sipping-early-media-02.txt, which I believe has been 
> approved by the IESG and is in the RFC Editor queue.
> 
> On Dec 7, 2004, at 6:10 PM, Anil Bollineni wrote:
> 
> > Hi,
> >   Thanks for the response. I have a basic question, considering 3
> > views.
> >
> > 1. Suppose terminating endpoint does not support 183, and sends the 
> > early media for IVR, should  UAC, play the media treated as 
> if early 
> > media.
> >
> 
> yes.
> 
> > 2. Any case the terminating endpoint must support 183 and send the
> > media
> > after it sends. The 100rel is optional, in this case the 
> sequence of 
> > 183
> > and early media is not guaranteed. Should UAC prepare media 
> > irrespective
> > of call progress message?
> >
> 
> The UAC should play any media it receives that is consistent with the 
> SDP it offered in the INVITE.
> 
> The exception to this case is described in the early media draft:
> 
>          Note that, in some situations, the UAC does need to receive
>          the answer before being able to play any media. UAs in such
>          a situation (e.g., QoS, media authorization or media
>          encryption is required) use preconditions to avoid media
>          clipping.
> 
> The use of preconditions is discussed in RFC 3312.
> 
> > 3. In case of 100Rel calling UA requires the option 100rel, should
> > terminating endpoint MUST send always after PRACK is received?
> >
> 
> That's debatable. One might be inclined to suspect that the 
> calling UA 
> has issues with "really early media" in this case, and the UAS SHOULD 
> hold off until receiving the PRACK. I don't know that MUST 
> applies, as 
> one can reasonably expect that SOME UASs might not delay, so the 
> calling UA MUST be prepared to deal with the consequences of a called 
> UA that responds with media before sending an SDP answer.
> 
> 
> 
> > Specifically, if we want deploy a firewall between originating and
> > terminating endpoints, should we allow early media after 
> INVITE without
> > 183 is being seen?
> >
> 
> yes.
> 
> 
> --
> Dean
> 
>