Subject: RE: [Sip] Doubts in SIP/SDP

From: "Anil Bollineni" <[email-masked]>
Date: Mon, 6 Dec 2004 14:58:23 -0800

Hi,
   Thanks for the response. Actually I may confuse you. Specifically, if the callee sends the media after 183, and 183 is lost, will the caller should accept the media, because it don't know codec should the media expect or caller should decode whatever is coming, by finding the codecs in the list it offers. Sorry I don't know that it is the basic requirement, but in RFC can I find the statements that tell the media starts after the SDP negotiation is completed.
My options are
    INVITE------------->		OR INVITE ------------>
	      <--------183 (lost)		      <-------->183(lost)
     drop<----------------media	    accept<-----------(media)

Thanks,
Anil

-----Original Message-----
From: Fatih "Ey|p" NAR [mailto:[email-masked]] 
Sent: Monday, December 06, 2004 2:44 PM
To: Syed, Mohammad Rafi; Anil Bollineni; [email-masked]; [email-masked]
Subject: RE: [Sip] Doubts in SIP/SDP

if u insist on to send sdp within provisional response
(180/183 etc 4 early media connection purpose ex.) and
you want to verify the reverse signalling path --> u
may use prack mechanism...

--- "Syed, Mohammad Rafi" <[email-masked]> wrote:

> Hi Anil,
>  
> Case 1)
> In INVITE w/o option 100rel(offer) case the callee
> is supposed to send answer(SDP) in 200 OK. if 200 OK
> sent from callee is lost its the callee's
> responsibility to retrnasmitt 200 OK.(or callee
> retransmitt 200 OK until he recvs ACK from caller).
>  
> thank u,
> Rafi.
> 
> 	-----Original Message----- 
> 	From: Anil Bollineni
> [mailto:[email-masked]] 
> 	Sent: Mon 12/6/2004 4:46 PM 
> 	To: [email-masked]; [email-masked] 
> 	Cc: 
> 	Subject: [Sip] Doubts in SIP/SDP
> 	
> 	
> 
> 	Dear All,
> 
> 	    I need to clear some doubts in SDP and SIP
> protocol specifics. 
> 
> 	   1. Caller sends INVITE without the option
> 100Rel, callee responds 183, and 183 message is
> lost, can caller should receive media from callee?.
> Or without 183, callee sends 200 OK, 200 OK is lost
> and sends media without, it waiting ACK for 200 OK,
> should caller should receive the media from callee?
> 
> 	  2. Assume caller sends INVITE to x.x.x.x:5060,
> can response to INVITE can come from y.y.y.y:5060?
> 
> 	  
> 
> 	Actually these two questions are different, if
> there is some possibility or the above requirements
> violates related RFCâ€™s, can you please let me
> know. I would greatly respect the responses.
> 
> 	 
> 
> 	Thanks in advance,
> 
> 	Anil
> 
> 	 
> 
> 	 
> 
> 	   
> 
> > _______________________________________________
> Sip mailing list 
> https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP
> Protocol
> Use [email-masked] for questions
> on current sip
> Use [email-masked] for new developments on the
> application of sip

__________________________________ 
Do you Yahoo!? 
Meet the all-new My Yahoo! - Try it today! 
http://my.yahoo.com 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Paul Kyzivat <[email-masked]>
Date: Mon, 06 Dec 2004 18:10:32 -0500

Anil,

At the time you send an offer you should be prepared to receive media on 
the offered port, using *any* of the codecs in the offer. Whether you 
receive the 183 with answer is irrelevant to that. The 183 with answer 
in this case potentially allows you to send early media, and possibly 
narrows down the list of codecs used for media you receive. The loss of 
the 183 prevents you from sending early but has no other important 
effect, since the same SDP will be repeated in the 200.

	Paul

Anil Bollineni wrote:
> Sip-implementors mailing list
> [email-masked]
> http://lists.cs.columbia.edu/mailman/listinfo/sip-implementors
>

---

From: Dean Willis <[email-masked]>
Date: Tue, 7 Dec 2004 16:05:08 -0600

On Dec 6, 2004, at 4:58 PM, Anil Bollineni wrote:

> Hi,
>    Thanks for the response. Actually I may confuse you. Specifically, 
> if the callee sends the media after 183, and 183 is lost, will the 
> caller should accept the media, because it don't know codec should the 
> media expect or caller should decode whatever is coming, by finding 
> the codecs in the list it offers. Sorry I don't know that it is the 
> basic requirement, but in RFC can I find the statements that tell the 
> media starts after the SDP negotiation is completed.
>

I believe the rule is "the caller MUST be ready to receive any media 
described in the SDP of an INVITE immediately after sending that 
INVITE." This is how we get all those neat early-media use-cases.

Note that this use case frequently occurs when placing a call from SIP 
through a PSTN gateway (with ISDN) that terminates on a PSTN IVR, like 
that used by American Airlines. The "answer" SDP arrives in a 200OK 
that is sent by the gateway after the PSTN circuit moves into connected 
state. However, the phone circuit is not in the "connected" state for 
the first round of engagement with the IVR. The gateway in my office 
will only tolerate this for about 32 seconds before it gives up on the 
INVITE, so I have to navigate the first level of the IVR quickly.

--
Dean