Subject: [Sip] Re: [Sip-implementors] OPTIONS outside dialog

From: Klaus Darilion <[email-masked]>
Date: Sat, 04 Dec 2004 13:59:02 +0100

You should response with the some response code as this mould have been 
an INVITE - e.g. 200 OK if everything is fine, "buse here" if the phone 
is busy...

You hsould also include an SDP body to indicate the possible codecs.

klaus

Anil Bollineni wrote:

> Hi,
> 
>     Assume OPTIONS comes outside dialog, what are the possible responses
> that are for OPTIONS, assume these are the same responses for any
> request as defined in RFC 3261. Please clarify.
> 
>  
> 
> Thanks in advance,
> 
> Anil
> 
>  
> 
> _______________________________________________
> Sip-implementors mailing list
> [email-masked]
> http://lists.cs.columbia.edu/mailman/listinfo/sip-implementors
> 
> 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: OmPrakashTripathi 70630 <[email-masked]>
Date: Wed, 01 Dec 2004 12:16:47 +0800

Hi,

   200 OK is the standard Response which one can expect or can send for any Out Of Dialog OPTIONS.
    In most of the cases devices cant understand the OPTIONS then its up to the Entity which sends the OPTIONS to decide what to accept.

Om..

----- Original Message -----
From: Anil Bollineni <[email-masked]>
Date: Wednesday, December 1, 2004 7:09 am
Subject: [Sip-implementors] [Sip] OPTIONS outside dialog

> Hi,
> 
>    Assume OPTIONS comes outside dialog, what are the possible 
> responsesthat are for OPTIONS, assume these are the same responses 
> for any