Subject: RE: [Sip] Doubts in SIP/SDP

From: "Syed, Mohammad Rafi" <[email-masked]>
Date: Mon, 6 Dec 2004 17:21:36 -0500

Hi Anil,
 
Case 1)
In INVITE w/o option 100rel(offer) case the callee is supposed to send answer(SDP) in 200 OK. if 200 OK sent from callee is lost its the callee's responsibility to retrnasmitt 200 OK.(or callee retransmitt 200 OK until he recvs ACK from caller).
 
thank u,
Rafi.

	-----Original Message----- 
	From: Anil Bollineni [mailto:[email-masked]] 
	Sent: Mon 12/6/2004 4:46 PM 
	To: [email-masked]; [email-masked] 
	Cc: 
	Subject: [Sip] Doubts in SIP/SDP

	Dear All,

	    I need to clear some doubts in SDP and SIP protocol specifics. 

	   1. Caller sends INVITE without the option 100Rel, callee responds 183, and 183 message is lost, can caller should receive media from callee?. Or without 183, callee sends 200 OK, 200 OK is lost and sends media without, it waiting ACK for 200 OK, should caller should receive the media from callee?

	  2. Assume caller sends INVITE to x.x.x.x:5060, can response to INVITE can come from y.y.y.y:5060?

	Actually these two questions are different, if there is some possibility or the above requirements violates related RFC’s, can you please let me know. I would greatly respect the responses.

	Thanks in advance,

	Anil

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Fatih "Ey�p" NAR <[email-masked]>
Date: Mon, 6 Dec 2004 14:43:51 -0800 (PST)

if u insist on to send sdp within provisional response
(180/183 etc 4 early media connection purpose ex.) and
you want to verify the reverse signalling path --> u
may use prack mechanism...

--- "Syed, Mohammad Rafi" <[email-masked]> wrote:

> Hi Anil,
>  
> Case 1)
> In INVITE w/o option 100rel(offer) case the callee
> is supposed to send answer(SDP) in 200 OK. if 200 OK
> sent from callee is lost its the callee's
> responsibility to retrnasmitt 200 OK.(or callee
> retransmitt 200 OK until he recvs ACK from caller).
>  
> thank u,
> Rafi.
> 
> 	   1. Caller sends INVITE without the option
> 100Rel, callee responds 183, and 183 message is
> lost, can caller should receive media from callee?.
> Or without 183, callee sends 200 OK, 200 OK is lost
> and sends media without, it waiting ACK for 200 OK,
> should caller should receive the media from callee?
> 
> 	  2. Assume caller sends INVITE to x.x.x.x:5060,
> can response to INVITE can come from y.y.y.y:5060?
> 
> 	  
> 
> 	Actually these two questions are different, if
> there is some possibility or the above requirements
> violates related RFC’s, can you please let me
> know. I would greatly respect the responses.
> 
> 	 
> 
> 	Thanks in advance,
> 
> 	Anil
> 
> 	 
> 
> 	 
> 
> 	   
> 
> Sip mailing list 
> https://www1.ietf.org/mailman/listinfo/sip

__________________________________ 
Do you Yahoo!? 
Meet the all-new My Yahoo! - Try it today! 
http://my.yahoo.com