Subject: [Sip] nested 3xx msgs

From: "Serge Blazhiyevskyy" <[email-masked]>
Date: Tue, 21 Dec 2004 17:22:07 -0800

Hi,
 
I have a question about 3xx messages. 
 
If client initiated a call with INVITE and got 3xx message with 3
destinations, for example.
 
The first destination returned 3xx msg as well. How client should react
in this case?
 
Should it forget the first contact header list and try the second one?
Or, should it try both?
 
Thanks.
Serge
_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 21 Dec 2004 23:26:15 -0500

Serge,

The client behavior in this case should be comparable to what would 
happen if a proxy handled the redirection. There are not hard and fast 
rules, but I believe current recommended practice (as specified in 
callerprefs - RFC3841) is to order the first set of contacts, and then 
if you get another 3xx from trying one of those, then order them 
subordinate to the position of contact they replace. Whether you serial 
or parallel fork, or some combination, is up to you.

Bottom line - try both sets before giving up.

	Paul

Serge Blazhiyevskyy wrote:
> ------------------------------------------------------------------------
>

---

From: "Nataraju A B" <[email-masked]>
Date: Wed, 22 Dec 2004 15:34:46 +0530

Comments inline...

Best Regards,
Nataraju A.B.
-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Paul Kyzivat
Sent: Wednesday, December 22, 2004 9:56 AM
To: Serge Blazhiyevskyy
Cc: [email-masked]
Subject: Re: [Sip] nested 3xx msgs

Serge,

[ABN] but don't repeat on any contacts received in multiple 3xx
responses...

	Paul