Subject: Re: [Sip] refer-with-norefersub

From: Dean Willis <[email-masked]>
Date: Wed, 15 Dec 2004 14:32:09 -0600

Did we have a conclusion from this that I just missed?

--
Dean

On Nov 5, 2004, at 9:06 PM, Cullen Jennings wrote:

>
> I think I understand that often the subscriptions is of no use and 
> what you
> want to do here.
>
> It seems like putting a tag in the uri of the refer like ";norefersub" 
> could
> be used as a hint not to create the implicit subscription. It does not 
> seem
> like the Supported Require stuff is needed.
>
> Would this work and do what you want?
>
> Cullen
>
>
>
>
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip
>

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Adam Roach <[email-masked]>
Date: Wed, 15 Dec 2004 15:26:41 -0600

Cullen Jennings wrote:

>I think I understand that often the subscriptions is of no use and what you
>want to do here. 
>
>It seems like putting a tag in the uri of the refer like ";norefersub" could
>be used as a hint not to create the implicit subscription. It does not seem

This seems wrong to me -- largely because you're saying that, for 
certain URIs, based on local policy decisions, we are supposed to ignore 
MUST-strength normative statements of RFC3515 (e.g. "The NOTIFY 
mechanism defined in [2] MUST be used to inform the agent sending the 
REFER of the status of the reference.")

It seems very much to me that changing behavior to be noncompliant with 
an RFC requires another RFC.

I could easily formulate scenarios where this proposal actually causes 
interoperability issues, but I believe that the objection on principle 
is sufficiently strong that it's not worth wasting anyone's time 
outlining the practical problems.

/a

---

From: Cullen Jennings <[email-masked]>
Date: Wed, 22 Dec 2004 08:08:05 -0800

Yes - I have seen the errors in my ways :-) You are right.

---

From: Cullen Jennings <[email-masked]>
Date: Mon, 27 Dec 2004 14:00:38 -0700

> outlining the practical problems.

Good point - I agree with need RFC - my only point was it seems like you
could do this without Require stuff but perhaps