Subject: RE: [Sip] Sending 200 OK after receiving ACK

From: "Anil Bollineni" <[email-masked]>
Date: Tue, 14 Dec 2004 17:54:15 -0800

Santosh,
   It can be because of some reasons, based on my experience,
	i. Check if the ACK packet is passed through firewall.
	ii. Check the ACK packet contents whether it match the INVITE
transaction.
	iii. It could be a problem with AOL messenger, with 200 Ok
retransmission algorithm :).

Hope it helps,
Anil

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Surya Santosh
Sent: Tuesday, December 14, 2004 4:28 AM
To: [email-masked]
Subject: [Sip] Sending 200 OK after receiving ACK

Hi All,

I have a doubt regarding the processing of ACK  by the UA. The UA , even

after receving ACK from the other UA is still sending 200 OK's.

I am using the following configuration.

Host1------------Firewall---------------------------Internet
                                          |
                                          |
                                        Host2

I am using AOL instant messenger on both the hosts. I started video from

Host2 to Host1. As AOL video uses SIP for connection establishment,
Host1 
sends SIP INVITE to HOST2 and the following figure depicts the flow of
the 
packets between the two UA's.

Host1--------------------------------------Host2
INVITE---------------------->
           <---------------------  100 Trying
           <---------------------  180 Ringing
           <---------------------- 200 OK
ACK    ----------------------->

After receiving the ACK, Host 2 is still sending 200 OK's . It is
happening 
often but not all the times.
I have attached the capture of both success case and failure case. Could

anyone please help me in finding out why Host2 is sending 200 OK' s even

after receiving ACK.

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Spencer Dawkins" <[email-masked]>
Date: Tue, 14 Dec 2004 21:55:03 -0600

My apologies for a possibly non-profound question, but

- where are you monitoring the exchange?

If you're sitting on top of Host1, just because you saw the ACK go 
past, doesn't mean Host2 has seen it yet.

If you're sitting on top of Host2, which is still misbehaving, 
something else must be going on, but I had to ask...

Thanks,

Spencer

-------------------------------------------------------

After receiving the ACK, Host 2 is still sending 200 OK's . It is
happening
often but not all the times.
I have attached the capture of both success case and failure case. 
Could

anyone please help me in finding out why Host2 is sending 200 OK' s 
even

after receiving ACK.