Subject: [Sip] Query on Early Media ( 183 Session in Progress )

From: "Bhattacharyya, Dipankar" <[email-masked]>
Date: Wed, 26 Jan 2005 18:57:19 -0500

Hi All,

    This is query regarding Early Media ( 183 Session in Progress ) .

Can an  Implementation ( Gateway ) send Media before sending out the 183
Session in Progress over UDP Transport in response to a INVITE   ? Is
there any RFC/draft on the details of 183 Session in progress and Media
handling ? 

Thanks in advance .

Best Regards,   

Dipankar Bhattacharyya 
Systems Engineer 
Communication Infrastructure Group

p |  972.401.4112 f | 972.596.4909 m | 214.766.1479
email | [email-masked]
6100 Ohio Drive , Suite 2011 |   Plano, TX  |  75024 .

E M P I R I X 
www.empirix.com
<file:///C:\Documents%20and%20Settings\rknaub\Application%20Data\Microso
ft\Signatures\www.empirix.com> 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 27 Jan 2005 09:14:47 -0500

You can send media as soon as the offer/answer exchange has provided you 
with a place to send it.

So, if the initial invite contains an offer, the UAS may begin sending 
media as soon as it receives that offer, even before sending any 
response. In this case, what the answer in the 183 does is permit the 
UAC to send media to the UAS, even prior to call completion.

Whether you *want* to send media that early, and whether you want to 
render it if you receive it, is another matter.

	Paul

Bhattacharyya, Dipankar wrote:
> *Dipankar Bhattacharyya
> *Systems Engineer
> *p |  **972.401.4112** f |** 972.596.4909 **m |** 214.766.1479*
> *email |* [email-masked] <mailto:[email-masked]>
> 6100 Ohio Drive , Suite 2011 *|*   Plano, TX  *|*  75024 .
> 
> *E M P I R I X
> *www.empirix.com 
> <file:///C:\Documents%20and%20Settings\rknaub\Application%20Data\Microsoft\Signatures\www.empirix.com>
> 
>  
> 
>  
> 
> 
> ------------------------------------------------------------------------
>