Subject: [Sip] Re: question on draft-ietf-sip-sctp-05.txt

From: Gonzalo Camarillo <[email-masked]>
Date: Thu, 13 Jan 2005 13:59:50 +0200

Cullen,

thanks for pointing this out. This problem was caused by the 
documentation process we followed. The original idea was to define 
everything in the SIP over SCTP draft, but then some parts were moved to 
RFC 3261 (e.g., the definition of the token for the via header and the 
value for the transport parameter) and to RFC 3263 (e.g., the definition 
of the SIP+D2S service). We obviously forgot to define (somewhere) both 
tokens and the new service for TLS over SCTP.

I will prepare a new revision of the draft including these definitions.

Thanks,

Gonzalo

Cullen Jennings wrote:

> What do the following two lines look like if I am using TLS over SCTP?
> 
>       sip:[email-masked];transport=sctp
>       Via: SIP/2.0/SCTP ws1234.example.com:5060
> 
> And could you explicitly mention what the SRV lookups are like (particularly
> with TLS and SCTP)
> 
> Thanks, Cullen
> 

-- 
Gonzalo Camarillo         Phone :  +358  9 299 33 71
Oy L M Ericsson Ab        Mobile:  +358 40 702 35 35
Telecom R&D               Fax   :  +358  9 299 30 52
FIN-02420 Jorvas          Email :  [email-masked]
Finland                   http://www.hut.fi/~gonzalo

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Gonzalo Camarillo <[email-masked]>
Date: Thu, 13 Jan 2005 19:50:54 +0200

Cullen,

please, have a look at Sections 4, 6, and 8 of the new revision of the 
draft (you can fetch it from the link below) and let me know if they 
address your concerns:

http://users.piuha.net/gonzalo/temp/draft-ietf-sip-sctp-06.txt

Thanks,

Gonzalo

Gonzalo Camarillo wrote:

>>And could you explicitly mention what the SRV lookups are like
> 
> (particularly
> 
>>with TLS and SCTP)
>>
>>Thanks, Cullen
>>
> 
>

---

From: Cullen Jennings <[email-masked]>
Date: Thu, 13 Jan 2005 17:53:18 -0800

Yes - that dealt with everything I was worried about. Looks good. Thanks.