Subject: [Sip] Few questions regarding PRACK (RFC3262)

From: Chadha Retesh-A19894 <[email-masked]>
Date: Wed, 23 Mar 2005 10:47:21 +0530

Here they go --
 
1. Is there any use of PRACK, if we are sure that the underlying transport
between all the SIP entities is reliable?
 
2. If one provisional response is reliable, is it a MUST that all the
subsequent provisional responses be reliable(not with Rseq header)? What
should be the behavior of the UAC? This is when UAC sent an INVITE with
Supported: 100rel.
 
3. In what scenario, will the UAC, send a new offer in PRACK?
 
4. In the following scenario, what is the response to the second PRACK
request -
    INVITE -->
               <--  180 Rseq: 1
    PRACK (Rack: 1)-->
Crossover happened here<--  180 RSeq:1 (this is a restransmission, since
PRACK is not received and T1 timer fires)
UAC got both the 1xx, but may be late
    PRACK (Rack: 1)-->
               <--  200 ok(1st PRACK )
               <--  481(PRACK)                <--- Let me know, if i am
right here??
 
Thanks in advance.
 
Rgds
Retesh
 
_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Christer Holmberg \(JO/LMF\)" <[email-masked]>
Date: Wed, 30 Mar 2005 22:30:56 +0200

Hi,

Comments inline ([CHH])

>1. Is there any use of PRACK, if we are sure that the underlying transport between all the SIP entities is reliable?

[CHH] With PRACK you can send a "real" offer/answer in a provisional response, and in the PRACK (the first PRACK) itself.

>2. If one provisional response is reliable, is it a MUST that all the subsequent provisional responses be reliable(not with 
>Rseq header)? What should be the behavior of the UAC? This is when UAC sent an INVITE with Supported: 100rel.

[CHH] If the UAC indicated SUPPORTED I believe that the UAS can choose which provisional response(s) should be sent reliably and which should not.

>3. In what scenario, will the UAC, send a new offer in PRACK?

[CHH] The UAC MAY send a new offer in the PRACK (the first PRACK) if it received an answer in the 18x.

>4. In the following scenario, what is the response to the second PRACK request -
>    INVITE -->
>    <--  180 Rseq: 1
>    PRACK (Rack: 1)-->
>Crossover happened here<--  180 RSeq:1 (this is a restransmission, since PRACK is not received and T1 timer fires)
>               <--  481(PRACK)                <--- Let me know, if i am right here??

[CHH] The UAC shall not generate a new PRACK for a re-transmission of the 180.

Regards,

Christer Holmberg
Ericsson Finland