Subject: [Sip] When does the RTP start

From: "M.N.A.Smadi" <[email-masked]>
Date: Tue, 08 Mar 2005 09:51:24 -0500

hi;

in a INVITE/200 OK/ACK sequence, does the standard indicate when does 
the rtp flaw exactly start at both ends?

thanks

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 08 Mar 2005 09:59:28 -0500

It doesn't specify when it *does* start. But it does specify when it 
*could* start:
- the offerer should be prepared to receive as soon as it sends the
   first message containing an offer
- the answerer may begin to send as soon as it receives the offer
- the answerer should be prepared to receive as soon as it sends
   the message containing an answer
- the offerer may begin to send as soon as it receives an answer

These are general rules, and can be modified in some circumstances. For 
instance:
- preconditions can delay things
- some media types have different rules. (But that doesn't apply
   to RTP, unless you consider RTP over TCP.)

	Paul