Subject: RE: [Sip] midcall signalling

From: "Louis Alexander" <[email-masked]>
Date: Thu, 24 Feb 2005 17:00:32 -0500

Of course, plain old inband dtmf (the DTMF tones encoded as audio packets,
NOT 2833 tones) is still legal as well :)

--Louis

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Fatih
Ey|p NAR
Sent: Thursday, February 24, 2005 4:45 PM
To: Ban Zie; [email-masked]
Subject: Re: [Sip] midcall signalling

SIP DMTF signalling is done with INFO messages or with
RTP messages, the media protocol. This is defined in
http://www.ietf.org/rfc/rfc2833.txt - IETF RFC 2833 

--- Ban Zie <[email-masked]> wrote:

> hello,
> is there 100% agreement / concensus on how midcall
> signalling data is to be carried in sip ?
> when 2 SIP UA's are alrady in conversation, then if
> one user presses some keys on his keypad, are they
> transmitted as DTMF on RTP, or how exactly is it
> done ?
> cheers,
> bzie.
> -- 
>
___________________________________________________________
> Sign-up for Ads Free at Mail.com
> http://promo.mail.com/adsfreejump.htm
> 
> 
> _______________________________________________
> Sip mailing list 
> https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP
> Protocol
> Use [email-masked] for questions
> on current sip
> Use [email-masked] for new developments on the
> application of sip
> 

__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

______________________________________________________________________
This email has been scanned by the MessageLabs Email Security System.
For more information please visit http://www.messagelabs.com/email 
______________________________________________________________________

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Eric Burger <[email-masked]>
Date: Fri, 4 Mar 2005 18:10:45 -0500

Yes and no.

*Transporting* DTMF as RFC2833 or coded dual-tone multi-frequency is always
legal.

However, the subject of the query is "midcall signaling".  Signaling is not
transport.  The only method of signaling midcall events in SIP is KPML.

> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Louis Alexander
> Sent: Thursday, February 24, 2005 5:01 PM
> To: 'Fatih Ey|p NAR'; 'Ban Zie'; [email-masked]
> Subject: RE: [Sip] midcall signalling
> 
>