Subject: [Sip] Multiple 2xx responses forking proxy

From: [email-masked]
Date: Wed, 16 Mar 2005 15:19:19 -0500

Hi,

As per RFC 3261, a forking proxy on receiving 2xx response will send 
CANCEL for the remaining client transactions.
However, it may happend that during this time another 2xx response is 
received, then what should be the proxy behaviour, 
should it forward it to the UA as it is mentioned in RFC that all the 2xx 
responses should be forwarded immediatle, will it do 
it statelessly?

And if UAC receives multiple 200 responses, how it should behave, because 
from user's perspective he dials a single destination but 
there are multiple dialogs established, but he cant be connected to 
everybody...
is it like UAC will terminate the dialogs after the first dialog is 
established by checking that it came from same destination (because of
same To header) but different tags..

Thanks,
Udit

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Amit Idnani" <[email-masked]>
Date: Wed, 16 Mar 2005 14:38:51 -0800

Udit,
 
An RFC-3261 compliant UAC should be prepared to receive multiple 2xx response for an INVITE request that it sends out. Each 2xx response is distinguished by the tag parameter in the To header header (making them different dialogs).
 
The appearance to the end user is purely an implementation choice where you can terminate all but the first dialog established by sending an ACK for the 2xx followed by a BYE request within that particular dialog.
 
Hope it helps.
 
Amit Idnani

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of [email-masked]
Sent: Wednesday, March 16, 2005 12:19 PM
To: [email-masked]
Subject: [Sip] Multiple 2xx responses forking proxy

Hi, 

As per RFC 3261, a forking proxy on receiving 2xx response will send CANCEL for the remaining client transactions. 
However, it may happend that during this time another 2xx response is received, then what should be the proxy behaviour, 
should it forward it to the UA as it is mentioned in RFC that all the 2xx responses should be forwarded immediatle, will it do 
it statelessly? 

And if UAC receives multiple 200 responses, how it should behave, because from user's perspective he dials a single destination but 
there are multiple dialogs established, but he cant be connected to everybody... 
is it like UAC will terminate the dialogs after the first dialog is established by checking that it came from same destination (because of 
same To header) but different tags.. 

Thanks, 
Udit