Subject: RE: [Sip] draft-jennings-sip-hashcash-01

From: "Francois Audet" <[email-masked]>
Date: Thu, 3 Mar 2005 14:46:00 -0500

As a separate note, shouldn't we try to solve the HERFP problem?

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Cullen Jennings
> Sent: Wednesday, March 02, 2005 12:16
> To: Jonathan Rosenberg
> Cc: [email-masked]
> Subject: Re: [Sip] draft-jennings-sip-hashcash-01
> 
> 
> On 3/2/05 2:15 AM, "Jonathan Rosenberg" <[email-masked]> wrote:
> 
> > 1. The mechanism interacts badly with forking at the moment. One 
> > problem is HERFP. If I have a mix of endpoints, some of 
> which support 
> > this (and thus send a 419), and others that don't (and thus 
> ring the 
> > phone), then you'll end up always completing the call on 
> the endpoints 
> > that don't support the extension.
> 
> Good point. I think will mention this in the draft but 
> clearly I won't attempt to solve the well studied HERFP 
> problem. As a separate issues, some day the WG should discuss 
> the limitations of the "If it hurts don't do it" solution to 
> the HERFP problem.
> 
> > 
> > 2. THe mechanism doesn't provide a way for a proxy to aggregate 
> > multiple Puzzle headers from forked branches. It needs to 
> do something 
> > like WWW-Authenticate where a proxy collects these from the various 
> > 419 and places all of them in the 419 forwarded upstream. That will 
> > also require something akin to realm, that allows a 
> UA/proxy to pull 
> > out its own puzzle.
> 
> Oops. Excellent point. Thanks, will fix this. 
> 
> 
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current 
> sip Use [email-masked] for new developments on the 
> application of sip
> 
> 
_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Thu, 03 Mar 2005 22:52:46 -0500

Sigh.... probably. Its been on my todo list forever, and its one of 
these things where the cure may be worse than the disease. But perhaps 
others have a better idea how to fix it than I did. That solution was 
discussed here:

http://www.jdrosen.net/papers/draft-rosenberg-sip-unify-00.txt

-Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.                   600 Lanidex Plaza
Director, Service Provider VoIP Architecture   Parsippany, NJ 07054-2711
Cisco Systems
[email-masked]                              FAX:   (973) 952-5050
http://www.jdrosen.net                         PHONE: (973) 952-5000
http://www.cisco.com