Subject: RE: [Sip] When does the RTP start

From: "Reinaldo Penno" <[email-masked]>
Date: Wed, 9 Mar 2005 07:09:09 -0500

Interesting, just yesterday I was dealing with a similar situation.

Would this be true for re-INVITES (and maybe UPDATES) as well?

I mean, should a client (a.k.a INVITEE) be prepared to receive in a
different port, etc as soon as the re-INVITE is issued? This means that
for a period of time the client would be listening on all ports
associated with both SDP specifications...?

Regards,

Reinaldo 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Paul Kyzivat
Sent: Tuesday, March 08, 2005 9:59 AM
To: M.N.A.Smadi
Cc: IETF SIP List
Subject: Re: [Sip] When does the RTP start

It doesn't specify when it *does* start. But it does specify when it 
*could* start:
- the offerer should be prepared to receive as soon as it sends the
   first message containing an offer
- the answerer may begin to send as soon as it receives the offer
- the answerer should be prepared to receive as soon as it sends
   the message containing an answer
- the offerer may begin to send as soon as it receives an answer

These are general rules, and can be modified in some circumstances. For 
instance:
- preconditions can delay things
- some media types have different rules. (But that doesn't apply
   to RTP, unless you consider RTP over TCP.)

	Paul

M.N.A.Smadi wrote:
> hi;
> 
> in a INVITE/200 OK/ACK sequence, does the standard indicate when does 
> the rtp flaw exactly start at both ends?
> 
> 
> thanks
> 
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip
> 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 09 Mar 2005 11:43:54 -0500

> Would this be true for re-INVITES (and maybe UPDATES) as well?

Yes.

> associated with both SDP specifications...?

Yes. This is all treated in RFC 3264.

-Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.                   600 Lanidex Plaza
Director, Service Provider VoIP Architecture   Parsippany, NJ 07054-2711
Cisco Systems
[email-masked]                              FAX:   (973) 952-5050
http://www.jdrosen.net                         PHONE: (973) 952-5000
http://www.cisco.com