Subject: RE: [Sip] midcall signalling

From: Eric Burger <[email-masked]>
Date: Fri, 4 Mar 2005 18:10:47 -0500

Do you want midcall signaling or DTMF transport?

If you need reliable, application-layer conveyance of signaling, then KPML
is the right answer.  See 
http://www.ietf.org/internet-drafts/draft-ietf-sipping-app-interaction-frame
work-04.txt
for a very detailed explanation why.

If all you need is unreliable transport of tones, use RFC2833 or the tones
themselves.

Note this has nothing to do with topology.  KPML is, in fact, purely for
UA-UA communications.  It just happens there is a use case where one of the
UA's is an IP or TDM gateway.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On 
> Behalf Of Ban
> Zie
> Sent: Friday, February 25, 2005 9:40 AM
> To: Mariano Stokle
> Cc: [email-masked]; Louis Alexander
> Subject: Re: [Sip] midcall signalling
> 
> 
> Hello Mariano:
> 
> > You should also check
> > http://www.ietf.org/internet-drafts/draft-ietf-sipping-kpml-07.txt
> 
> I quickly skimmed thru this I-D, and it appears to me that 
> this is more likely to be associated as a Event delivery 
> medium between and IVR / G/w / Transcoder and a SIP 
> AppServer. In my scenario, i.e. UA <----> UA, this doesn't 
> seem reasonable thing to do. Here the second-UA is like a 
> Telephonic credit-card payment gateway.
> 
> -z
> -- 
> ___________________________________________________________
> Sign-up for Ads Free at Mail.com
> http://promo.mail.com/adsfreejump.htm
> 
> 
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip
> 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Cullen Jennings <[email-masked]>
Date: Fri, 04 Mar 2005 20:54:54 -0800

This whole thread is somewhat misleading.

If you want to get DTMF from one UA to the other UA that it is talking to,
your bar none best bet is 2833. This was the original problem stated - it is
what almost all SIP devices do today. It is how most people at IETF
recommend solving this problem. It generally it works better than solutions
that leave the DTMF tones in the encoded audio. KPML is meant for a
different problem.