Subject: RE: [Sip] sip-identity-05: display-name woes

From: "Peterson, Jon" <[email-masked]>
Date: Tue, 19 Apr 2005 04:43:16 -0400

Understand that most of what I wrote below was intended only to support the design decision that identity for telephone numbers is out of scope for the current sip-identity draft, and thus that TNs wouldn't serve as a clear argument about display-names one way or another. So, this is all just hypotheticals.
 
Currently, the ENUM database has no capability whatsoever to provide names of end users; any such capability would need to be invented before it could be leveraged. Presumably, if a block of phone numbers is delegated to an organization with ENUM, it is the responsibility of that organization to populate any and all ENUM records, including any hypothetical records that assisted in providing names for end users. Note that in many principalities, organizations are not allowed to "own" telephone numbers, only carriers have that privilege. In such contexts the idea of, say, an enterprise being responsible for this function wouldn't make any sense.
 
Strictly following my logic below, in a case where an organization is responsible for a block of telephone numbers in ENUM, they would be the appropriate signatory for any and all authentication service responsibilities when telephone numbers are used in the From header field of SIP requests. Thus, ENUM could be used to discover the organization responsible for the number, yes, and so to determine who is eligible to provide an authentication service for the user in question. While it could theoretically be used furthermore to derive the appropriate name, if we were to invent such a mechanism, this would be a separable capability.
 
Jon Peterson
NeuStar, Inc.

-----Original Message-----
From: Francois Audet [mailto:[email-masked]]
Sent: Monday, April 18, 2005 11:56 AM
To: Peterson, Jon; 'Paul Kyzivat'; 'Brian Rosen'
Cc: [email-masked]'
Subject: RE: [Sip] sip-identity-05: display-name woes

There is also the case where the ENUM database wouldn't have the Name of the 
end-user because a block of phone numbers are assigned to an organization (like 
a corporation). 

It this case, I'm assuming that the display name would be provided 
by the organization itself, but the SIP service provider would 
assert that the organization was allowed to populate the display name. 

Perhaps ENUM could be used to verify that, but it wouldn't be used 
to derive the name itself (just the owner). 

Is this what you had in mind? 

> -----Original Message----- 
> From: [email-masked] [ mailto:[email-masked]] On 
> Behalf Of Peterson, Jon 
> Sent: Friday, April 08, 2005 12:54 
> To: Paul Kyzivat; Brian Rosen 
> Cc: [email-masked] 
> Subject: RE: [Sip] sip-identity-05: display-name woes 
> 
> 
> 
> Some notes inline. 
> 
> Jon Peterson 
> NeuStar, Inc. 
> 
> > -----Original Message----- 
> > From: Paul Kyzivat [ mailto:[email-masked]] 
> > Sent: Thursday, April 07, 2005 7:33 AM 
> > To: Brian Rosen 
> > Cc: Peterson, Jon; [email-masked] 
> > Subject: Re: [Sip] sip-identity-05: display-name woes 
> > 
> [snip] 
> > 
> > The most immediate problem I can see comes when your call lands on a 
> > gateway to the PSTN. At that point the identification 
> conventions of the 
> > SIP network must be interworked with those of the public telephone 
> > network. The gateway must decide whether to populate the 
> calling name 
> > and number fields on the PSTN side. If it has no 
> authentication that the 
> > information is correct, should it populate it? 
> 
> Let's be careful, though. If I'm calling from 
> sip:[email-masked], what exactly does the gateway put in the 
> ISUP CgPN field, let alone what might it share as a textual 
> string in the GNP? That sort of SIP-ISUP mapping has bigger 
> problems than just how to deal with display-name. Clearly, if 
> the gateway is going to just make up a telephone number to 
> represent the calling party, all bets are off about how to 
> understand the GNP. 
> 
> Of course, the From header field of a SIP request might 
> contain a tel URI, or a SIP URI with a tel URI user portion. 
> But in that instance, provided it is a valid telephone 
> number, there is most likely a CNAM record associated with it 
> in the PSTN. Gateways or subsequent PSTN signaling elements 
> can always do CNAM queries to recover the associated 
> appropriate calling name to populate the GNP. But clearly 
> there's no point in even getting the CNAM if the telephone 
> number itself can just trivially be forged in SIP From header 
> fields. This gets into the whole question of why a gateway 
> would ever trust an Identity header that asserts a telephone 
> number. As sip-identity-04 suggests, that has to be a subject 
> for future work, but the only plausible lines of thought we 
> have on this today are ENUM architectures. 
> 
> By launching an ENUM query, the story might go, the gateway 
> could learn who the number owner is, and thus who should 
> provide the signature over the Identity information, and 
> conceivably the gateway could also learn info like CNAM at 
> the time. This would be tantamount to just reinventing CNAM 
> in an IP context - something that is probably inevitable if 
> telephone numbers are to be used extensively in SIP, 
> something that people are no doubt noodling in various shops 
> around the world today, and something that probably wouldn't 
> necessarily require signing the display-name in order for it to work. 
> 
> But until we boil that particular ocean, I feel that PSTN 
> interworking might not the best case on which to argue the 
> display-name issue one way or another. 
> 
> _______________________________________________ 
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip 
> This list is for NEW development of the core SIP Protocol 
> Use [email-masked] for questions on current 
> sip Use [email-masked] for new developments on the 
> application of sip 
> 
> 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 19 Apr 2005 09:34:15 -0400

Jon,

So what you are suggesting is:

- your identity draft is based on ability to determine
   authenticator based on domain name in URI. It doesn't
   work for phone numbers

- potentially that could be solved by having something
   (e.g. enum) provide a specification for who the
   authenticator should be for a particular tel: URI.
   Given that, the identity draft could then provide
   the authentication.

I think that makes a lot of sense as a potential way forward, though it 
further increases the potential latency for a call.

And yes, this is just a bunch of hypotheticals. But a potentially 
important bunch. It may form bhe beginning of a plan for where to go. 
SIP is starting to get real traction in the consumer market now. This 
stuff seems important for continued progress.

I think those hypotheticals need to include how meet perceived needs 
such as display of calling name. Whether it comes from the display name 
or from somewhere else can remain an open question for awhile.

	Paul

Peterson, Jon wrote:
>  
> Understand that most of what I wrote below was intended only to support 
> the design decision that identity for telephone numbers is out of scope 
> for the current sip-identity draft, and thus that TNs wouldn't serve as 
> a clear argument about display-names one way or another. So, this is all 
> just hypotheticals.
>  
> Currently, the ENUM database has no capability whatsoever to provide 
> names of end users; any such capability would need to be invented before 
> it could be leveraged. Presumably, if a block of phone numbers is 
> delegated to an organization with ENUM, it is the responsibility of that 
> organization to populate any and all ENUM records, including any 
> hypothetical records that assisted in providing names for end users. 
> Note that in many principalities, organizations are not allowed to "own" 
> telephone numbers, only carriers have that privilege. In such contexts 
> the idea of, say, an enterprise being responsible for this function 
> wouldn't make any sense.
>  
> Strictly following my logic below, in a case where an organization is 
> responsible for a block of telephone numbers in ENUM, they would be the 
> appropriate signatory for any and all authentication service 
> responsibilities when telephone numbers are used in the From header 
> field of SIP requests. Thus, ENUM could be used to discover the 
> organization responsible for the number, yes, and so to determine who is 
> eligible to provide an authentication service for the user in question. 
> While it could theoretically be used furthermore to derive the 
> appropriate name, if we were to invent such a mechanism, this would be a 
> separable capability.
>  
> Jon Peterson
> NeuStar, Inc.
> 
>     *From:* Francois Audet [mailto:[email-masked]]
>     *Sent:* Monday, April 18, 2005 11:56 AM
>     *To:* Peterson, Jon; 'Paul Kyzivat'; 'Brian Rosen'
>     *Cc:* [email-masked]'
>     *Subject:* RE: [Sip] sip-identity-05: display-name woes
> 
>      > From: [email-masked] [mailto:[email-masked]] On
>      > Behalf Of Peterson, Jon
>      > > From: Paul Kyzivat [mailto:[email-masked]]