Subject: [Sip] Registration question

From: Satya Kondury <[email-masked]>
Date: Thu, 14 Apr 2005 12:23:27 +0100 (BST)

Hi,
  I am new to working in SIP area. I have a basic
quetsion.

  Incase a registered user again registers with
different contact address registrar with out
deregistering from the first contact address, both the
addresses will be stored in the location
database(assume expiry time is not over for the
previous registration). Then how the routing takes
place for an incoming call to that user? 

  Is there any difference in case a user registers
with two contact addresses in a single registration
message as far as routing is concerned? 

Satya

________________________________________________________________________
Yahoo! India Matrimony: Find your partner online. http://yahoo.shaadi.com/india-matrimony/

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 14 Apr 2005 08:20:46 -0400

> place for an incoming call to that user? 

Both addresses are *candidates* for routing of requests addressed to the 
address of record identified in the REGISTER. The details of if, and in 
what order, the candidates are tried is not normatively specified. There 
are some guidelines/suggestions in RFCs 3261 and 3841 (callerprefs). 
Everything else being equal, you might expect that requests would be 
forked to both.

> message as far as routing is concerned? 

No - that should make no difference.

	Paul