Subject: RE: [Sip] Changing the From header

From: "Elwell, John" <[email-masked]>
Date: Thu, 10 Nov 2005 20:36:09 +0000

Michael,
 
The consensus in SIP on Tuesday was that we should not take any special
action to deal with proxies that fail to comply with RFC3261. Therefore my
question concerns only UAs.
 
John
 
  _____  

From: Michael Hammer (mhammer) [mailto:[email-masked]] 
Sent: 10 November 2005 19:49
To: Elwell, John; Francois Audet; IETF SIP List
Subject: RE: [Sip] Changing the From header

John,
 
Wouldn't you need to have every UA and proxy involved with the call to
signal that it supports changing From, e.g. in the Record-Route, e.g. a 3261
tag?  If any one does not support it then making a mid-dialog change will
break at the point that one doesn't recognize the dialog.
 
The converse might be to have a option-tag: 2543 if any node recognizes that
another node will not support the above.
 
Mike

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Elwell, John
Sent: Thursday, November 10, 2005 2:15 PM
To: Francois Audet; IETF SIP List
Subject: RE: [Sip] Changing the From header

Francois,
 
I hope we don't need it, but I would like confirmation.
 
John

  _____  

From: Francois Audet [mailto:[email-masked]] 
Sent: 10 November 2005 18:05
To: Elwell, John; IETF SIP List
Subject: RE: [Sip] Changing the From header

John,
 
Do you think we need this?
 
Seems to me this is unecessary (provided we don't require RFC 2543 backward
compatibility).

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Elwell, John
Sent: Wednesday, November 09, 2005 19:09
To: IETF SIP List
Subject: [Sip] Changing the From header

At yesterday's SIP session we had rough consensus on changing the From
header field URI in mid-dialog requests. We also said that no special
provision would be made to accommodate proxies that cannot cope with this.
Nothing was said about UASs that cannot cope with this. Do we need an option
tag to indicate support for a changed From header field URI during a dialog?
With such an option tag, a UA that does not receive a Supported header field
with this option tag during the dialog-forming transaction would refrain
from changing the From header field URI in mid-dialog requests.

John 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Thu, 10 Nov 2005 20:42:33 -0500

I still think a Supported is a good idea. At the very least, if its not 
supported, a UA on the other side can know its not worth its trouble to 
try an UPDATE with a new From. There is no harm to the Supported tag, 
and it might help.

-Jonathan R.

Elwell, John wrote:

> action to deal with proxies that fail to comply with RFC3261. Therefore 
> my question concerns only UAs.
>  
> John
>  
> ------------------------------------------------------------------------
> *From:* Michael Hammer (mhammer) [mailto:[email-masked]]
> *Sent:* 10 November 2005 19:49
> *To:* Elwell, John; Francois Audet; IETF SIP List
> *Subject:* RE: [Sip] Changing the From header
> 
>     John,
>      
>     Wouldn't you need to have every UA and proxy involved with the call
>     to signal that it supports changing From, e.g. in the Record-Route,
>     e.g. a 3261 tag?  If any one does not support it then making a
>     mid-dialog change will break at the point that one doesn't recognize
>     the dialog.
>      
>     The converse might be to have a option-tag: 2543 if any node
>     recognizes that another node will not support the above.
>      
>     Mike
> 
>         ------------------------------------------------------------------------
>         *From:* [email-masked] [mailto:[email-masked]] *On
>         Behalf Of *Elwell, John
>         *Sent:* Thursday, November 10, 2005 2:15 PM
>         *To:* Francois Audet; IETF SIP List
>         *Subject:* RE: [Sip] Changing the From header
> 
>         Francois,
>          
>             ------------------------------------------------------------------------
>             *From:* Francois Audet [mailto:[email-masked]]
>             *Sent:* 10 November 2005 18:05
>             *To:* Elwell, John; IETF SIP List
>             *Subject:* RE: [Sip] Changing the From header
> 
>             John,
>              
>             Seems to me this is unecessary (provided we don't require
>             RFC 2543 backward compatibility).
>              
> 
>                 *From:* [email-masked]
>                 [mailto:[email-masked]] *On Behalf Of *Elwell, John
>                 *Sent:* Wednesday, November 09, 2005 19:09
>                 *To:* IETF SIP List
>                 *Subject:* [Sip] Changing the From header
> 
>                 At yesterday's SIP session we had rough consensus on
>                 changing the From header field URI in mid-dialog
>                 requests. We also said that no special provision would
>                 be made to accommodate proxies that cannot cope with
>                 this. Nothing was said about UASs that cannot cope with
>                 this. Do we need an option tag to indicate support for a
>                 changed From header field URI during a dialog? With such
>                 an option tag, a UA that does not receive a Supported
>                 header field with this option tag during the
>                 dialog-forming transaction would refrain from changing
>                 the From header field URI in mid-dialog requests.
> 
>                 John
> 
> 
> ------------------------------------------------------------------------
> 

-- 
Jonathan D. Rosenberg, Ph.D.                   600 Lanidex Plaza
Director, Service Provider VoIP Architecture   Parsippany, NJ 07054-2711
Cisco Systems
[email-masked]                              FAX:   (973) 952-5050
http://www.jdrosen.net                         PHONE: (973) 952-5000
http://www.cisco.com