Subject: RE: [Sip] GRUU (was Whats wrong with Supported. (was: Alert-Info Idea)

From: "Sean Olson" <[email-masked]>
Date: Fri, 4 Nov 2005 10:15:13 -0800

Very true. You can always try, fail, then take appropriate steps. I'm
just talking about short circuiting the failure. You don't know that a
GRUU will succeed, but you have a fairly high level of confidence that a
non-GRUU will fail. I really hope that this becomes the 1% case with 99%
of URIs are GRUUs. With that long term goal in mind, I'd prefer to
signal that something is not a GRUU rather than always have to signal
that it is one. 

-----Original Message-----
From: Dean Willis [mailto:[email-masked]] 
Sent: Friday, November 04, 2005 9:50 AM
To: Sean Olson
Cc: Jeroen van Bemmel; Sip
Subject: Re: [Sip] GRUU (was Whats wrong with Supported. (was:
Alert-Info Idea)

On Nov 3, 2005, at 6:57 PM, Sean Olson wrote:

> Well, if GRUU ==  Globally Routable UA URI, and you treat a URI as a 
> GRUU which does not have one of these properties, things will break. 
> If you care when things break, you would want to know in advance. This

> would apply to UAs, proxies, etc. You could make the argument that all

> URIs should be GRUUs so what you really want is a property that says a

> URI is *not* at a GRUU and assume all others are ;-)

So, exactly what do you do differently if you think something might not
be GRUU?

You've been given this URI. Don't you just have to try it and see if it
works, and if not then back off to some other behavior?

Remember, there's really no such thing as an absolutely universally
reachable URI. It might b a URI on the public internet that your corp
firewall has decided to block. It might just stop working between the
time you get it and the time you try to use it. The Net might partition
in between you. And so on.

--
Dean

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Dolly, Martin C, ALABS" <[email-masked]>
Date: Fri, 4 Nov 2005 19:58:58 -0600

the wonderful things about GRUUs, are that GRUUs are wonderful things,
there names are made out of URIs, but individual things....

> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Dale R. Worley
> Sent: Friday, November 04, 2005 7:02 PM
> To: Sip
> On Fri, 2005-11-04 at 11:49 -0600, Dean Willis wrote:
> > So, exactly what do you do differently if you think 
> something might  
> > not be GRUU?
> > 
> > You've been given this URI. Don't you just have to try it 
> and see if  
> > it works, and if not then back off to some other behavior?
> 
> I believe that is what everybody does in practice.  And we 
> have sort of
> given them permission to do so, since RFC 3261 says that 
> Contacts should
> be GRUUs.
> 
> Dale
> 
> 
>