Subject: RE: [Sip] Query about '491 response' in case of RE-INVITE.

From: "Syed, Mohammad Rafi" <[email-masked]>
Date: Thu, 17 Nov 2005 14:10:15 -0500

This is right behaviour as Offer recvd at UA-B in the initial INVITE is still not replied with an answer(either in 18X if reliable is used or 200OK with SDP).

A                   B
----INVITEOffer1---->
<------answer1----(18X with SDP if reliable or 200 OK with SDP)

-Rafi.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Manjeet Soodan
Sent: Thursday, November 17, 2005 1:58 PM
To: [email-masked]
Subject: [Sip] Query about '491 response' in case of RE-INVITE.

1) There are two SIP UA's A and B.
2) A sends INVITE with SDP to B.
3) B responds with 100 and then 180 Ringing(wthout SDP)  and adds TO tag to
180.
3) After 180 is received, A sends a  RE-INVITE before 200 OK is received
(i.e RE-INVITE with all the headers having same value as initial INVITE and
higher CSEQ value).
4) In this case B responds with a  '491 Request Pending' for RE-INVITE.

Is it the right behaviour, if not then what should be the right behaviour of
B?

-Manjeet

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 17 Nov 2005 15:07:47 -0500

No, this is not correct behavior. There must not be a reinvite until the 
initial invite transaction is completed (with a 200 and an ACK).

If the 180 is sent *reliably* (using the 100rel option) and then 
PRACKed, then there is an early dialog and A may send an UPDATE. That is 
as close as you can get to the functionality of a reinvite before the 
initial invite is present.

	Paul

---

From: "Manjeet Soodan" <[email-masked]>
Date: Fri, 18 Nov 2005 12:50:32 +0530

Paul, but in our case an early dialog is already formed when we received a
'180' with TO tag, so in this case a INVITE can be considered as a RE-INVITE
as is the case
below, then a '491' becomes a valid response.

Acc to RFC 3261 :- 12.1 Creation of a Dialog

   Dialogs are created through the generation of non-failure responses
   to requests with specific methods.  Within this specification, only
   2xx and 101-199 responses with a To tag, where the request was
   INVITE, will establish a dialog.  A dialog established by a non-final
   response to a request is in the "early" state and it is called an
   early dialog.

-Manjeet

-----Original Message-----
From: Paul Kyzivat [mailto:[email-masked]]
Sent: Friday, November 18, 2005 1:38 AM
To: Syed, Mohammad Rafi
Cc: Manjeet Soodan; [email-masked]
Subject: Re: [Sip] Query about '491 response' in case of RE-INVITE.

	Paul

Syed, Mohammad Rafi wrote:
> This is right behaviour as Offer recvd at UA-B in the initial INVITE is
still not replied with an answer(either in 18X if reliable is used or 200OK
with SDP).

---

From: "Manjeet Soodan" <[email-masked]>
Date: Fri, 18 Nov 2005 14:55:10 +0530

if we say that this is not the correct behaviour then what should be the
reply from the UAS B, when the 2nd INVITE is send.

what error code will be a valid response for the 2nd INVITE in this case?

-Manjeet

-----Original Message-----
From: Paul Kyzivat [mailto:[email-masked]]
Sent: Friday, November 18, 2005 1:38 AM
To: Syed, Mohammad Rafi
Cc: Manjeet Soodan; [email-masked]
Subject: Re: [Sip] Query about '491 response' in case of RE-INVITE.

	Paul

---

From: Paul Kyzivat <[email-masked]>
Date: Fri, 18 Nov 2005 08:51:16 -0500

Manjeet,

Sorry that my prior reply missed the point of what you were asking. Once 
we havemade the assumption that A has violated 3261, we are in an area 
of speculation. In general 3261 doesn't specify the proper response to 
invalid usage. I think your use of 491 might be ok. Lots of other things 
might also be plausible.

	Paul

Manjeet Soodan wrote:
>>3) B responds with 100 and then 180 Ringing(wthout SDP)  and adds TO tag
> 
> to
> 
>>180.
>>(i.e RE-INVITE with all the headers having same value as initial INVITE
> 
> and
> 
>>higher CSEQ value).
>>Is it the right behaviour, if not then what should be the right behaviour
> 
> of
> 
>>B?
>>
>>
>>-Manjeet
>>
>>
>>

---

From: "Manjeet Soodan" <[email-masked]>
Date: Fri, 18 Nov 2005 21:04:54 +0530

paul,

just last question, can we send '180 Ringing' as a response in this case for
the 2nd INVITE, and would 180 be a valid response in this case.?

We are having a big discussion over this?

-Manjeet

-----Original Message-----
From: Paul Kyzivat [mailto:[email-masked]]
Sent: Friday, November 18, 2005 7:21 PM
To: Manjeet Soodan
Cc: Syed, Mohammad Rafi; [email-masked]
Subject: Re: [Sip] Query about '491 response' in case of RE-INVITE.

Manjeet,

	Paul

---

From: Paul Kyzivat <[email-masked]>
Date: Fri, 18 Nov 2005 11:17:49 -0500

> We are having a big discussion over this?

The entire call flow is invalid from the time that A sent the reinvite, 
because a reinvite is not allowed in that state. So it is impossible to 
say what response to it is "valid". All you can do is conjecture what 
kind of response will have the most satisfactory result. But you are 
guessing about how a broken UA (A) will respond, and there is no general 
way to know that.

You can send any final error response to the reinvite, and then send an 
error response to the initial invite as well to indicate your 
displeasure. Or you can just reject the reinvite and hope for the best.

I can't find any error responses that are really appropriate for this 
situation. The 491 you suggest seems at least as good as any other for 
the reinvite. If you then want to reject the original invite as well 
because of concern that the caller is broken, there is again no 
obviously appropriate status to use. I think I might use 487 in that case.

	Paul

>>still not replied with an answer(either in 18X if reliable is used or
> 
> 200OK
> 
>>with SDP).
>>
>>
>>>A                   B
>>>----INVITEOffer1---->