Subject: [Sip] Diversion Header Question

From: "Manjeet Soodan" <[email-masked]>
Date: Thu, 1 Dec 2005 21:22:25 +0530

Hi,

Below is the scenario i am trying in case of Voice Mail :-

1) A,B,C are MGCP subscribers.
2) B has CFNA to C, C has CFNA to Voice Mail server(over SIP).
3) A calls B, B doesn't Answer and Call gets forwarded to C, C remains
OnHook and Call gets diverted to the Voice Mail server over SIP.

A INVITE message goes to the Voice Mail Server with a Diversion header
containing B's Number. But i think the Diversion header should contain C's
number because it's
C from where the Call finally got diverted to the Voice Mail server. Am i
right?

Thanks,
-Manjeet

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Manish Joshi <[email-masked]>
Date: Thu, 1 Dec 2005 15:37:02 -0800 (PST)

Actually in this case it should contain two Diversion Headers since there are two hops involved. The lower one should contain B's number and upper one should contain C's.
   
  B is actually an Original Called Number. I guess if only one Diversion Header is present, its more of an implementation option regarding which Hope information should be present.

  -Manish
  
Manjeet Soodan <[email-masked]> wrote:
  Hi,

Thanks,
-Manjeet

		
---------------------------------
 Yahoo! Personals
 Single? There's someone we'd like you to meet.
 Lots of someones, actually. Yahoo! Personals