Subject: [Sip] [Sip-implementors] 'User' syntax clarification

From: "Anil Bollineni" <[email-masked]>
Date: Wed, 28 Dec 2005 16:59:36 -0800

Hi,

            According to RFC 3261 19.1.1

     "The set of valid telephone-subscriber strings is a subset of valid
user strings."

     Since the 'user' info part of SIP URL does not cover "#" symbol
according rfc 3261 syntax for 'user'.

According to RFC 2806, the syntax for telephone-subscriber is

telephone-subscriber= 1*dtmf-digit

dtmf-digit            = "*" / "#" / "A" / "B" / "C" / "D"

How can telephone-subscriber string is a subset of valid user string? 

Can you please help to resolve the above statement?

Thanks & Regards,

Anil

_______________________________________________
Sip-implementors mailing list
[email-masked]
https://lists.cs.columbia.edu/cucslists/listinfo/sip-implementors

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Mahesh Govind <[email-masked]>
Date: Thu, 29 Dec 2005 10:40:28 +0900

HI,
The following link may  help you.
http://www.mail-archive.com/[email-masked]/msg02405.html
With regards
Mahesh

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Anil
Bollineni
Sent: Thursday, December 29, 2005 10:00 AM
To: Anil Bollineni; [email-masked]
Subject: [Sip] [Sip-implementors] 'User' syntax clarification

Hi,

 

Thanks & Regards,

Anil