Subject: [Sip] Re: Info required for transporting LK (Location Key)

From: "James M. Polk" <[email-masked]>
Date: Wed, 07 Dec 2005 17:28:21 -0600

Monica

I've changed WG lists here because this document moved from the SIPPING WG 
to the SIP WG last winter. The current document is here:
http://www.ietf.org/internet-drafts/draft-ietf-sip-location-conveyance-01.txt

and it does not support a location key, per se.

It proposes conveyance of:

#1 - Location-by-value (the PIDF-LO message body in the message), and

#2 - Location-by-Reference (a URI to a record on a server that has the 
PIDF-LO for that UA)

The next version of the document will not be published until at least 
January 06.

We have a goal of having this document ready (i.e. done) for IESG review by 
May 06.

At 06:03 PM 12/7/2005 -0500, [email-masked] wrote:
>All,
>
>NENA refers to draft-ietf-sipping-location-requirements-02 for 
>transporting the location or location key. This draft seems to refer 
>details on LO. This draft seems to have expired on 25th October 2004. 
>Please refer me to the latest document available. I am interested in 
>transporting LK (Location Key). Is there any specific header or tag 
>defined to carry LK ? Any pointers to this question will be helpful.
>
>- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - 
>- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
>Thanks & Regards
>Monica Ingudam

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Winterbottom, James" <[email-masked]>
Date: Wed, 7 Dec 2005 17:33:55 -0600

Just to be clear.
A location-Key (LK) as described in the NENA i2 specification is a
location-by-reference.

Cheers
James

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> James M. Polk
> Sent: Thursday, 8 December 2005 10:28 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [Sip] Re: Info required for transporting LK (Location Key)
> 
> Monica
> 
http://www.ietf.org/internet-drafts/draft-ietf-sip-location-conveyance-
> 01.txt
> We have a goal of having this document ready (i.e. done) for IESG
review
> by

------------------------------------------------------------------------------------------------
This message is for the designated recipient only and may
contain privileged, proprietary, or otherwise private information.  
If you have received it in error, please notify the sender
immediately and delete the original.  Any unauthorized use of
this email is prohibited.
------------------------------------------------------------------------------------------------
[mf2]

---

From: "James M. Polk" <[email-masked]>
Date: Wed, 07 Dec 2005 17:48:59 -0600

>A location-Key (LK) as described in the NENA i2 specification is a

that's why I said "per se", as the LK wasn't always described as a URI, but 
of a sequence or string instead.  A URI has a known-to-many base structure.