Subject: Re: [Sip] Re: [Enum] SIP AoR, tel and ENUM - Second Try

From: "Stastny Richard" <[email-masked]>
Date: Fri, 9 Dec 2005 20:03:08 +0100

Paul,
 
of course in all cases I mentioned a tel: URI could
(should?) be used.
 
I made the examples with the sip URI 

1. to show how it works with sip URI containing
tel Uris to make the point
 
2. because this seems to be the currently used method,
because most UA and also most SIP proxys do not
interpret tel URI (I have no reason why)
 
Richard

________________________________

Von: Paul Kyzivat [mailto:[email-masked]]
Gesendet: Fr 09.12.2005 19:43
An: Stastny Richard
Cc: Dale R. Worley; Sip
Betreff: Re: [Sip] Re: [Enum] SIP AoR, tel and ENUM - Second Try

Stastny Richard wrote:
> My take on this:
> 
> A user enters a phone number, the UA sends it by default
> to his provider A with
> sip:[email-masked];user=phone

The key here is that the phone is *creating* a uri in this domain. To do
so it must be considered part of the domain in order to interpret the
user part of the uri. It then sends it to a server that is also
permitted to interpret the user part.

It *could* also just use tel:+4312345. In that case anybody can
interpret the number because its meaning is defined by a standard.

> proxy A of Provider A interprets this as an E.164 number and
> does whatever he is programmed to do with this:
> 
> 1. forward it to his own gateway sip:[email-masked];user=phone
> 2. forward it to another proxy with a gateway sip:[email-masked];user=phone

In other words, if it wants to pass this to another domain using the sip
form, and wants the other domain to interpret it as a phone number, then
it needs to rewrite the URI to a form that the receiving network uses to
represent phone numbers. Knowing if/how/when this can be done requires
some kind of agreement (implicit or explicit) between the source network
and the destination network.

Again, this *could* also be done by rewriting as a tel uri before
passing to the other network.

        Paul

> 3. query ENUM
> in this case he may either get back sip:[email-masked]
> or
> sip:[email-masked];user=phone
> or
> sip:[email-masked];user=phone
> 
> Richard
>
> ________________________________
>
> Von: [email-masked] im Auftrag von Dale R. Worley
> Gesendet: Fr 09.12.2005 16:51
> An: Sip
> Betreff: Re: [Sip] Re: [Enum] SIP AoR, tel and ENUM - Second Try
>
>
>
> On Fri, 2005-12-09 at 10:28 -0500, Paul Kyzivat wrote:
>
>>>if UA is to send a request to sip:[email-masked], it MUST send it to
>>>provA.com.  in case of sip:[email-masked];user=phone, it can (and
>>>usually MUST) send it wherever it is sending requests to e.164 numbers,
>>>i.e., where it would send tel:+4312345, because the UA may not have any
>>>deal to use provA.com as its outbound proxy.
>>
>>I disagree with you Juha. AFAIK the routing of *either* form MUST be
>>routed solely based on the provA.com domain. Unless you are responsible
>>for the domain in question you are not to interpret the user part in any
>>way. There is no dispensation to violate this when the user=phone
>>parameter is present.
>
>
> RFC 3273 seems to me to come down very strongly in favor of Paul's
> position.  The only escape would be a later RFC that specifically
> authorized an agent that is not authoritative for provA.com to interpret
> the URI differently.
>
> Dale
>
>
>
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip
>
>
>
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip
>

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Paul Kyzivat <[email-masked]>
Date: Mon, 12 Dec 2005 09:07:16 -0500

> interpret tel URI (I have no reason why)

OK. Understood. And I agree that what you proposed can work. But when 
doing the rewriting at the border between domains, it is necessary for 
the sender to know the conventions of the receiver regarding the 
representation of phone numbers in sip uris. Really this is true in all 
cases, but it would be easier if everybody agreed on the same form (the 
tel uri) for representation of phone numbers.

	Paul