Subject: [Sip] Jabber VoIP specs

From: [email-masked]
Date: Fri, 16 Dec 2005 15:10:38 -0600

For those that may not have seen this, the Jabber Foundation has published their VoIP signaling and media encoding specs.  These specs have been reconciled with Google Talk if I read the introductory comments correctly.  I'd be interested in any discussion of the design of these protocols by the SIP gurus here...

http://www.jabber.org/jeps/jep-0166.html
http://www.jabber.org/jeps/jep-0167.html

FM

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Dan Wing" <[email-masked]>
Date: Thu, 22 Dec 2005 18:10:40 -0800

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of [email-masked]
> Sent: Friday, December 16, 2005 1:11 PM
> To: [email-masked]
> Subject: [Sip] Jabber VoIP specs
> 
> 
> For those that may not have seen this, the Jabber Foundation 
> has published their VoIP signaling and media encoding specs.  
> These specs have been reconciled with Google Talk if I read 
> the introductory comments correctly.  I'd be interested in 
> any discussion of the design of these protocols by the SIP 
> gurus here...

Thanks for mentioning the specifications.

> http://www.jabber.org/jeps/jep-0166.html

This specification describes a 'dribble' mode and a 'burst'
mode to exchange endpoint candidate addresses.  Only 
'burst' mode is compatible with ICE (draft-ietf-mmusic-ice).

Section 6.5.2 says that both modes are only SHOULDs.

If we want to have compatibility with Jingle, they'll have 
to make 'burst' mode a MUST.

-d

---

From: Dean Willis <[email-masked]>
Date: Sat, 24 Dec 2005 21:44:10 -0600

If I'm reading this right, interworking between SIP and Jabber using   
ICE is going to require "burst" mode in the Jabber implementations  
every time. Without it, interworking failure appears to be very likely.

This is a good point. Anybody here working on the jingle stuff and  
can get a change made? Rohan?
--
Dean