Subject: RE: [Sip] [SIP Cacel Method]

From: Kapil Nayar <[email-masked]>
Date: Thu, 1 Dec 2005 22:40:15 +0000 (GMT)

Hi

I guess you are confusing the timerB with timerA - 
timerB(64xT1) is the transaction timeout timer started
to receive the final response to INVITE. If it
expires, the UAC should consider the transaction
cancelled and may destroy the local context. While
some implementations would like to send CANCEL just to
make sure the INVITE is indeed cancelled.

The situation may occur in case where the UAC sent the
CANCEL on timeout and also destroyed the local context
(though this shouldn't occur in normal circumstances).
The 200OK to CANCEL completes the CANCEL transaction.
However, the 487 response (from UAS) to INVITE (which
doesnot exist at UAC) would result in retransmissions
from the UAS.

Well I guess upon timerH timeout on UAS the 487
response retransmissions should stop.

Let me know if I missed something here....

thanks,
-kapil nayar  

--- "Prakash  Maria susai  - NPD, Chennai"
<[email-masked]> wrote:

> Hi,
>  
> As Sreeram has mentioned, it cannot be Timer B,
> since Timer B is not active
> once 1xx is got.
> The some other timer could be a Timer started
> through Expires Header
> indicated in INVITE request.
>  
> Thanks,
> Prakash.
> 
> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of
> [email-masked]
> Sent: Wednesday, November 30, 2005 1:04 PM
> To: [email-masked]; [email-masked]
> Subject: RE: [Sip] [SIP Cacel Method]
> 
> 
> Yes you must generate ACK in second case also.
>  
> also, in case2) it is not "timerb timeout" as the
> caller received
> provisional response its state machine goes to
> "proceeding state"
> It should be some other timer implemented  at the
> uac to handle the case
> when there is no final response in the "proceeding
> state"    
>  
> HTH,
> Sreeram.
> 
>   _____  
> 
> From: [email-masked]
> [mailto:[email-masked]] On Behalf Of Chen
> Shuping
> Sent: Wednesday, November 30, 2005 11:50 AM
> To: [email-masked]
> Subject: [Sip] [SIP Cacel Method]
> 
> 
> Hi,All
>  
>   I have such a doubt:
>  
>    In RFC 3261 17.1.1.2  Time_B timeout in Calling
> state,Invite transaction
> transit to terminated
>  
> state,What if Timer_B timeout in Proceeding 
> state(this could happen when
> the callee is not in office,
>  
> his softphone keep ringring until caller's timer_b
> timeout).
>  
> In my implementation my call flow like this:
>  
> CASE 1:
>  
> caller                                         
> callee
> ------------INVITE------------------->
> <-----------100 Trying-----------------
> <-----------180 Ringing--------------
>  
> caller hang up
>  
> --------------Cancel----------------->
> <-------------200 for Cancel--------
> <-------------487----------------------
> ---------------ACK------------------>
>  
> CASE 2:
>  
> INVITE-------------------> 
> <-----------100 Trying-----------------
> <-----------180 Ringing--------------
>  
> caller keep waiting ,Timer_b time out
>  
> --------------Cancel----------------->
> <-------------200 for Cancel--------
> <-------------487----------------------
> 
> <-------------487----------------------
> 
> <-------------487----------------------
> 
> <-------------487----------------------
> 
> <-------------487----------------------
>  
> My question is should I generate ACK for the second
> case.
>  
>  
> Thanks
>  
>  
>  
>  
> 
> 
> Disclaimer:
> 
> This message and any attachment(s) contained here
> are information that is confidential, proprietary to
> HCL Technologies and its customers, privileged or
> otherwise protected by law. The information is
> solely intended for the individual or the entity it
> is addressed to. If you are not the intended
> recipient of this message, you are not authorized to
> read, forward, print, retain, copy or disseminate
> this message or any part of it. If you have received
> this e-mail in error, please notify the sender
> immediately by return e-mail and delete it from your
> computer.
> > _______________________________________________
> Sip mailing list 
> https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP
> Protocol
> Use [email-masked] for questions
> on current sip
> Use [email-masked] for new developments on the
> application of sip

___________________________________________________________ 
Yahoo! Messenger - NEW crystal clear PC to PC calling worldwide with voicemail http://uk.messenger.yahoo.com

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Chen Shuping <[email-masked]>
Date: Fri, 02 Dec 2005 09:26:20 +0800

--inline 

-----邮件原件-----
发件人: Kapil Nayar [mailto:[email-masked]] 
发送时间: 2005年12月2日 6:40
收件人: Prakash Maria susai - NPD, Chennai; [email-masked];
[email-masked]; [email-masked]
主题: RE: [Sip] [SIP Cacel Method]

Hi

I guess you are confusing the timerB with timerA -
timerB(64xT1) is the transaction timeout timer started to receive the final
response to INVITE. If it expires, the UAC should consider the transaction
cancelled and may destroy the local context. While some implementations
would like to send CANCEL just to make sure the INVITE is indeed cancelled.

The situation may occur in case where the UAC sent the CANCEL on timeout and
also destroyed the local context (though this shouldn't occur in normal
circumstances).
The 200OK to CANCEL completes the CANCEL transaction.
However, the 487 response (from UAS) to INVITE (which doesnot exist at UAC)
would result in retransmissions from the UAS.

--It is excacly my case,I use Timer_B as Invitie Transaction Timer_B,When
Timer_B fires,if no final response arrived,I
--send cancel to confirm the transaction cacelation.
--Thank all of you,Now,I introduce a session timer to proect call time
out,And Keep timer_b a sip stack layer to
--keep a call manager from error or wrong implementation.

--Thank you

Well I guess upon timerH timeout on UAS the 487 response retransmissions
should stop.

thanks,
-kapil nayar  

--- "Prakash  Maria susai  - NPD, Chennai"
<[email-masked]> wrote:

> Hi,
>  
> As Sreeram has mentioned, it cannot be Timer B, since Timer B is not 
> active once 1xx is got.
> The some other timer could be a Timer started through Expires Header 
> [mailto:[email-masked]]On Behalf Of [email-masked]
> also, in case2) it is not "timerb timeout" as the caller received 
> provisional response its state machine goes to "proceeding state"
> It should be some other timer implemented  at the uac to handle the 
> case when there is no final response in the "proceeding
> state"    
>  
> HTH,
> Sreeram.
> 
>   _____
> 
> [mailto:[email-masked]] On Behalf Of Chen Shuping
>    In RFC 3261 17.1.1.2  Time_B timeout in Calling state,Invite 
> transaction transit to terminated
>  
> state,What if Timer_B timeout in Proceeding state(this could happen 
> when the callee is not in office,
>  
> his softphone keep ringring until caller's timer_b timeout).
>  
> <-----------100 Trying----------------- <-----------180 
> Ringing--------------
>  
> caller hang up
>  
> <-----------100 Trying----------------- <-----------180 
> Ringing--------------
>  
> My question is should I generate ACK for the second case.
>  
>  
> Thanks
>  
>  
>  
>  
> 
> 
> Disclaimer:
> 
> This message and any attachment(s) contained here are information that 
> is confidential, proprietary to HCL Technologies and its customers, 
> privileged or otherwise protected by law. The information is solely 
> intended for the individual or the entity it is addressed to. If you 
> are not the intended recipient of this message, you are not authorized 
> to read, forward, print, retain, copy or disseminate this message or 
> any part of it. If you have received this e-mail in error, please 
> notify the sender immediately by return e-mail and delete it from your 
> computer.
> This list is for NEW development of the core SIP Protocol Use 
> [email-masked] for questions on current sip Use 
> [email-masked] for new developments on the application of sip

___________________________________________________________
Yahoo! Messenger - NEW crystal clear PC to PC calling worldwide with
voicemail http://uk.messenger.yahoo.com