Subject: [Sip] INVITE request after 302 response

From: "zhangwei" <[email-masked]>
Date: Fri, 16 Jun 2006 11:35:31 +0800

Hi,

   In SIP, 302 Moved Temporarily can be used by User Agent to set call forwarding. When the caller received 302, it should re-create a new INVITE request to forward call to a given contact.

   My question is how Proxy Server detect whether INVITE is created after having received 302 response. The Proxy Server is transaction stateful. What's the difference between INVITE after 302 and the normal INVITE ? 

Regards
Zhang Wei

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Paul Kyzivat <[email-masked]>
Date: Sat, 17 Jun 2006 16:37:27 -0400

>    My question is how Proxy Server detect whether INVITE is created after having received 302 response. The Proxy Server is transaction stateful. What's the difference between INVITE after 302 and…

In general there is no way to detect this. And in general there is no
reason why the proxy should need to detect it.

Of course in certain network architectures the proxy may want to detect
this - to coordinat billing actions perhaps. To do so without
maintaining state in the proxy will require some creativity. E.g. the
contact address in the 302 might be modified in some way to facilitate this.

	Paul

> Regards
> Zhang Wei
> 
> 
> ------------------------------------------------------------------------
>