Subject: [Sip] privacy header format - RFC 3323

From: venugopal iyer <[email-masked]>
Date: Wed, 24 May 2006 12:49:37 -0700 (PDT)

Am looking for some clarification about the definition  of Privacy-hdr
(from RFC 3323):

    Privacy-hdr  =  "Privacy" HCOLON priv-value *(";" priv-value)
    priv-value   =   "header" / "session" / "user" / "none" / "critical"
                     / token

I am not clear about ";" above given the header defns in RFC 3261.  I would
have thought it should be a COMMA. I maybe missing something.

I did come across a mail that specifically talks about this:
(http://www.atm.tut.fi/list-archive/sip/msg05124.html)

"
> Privacy-hdr  =  "Privacy" HCOLON priv-value *(COMMA priv-value)
>    priv-value   =   "header" | "session" | "user" | "none" | "critical" | token

I would strongly advise that you also allow for semi-colon separated
parameters for the purposes of future extensibility.

Also, you need to use slashes "/" to separate or-values, not vertical
bars "|".
"

but am not sure the comment actually resulted in the change from COMMA to
SEMI.

thanks,

-venu

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Attila Sipos" <[email-masked]>
Date: Wed, 7 Jun 2006 15:23:00 +0100

Hi Venu,

Your mentioned mail is referring to
the draft version (draft-ietf-sip-privacy-general)
of something that became RFC3323.

Since it is only a draft and RFC3323 is newer and it's
an approved RFC, then you should ditch the draft and
use the RFC (which uses ";").

Regards,
Attila

Attila Sipos
http://www.vegastream.com

>> -----Original Message-----
>> From: venugopal iyer [mailto:[email-masked]]
>> Sent: 24 May 2006 20:50
>> To: [email-masked]
>> Subject: [Sip] privacy header format - RFC 3323
>> 
>> 
>> 
>>