Subject: AW: [Sip] updated GRUU spec

From: "Lu, Yang, VF-DE" <[email-masked]>
Date: Mon, 26 Jun 2006 09:56:50 +0200

Is it a correct understanding that when a UA applies gruu extension to any requests including the REGISTER request, it DOES NOT need to use the Proxy-Require header field to insist that any proxies that are traversed understand gruu? 

Best Regards
          Yang  @ Vodafone    

-----Ursprüngliche Nachricht-----
Von: Jonathan Rosenberg [mailto:[email-masked]] 
Gesendet: Freitag, 23. Juni 2006 17:24
An: Dale R. Worley
Cc: [email-masked]
Betreff: Re: [Sip] updated GRUU spec

inline.

Dale R. Worley wrote:

>    From: "Jeroen van Bemmel" <[email-masked]>
> 
>    1) The protocol bits that trigger issueing of a GRUU are "Supported: gruu" 
>    and a sip.instance id in the Contact header. If "supported" then "MUST issue 
>    GRUU". If you compare this with e.g. 100rel it seems a bit odd, Supported: 
>    100rel does not force the server to use it. How about Supported -> SHOULD, 
>    Require -> MUST ? (could a domain have reasons not to honor the request for 
>    GRUUs?)
> 
> Actually, what triggers *constructing* a GRUU is (1) Registrar 
> implements GRUU, and (2) Contact contains +sip.instance.

Exactly.

> What
> triggers adding the gruu header-parameter in the response is (1) and
> (2) along with (3) "Supported: gruu" in the request (so the Registrar 
> knows that the UAC can cope with it).

Exactly.

> 
> (As I was reading the I-D, I wondered why the UAC could send
> +sip.instance without first discerning that the Registrar supported
> it, but the Registrar could not send gruu without first discerning 
> that the UAC supported it.  But I think that's because +sip.instance 
> is identifiable as a caller preference, and there is a defined way for 
> UASs to deal with a caller preference it does not understand.)

There is no need for the client to discover registrar support for gruu prior to registration, because there is no harm in including 
+sip.instance even if the registrar doesnt support it. Indeed, if ALL
the registrar/proxy supports is rfc3841, then +sip.instance is still usable with that (though not terribly valuable).

> 
> So if a UA wants to get a GRUU when it can, but not get its 
> registration rejected if it cannot, it uses Supported: gruu and
> +sip.instance.

Right, and this is what it normally ought to do.

>  If the Registrar implements gruu, it MUST send a gruu in response.  
> But if a UA wants to make sure it gets a GRUU (and gets its REGISTER 
> rejected with 420 if it cannot), it uses Supported: gruu,
> Require: gruu, and +sip.instance.

Only caveat is that require just makes sure the registrar supports gruu; it doesn't FORCE the proxy to hand you out a gruu. Policy may, for some reason, still tell it not to hand you a gruu since you've been a bad boy this year.

-Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.                   600 Lanidex Plaza
Cisco Fellow                                   Parsippany, NJ 07054-2711
Cisco Systems
[email-masked]                              FAX:   (973) 952-5050
http://www.jdrosen.net                         PHONE: (973) 952-5000
http://www.cisco.com

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol Use [email-masked] for questions on current sip Use [email-masked] for new developments on the application of sip

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: [email-masked]
Date: Mon, 26 Jun 2006 14:53:18 -0400

From: "Lu, Yang, VF-DE" <[email-masked]>

   Is it a correct understanding that when a UA applies gruu extension
   to any requests including the REGISTER request, it DOES NOT need to
   use the Proxy-Require header field to insist that any proxies that
   are traversed understand gruu? 

Yes, that is correct.  Only the Registrar (the UAC of the REGISTER
request) needs to understand the gruu extension.

Of course, any proxy that is allowed to translate the GRUU URI to its
contact URI must understand the special rules for doing so, but the
fact that the corresponding Registrar issues GRUUs is evidence that
the proxy can do so.

Dale

---

From: Jonathan Rosenberg <[email-masked]>
Date: Mon, 26 Jun 2006 20:47:46 -0400

Dale is, of course, correct here. Proxy-Require is not needed with GRUU.

Thanks,
Jonathan R.