Subject: RE: [Sip] What to do with SIP SAML draft

From: "Peterson, Jon" <[email-masked]>
Date: Wed, 7 Jun 2006 16:32:18 -0400

Didn't we already have a mailing list "hum" to adopt this as a WG item on 3/26/06? Was that deemed inconclusive by the chairs?

Jon Peterson
NeuStar, Inc.

> -----Original Message-----
> From: Dean Willis [mailto:[email-masked]]
> Sent: Tuesday, June 06, 2006 10:56 AM
> To: Sip IETF
> Subject: [Sip] What to do with SIP SAML draft
> 
> 
> 
> Our current charter and slightly-stale milestones include a  
> deliverable for SAML:
> 
> Jul 2006 -- Using SAML for SIP (PS)
> 
> 
> At the IETF 65, we discussed the Tschofenig draft, currently  
> available as:
> 
> http://www.ietf.org/internet-drafts/draft-tschofenig-sip-saml-05.txt
> 
> We didn't have a firm consensus in the room for what to do 
> with this,  
> so It'd like to discuss it now.
> 
> 
> Our options include:
> 
> 1) Adopt this draft as a WG document and keep working on it.
> 
> 2) Decide we don't need to solve the problem just yet and 
> abandon the  
> milestone.
> 
> 3) Let Hannes and team keep working on it until we decide it has  
> reached critical mass, and keep slipping the milestone along.
> 
> 4) Do something entirely different.
> 
> 
> So, what do you people think?
> 
> --
> Dean
> 
> 
> 
> 
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip
> 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Dean Willis <[email-masked]>
Date: Wed, 07 Jun 2006 21:47:58 -0500

> Didn't we already have a mailing list "hum" to adopt this as a WG item on 3/26/06? Was that deemed inconclusive by the chairs?

Indeed we did, and the 7 or 8 people who responded were all in favor of 
adopting the draft. Of course, it's 3 months later now, and the status 
of the draft hasn't changed a lot (so at the least there's a scheduling 
issue to resolve), and there's more than 7 or 8 people in the working group.

Consider it a recheck for my sanity, which is questionable at best.

--
Dean

---

From: "James M. Polk" <[email-masked]>
Date: Wed, 07 Jun 2006 22:07:30 -0500

At 09:47 PM 6/7/2006 -0500, Dean Willis wrote:
>Peterson, Jon wrote:
>>Didn't we already have a mailing list "hum" to adopt this as a WG item on 
>>3/26/06? Was that deemed inconclusive by the chairs?
>
>adopting the draft. Of course, it's 3 months later now, and the status of 
>the draft hasn't changed a lot (so at the least there's a scheduling issue 
>to resolve), and there's more than 7 or 8 people in the working group.
>

Does this mean our next version of the ID (what was 
draft-tschofenig-sip-saml-05.txt) should now be

         draft-ietf-sip-saml-00.txt

?

If so,

#1 - we need to submit it a week earlier than planned
and
#2 - The WG chairs need to submit a message to the Secretariat that this 
draft-sip-...-00 is coming

---

From: Dean Willis <[email-masked]>
Date: Thu, 8 Jun 2006 15:35:08 -0500

On Jun 7, 2006, at 10:07 PM, James M. Polk wrote:

>>> Didn't we already have a mailing list "hum" to adopt this as a WG  
>>> item on 3/26/06? Was that deemed inconclusive by the chairs?
>>
>> Indeed we did, and the 7 or 8 people who responded were all in  
>> favor of adopting the draft. Of course, it's 3 months later now,  
>> and the status of the draft hasn't changed a lot (so at the least  
>> there's a scheduling issue to resolve), and there's more than 7 or  
>> 8 people in the working group.
>>
> Does this mean our next version of the ID (what was draft- 
> tschofenig-sip-saml-05.txt) should now be
>
> #2 - The WG chairs need to submit a message to the Secretariat that  
> this draft-sip-...-00 is coming
>

That was sort of at the root of the question -- I asked if anybody  
was planning to submit a new -00 draft before cutoff so I could pre- 
approve, and I didn't hear much back.

The current response set (also small) still supports adopting the  
draft. The AD response seem to indicate support for that position.  
I've heard no objections and only one suggestion that as postponement  
might be appropriate, so I'd say we maintain a consensus to adopt,  
but need to push our delivery milestone out to something like WGLC in  
November and IESG review in January 2007. Please provide feedback on  
those dates.

Personally, I don't suppose that it matters much which title you use  
in the next rev, so long as we meet the scheduling and approval  
constraints appropriate to the title. We can always retitle at the  
next rev.

--
Dean

---

From: "James M. Polk" <[email-masked]>
Date: Thu, 08 Jun 2006 16:00:09 -0500

Dean

Thanks

I'll suggest this title to my co-authors:

I agree more needs to be done here

---

From: Cullen Jennings <[email-masked]>
Date: Fri, 9 Jun 2006 20:53:19 -0700

On Jun 8, 2006, at 1:35 PM, Dean Willis wrote:

>  The AD response seem to indicate support for that position.

I was pretty vague and have no objections either way. I would guess  
we will adopt this sooner or later. I am not keen on a "trash this  
and do something totally different path" but I don't think anyone has  
been keen on that.