Subject: RE: [Sip] I-D ACTION:draft-ietf-sip-outbound-04.txt

From: "Christer Holmberg \(JO/LMF\)" <[email-masked]>
Date: Fri, 30 Jun 2006 11:00:41 +0200

Hi Jeroen,

I agree with most of what you say.

Also, I agree that by inserting keepalive=stun in the Path header the edge proxy can indicate that it supports STUN (I proposed that also myself), and the client can find out about the support by looking at the Path header.

BUT, you then propose text talking about sending STUN "towards this URI". Now, I think it is important to remember that the client is not going to use the Path header(s) to route anything - at least not SIP requests. The Path is used by the REGISTRAR for routing requests towards the client - not the other way around. Or, am I wrong?

So, yes, the client can look at the Path header to find out whether the edge proxy supports STUN, but the Path header is not used for routing SIP requests towards the edge proxy (eventhough the URI value of the pre-inserted Route pointing towards the edge proxy, and the URI inserted in the Path by the edge proxy itself, may of course be the same).

If we were using the Service-Route header the situation would be a little different.

Regards,

Christer

-----Original Message-----
From: Jeroen van Bemmel [mailto:[email-masked]] 
Sent: 30. kesäkuuta 2006 1:28
To: [email-masked]
Subject: Re: [Sip] I-D ACTION:draft-ietf-sip-outbound-04.txt 

We've had some VERY long and extensive discussions on this (starting with
http://www1.ietf.org/mail-archive/web/sip/current/msg13677.html) but the draft is still not addressing some of the issues that were raised

1) The UAC needs a positive indication that the selected proxy can indeed handle STUN packets without choking on them. It is not sufficient if the URI it is configured with says 'keepalive=stun', that's a wish but no guarantee.

A simple way to do this is to have the edge proxy that receives a REGISTER with its own address and 'keepalive=stun' in the topmost Route header mirror that parameter in the Path header it MUST insert (according to 5.1).

There could be an issue in case systems exist that simply copy verbatim what is in the Route header URI into their Path header URI. To avoid this scenario, perhaps a header parameter (instead of an URI parameter) would be an idea.

The text should then say "the UAC MUST wait for a 200 OK to REGISTER before it starts sending STUN packets. If the last Path header of the 200 OK does not contain keepalive=stun, the UAC MUST NOT use STUN towards this URI. If there are no Path headers and no "Supported: outbound", the UAC also MUST NOT use STUN towards the registrar.". It could still use TCP keepalive if it supports that

2) Section 5.3: the Edge Proxy MUST Record-Route dialog forming INVITE requests that it forwards over the flow towards the UA (reverse direction is not strictly necessary, but probably common too). If it does not do this, an ACK for 2xx cannot arrive. For incoming SUBSCRIBE it might work without (the NOTIFY could create a direct flow towards the target or some other proxy, using the local socket as a Contact), but then there would be an issue with keeping that flow alive (the STUN question). Probably safer to say that (in addition to MUST for INVITE) "the Edge Proxy SHOULD Record-Route all dialog-forming requests it forwards to the UA"

3) The Proxy-Require mechanism we have discussed could be useful to UACs that want to ensure that a selected edge proxy supports outbound, aborting if not.

4) (minor remark) Perhaps some words could be added that the UAC SHOULD perform keepalives when configured to do so, even if it detects that there is no NAT. There could be a transparent firewall device that needs to be kept open.

Regards,

Jeroen

----- Original Message -----
From: <[email-masked]>
To: <[email-masked]>
Cc: <[email-masked]>
Sent: Wednesday, June 28, 2006 12:50 AM
Subject: [Sip] I-D ACTION:draft-ietf-sip-outbound-04.txt

>A New Internet-Draft is available from the on-line Internet-Drafts 
>directories.
> This draft is a work item of the Session Initiation Protocol Working Group 
> of the IETF.
>
> Title : Managing Client Initiated Connections in the
>                          Session Initiation Protocol (SIP)
> Author(s) : C. Jennings, R. Mahy
> Filename : draft-ietf-sip-outbound-04.txt
> Pages : 34
> Date : 2006-6-27
>
> The Session Initiation Protocol (SIP) allows proxy servers to
>   initiate TCP connections and send asynchronous UDP datagrams to User
>   Agents in order to deliver requests.  However, many practical
>   considerations, such as the existence of firewalls and Network
>   Address Translators (NATs), prevent servers from connecting to User
>   Agents in this way.  This specification defines behaviors for User
>   Agents, registrars and proxy servers that allow requests to be
>   delivered on existing connections established by the User Agent.  It
>   also defines keep alive behaviors needed to keep NAT bindings open
>   and specifies the usage of multiple connections.
>
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-ietf-sip-outbound-04.txt
>
> To remove yourself from the I-D Announcement list, send a message to
> [email-masked] with the word unsubscribe in the body of the 
> message.
> You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce
> to change your subscription settings.
>
>
> Internet-Drafts are also available by anonymous FTP. Login with the 
> username
> "anonymous" and a password of your e-mail address. After logging in,
> type "cd internet-drafts" and then
> "get draft-ietf-sip-outbound-04.txt".
>
> A list of Internet-Drafts directories can be found in
> http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>
>
> Internet-Drafts can also be obtained by e-mail.
>
> Send a message to:
> [email-masked].
> In the body type:
> "FILE /internet-drafts/draft-ietf-sip-outbound-04.txt".
>
> NOTE: The mail server at ietf.org can return the document in
> MIME-encoded form by using the "mpack" utility.  To use this
> feature, insert the command "ENCODING mime" before the "FILE"
> command.  To decode the response(s), you will need "munpack" or
> a MIME-compliant mail reader.  Different MIME-compliant mail readers
> exhibit different behavior, especially when dealing with
> "multipart" MIME messages (i.e. documents which have been split
> up into multiple messages), so check your local documentation on
> how to manipulate these messages.
>
>
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.
>

--------------------------------------------------------------------------------

> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Jeroen Van Bemmel <[email-masked]>
Date: Fri, 30 Jun 2006 11:45:19 +0200

Hi Christer,

Yes, 'this URI' should be interpreted as the URI that the UAC used in its Route header, and not the URI in the Path header

Regards,

jeroen 

-----Oorspronkelijk bericht -----
Van: "Christer Holmberg (JO/LMF)" <[email-masked]>
Aan: "Jeroen van Bemmel" <[email-masked]>; [email-masked]
Verzonden: 30-6-06 11:00
Onderwerp: RE: [Sip] I-D ACTION:draft-ietf-sip-outbound-04.txt 

Hi Jeroen,

Regards,

Christer

-----Original Message-----
From: Jeroen van Bemmel [mailto:[email-masked]] 
Sent: 30. kesäkuuta 2006 1:28
To: [email-masked]
Subject: Re: [Sip] I-D ACTION:draft-ietf-sip-outbound-04.txt 

Regards,

Jeroen