Subject: Re: [Sip] Re: INVITE request after 302 response

From: Rayees Khan <[email-masked]>
Date: Sun, 18 Jun 2006 21:43:38 +0530

Hi Mr Zhang,

As far as I understand the behaviour of UAs the normal procedure is that on receiving 302 response the UA would extract the information from contact of 302 and put it into request line of new INVITE. The INVITE that would be generated by UA as a result of this redirection would have UA3 in request line and UA2 in 'To' header. However, it is not mandatory, and UA can choose to change both.
One of the ways I can think of is to have some kind of intelligence in proxy to keep track of the 302 responses that are proxied. The INVITE generated form these UAs after 302 are most likely to be result of 302, though again there is no guarantee. Additionally, one more interesting point is that the From header is likely to be retained.

regards
Rayees

-----"zhangwei" <[email-masked]> wrote: -----

To: Sumit Dhar/BLR/HSS@HSS, <[email-masked]>, "Lei Weimin" <[email-masked]>
From: "zhangwei" <[email-masked]>
Date: 06/16/2006 03:04PM
Subject: [Sip] Re: INVITE request after 302 response

Hello Sumit,

Thanks for your response.

Take an example for the application.

UA1      Proxy
Server    UA2    UA3

|

|
|         |

|---INVITE--->|
|         |

|
|---
INVITE
--> |
|

|
|<----302 ------|         |

|<----302-------|
|
|

|

|
|
|

|-----ACK---->|
|         |

|
|---ACK------>|
|

|---INVITE--->|
|         |

|
|------------
INVITE
---->|

|
|<--100/180/200------|

|100/180/200|
|
|

|
|
|
|

|----ACK----->|
|         |

|
|--------------ACK----->|

Our project need to account according to
INVITE/200/ACK and BYE.

For the instance above, we want to make two
accountings. One is UA1 call UA2. The other is UA2 call UA3.

Our Proxy Server is transaction stateful. But we
want that Proxy Server can obtain UA1 UA2 and UA3's info only from the second
INVITE request.

How can my Proxy Server obtain UA2's info only
from the second INVITE request?

Thanks & Best regards

Zhang Wei

----- Original Message -----

From:

Sumit Dhar

To:

zhangwei

Sent:
Friday, June 16, 2006 7:08 PM

Subject:
Re: INVITE request after 302
response

Hello Mr Zhang,

Thanks for your mail.

I wasnt too sure however as to where you
got my contacts from. I have anyways organized a response for your question
which is enclosed in my mail.

May
I request to know more details about the project you are working on, and if we
can possible collaborate .

Thanks
& Best Regards,

Sumit

Response>

A typical 3261 compliant transaction stateful proxy
would not be able to distinguish if an INVITE is an initial INVITE sent by a
UA

OR was sent subsequent to the
reception of a 302 response. Also, a transatcion stateful proxy need not know
it.

An exception however is when a
proxy is capable to performing recursion. In this case, the proxy would
interpret the 302 response

by itself
and send a new INVITE to the redirected contact address.

If however, there is a need to
know that an INVITE was redirected, one option is to check the cseq
number..

RFC 3261 recommends that the
UA uses the same call-id, from-tag, to-tag etc and just increment the cseq
number for

a new INVITE towards the
redirected address. However, this is just a recommendation and may not be
adhered to by the UA.

--------------------------------------------------------
Sumit
Dhar
Segment
Manager,
Service Provider Products Business,
Flextronics
Software Systems
(Formerly Hughes Software Systems)
No. 18,
Outer Ring Road, Panathur Post,
Bangalore -560 087,  India

Phone  :
+91-80-4106 7138  Fax     : +91-80-4126 6501

visit us at http://www.flextronicssoftware.com

"zhangwei"
<[email-masked]>

06/16/2006 01:11 PM

To

Sumit
Dhar/BLR/HSS@HSS

cc

Subject

INVITE request after
302 response

Hi,

In SIP, 302
Moved Temporarily can be used by User Agent to set call forwarding. When the
caller received 302, it should re-create a new INVITE request to forward call
to a given contact.

My question is how Proxy Server
detect whether INVITE is created after having received 302 response. The Proxy
Server is transaction stateful. What's the difference between INVITE after 302
and the normal INVITE ?

Regards

Zhang Wei

***********************  FSS-
Confidential   ***********************

"DISCLAIMER: This message is proprietary to Flextronics Software Systems (FSS) and is intended solely for the use of
the individual to whom it is addressed. It may contain privileged or confidential information and should not be
circulated or used for any purpose other than for what it is intended. If you have received this message in error,
please notify the originator immediately. If you are not the intended recipient, you are notified that you are strictly
prohibited from using, copying, altering, or disclosing the contents of this message. FSS accepts no responsibility for
loss or damage arising from the use of the information transmitted by this email including damage from virus."

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

*****FSS-Private *****" DISCLAIMER: This message is proprietary to Flextronics Software Systems Limited (FSS) and is intended solely for the use of the individual to whom it is addressed. It may contain privileged or confidential information and should not be circulated or used for any purpose other than for what it is intended. If you have received this message in error, please notify the originator immediately. If you are not the intended recipient, you are notified that you are strictly prohibited from using, copying, altering, or disclosing the contents of this message. FSS accepts no responsibility for loss or damage arising from the use of the information transmitted by this email including damage from virus."

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Nataraju A B" <[email-masked]>
Date: Mon, 19 Jun 2006 11:49:10 +0530

Thanks & Regards,
Nataraju A.B.
-----Original Message-----
From: Rayees Khan [mailto:[email-masked]] 
Sent: Sunday, June 18, 2006 9:44 PM
To: zhangwei
Cc: [email-masked]; Sumit Dhar; Lei Weimin
Subject: Re: [Sip] Re: INVITE request after 302 response

Hi Mr Zhang, 

As far as I understand the behaviour of UAs the normal procedure is that
on receiving 302 response the UA would extract the information from
contact of 302 and put it into request line of new INVITE. The INVITE
that would be generated by UA as a result of this redirection would have
UA3 in request line and UA2 in 'To' header. However, it is not
mandatory, and UA can choose to change both. 
One of the ways I can think of is to have some kind of intelligence in
proxy to keep track of the 302 responses that are proxied. The INVITE
generated form these UAs after 302 are most likely to be result of 302,
though again there is no guarantee. Additionally, one more interesting
point is that the From header is likely to be retained.

[ABN] if the INVITE is generated because of 302, then the new INVITE
would have the same TO header which was there in the received request.
Otherwise this might lead to dialog match in the UAC once final response
received from UA3 by UAC (UA1). Only R-URI would be changed with the
contact address received in the 302 response. 

regards
Rayees

-----"zhangwei" <[email-masked]> wrote: -----
To: Sumit Dhar/BLR/HSS@HSS, <[email-masked]>, "Lei Weimin"
<[email-masked]>
From: "zhangwei" <[email-masked]>
Date: 06/16/2006 03:04PM
Subject: [Sip] Re: INVITE request after 302 response
Hello Sumit, 

  
UA1      Proxy Server    UA2    UA3 
|                  |                  |         | 
|---INVITE--->|                  |         | 
|                  |--- INVITE --> |         | 
|                  |<----302 ------|         | 
|<----302-------|                  |         | 
|                   |                  |         | 
|-----ACK---->|                  |         | 
|                  |---ACK------>|         | 
|---INVITE--->|                  |         | 
|                  |------------ INVITE ---->| 
|                  |<--100/180/200------| 
|100/180/200|                  |         | 
|                  |                  |         | 
|----ACK----->|                  |         | 
|                  |--------------ACK----->| 

Our project need to account according to INVITE/200/ACK and BYE.   
  
For the instance above, we want to make two accountings. One is UA1 call
UA2. The other is UA2 call UA3. 
  
Our Proxy Server is transaction stateful. But we want that Proxy Server
can obtain UA1 UA2 and UA3's info only from the second INVITE request. 
  
How can my Proxy Server obtain UA2's info only from the second INVITE
request?  

Thanks & Best regards 
  
Zhang Wei 
  
----- Original Message ----- 
From: Sumit Dhar  <mailto:[email-masked]> 
To: zhangwei  <mailto:[email-masked]> 
Sent: Friday, June 16, 2006 7:08 PM 
Subject: Re: INVITE request after 302 response 

Hello Mr Zhang, 

Thanks for your mail. 

I wasnt too sure however as to where you got my contacts from. I have
anyways organized a response for your question which is enclosed in my
mail. 

May I request to know more details about the project you are working on,
and if we can possible collaborate . 

Thanks & Best Regards, 

Sumit 

Response> 
A typical 3261 compliant transaction stateful proxy would not be able to
distinguish if an INVITE is an initial INVITE sent by a UA 
OR was sent subsequent to the reception of a 302 response. Also, a
transatcion stateful proxy need not know it. 
An exception however is when a proxy is capable to performing recursion.
In this case, the proxy would interpret the 302 response 
by itself and send a new INVITE to the redirected contact address. 

If however, there is a need to know that an INVITE was redirected, one
option is to check the cseq number.. 
RFC 3261 recommends that the UA uses the same call-id, from-tag, to-tag
etc and just increment the cseq number for 
a new INVITE towards the redirected address. However, this is just a
recommendation and may not be adhered to by the UA. 

--------------------------------------------------------
 Sumit Dhar           
 Segment Manager,
 Service Provider Products Business,
 Flextronics Software Systems
 (Formerly Hughes Software Systems)
 No. 18, Outer Ring Road, Panathur Post,
 Bangalore -560 087,  India               
 Phone  : +91-80-4106 7138  Fax     : +91-80-4126 6501   
 visit us at http://www.flextronicssoftware.com 

"zhangwei" <[email-masked]> 
06/16/2006 01:11 PM 

To 
Sumit Dhar/BLR/HSS@HSS 

cc 

Subject 
INVITE request after 302 response 

Hi, 
  
   In SIP, 302 Moved Temporarily can be used by User Agent to set call
forwarding. When the caller received 302, it should re-create a new
INVITE request to forward call to a given contact. 
  
   My question is how Proxy Server detect whether INVITE is created
after having received 302 response. The Proxy Server is transaction
stateful. What's the difference between INVITE after 302 and the normal
INVITE ? 

Regards 
Zhang Wei 

***********************  FSS- Confidential   *********************** 

"DISCLAIMER: This message is proprietary to Flextronics Software Systems
(FSS) and is intended solely for the use of 
the individual to whom it is addressed. It may contain privileged or
confidential information and should not be 
circulated or used for any purpose other than for what it is intended.
If you have received this message in error, 
please notify the originator immediately. If you are not the intended
recipient, you are notified that you are strictly
prohibited from using, copying, altering, or disclosing the contents of
this message. FSS accepts no responsibility for 
loss or damage arising from the use of the information transmitted by
this email including damage from virus."
_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

*****FSS-Private *****" DISCLAIMER: This message is proprietary to
Flextronics Software Systems Limited (FSS) and is intended solely for
the use of the individual to whom it is addressed. It may contain
privileged or confidential information and should not be circulated or
used for any purpose other than for what it is intended. If you have
received this message in error, please notify the originator
immediately. If you are not the intended recipient, you are notified
that you are strictly prohibited from using, copying, altering, or
disclosing the contents of this message. FSS accepts no responsibility
for loss or damage arising from the use of the information transmitted
by this email including damage from virus."
_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip