Subject: AW: AW: [Sip] Connected-identity and changing the To header field ina response

From: "Jesske, R" <[email-masked]>
Date: Thu, 1 Jun 2006 09:30:16 +0200

Christer,
I'm looking which ways are possible. The discussion with the urichange is at the moment is not very satisfying. So I'm happy if people come with other possibilies that could solve the issue.
The reply-to header could be an other solution that fits and do not use a P-header. 
The question which solution will be available faster.
The to header change has the advantage that we do not need a additional header and the draft is on the way and stable. 
I could life with both possibilities. 

Which way do you prefer?

Best Regards

Roland 

> -----Ursprüngliche Nachricht-----
> Von: Christer Holmberg (JO/LMF) 
> [mailto:[email-masked]] 
> Gesendet: Donnerstag, 1. Juni 2006 09:06
> An: Jesske, Roland; [email-masked]
> Cc: [email-masked]; [email-masked]; [email-masked]; 
> [email-masked]
> Betreff: RE: AW: [Sip] Connected-identity and changing the To 
> header fieldina response
> 
> 
> 
> What happened to the modified To header?
> 
> Regards,
> 
> Christer 
> 
> -----Original Message-----
> From: Jesske, R [mailto:[email-masked]] 
> Sent: 1. kesäkuuta 2006 8:28
> To: [email-masked]
> Cc: [email-masked]; [email-masked]; [email-masked]; 
> [email-masked]; Christer Holmberg (JO/LMF)
> Subject: AW: AW: [Sip] Connected-identity and changing the To 
> header fieldina response
> 
> Paul,
> in the past we lookes also on the Reply-to header. But per 
> definition it is the address where the user want to be 
> connected. So it is not in each case the real conected 
> identity. But the COLP (TIP) service could be used in the same way.
> So if it would be possible to use Reply-to header in 
> Responses, if people are willing and we as TISPAN can narrow 
> it then only to the real connected identity (within our 
> walled garden service definition) I would be happy.
> 
> Best Regards
> 
> Roland
> 
> > -----Ursprüngliche Nachricht-----
> > Von: Paul Kyzivat [mailto:[email-masked]]
> > Gesendet: Mittwoch, 31. Mai 2006 17:04
> > An: Jesske, Roland
> > Cc: [email-masked]; [email-masked]; [email-masked]; 
> > [email-masked]; [email-masked]
> > Betreff: Re: AW: [Sip] Connected-identity and changing the 
> To header 
> > field ina response
> > 
> > 
> > 
> > 
> > Jesske, R wrote:
> > > These are the requirements we already expressed in our
> > draft draft-jesske-sipping-tispan-requirements-02:
> > > 
> > >    REQ-TIP-1: In addition to any network asserted identity,
> > it must be
> > >               possible for the callee to indicate in a SIP
> > response an
> > >               additional identity where the user is
> > reachable for future
> > >               direct communications.  Note that the
> > requirement refers
> > >               to the user, not to the same instance of the
> > User Agent.
> > >    REQ-TIP-2: The identity mentioned in REQ-TIP-1 must be
> > formatted as a
> > >               SIP URI [2] or TEL URL [3].  A translation
> > between SIP URI
> > >               and TEL URL by the network is not requested.
> > >    REQ-TIP-3: The identity mentioned in REQ-TIP-1 is
> > considered an end
> > >               user supplied information that is not 
> asserted by the
> > >               network.
> > > 
> > > 
> > > As you can see we do not need any authenticated identity in
> > the response. For the authenticated identity we are using the 
> > P-Asserted-Identity. So we have two identities in a Response.
> > > For our purposes the user provided identity in a final 200
> > OK response is sufficient. So that avoids confusion within forking 
> > cases.
> > 
> > I haven't been paying close attention to this. What header are you 
> > planning to use to carry this callee provided identity?
> > 
> > The Reply-To header would seem to be appropriate for this 
> purpose, but 
> > unfortunately, according to table 2 of 3261, it is only allowed in 
> > INVITE.
> > 
> > 	Paul
> > 
> > > Roland
> > > 
> > > 
> > > 
> > > 
> > >> -----Ursprüngliche Nachricht-----
> > >> Von: Cullen Jennings [mailto:[email-masked]]
> > >> Gesendet: Montag, 22. Mai 2006 17:32
> > >> An: Jesske, Roland
> > >> Cc: John Elwell; [email-masked]; Roland Jesske; Christer Holmberg 
> > >> (JO/LMF)
> > >> Betreff: Re: [Sip] Connected-identity and changing the To header 
> > >> field ina response
> > >>
> > >>
> > >>
> > >> On May 16, 2006, at 7:07 AM, Jesske, R wrote:
> > >>
> > >>> John,
> > >>> it is that we don't can get an connected identity within
> > the final
> > >>> response of the initial INVITE.
> > >>> Your draft proposes a mid dialog request for getting this
> > >> information.
> > >>> That is not usable for the TIP service.
> > >> I think this is part of what I am not understanding. What is the 
> > >> requirement here?
> > >>
> > > 
> > > _______________________________________________
> > > Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> > > This list is for NEW development of the core SIP Protocol Use 
> > > [email-masked] for questions on current sip Use 
> > > [email-masked] for new developments on the application of sip
> > > 
> > 
> > _______________________________________________
> > Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> > This list is for NEW development of the core SIP Protocol Use 
> > [email-masked] for questions on current sip Use 
> > [email-masked] for new developments on the application of sip
> > 
> 
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol Use 
> [email-masked] for questions on current sip 
> Use [email-masked] for new developments on the application of sip
> 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Christer Holmberg \(JO/LMF\)" <[email-masked]>
Date: Thu, 1 Jun 2006 18:45:37 +0200

Hi Paul,

One suggestion has been to modify the To header in the response. It has been agreed on the list that it should not cause any harm to 3261 compliant nodes because the To header is not used as a transaction identifier. As, for the dialog identifier, only the tag parameter is used (and that would not be modified).

Regards,

Christer

-----Original Message-----
From: Paul Kyzivat [mailto:[email-masked]] 
Sent: 1. kesäkuuta 2006 16:43
To: Jesske, R
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]; Christer Holmberg (JO/LMF)
Subject: Re: AW: AW: [Sip] Connected-identity and changing the To header field ina response

I don't know if Reply-To would be any better for your schedule than a new header. It will still require an RFC to make it legal to use in responses. But it would avoid bringing yet another new header into the world.

IMO, if the semantics are right, then it is better to reuse it than to invent something new. If the semantics are wrong, then it shouldn't be used. Based on my limited understanding of the usage, the semantics seem about right to me.

	Paul

Jesske, R wrote:
> Paul,
> in the past we lookes also on the Reply-to header. But per definition it is the address where the user want to be connected. So it is not in each case the real conected identity. But the COLP (TIP) service could be used in the same way.
> So if it would be possible to use Reply-to header in Responses, if people are willing and we as TISPAN can narrow it then only to the real connected identity (within our walled garden service definition) I would be happy.
> 
> Best Regards
> 
> Roland
> 
>> Betreff: Re: AW: [Sip] Connected-identity and changing the To header 
>> field ina response
>>
>>
>>
>>
>> Jesske, R wrote:
>>>               user supplied information that is not asserted by the
>>>               network.
>>>
>>>
>> The Reply-To header would seem to be appropriate for this purpose, 
>> but unfortunately, according to table 2 of 3261, it is only allowed 
>> in INVITE.
>>
>> 	Paul
>>
>>> Roland
>>>
>>>
>>>
>>>

---

From: "Jesske, R" <[email-masked]>
Date: Thu, 8 Jun 2006 08:05:43 +0200

> Gesendet: Mittwoch, 7. Juni 2006 20:45
> An: Drage, Keith (Keith)
> Cc: Jesske, Roland; [email-masked]'
> Betreff: Re: [Sip] Connected-identity and changing the To 
> header field ina response
> 
> 
> 
> On Jun 7, 2006, at 6:09 AM, Drage, Keith (Keith) wrote:
> 
> > Neither identity is clearly wrong. This issue is that the 
> assertion  
> > of each identity may be right for some purposes, but not the best  
> > for others. The public network asserted identity works fine for  
> > charging purposes, and allocation of public network services in  
> > accordance with the subscriber's wishes, but is useless as a dial  
> > back number. For the enterprise network asserted identity, the  
> > opposite applies.
> 
> Ok, that makes sense. If the requirements are we need an billing  
> identifier and an number where the user (not I said user not device)  
> may be reached we can try to suggest work on something. If the  
> requirement is where the devices (not the user) may be reached we  
> could work on that too. I did not get this out of the requirement  
> document.

If we are going into Requirement I try to describe it in that way.

We have the P-Asserted-Identity so this is the Identity where the subscriber (not user) will be billed for. 
For Clarification: A 'subscriber' is a person or other entity that has contractual relationship with a service provider on behalf of one or more users. (A subscriber is responsible for the payment of charges due to that service provider)
I took a description of user from the ETSI database http://webapp.etsi.org/Teddi/

The "additional connected identity" is the identity where the user may be reached. In the PTSN world it is the line where the Black Phone is on. In SIP it should be an identity where the user may be reached.

Best Regards

Roland

---

From: "Elwell, John" <[email-masked]>
Date: Thu, 08 Jun 2006 07:57:12 +0100

Roland,

You wrote:
> The "additional connected identity" is the identity where the 
> user may be reached. In the PTSN world it is the line where 
> the Black Phone is on. In SIP it should be an identity where 
> the user may be reached.
[JRE] Expressed this way it sounds like a contact URI for a particular UA
that is currently registered on behalf of the user. I don't think this is
the intention - I think it should be the identity of the particular user (as
opposed to the 'subscriber' used for billing purposes).

John