Subject: AW: AW: [Sip] Issue 1 in draft-ietf-sip-connected-identity-00.txt

From: "Jesske, R" <[email-masked]>
Date: Fri, 2 Jun 2006 07:50:01 +0200

> -----Ursprüngliche Nachricht-----
> Von: David R Oran [mailto:[email-masked]] 
> Gesendet: Donnerstag, 1. Juni 2006 15:04
> An: Jesske, Roland
> Cc: [email-masked]; [email-masked]; [email-masked]; 
> [email-masked]; [email-masked]; 
> [email-masked]
> Betreff: Re: AW: [Sip] Issue 1 in 
> draft-ietf-sip-connected-identity-00.txt
> 
> 
> 
> On May 31, 2006, at 2:03 AM, Jesske, R wrote:
> 
> > The problem is that we try to solve two different approaches.
> > 1. The identity approach to get back an authenticated identity of  
> > the connected user
> > 2. To get back an "additional connected identity" that is  
> > unauthenticated and provided by the user.
> >
> Doesn't (2) sound like the job for a body, not a header? You could  
> send a picture, your C.V., a voiceprint - anything you want.

In the PSTN it is a full E164 number so we need an SIP uri/ tel uri. For us it must be interopeable.

Roland

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: David R Oran <[email-masked]>
Date: Fri, 2 Jun 2006 07:47:40 -0400

> uri. For us it must be interopeable.
So, in the case of the PSTN send a text/uri body type in the response  
and put a Tel uri in it. The point is that if I'm NOT talking to the  
PSTN the "connected identity" doesn't have to be an E.164 number. And  
by the way, if this is unauthenticated and asserted by the whoever,  
how can you tell it's an E.164 number, other than in a syntactic sense?

This header-containing-identities thing could have no end. I might  
want to send my identity, the identity of my secretary, the identity  
of my lawyer, etc. etc.

I would have less problem with  header if it had different semantics  
(in fact I'm not sure if even in the PSTN case the semantics of  
"connected identity" are well defined). If it really was a "if you  
want to call again in the future, use this URI" then I'd be  
moderately OK with using a "Reply-To" header, although as Paul K.  
points out, it's bit of a stretch.