Subject: RE: [Sip] Additional uses of INFO

From: "Drage, Keith (Keith)" <[email-masked]>
Date: Wed, 21 Jun 2006 13:56:38 +0100

The problem I am seeing is what we have at the moment is hiding the issue under the carpet.

Because we have no clear statement on whether INFO applications are regulated, or even allowed, and anybody in the past who has made a proposal for the use of INFO has been cast into the abyss, anybody using them just invents it and uses it, with no reference to IETF.

By the way RFC 4485 does not provide guidance on how to extend SIP. It tells you how to document an extension once you have invented it.

That is why I suggested maybe addressing the issue in RFC 3427.

regards

Keith

> -----Original Message-----
> From: Cullen Jennings [mailto:[email-masked]]
> Sent: 21 June 2006 03:44
> To: Dean Willis
> Cc: Jonathan Rosenberg; [email-masked]; James M. Polk; Drage, Keith
> (Keith)
> Subject: Re: [Sip] Additional uses of INFO
> 
> 
> 
> On Jun 14, 2006, at 8:53 PM, Dean Willis wrote:
> 
> > Do we have to change HTTP every time somebody uses it to get a new  
> > type of image file or to build a new type of web application? Let  
> > me think . . . nope, we don't.
> 
> Clearly some applications fit inside the extensibility model that  
> HTTP had - others, such as webdav, caldav, atom may not change HTTP  
> but were some pretty serious extensions - and Don't even ask about  
> how ETag works consistently across all theses.
> 
> Back to the topics of SIP ... I have not gone and read the various  
> drafts on this but it seems like we have some recommendation on how  
> to extend SIP (RFC 4485). Now I'm sure eventually things will 
> come up  
> where this is not enough but discussing it in the abstract is pretty  
> hard. I'd rather not build new extensibility mechanisms until we saw  
> some things that would use them - I'd be very afraid whatever we  
> build would not meet the needs of anything if it was done in the  
> abstract.
> 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 21 Jun 2006 09:27:04 -0400

I'm all for making a clear statement, and indeed this is why I wrote the 
I-D on INFO harmful. But from the brief discussion so far we obviously 
have a diversity of opinion on the topic.

I guess the question then is whether we want to endeavor to make a 
statement on this? I.e., should we add a charter item whose objective is 
to document the appropriate and inappropriate usages of INFO? I think 
Cullen is suggesting that its hard to do this in absence of specific use 
cases.

-Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.                   600 Lanidex Plaza
Cisco Fellow                                   Parsippany, NJ 07054-2711
Cisco Systems
[email-masked]                              FAX:   (973) 952-5050
http://www.jdrosen.net                         PHONE: (973) 952-5000
http://www.cisco.com

---

From: Dean Willis <[email-masked]>
Date: Wed, 21 Jun 2006 10:21:37 -0500

On Jun 21, 2006, at 8:27 AM, Jonathan Rosenberg wrote:

> I'm all for making a clear statement, and indeed this is why I  
> wrote the I-D on INFO harmful. But from the brief discussion so far  
> we obviously have a diversity of opinion on the topic.
>
> statement on this? I.e., should we add a charter item whose  
> objective is to document the appropriate and inappropriate usages  
> of INFO? I think Cullen is suggesting that its hard to do this in  
> absence of specific use cases.

Fair question. What is fundamentally different about documenting  
appropriate/inappropriate uses of INFO from documenting the same  
aspect of event packages?

--
Dean