Subject: [Sip] Anybody feeling a connection with "connect reuse"?

From: Dean Willis <[email-masked]>
Date: Fri, 23 Jun 2006 16:08:58 -0500

We've been following the connection reuse draft, currently draft-ietf- 
sip-connect-reuse-05.txt, for a long long time.

We've slipped the charter delivery date several times.

Are we ever going to finish this work? Do we need to finish this work?

Is this something that we could just not do?

Otherwise said: "Does the SIP working group still have a consensus to  
expend working group effort on connection reuse?"

If you have an opinion, for or against, please let it be known on  
this list.

Thanks,

--
Dean, as chairmonkey

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Samir Srivastava" <[email-masked]>
Date: Fri, 23 Jun 2006 16:13:39 -0500

As per my earlier postings regarding security, we need connect-reuse
think of TLS e2e and cost of TLS setup.

Samir 

-----Original Message-----
From: Dean Willis [mailto:[email-masked]] 
Sent: Friday, June 23, 2006 2:09 PM
To: IETF SIP List
Cc: Rohan Mahy; Keith Drage
Subject: [Sip] Anybody feeling a connection with "connect reuse"?

If you have an opinion, for or against, please let it be known on this
list.

Thanks,

--
Dean, as chairmonkey

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol Use
[email-masked] for questions on current sip Use
[email-masked] for new developments on the application of sip

---

From: "Vijay K. Gurbani" <[email-masked]>
Date: Fri, 23 Jun 2006 16:30:08 -0500

> If you have an opinion, for or against, please let it be known on  this 

Dean: I was about to get the chairs connected in after the
-0N date, but here goes ...

Current status: blocked on some text on how to handle certs
and virtual SIP/TLS servers.  There are some open issues on
virtual hosting (see
http://www3.ietf.org/proceedings/06mar/slides/sip-6.pdf).

I am gathering some thoughts on the contents of certificates for
virtual SIP servers in gurbani-sip-domain-certs draft (which is
furiously being updated for the Monday deadline).  Pending some
discussion on this, the connect-reuse draft will be rev'd.

Who cares:

   1) well ... at least the authors of the draft care,
      having spent considerable cycles in it.
   2) And it seems that others care as well -- at the last SIPit
      (April 2006), there were six implementations.

Can you please be so kind as to grant it a reprieve?

Thanks.

- vijay
-- 
Vijay K. Gurbani  vkg@{lucent.com,research.bell-labs.com,acm.org}
Bell Laboratories, Lucent Technologies, Inc.
2701 Lucent Lane, Rm. 9F-546, Lisle, Illinois 60532 (USA)

---

From: "Francois Audet" <[email-masked]>
Date: Fri, 23 Jun 2006 21:00:47 -0500

Personally, I think it should just be folded back into the SIP outbound
draft.

(Not necessarily the whole content, but the technical content that makes
sense
to use with SIP outbound).

> Sent: Friday, June 23, 2006 14:09
> To: IETF SIP List
> Use [email-masked] for questions on current 
> sip Use [email-masked] for new developments on the 
> application of sip
>

---

From: Rohan Mahy <[email-masked]>
Date: Sat, 24 Jun 2006 10:49:47 -0700

On behalf of Cullen and I (the current editors of outbound), please do 
not make us do that.

thanks,
-rohan

---

From: "Rajnish Jain" <[email-masked]>
Date: Sun, 25 Jun 2006 07:51:09 -0400

I'd like to see this work completed.

Thanks,
Rajnish 

-----Original Message-----
From: Dean Willis [mailto:[email-masked]] 
Sent: Friday, June 23, 2006 5:09 PM
To: IETF SIP List
Cc: Rohan Mahy; Keith Drage
Subject: [Sip] Anybody feeling a connection with "connect reuse"?

Otherwise said: "Does the SIP working group still have a consensus to expend
working group effort on connection reuse?"

If you have an opinion, for or against, please let it be known on this list.

Thanks,

--
Dean, as chairmonkey

---

From: "Vijay K. Gurbani" <[email-masked]>
Date: Sun, 25 Jun 2006 23:17:44 -0500

Francois Audet wrote:
> Personally, I think it should just be folded back into the SIP
> outbound draft.
> 
> (Not necessarily the whole content, but the technical content that
> makes sense to use with SIP outbound).

Francois: When the draft was rev'd from -04 to -05, we went
through the expedient exercise of excising all outbound related
content of connect-reuse to outbound (see
http://www1.ietf.org/mail-archive/web/sip/current/msg12373.html)

At this point in time, what remains in connect-reuse is
text that is germane to connect-reuse and not outbound.

Thanks,

- vijay

---

From: Nils Ohlmeier <[email-masked]>
Date: Tue, 27 Jun 2006 16:54:12 +0200

> If you have an opinion, for or against, please let it be known on

I think their are two options left:

- either push it out as "TLS-connection-reuse-between-proxies" (if nobody 
comes up with any issue any more)
- or drop it because the real world usage is too limited

I have little preference for the first alternative, but wouldn't mind to go 
for the second option.

Regards
  Nils