Subject: RE: [Sip] Connected-identity and changing the To header field ina response

From: "Drage, Keith (Keith)" <[email-masked]>
Date: Thu, 1 Jun 2006 11:06:01 +0100

I don't entirely agree with this answer.

Using the term "authenticated" is too general to be meaningful.

As far as I understand the requirements for this, they are to enable the ISDN service to be mimicked. This additional identifier required here merely has a different assertion. The P-Asserted-Identity is asserted by the network. The additional identifier is asserted by whichever entity the "special arrangement" has been granted to. These entities are outside the trust domain of the P-Asserted-Identity, but that does not necessarily mean there is not some level of trust. For the ISDN, in some countries, e.g. USA, this may be any customer premises equipment, in other countries it may be more controlled and be the specific operator of an enterprise network interconnected to the public network. It was not possible to gain international agreement on this because (way back somewhere around 1983) they wrote the codepoints before they defined what they meant (which did not really happen until around 1989).

And to answer Cullen's request later in the thread, the seond identifier is needed because in certain enterprise network scenarios, it stands more chance of being a real dial-back number than the P-Asserted-Identity.

regards

Keith

> -----Original Message-----
> From: Jesske, R [mailto:[email-masked]]
> Sent: 31 May 2006 06:38
> To: [email-masked]
> Cc: [email-masked]; [email-masked]; [email-masked];
> [email-masked]
> Subject: AW: [Sip] Connected-identity and changing the To header field
> ina response
> 
> 
> These are the requirements we already expressed in our draft 
> draft-jesske-sipping-tispan-requirements-02:
> 
>    REQ-TIP-1: In addition to any network asserted identity, it must be
>               possible for the callee to indicate in a SIP response an
>               additional identity where the user is reachable 
> for future
>               direct communications.  Note that the requirement refers
>               to the user, not to the same instance of the User Agent.
>    REQ-TIP-2: The identity mentioned in REQ-TIP-1 must be 
> formatted as a
>               SIP URI [2] or TEL URL [3].  A translation 
> between SIP URI
>               and TEL URL by the network is not requested.
>    REQ-TIP-3: The identity mentioned in REQ-TIP-1 is considered an end
>               user supplied information that is not asserted by the
>               network.
> 
> 
> As you can see we do not need any authenticated identity in 
> the response. For the authenticated identity we are using the 
> P-Asserted-Identity. So we have two identities in a Response.
> For our purposes the user provided identity in a final 200 OK 
> response is sufficient. So that avoids confusion within forking cases.
> 
> Roland
> 
> 
> 
> 
> > -----Ursprüngliche Nachricht-----
> > Von: Cullen Jennings [mailto:[email-masked]] 
> > Gesendet: Montag, 22. Mai 2006 17:32
> > An: Jesske, Roland
> > Cc: John Elwell; [email-masked]; Roland Jesske; Christer 
> > Holmberg (JO/LMF)
> > Betreff: Re: [Sip] Connected-identity and changing the To 
> > header field ina response
> > 
> > 
> > 
> > On May 16, 2006, at 7:07 AM, Jesske, R wrote:
> > 
> > > John,
> > > it is that we don't can get an connected identity within 
> the final  
> > > response of the initial INVITE.
> > > Your draft proposes a mid dialog request for getting this 
> > information.
> > > That is not usable for the TIP service.
> > 
> > I think this is part of what I am not understanding. What is the  
> > requirement here?
> > 
> 
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip
> 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 01 Jun 2006 09:35:49 -0400

Reading this, I get the feeling that this identity is *similar in 
intent* (but not identical) to the Contact address in a sip message.

Unfortunately it seems that we have more and more "twisty little 
addresses, all slightly different".

	Paul

---

From: Cullen Jennings <[email-masked]>
Date: Tue, 6 Jun 2006 22:31:56 -0700

On Jun 1, 2006, at 3:06 AM, Drage, Keith (Keith) wrote:

> And to answer Cullen's request later in the thread, the seond  
> identifier is needed because in certain enterprise network  
> scenarios, it stands more chance of being a real dial-back number  
> than the P-Asserted-Identity.

Ok, I am a little lost on the benefit of the network asserting that  
the correct id is one that is clearly wrong. And I still don't feel  
like I understand the problem well enough to tell why the contact or  
the Reply-To could not be used. I'm perfectly willing to believe  
there is a good reason they can't but I don't feel that we have  
enough information about the requirements to figure out how this  
might map to SIP.