Subject: [Sip] Error (nit) in RFC 3261

From: "Francois Audet" <[email-masked]>
Date: Mon, 12 Jun 2006 19:03:28 -0500

I spotted an error in RFC 3261.

The Registration response (200) in section 24.1 on p. 214 uses and Expires Header.

Section 10.3, point 8 (on p. 66) states that the 200 MUST use an expires parameter, not
an Expire Header (one for each contact). 

This is clearly an error.

Also, the text says that the 200 SHOULD have a Date header, but the example on p. 214 doesn't
have one. This is not really an error and it seems to be widespread omission (RFC 3265, outbound, 
etc.).

Not sure what is the process for putting this in the Errata.

----
François AUDET, Nortel Networks
mailto:[email-masked]

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 13 Jun 2006 09:51:40 -0400

> This is clearly an error.

If/when 3261 gets  updated, can we please do something clean? 
Specifically, say that in a REGISTER request or response the Expires 
header serves as a default value for any Contact that doesn't have an 
expires parameter.

	Paul