Subject: RE: [Sip] outbound i-d update?

From: "Christer Holmberg \(JO/LMF\)" <[email-masked]>
Date: Wed, 14 Jun 2006 10:20:10 +0200

Hi,

If the client receives multiple URIs, and/or IP addresses, the "default behavior" could be to open flows to at least of those.

But, I still think that the client should still be allowed to open a flow with only a single IP address, because the fact that it receives multiple URIs/addresses may have nothing to do with fault tolerance. But, in this case the client must of course have knowledge about that.

Regards,

Christer

-----Original Message-----
From: Juha Heinanen [mailto:[email-masked]] 
Sent: 14. kesäkuuta 2006 11:15
To: Christer Holmberg (JO/LMF)
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: RE: [Sip] outbound i-d update?

Christer Holmberg (JO/LMF) writes:

 > I think that can be mentioned in the document, but I still think the  > operator should be able to choose. Because, there may be other ways to  > provide fault tolerance than using multiple IP addresses.

i know, since at the moment we are using those "other ways" and i can tell you that they are not fun.  but you are right in that if a domain only advertises one outbound URI, which resolves to only one proxy host, then let it be that way.  it is domain's call.

however, the important thing is that IF domain advertises more than one outbound URI or a single URI that resolve(s) to more than one proxy host, then UA MUST keep flows open to at least two of those proxy hosts.

without this above requirement, outbound-id doesn't add any real value over what we have today.

-- juha

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Juha Heinanen <[email-masked]>
Date: Wed, 14 Jun 2006 11:23:48 +0300

Christer Holmberg (JO/LMF) writes:

 > But, I still think that the client should still be allowed to open a
 > flow with only a single IP address, because the fact that it receives
 > multiple URIs/addresses may have nothing to do with fault
 > tolerance. But, in this case the client must of course have knowledge
 > about that.

and how would that knowledge be auto-configured to the client?

-- juha