Subject: RE: [Sip] Outbound: keep-alive, outbound and 3489bis

From: "Christer Holmberg \(JO/LMF\)" <[email-masked]>
Date: Wed, 21 Jun 2006 22:43:06 +0200

Hi,

I'm happy with using the keepalive parameter. 

Francois, I guess the parameter value would still be "stun" (instead of "true", as in your example), right?

The other question is still whether it should be specified in the outbound draft, or in a separate draft. Again, IF it remains in the outbound draft we need to clearly separate the keep-alive usage from the outbound mechanism itself.

Regards,

Christer

-----Original Message-----
From: Francois Audet [mailto:[email-masked]] 
Sent: 21. kesäkuuta 2006 20:59
To: Cullen Jennings; Christer Holmberg (JO/LMF)
Cc: [email-masked]
Subject: RE: [Sip] Outbound: keep-alive, outbound and 3489bis

I guess it could also be configured in the phone (STUN-in-SIP == TRUE).

But if we want to have the keepalive=true in the URI as mandatory, I'm perfectly happy with that. It just means that instead of configuring it seperately, it's inferred from the URI, which is better because it is one less thing to worry about.

That's exactly the type of thing that I'd like to see in the paragraph.

> -----Original Message-----
> From: Cullen Jennings [mailto:[email-masked]]
> Sent: Wednesday, June 21, 2006 10:12
> To: Christer Holmberg ((JO/LMF))
> Cc: [email-masked]; Audet, Francois [SC100:3055:EXCH]
> Subject: Re: [Sip] Outbound: keep-alive, outbound and 3489bis
> 
> 
> 
> On Jun 21, 2006, at 9:57 AM, Christer Holmberg ((JO/LMF)) wrote:
> 
> > There must also be a way for the edge proxy to indicate to the 
> > client that it supports the STUN keep-alive usage. Because, if the 
> > other outbound features aren't supported/requested, there will be no 
> > "outbound" in the Supported header of the registration response.
> 
> this is done with the keepalive=stun parameter in the URI for the edge 
> proxy
> 
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol Use 
> [email-masked] for questions on current sip Use 
> [email-masked] for new developments on the application of sip
> 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Francois Audet" <[email-masked]>
Date: Wed, 21 Jun 2006 16:47:32 -0500

Correct.

That was just a "logical" example.

> From: Christer Holmberg (JO/LMF) 
> [mailto:[email-masked]] 
> Sent: Wednesday, June 21, 2006 13:43
> To: Audet, Francois [SC100:3055:EXCH]; Cullen Jennings
> Cc: [email-masked]
> Francois, I guess the parameter value would still be "stun" 
> (instead of "true", as in your example), right?
> 
> The other question is still whether it should be specified in 
> the outbound draft, or in a separate draft. Again, IF it 
> remains in the outbound draft we need to clearly separate the 
> keep-alive usage from the outbound mechanism itself.
> 
> Regards,
> 
> Christer
>  
> 
> But if we want to have the keepalive=true in the URI as 
> mandatory, I'm perfectly happy with that. It just means that 
> instead of configuring it seperately, it's inferred from the 
> URI, which is better because it is one less thing to worry about.
>