Subject: RE: [Sip] Ready for WGLC on Outbound?

From: "Drage, Keith (Keith)" <[email-masked]>
Date: Wed, 5 Jul 2006 14:47:11 +0100

Attempt to resend as the previous version seems to have disappeared into the ether.

regards

Keith

> -----Original Message-----
> From: Drage, Keith (Keith) 
> Sent: 05 July 2006 11:25
> To: Cullen Jennings
> Cc: [email-masked]; [email-masked]; [email-masked]
> Subject: RE: [Sip] Ready for WGLC on Outbound?
> 
> 
> (As chair)
> 
> Right now both Dean and myself believe outbound is blocked.
> 
> We asked the question a month or so ago about whether 
> outbound could proceed without a discovery mechanism (either 
> included or normatively referenced), and there was a 
> significant number of people who apparently said no (we do 
> have difficulties on this list who respond to a direct 
> question from the chairs by going away and discussing 
> something completely different).
> 
> It appears that for these people, outbound could proceed if 
> we have a normative reference to a discovery mechanism, but 
> in that case, is that one mechanism or several, and do all or 
> any of these require mandatory support.
> 
> Conversely we have a set of people who appear to be saying 
> "use any mechanism you like" and therefore no normative 
> reference is needed.
> 
> Now obviously, we would like to get this resolved one way or 
> the other. We will quite probably be conducting hums on this 
> issue in the SIP WG session in Montreal, having failed to 
> achieve concensus on the list - unless in the next two or 
> three days we see a breaking of this impasse.
> 
> And remember, if outbound is blocked, then GRUU is dependent 
> on outbound, so at the end of the day that will also be 
> blocked, even if we progress it to the RFC editor's queue.
> 
> We are formulating the questions we need to ask the WG on 
> this issue, so any guidance from those involved would be 
> useful. It would be nice to get the problem stated as clearly 
> as possible so that the WG is able to give an intelligent answer.
> 
> regards
> 
> Keith
> 
> 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Christer Holmberg" <[email-masked]>
Date: Fri, 7 Jul 2006 02:09:03 +0300

Hi,

I agree with Bell. A server shouldn't crash if someone sends "non-SIP" stuff to it. In that case people will be in trouble - with or without outbound and STUN.

The main reasons I want to know whether the proxy supports STUN are:

1. I don't want to send STUN request for nothing. It's not about whether the receiver will crash or not - it's just bad and unoptimized behavior. And, as Jeroen mentioned, the proxy could blacklist a client sending "unknown stuff".

2. A client may choose another edge proxy, if the current does not support STUN.

Regards,

Christer

---

From: Jeroen Van Bemmel <[email-masked]>
Date: Fri, 07 Jul 2006 18:33:34 +0200

Adam,

I hear what you're saying - one cannot even begin to list every possible way in which things could go wrong, let alone implement preventive measures

However, this case is different. 1) there is a simple solution that can avoid much pain and 2) What you describe below is relatively easy to diagnose (mail server receiving SIP). For outbound, what you will see is UAs that re-register every 90 seconds or so. Try detecting that, and then relating that to a DNS configuration error which is not apparent from only inspecting the DNS config
3) There are multiple config mechanisms. DNS is setup by (relative) professionals, but eg manual config is much more error prone (and nothing can be assumed about future mechanisms)

People used to think that 32 bits would be plenty,and look where that's gotten us. Now is the moment to say "if the topmost Route URI contains a 'keepalive=stun' parameter, an edge proxy MUST copy this parameter into the Path URI that it inserts". One simple sentence to prevent all sorts of trouble

Regards,

Jeroen

-----Oorspronkelijk bericht -----
Van: "Adam Roach" <[email-masked]>
Aan: "Dean Willis" <[email-masked]>
CC: "Cullen Jennings" <[email-masked]>; [email-masked]; "Juha Heinanen" <[email-masked]>; [email-masked]
Verzonden: 7-7-06 17:28
Onderwerp: Re: [Sip] Ready for WGLC on Outbound?

Dean Willis wrote:
> The problem as I see it is we have no way of easily detecting an error 
> if somebody mistakenly lists a non-compliant proxy as an outbound 
> proxy in DHCP or some other discovery mechanism. I hate leaping off a 
> trapeze without a safety net . . .

You mean like sending SIP to an address and port just because DNS 
resolution leads you to believe that address and port is ready to 
receive SIP? But what if someone misconfigures their DNS and 
accidentally resolves a request for the SIP service to their SMTP port?

At some point, we need to trust that system administrators have a couple 
of brain cells to rub together; that they can notice when they've 
misconfigured their systems; and that they will take corrective measures 
when things fail to work.

/a

---

From: "Christer Holmberg" <[email-masked]>
Date: Sat, 8 Jul 2006 10:49:58 +0300

Hi,

Maybe I've missed it, but what is the purpose of sending the keepalive parameter to the edge proxy in the first place?

To me it is only used to tell the client to use STUN keepalive, but what will the proxy do with that information? Should it reject a reuest if it does expect STUN, but the parameter is not present? Or?

Regards,

Christer

Regards,

Christer