Subject: [Sip] RE: [Geopriv] Does Location-Conveyance have an HTTP dereferencemechanism defined

From: "Rosen, Brian" <[email-masked]>
Date: Mon, 31 Jul 2006 18:05:40 -0400

Please don't change the subject, I understand the controversy on
constraining the ABNF.  I tried (apparently without success) to separate
those issues.  

I'm asking if anyone objects to NOT mentioning HTTP in any way with
respect to dereferencing URIs carried by the Location header.  That is
the only question I asked.  

I'm not trying to evade the constrained ABNF issue, and I'm not implying
anything tricky.  I simply want to know if it's okay if we leave
anything that deals specifically with HTTP and the Location header URI
to another document.

Brian

> -----Original Message-----
> From: Winterbottom, James [mailto:[email-masked]]
> Sent: Monday, July 31, 2006 5:55 PM
> To: Rosen, Brian; IETF SIP List
> Cc: GEOPRIV
> Subject: RE: [Geopriv] Does Location-Conveyance have an HTTP
> dereferencemechanism defined
> 
> Brian,
> 
> Your second paragraph re-opens the sore I am afraid.
> A large number of people have agreed with Henning's statements and
these
> are clear:
> 1) Do not constrain the ABNF
> 2) Provide minimal description of the reference function.
> 
> If you insist on saying then that the ABNF will be restricted if there
is
> not matching text, then I think it unlikely that you will reach a
> consensus.
> 
> Cheers
> James
> 
> ________________________________
> 
> From: Rosen, Brian [mailto:[email-masked]]
> Sent: Mon 31/07/2006 8:38 AM
> To: IETF SIP List
> Cc: GEOPRIV
> Subject: [Geopriv] Does Location-Conveyance have an HTTP
> dereferencemechanism defined
> 
> 
> 
> I have lost track of where we stand on whether the only mentioned URI
> schemes in location-conveyance are sip/sips/pres.  I "think" we have
> agreed that an HTTP/HTTPS dereference is in a separate document, but
I'm
> not sure.
> 
> This is NOT the discussion of what the ABNF of the location header
looks
> like (although it would NOT have http/https in it for sure if we agree
> that an HTTP dereference protocol is a separate draft).
> 
> If you think location-conveyance DOES have HTTP dereference text in
it,
> please say so, and please explain why you would not be satisfied if
> there were a separate draft on the subject.
> 
> Brian
> 
> _______________________________________________
> Geopriv mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/geopriv
> 
> 
> 
>
------------------------------------------------------------------------
--
> ----------------------
> This message is for the designated recipient only and may
> contain privileged, proprietary, or otherwise private information.
> If you have received it in error, please notify the sender
> immediately and delete the original.  Any unauthorized use of
> this email is prohibited.
>
------------------------------------------------------------------------
--
> ----------------------
> [mf2]

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Winterbottom, James" <[email-masked]>
Date: Mon, 31 Jul 2006 17:19:25 -0500

Not true
 
"> This is NOT the discussion of what the ABNF of the location header
looks
> that an HTTP dereference protocol is a separate draft)."
 
This is a discussion on ABNF and what the document contains, and to that extent they are not separable.
The consensus has been, do not restrict the ABNF, keep the discussion in the document about references limited. I am failing to understand why you can't accept that.

From: Rosen, Brian [mailto:[email-masked]]
Sent: Mon 31/07/2006 5:05 PM
To: Winterbottom, James; IETF SIP List
Cc: GEOPRIV
Subject: RE: [Geopriv] Does Location-Conveyance have an HTTP dereferencemechanism defined

Brian

these
is
I'm
looks
it,

------------------------------------------------------------------------------------------------
------------------------------------------------------------------------------------------------
[mf2]

---

From: Andrew Newton <[email-masked]>
Date: Mon, 31 Jul 2006 21:03:22 -0400

On Jul 31, 2006, at 6:19 PM, Winterbottom, James wrote:

> The consensus has been, do not restrict the ABNF, keep the  
> discussion in the document about references limited. I am failing  
> to understand why you can't accept that.

Brian is right.  They are not the same issue, atleast they do not  
have to be.

 From where I sit, I think the consensus is:
   - do not constrain the ABNF
   - HTTP goes in another document

Keep in mind, my hat is labeled "GEOPRIV" and this is a SIP document.

-andy

---

From: "Winterbottom, James" <[email-masked]>
Date: Mon, 31 Jul 2006 20:11:16 -0500

Hi Andy,
 
That is all I have asked for, do not constrain the ABNF. If "how I use HTTP as a reference" goes in a different document that is fine providing the ABNF is not constrained in the conveyance specification. This is not how I read Brian's statement below:
 
"This is NOT the discussion of what the ABNF of the location header looks
like (although it would NOT have http/https in it for sure if we agree
that an HTTP dereference protocol is a separate draft)."
 
Which to me clearly says the ABNF will be restrict to exclude HTTP/HTTPS if there is agreement that the conveyance draft doesn't have specific text on how to deference an HTTP reference.
 
Cheers
James

From: Andrew Newton [mailto:[email-masked]]
Sent: Mon 31/07/2006 8:03 PM
To: Winterbottom, James
Cc: Rosen, Brian; IETF SIP List; GEOPRIV
Subject: Re: [Sip] RE: [Geopriv] Does Location-Conveyance have an HTTP dereferencemechanism defined

-andy

---

From: Andrew Newton <[email-masked]>
Date: Mon, 31 Jul 2006 21:14:44 -0400

On Jul 31, 2006, at 9:11 PM, Winterbottom, James wrote:

> Hi Andy,
>
> That is all I have asked for, do not constrain the ABNF. If "how I  
> use HTTP as a reference" goes in a different document that is fine  
> providing the ABNF is not constrained in the conveyance  
> specification. This is not how I read Brian's statement below:
>
> Which to me clearly says the ABNF will be restrict to exclude HTTP/ 
> HTTPS if there is agreement that the conveyance draft doesn't have  
> specific text on how to deference an HTTP reference.
>
> Cheers
> James

Please keep in mind that this does not stop the draft from using MUST/ 
SHOULD language from stipulating "the URI MUST be a GEOPRIV standards  
track using protocol."

-andy