Subject: RE: [Sip] A thought on progressing outbound

From: "Drage, Keith (Keith)" <[email-masked]>
Date: Thu, 6 Jul 2006 17:25:34 +0100

Firstly I was not necessarily targetting your comments in particular, but lets try and address your issue in terms of some simple tests:

1)	what is currently in the draft fulfils the current requirements
2)	what is currently in the draft does not appear to be technically wrong
3)	we apparently do not need to decide between two alternative technical solutions to a requirement

therefore you have a use case that is different from that of the editors, and ideally we need to reflect the difference between those two use cases either:

-	by clearly stating a need for flexibility to allow those two use cases in the requirements
-	or detailing the use cases that need to be supported.

(assuming that these use cases are considered to be valid)

The first of these is probably correct in this case.

regards

Keith

> -----Original Message-----
> From: Miguel Garcia [mailto:[email-masked]]
> Sent: 06 July 2006 12:47
> To: Drage, Keith (Keith)
> Cc: [email-masked]
> Subject: Re: [Sip] A thought on progressing outbound
> 
> 
> I don't have any problem with the current list of requirements in 
> Section 12. The problem is that text in the draft seems to go beyond 
> these requirements and impose a certain mandatory redundancy 
> scheme, to 
> which I strongly disagree as a "mandatory" feature.
> 
> /Miguel
> 
> Drage, Keith (Keith) wrote:
> > (As WG chair)
> > 
> > Having looked at some of the comments on outbound being 
> addressed to the list in the last few days, it occurs to me 
> that at least of you have fundamental requirements that 
> impact the solution and these requirements themselves need to 
> be discussed.
> > 
> > Hidden in the current draft you will find section 12 
> labelled "requirements". This is a somewhat thin section at 
> the moment (not necessarily a bad thing).
> > 
> > Can you all please review this section, and identify 
> whether these requirements encompass all the requirements 
> that you wish to have met in outbound, and then try to 
> motivate what you think is missing.
> > 
> > And as always "send text".
> > 
> > regards
> > 
> > Keith
> > 
> > Keith Drage
> > Lucent Technologies
> > [email-masked]
> > tel: +44 1793 776249
> > 
> > _______________________________________________
> > Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> > This list is for NEW development of the core SIP Protocol
> > Use [email-masked] for questions on current sip
> > Use [email-masked] for new developments on the application of sip
> > 
> 
> -- 
> Miguel A. Garcia           tel:+358-50-4804586
> sip:[email-masked]
> Nokia Research Center      Helsinki, Finland
> 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Christer Holmberg \(JO/LMF\)" <[email-masked]>
Date: Thu, 6 Jul 2006 18:40:35 +0200

Hi,
 
In order to progress the work, and avoid discussions later, I think we also need to make clear which requirements are related to the STUN keep-alive mechanism, but not the rest of outbound, and which requirements have nothing to do with the STUN keep-alive mechanism.
 
Regards,
 
Christer

________________________________

From: Drage, Keith (Keith) [mailto:[email-masked]]
Sent: Thu 06/07/2006 18:25
To: Miguel Garcia
Cc: [email-masked]
Subject: RE: [Sip] A thought on progressing outbound

regards

Keith

---

From: Miguel Garcia <[email-masked]>
Date: Fri, 07 Jul 2006 08:53:05 +0300

Well, then I would say that what is missing is a mechanism that allows 
the domain to indicate the number of flows the UA should establish, 
independently of the number of provided URIs. At the moment both are 
tied together, one URI equals one flow. I think those should be decoupled.

/Miguel