Subject: [Sip] draft-ietf-sip-outbound and STUN keepalives

From: "Drage, Keith (Keith)" <[email-masked]>
Date: Thu, 20 Jul 2006 13:11:17 +0100

(As WG chair)

Previous mails on the SIP list have expressed the view that the STUN keepalive mechanism should be documented separately as it is a useful mechanism in its own right.

See http://www3.ietf.org/proceedings/06jul/slides/sip-5.pdf slide 5 for the issue as raised at the IETF #66 meeting.	

After discussion with the editor, the WG chairs propose the following:

-	that the documentation on STUN keepalive will REMAIN in the outbound document, and WILL NOT be split to a separate specification;

-	that the STUN keepalive mechanism WILL BE separated within the outbound specification, such that it is clear that it can be implemented independently of the rest of the outbound specification, and so that the keepalive material is clearly referencable in its own right.

We believe that this meets the requirements of at least most of the working group, and for pragmatic reasons we want to work against more fragmentation of the SIP documentation.

If you have problems with this proposal and desire a different solution, then please raise your concerns to the list, or direct to the WG chairs, in response to this mail.

regards

Keith

Keith Drage
[email-masked]
tel: +44 1793 776249

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Joel M. Halpern" <[email-masked]>
Date: Thu, 20 Jul 2006 08:20:39 -0400

This looks like a good solution to me.
Thank you.
Joel

At 08:11 AM 7/20/2006, Drage, Keith (Keith) wrote:
>(As WG chair)
>
>Previous mails on the SIP list have expressed the view that the STUN 
>keepalive mechanism should be documented separately as it is a 
>useful mechanism in its own right.
>
>See http://www3.ietf.org/proceedings/06jul/slides/sip-5.pdf slide 5 
>for the issue as raised at the IETF #66 meeting.
>
>-       that the documentation on STUN keepalive will REMAIN in the 
>outbound document, and WILL NOT be split to a separate specification;
>
>-       that the STUN keepalive mechanism WILL BE separated within 
>the outbound specification, such that it is clear that it can be 
>implemented independently of the rest of the outbound specification, 
>and so that the keepalive material is clearly referencable in its own right.
>
>We believe that this meets the requirements of at least most of the 
>working group, and for pragmatic reasons we want to work against 
>more fragmentation of the SIP documentation.
>
>If you have problems with this proposal and desire a different 
>solution, then please raise your concerns to the list, or direct to 
>the WG chairs, in response to this mail.
>
>regards
>
>Keith
>
>Keith Drage
>[email-masked]
>tel: +44 1793 776249

---

From: "Christer Holmberg \(JO/LMF\)" <[email-masked]>
Date: Fri, 21 Jul 2006 15:41:21 +0200

Hi Keith,

I am ok with the proposal.

In the "STUN keep-alive: Where to document it?" thread (http://www1.ietf.org/mail-archive/web/sip/current/msg15227.html) it is discussed where different things related to STUN keep-alive should be documented. Some things MAY have to be documented in 3489bis.

Regards,

Christer

-----Original Message-----
From: Drage, Keith (Keith) [mailto:[email-masked]] 
Sent: 20. heinäkuuta 2006 15:11
To: [email-masked]'
Subject: [Sip] draft-ietf-sip-outbound and STUN keepalives

(As WG chair)

regards

Keith

Keith Drage
[email-masked]
tel: +44 1793 776249

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol Use [email-masked] for questions on current sip Use [email-masked] for new developments on the application of sip

---

From: "Francois Audet" <[email-masked]>
Date: Fri, 21 Jul 2006 11:59:13 -0500

This is perfect.

In fact, I tought that this is what has been proposed all along: that 
is certainly what I personally wanted. 

FA> -----Original Message-----
FA> From: Drage, Keith (Keith) [mailto:[email-masked]] 
FA> Sent: Thursday, July 20, 2006 5:11 AM
FA> To: [email-masked]'
FA> Subject: [Sip] draft-ietf-sip-outbound and STUN keepalives
FA> 
FA> (As WG chair)
FA> 
FA> Previous mails on the SIP list have expressed the view that 
FA> the STUN keepalive mechanism should be documented 
FA> separately as it is a useful mechanism in its own right.
FA> 
FA> See http://www3.ietf.org/proceedings/06jul/slides/sip-5.pdf 
FA> slide 5 for the issue as raised at the IETF #66 meeting.	
FA> 
FA> After discussion with the editor, the WG chairs propose the 
FA> following:
FA> 
FA> -	that the documentation on STUN keepalive will REMAIN in 
FA> the outbound document, and WILL NOT be split to a separate 
FA> specification;
FA> 
FA> -	that the STUN keepalive mechanism WILL BE separated 
FA> within the outbound specification, such that it is clear 
FA> that it can be implemented independently of the rest of the 
FA> outbound specification, and so that the keepalive material 
FA> is clearly referencable in its own right.
FA> 
FA> We believe that this meets the requirements of at least 
FA> most of the working group, and for pragmatic reasons we 
FA> want to work against more fragmentation of the SIP documentation.
FA> 
FA> If you have problems with this proposal and desire a 
FA> different solution, then please raise your concerns to the 
FA> list, or direct to the WG chairs, in response to this mail.
FA> 
FA> regards
FA> 
FA> Keith
FA> 
FA> Keith Drage
FA> [email-masked]
FA> tel: +44 1793 776249
FA> 
FA> _______________________________________________
FA> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
FA> This list is for NEW development of the core SIP Protocol 
FA> Use [email-masked] for questions on 
FA> current sip Use [email-masked] for new developments on 
FA> the application of sip
FA>

---

From: Jonathan Rosenberg <[email-masked]>
Date: Fri, 21 Jul 2006 14:19:24 -0400

Right. I mentioned this in the behave meeting. The idea is that 
rfc3489bis formally defines the usage, and calls out additional things 
that an actual protocol that uses it, would have to say. Then 
sip-outbound says those things.

-Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.                   600 Lanidex Plaza
Cisco Fellow                                   Parsippany, NJ 07054-2711
Cisco Systems
[email-masked]                              FAX:   (973) 952-5050
http://www.jdrosen.net                         PHONE: (973) 952-5000
http://www.cisco.com