Subject: RE: [Sip] Re: A coment to draft-ietf-sip-outbound-04

From: "Michael Hammer \(mhammer\)" <[email-masked]>
Date: Mon, 10 Jul 2006 10:59:11 -0400

And what is your approach to re-registration avalanches?

Oh, wait that is not a handset problem.

Mike

> -----Original Message-----
> From: Miguel Garcia [mailto:[email-masked]] 
> Sent: Monday, July 10, 2006 9:58 AM
> To: Rohan Mahy
> Cc: [email-masked]; Cullen Jennings (fluffy)
> Subject: Re: [Sip] Re: A coment to draft-ietf-sip-outbound-04
> 
> Rohan Mahy wrote:
> > 
> >
> > So we are back to a pure semantic question.  Does the 
> service get to 
> > decide how many flows the UA opens (up to an implementation 
> supported 
> > maximum), does the UA decide how many flows to open, or is 
> there some
> > negotiation?   I still think the current semantics are 
> fine, because 
> > they allow a single flow to a URI that can still load-share and 
> > failover to a large number of actual servers.  Of course there are 
> > others who don't like that because it relies on DNS for failover.
> > 
> > thanks,
> > -rohan
> > 
> 
> I thought a bit more about this. I believe the service 
> provider has no more say than providing the list of outbound 
> URIs. The UA has to decide on how many flows to open, and 
> what is the cost of this decision. I can imagine a policy in 
> my laptop that makes the number of flows dependent on whether 
> I am plug to the main or running on battery, so that if I am 
> running on batteries I keep only one flow. My provider will 
> never know what is my battery status: He can only set the 
> maximum number of flows, but not the minimum.
> 
> /Miguel
> 
> -- 
> Miguel A. Garcia           tel:+358-50-4804586
> sip:[email-masked]
> Nokia Research Center      Helsinki, Finland
> 
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol Use 
> [email-masked] for questions on current sip 
> Use [email-masked] for new developments on the application of sip
> 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Hadriel Kaplan" <[email-masked]>
Date: Mon, 10 Jul 2006 11:24:45 -0400

I don't put that much value in using multiple concurrent flows for avalanche
avoidance.  There are already ways proxies handle this, though they're
mostly about smoothing out registration rates over time.  And the UAs will
already be doing some smoothing on their own as they detect the failure at
different times (over a 2 min period?).  The worst-case avalanche is
probably right after a power outage, and that's not covered by multiple
flows.  So your proxies need to be able to handle it.

-hadriel

> From: Michael Hammer (mhammer) [mailto:[email-masked]]
> Sent: Monday, July 10, 2006 10:59 AM
> To: Miguel Garcia; Rohan Mahy
> Subject: RE: [Sip] Re: A coment to draft-ietf-sip-outbound-04
>