Subject: RE: [Sip] Re: A coment to draft-ietf-sip-outbound-04

From: "Michael Hammer \(mhammer\)" <[email-masked]>
Date: Mon, 10 Jul 2006 13:24:56 -0400

So, could one infer from your statement, that if a network uses multiple
flows, but not keepalives, because it knows there are no NATs, then that
would be an acceptable configuration?

Mike

> -----Original Message-----
> From: Miguel Garcia [mailto:[email-masked]] 
> Sent: Monday, July 10, 2006 12:18 PM
> To: Jonathan Rosenberg (jdrosen)
> Cc: [email-masked]; Rohan Mahy; Cullen Jennings (fluffy)
> Subject: Re: [Sip] Re: A coment to draft-ietf-sip-outbound-04
> 
> Jonathan Rosenberg wrote:
> > inline.
> > 
> > I'm not entirely convinced that, once you're doing one flow with 
> > sip-outbound, that the incremental cost of an additional flow has a 
> > major impact on battery life.
> 
> It does, not because of the flow itself, but because of the 
> keepalives every 30 seconds.
> 
> 
> > That said, I think this is starting to split hairs. The 
> main point, I 
> > think, is that, under almost all conditions, if a client is 
> offered N 
> > URI it opens N flows. Only for *exceptional* conditions 
> would it open 
> > less. I would be OK with a strongly-qualified SHOULD. I.e., 
> the spec 
> > would say SHOULD and then explain that its only under such extreme 
> > conditions that it would open fewer.
> 
> I am fine with this proposal. And I wouldn't mine to add some 
> paragraph 
> describing the conditions under which the UA would establish 
> the N flows.
> 
> /Miguel
> 
> > Thanks,
> > Jonathan R.
> 
> -- 
> Miguel A. Garcia           tel:+358-50-4804586
> sip:[email-masked]
> Nokia Research Center      Helsinki, Finland
> 
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip
> 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Miguel Garcia <[email-masked]>
Date: Mon, 10 Jul 2006 20:30:34 +0300

> would be an acceptable configuration?

Yes, although I am not sure the benefit outbound will give you in this 
case, but it would be fine.

/Miguel

---

From: "Jeroen van Bemmel" <[email-masked]>
Date: Mon, 10 Jul 2006 21:24:13 +0200

Acceptable with a minor change in wording: "if a network OFFERS TO use 
multiple flows".

I compare this with an incoming INVITE that offers both audio and video. An 
UA might accept the audio but refuse the video, for whatever reason. The 
communication experience will be different (some might say "less"), but it's 
the UA's decision.

If there are no keepalives, then that is one compelling reason less to 
establish fewer flows than offered. So phrases like "the UA SHOULD establish 
a flow to each URI in the outbound proxy set" and "it is RECOMMENDED 
that..." are fine.

Regards,

Jeroen

----- Original Message ----- 
From: "Miguel Garcia" <[email-masked]>
To: "ext Michael Hammer (mhammer)" <[email-masked]>
Cc: <[email-masked]>; "Rohan Mahy" <[email-masked]>; "Cullen Jennings 
(fluffy)" <[email-masked]>
Sent: Monday, July 10, 2006 7:30 PM
Subject: Re: [Sip] Re: A coment to draft-ietf-sip-outbound-04

---

From: "Jeroen van Bemmel" <[email-masked]>
Date: Mon, 10 Jul 2006 21:31:47 +0200

>would be an acceptable configuration?

Besides being outside of the scope of outbound, the current text also makes 
it impossible to do optimizations like this (ie telling the UA not to do 
keepalive) because of the text in 7.1:

"When a URI is created that refers to a SIP device that supports STUN
   as described in this section, the 'keepalive' URI parameter, as
   defined in Section 10 MUST be added to the URI, with a value of
   'stun'."

Regards,

jeroen