Subject: RE: [Sip] Re: A coment to draft-ietf-sip-outbound-04

From: "Michael Hammer \(mhammer\)" <[email-masked]>
Date: Mon, 10 Jul 2006 11:43:09 -0400

That 2-minute period could be smoothed out over a much longer period of
time if there were multiple flows.

Your power outage example assumes a specific topology relative to where
power was lost.  I disagree with assuming a poor network design as
argument for multiple flows not handling the outage.

I do agree that proxies need to handle such overloads, but that leads
right back to the service being out for longer than the acceptable (?) 2
minute period.

I am not adverse to wireless networks choosing to make the tradeoff of
battery time to increased possibility of missing incoming calls, I just
think that there needs to be agreement between the network and client as
to what is acceptable and what those tradeoffs are, such that neither
has negative impacts.

Mike

> -----Original Message-----
> From: Hadriel Kaplan [mailto:[email-masked]] 
> Sent: Monday, July 10, 2006 11:25 AM
> To: Michael Hammer (mhammer); 'Miguel Garcia'; 'Rohan Mahy'
> Cc: [email-masked]; Cullen Jennings (fluffy)
> Subject: RE: [Sip] Re: A coment to draft-ietf-sip-outbound-04
> 
> I don't put that much value in using multiple concurrent 
> flows for avalanche avoidance.  There are already ways 
> proxies handle this, though they're mostly about smoothing 
> out registration rates over time.  And the UAs will already 
> be doing some smoothing on their own as they detect the 
> failure at different times (over a 2 min period?).  The 
> worst-case avalanche is probably right after a power outage, 
> and that's not covered by multiple flows.  So your proxies 
> need to be able to handle it.
> 
> -hadriel
> 
> 
> > -----Original Message-----
> > From: Michael Hammer (mhammer) [mailto:[email-masked]]
> > Sent: Monday, July 10, 2006 10:59 AM
> > To: Miguel Garcia; Rohan Mahy
> > Cc: [email-masked]; Cullen Jennings (fluffy)
> > Subject: RE: [Sip] Re: A coment to draft-ietf-sip-outbound-04
> > 
> > And what is your approach to re-registration avalanches?
> > 
> > Oh, wait that is not a handset problem.
> > 
> > Mike
> > 
> > 
> > > -----Original Message-----
> > > From: Miguel Garcia [mailto:[email-masked]]
> > > Sent: Monday, July 10, 2006 9:58 AM
> > > To: Rohan Mahy
> > > Cc: [email-masked]; Cullen Jennings (fluffy)
> > > Subject: Re: [Sip] Re: A coment to draft-ietf-sip-outbound-04
> > >
> > > Rohan Mahy wrote:
> > > >
> > > >
> > > > So we are back to a pure semantic question.  Does the
> > > service get to
> > > > decide how many flows the UA opens (up to an implementation
> > > supported
> > > > maximum), does the UA decide how many flows to open, or is
> > > there some
> > > > negotiation?   I still think the current semantics are
> > > fine, because
> > > > they allow a single flow to a URI that can still load-share and 
> > > > failover to a large number of actual servers.  Of 
> course there are 
> > > > others who don't like that because it relies on DNS for 
> failover.
> > > >
> > > > thanks,
> > > > -rohan
> > > >
> > >
> > > I thought a bit more about this. I believe the service 
> provider has 
> > > no more say than providing the list of outbound URIs. The 
> UA has to 
> > > decide on how many flows to open, and what is the cost of this 
> > > decision. I can imagine a policy in my laptop that makes 
> the number 
> > > of flows dependent on whether I am plug to the main or running on 
> > > battery, so that if I am running on batteries I keep only 
> one flow. 
> > > My provider will never know what is my battery status: He 
> can only 
> > > set the maximum number of flows, but not the minimum.
> > >
> > > /Miguel
> > >
> > > --
> > > Miguel A. Garcia           tel:+358-50-4804586
> > > sip:[email-masked]
> > > Nokia Research Center      Helsinki, Finland
> > >
> > > _______________________________________________
> > > Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> > > This list is for NEW development of the core SIP Protocol Use 
> > > [email-masked] for questions on current sip Use 
> > > [email-masked] for new developments on the application of sip
> > >
> > 
> > _______________________________________________
> > Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> > This list is for NEW development of the core SIP Protocol Use 
> > [email-masked] for questions on current sip Use 
> > [email-masked] for new developments on the application of sip
> 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Hadriel Kaplan" <[email-masked]>
Date: Mon, 10 Jul 2006 14:23:28 -0400

My point was just that it's not a panacea for the avalanche issue.  It helps
in various failure modes, doesn't in others.  The power outage was just an
extreme failure mode example; there are others.  

I know everyone's mileage varies, but 2 Minutes lets a heck of a lot of UAs
register, from what I've seen of registrar reg/sec load handling.  Like at
least in the thousands.  If more than thousands of UAs are registering anew,
the odds are it was either because they've all rebooted due to regional
power loss, or their primary proxy died/lost-comms.  In the former case
multiple flows would not help.  In the latter case outbound would have all
the UAs connecting to a backup for that failed primary in 90 seconds (ie,
they use the secondary proxy, but then create a replacement for the failed
flow).  So the avalanche is still there, just for another proxy, no?

-hadriel

> Sent: Monday, July 10, 2006 11:43 AM
> To: Hadriel Kaplan; Miguel Garcia; Rohan Mahy