Subject: RE: [Sip] SIP Transport Selection Question

From: "Drage, Keith (Keith)" <[email-masked]>
Date: Mon, 3 Jul 2006 22:14:32 +0100

There is an implicit assumption in the MTU size that may or may not prevent fragmentation.

The request is specified to be MTU minus 200 bytes such that it is unlikely that the addition of headers and parameters by proxies along the path will still keep it in the MTU size, and a further assumption exists that responses will be no larger than requests.

Neither of these assumptions is true in all circumstances.

However a response to a request sent over UDP will be returned over UDP, and the response will in most cases get through even if the MTU size is exceeded. The problem is that the response is not delivered reliably and there may be unnecessary retransmissions of the response in order for it to be delivered.

As over the years the size of SIP messages have exploded, there have been calls for the UDP option to be removed entirely.

regards

Keith

-----Original Message-----
From: Rayees Khan [mailto:[email-masked]]
Sent: 03 July 2006 09:39
To: Joe
Cc: [email-masked]
Subject: Re: [Sip] SIP Transport Selection Question

Hi Joe,

My understanding is that since response has to follow the transport published in via header, the UAS does not have choice in choosing transport for response.

regards
Rayees

-----Joe <[email-masked]> wrote: -----

To: [email-masked]
From: Joe <[email-masked]>
Date: 07/01/2006 01:22AM
Subject: [Sip] SIP Transport Selection Question

Under the Clients section 3261 states:

"If a request is within 200 bytes of the path MTU, or if it is larger than 1300 bytes and the path MTU is unknown, the request MUST be sent using an RFC 2914 congestion controlled transport protocol, such as TCP."

Is this for "requests" (INVITE, etc.) only? What if an INVITE were sent as UDP but a response (200 OK) were to come back with extra headers which breached the MTU? Must the node sending the OK switch the transport to TCP? Is this optional?

Regards,
Joe
_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip
*****FSS-Private *****" DISCLAIMER: This message is proprietary to Flextronics Software Systems Limited (FSS) and is intended solely for the use of the individual to whom it is addressed. It may contain  privileged or confidential information and should not be circulated or used for any purpose other than for what it is intended. If you have received this message in error, please notify the originator immediately. If you are not the intended recipient, you are notified that you are strictly prohibited from using, copying, altering, or disclosing the contents of this message. FSS accepts no responsibility for loss or damage arising from the use of the information transmitted by this email including damage from virus."
"DISCLAIMER: This message is proprietary to Flextronics Software 
Systems Limited (FSS) and is intended solely for the use of the 
individual to whom it is addressed. It may contain privileged or 
confidential information and should not be circulated or used for 
any purpose other than for what it is intended. If you have received 
this message in error, please notify the originator immediately. 
If you are not the intended recipient, you are notified that you are
strictly prohibited from using, copying, altering, or disclosing
the contents of this message. FSS accepts no responsibility for
loss or damage arising from the use of the information transmitted
by this email including damage from virus." 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Samir Srivastava" <[email-masked]>
Date: Mon, 3 Jul 2006 16:49:09 -0500

As over the years the size of SIP messages have exploded, there have
been calls for the UDP option to be removed entirely.

SS>> Refer followwing thread from MMUSIC, for how big SDP can be with
ICE etc extensions (~10 K)
http://www1.ietf.org/mail-archive/web/mmusic/current/msg04204.html

Should we take action sooner ? 

Thx
Samir