Subject: RE: [Sip] Ready for WGLC on Outbound?

From: Jeroen Van Bemmel <[email-masked]>
Date: Fri, 07 Jul 2006 18:47:29 +0200

Rohan,

Clients ignoring the flag would not do so on purpose, but simply because they would not know about it (ie only implementing outbound and not the separate extension). By making it part of outbound it becomes atomic: either the client does both STUN and "crash prevention", or neither of these. That is the only way to make it safe

Regards ,

Jeroen

-----Oorspronkelijk bericht -----
Van: "Rohan Mahy" <[email-masked]>
Aan: "Jeroen van Bemmel" <[email-masked]>
CC: [email-masked]; "Cullen Jennings" <[email-masked]>; "Rohan Mahy" <[email-masked]>; "Jonathan Rosenberg" <[email-masked]>; "Anders Kristensen" <[email-masked]>; [email-masked]
Verzonden: 7-7-06 17:25
Onderwerp: Re: [Sip] Ready for WGLC on Outbound?

Jeroen,

On Jul 6, 2006, at 14:12, Jeroen van Bemmel wrote:
> [ snap ]
>> Jonathan wrote
>>
>> I'm not objecting to the concept of this check. I just think its not 
>> necessary, something that might be optional at best. As such, if 
>> folks decide they want something, it can go in another draft. I dont 
>> think we need to burden sip-outbound with this.
>
> The trouble is, once outbound is "out" any mechanism defined in a 
> separate draft won't work as good. Because then there will be clients 
> that simply ignore the flag.

Why is this anymore likely for clients that implement outbound?  What 
is the motivation for clients to ignore the flag?  If they ignore the 
flag and send STUN requests anyway against the they trash their own 
proxy.  That is not in the interest of the client vendor.

thanks,
-rohan

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Rohan Mahy <[email-masked]>
Date: Fri, 7 Jul 2006 22:45:06 -0700

Jeroen,

Clients which implement outbound-04 as written already have a flag: the 
presence of keepalive=stun in the outbound-proxy-set.  The draft is 
pretty clear that clients send STUN messages to their outbound proxies 
when this parameter is present.

Some *other* flag that lets a client with a derived outbound-proxy-set 
figure out it is also safe to send STUN to a proxy is a perfectly fine 
future extension which does no harm.  Clients that just implement 
outbound-04 will never send STUN messages to the proxies with the 
future extension but no keepalive parameter, nor will they send STUN 
messages to unsuspecting proxies.

thanks,
-rohan

On Jul 7, 2006, at 9:47, Jeroen Van Bemmel wrote:

> Rohan,
>
> Clients ignoring the flag would not do so on purpose, but simply 
> because they would not know about it (ie only implementing outbound 
> and not the separate extension). By making it part of outbound it 
> becomes atomic: either the client does both STUN and "crash 
> prevention", or neither of these. That is the only way to make it safe
>
> Regards ,
>
> Jeroen
>
>
> CC: [email-masked]; "Cullen Jennings" <[email-masked]>; 
> "Rohan Mahy" <[email-masked]>; "Jonathan Rosenberg" 
> <[email-masked]>; "Anders Kristensen" <[email-masked]>; 
> [email-masked]
> Verzonden: 7-7-06 17:25