Subject: [Sip] Issue related to sigcomp

From: <[email-masked]>
Date: Wed, 6 Dec 2006 14:55:55 +0200

Hello,

I have encountered one unclarity in usage of SigComp as specified by RFC 3486. In section "4. Sending a Request to a Server" there is said that if client wants to receive subsequent requests with compression then "this client SHOULD add the parameter comp=sigcomp to the URI in the Contact header field". Later in the specification there are examples that are in conflict with this statement.

(1) INVITE UAS
    Via: UAC;comp=sigcomp
    Route: P1;comp=sigcomp
    Contact: UAC;comp=sigcomp

The contact header adds the comp parameter, but not as the URI parameter but as the header parameter.

I have found another example in 3GPP TS 24.141 v7.2.0 where on page 24 there is the Contact header in the form

Contact: <sip:[5555::aaa:bbb:ccc:ddd]:1357;comp=sigcomp>

This header has no header parameter and its value is sip uri with parameter. Later in that document, there is SIP NOTIFY message where the SIP URI from the Contact header is used in Request-URI in exactly the same format.

I have got few questions:
1. Where shall be the comp parameter used - as uri parameter or as header parameter?
2. If it is uri parameter, are the examples in RFC 3486 invalid?
3. If it is header parameter, then if client issues comp parameter as uri parameter does it mean that it is willing to receive compressed content?

br, Martin Hynar

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Jeroen van Bemmel" <[email-masked]>
Date: Wed, 6 Dec 2006 14:26:31 +0100

Martin,

The text above the example in RFC3486 explicitly says "We have not used a 
correct format for these header fields."

comp=sigcomp is a URI parameter, not a header parameter

Regards,
Jeroen

[email-masked] wrote:
> Hello,
>
> I have encountered one unclarity in usage of SigComp as specified by
> RFC 3486. In section "4. Sending a Request to a Server" there is said
> that if client wants to receive subsequent requests with compression
> then "this client SHOULD add the parameter comp=sigcomp to the URI in
> the Contact header field". Later in the specification there are
> examples that are in conflict with this statement.
>
> (1) INVITE UAS
>     Via: UAC;comp=sigcomp
>     Route: P1;comp=sigcomp
> I have found another example in 3GPP TS 24.141 v7.2.0 where on page
> 24 there is the Contact header in the form
>
> This header has no header parameter and its value is sip uri with
> parameter. Later in that document, there is SIP NOTIFY message where
> the SIP URI from the Contact header is used in Request-URI in exactly
> the same format.
>
> 3. If it is header parameter, then if client issues comp parameter as
> uri parameter does it mean that it is willing to receive compressed
> content?
>
> br, Martin Hynar
>