Subject: RE: [Sip] Message size - regarding

From: "Adarsh Guler" <[email-masked]>
Date: Tue, 12 Dec 2006 17:32:03 +0530

Hi Raj,

If the SIP packet is too large, message must be represented in "short"
format.

Ex:

Call-ID: 44fer23ei4291dekfer34231232

i:  44fer23ei4291dekfer34231232

From: Thomas Edison<sips:[email-masked]>;tag=532

F: Thomas Edison<sips:[email-masked]>;tag=532

Thanks & Regards

Adarsh.

________________________________

From: Raj [mailto:[email-masked]] 
Sent: Tuesday, December 12, 2006 5:21 PM
To: SIP forum
Subject: [Sip] Message size - regarding

Hello To all,

                We know that SIP uses TCP or UDP as the transport layer
protocol. There is some size restrictions on UDP packets and TCP
packets. It is been stated that one packet carries exactly one SIP
request or SIP response messages.

                My doubts is if the size of the SIP messages is more
than the size of the UDP or TCP packets, then what happens, will the
packet will be fragemented or SIP message will be discarded from being
transmitted.

with regards

Raj.

________________________________

Check out the all-new Yahoo! Mail beta
<http://us.rd.yahoo.com/evt=43257/*http:/advision.webevents.yahoo.com/ma
ilbeta>  - Fire up a more powerful email and get things done faster.

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "vamsi" <[email-masked]>
Date: Tue, 12 Dec 2006 19:22:37 +0530

Hi Adarsh,
 
         To represent in 'short', is which part of Implementation?  SIP or UDP?  
thanks & regards, 
vamsi.
  ----- Original Message ----- 
  From: Adarsh Guler 
  To: Raj ; SIP forum 
  Sent: Tuesday, December 12, 2006 5:32 PM
  Subject: RE: [Sip] Message size - regarding

  Hi Raj,

  If the SIP packet is too large, message must be represented in "short" format.

  Ex:

   

  Thanks & Regards

  Adarsh.

------------------------------------------------------------------------------

  Hello To all,

                  We know that SIP uses TCP or UDP as the transport layer protocol. There is some size restrictions on UDP packets and TCP packets. It is been stated that one packet carries exactly one SIP request or SIP response messages.

                  My doubts is if the size of the SIP messages is more than the size of the UDP or TCP packets, then what happens, will the packet will be fragemented or SIP message will be discarded from being transmitted.

  with regards

  Raj.

------------------------------------------------------------------------------

  Check out the all-new Yahoo! Mail beta - Fire up a more powerful email and get things done faster.

------------------------------------------------------------------------------

---

From: "Gupta Vineet-A18467" <[email-masked]>
Date: Tue, 12 Dec 2006 21:57:50 +0800

Hi Vamsi,
 
Short representation is a part of SIP itself. 
 
Any SIP implementation compliant with RFC3261 should be able to recognize header in short or normal form. Even a single SIP request can have some header in short form and some in normal, although no implemenation will do that as they would designed to send messages either in short or the long form. 
 
However, with this the compression would not be much, espeically if the message contains few headers and a large body. In that case sigcomp can be used for compessing the messages.
 
Regards,
Vineet.

-----Original Message-----
From: vamsi [mailto:[email-masked]]
Sent: Tuesday, December 12, 2006 7:23 PM
To: [email-masked]
Subject: Re: [Sip] Message size - regarding

Hi Adarsh,

----- Original Message ----- 
From: Adarsh Guler <mailto:[email-masked]>  
To: Raj <mailto:[email-masked]>  ; SIP forum <mailto:[email-masked]>  
Sent: Tuesday, December 12, 2006 5:32 PM
Subject: RE: [Sip] Message size - regarding

Hi Raj,

Ex:

 

Thanks & Regards

Adarsh.

  _____  

Hello To all,

with regards

Raj.

  _____  

Check out the  <http://us.rd.yahoo.com/evt=43257/*http:/advision.webevents.yahoo.com/mailbeta> all-new Yahoo! Mail beta - Fire up a more powerful email and get things done faster.

  _____