Subject: [Sip] Re: [Sip-implementors] Signalling and media path of SIP

From: vinodk <[email-masked]>
Date: Thu, 30 Nov 2006 18:56:58 +0530

Hi Raj,
For first problem, I don't think there is any protocol to find out the 
optimal Media Path. The SDP contact address which they share in INVITE 
and 200 OK will be used for Media transmission.

For second, If you want to send BYE in the same path where your previous 
packets traversed you should have enabled Record-Route at the proxy 
servers. Else BYE will go directly to the contact address which  came in 
200 OK of INVITE(at UAC)  and ACK(at UAS).

Regards
Vinod Kagalkar
Senior Project Leader
MultiTech Software Systems
Bangalore

Raj wrote:

>Hello,
>   
>                Recently I read from an article that signalling path of SIP is different from the path of media. When two end points want to communicate using SIP, the signalling takes place according to the operation of SIP, but once the signalling is over and when the media channel has to be established, which protocol is used to find the optimal media path?
>   
>               Moreover, when the session has to be terminated, SIP enabled end point has to send the BYE request, in this case, whether it takes the same path of INVITE request(which initiated the session) or  a different one. I am considering the stateless proxies to be in the network.
>   
>  with regards
>  Raj.
>
> 
>---------------------------------
>Everyone is raving about the all-new Yahoo! Mail beta.
>_______________________________________________
>Sip-implementors mailing list
>[email-masked]
>https://lists.cs.columbia.edu/cucslists/listinfo/sip-implementors
>
>
>  
>
_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Vivek Gupta <[email-masked]>
Date: Wed, 29 Nov 2006 19:28:22 -0800

SDP (session description protocol) information carried in the message 
body of the SIP messages(usually INVITE and its 200 OK response) 
exchanged b/w the two endpoints, explains the terminal capabilities of 
an endpoint to its peer. This SDP also includes the IP address and UDP 
port that will be used for the media packet flow. So once the signaling 
is through, flow of media packets is end to end.

Once the dialog is established, two endpoints communicate directly 
through the URI received in the contact headers. Hence, the bye request 
is sent directly end to end bypassing any proxy.

-- 
Noida Office

Vivek Gupta
Lead Technology
Globallogic
The Leader in Outsourced Product Development
B-34/1, Sector 59
Noida, UP, 201301
Phone: +91-120-4342965
Fax: +91-120-2585721

[email-masked]
www.globallogic.com