Subject: [Sip] The support of multiple connection line 'c=' in SIP UA.

From: Eanny Bae <[email-masked]>
Date: Fri, 08 Dec 2006 14:42:23 +0900

Dear all SIP experts,

Related with the usage of this multiple connections in SDP, I'd like to get
a clarification from all your SIP experts. 

The IETF RFC 4317 provides some examples for multiple connection lines (i.e.
'c=') in SDP offer and SDP answer. 

Even though IETF RFC 4566 (SDP), there is no clear definition of the usage
of multiple connection lines in SDP. Can it be expected that all SIP UA
support media transmission to/from multiple IP addresses in a single
session. i.e. Can supporting multiple connection('c=') lines be regarded as
a basic capability of the SIP UA?

Best Regards,

Eanny Bae 

-----------------------------------------------------
Eanny Bae (Ms.)
 
Engineer
Samsung Electronics Co., Ltd.
Tel) +82-31-279-5886
Mobile) +82-16-9530-5886
E-Mail)  <mailto:[email-masked]> [email-masked]
-----------------------------------------------------

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Attila Sipos" <[email-masked]>
Date: Fri, 8 Dec 2006 08:17:49 -0000

By the way, for interop, most UA's like the style in
example 1.  I have found some UA's that don't like
example 2 where there is no c= line in the session description.

(I have not actually tried example 3 with any UA)

Regards,
Attila

-----Original Message-----
From: Eanny Bae [mailto:[email-masked]]
Sent: 08 December 2006 07:26
To: Attila Sipos; 'mmusic'; 'sipping'; 'SIP'
Subject: RE: [Sip] The support of multiple connection line 'c=' in SIP
UA.

Dear Attila Sipos, 

Thanks for quick answer. 
>From your kindly explanation, I got to clarify that all SIP UA can support
SDP including multiple media description having a different connection
('c=') value per media type. Furthermore, I believe this capability is a
basic capability of SIP UA. 

Best Regards,
Eanny Bae 

Engineer
Samsung Electronics Co., Ltd.
Tel) +82-31-279-5886
Mobile) +82-16-9530-5886
E-Mail) [email-masked]
-----------------------------------------------------

-----Original Message-----
From: Attila Sipos [mailto:[email-masked]] 
Sent: Friday, December 08, 2006 3:56 PM
To: Eanny Bae; mmusic; sipping; SIP
Subject: RE: [Sip] The support of multiple connection line 'c=' in SIP UA.

RFC 4566 says...
 
5.7.  Connection Data ("c=")

      c=<nettype> <addrtype> <connection-address>

   The "c=" field contains connection data.

   A session description MUST contain either at least one "c=" field in
   each media description or a single "c=" field at the session level.
   It MAY contain a single session-level "c=" field and additional "c="
   field(s) per media description, in which case the per-media values
   override the session-level settings for the respective media.

The "session description" above  is the bit before any m= lines.
The "media descriptions" start with an m= line.
So an SDP has 1 session description section and can have
multiple media descriptions.
 
so as examples or positioning of c= lines, you can have:
 
1. There is one c= line at the session description
    Each media description uses the connection information from
    that top c= line.
c=....                     // session description
m=....                    // 1st media description
a=..... 
m=....                    // 2nd media description
a=.....
 
or

2. Each media description has its own c= line
    (There is no session description c= line):

                                // session description (no c= line)
m=....                    // 1st media description
c=....
a=..... 
m=....                    // 2nd media description
c=....
a=.....

or
 
3. There is a session description c= line but the first
    media description has its own c= line , so the first
    media description's c= line overrides the session description c= line.
   The 2nd media description uses the c= line in the session description.
c=....                    // session description
m=....                    // 1st media description
c=....
a=..... 
m=....                    // 2nd media description
a=.....

Regards,
Attila

	-----Original Message----- 
	From: Eanny Bae [mailto:[email-masked]] 
	Sent: Fri 08/12/2006 05:42 
	To: 'mmusic'; 'sipping'; 'SIP' 
	Cc: 
	Subject: [Sip] The support of multiple connection line 'c=' in SIP
UA. 

	Dear all SIP experts,

	Related with the usage of this multiple connections in SDP, I'd like
to get a clarification from all your SIP experts. 

	The IETF RFC 4317 provides some examples for multiple connection
lines (i.e. 'c=') in SDP offer and SDP answer. 

	Even though IETF RFC 4566 (SDP), there is no clear definition of the
usage of multiple connection lines in SDP. Can it be expected that all SIP
UA support media transmission to/from multiple IP addresses in a single
session. i.e. Can supporting multiple connection('c=') lines be regarded as
a basic capability of the SIP UA?

	Best Regards,

	Eanny Bae 

	 
	Engineer
	Samsung Electronics Co., Ltd.
	Tel) +82-31-279-5886
	Mobile) +82-16-9530-5886
	E-Mail) [email-masked] <mailto:[email-masked]> 
	-----------------------------------------------------