Subject: [Sip] Message size - regarding

From: Raj <[email-masked]>
Date: Tue, 12 Dec 2006 03:51:19 -0800 (PST)

Hello To all,
   
                  We know that SIP uses TCP or UDP as the transport layer protocol. There is some size restrictions on UDP packets and TCP packets. It is been stated that one packet carries exactly one SIP request or SIP response messages.
   
                  My doubts is if the size of the SIP messages is more than the size of the UDP or TCP packets, then what happens, will the packet will be fragemented or SIP message will be discarded from being transmitted.
   
  with regards
  Raj.

---------------------------------
Check out the all-new Yahoo! Mail beta - Fire up a more powerful email and get things done faster.

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Hisham Khartabil" <[email-masked]>
Date: Tue, 12 Dec 2006 15:32:00 +0100

On 12/12/06, Raj <[email-masked]> wrote:
>
> Hello To all,
>
>                 We know that SIP uses TCP or UDP as the transport layer
> protocol. There is some size restrictions on UDP packets and TCP packets. It
> is been stated that one packet carries exactly one SIP request or SIP
> response messages.
>

This is only true for  UDP. For TCP, you can have the sip messages
fragmented.

Hisham

                My doubts is if the size of the SIP messages is more than
> the size of the UDP or TCP packets, then what happens, will the packet will
> be fragemented or SIP message will be discarded from being transmitted.
>
> with regards
> Raj.
>
> ------------------------------
> Check out the all-new Yahoo! Mail beta<http://us.rd.yahoo.com/evt=43257/*http://advision.webevents.yahoo.com/mailbeta>- Fire up a more powerful email and get things done faster.
>
>

---

From: [email-masked]
Date: Tue, 12 Dec 2006 09:56:33 -0500

From: Raj <[email-masked]>

   It is been stated that one packet carries exactly one SIP request
   or SIP response messages.

That is correct for UDP, but not for TCP.

Dale

---

From: Xiao Wang <[email-masked]>
Date: Wed, 13 Dec 2006 11:47:13 +0800

Hi, Raj

         It is no problem for TCP, because TCP can prevent IP fragment by
MTU. Otherwise, UDP can occur to IP fragment.

So, in order to involve this problem, using TCP send SIP  message when the
size of SIP message more than the size of UDP.

But in a SIP transaction, it must use the same transport layer protocol.
Thus there may be a problem, if SIP request use UDP, 

corresponding SIP response use UDP, too. However, SIP response message size
may beyond the size of UDP. If the SIP response

is sent by UDP,  IP fragment will be  appearance.

Xiao

  _____  

From: Raj [mailto:[email-masked]] 
Sent: Tuesday, December 12, 2006 7:51 PM
To: SIP forum
Subject: [Sip] Message size - regarding

Hello To all,

with regards

Raj.

  _____  

Check out the
<http://us.rd.yahoo.com/evt=43257/*http:/advision.webevents.yahoo.com/mailbe
ta>  all-new Yahoo! Mail beta - Fire up a more powerful email and get things
done faster.