Subject: Re: [Sip] outbound-06 submitted

From: Byron Campen <[email-masked]>
Date: Tue, 12 Dec 2006 13:26:49 -0600

I have a question about the usage of STUN as a keepalive over UDP.  
Are clients supposed to start sending STUN before they try to  
REGISTER? If not, I can see the scenario where a UA sends the  
REGISTER, sets a timer (btw 24-29 seconds) for the first STUN  
keepalive, but before that STUN request is sent, the pinhole closes.  
Both ends will think the flow is ok (the STUN keepalive will open a  
new pinhole, but the UA won't know that), and the mess won't get  
cleaned up until the UA re-registers. Sending the keepalive "soon"  
after the REGISTER would probably solve this problem also, if sending  
before is not acceptable.

Best regards,
Byron Campen

> Hi,
>
> I submitted -06 of outbound so folks can at least take a look to see
> that the many small changes we have agreed to have been incorporated.
> I also included the proposed text for FASTEST, since the draft would
> need significant surgery anyway if we go with CLEANEST.
>
> Until it appears in the archive you can find it here:
> http://svn.resiprocate.org/rep/ietf-drafts/fluffy/draft-ietf-sip- 
> outbound-06.html
> http://svn.resiprocate.org/rep/ietf-drafts/fluffy/draft-ietf-sip- 
> outbound-06.txt
>
> thanks,
> -rohan
>
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Rohan Mahy" <[email-masked]>
Date: Tue, 12 Dec 2006 15:50:33 -0800

Hi Byron,

We could add text recommending that the UA compare the rport/received
with the XOR-MAPPED-ADDRESS.  That would appear to solve the problem.
Can you think of any problem with this?

thanks,
-rohan

---

From: Byron Campen <[email-masked]>
Date: Wed, 13 Dec 2006 08:50:05 -0600

That sounds reasonable to me.

Best regards,
Byron Campen

---

From: "Christer Holmberg \(JO/LMF\)" <[email-masked]>
Date: Thu, 14 Dec 2006 09:28:17 +0100

Hi,

I see no reason why the UA should need to send STUN BEFORE the REGISTER,
but I agree it should do it very soon after it has received the REGISTER
response - which may include information whether the edge proxy supports
STUN in the first place.

Regards,

Christer  

> -----Original Message-----
> From: Rohan Mahy [mailto:[email-masked]] 
> Sent: 13. joulukuuta 2006 1:51
> To: Byron Campen
> Cc: SIP WG; Cullen Jennings; Rohan Mahy
> Subject: Re: [Sip] outbound-06 submitted
> 
> Hi Byron,
> 
> We could add text recommending that the UA compare the 
> rport/received with the XOR-MAPPED-ADDRESS.  That would 
> appear to solve the problem.
> > > This list is for NEW development of the core SIP Protocol Use 
> > > [email-masked] for questions on current sip Use 
> > > [email-masked] for new developments on the application of sip
> >
> >
> >
> >
> 
> This list is for NEW development of the core SIP Protocol Use 
> [email-masked] for questions on current sip