Subject: [Sip] RE: I-D ACTION:draft-dotson-sip-certificate-auth-sol-00.txt

From: "Elwell, John" <[email-masked]>
Date: Thu, 08 Feb 2007 13:40:38 +0000

Steve,

I would have appreciated some discussion of the relationship of this to TLS
server authentication and mutual authentication. Presumably the benefit of
this is that it can be used for authentication when there is more than one
hop between the UA and the server.

John

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> Sent: 07 February 2007 20:50
> To: [email-masked]
> Subject: I-D ACTION:draft-dotson-sip-certificate-auth-sol-00.txt
> 
> A New Internet-Draft is available from the on-line Internet-Drafts 
> directories.
> 
> 
> 	Title		: SIP Certificate Authentication Solution
> 	Author(s)	: S. Dotson
> 	Filename	: draft-dotson-sip-certificate-auth-sol-00.txt
> 	Pages		: 20
> 	Date		: 2007-2-7
> 	
> 
>    This document specifies SIP Certificate Authentication (SCA), a
>    challenge-response mechanism that uses public key cryptography to
>    perform certificate-based authentication in Session Initiation
>    Protocol (SIP) based architectures.  Performing 
> authentication in SIP
>    with certificates will provide stronger authentication capabilities
>    and increase possible deployment scenarios in SIP networks.  The
>    scope is limited to the authentication of the SIP UA to the SIP
>    Service Provider's network.  It does not include UA to UA
>    authentication within its scope.
> 
> 
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-dotson-sip-certifica
> te-auth-sol-00.txt
> 
> To remove yourself from the I-D Announcement list, send a message to 
> [email-masked] with the word unsubscribe in 
> the body of 
> the message. 
> You can also visit 
> https://www1.ietf.org/mailman/listinfo/I-D-announce 
> to change your subscription settings.
> 
> Internet-Drafts are also available by anonymous FTP. Login with the 
> username "anonymous" and a password of your e-mail address. After 
> logging in, type "cd internet-drafts" and then 
> "get draft-dotson-sip-certificate-auth-sol-00.txt".
> 
> A list of Internet-Drafts directories can be found in
> http://www.ietf.org/shadow.html 
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
> 
> Internet-Drafts can also be obtained by e-mail.
> 
> Send a message to:
> 	[email-masked].
> In the body type:
> 	"FILE 
> /internet-drafts/draft-dotson-sip-certificate-auth-sol-00.txt".
> 	
> NOTE:	The mail server at ietf.org can return the document in
> 	MIME-encoded form by using the "mpack" utility.  To use this
> 	feature, insert the command "ENCODING mime" before the "FILE"
> 	command.  To decode the response(s), you will need "munpack" or
> 	a MIME-compliant mail reader.  Different MIME-compliant 
> mail readers
> 	exhibit different behavior, especially when dealing with
> 	"multipart" MIME messages (i.e. documents which have been split
> 	up into multiple messages), so check your local documentation on
> 	how to manipulate these messages.
> 
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.
> 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Dan Wing" <[email-masked]>
Date: Wed, 14 Feb 2007 17:37:02 -0800

> I would have appreciated some discussion of the relationship 
> of this to TLS server authentication and mutual authentication. 
> Presumably the benefit of this is that it can be used for 
> authentication when there is more than one hop between the 
> UA and the server.

Yes, much like SIP digest authentication.  

-d