Subject: RE: [Sip] Knowing status of sent message

From: [email-masked]
Date: Tue, 27 Feb 2007 21:03:20 +0530

intermediate proxies can send 202 .
In MESSAGE case 
200 -> implies that the Msg has reached to destination
202 -> that  proxy has recvd it & will frwrded it towards final 
destination

vishnu

<[email-masked]> 
02/20/2007 03:29 PM

To
<[email-masked]>, <[email-masked]>, <[email-masked]>
cc

Subject
RE: [Sip] Knowing status of sent message

Hi Ranjit,
Every MESSAGE method will be acknowledged by 200 OK success response.
 
That means, 
If ?A? sends MESSAGE to ?B?, upon receiving this MESSAGE B sends 200 OK 
response to A.
 
Regards
Kamal

From: Avasarala Ranjit-A20990 [mailto:[email-masked]] 
Sent: Tuesday, February 20, 2007 3:21 PM
To: [email-masked]; [email-masked]
Subject: [Sip] Knowing status of sent message
Importance: High
 
Hi 
Is there a mechanism in SIP to know the status of sent instant message 
using MESSAGE? 
Thanks 
Regards 
Ranjit _______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

***********************  Aricent-Private   ***********************
"DISCLAIMER: This message is proprietary to Aricent and is intended solely for the use of 
the individual to whom it is addressed. It may contain privileged or confidential information and should not be 
circulated or used for any purpose other than for what it is intended. If you have received this message in error, 
please notify the originator immediately. If you are not the intended recipient, you are notified that you are strictly
prohibited from using, copying, altering, or disclosing the contents of this message. Aricent accepts no responsibility for 
loss or damage arising from the use of the information transmitted by this email including damage from virus."
_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Byron Campen <[email-masked]>
Date: Wed, 28 Feb 2007 16:35:05 -0600

Just a note; a proxy, as defined by 3261, is not allowed to do this.  
This is strictly a B2BUA thing.

Best regards,
Byron Campen

> If “A” sends MESSAGE to “B”, upon receiving this MESSAGE B sends  
> 200 OK response to A.
>
> Regards
> Kamal
>
>
> Is there a mechanism in SIP to know the status of sent instant  
> message using MESSAGE?
>
> Thanks
>
> Regards
> the individual to whom it is addressed. It may contain privileged  
> or confidential information and should not be
> circulated or used for any purpose other than for what it is  
> intended. If you have received this message in error,
> please notify the originator immediately. If you are not the  
> intended recipient, you are notified that you are strictly
> prohibited from using, copying, altering, or disclosing the  
> contents of this message. Aricent accepts no responsibility for
> loss or damage arising from the use of the information transmitted  
> by this email including damage from virus."
>

---

From: [email-masked]
Date: Wed, 28 Feb 2007 18:25:54 -0500

From: [email-masked]

   vishnu

As Byron pointed out, no absolutely not, a proxy can't send 202, only
a user agent.  But various sorts of intermediate server can be (from
the SIP point of view) user agents.

The response codes are discussed in RFC 3428:

   If the UAC receives a 200 OK response to a MESSAGE request, it may
   assume the message has been delivered to the final destination.  It
   MUST NOT assume that the recipient has actually read the instant
   message.  If the UAC receives a 202 Accepted response, the message
   has been delivered to a gateway, store and forward server, or some
   other service that may eventually deliver the message.  In this case,
   the UAC MUST NOT assume the message has been delivered to the final
   destination.  If confirmation of delivery is required for a message
   that has been responded to with a 202 Accepted, that confirmation
   must be delivered via some other mechanism, which is beyond the scope
   of this specification.

Dale