Subject: [Sip] Question about a REFER scenario

From: "Subramanian, Vijay" <[email-masked]>
Date: Thu, 1 Feb 2007 14:09:44 -0500

What should the UA's behavior be in the following scenario? It is not clear whether UA should release all legs after the conversation between A and C has ended? Or is it the responsibility of B (or A) to send a BYE? 

A<---------UA-------------------->B (Stable Call)

	<---Invite (hold)
	---200--->
	
	<---Refer (referto: C)
	--202-->

	---Invite ---------->C
	<---180----
	<---200----

A<------------------------------>C (Stable Call)

	--NOTIFY (180)->B
	--200---------------

	--NOTIFY (200)->B
	--200---------------

	<---BYE---------- C
	---200 ------------>

A<------------------------------> B (B is still onhold. At this point, should it be the UA's responsibility to clean up A and B legs?)

Thanks
Vijay

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Sanjay Sinha \(sanjsinh\)" <[email-masked]>
Date: Thu, 1 Feb 2007 18:48:32 -0500

A's UA should send a BYE for call leg between itself and B after sending
NOTIFY with status 200 OK, if it hasn't received a BYE from B before
then.

Sanjay

>-----Original Message-----
>From: Subramanian, Vijay [mailto:[email-masked]] 
>Sent: Thursday, February 01, 2007 2:10 PM
>To: [email-masked]
>Subject: [Sip] Question about a REFER scenario
>
>What should the UA's behavior be in the following scenario? It 
>is not clear whether UA should release all legs after the 
>conversation between A and C has ended? Or is it the 
>responsibility of B (or A) to send a BYE? 
> 
>
>A<------------------------------> B (B is still onhold. At 
>this point, should it be the UA's responsibility to clean up A 
>and B legs?)
>
>
>Thanks
>Vijay
>
>
>
>This list is for NEW development of the core SIP Protocol Use 
>[email-masked] for questions on current sip