Subject: RE: [Sip] How does SIP keepalive between 2 UA?

From: "Attila Sipos" <[email-masked]>
Date: Thu, 1 Feb 2007 09:16:18 -0000

If there are no NATs in between the UA's then keepalive
is not very important.  However you can use SIP session
timer (RFC 4028) to check that the session is still active.

If there are NATs in between the UAs then you have to make
sure that some kind of keepalive is sent to keep the NAT
bindings open.  You could use SIP session timer for this too
but maybe the SIP session timer is a bit too heavy for keepalive
use.

You might want to consider the mechanisms in outbound-07:
http://www.ietf.org/internet-drafts/draft-ietf-sip-outbound-07.txt

See sections:
4.4.1.  Keepalive with TCP KEEPALIVE
and
4.4.2.  Keepalive with STUN

Regards,

Attila

-----Original Message-----
From: XuChunrong [mailto:[email-masked]]
Sent: 01 February 2007 03:08
To: [email-masked]
Subject: [Sip] How does SIP keepalive between 2 UA?

Hi..

I have a simple question..
When 2 SIP UAs have established a dialogue, and they want to exchange text  
infomations..
However this text infomation exchange may be very infrequent, how does SIP  
keepalive between the 2 UAs?
for example, 2 IM(Instance Message)
users may online but talk very infrequent,
-- 
Best Regards

Xu Chunrong
Southeast University, Nanjing

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 01 Feb 2007 09:11:22 -0500

Also note that session timer is not needed between the two UA endpoints
of a session. Either one can initiate a sip message within the dialog
any time it thinks it might want to verify the session.

	Paul