Subject: [Sip] Server receiving the SIP request over TCP client connection ?

From: "Vlado Vrlika \(ZG/ETK\)" <[email-masked]>
Date: Mon, 12 Mar 2007 15:17:53 +0100

Hello,
anyone having opinion (or any reference to RFC/draft) about what server
shall do when
receiving the request over TCP (or SCTP) client connection ? I know it
means a weird behaviour
on the remote UAC side, but ..  my first guess is: it's upon local SIP
transport layer policing
Option 1: such request can silently be discarded
Option 2: such request is handled normally, i.e. as it would have been
received over server connection.

My understanding of RFC 3261 and related stuff was "Option 2", as first
option might lead
to interoperability problems when transport network has poor quality and
policies are not aligned.
Old mail references on this issue are very much welcome.

Thanks,
  /Vlado Vrlika
_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Vijay K. Gurbani" <[email-masked]>
Date: Tue, 13 Mar 2007 07:51:05 -0600

Vlado Vrlika (ZG/ETK) wrote:
> Hello, anyone having opinion (or any reference to RFC/draft) about
> what server shall do when receiving the request over TCP (or SCTP)
> client connection ? I know it means a weird behaviour on the remote
> UAC side, but ..  my first guess is: it's upon local SIP transport
> layer policing Option 1: such request can silently be discarded 
> Option 2: such request is handled normally, i.e. as it would have
> been received over server connection.

Some discussion around this issue is in the connect-reuse
draft (http://tools.ietf.org/html/draft-ietf-sip-connect-reuse-07).
Accepting a request over a client connection may lead to the
sort of attacks described in S9 of that draft.

Thanks,

- vijay
-- 
Vijay K. Gurbani, Bell Laboratories, Alcatel-Lucent
2701 Lucent Lane, Rm. 9F-546, Lisle, Illinois 60532 (USA)
Email: vkg@{alcatel-lucent.com,bell-labs.com,acm.org}
WWW:   http://www.alcatel-lucent.com/bell-labs