Subject: RE: [Sip] Comment on sip-outbound-08

From: "Elwell, John" <[email-masked]>
Date: Sun, 18 Mar 2007 22:20:02 +0000

The purpose of the keep-alive is so that the UA can remake the connection if
it fails so that the proxy can get inbound SIP messages to the UA. Therefore
if messages are being received, isn't everything OK? I don't feel strongly
about this, so if people think there are genuine cases where SIP messages
are being received but there is still something wrong, then leave it as it
is.

John

> -----Original Message-----
> From: Christer Holmberg (JO/LMF) 
> [mailto:[email-masked]] 
> Sent: 18 March 2007 18:13
> To: Elwell, John; Cullen Jennings; Rohan Mahy; [email-masked]
> Subject: RE: [Sip] Comment on sip-outbound-08
> 
> 
> Hi, 
> 
> >"If the server does not receive a "pong" within an appropriate 
> >amount of time, it considers the flow failed."
> > 
> >First, it is the client that receives the pong. Second, if 
> >the client receives a regular SIP message, the connection 
> >must still be alive. Can we change this to say the following?
> >"If the client does not receive a "pong" or SIP message 
> >        ^^^^^^                           ^^^^^^^^^^^^^^^
> >within an appropriate amount of time, it considers the 
> >flow failed."
> 
> Wouldn't it be better to say, that if the UAC receives a SIP 
> message, it
> can "reset" the "ping" timer? 
> 
> Because, if it doesn't receive a "pong", something is obviously not
> working correct at the edge proxy - even if the NAT binding is still
> working...
> 
> Regards,
> 
> Christer
> 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Christer Holmberg \(JO/LMF\)" <[email-masked]>
Date: Mon, 19 Mar 2007 07:24:12 +0100

Hi, 

>The purpose of the keep-alive is so that the UA can remake 
>the connection if it fails so that the proxy can get inbound 
>SIP messages to the UA. Therefore if messages are being 
>received, isn't everything OK? I don't feel strongly about 
>this, so if people think there are genuine cases where SIP 
>messages are being received but there is still something 
>wrong, then leave it as it is.

If the UAC doesn't receive a "pong", the edge proxy may not even support
ping-pong, which means that the NAT binding will go down at some point
when the UAC does NOT receive an incoming SIP request. Of course the UAC
will detect it at that point, but it may be good to choose another flow
(or another keep-alive mechanism) already before that.

Regards,

Christer

> > >"If the server does not receive a "pong" within an 
> appropriate amount 
> > >of time, it considers the flow failed."
> > > 
> the client 
> > >receives a regular SIP message, the connection must still 
> be alive. 
> > >Can we change this to say the following?
> > Wouldn't it be better to say, that if the UAC receives a 
> SIP message, 
> > it can "reset" the "ping" timer?
> >