Subject: [Sip] SUBSCRIBE & REFER within INVITE established dialog

From: Nina Garaca <[email-masked]>
Date: Thu, 08 Mar 2007 15:22:38 +0100

Hi,

According to RFC 3265, it is legal to send a SUBSCRIBE within a dialog
established by an INVITE. In this case, the subscribe, the //invite, and 
all
the notifies resulting from the subscribe share the same dialog.
Q1: Is the converse true?
Q2: Does it mean that BYE for INVITE that has established the dialog, 
will not realy
   terminate the dialog, because of probably existed subscription?
Q3: Can this all be also aplied to REFER within the INVITE established 
dialog_

Thanks in advance.

-- 
Nina Garaca
Software Development & Testing

---

"ZESIUM mobile" d.o.o.
Valentina Vodnika 8/9
21000 Novi Sad
Serbia
Tel: +381 (0)21 472 15 48
Fax: +381 (0)21 472 15 49
Mob: +381 (0)63 16 15 891
E-mail: [email-masked]

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Christer Holmberg \(JO/LMF\)" <[email-masked]>
Date: Thu, 8 Mar 2007 15:28:02 +0100

Hi,

Please have a look at the dialog-usage draft, and see whether it answers
your questions.

Regards,

Christer 

> -----Original Message-----
> From: Nina Garaca [mailto:[email-masked]] 
> Sent: 8. maaliskuuta 2007 16:23
> To: [email-masked]
> Subject: [Sip] SUBSCRIBE & REFER within INVITE established dialog
> 
> Hi,
> 
> According to RFC 3265, it is legal to send a SUBSCRIBE within 
> a dialog established by an INVITE. In this case, the 
> subscribe, the //invite, and all the notifies resulting from 
> the subscribe share the same dialog.
> Q2: Does it mean that BYE for INVITE that has established the 
> dialog, will not realy
> Q3: Can this all be also aplied to REFER within the INVITE 
> established dialog_
> 
> Thanks in advance.
> 
> --
> Nina Garaca
> This list is for NEW development of the core SIP Protocol Use 
> [email-masked] for questions on current sip