Subject: [Sip] Comment on sip-outbound-08

From: "Elwell, John" <[email-masked]>
Date: Sat, 17 Mar 2007 16:09:00 +0000

"If
   the server does not receive a "pong" within an appropriate amount of
   time, it considers the flow failed."

First, it is the client that receives the pong. Second, if the client
receives a regular SIP message, the connection must still be alive. Can we
change this to say the following?
"If
   the client does not receive a "pong" or SIP message 
       ^^^^^^                           ^^^^^^^^^^^^^^^
   within an appropriate amount of time, it considers the flow failed."

Section 3.5.3 "STUN Keepalive Technique". The note seems to be out of date.
This describes the rationale for the choice of STUN, yet that rationale was
really the justification for using STUN with TCP/TLS, since there is other
justification for using STUN with UDP/DTLS. The note can probably be removed
or considerably reduced in size.

"If a pong is not received
   within 10 seconds (TODO - is 10 seconds the right amount of time)
   then the client MUST treat the flow as failed."
Change to
"If a pong or SIP message is not received
           ^^^^^^^^^^^^^^^
   within 10 seconds (TODO - is 10 seconds the right amount of time)
   then the client MUST treat the flow as failed."

John

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Cullen Jennings <[email-masked]>
Date: Sun, 18 Mar 2007 08:07:55 +0100

>    the client does not receive a "pong" or SIP message
in some previos conversations about there was concern that the client  
was just getting a queued up SIP message and this did not show the  
connection was live. Personally, I don't see this as a big problem  
and would be fine with the change you proposes but we might want to  
see if anyone had some serious issues with this.
> or considerably reduced in size.
yep - thanks for catching that.

---

From: "Christer Holmberg \(JO/LMF\)" <[email-masked]>
Date: Sun, 18 Mar 2007 19:13:07 +0100

Hi, 

>"If the server does not receive a "pong" within an appropriate 
>amount of time, it considers the flow failed."
> 
>First, it is the client that receives the pong. Second, if 
>the client receives a regular SIP message, the connection 
>must still be alive. Can we change this to say the following?
>"If the client does not receive a "pong" or SIP message 
>        ^^^^^^                           ^^^^^^^^^^^^^^^

Wouldn't it be better to say, that if the UAC receives a SIP message, it
can "reset" the "ping" timer? 

Because, if it doesn't receive a "pong", something is obviously not
working correct at the edge proxy - even if the NAT binding is still
working...

Regards,

Christer

---

From: <[email-masked]>
Date: Mon, 19 Mar 2007 09:30:19 +0200

Hi,

>"If a pong or SIP message is not received

Could someone please tell me how the UA is able to achieve
the same when using TCP keepalive ? Currently the draft
does not discuss any timing behaviour for TCP keepalive.

If this kind behaviour will be introduced for CRLF keepalive,
I believe the UA using TCP keepalive should also have some
explicit limits for its timing behaviour how long does it
wait for TCP ACK before deeming the flow failed.

Regards,

Erkki