Subject: [Sip] Current status of WG slides posted for review with IETF 68

From: Dean Willis <[email-masked]>
Date: Fri, 16 Mar 2007 05:52:21 -0500

There are some status slides posted at:

http://www.softarmor.com/sipwg/meets/ietf68/slides/index.html

Please check them out and make sure they look reasonable to you.

We won't have a lot of time to discuss them in Prague.

--
Dean

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Cullen Jennings <[email-masked]>
Date: Fri, 16 Mar 2007 23:06:06 +0100

On slide 4

e2m is waiting for resoltuion of issues with author and sec review

conncted-id is in rfc ed q

All the list URI messages are waiting for consent before we start  
processing them

ACR cod is in pub requested

Slide 15:
"how UPD is supported" is not an open issue from my read of the list  
traffic . Do we change to CRLF keep alive for TCP and STUN for UDP is  
the topic that we agree to discuss.

Skude 17  - I am unaware of what part of this is waiting for sips or  
domain-certs. Please let me know.

---

From: Dean Willis <[email-masked]>
Date: Mon, 19 Mar 2007 10:29:15 +0100

I'm almost windering if we're looking at different versions of the  
slides. I'm going to post a new one anyhow, but . . .

> e2m is waiting for resoltuion of issues with author and sec review

yeah, that's what it says.

> conncted-id is in rfc ed q

thanks.

> All the list URI messages are waiting for consent before we start  

The status slides say "waiting on publication request for draft-ietf- 
sip-consent-framework". Is this unclear?

> ACR cod is in pub requested

yeah, that's what is says on page 4.

>
> Slide 15:
> "how UPD is supported" is not an open issue from my read of the  
> list traffic . Do we change to CRLF keep alive for TCP and STUN for  
> UDP is the topic that we agree to discuss.
>
>
Right.

>
> Skude 17  - I am unaware of what part of this is waiting for sips  
> or domain-certs. Please let me know.
>

sips may or may not depend on domain certs.

if sips changes sips: usage, it will certainly impact the example  
call flows that use sips:.

--
Dean

---

From: Cullen Jennings <[email-masked]>
Date: Mon, 19 Mar 2007 11:27:00 +0100

> yeah, that's what it says.

hmm - did I review the wrong slides? - if so my appolgies  - all  
these notes were for the slide 4 summary not later notes
> sips may or may not depend on domain certs.
Seems very unlikely to me but sure, whatever, is fine with me, we  
will see
> call flows that use sips:.
I sort of doubt this - the example just show the basic setup of the  
crypto stuff and don't deal with the type of stuff sips covers but  
again, sure, we can see what the examples look like when done.

---

From: "Drage, Keith \(Keith\)" <[email-masked]>
Date: Tue, 20 Mar 2007 14:06:31 +0100

> > if sips changes sips: usage, it will certainly impact the 
> example call 
> > flows that use sips:.
> I sort of doubt this - the example just show the basic setup 
> of the crypto stuff and don't deal with the type of stuff 
> sips covers but again, sure, we can see what the examples 
> look like when done.
> 
> 
On this point, this is what we got from the editor (Robert) at the last
meeting. He said he was going to wait on updating the document because
he needed to see if these documents did any change.

Hopefully we can unravel this when we have finished the sip-sips
discussion.

Keith 

> -----Original Message-----
> From: Cullen Jennings [mailto:[email-masked]] 
> Sent: Monday, March 19, 2007 10:27 AM
> To: Dean Willis
> Cc: SIP IETF; Drage, Keith (Keith)
> Subject: Re: Current status of WG slides posted for review 
> with IETF 68
> 
> 
> hmm - did I review the wrong slides? - if so my appolgies  - 
> all these notes were for the slide 4 summary not later notes
> >
> > >
> > > traffic . Do we change to CRLF keep alive for TCP and 
> STUN for UDP 
> > > is the topic that we agree to discuss.
> > >
> > >
> > Right.
> >
> > >
> Seems very unlikely to me but sure, whatever, is fine with 
> me, we will see
> >
> > if sips changes sips: usage, it will certainly impact the 
> example call 
> > flows that use sips:.
> I sort of doubt this - the example just show the basic setup 
> of the crypto stuff and don't deal with the type of stuff 
> sips covers but again, sure, we can see what the examples 
> look like when done.
> 
> 
>

---

From: Robert Sparks <[email-masked]>
Date: Tue, 20 Mar 2007 14:25:14 +0100

And where the sip-sips discussion has gone, I don't think the outcome  
will change the existing examples in the secflows draft at all.

The problem spots I was watching have moved into other documents  
(specifically,
what gets put into SubjectAltName of the certs involved).

RjS

---

From: Cullen Jennings <[email-masked]>
Date: Thu, 22 Mar 2007 11:19:50 +0100

Vijay and Scott went and presented in pkix and got that WG's advice  
on some of the certificates issues. I'm sure they will report back  
and update their draft based on this but from what they old me, it  
sounded like all the advice they got was consistent with the current  
document robert is working on.

Anyways - I am fine with these slides as they are - we will just keep  
moving it along and change the examples if we find out we need too.

---

From: "Vijay K. Gurbani" <[email-masked]>
Date: Thu, 22 Mar 2007 07:00:14 -0500

Cullen Jennings wrote:
> Vijay and Scott went and presented in pkix and got that WG's advice on 
> some of the certificates issues. I'm sure they will report back and 
> update their draft based on this but from what they old me, it sounded 
> like all the advice they got was consistent with the current document 
> robert is working on.

Cullen: domain-certs was presented at pkix on Tuesday by Scott.
pkix was fine with the use of EKU OIDs, though we still need to
vet the exact wording and semantics on the pkix mailing list
by Chicago.  Other guidance, such as the use of SIP URIs in
SAN, multiple names in SAN, and not inserting hostnames in the
CN matches the general sipwg guidelines that we have talked about
in context of domain-certs.

We plan to rev up domain-certs to normatively capture this
guidance relatively soon after Prague and socialize the
rev'd draft on pkix as well as sip wg list.  We also need to
sync up with Francois to see if this affects sip-sips and RjS
for sec-flows.

Thanks,

- vijay
-- 
Vijay K. Gurbani, Bell Laboratories, Alcatel-Lucent
2701 Lucent Lane, Rm. 9F-546, Lisle, Illinois 60532 (USA)
Email: vkg@{alcatel-lucent.com,bell-labs.com,acm.org}
WWW:   http://www.alcatel-lucent.com/bell-labs