Subject: [Sip] Review of draft-ietf-sip-location-conveyance

From: "Drage, Keith \(Keith\)" <[email-masked]>
Date: Mon, 16 Apr 2007 19:13:10 +0200

I have posted the comments from WGLC on
draft-ietf-sip-location-conveyance at:

http://www.softarmor.com/sipwg/reviews/location-conveyance/index.html

Please let me know if I have missed any comments. 

There will be a review conference call of these comments on:

Wednesday 25th April at

	1:00 pm - 3:00 pm Central US time
	2:00 pm - 4:00 pm Eastern US time
	7:00 pm - 9:00 pm UK time
	8:00 pm - 10:00 pm Central Europe time

Bridge details:

Chairperson Name:  KEITH DRAGE
Access Phone Number:  8007718734
International Access Phone Number:  +1 6477233953 7-Digit Access Code:
5776249 

While this call is in no sense restricted, this call is for people who
have reviewed the document. If you think you qualify, and have not sent
comments that are included above, or indeed reviewed and had no
comments, then please send me a mail indicating this.

Regards

Keith

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Drage, Keith \(Keith\)" <[email-masked]>
Date: Tue, 24 Apr 2007 19:38:33 +0200

A reminder of the call tomorrow, and also that I have posted an updated
set of comments including some late comments received. 

The numbering remains consistent for the comments that were previously
posted, and we will refer to comments by numbers on the call tomorrow.

Keith

> -----Original Message-----
> From: Drage, Keith (Keith) [mailto:[email-masked]] 
> Sent: Monday, April 16, 2007 6:13 PM
> To: IETF SIP List
> Subject: [Sip] Review of draft-ietf-sip-location-conveyance
> 
> While this call is in no sense restricted, this call is for 
> people who have reviewed the document. If you think you 
> qualify, and have not sent comments that are included above, 
> or indeed reviewed and had no comments, then please send me a 
> mail indicating this.
> 
> Regards
> 
> Keith
> 
> 
> This list is for NEW development of the core SIP Protocol Use 
> [email-masked] for questions on current sip

---

From: "James M. Polk" <[email-masked]>
Date: Wed, 25 Apr 2007 00:34:21 -0500

1st half of the list from me (it's 12:30am and time for bed)

>posted, and we will refer to comments by numbers on the call tomorrow.

IMO, these points should be discussed on the call:

2, 3, 7, 11, 13, 16, 19, 21, 25, 27, 29, 30, 31, 43A, 61A, 64, 73, 
74, 76, 78, 79, 80, 84/85, 88, .......................

....more coming in the morning

These points are "maybes" for the call:

6, 10, 23, 31A, , , , , , , , , , , , , , , , , , , , , , , , , , , , 
, , , , , , , , ,

....more coming in the morning

---

From: Hannes Tschofenig <[email-masked]>
Date: Wed, 25 Apr 2007 09:18:00 +0200

Hi Keith,

I took a look at the webpage 
(http://www.softarmor.com/sipwg/reviews/location-conveyance/location-conveyance-comments-r1.htm) 
and I noticed that only minor editorial comments were captured on your 
webpage.
I believe that the technical comments are more important. Should they 
also be added to the page?

Ciao
Hannes

James M. Polk wrote:
> 2, 3, 7, 11, 13, 16, 19, 21, 25, 27, 29, 30, 31, 43A, 61A, 64, 73, 74, 
> 76, 78, 79, 80, 84/85, 88, .......................
>

---

From: "Drage, Keith \(Keith\)" <[email-masked]>
Date: Wed, 25 Apr 2007 11:51:51 +0200

Then you need to tell me what is missing - as does anyone else who posted comments.

I believe I took all the comments from both your comments on -05 and the new ones on -07. Obviously I had to add the classification because you in general omitted it. In general I also had to try and identify section numbers as well.

(Now if you had followed the instructions in the original posting as to presentation it would have made my job easier and less likely to error.)

Regards

Keith

> From: Hannes Tschofenig [mailto:[email-masked]] 
> Sent: Wednesday, April 25, 2007 8:18 AM
> Cc: Drage, Keith (Keith); IETF SIP List
> Subject: Re: [Sip] Review of draft-ietf-sip-location-conveyance
> 
> Hi Keith,
> 
> and I noticed that only minor editorial comments were 
> captured on your webpage.
> I believe that the technical comments are more important. 
> Should they also be added to the page?
> 
> Ciao
> Hannes
> 
> James M. Polk wrote:
> >> A reminder of the call tomorrow, and also that I have posted an 
> >> updated set of comments including some late comments received.
> >>
> >> The numbering remains consistent for the comments that were 
> >> previously posted, and we will refer to comments by 
> numbers on the call tomorrow.
> >
> >> > While this call is in no sense restricted, this call is 
> for people 
> >> > who have reviewed the document. If you think you 
> qualify, and have 
> >> > not sent comments that are included above, or indeed 
> reviewed and 
> >> > had no comments, then please send me a mail indicating this.
> >> >
> >> > Regards
> >> >
> >> > Keith
> >> >
> >> >
> >> > [email-masked] for questions on 
> current sip Use 
> >> > [email-masked] for new developments on the application of sip
> >> >
> >>
> >>
> >> [email-masked] for questions on current sip Use 
> >> [email-masked] for new developments on the application of sip
> >
> >
> > [email-masked] for questions on current sip Use 
> > [email-masked] for new developments on the application of sip
> 
>

---

From: "Drage, Keith \(Keith\)" <[email-masked]>
Date: Wed, 25 Apr 2007 15:47:48 +0200

The following is the details of the review call and agenda for the call.

Comments are welcomed by email before the start of the call.

Regards

Keith

Wednesday 25th April at

Bridge details:

Agenda:

1)	Roll call

2)	Agenda bash - lets not spend too much time moving things around,
concentrate on what is missing, or what does not  need to be discussed.
Note that the comments listed below are only what are regarded as the
more major issues meriting collective discussion and review - I expect
the editors to use their initiative on many of the others.

3)	Methodology
	First discussion of key points. 
	If new comments arise from discussion, please identify verbally
and ensure they are documented.
	Comments discussed can have resolution agreed in the call, or
defer, or take to list, or leave to authors to make a  judgement.

4)	
Issues relating to multiple locations

	Comments: 2, 3, (66), 78, 94, 96, 153, 164

	Key questions: 
	Do we want multiple locations?	If there are multiple locations,
which should be used?
	If a 424 is returned, which location does it relate to?

	Which location does the warning refer to?
	In what circumstances can multiple locations cause a call to
fail - or can one be used and ignore the rest?
	If you have a location by value, do you need to also resolve any
location by reference?
	Anything different for multiple locations in responses?

5)	Security issues

	Comments: 21, 27, 117A, 129C, 129D, 168, 181A, 181B, 137
	Key questions:
	Any issues with mandating multipart MIME?
	Signing versus encryption issues?
	Document security issues when retrieving location by reference?
	Are mechanisms different for LbyrR and LbyV?
	Is security considerations section adequate?
	Are self signed certificates out of scope?
	Is mandating a retry without TLS in scope?

6)	Emergency issues

	Comments: 129B, 167A, 169
	Key questions:
	Should we cover emergency at all in this document?

7)	Response usage

	Comments: 29, 150
	Key questions:
	Is it allowed in responses, and if so, what are the procedures
for error handling?
	What are the associated Require: and Supported: procedures?

8)	Error handling issues

	Comments: 30, 79, 84, 85, 110, 147
	Key questions:
	Dialog usage - does 424 clear the dialog or just the specific
usage?
	Can Warning only appear in 424?
	Do we need all the warnings given?
	Do we need 701?
	What mechanism should we use to indicate URL schemes?
	Do we always return an error, or can we just ignore a problem?	

9)	Method usage

	Comments: 62, 69, 73, 74
	Key questions:
	INFO?
	Mid call location updates use what mechanism?
	REFER?
	PUBLISH?
	BYE?

10)	Body issues

	Comments: 159
	Key questions:
	What additional information is needed to describe bodies?

11)	PIDF-LO usage

	Comments: 121, 153A
	Key questions:
	Point usage deprecated?
	Proxy usage - what can proxy say about this location - is this
in scope of this document or does GEOPRIV need to  handle it?

12)	URI issues

	Comments: 7, 64
	Key questions:

13)	Routeing query allowed issues

	Comments: 11
	Key questions:

14)	Retransmission allowed issues

	Comments: 61A
	Key questions:
	Is mechanism needed?

15)	Terminology usage

	Comments: 1, 19, 43A, 101A, 116B, 129A
	Key questions
	Are "by value" and "by reference" the appropriate terms?
	Is LbyR a using protocol?
	Are there any circumstances where we need to talk about LIS
rather than LS?

16)	Pull mechanisms

	Comments: 25, 144A
	Key questions:
	Are the mentioned pull mechanism valid, given that we don't
cover them at all?

> Sent: Tuesday, April 24, 2007 6:39 PM
> To: IETF SIP List
> Subject: RE: [Sip] Review of draft-ietf-sip-location-conveyance
> 
> A reminder of the call tomorrow, and also that I have posted 
> an updated set of comments including some late comments received. 
> 
> previously posted, and we will refer to comments by numbers 
> on the call tomorrow.
> 
> Keith
> 
> people who 
> > have reviewed the document. If you think you qualify, and have not 
> > sent comments that are included above, or indeed reviewed 
> and had no

---

From: "Drage, Keith \(Keith\)" <[email-masked]>
Date: Thu, 26 Apr 2007 18:47:49 +0200

We made good progress on the call yesterday, but as might be expected,
we did not finish.

There will be another review call next week - details as follows:

Tuesday 1st May 2007 at

	9:00 am - 11:00 am Central US time
	10:00 am - 12:00 noon Eastern US time
 	3:00 pm - 5:00 pm UK time
 	4:00 pm - 6:00 pm Central Europe time
 
Bridge details:

Chairperson Name:  KEITH DRAGE
Access Phone Number:  8007718734
International Access Phone Number:  +1 6477233953 
7-Digit Access Code: 5776249

We will have some notes from the previous call, and a number of issues
for further WG discussion on list that will come out in due course.

Regards

Keith