Subject: [Sip] draft-ietf-sip-outbound-08: Registrar Response

From: "Peter Musgrave" <[email-masked]>
Date: Thu, 5 Apr 2007 08:53:56 -0600

Hi, 

Apologies if this is a NIT.

In 6.3

The Registrar MUST include the 'outbound' option-tag (defined in

   Section (Section 12.1)) in a Supported header field value in its

   responses to REGISTER requests for which it has performed outbound

   processing

Is this an "If and only if"??

Should I assume that a registrar MUST NOT include the outbound tag if it
has not performed outbound processing?

What if there were multiple contacts and outbound was not done for all?

Thanks, 

Peter

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Rohan Mahy <[email-masked]>
Date: Fri, 6 Apr 2007 08:57:10 -0700

Hi Peter,

The intent is "if and only if". I think it should be pretty clear to  
an implementor that if the registrar includes the outbound tag when  
it doesn't do outbound processing, that things aren't going to work.

As for multiple contacts, the spec does already say that you can't do  
multiple contacts with outbound registration behavior.

thanks,
-rohan

On Apr 5, 2007, at 7:53 AM, Peter Musgrave wrote:

> Is this an “If and only if”??
>
>
>
> Should I assume that a registrar MUST NOT include the outbound tag  
> if it has not performed outbound processing?
>
>
>