Subject: [Sip] Removing the Via received parameter before forwarding a response?

From: "Christer Holmberg \(JO/LMF\)" <[email-masked]>
Date: Tue, 3 Apr 2007 21:56:53 +0200

Hi,

Chapter 18.2.1 describes how a node receiving a request may add a
received parameter to the top Via, and chapter 18.2.2 later describes
how it can be used to route the response.

HOWEVER, chapter 8.2.6.2 of 3261 says:

"The Via header field values in the response MUST equal the Via header
field values
in the request and MUST maintain the same ordering."

So, my question is: if a node has added a received parameter to a Via
header when receiving the request, shall it remove it before sending
back the associated response?

I can find no text saying that the parameter shall be removed before the
response is forwarded, and 3261 also shows message examples where the
Via received parameter is shown in the response, eventhough it did not
exist in the request.

One can of course say that the header values that were present in the
request must be identical in the response, but additional parameters may
be added. But, that is not clear in the text.

Regards,

Christer

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Robert Sparks <[email-masked]>
Date: Tue, 3 Apr 2007 15:12:22 -0500

The intent, and the expectation of all implementations I am aware of,  
is that the populated received= parameter appears in the topmost via  
of responses (when received is added). There is no requirement to  
remove it from the topmost via of the response. We can capture this  
as something to clarify.

RjS

---

From: "Christer Holmberg \(JO/LMF\)" <[email-masked]>
Date: Wed, 4 Apr 2007 05:26:45 +0200

Hi Robert,

I have been made aware of an implementation that most likely does have a
problem with this, so a clarification would be useful.

Regards,

Christer 

> -----Original Message-----
> From: Robert Sparks [mailto:[email-masked]] 
> Sent: 3. huhtikuuta 2007 23:12
> To: Christer Holmberg (JO/LMF)
> Cc: IETF SIP List
> Subject: Re: [Sip] Removing the Via received parameter before 
> forwarding a response?
> 
> The intent, and the expectation of all implementations I am 
> aware of, is that the populated received= parameter appears 
> in the topmost via of responses (when received is added). 
> There is no requirement to remove it from the topmost via of 
> the response. We can capture this as something to clarify.
> 
> RjS
> 
> > field values in the request and MUST maintain the same ordering."
> >
> > I can find no text saying that the parameter shall be 
> removed before 
> > the response is forwarded, and 3261 also shows message 
> examples where 
> > the Via received parameter is shown in the response, 
> eventhough it did 
> > not exist in the request.
> >
> > request must be identical in the response, but additional 
> parameters 
> > may be added. But, that is not clear in the text.
> >
> > Regards,
> >
> > Christer
> >
> >
> > This list is for NEW development of the core SIP Protocol Use 
> > [email-masked] for questions on current sip Use 
> > [email-masked] for new developments on the application of sip
> 
>

---

From: Robert Sparks <[email-masked]>
Date: Tue, 3 Apr 2007 22:36:14 -0500

To make sure I understand: You know of an implementation that gets  
upset because it receives a response that has a received parameter in  
the topmost via.
I will capture a bug to make sure we look for places to make this  
clearer going forward.

I will note that there _is_ text that establishes that a requestor  
must be ready to see a such a received parameter in the response.

For instance, the last sentence on page 119:
"In particular, the proxy MUST NOT remove any "received" parameter it  
may have added to the next Via header field value while processing  
the request associated with this response."

But as I note, we'll watch for the opportunity to make it even more  
obvious.

RjS

---

From: "Christer Holmberg \(JO/LMF\)" <[email-masked]>
Date: Wed, 4 Apr 2007 08:16:55 +0200

Hi, 

>To make sure I understand: You know of an implementation that 
>gets upset because it receives a response that has a received 
>parameter in the topmost via.

Yes. I was told that the implementation requires the Via in the response
to be identical to the Via in the request, and does not accept the
response since a received parameter has been added to the Via header.

>I will capture a bug to make sure we look for places to make 
>this clearer going forward.
> 
>I will note that there _is_ text that establishes that a 
>requestor must be ready to see a such a received parameter in 
>the response.
> 
>"In particular, the proxy MUST NOT remove any "received" 
>parameter it may have added to the next Via header field 
>value while processing the request associated with this response."
> 
>But as I note, we'll watch for the opportunity to make it 
>even more obvious.

Great.

I think it's the text in chapter 8.2.6.2 that needs to be modified - or
removed completely.

Regards,

Christer

> > I have been made aware of an implementation that most 
> likely does have 
> > a problem with this, so a clarification would be useful.
> >
> > Regards,
> >
> > Christer
> >
> >> of responses (when received is added).
> >> There is no requirement to remove it from the topmost via of the 
> >> response. We can capture this as something to clarify.
> >>
> >> RjS
> >>

---

From: "Christer Holmberg \(JO/LMF\)" <[email-masked]>
Date: Wed, 4 Apr 2007 08:19:12 +0200

One more thing...

>value while processing the request associated with this response."

That applies to an UAS also.

Regards,

Christer