Subject: RE: Poll: Do we have sips/sip retageting in the wild (was Re: [Sip] RE:Securing Other URI (Tel URI) scheme)

From: "Charles Eckel \(eckelcu\)" <[email-masked]>
Date: Mon, 16 Apr 2007 14:44:35 -0700

Sorry for the late response, but the Cisco SIP Proxy Server (CSPS)
allowed for retargeting from sips to sip. Whether or not to allow this
is configurable, and it is disabled by default.
I do not recall what we did in terms of sip to sips, but I think we
allowed it as well. This was done in 2003 and not changed since as far
as I know. 

Cheers,
Charles 

> -----Original Message-----
> From: Dean Willis [mailto:[email-masked]] 
> Sent: Thursday, March 29, 2007 12:12 PM
> To: IETF SIP List
> Subject: Poll: Do we have sips/sip retageting in the wild 
> (was Re: [Sip] RE:Securing Other URI (Tel URI) scheme)
> 
> 
> On Mar 29, 2007, at 12:01 PM, Francois Audet wrote:
> 
> > I don't agree.
> >
> > I think this is theoretical. I don't believe proxies that "upgrade"
> > from SIP to SIPS using a retargeting exist in nature. And 
> if they did,
> > they
> > would likely break stuff, or have some assumptions that makes them
> > essentially proprietary. It just doesn't work except for some very
> > narrow sceanrios (e.g., transactions that don't create a dialog, or
> > dialogs
> > with double Record-Route used at the retargeting point, along with
> > endpoints that
> > don't understand SIPS but somehow don't choke on the 
> scheme, use of  
> > SIP
> > outbound
> > which is not standard yet, etc.). Same applies for downgrades.
> >
> > So to me, it's a non-issue.
> >
> > From a standard's purist dreamland point of view, we could define
> > this extension: it would not "break" anything. It would just make
> > the spec more complicated for no good reason.
> 
> I used to have a proxy at the house that would retarget inbound from  
> sips to sip to let my old 3Com phone work. It would also 
> retarget sip  
> to sips outbound so I could call sips (said proxy is why I insisted  
> on last-hop exception in 3261). Such proxies do exist.
> 
> The good news is, I don't use it anymore (the bad news is I don't  
> have a working SIP phone at home right now).
> 
> So (Chair Hat on): Anybody else out there have a proxy currently (or  
> planned to be) in use that retargets sip to sips or vice versa?
> 
> If we can't come up with any, I suppose I'd be willing to 
> concede the  
> issue as "fixing an improbable problem"
> 
> --
> Dean
> 
> 
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip
> 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Samir Srivastava" <[email-masked]>
Date: Tue, 17 Apr 2007 14:13:20 -0500

Hi Charles,

   If it is not confidential, could you please share with the group
whether users of CSPS USED the SIPS. As it was implemented in 2003 and
if it is being used heavily, then we MUST be seeing atleast couple of
the issues coming from SIPS much earlier.

Thx
Samir 

>From: Charles Eckel (eckelcu) [mailto:[email-masked]] 
>Sent: Monday, April 16, 2007 2:45 PM
>To: Dean Willis; IETF SIP List
>Subject: RE: Poll: Do we have sips/sip retageting in the wild 
>Sorry for the late response, but the Cisco SIP Proxy Server 
>(CSPS) allowed for retargeting from sips to sip. Whether or 
>not to allow this is configurable, and it is disabled by default.
>I do not recall what we did in terms of sip to sips, but I 
>think we allowed it as well. This was done in 2003 and not 
>changed since as far as I know. 
>
>Cheers,
>Charles 
>
>> Subject: Poll: Do we have sips/sip retageting in the wild (was Re: 
>> [Sip] RE:Securing Other URI (Tel URI) scheme)
>> 
>> 
>> > dialogs with double Record-Route used at the retargeting point, 
>> > along with endpoints that don't understand SIPS but somehow don't 
>> > choke on the
>> scheme, use of
>> > SIP
>> > outbound
>> to sips outbound so I could call sips (said proxy is why I 
>insisted on 
>> last-hop exception in 3261). Such proxies do exist.
>> 
>> The good news is, I don't use it anymore (the bad news is I 
>don't have 
>> a working SIP phone at home right now).
>> 
>> This list is for NEW development of the core SIP Protocol Use 
>> [email-masked] for questions on current sip Use 
>> [email-masked] for new developments on the application of sip
>> 
>
>This list is for NEW development of the core SIP Protocol Use 
>[email-masked] for questions on current sip

---

From: "Francois Audet" <[email-masked]>
Date: Tue, 17 Apr 2007 14:28:05 -0500

That would be the rationale for supporting the option tag.

(i.e., for open issue number 2).

Thanks. 

> From: Srivastava, Samir (SC100:8826) 
> Sent: Tuesday, April 17, 2007 12:13
> To: Charles Eckel (eckelcu); Dean Willis; IETF SIP List
>    If it is not confidential, could you please share with the 
> group whether users of CSPS USED the SIPS. As it was 
> implemented in 2003 and if it is being used heavily, then we 
> MUST be seeing atleast couple of the issues coming from SIPS 
> much earlier.
> 
> Thx
> Samir 
> 
> >Subject: RE: Poll: Do we have sips/sip retageting in the 
> wild (was Re: 
> >(CSPS) allowed for retargeting from sips to sip. Whether or not to 
> >allow this is configurable, and it is disabled by default.

---

From: "Charles Eckel \(eckelcu\)" <[email-masked]>
Date: Tue, 17 Apr 2007 12:58:49 -0700

I do not think this TLS functionality is being used heavily outside of
SIPits and some very well constrained environments.

Cheers,
Charles

> From: Francois Audet [mailto:[email-masked]] 
> Sent: Tuesday, April 17, 2007 12:28 PM
> To: Samir Srivastava; Charles Eckel (eckelcu); Dean Willis; 
> IETF SIP List
> think we

---

From: "Samir Srivastava" <[email-masked]>
Date: Tue, 17 Apr 2007 17:34:57 -0500

When SIP entities need to be upgraded for the to be defined new OPTION
tag for SIPS to be working in kludge way, then why don't we do it in a
completely neat way using Proxy-Require/Require etc. This stop gap
measure (without support of tel,im,pres security and other issues which
I talked earlier too, don't want to repeat here again), doesn't serve
much purpose for the end user. This is consuming a lot of group cycles,
which will not be used in a long run. I have my own doubts, how many new
vendors will be implementing this half naked stuff. It looks to me this
group is fond of text processing.

Thx
Samir

>From: Audet, Francois (SC100:3055) 
>To: Srivastava, Samir (SC100:8826); Charles Eckel (eckelcu); 
>Dean Willis; IETF SIP List
>(was Re:

---

From: Cullen Jennings <[email-masked]>
Date: Tue, 17 Apr 2007 18:20:09 -0700

people have answered this question to you multiple times in the past  
- I don't know what else to say.

---

From: "Francois Audet" <[email-masked]>
Date: Wed, 18 Apr 2007 13:19:31 -0500

Charles,

Do you have an opinion on "should we have the option tag or not"?

So far we have had 3 people with opinions (including myself who changed
opinion
once already).

Dean & I believe we should have the option-tag.
Hisham  believes we don't (he sees the draft as "correcting" RFC 3261).

Not sure how strongly opiniated are Dean and Hisham on the issue.
I personally won't loose any sleep over it.

Off the list, I've heard that the option-tag is useful with
Proxy-Require if you
want to absolutely enforce the deprecation of the last-hop exception
rule for 
example. Otherwise, you have no garantee. 

I also don't think there is a huge installed base of SIPS
implementations to worry
about, but the "just in case factor" should not be discounted. At least
not from a standards writing process perspective.

Other opinions welcome...

> Sent: Tuesday, April 17, 2007 12:59
> To: Audet, Francois (SC100:3055); Srivastava, Samir 
> (SC100:8826); Dean Willis; IETF SIP List
> I do not think this TLS functionality is being used heavily 
> outside of SIPits and some very well constrained environments.
> 
> Cheers,
> Charles
> 
> IETF SIP 
> > List
> wild (was 
> > > Re: [Sip] RE:Securing Other URI (Tel URI) scheme)
> > > 
> > > Hi Charles,
> > > 
> > > whether users of CSPS USED the SIPS. As it was 
> implemented in 2003 
> > > and if it is being used heavily, then we MUST be seeing atleast 
> > > couple of the issues coming from SIPS much earlier.
> > > 
> > > Thx
> > > Samir
> > >

---

From: "Charles Eckel \(eckelcu\)" <[email-masked]>
Date: Wed, 18 Apr 2007 16:08:33 -0700

Yes, the option-tag looks worthwhile to me.

Thanks,
Charles 

> Sent: Wednesday, April 18, 2007 11:20 AM
> To: Charles Eckel (eckelcu); Dean Willis; IETF SIP List; 
> Hisham Khartabil
> Subject: draft-ietf-sip-sips-03: option-tag or not
> 
> Charles,
>