Subject: [Sip] MIME: External-body body types

From: "Christer Holmberg (JO/LMF)" <[email-masked]>
Date: Wed, 30 May 2007 11:14:55 +0200

Hi,

One thing I think we should study a little more is the usage of
'external-body'.

It can be used to indicate references to bodies located elsewhere then
in the SIP message itself, so maybe there could be some potential usage
for it. 

We also have SIP headers (e.g. Alert-Info) which can be used for similar
things, so...

If we don't want to allow it, it would be good to also explicitly add it
to the list of body types which would require an option-tag.

Regards,

Christer
_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Gonzalo Camarillo <[email-masked]>
Date: Wed, 30 May 2007 12:16:43 +0300

Hi Christer,

external body is not a multipart subtype. It it a message subtype. This 
draft deals with multipart subtypes.

Cheers,

Gonzalo

---

From: "Christer Holmberg (JO/LMF)" <[email-masked]>
Date: Wed, 30 May 2007 11:20:02 +0200

Correct. Sorry for that.

I guess the same applies to my other mail regarding the partial subtype.

The question is whether we also need to say something about message
subtypes, but if we think it should be done in another document I won't
argue against that.

Regards,

Christer 

> -----Original Message-----
> From: Gonzalo Camarillo [mailto:[email-masked]] 
> Sent: 30. toukokuuta 2007 12:17
> To: Christer Holmberg (JO/LMF)
> Cc: [email-masked]
> Subject: Re: MIME: External-body body types
> 
> Hi Christer,
> 
> external body is not a multipart subtype. It it a message 
> subtype. This draft deals with multipart subtypes.
> 
> Cheers,
> 
> Gonzalo
> 
> 
> 
> > in the SIP message itself, so maybe there could be some potential 
> > usage for it.
> > 
> > We also have SIP headers (e.g. Alert-Info) which can be used for 
> > similar things, so...
> > 
> > If we don't want to allow it, it would be good to also 
> explicitly add 
> > it to the list of body types which would require an option-tag.
> > 
> > Regards,
> > 
> > Christer
> > 
> 
>