Subject: [Sip] Treatment of ACK for 2xx final response

From: "Kadirvelu, Kannan \(Kanna\)" <[email-masked]>
Date: Thu, 31 May 2007 23:30:36 +0530

Hi All,

We require some clarity on ACK processing on the UA server side. 

Consider the following scenario : 

A -- INVITE ----> B
A <-- 200 OK ---- B
A -- ACK -------> B

A, B are SIP UAs. 

In the above example, the SIP server A sent the ACK with same branch ID
as that of INVITE. We know clearly A is in error. However we are not
clear on what should be the behavior of B. Should the transaction layer
of B absorb this ACK or send it to TU ? 

Please help.

Regards,
Kannan

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Nayak, Subhransu S" <[email-masked]>
Date: Thu, 31 May 2007 16:44:52 -0400

The Invite Server transaction is completed as soon as the server on B sends 200 OK to the original INVITE. ACK to 2XX response is considered a separate transaction and in this case should be forwarded to TU by the transaction layer. 

Now if your question is whether the TU should honor this ACK and stop re-transmitting 200 response, RFC 3261 is not clear about this. based on your implementation the TU may choose to ignore this ACK with incorrect branch and continue to retransmit 200 OK until an ACK with valid branch is received or, there is a timeout ( 64 * T1 ).

-----Original Message-----
From: Kadirvelu, Kannan (Kanna) [mailto:[email-masked]]
Sent: Thursday, May 31, 2007 2:01 PM
To: [email-masked]
Subject: [Sip] Treatment of ACK for 2xx final response

Hi All,

A -- INVITE ----> B
A <-- 200 OK ---- B
A -- ACK -------> B

A, B are SIP UAs. 

Please help.

Regards,
Kannan