Subject: [Sip] draft-ietf-sip-sips-05.txt - comment on response codes 418 and 419

From: "Attila Sipos" <[email-masked]>
Date: Mon, 9 Jul 2007 08:51:23 +0100

This draft specifies two new response codes:

418 SIPS Not Allowed
419 SIPS Required

With sipsec around the corner shouldn't we make
these headers more generic like we do for other
SIP things?

For example, if someone uses a method we don't allow
then we return "405 Method Not Allowed" and then
list the allowed methods in the Allow header.
And there is a similar solution for SIP extensions
(420 Bad Extension or 421 Extension Required).

So how about:
418 URI Scheme Not Allowed
Allow-URI: sip

419 URI Scheme Required
Require-URI: sips,sipsec

In fact, you probably only need one of them as they are
almost identical in resultant behaviour.

Regards,

Attila

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Francois Audet" <[email-masked]>
Date: Mon, 16 Jul 2007 15:48:51 -0500

My personal opinion is that those are good suggestions. But it does mean
2 new headers as well. I also like the idea of having only one response
code (i.e., 418 Invalid URI scheme).

Any other opinions?

I will flag this as a remaining issue in Chicago.

> -----Original Message-----
> From: Attila Sipos [mailto:[email-masked]] 
> Sent: Monday, July 09, 2007 00:51
> To: [email-masked]
> Subject: [Sip] draft-ietf-sip-sips-05.txt - comment on 
> response codes 418 and 419
> 
> 
> With sipsec around the corner shouldn't we make these headers 
> more generic like we do for other SIP things?
> 
> For example, if someone uses a method we don't allow then we 
> return "405 Method Not Allowed" and then list the allowed 
> methods in the Allow header.
> And there is a similar solution for SIP extensions (420 Bad 
> Extension or 421 Extension Required).
> 
> So how about:
> This list is for NEW development of the core SIP Protocol Use 
> [email-masked] for questions on current sip