Subject: RE: [Sip] Doubt about ACK and BYE

From: "Attila Sipos" <[email-masked]>
Date: Wed, 25 Jul 2007 08:15:38 +0100

It is some configuration issue (or maybe a bug) in the SIP client 1 I
think.
 
Once the call is established and the route has been learnt (using
Record-Route), any new
requests should only be sent to the proxies on that learnt route.
Unfortunately I have heard that some SIP clients break this rule and
send EVERY message to
the outbound proxy even when the outbound proxy did not add a
Record-Route header.
 
>>Could you anyone clarify that how can i send ACK and BYE messages to
Registered proxy2 instead outbound proxy1?
Of course, it should only get sent to proxy 2 if proxy 2 had added a
Record-Route.
Like I say, to fix the problem, I think it's either a bug or
configuration issue for SIP client 1.
 
Regards,

Attila

________________________________

From: sengottuvelan srirangan [mailto:[email-masked]] 
Sent: 25 July 2007 06:15
To: [email-masked]
Subject: [Sip] Doubt about ACK and BYE 

Hi SIP-experts,
 
I have doubt in a specific Scenario where SIP client is set to send
INVITE messages via outbound proxy. The setup is like below:
SIP-client 1---------------------------SIP
outbound---------------------SIP proxy2---------------SIP client2
                                           &n! bsp;    proxy1
 
Here SIP client1 is registered with Proxy2 and set outbound proxy as
proxy1. Outbound proxy1 is set not to include its ip address in the
Record-Route header. After SIP 200 OK message is received in SIP-client1
which is still sending ACK and BYE messages via outbound proxy1 instead
proxy2.
 
Could you anyone clarify that how can i send ACK and BYE messages to
Registered proxy2 instead outbound proxy1?
 
Regards
Sengottuvelan

________________________________

Shape Yahoo! in your own image. Join our Network Research Panel today!
<http://us.rd.yahoo.com/evt=48517/*http://surveylink.yahoo.com/gmrs/yaho
o_panel_invite.asp?a=7>  
_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: sengottuvelan srirangan <[email-masked]>
Date: Wed, 25 Jul 2007 05:43:44 -0700 (PDT)

Hi Attila,
   
  The problem is got fixed after changing the client1(as you suggested).
   
  Thanks.
   
  Regards
  Sengottuvelan

Attila Sipos <[email-masked]> wrote:
       
  It is some configuration issue (or maybe a bug) in the SIP client 1 I think.
   
  Once the call is established and the route has been learnt (using Record-Route), any new
  requests should only be sent to the proxies on that learnt route.
  Unfortunately I have heard that some SIP clients break this rule and send EVERY message to
  the outbound proxy even when the outbound proxy did not add a Record-Route header.
   
  >>Could you anyone clarify that how can i send ACK and BYE messages to Registered proxy2 instead outbound proxy1?
  Of course, it should only get sent to proxy 2 if proxy 2 had added a Record-Route.
  Like I say, to fix the problem, I think it's either a bug or configuration issue for SIP client 1.
   
  Regards,
  
Attila

---------------------------------
  From: sengottuvelan srirangan [mailto:[email-masked]] 
Sent: 25 July 2007 06:15
To: [email-masked]
Subject: [Sip] Doubt about ACK and BYE 

  Hi SIP-experts,
   
  I have doubt in a specific Scenario where SIP client is set to send INVITE messages via outbound proxy. The setup is like below:

  SIP-client 1---------------------------SIP outbound---------------------SIP proxy2---------------SIP client2
                                             &n! bsp;    proxy1
   
  Here SIP client1 is registered with Proxy2 and set outbound proxy as proxy1. Outbound proxy1 is set not to include its ip address in the Record-Route header. After SIP 200 OK message is received in SIP-client1 which is still sending ACK and BYE messages via outbound proxy1 instead proxy2.
   
  Could you anyone clarify that how can i send ACK and BYE messages to Registered proxy2 instead outbound proxy1?
   
  Regards
  Sengottuvelan

    
---------------------------------
  Shape Yahoo! in your own image. Join our Network Research Panel today! 

---------------------------------
Boardwalk for $500? In 2007? Ha! 
Play Monopoly Here and Now (it's updated for today's economy) at Yahoo! Games.