Subject: [Sip] Open issue in the hitchhikers guide - seriously! Relation to essential corrections

From: Jonathan Rosenberg <[email-masked]>
Date: Thu, 05 Jul 2007 16:18:13 -0400

I was working on my regular update to the sip hitchhikers guide:
http://www.ietf.org/internet-drafts/draft-ietf-sip-hitchhikers-guide-02.txt

and ran into an issue. We are now pursuing the SIP essential corrections 
process:
http://www.ietf.org/internet-drafts/draft-drage-sip-essential-correction-01.txt

which has begun to produce internet drafts, that are draft-ietf-sip-XXX, 
which will be tracked and produced by the working group. The question 
is, do these drafts get included into the hitchhikers guide or not. My 
view on this, is NO, they do not. The reason is that these drafts will 
never reach RFC, only the collected essential correction RFC. So, once 
that first RFC is produced, the hitchhikers guide would reference that, 
and that would encompass everything.

So, in the interim, what I'd propose is that the running I-D version of 
hitchhikers guide have an "essential corrections" draft, which in fact 
references all of the I-Ds currently in line for essential correction. 
Unfortunately, its not clear which drafts those are. record-route-fix, 
yes. What about loop-fix? Is that going in? It would be convenient to 
have a way of clearly knowing what drafts are going to be for essential 
corrections. Is the rule:

draft-ietf-sip-*-fix

are drafts targeted for essential correction? If so, I think that should 
be clearly stated in the drage-essential-corrections draft.

Thanks,
Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.                   600 Lanidex Plaza
Cisco Fellow                                   Parsippany, NJ 07054-2711
Cisco Systems
[email-masked]                              FAX:   (973) 952-5050
http://www.jdrosen.net                         PHONE: (973) 952-5000
http://www.cisco.com

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "DRAGE, Keith \(Keith\)" <[email-masked]>
Date: Tue, 10 Jul 2007 19:03:26 +0200

Your proposal as to what goes into the hitchhiker's guide sounds sensible to me. 

I will take the comment about the file nameing convention into the next version of my essential-corrections draft. Proposals for a naming convention welcome; if no alternatives I will use something based on what Jonathan suggests below. I see only two issues:

-	we seem to be unable to decide what is a fix and what is not. If we make a decision that something is a fix after the -00 version, we need to decide whether the continuity of the existing nameing has priority or the convention of having -fix in the name.

-	there are already a number of candidate drafts, which obviously do not yet follow this convention. Again we need to decide whether to keep the continuity of the existing naming or not.

In regard to the fork-loop-fix, this needs to be rediscussed in the WG and has agenda time at the forthcoming meeting.

We are looking to get a website or WIKI up that clearly indicates what is in progress.

Regards

Keith

> -----Original Message-----
> From: Jonathan Rosenberg [mailto:[email-masked]] 
> Sent: Thursday, July 05, 2007 9:18 PM
> To: IETF SIP List
> Subject: [Sip] Open issue in the hitchhikers guide - 
> seriously! Relation to essential corrections
> 
> which has begun to produce internet drafts, that are 
> draft-ietf-sip-XXX, which will be tracked and produced by the 
> working group. The question is, do these drafts get included 
> into the hitchhikers guide or not. My view on this, is NO, 
> they do not. The reason is that these drafts will never reach 
> RFC, only the collected essential correction RFC. So, once 
> that first RFC is produced, the hitchhikers guide would 
> reference that, and that would encompass everything.
> 
> So, in the interim, what I'd propose is that the running I-D 
> version of hitchhikers guide have an "essential corrections" 
> draft, which in fact references all of the I-Ds currently in 
> line for essential correction. 
> Unfortunately, its not clear which drafts those are. 
> record-route-fix, yes. What about loop-fix? Is that going in? 
> It would be convenient to have a way of clearly knowing what 
> drafts are going to be for essential corrections. Is the rule:
> 
> draft-ietf-sip-*-fix
> 
> are drafts targeted for essential correction? If so, I think 
> that should be clearly stated in the 
> drage-essential-corrections draft.
> 
> Thanks,
> Jonathan R.
> 
> -- 
> This list is for NEW development of the core SIP Protocol Use 
> [email-masked] for questions on current sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 11 Jul 2007 09:20:29 -0400

DRAGE, Keith (Keith) wrote:
> I will take the comment about the file nameing convention into the
> next version of my essential-corrections draft. Proposals for a
> naming convention welcome; if no alternatives I will use something
> based on what Jonathan suggests below. I see only two issues:
> 
> -	we seem to be unable to decide what is a fix and what is not. If we
> make a decision that something is a fix after the -00 version, we
> need to decide whether the continuity of the existing nameing has
> priority or the convention of having -fix in the name.

I think the convention has priority. SO if we decide its not a fix, it 
gets renamed.

> 
> -	there are already a number of candidate drafts, which obviously do
> not yet follow this convention. Again we need to decide whether to
> keep the continuity of the existing naming or not.

I favor the convention.

-Jonathan R.

---

From: "DRAGE, Keith \(Keith\)" <[email-masked]>
Date: Thu, 12 Jul 2007 14:07:39 +0200

I will be following this in the next version of draft-drage-sip-essential-correction unless I hear otherwise from the list.

Keith 

> Sent: Wednesday, July 11, 2007 2:20 PM
> To: DRAGE, Keith (Keith)
> Cc: IETF SIP List
> Subject: Re: [Sip] Open issue in the hitchhikers guide - 
> > next version of my essential-corrections draft. Proposals 
> for a naming 
> > convention welcome; if no alternatives I will use something 
> based on 
> > what Jonathan suggests below. I see only two issues:
> > 
> > make a decision that something is a fix after the -00 
> version, we need 
> > to decide whether the continuity of the existing nameing 
> has priority 
> > or the convention of having -fix in the name.
> 
> I think the convention has priority. SO if we decide its not 
> a fix, it gets renamed.
> 
> >