Subject: [Sip] Event - list subscribe

From: "vishal jogi" <[email-masked]>
Date: Thu, 19 Jul 2007 13:00:27 +0530

Hi,
I have one doubt.

i m subscribing to RLS uri,
which is refering one Resource-list which doesn't have any <entry>
mean it's blank <LIST>

server is sending 404 as response for Subscribe, can anyone tell me it's
correct behaviour of server,
as that <LIST> is existing

Thanks,
Vishal...
_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Vikram Chhibber" <[email-masked]>
Date: Thu, 19 Jul 2007 14:24:53 +0530

I don't think that this is correct behavior of the RLS. If the RLS
understands the uri pointing to a resource-list. It should accept this
subscription. Even though the list is empty. The user/administrator
may provision entries in this list in future by non-SIP mechanism
(XCAP).

On 7/19/07, vishal jogi <[email-masked]> wrote:
> Sip mailing list
> https://www1.ietf.org/mailman/listinfo/sip

---

From: "vishal jogi" <[email-masked]>
Date: Fri, 20 Jul 2007 10:37:43 +0530

Hi Vikram,

I have checked draft-ietf-simple-event-list-07, but it doesn't specify
anything about this case,
is there any draft or RFC which will give exact idea about it??

Thanks,
Vishal...

 On 7/19/07, Vikram Chhibber <[email-masked]> wrote:
> On 7/19/07, vishal jogi < [email-masked]> wrote:
> > Hi,
> > I have one doubt.
> >

---

From: "Hisham Khartabil" <[email-masked]>
Date: Thu, 26 Jul 2007 15:09:17 +1000

This is incorrect behaviour by the RLS. The list certainly exists. It just
happens to be empty. A 2xx response to the SUBSCRIBE followed by a NOTIFY
with the appropriate payload is what I would consider to be the correct
behaviour.

Thanks,
Hisham