Subject: [Sip] Sending SIP packet over TCP

From: Rathod Subhashchandra <[email-masked]>
Date: Mon, 16 Jul 2007 19:44:53 +0530 (IST)

Hi Guys,

I am facing a problem in following scenario on WinCE 5.0. Please let me know if you got an answer for this ASAP.

In SIP Client
1.  I have opened server TCP and UDP on 5060 port for polling responses aswell as request
2.  To send a SIP packet, I have opened a TCP client socket 5060 for destination. I got a socket descriptor as 9

SIP request goes on dest port as 5060, src port as 1997.
Server is responding on src port 1997. Hence my polling is failing as it is for TCP and UDP sockets.

Src port 1997 is not constant. It is just random. for me to poll, I need socket descriptor. How to get this logical port number given TCP? If I can get this, I can create a socket and get the descriptor and add to polling list

Waiting a quick response if possible.

Thanks !
Rathod.

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Attila Sipos" <[email-masked]>
Date: Mon, 16 Jul 2007 15:38:52 +0100

If you got socket descriptor 9 when creating the socket, and to
poll you need the socket descriptor (and if you really need to poll)
then poll socket descriptor 9.
Or is this not possible?

Regards,
Attila

-----Original Message-----
From: Rathod Subhashchandra [mailto:[email-masked]] 
Sent: 16 July 2007 15:15
To: [email-masked]
Cc: [email-masked]
Subject: [Sip] Sending SIP packet over TCP

Hi Guys,

I am facing a problem in following scenario on WinCE 5.0. Please let me
know if you got an answer for this ASAP.

In SIP Client
1.  I have opened server TCP and UDP on 5060 port for polling responses
aswell as request 2.  To send a SIP packet, I have opened a TCP client
socket 5060 for destination. I got a socket descriptor as 9

SIP request goes on dest port as 5060, src port as 1997.
Server is responding on src port 1997. Hence my polling is failing as it
is for TCP and UDP sockets.

Src port 1997 is not constant. It is just random. for me to poll, I need
socket descriptor. How to get this logical port number given TCP? If I
can get this, I can create a socket and get the descriptor and add to
polling list

Thanks !
Rathod.

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol Use
[email-masked] for questions on current sip Use
[email-masked] for new developments on the application of sip