Subject: Re: [Sip] INFO

From: "Eric Burger" <[email-masked]>
Date: Mon, 10 Sep 2007 13:26:23 -0700

Precisely. To be blunt, one would be "less than smart" to use either KPML or INFO for any interactive voice response application.

INFO doesn't route by default. You have to *hope* your softswitch, SBC, or other B2BUA in the way knows to relay the INFO. At least most of those elements knows to relay pub/sub.

Both KPML and INFO have the proxy latency penalty, making for a piss-poor user experience.  

While we're at it, let's transport voice in SIP ;-)

--
Sent from my wireless e-mail device. Sorry if terse.  We all need lemonade: see <http://www.standardstrack.com/ietf/lemonade> for what lemonade is.

----- Original Message -----
From: Francois Audet <[email-masked]>
To: Hadriel Kaplan <[email-masked]>; Brian Stucker <[email-masked]>; Eric Burger
Cc: sip <[email-masked]>
Sent: Mon Sep 10 13:08:58 2007
Subject: RE: [Sip] INFO

Ah.... Good point. Hadn't tought of that.

In any case, I'm not sure voicemail is the best example. Seems to me
you are more likely to use RFC 2833 for voicemail, since it's a 
media server. Furthermore, you'll for sure be dealing with people 
leaving voicemails that are NOT SIP users and would be going through
a generic PSTN-SIP gateway (which would do RFC 2833).

I'd think that KPML is more useful for features that don't terminate
media, like the Calling card example, or *gasp* invocation of feature 
codes, and where the end-user device is known to be a SIP phone.

> -----Original Message-----
> From: Hadriel Kaplan [mailto:[email-masked]] 
> Sent: Monday, September 10, 2007 12:42
> To: Audet, Francois (SC100:3055); Stucker, Brian 
> (RICH1:AR00); 'Eric Burger'
> Cc: 'sip'
> Subject: RE: [Sip] INFO
> 
> But most calls to a voicemail server DON'T actually use DTMF, 
> I've been told
> - since most calls to a vmail server are to leave messages.  
> Calls to retrieve voicemail do always use dtmf, but calls to 
> leave voicemail don't.
> However calls to leave voicemail usually have the optional 
> ability for the caller to send DTMF - for example pressing 
> "*" and then the passcode to retrieve voicemail, or "0" to 
> reach an attendant, or some button to cancel the recording, 
> etc.  Only a fraction of those calls actually end up with 
> someone pressing a dtmf button, but because you *could* press 
> dtmf, the vmail server would have to KPML subscribe for all calls.

Notice:  This email message, together with any attachments, may contain information  of  BEA Systems,  Inc.,  its subsidiaries  and  affiliated entities,  that may be confidential,  proprietary,  copyrighted  and/or legally privileged, and is intended solely for the use of the individual or entity named in this message. If you are not the intended recipient, and have received this message in error, please immediately return this by email and then delete it.

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Brian Stucker" <[email-masked]>
Date: Mon, 10 Sep 2007 15:38:53 -0500

> From: Eric Burger [mailto:[email-masked]] 
> Sent: Monday, September 10, 2007 3:26 PM
> To: Audet, Francois (SC100:3055); [email-masked]; 
> Stucker, Brian (RICH1:AR00)
> Cc: [email-masked]
> Subject: Re: [Sip] INFO
> 
> Precisely. To be blunt, one would be "less than smart" to use 
> either KPML or INFO for any interactive voice response application.
> 
> INFO doesn't route by default. You have to *hope* your 
> softswitch, SBC, or other B2BUA in the way knows to relay the 
> INFO. At least most of those elements knows to relay pub/sub.
> 

Can you idenitfy ANY IVR application that people didn't think it was a
poor user experience? Yeah, IVR jail. Wheee...

> Sent from my wireless e-mail device. Sorry if terse.  We all 
> need lemonade: see 
> <http://www.standardstrack.com/ietf/lemonade> for what lemonade is.
> 
> In any case, I'm not sure voicemail is the best example. 
> Seems to me you are more likely to use RFC 2833 for 
> voicemail, since it's a media server. Furthermore, you'll for 
> sure be dealing with people leaving voicemails that are NOT 
> SIP users and would be going through a generic PSTN-SIP 
> gateway (which would do RFC 2833).
> 
> I'd think that KPML is more useful for features that don't 
> terminate media, like the Calling card example, or *gasp* 
> invocation of feature codes, and where the end-user device is 
> known to be a SIP phone.
> 
> 
> Notice:  This email message, together with any attachments, 
> may contain information  of  BEA Systems,  Inc.,  its 
> subsidiaries  and  affiliated entities,  that may be 
> confidential,  proprietary,  copyrighted  and/or legally 
> privileged, and is intended solely for the use of the 
> individual or entity named in this message. If you are not 
> the intended recipient, and have received this message in 
> error, please immediately return this by email and then delete it.
>