Subject: [Sip] No RTP Data receiving

From: "Guenther Sohler" <[email-masked]>
Date: Thu, 13 Sep 2007 19:38:44 +0200

Dear Group!

I have been programming a state machine to register and call somebody(the test account of my sip provider)

But it does not send me RTP Data

Please find attached the log. Remarkable the proxy does send me the SIP 200 OK repeatedly. it seems it is not happy with my ACK Statement.

If i manually create udp packets with "nc -u" to  192.168.10.2 it works out!

I have got an internet connection with a small server which does nat to an internal network. in this internal network, there is a Hardware SIP Phone, which completely works, and my PC where i try to code this SIP Sample.

Can anybody inspect the log and tell me if there are errors.

Thank you in advance!

-- 
Der GMX SmartSurfer hilft bis zu 70% Ihrer Onlinekosten zu sparen! 
Ideal für Modem und ISDN: http://www.gmx.net/de/go/smartsurfer
_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "STAELENS Nadine" <[email-masked]>
Date: Fri, 14 Sep 2007 09:13:27 +0200

Hi,

This is a question for the sip-implementors list.

Have a look at your Call-Id in the ACK!

Regards,
  Nadine.

-----Original Message-----
From: Guenther Sohler [mailto:[email-masked]] 
Sent: donderdag 13 september 2007 19:39
To: [email-masked]
Subject: [Sip] No RTP Data receiving

Dear Group!

Thank you in advance!