Subject: Re: [Sip] Request to consider media control framework and requirements

From: "Hisham Khartabil" <[email-masked]>
Date: Thu, 14 Feb 2008 17:38:41 +1100

My opinion is that those requirements need to go to sipping first for
discussion as sipping is, as I understand it, chartered to agree on
requirements before any extension work is taken up by the sip wg.

Thanks,
Hisham

On 01/02/2008, Dean Willis <[email-masked]> wrote:
>
>
> The media control group has produced a requirements-oriented draft
> that they would like to meet with SIP, and would like the SIP working
> group to take on the work of meeting those requirements.
>
> Here's a link to the draft:
>
> http://tools.ietf.org/html/draft-ietf-mediactrl-sip-control-framework-00
>
>
> Do you folks think these requirements are sufficiently cooked to work
> with, or do we need to punt this football back to the senders or
> perhaps lateral it to SIPPING for a little more thought?
>
> --
> Dean
> _______________________________________________
> Sip mailing list  http://www.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip
>
_______________________________________________
Sip mailing list  http://www.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "DRAGE, Keith \(Keith\)" <[email-masked]>
Date: Thu, 14 Feb 2008 19:18:07 +0100

The SIP, SIPPING and MEDIACTRL chairs (or at least a representative collection of them) did get together to consider this issue, and decided that as the work (as currently proposed) did not in fact extend SIP, that MEDIACTRL should retain the work. 

SDP extensions are proposed to MMUSIC, and that would appear to be appropriate.

At some point when the work is complete enough for review, it was agreed that RAI wide review of this document should occur, and one of the review experts in the SIP WG will be jumped on at that point to review the solution.

We did not discuss whether the solution adopted by the draft was the correct solution - if people in the SIP WG have concerns, then please address them to the MEDIACTRL WG. If you are not participants in that WG then we (the SIP chairs) will be pleased to forward on comments.

Regards

Keith

PS: My understanding of the various charters is that SIP does not generate requirements for development of SIP, except in the security area. However it can charter work based on requirements from any appropriate working group, which includes among others, both SIPPING and MEDIACTRL. I suspect the ADs would want to be confident that the appropriate experts had contributed to the appropriate requirements.

________________________________

	From: [email-masked] [mailto:[email-masked]] On Behalf Of Hisham Khartabil
	Sent: Thursday, February 14, 2008 6:39 AM
	To: Dean Willis
	Cc: IETF SIP List
	Subject: Re: [Sip] Request to consider media control framework andrequirements

	My opinion is that those requirements need to go to sipping first for discussion as sipping is, as I understand it, chartered to agree on requirements before any extension work is taken up by the sip wg.
	 
	Thanks,
	Hisham