Subject: [Sip] SIPS over NAT and Firewalls

From: "PAVAN KUMAR O" <[email-masked]>
Date: Wed, 27 Feb 2008 15:33:15 +0530

Hi all,

       I am Pavan.I am working on implementing security features for SIP on
a Voip enabled phone.\
1) I am bit confused with the implementation of "sips" scheme and the
necessary changes to be made in the sip headers to make them comply with
sips scheme.
2) How to transport sip/sips messages over NAT or Firewall??

Any help in this regard will be greatly appreciated.

Thanks & Regards
Pavan Kumar O
M.E Embedded Systems
BITS Pilani
India
_______________________________________________
Sip mailing list  https://www.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Hulbut hulbut" <[email-masked]>
Date: Wed, 27 Feb 2008 17:24:15 +0530

Hi Pavan,

Not sure abt the 1st part of ur questions...but regarding point 2 I have
some suggestions:
1) Not sure what you mean by how to transport ??....but here I assume that u
r concerned about how the packets will be seen in the REAL world. There are
several options
a) Clients can have STUN support, which will make clients transparent of any
NAT traversal
b) Proxies can be sip-outbound-draft compliant...this will take care of
routing based on actuall src IP:Port overriding 3261 based approach (routing
request based on Contact/Route hdr etc ..).
c) Your network can have a ALG , just outside NAT box.....this ALG needs to
be SIP aware and should do all the header re-writings. Unfortunately no
standard exists as such ..but some googling may help

rgds
  Hul

On Wed, Feb 27, 2008 at 3:33 PM, PAVAN KUMAR O <[email-masked]> wrote:

> Hi all,
>
>        I am Pavan.I am working on implementing security features for SIP
> on a Voip enabled phone.\

---

From: "Avasarala Ranjit-A20990" <[email-masked]>
Date: Wed, 27 Feb 2008 20:04:24 +0800

Hi Pavan
 
For question 1) implementing sips means implementing TLS. So the SIP
stack would use SIP over TLS/TCP or DTLS over UDP. Then the URI would be
sips: Refer to RFC 3261 for more details about which flags / headers
need to changed.
I think transportation of either sip or sips messages over NAT/Firewall
remains almost same. For more details on SIP over NAT refer to RFC 3489
which explains STUN (Simple Traversal of Udp over NAT).
 
Regards 
Ranjit 

________________________________

From: [email-masked] [mailto:[email-masked]] On Behalf Of
PAVAN KUMAR O
Sent: Wednesday, February 27, 2008 3:33 PM
To: [email-masked]
Subject: [Sip] SIPS over NAT and Firewalls

Hi all,

 
Thanks & Regards
Pavan Kumar O
M.E Embedded Systems
BITS Pilani
India