Subject: [Sip] nit in draft-wing-sip-e164-rrc-01

From: "David Schwartz" <[email-masked]>
Date: Wed, 27 Feb 2008 00:31:04 +0200

Hi Dan

a quick comment on this draft...

There is no discussion of what happens when there is a validation failure. While obvious, you should probably reference 4474 processing upon validation failure (i.e. respond with 438 'Invalid Identity Header'). And while on the topic in your second example where the cert comparison test fails your diagram still shows the call proceeding to its destination (hence the earlier comment).
D.
_______________________________________________
Sip mailing list  http://www.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Dan Wing" <[email-masked]>
Date: Fri, 29 Feb 2008 16:35:43 -0800

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of David Schwartz
> Sent: Tuesday, February 26, 2008 2:31 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [Sip] nit in draft-wing-sip-e164-rrc-01
> 
> 
> Hi Dan
> 
> There is no discussion of what happens when there is a 
> validation failure. While obvious, you should probably 
> reference 4474 processing upon validation failure (i.e. 
> respond with 438 'Invalid Identity Header'). And while on the 
> topic in your second example where the cert comparison test 
> fails your diagram still shows the call proceeding to its 
> destination (hence the earlier comment).

I'm not sure we want to fail a call if validation fails; 
rather, we may want to allow it to complete and tell the
user 'unauthenticated caller' (similar to what the PSTN 
does today by displaying "unidentified call" when caller
ID failed).

-d

Sip mailing list  https://www.ietf.org/mailman/listinfo/sip