Subject: [Sip] Headsup on Short Agenda for IETF 71

From: Dean Willis <[email-masked]>
Date: Sat, 16 Feb 2008 02:23:40 -0600

It appears that we will get only 2 hours of working group meeting time 
in Philadelphia.

That means we're going to have to be VERY efficient with our use of time.

What are the mosr important things? The things we REALLY need to talk 
about? Inquiring minds want to know.

Here are the things on our charter we're currently late on:

  1) Outbound
  2) SIPS (which I think is pretty much done)
  3) Diagnostic Responses
  4) Example security flows
  5) Extensions to SIP UA Profile Delivery Change Notification Event 
Package for XCAP
  6) Location Conveyance with SIP
  7) Connection reuse mechanism
  8) Session Policies
  9) Etags in conditional notification
10) Using SAML for SIP
11) New resource priority namespaces for DISA
12) Requirements for media keying
13) X.509 Certificates for TLS use in SIP (done?)
14) X.509 extended key usage for SIP (done?)
15) Roadmap for SIP
16) Delivering request-URI and parameters to UAS via proxy
17) Establishment of secure media sessions using DTLS-SRT
18) MIME body handling in SIP
19) Identify requirements for test matrix to move SIP to Draft Standard

And the things we aren't late on yet:

1) Essential corrections to RFC 3261 (1st batch)
2) Mechanisms for UA initiated privacy to WGLC

So c'mon, people. What do we need to talk about? And why aren't we 
talking about it on the list already?

--
Dean

_______________________________________________
Sip mailing list  http://www.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Christer Holmberg" <[email-masked]>
Date: Sat, 16 Feb 2008 11:28:50 +0100

Hi Dean,
 
One thing missing from your list is INFO. I am not sure whether we are "late" or not, but just keep in minds that there are other SDOs which may need the output. I am not sure how much time we would need to discuss it, but since we now have collected use-cases etc I think we should make some kind of decission on how to move forward.
 
Another thing missing, which has been discussed (again) lately is the how-to-reject-an-offer-in-PRACK. I wouldn't say that we are late on that, and for now I guess we can keep the discussion on the list if there is no time at the meeting.
 
Regards,
 
Christer

________________________________

From: [email-masked] on behalf of Dean Willis
Sent: Sat 16/02/2008 09:23
To: [email-masked]
Subject: [Sip] Headsup on Short Agenda for IETF 71

  1) Outbound

--
Dean

---

From: "Vijay K. Gurbani" <[email-masked]>
Date: Mon, 18 Feb 2008 11:52:32 -0600

>   7) Connection reuse mechanism

-09 was submitted on Feb 8 and it included the comments
raised during WGLC review and subsequent list discussion.

> 13) X.509 Certificates for TLS use in SIP (done?)

Yes.  Needs WG review.

> 14) X.509 extended key usage for SIP (done?)

Just submitted an updated -01 for sip-eku.  Needs WG review,
probably along with PKIX's as well.

Thanks, Dean.

- vijay
-- 
Vijay K. Gurbani, Bell Laboratories, Alcatel-Lucent
2701 Lucent Lane, Rm. 9F-546, Lisle, Illinois 60532 (USA)
Email: vkg@{alcatel-lucent.com,bell-labs.com,acm.org}
WWW:   http://www.alcatel-lucent.com/bell-labs
_______________________________________________
Sip mailing list  http://www.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Dan Wing" <[email-masked]>
Date: Mon, 18 Feb 2008 23:23:04 -0800

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Dean Willis
> Sent: Saturday, February 16, 2008 12:24 AM
> To: [email-masked]

If the chairs could update everyone on the status -- we're 
waiting for requirements from 3GPP -- that should be enough 
to say about it in Philly.

There is a discussion on the list regarding one requirement 
(R-REUSE), but so far only two of the co-authors of the document 
seem to be interested in discussing that requirement, so I guess 
it isn't much of a 'discussion'.  We'll take it off-list and 
assume everyone agrees.

> talking about it on the list already?

There is the whole SIP Identity and E.164 problem which was brought
to light during Jason Fischl's DTLS presentation in Vancouver.  There
are at least eight new drafts posted related to SIP Identity and 
E.164:

  draft-darilion-sip-e164-enum-00.txt
  draft-elwell-sip-e164-problem-statement-00.txt
  draft-fischer-sip-e2e-sec-media-00.txt
  draft-kaplan-sip-baiting-attack-01.txt
  draft-kaplan-sip-uris-change-00.txt
  draft-rosenberg-sip-rfc4474-concerns-00.txt
  draft-schwartz-sip-e164-ownership-00.txt
  draft-wing-sip-e164-rrc-01.txt

So it seems there is interest in that topic, but a 10-20 minute
slot isn't enough time to say anything intelligent.

-d