Subject: [Sip] I-D on ICE diagnostic error code

From: Jonathan Rosenberg <[email-masked]>
Date: Sat, 23 Feb 2008 14:30:32 -0500

I just submitted:
http://www.ietf.org/internet-drafts/draft-rosenberg-sip-ice-error-code-01.txt

This is nearly identical to a draft I submitted before Vancouver, but we 
never discussed. The basic idea here is to define a new SIP response 
code for the case when all ICE connectivity checks fail. THe main 
benefit is that proxies can log this and collect statistics on 
successful and failed ICE cases from the SIP messaging.

Comments welcome.

-Jonathan R.
-- 
Jonathan D. Rosenberg, Ph.D.                   499 Thornall St.
Cisco Fellow                                   Edison, NJ 08837
Cisco, Voice Technology Group
[email-masked]
http://www.jdrosen.net                         PHONE: (408) 902-3084
http://www.cisco.com
_______________________________________________
Sip mailing list  http://www.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Christer Holmberg" <[email-masked]>
Date: Mon, 25 Feb 2008 08:43:33 +0100

Hi Jonathan,
 
The response code is ICE specific. But, couldn't it be useful at least
also for RFC4145, if one fails to establish a TCP connection?
 
So, instead of "Connectivity Checks Failed" the text would be more
generic and say "Connectivity Failure", or something like that...
 
Regards,
 
Christer

________________________________

From: [email-masked] on behalf of Jonathan Rosenberg
Sent: Sat 23/02/2008 20:30
To: IETF SIP List
Subject: [Sip] I-D on ICE diagnostic error code

I just submitted:
http://www.ietf.org/internet-drafts/draft-rosenberg-sip-ice-error-code-0
1.txt

Comments welcome.

-Jonathan R.
http://www.jdrosen.net <http://www.jdrosen.net/>
PHONE: (408) 902-3084
http://www.cisco.com <http://www.cisco.com/>