Subject: [Sip] Outbound flow-token and (instance-id + reg-id) use case?

From: "Karthikeyan Gopal , TLS-Chennai" <[email-masked]>
Date: Thu, 14 Feb 2008 16:05:16 +0530

Hi All,

    In SIP outbound draft 11 it was mentioned that flow back to
particular UA can be Identified based on instance-id and reg-id.

Then what is the need for flow-token.

Is this flow-token is used only in case of edge-proxy support?

If it is so what is the need of instance-id in case of edge-proxy.

Thanks & Regards,

Karthikeyan.G

DISCLAIMER:
-----------------------------------------------------------------------------------------------------------------------

The contents of this e-mail and any attachment(s) are confidential and intended for the named recipient(s) only.
It shall not attach any liability on the originator or HCL or its affiliates. Any views or opinions presented in 
this email are solely those of the author and may not necessarily reflect the opinions of HCL or its affiliates.
Any form of reproduction, dissemination, copying, disclosure, modification, distribution and / or publication of 
this message without the prior written consent of the author of this e-mail is strictly prohibited. If you have
received this email in error please delete it and notify the sender immediately. Before opening any mail and 
attachments please check them for viruses and defect.

-----------------------------------------------------------------------------------------------------------------------

_______________________________________________
Sip mailing list  http://www.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Hulbut hulbut" <[email-masked]>
Date: Thu, 14 Feb 2008 16:19:54 +0530

Hi,

Pls see comments inline:

-- regards
Hul

On Thu, Feb 14, 2008 at 4:05 PM, Karthikeyan Gopal , TLS-Chennai <
[email-masked]> wrote:

>  Hi All,
>
>     In SIP outbound draft 11 it was mentioned that flow back to particular
> UA can be Identified based on instance-id and reg-id.
>
[Hb] I dont think Instance-id and reg-id can be used to identify the ip
address of user. They are just used to identify the uniqueness of device.

> Then what is the need for flow-token.
[Hb]Flow token actually contains information of src ip address and port(Flow
token  = HMAC(users address, local address, key)). Thus a stateless proxy
need not have any other information to correctly send the request to UE.

> Is this flow-token is used only in case of edge-proxy support?
[Hb] Yes, it appears that flow token is used only by edge proxy.

> If it is so what is the need of instance-id in case of edge-proxy.
[Hb] Flow token may not be usefull in case of edge proxy, but surely as per
outbound section 7(bullet 3), its usefull for Authoritative proxies and
SCSCF (in IMS)  .

> The contents of this e-mail and any attachment(s) are confidential and
> intended for the named recipient(s) only.
> It shall not attach any liability on the originator or HCL or its
> affiliates. Any views or opinions presented in
> Any form of reproduction, dissemination, copying, disclosure,
> modification, distribution and / or publication of
> this message without the prior written consent of the author of this
> e-mail is strictly prohibited. If you have