Subject: Re: [Sip] gruu and SIP MESSAGE

From: "Attila Sipos" <[email-masked]>
Date: Thu, 7 Feb 2008 14:39:02 -0000

You can use gruu in any non-REGISTER request.

You don't need an INVITE, you only need to REGISTER the UA
to get a gruu.

from http://www.jdrosen.net/papers/draft-ietf-sip-gruu-13.txt :

3.3.  Using a GRUU

   Once a user agent obtains GRUUs from the registrar, it uses them in
   several ways.  First, it uses them as the contents of the Contact
   header field in non-REGISTER requests and responses that it emits
   (for example, an INVITE request and 200 OK response). 

Regards,
Attila

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Salvatore Loreto
Sent: 07 February 2008 11:40
To: [email-masked]
Subject: [Sip] gruu and SIP MESSAGE

Hi,

I haven't found any references that GRUU can be used in SIP MESSAGE.
So, how do I ensure routing back to a specific client for SIP MESSAGE,
without be forced to associate a MESSAGE with an existing INVITE?

regards
Sal
_______________________________________________
Sip mailing list  http://www.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol Use
[email-masked] for questions on current sip Use
[email-masked] for new developments on the application of sip
_______________________________________________
Sip mailing list  http://www.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Salvatore Loreto <[email-masked]>
Date: Thu, 07 Feb 2008 17:26:56 +0200

Hi Attila,

sorry maybe I wasn't clear in my question.

My problem is:
I send out a MESSAGE to a AoR, and I want be sure that the receiver of 
the MESSAGE
(if he wants to reply to the MESSAGE) will send out the reply to the 
same UA I used to send out the MESSAGE.
Now, how is it possible if I can not insert a Contact header with my 
GRUU within the MESSAGE ?

/sal

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 07 Feb 2008 10:47:16 -0500

> GRUU within the MESSAGE ?

MESSAGE forbids the inclusion of Contact because it was not intended for 
message sessions. If you want to include a place you can be reached, you 
could use the Reply-To header. What you put in such a header is up to you.

	Paul

---

From: Jonathan Rosenberg <[email-masked]>
Date: Thu, 07 Feb 2008 12:22:18 -0500

This is what session mode is for.

-Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.                   499 Thornall St.
Cisco Fellow                                   Edison, NJ 08837
Cisco, Voice Technology Group
[email-masked]
http://www.jdrosen.net                         PHONE: (408) 902-3084
http://www.cisco.com
_______________________________________________
Sip mailing list  http://www.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip