Subject: [Sip] MUST 200 OK contain SDP? Thanks

From: "Yuantao Zhang" <[email-masked]>
Date: Thu, 22 May 2008 16:54:46 +0800

Dear all

I am really confused by the following part in RFC_3261. Could you please
help us to explain it? Thank you very much.
"
13.2.1 Creating the Initial INVITE
.
.
.
      o  If the initial offer is in an INVITE, the answer MUST be in a
         reliable non-failure message from UAS back to UAC which is
         correlated to that INVITE.  For this specification, that is
         only the final 2xx response to that INVITE.  That same exact
         answer MAY also be placed in any provisional responses sent
         prior to the answer.  The UAC MUST treat the first session
         description it receives as the answer, and MUST ignore any
         session descriptions in subsequent responses to the initial
         INVITE.
.
.
."

Let's break it into 2 parts, in part 1, 
         "If the initial offer is in an INVITE, the answer MUST be in a
         reliable non-failure message from UAS back to UAC which is
         correlated to that INVITE.  For this specification, that is
         only the final 2xx response to that INVITE. "
Does that mean if "Invite" contains SDP offer, "200 OK" MUST contain SDP
answer.

In part 2,
         "That same exact answer MAY also be placed in any provisional
responses sent
         prior to the answer.  The UAC MUST treat the first session
         description it receives as the answer, and MUST ignore any
         session descriptions in subsequent responses to the initial
         INVITE."
Does that mean if "Invite" contains SDP offer, the answer SDP MAY be in
"180 ring" and not in "200 OK"? I think part 1 and part 2 are
inconsistent.

The attached sequence chart is the real problem we meet. Sx1 sends "bye"
to sx2 after the "200 OK" because there is no SDP answer in "200 OK".
But the producer of sx2 argues that the SDP answer is in "180 ring"
already. No need to repeat it in "200 OK". Could you please tell me who
is right? MUST 200 OK contain SDP? Thank you very much.

Sx1                              xs2
   ====1   invite(SDP)    ====> 
  <====2   100 trying     ====
  <====3   180 ringing(SDP)==== 
   ====4   prack          ====> 
  <====5   200 ack        ====> 
  <====6   200 OK (no SDP)====>
		
Best Regards
Yuantao Zhang

_______________________________________________
Sip mailing list  https://www.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Christer Holmberg" <[email-masked]>
Date: Thu, 22 May 2008 11:02:22 +0200

Hi,
 
Please take a look at the draft-ietf-sipping-sip-offeranswer draft.
 
Regards,
 
Christer

________________________________

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Yuantao Zhang
Sent: 22. toukokuuta 2008 11:55
To: [email-masked]
Subject: [Sip] MUST 200 OK contain SDP? Thanks

Dear all

"

.

.

.

         INVITE.

.

.

."

In part 2,

         INVITE."

Sx1                              xs2

   ====1   invite(SDP)    ====> 

  <====2   100 trying     ====

   ====4   prack          ====> 

  <====5   200 ack        ====> 

Best Regards

Yuantao Zhang

---

From: "Aditya Sehgal" <[email-masked]>
Date: Thu, 22 May 2008 15:59:12 +0530

Hi,
180 can contain a SDP. However, not every message that contains an SDP is an
answer to the initial offer. 180 are un-reliable messages (without 100 rel
supported).

Anyways, there are far too many combinations to put here.
In short, if you support 100 rel (which based on your callflow you do), the
producer of sx2 is correct.
For a detailed analysis, please give heed to Christer's advice.

Thanks & Regards,
Aditya Sehgal

On Thu, May 22, 2008 at 2:32 PM, Christer Holmberg <
[email-masked]> wrote:

>  ------------------------------
> *From:* [email-masked] [mailto:[email-masked]] *On Behalf Of *Yuantao
> Zhang
> *Sent:* 22. toukokuuta 2008 11:55
> *To:* [email-masked]
> *Subject:* [Sip] MUST 200 OK contain SDP? Thanks
>
>  Dear all
>
> Does that mean if "Invite" contains SDP offer, the answer SDP MAY be in "180
> ring" and not in "200 OK"? I think part 1 and part 2 are inconsistent.
>
> The attached sequence chart is the real problem we meet. Sx1 sends "bye"to sx2 after the "200
> OK" because there is no SDP answer in "200 OK". But the producer of sx2
> argues that the SDP answer is in "180 ring" already. No need to repeat it
> in "200 OK". Could you please tell me who is right? MUST 200 OK contain
> SDP? Thank you very much.
>
>  Sx1                              xs2
>
>    ====1   invite(SDP)    ====>
>
>   <====2   100 trying     ====
>
> Best Regards******

-- 
Don't take life too seriously....Nobody comes out alive anyway