Subject: [Sip] SIP one DNS domain much IP

From: "孙永光" <[email-masked]>
Date: Tue, 20 May 2008 19:10:35 +0800

Hi Guys:

     I have a question about DNS
it is that one DNS domain has much IP Addrs , eg: as.test.net=>(
192.168.2.1/192.168.2.2)
and "as.test.net: is B2B server
1) A INVITE B , A resolves the DNS "as.test.net" 192.168.2.1,then A sends
INVITE request to
   192.168.2.1
2) A receives 200 response with contact "as.test.net" and no record route
3)A resolves the DNS "as.test.net" again, it gets 192.16.2.2 and sends ACK
to 192.168.2.2

now the 192.16.2.1 can't recieve the ACK request , so the session can't be
created

Anyone can give me any advice, or some RFC/draft about it

Thanks in advance

Samman
2008-5-20
_______________________________________________
Sip mailing list  https://www.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Brett Tate" <[email-masked]>
Date: Tue, 20 May 2008 08:41:36 -0400

Because of potential load-balancing (as you are observing), solely using A records within primary/secondary configurations should be avoided unless additional agreements or configuration has been made to avoid the situation you are describing concerning in dialog requests.  The additional agreements override typical rfc3263 behavior by applying local policy (potentially non compliant) to remain stateful within dialog.  The potential additional configuration (to avoid the mentioned override) is to have DNS control to avoid automatic load-balancing/iterating concerning A records so that the A record query/handling can always result in the same ordered list.

RFC 3263 discusses using DNS SRV records to more clearly indicate prioritization and load-balancing.  If SRV records not supported, the Contact should reflect a single AS unless the alternative locations can accommodate the situation (or additional agreements or configuration has been made to avoid trying the alternative locations first).

________________________________

	From: [email-masked] [mailto:[email-masked]] On Behalf Of ???
	Sent: Tuesday, May 20, 2008 7:11 AM
	To: [email-masked]; IETF Sipping List
	Subject: [Sip] SIP one DNS domain much IP

	Hi Guys:

	     I have a question about DNS
	it is that one DNS domain has much IP Addrs , eg: as.test.net=>(192.168.2.1/192.168.2.2)
	and "as.test.net: is B2B server
	1) A INVITE B , A resolves the DNS "as.test.net" 192.168.2.1,then A sends INVITE request to
	   192.168.2.1
	2) A receives 200 response with contact "as.test.net" and no record route
	3)A resolves the DNS "as.test.net" again, it gets 192.16.2.2 and sends ACK to 192.168.2.2

	now the 192.16.2.1 can't recieve the ACK request , so the session can't be created

	Thanks in advance

	Samman 
	2008-5-20

---

From: [email-masked]
Date: Tue, 20 May 2008 15:36:44 -0400

From: "=?GB2312?B?y+/TwLni?=" <[email-masked]>

"A" has behaved correctly.  When "B" provides "as.test.net" as its
contact, it is stating that it is OK for "A" to send further requests
to any IP address for "as.test.net".  If further requests must be sent
to 192.168.2.1, then "B" must use "192.168.2.1" as its contact
address.

Dale