Subject: [Sip] PTT query

From: atul garg <[email-masked]>
Date: Thu, 12 Jun 2008 16:28:20 +0530 (IST)

Hello,

I have a question regarding push to talk message .

Is there any way through which I can identify that particular SIP message is meant for PTT ie. this sip message is a part of some Push To Talk session..

Like through which I can filter that such message is for PTT.

Such criteria which can be applicable on all SIP messages ie.

1) Invite
2) Register
3) 2xx/1xx/4xx/3xx etc. responces
..
..
etc.

Thnx
Atul

      From Chandigarh to Chennai - find friends all over India. Go to http://in.promos.yahoo.com/groups/citygroups/

_______________________________________________
Sip mailing list  https://www.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 12 Jun 2008 08:54:27 -0400

> 3) 2xx/1xx/4xx/3xx etc. responces

Are you talking specifically about the 3gpp IMS form of PTT? Or is your 
question more general?

If you are talking about IMS PTT then you should be asking the IMS 
community, because their soluitons are very unique to their environment.

Beyond that, AFAIK there is no specification for how PTT should work.

IMO the concept of PTT is about the characteristics of a media session. 
I don't see why it has anything to do with REGISTER, etc. aside possibly 
the communication of capabilities, which can be handled via callerprefs 
/ callee capabilities.

	Thanks,
	Paul

---

From: "T Satyanarayana-A12694" <[email-masked]>
Date: Thu, 12 Jun 2008 23:32:54 +0800

If you are talking about OMA PoC (PTT over Cellular), there is a way
defined in OMA standards to do this. It specifies a feature-tag in
contact header to identify PoC calls.

However, this is outside the purview of SIP.

Regards
Satya T
-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Paul Kyzivat
Sent: Thursday, June 12, 2008 6:24 PM
To: [email-masked]
Cc: [email-masked]
Subject: Re: [Sip] PTT query

atul garg wrote:
> Is there any way through which I can identify that particular SIP
message is meant for PTT ie. this sip message is a part of some Push To
Talk session..

	Thanks,
	Paul
_______________________________________________
Sip mailing list  https://www.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol Use
[email-masked] for questions on current sip Use
[email-masked] for new developments on the application of sip
_______________________________________________
Sip mailing list  https://www.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Dean Willis <[email-masked]>
Date: Thu, 12 Jun 2008 11:40:31 -0500

On Jun 12, 2008, at 5:58 AM, atul garg wrote:

> message is meant for PTT ie. this sip message is a part of some Push  
> To Talk session..
>

I believe that requires reading the PTT specification. There is no  
IETF PTT specification.

You might want to look at OMA's publicly-available specs:

http://member.openmobilealliance.org/ftp/Public_documents/POC

--
Dean

---

From: "Avasarala Ranjit-A20990" <[email-masked]>
Date: Fri, 13 Jun 2008 18:10:07 +0800

Hi Atul

Have a look at the OMA PoC spec
http://www.openmobilealliance.org/technical/release_program/docs/PoC/V2_
0-20080507-C/OMA-TS-PoC_ControlPlane-V2_0-20080507-C.pdf to see what
media feature tags are used in SIP Messages for PoC. 

Regards
Ranjit

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
atul garg
Sent: Thursday, June 12, 2008 4:28 PM
To: [email-masked]
Subject: [Sip] PTT query

Hello,

1) Invite
2) Register

Thnx
Atul

      From Chandigarh to Chennai - find friends all over India. Go to
http://in.promos.yahoo.com/groups/citygroups/