Subject: [Sip] Both sides of dialog sending request at the same time

From: Maciej Kowalski <[email-masked]>
Date: Thu, 12 Jun 2008 12:09:40 +0200

Hi Everybody.

I'm currently working on SIP/TDM Gateway application.
I've encountered following problem.
During Sip dialog both sides at the exactly same moment send Re-Invite 
requests.
Those are reaching their destinations while both client are expecting 
replies. What should be the behavior of SIP client in a situation like that.

_______________________________________________
Sip mailing list  https://www.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 12 Jun 2008 08:47:47 -0400

This situation is known as "glare". It is discussed in rfc 3261 and in 
http://www.ietf.org/internet-drafts/draft-ietf-sipping-race-examples-05.txt.
In short, both sides should send a 491 response, back off, and retry.

	Paul

---

From: [email-masked]
Date: Thu, 12 Jun 2008 10:29:30 -0400

From: Maciej Kowalski <[email-masked]>

Sections 14.1 and 14.2 of RFC 3261 give detailed instructions on how
this situation must be handled.

Dale

---

From: Maciej Kowalski <[email-masked]>
Date: Fri, 13 Jun 2008 08:25:29 +0200

Thank You for such quick and detailed response.

Maciej