Subject: [Sip] can SDP contain 2 'M' lines

From: "Sudhir Kumar Reddy" <[email-masked]>
Date: Thu, 26 Jun 2008 12:03:47 +0530

Hi All,

In SDP can we have two 'M' lines for re-INVITE i.e. for call hold.

if yes what is RFC / draft

Any response is highly appreciated

Regards
Sudhir
_______________________________________________
Sip mailing list  https://www.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: <[email-masked]>
Date: Thu, 26 Jun 2008 13:37:58 +0530

Yes, each m line start a new media section in the SDP. You can take a
look at SDP RFC.

Best Regards, 
Ashish Saxena 
877-5570 

________________________________

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Sudhir Kumar Reddy
Sent: Thursday, June 26, 2008 12:04 PM
To: [email-masked]
Subject: [Sip] can SDP contain 2 'M' lines

Hi All,

Regards
Sudhir

---

From: "Alfred E. Heggestad" <[email-masked]>
Date: Thu, 26 Jun 2008 11:39:34 +0200

> Any response is highly appreciated

yes, please see details here:

   http://www.ietf.org/rfc/rfc4566.txt

   http://www.ietf.org/rfc/rfc3264.txt

/alfred

---

From: "Dan Wing" <[email-masked]>
Date: Thu, 26 Jun 2008 09:32:52 -0700

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Sudhir Kumar Reddy
> Sent: Wednesday, June 25, 2008 11:34 PM
> To: [email-masked]

I have seen two responses that answer your first question and say 'yes'.
However, multiple m= lines are not used to put a call on hold.

-d

---

From: "James M. Polk" <[email-masked]>
Date: Thu, 26 Jun 2008 21:13:04 -0500

>However, multiple m= lines are not used to put a call on hold.

indeed

1 (the same) m= line in sdp (offer) of reINVITE;
same Call-ID, From and To tag as original INVITE;
R-URI to same UA; (though I'm not sure if this R-URI can be to the 
Contact address in original 200 OK);
same c= line;
*different* (1) or *new* a= line from
         a=sendrecv
         to
         a=sendonly

the answer will be a=recvonly

(1) omitting a=sendrecv is ok in the original offer, since it is 
implied unless a direction tag is explicitly different in any offer.

see RFCs 3264 and 4566 for more details

James