Subject: [Sip] Let's talk about a Dublin agenda

From: Dean Willis <[email-masked]>
Date: Tue, 24 Jun 2008 14:19:54 -0500

I've been tipped off that we may be down to as little as two hours (or  
maybe 2.5)  of meeting time in Dublin due to additional WG and BOF  
events that didn't make it onto the earlier published agenda (like  
MEDIACTRL).

What are the absolutely most important things we need to talk about?  
What is the best possible use of our very valuable and very scarce  
time together?

I suspect that going by-rote through the list of open milestones is  
not the best use of our time.

Topics that I think we might want to talk about include but are not  
limited to:

Agenda bash and announcements usually use 10 minutes

1) Using SAML for SIP.
-- Milestone was Dec. 2007
-- Author has promised new rev before meeting
-- Is the WG committed to doing this work?
-- 10 minutes?

2) Test Matrix for SIP to Draft Standard
-- Milestone was Feb 2008
-- How are we going to move forward?
-- 10 minutes

3) Delivery of Request URI and Parameters to UAS Through Proxy
-- Milestone was Feb 2008
-- Conversation has lagged. Do we see a workable solution?
-- 30 minutes?

4) DTLS-SRTP
-- Milestone was Feb 2008
-- Delayed by the RFC 4474/Gateway/B2BUA
-- Decide: Do we hold DTLS-SRTP or publish with a caveat?
-- EKR may not be attending, can we resolve on-list? (no time?)

5) Mechanisms for UA Initiated Privacy
-- Milestone is July 2008
-- Author has promised new rev before meeting
-- 20 minutes?

6) Termination of early Dialog Prior to Final Response (199)
-- Milestone is November 2008
-- Substantial list activity
-- 30 minutes?

7) Guidelines for SIP Extension Modalities
-- No milestone
-- Needs conceptual discussion
-- Defer until #8 below is resolved? (no time?)

8) The INFO solution and Paul's compromise for historical registration
-- No milestone
-- Previous WG consensus to "do something"
-- 40 minutes?

Am I missing something that is critically important?

Which topics do we really need to talk about in order to move forward?
_______________________________________________
Sip mailing list  https://www.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Elwell, John" <[email-masked]>
Date: Tue, 24 Jun 2008 20:38:36 +0100

Dean,

Well, just how exactly do we go about resolving the various Identify
issues (E.164 / SBCs / gateways)? I think Dan has tried unsuccessfully
for a BoF earlier. No agenda time in SIP this time. There have been some
huge email threads since Philadelphia. There are several relevant drafts
around (and possibly more before Dublin). 

John

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Dean Willis
> Sent: 24 June 2008 20:20
> To: [email-masked]
> Cc: Keith Drage
> Subject: [Sip] Let's talk about a Dublin agenda
> 
>

---

From: Dean Willis <[email-masked]>
Date: Tue, 24 Jun 2008 14:47:44 -0500

> around (and possibly more before Dublin).

My suggestion is in two parts:

1) For DTLS-SRTP Framework, simply document the limitation of RFC 4474  
and move on. This is a one-paragraph add to the framework.

2) For the remainder, I'd like to suggest the "REal Time Identity and  
Role Expression" (RETIRE) Working Group, which would take over the RFC  
4474 revision along with SIP-SAML.

--
Dean

---

From: [email-masked]
Date: Tue, 24 Jun 2008 20:09:32 +0000

Hey - not our fault - we got our request in on time. 

That said, I would offer #2 is possibly the most important work item, as it will drive a coherent, scoped work plan. 

How is this for a far-fetched thought: SIP to DS is the *only* work item for the SIP work group. If we could not get X done in 10 years (yes, it has been that long for some of these things), let us charter a new work group to work on X.
Sent from my Verizon Wireless BlackBerry

-----Original Message-----
From: Dean Willis <[email-masked]>

Date: Tue, 24 Jun 2008 14:19:54 
To:[email-masked]
Cc:Keith Drage <[email-masked]>
Subject: [Sip] Let's talk about a Dublin agenda

1) Using SAML for SIP.

4) DTLS-SRTP

---

From: "Elwell, John" <[email-masked]>
Date: Tue, 24 Jun 2008 21:17:48 +0100

Dean,

> From: Dean Willis [mailto:[email-masked]] 
> Sent: 24 June 2008 20:48
> To: Elwell, John
> Cc: [email-masked]; Keith Drage
> Subject: Re: [Sip] Let's talk about a Dublin agenda
> 
> 
> > for a BoF earlier. No agenda time in SIP this time. There 
> have been  
> > some
[JRE] Will that produce results before we all retire? But seriously, a
new WG might be a good idea, but how long to set it up? What needs to be
done at or before Dublin in that direction?

John

---

From: "Elwell, John" <[email-masked]>
Date: Tue, 24 Jun 2008 21:23:08 +0100

Eric,

I too think #2 is important, particularly if that is viewed as one means
of attacking the issues from SFSIW. I am thinking here that less is
more, and what can we throw out of the Draft Standard to reduce the
options, whilst at the same time retaining or adding whatever is needed
to give us the necessary resilience, security, NAT/firewall-tolerance,
etc..

John

> Behalf Of [email-masked]
> Sent: 24 June 2008 21:10
> To: Dean Willis; [email-masked]
> That said, I would offer #2 is possibly the most important 
> work item, as it will drive a coherent, scoped work plan. 
> 
> How is this for a far-fetched thought: SIP to DS is the 
> *only* work item for the SIP work group. If we could not get 
> X done in 10 years (yes, it has been that long for some of 
> these things), let us charter a new work group to work on X.

---

From: Hadriel Kaplan <[email-masked]>
Date: Tue, 24 Jun 2008 16:45:50 -0400

Oy vey.  That's less time than we had in Philly, and we got barely anything done there.

Why can't some RAI groups overlap - for example mediactrl or xcon at the same time as speermint or drinks, or let p2psip overlap with any of those 4?

-hadriel

> From: [email-masked] [mailto:[email-masked]] On Behalf Of Dean
> Willis
> Sent: Tuesday, June 24, 2008 3:20 PM
> To: [email-masked]
> Cc: Keith Drage

---

From: Dean Willis <[email-masked]>
Date: Tue, 24 Jun 2008 17:38:28 -0500

> done at or before Dublin in that direction?

Well, a new working group starts with a BOF request and a draft  
charter and somebody who wants the WG badly enough to do the leg work  
and chair the BOF.

It's a little late in the cycle to get one of those in for Dublin, but  
we could certainly start talking about a draft charter, then run a BOF  
at the next meeting. That would fit squarely with my goal of ramping  
down the "eternal SIP group" by fall 2009.

---

From: Dean Willis <[email-masked]>
Date: Tue, 24 Jun 2008 17:41:52 -0500

On Jun 24, 2008, at 3:09 PM, [email-masked] wrote:

> That said, I would offer #2 is possibly the most important work  
> item, as it will drive a coherent, scoped work plan.

#2 was:

>
>
>
> How is this for a far-fetched thought: SIP to DS is the *only* work  
> item for the SIP work group. If we could not get X done in 10 years  
> (yes, it has been that long for some of these things), let us  
> charter a new work group to work on X.

How about SIP to Draft Standard as the only work item for a new WG?  
That's a pretty crisply defined charter. Our current milestone is only  
to define a test matrix; said test matrix being input to some other  
work process that either takes SIP to Draft or decides it can't be done.

--
Dean

---

From: "Dan Wing" <[email-masked]>
Date: Tue, 24 Jun 2008 15:50:19 -0700

> Sent: Tuesday, June 24, 2008 12:48 PM
> To: Elwell, John

Sounds good.

> 4474 revision along with SIP-SAML.

Sounds good, too.

-d

---

From: "Dan Wing" <[email-masked]>
Date: Tue, 24 Jun 2008 15:55:58 -0700

> Sent: Tuesday, June 24, 2008 3:38 PM
> To: Elwell, John
> charter and somebody who wants the WG badly enough to do the 
> leg work and chair the BOF.

You say that as if nobody tried before.  I requested a BoF for
Philadelphia, called Discussion and Analysis of SIP Identity 
(DASI).  It was turned down by the IESG, and did not have the
support of the RAI ADs.

I have received no indication that additional people in SIP cared 
about the problem (beyond the ~6 or so involved in the thread we
had on the list), nor an indication from the RAI ADs that our email 
threads on SIP after the Philadelphia meeting had swayed their 
opinion.

I could continue to beat my head against the wall, but I can't
see through the blood as it is.

> It's a little late in the cycle to get one of those in for 
> Dublin, but we could certainly start talking about a draft 
> charter, then run a BOF at the next meeting.  That would fit 
> squarely with my goal of ramping down the "eternal SIP group" 
> by fall 2009.

-d

---

From: "Dan Wing" <[email-masked]>
Date: Tue, 24 Jun 2008 16:06:38 -0700

Hadriel Kaplan wrote:

> Why can't some RAI groups overlap - for example mediactrl or 
> xcon at the same time as speermint or drinks, or let p2psip 
> overlap with any of those 4?

I was shot down when I proposed it:
http://www.ietf.org/mail-archive/web/rai-discuss/current/threads.html#00009

I do hope we reconsider.

-d

---

From: "Mary Barnes" <[email-masked]>
Date: Tue, 24 Jun 2008 18:09:47 -0500

Dan - your suggestion was for groups that have more overlap (e.g., SIP,
MMUSIC with XCON, MEDIACTRL).  The groups Hadriel is explicitly
suggesting might just work (well it does for me :). 

Mary.  
- who was the one that shot Dan down last time. 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Dan Wing
Sent: Tuesday, June 24, 2008 6:07 PM
To: 'Hadriel Kaplan'; 'Dean Willis'; [email-masked]
Cc: 'Keith Drage'
Subject: Re: [Sip] Let's talk about a Dublin agenda

Hadriel Kaplan wrote:

> Why can't some RAI groups overlap - for example mediactrl or xcon at 
> the same time as speermint or drinks, or let p2psip overlap with any 
> of those 4?

I was shot down when I proposed it:
http://www.ietf.org/mail-archive/web/rai-discuss/current/threads.html#00
009

I do hope we reconsider.

-d

_______________________________________________
Sip mailing list  https://www.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol Use
[email-masked] for questions on current sip Use
[email-masked] for new developments on the application of sip
_______________________________________________
Sip mailing list  https://www.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Dean Willis <[email-masked]>
Date: Tue, 24 Jun 2008 18:23:00 -0500

> (DASI).  It was turned down by the IESG, and did not have the

True, However, the approach you took at that time wasn't clearly  
coordinated as a handoff of responsibility from the SIP working group.  
That's what I propose to try now.

We should also consider that much of the proposed work of RUCUS  
(Reducing Unwanted Communications Using SIP), aka anti-SPIT, depend on  
strong identity.

--
Dean

---

From: Hadriel Kaplan <[email-masked]>
Date: Tue, 24 Jun 2008 19:36:17 -0400

That's because you posted that on a list no one pays attention to. :)
(who even knew there was an [email-masked] separate from [email-masked]??)

And you proposed overlapping things with SIP and MMUSIC, which does seem tough.
I'm thinking more like...

Thread-safe:
Thread-1          Thread-2        Thread-3
--------          --------        --------
speermint         xcon            p2psip
drinks            mediactrl
enum              speechsc

Global:
-------
avt
bliss
mmusic
simple
sip
sipping
ecrit
geopriv

Any Thread WG can conflict with a WG from another Thread.  No Global or Thread WG can conflict with a Global WG.
You could probably create a Thread-4 with ecrit and geopriv, but 3 concurrent threads seem enough.

-hadriel

> From: Dan Wing [mailto:[email-masked]]
>

---

From: "Dan Wing" <[email-masked]>
Date: Tue, 24 Jun 2008 16:45:19 -0700

> coordinated as a handoff of responsibility from the SIP 

True.

> That's what I propose to try now.

Ok.

> (Reducing Unwanted Communications Using SIP), aka anti-SPIT, 
> depend on strong identity.

Yes, it does.

-d

---

From: "Dan Wing" <[email-masked]>
Date: Tue, 24 Jun 2008 16:50:22 -0700

> (who even knew there was an [email-masked] separate 

Neither are used much at all, for whatever that's worth.

> Any Thread WG can conflict with a WG from another Thread.  No 
> Global or Thread WG can conflict with a Global WG.

Sounds great to me!

-d

---

From: Cullen Jennings <[email-masked]>
Date: Tue, 24 Jun 2008 19:48:58 -0700

> Neither are used much at all, for whatever that's worth.

I moved the main part of this thread over to rai@ietf. The rai-discuss  
list was formed very early before the area was formed and is supposed  
to be more or less dead. The right list for general rai area topics  
would be [email-masked] but as Dan points out, not much happens on it.

---

From: "Dan York" <[email-masked]>
Date: Wed, 25 Jun 2008 02:53:23 +0000

Cullen,

So is that a polite way of telling us that we should also join the [email-masked] list and post responses to today's thread about splitting up the SIP WG *there* versus here?

Dan (the other one)
-- 
Dan York, CISSP, Director of Emerging Communication Technology
Office of the CTO    Voxeo Corporation     [email-masked]
Phone: +1-407-455-5859  Skype: danyork  http://www.voxeo.com
Blogs: http://blogs.voxeo.com  http://www.disruptivetelephony.com

Bring your web applications to the phone.
Find out how at http://evolution.voxeo.com

-----Original Message-----
From: Cullen Jennings <[email-masked]>

Date: Tue, 24 Jun 2008 19:48:58 
To:Dan Wing <[email-masked]>
Cc:[email-masked], 'Keith Drage' <[email-masked]>,'Dean Willis' <[email-masked]>
Subject: Re: [Sip] Let's talk about a Dublin agenda

---

From: Cullen Jennings <[email-masked]>
Date: Tue, 24 Jun 2008 19:59:07 -0700

The discution of breaking out part of SIP to a new WG is probably best  
done on SIP list for now.

However, discussion of scheduling all the WG in RAI is probably best  
done on rai@ietf. Not a real big deal one way or the other.

On Jun 24, 2008, at 7:53 PM, Dan York wrote:

> Cullen,
>
> So is that a polite way of telling us that we should also join the [email-masked] 
>  list and post responses to today's thread about splitting up the  
> SIP WG *there* versus here?
>
> Dan (the other one)
> --

---

From: "Elwell, John" <[email-masked]>
Date: Wed, 25 Jun 2008 08:31:56 +0100

Those overlaps would work for me.

John 

> Behalf Of Hadriel Kaplan
> Sent: 24 June 2008 21:46
> Behalf Of Dean