Subject: [Sip] Progress on draft-jesske-sipping-etsi-ngn-reason-03

From: "Jesske, R" <[email-masked]>
Date: Thu, 26 Jun 2008 17:56:44 +0200

Dear all,
at the moment I'm looking for comments on the http://tools.ietf.org/id/draft-jesske-sipping-etsi-ngn-reason-03.txt, to progress the work on that. 
The reason in responses will be used within the IMS so progress of this draft is needed.
 
Also I've got the comment that the work should be shifted to SIP WG.
 
Thoughts? Comments?
 
Best Regards
 
Roland
 
 <http://tools.ietf.org/id/draft-jesske-sipping-etsi-ngn-reason-03.txt>  

Deutsche Telekom AG 
Zentrum Technik Einführung 
Roland Jesske 
Gateways, Protokolle, Konvergenz, TE32-1
Heinrich-Hertz-Str. 3-7,  64295 Darmstadt,  
Postfach, 64307 Darmstadt (Postanschrift) 
+496151 628 2766 (Tel)
+491718618445  (Mobile) 
E-Mail: [email-masked] 

 <http://www.telekom.de/> http://www.telekom.de 

Registerrechtliche Unternehmensangaben: 
Deutsche Telekom AG
Aufsichtsrat: Prof. Dr Ulrich Lehner (Vorsitzender)
Vorstand: René Obermann (Vorsitzender),
Dr. Karl-Gerhard Eick (stellvertretender Vorsit-zender),
Hamid Akhavan, Reinhard Clemens, Timotheus Höttges, Thomas Sattelberger 
Handelsregister: Amtsgericht Bonn HRB 6794, 
Sitz der Gesellschaft: Bonn 
WEEE-Reg.-Nr.: DE50478376 
*************************************************************** 
Deutsche Telekom AG 
Supervisory Board: Prof. Dr Ulrich Lehner (Chairman) 
Board of Management: René Obermann (Chairman), 
Dr. Karl-Gerhard Eick (Deputy Chairman), 
Hamid Akhavan, Reinhard Clemens, Timotheus Höttges,  Thomas Sattelberger 
Commercial register: Amtsgericht Bonn HRB 6794, 
corporate seat: Bonn 
WEEEreg.no: DE50478376 

_______________________________________________
Sip mailing list  https://www.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Mary Barnes" <[email-masked]>
Date: Thu, 26 Jun 2008 11:27:53 -0500

If the requirements in this document are agreed in SIPPING WG (the doc seems really sparse in terms of requirements at this point), THEN the work could progress to the SIP WG. But, we first need to agree requirements. 
 
I see your applicability section and earlier there's reference to the TISPAN requirements document (which is expired). Can you pull the specific requirements from that document into this one or at least let's discuss on the list?  In scanning that requirements document, it's not clear to me which requirement this header is intended to meet. If it is intended to support many of those simulation services, then that should be stated. And, so I believe this brings us to the question as to whether we are going to support those simulation services? 
 
Given that many of those services are being developed in BLISS, would it not be prudent to wait until we see the details of those services to suggest that we need this header?  Or has that already been discussed and I've missed it? If so, please provide us a pointer to that discussion.  In that case, we could agree that SIPPING WG does not need to spend much time on the requirements and we could more easily agree that this could move to SIP WG to be completed.  Or, are there other requirements for this header?  
 
And, just for clarification, are their plans to progress that other general requirements document or should the WG treat that document as we did in the past the 3GPP requirements document as a working document, from which to pull specific requirements and solution proposals?  My inclination would be the latter, but we need feedback from the WG (including ETSI/TISPAN/IMS folks, of course). 
 
And, just a note, I bcc'ed SIP WG on this thread, since I would prefer this thread stay only in SIPPING WG for now, in particular just to keep down the volume on the SIP list, which is already really busy.
 
Thanks,
Mary. 

________________________________

From: [email-masked] [mailto:[email-masked]] On Behalf Of Jesske, R
Sent: Thursday, June 26, 2008 10:57 AM
To: [email-masked]; [email-masked]
Subject: [Sipping] Progress on draft-jesske-sipping-etsi-ngn-reason-03

Dear all,

Thoughts? Comments?
 
Best Regards
 
Roland

Deutsche Telekom AG 

http://www.telekom.de <http://www.telekom.de/>

---

From: "Mary Barnes" <[email-masked]>
Date: Thu, 26 Jun 2008 11:33:00 -0500

Hi folks,
 
Just to get this queued since I've not yet seen a posting to SIP WG on
this topic, my attempt at bcc'ing SIP and keeping this discussion on
SIPPING only didn't work (I think I forgot to delete SIP in the too ;(  
 
But, please note that I would prefer (barring any disagreement from SIP
chairs) to keep this discussion on the SIPPING WG mailing list for now.
 
Thanks,
Mary.

---

From: "DRAGE, Keith \(Keith\)" <[email-masked]>
Date: Thu, 26 Jun 2008 19:19:45 +0200

(As SIP WG co chair)
 
Please respond to this thread on the SIPPING list.
 
As Mary has indicated, SIPPING have to agree the requirements and then
SIP can consider how best to develop the extensions.
 
regards
 
Keith

	From: [email-masked] [mailto:[email-masked]] On
Behalf Of Mary Barnes
	Sent: Thursday, June 26, 2008 5:33 PM
	To: [email-masked]
	Subject: Re: [Sip] [Sipping] Progress
ondraft-jesske-sipping-etsi-ngn-reason-03

	Hi folks,
	 
	Just to get this queued since I've not yet seen a posting to SIP
WG on this topic, my attempt at bcc'ing SIP and keeping this discussion
on SIPPING only didn't work (I think I forgot to delete SIP in the too
;(  
	 
	But, please note that I would prefer (barring any disagreement
from SIP chairs) to keep this discussion on the SIPPING WG mailing list
for now.
	 
	Thanks,
	Mary.

---

From: "Jesske, R" <[email-masked]>
Date: Fri, 27 Jun 2008 10:28:55 +0200

Dear Mary,
Thank for your advice.
I think the most important is to say that the Reason header already exists in RFC3326. The draft draft-jesske-sipping-etsi-ngn-reason-03 clarifies the use of the Reason Header within Responses. because RFC 3326 says:
 
   Initially, the Reason header field defined here appears to be most

   useful for BYE and CANCEL requests, but it can appear in any request

   within a dialog, in any CANCEL request and in any response whose

   status code explicitly allows the presence of this header field.

   Note that the Reason header field is usually not needed in responses

   because the status code and the reason phrase already provide

   sufficient information.

This section is the problem we see and this needs to be clarified.
 
With regard to the TISPAN requirements document, meanwhile the most are fulfilled and many of the services are deployed.
 
With regard to the use of the Reason Header I will stripp of the main Requirement wich fits. This is the interoperability between the PSTN/ISDN network and SIP networks. So the TISPAN requirements document says:
 
REQ-GEN-1:   

   All simulation services must provide interoperability with the  

   PSTN/ISDN. By interoperability we mean that, in the case that a  

   simulation or supplementary service is provided to one of the users  

   when one of the endpoints is located in the PSTN and the other is  

   located in the NGN IMS network, the user should receive the service  

   without any degradation as if the service were provided in the native  

   network.  
 
So the Reason header within responses will help to fulfil this there are certain cause values that are very specific for services. Like the example within the draft pointing to the Closed User Group service.
 
So I will add some requirements to the draft for the certain cases described within the draft.
 
Best Regards
 
Roland

  _____  

Von: [email-masked] [mailto:[email-masked]] Im Auftrag von Mary Barnes
Gesendet: Donnerstag, 26. Juni 2008 18:28
An: Jesske, Roland; [email-masked]; [email-masked]
Betreff: Re: [Sipping] Progress on draft-jesske-sipping-etsi-ngn-reason-03

 

 
Thanks,
Mary. 

  _____  

Dear all,

Thoughts? Comments?
 
Best Regards
 
Roland

Deutsche Telekom AG