Subject: [Sip] Maximum allowed value of Clock rate in SDP ???

From: atul garg <[email-masked]>
Date: Tue, 10 Jun 2008 19:25:05 +0530 (IST)

Hello,

Is there any limitation about the maximum allowed value for the Clock-rate appears in SDP.

a = rtpmap : <payload type> <encoding name> </clock rate>

eg:- a =rtpmap:96 H263/90000

here this 90000, I have seen in real network ..is this value aloowed ???

If anyone also can mention any reference which states about this ,would help me alot.

Regards
shiva

      Unlimited freedom, unlimited storage. Get it now, on http://help.yahoo.com/l/in/yahoo/mail/yahoomail/tools/tools-08.html/

_______________________________________________
Sip mailing list  https://www.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Colin Perkins <[email-masked]>
Date: Wed, 11 Jun 2008 15:09:26 +0100

> here this 90000, I have seen in real network ..is this value  

Yes - this is the clock rate used for most video formats.

> this ,would help me alot.

The legal values for the clock rate for each RTP payload format are  
defined in the payload format RFC. SDP doesn't specify a maximum  
value. The largest clock rate used that I'm aware of is video/ 
smpte292m, which uses a rate of 148500000.

-- 
Colin Perkins
http://csperkins.org/