Subject: [Sip] Call ID doubt in SIP and PTT

From: atul garg <[email-masked]>
Date: Fri, 6 Jun 2008 11:15:59 +0530 (IST)

Hello,

I have two queries  -
 
1) When we say there is a SIP Conference ie more than two parties are in one call session then how call-id are maintained that is Call -id remains same or changes ,more precisely if SIP Client-A want to invite Client-B and C for call ,it sends a SIP INvite to SIP server-A and ask it to call B and C. Now when SIP server will send two Invites ,one to B and second to c will all these Call IDs be different or same.

2) Same is for Push To Talk(PTT) , when there is a chat session established between multiple clients , are the Call id s same or different or else how one can correlate different messages belong to one session ?/ is there any session id or some other unique field present ??

Please also suggest if anyone have some study documnt regarding this.

Thanx
Shiva

      Bring your gang together. Do your thing. Find your favourite Yahoo! group at http://in.promos.yahoo.com/groups/
_______________________________________________
Sip mailing list  https://www.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Dean Willis <[email-masked]>
Date: Sat, 7 Jun 2008 01:59:07 -0500

On Jun 6, 2008, at 12:45 AM, atul garg wrote:

> Hello,
>
> I have two queries  -
>
> 1) When we say there is a SIP Conference ie more than two parties  
> are in one call session then how call-id are maintained that is Call  
> -id remains same or changes ,more precisely if SIP Client-A want to  
> invite Client-B and C for call ,it sends a SIP INvite to SIP server- 
> A and ask it to call B and C. Now when SIP server will send two  
> Invites ,one to B and second to c will all these Call IDs be  
> different or same.
>
> 2) Same is for Push To Talk(PTT) , when there is a chat session  
> established between multiple clients , are the Call id s same or  
> different or else how one can correlate different messages belong to  
> one session ?/ is there any session id or some other unique field  
> present ??
>

Most SIP "conferences" are implemented by conference bridges, which  
are back-to-back user agents. What do they do with call IDs? Whatever  
they want to -- there behavior really isn't specified by IETF.

usually, each "leg" of the bridge will be a separate call with a  
distinct call ID. This makes life much easier.

As I understand OMA POC, this is what happens there -- but you'd have  
to read their spec to be sure. Each "POC controller" (they call it a  
"participating function", IIRC) is basically a B2BUA. So even a  
minimal 2 party POC call has three different call legs, all of which  
probably have (or at least probably should have) different call-IDs.

--
Dean