Subject: [Sip] Regarding provisional responses to SIP requests

From: brijesh nair <[email-masked]>
Date: Thu, 19 Jun 2008 23:10:45 -0700 (PDT)

Hi,

  I have a question regarding provisional responses in SIP. Can the username/displayname part of To/From header be changed in a provisional response to a SIP request ? If so, can you please direct me to a draft/rfc which states this can be done ?

Thanks and Regards,
Brijesh 

_______________________________________________
Sip mailing list  https://www.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "James M. Polk" <[email-masked]>
Date: Fri, 20 Jun 2008 01:55:01 -0500

At 01:10 AM 6/20/2008, brijesh nair wrote:
>Hi,
>
>   I have a question regarding provisional responses in SIP. Can the 
> username/displayname part of To/From header be changed in a 
> provisional response to a SIP request ? If so, can you please 
> direct me to a draft/rfc which states this can be done ?

RFC 4474 (SIP Identity) states the display name in the To header 
cannot be prevented from being changed (therefore shouldn't be 
trusted) in any response.  Does that answer your question?