Subject: Re: [Sip] Draft submission: draft-ietf-sip-199-00

From: "Attila Sipos" <[email-masked]>
Date: Wed, 11 Jun 2008 07:25:14 +0100

( Aren't we at draft 04 now?  )
 
Should the document describe what should
happen if you get a 199 and the 199 refers
the only leg you have?

e.g. 
      UAC               P1                  UAS_2    UAS_3

       --- INVITE ------>
                         --- INVITE (leg 2) ->
                         --- INVITE (leg 3) ---------->
                         <-- 18x (leg 2) -----
       <-- 18x (leg 2) --
                         <-- 4xx (leg 2) -----
       <-- 199 (leg 2) --

 =======================
  what does UAC do now?
 =======================

                         <-- 18x (leg 3) --------------
       <-- 18x (leg 3) --

                         <-- 200 (leg 3) --------------
       <-- 200 (leg 3) --
       --- ACK (leg 3) ->
                         --- ACK (leg 3) ------------->

The UAC would have to act as if it hadn't received
the "18x (leg 2)" and "199 (leg 2)" message.  So it
would be as if it was still be waiting for its first
non-100 response.

This answer is obvious maybe but maybe some explicit
text might be useful otherwise the question might come
up over and over.

Regards,

Attila

_______________________________________________
Sip mailing list  https://www.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Christer Holmberg" <[email-masked]>
Date: Wed, 11 Jun 2008 19:43:03 +0200

Hi, 

>( Aren't we at draft 04 now?  )

No. We are now discussing the SIP WG draft, which has been put together
based on the requirement in the previous individual draft for SIPPING.

>Should the document describe what should happen if you get a 199 and
the 199 refers the only leg you have?
>The UAC would have to act as if it hadn't received the "18x (leg 2)"
and "199 (leg 2)" message.  So it would be as if it >was still be
waiting for its first non-100 response.
>
>This answer is obvious maybe but maybe some explicit text might be
useful otherwise the question might come up over and 
>over.

I can add some words about it.

Thanks for the comment!

Regards,

Christer

Regards,

Attila